Getting Started

Intersoft WebEssentials Documentation
Getting Started
Send comments on this topic.
Intersoft WebEssentials > Getting Started

Glossary Item Box

This section is designated to help you quickly getting started with WebEssentials.NET. You can use all links below to become familiar with WebEssentials.

Installation

The following topics will guide you how to install WebEssentials.NET and what the system requirements you need to have in order to run WebEssentials.NET in your PC.

  • Installation Guide
  • System Requirements
  • Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Deployment

This section will help you to configure and set the application in deploying the project to server. It also provides a Deployment Checklist which contains the essential things you need to manage before proceeding to deployment.

  • Deployment Guide

© 2013 Intersoft Solutions Corp. All Rights Reserved.


Application Wide Configurations

Application Wide Configurations
Send comments on this topic.
Intersoft WebEssentials > Getting Started > Deployment > Application Wide Configurations

Glossary Item Box

One of the unique features introduced since the initial products is the ability to configure specific deployment-related properties via web.config. WebUI.NET Framework further enhanced this capability by adding more properties which are configurable through web.config. Now, it also supports relative application path by using ~ character. The application-wide configurations feature allows centralized configuration for common deployment properties such as ScriptDirectory etc, which dramatically increase effectiveness and efficiency particularly for maintenance purpose.

Following is the list of properties that are configurable through web.config:

  • SharedScriptDirectory
  • ScriptDirectory
  • ImagesDirectory

The settings specified in web.config will only be applied to instances' properties that have Default value (unchanged).
The format of the key used for the configuration is AssemblyFullName.vProductVersion.Properties.

Examples:

The sample configuration in web.config below will change the property value of ScriptDirectory, ImagesDirectory, SharedScriptDirectory and LocalizationDirectory to all WebEssentials V3.0.1000 instances in the application.

<configuration>

<appSettings>

<add key="ISNet.WebUI.WebEssentials.v3_0_1000.ScriptDirectory" value="~/CommonLibrary/WebTreeView/V3_0_1000/" />

<add key="ISNet.WebUI.WebEssentials.v3_0_1000.ImagesDirectory" value="~/CommonLibrary/Images/" />

<add key="ISNet.WebUI.WebEssentials.v3_0_1000.SharedScriptDirectory" value="/CommonLibrary/Shared/" />

</appSettings>

... other settings

</configuration>

Additional application-wide configurations may be available specifically per product. Please refer to the Application-wide Configurations topic in the product's help file.


How-to: Bind DataSource to WebListBox

How-to: Bind DataSource to WebListBox
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > WebListBox How-to Topics > How-to: Bind DataSource to WebListBox

Glossary Item Box

WebListBox is enhanced with data binding to data source control capability.

This topic will show you how to bind DataSource to WebListBox.

To bind DataSource to WebListBox

  1. Right-click on WebListBox control and choose Properties.
  2. Go to DataSourceID and create new data source.
  3. Choose Access Database to use AccessDataSource control.
  4. Choose any database you want to bind, such as Northwind.mdb.
  5. Go to WebListBox's Properties. You need to set some properties in order to bind data from AccessDataSource to WebListBox like following.

  6. Fill in some properties such as NameFieldDataMember, ImageFieldDataMember, TextFieldDataMember, ValueFieldDataMember, TargetURLFieldDataMember and ImageFieldFormatString.

  7. Run the project.

See Also

Tasks
{How-to: Create Unbound WebListBox}
{How-to Topics}

Other Resources
{Data Binding}


Bug Reports

Bug Reports
Send comments on this topic.
Intersoft WebEssentials > Support and Community > Bug Reports

Glossary Item Box

Please submit any bugs or product issues to technical@intersoftpt.com

When submitting the bug report, make sure you have following information to avoid multiple communication roundtrip:

  • Product Edition (if applicable)
  • Full Product Version. Eg: 1.0.1500
  • Browsers (with Full Version, including Service Packs or HotFixes if any)
  • Operating System (with Full Version, including Service Packs or HotFixes if any)
  • Development Environment Products
  • Development Environment Versions
  • Affected Machines: Development, Production Server or Both
  • Monitors: Single or Dual

You also might need to provide issue-specific information such as:

  • Current result/behavior
  • Expected result/behavior
  • Steps to reproduce
  • Working/Compilable Samples


Client-side References

Client-side References
Send comments on this topic.
Intersoft WebEssentials > Client-side References

Glossary Item Box

This section is designated to help user working with client-side references in WebEssentials.

In This Section

WebAccordion

WebAccordionItemSettings

WebAccordionItem

WebAccordionClientSideEvents

WebCalendar

WebCalendarImagesSettings

WebCalendarTextSettings

WebCalendarWorkWeekSettings

WebCalendarHoliday

WebCalendarClientSideEvents

WebExpander

WebExpanderItem

WebExpanderItemSettings

WebExpanderClientSideEvents

WebRating

WebRatingImagesSettings

WebRatingClientSideEvents

WebSlider

WebSliderImagesSettings

WebSliderClientSideEvents

WebProgressBar

WebProgressBarClientSideEvents

WebListBox

WebListBoxItem

WebListBoxLayoutSettings

WebListBoxImagesSettings

WebListBoxClientSideEvents

WebSlidingMenu

WebSlidingMenuLevel

WebSlidingMenuItem

WebSlidingMenuLayoutSettings

WebSlidingMenuTextSettings

WebSlidingMenuImagesSettings

WebSlidingMenuClientSideEvents

WebRibbon

WebRibbonClientSideEvents

WebRibbonResources

WebRibbonApplicationMenuItem

WebRibbonApplicationMenuListItem

WebRibbonContextualTabGroup

WebRibbonTab

WebRibbonGroup

WebRibbonGroupItem

WebRibbonMenuItem

NonContextualTabGroup

RadioButtonGroup


How-to: Configure Navigation in WebListBox

How-to: Configure Navigation in WebListBox
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > WebListBox How-to Topics > How-to: Configure Navigation in WebListBox

Glossary Item Box

WebListBox is able to be used as a navigation control.

This topic will show you how to configure navigation in WebListBox.

To configure navigation

  1. Customize Display Mode.
  2. Set TargetWindow and TargetURL to specify whether URL will be opened in a new window or target IFrame.
  3. Run the project.
You may also set LayoutSettings >> TargetWindow to configure a new window or target when an item is clicked.

See Also

Tasks
{How-to Topics}

Other Resources
{Navigation}


How-to: Configure Navigation in WebSlidingMenu

How-to: Configure Navigation in WebSlidingMenu
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > How-to: Configure Navigation in WebSlidingMenu

Glossary Item Box

WebSlidingMenu can be used as a navigation control.

This topic will show you how to configure navigation in WebSlidingMenu.

To configure Navigation

  1. Right-click on WebSlidingMenu control and choose Properties.
  2. Go to LayoutSettings and set TargetWindow to any url you want.
  3. To set individually, go to Items and click the collection button.
  4. Set TargetURL to any url you want.
  5. Run the project.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Concepts
{Navigation}


How-to: Configure Scroll Mode in WebListBox

How-to: Configure Scroll Mode in WebListBox
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > WebListBox How-to Topics > How-to: Configure Scroll Mode in WebListBox

Glossary Item Box

Scroll mode option is provided to anticipate having many items in WebListBox which exceeds the container's height.

This topic will show you how to configure Scroll mode in WebListBox.

To configure Scroll mode

  1. Right-click on WebListBox control and choose Properties.
  2. Expand LayoutSettings and set ScrollerMode to either Scroller, ScrollBar or None.
  3. Run the project.

See Also

Tasks
{How-to Topics}


How-to: Configure Selection Mode in WebListBox

How-to: Configure Selection Mode in WebListBox
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > WebListBox How-to Topics > How-to: Configure Selection Mode in WebListBox

Glossary Item Box

WebListBox is able to select not only one item, but multiple items at a time.

This topic will show you how to configure Selection Mode in WebListBox.

To configure Selection Mode

  1. Right-click on WebListBox control and choose Properties.
  2. Set SelectionMode to either Single or Multiple.
  3. Run the project. When you use Single mode, you can select only one item at a time. When you use Multiple mode, you can select multiple items.

See Also

Tasks
{How-to Topics}

Other Resources
{Selection Mode}


Copyright Information

Copyright Information
Send comments on this topic.
Intersoft WebEssentials > Licensing > Copyright Information

Glossary Item Box

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Intersoft Solutions Corp.

--------------------------------------------------------------------------------

Intersoft Solutions, Intersoft Solutions Logo, A Better Web Experience, WebUI.NET Framework, WebUI.NET Framework Logo, WebUI Studio.NET Family, WebCombo.NET, WebGrid.NET Enterprise, WebInput.NET, WebUIControls.NET, ISDataSource.NET, WebDesktop.NET, WebTreeView.NET , WebAqua.NET, WebScheduler.NET, Intersoft Presenter are either trademarks or registered trademarks of Intersoft Solutions Corporation.

Copyright © 2000-2009 Intersoft Solutions Corp. All rights reserved.

--------------------------------------------------------------------------------

ActiveX, Internet Explorer, Microsoft, Visual Basic, Visual Basic .NET, Visual C# .NET, Visual C++ .NET, Visual Studio, Visual Studio .NET, Windows, Windows 95, Windows 98, Windows 2000, Windows Millennium Edition, Windows .NET server family, Windows NT, Windows XP and Windows Vista are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

The names of actual companies and products mentioned herein may be the trademarks or registered trademarks of their respective owners.


How-to: Create Unbound WebListBox

How-to: Create Unbound WebListBox
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > WebListBox How-to Topics > How-to: Create Unbound WebListBox

Glossary Item Box

WebListBox supports unbound mode. You simply need to add the item manually.

This topic will show you how to create unbound WebListBox.

To create unbound WebListBox

  1. Right-click on WebListBox control and choose Properties.
  2. Go to Items and click the collection button.
  3. Add an item. You need to set several properties such as DisplayMode, Image, Text and many others.

See Also

Tasks
{How-to: Bind DataSource to WebListBox}
{How-to Topics}

Other Resources
{Data Binding}


How-to: Customize Display Mode

How-to: Customize Display Mode
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > Understanding WebListBox User Interface > Understanding WebListBox User Interface How-to Topics > How-to: Customize Display Mode

Glossary Item Box

WebListBox provides feature to customize the way item will be displayed.

This topic will show you how to customize Display Mode.

To customize Display Mode

  1. Right-click WebListBox control and choose Properties.
  2. Go to Items and click the collection button.
  3. Add an item. Set DisplayMode to either Text, Image, TextAndImage or Default.
  4. If you are using Image or TextAndImage display mode, set Image to the image url you want to display.
  5. Run the project.
You may also use LayoutSettings >> DisplayMode to customize display mode globally.

See Also

Tasks
How-to Topics

Other Resources
Display Mode


How-to: Customize Header Height

How-to: Customize Header Height
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Understanding WebSlidingMenu User Interface > How-to: Customize Header Height

Glossary Item Box

WebSlidingMenu provides feature to adjust header height.

This topic will show you how to customize header height.

To customize header height

  1. Right-click on WebSlidingMenu control and choose Properties.
  2. Go to LayoutSettings and set HeaderHeight to any size you prefer.
  3. To set individual header height, go to Items and click the collection button.
  4. Set HeaderHeight to any size you prefer.
  5. Run the project.

See Also

Tasks
How-to: Customize Item Height
How-to: Show/Hide item next indicator
How-to: Show/Hide item previous indicator
{Walkthrough Topics}
{How-to Topics}


How-to: Customize Image Position

How-to: Customize Image Position
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > Understanding WebListBox User Interface > Understanding WebListBox User Interface How-to Topics > How-to: Customize Image Position

Glossary Item Box

You can adjust image position when TextAndImage display mode is used.

This topic will show you how to customize image position.

To customize image position

  1. Right-click WebListBox control and choose Properties.
  2. Go to Items and click the collection button.
  3. Add an item. Set DisplayMode to TextAndImage and set Image to the image url you want to display.
  4. Set ImagePosition to either AboveText, BelowText, AfterText and BeforeText.
  5. Run the project.
You may also use LayoutSettings >> ImagePosition to customize image position globally.

See Also

Tasks
How-to Topics

Other Resources
Image Position


How-to: Customize Image Size

How-to: Customize Image Size
See Also Send comments on this topic.

Glossary Item Box

You can adjust image size when using Image or TextAndImage display modes.

This topic will show you how to customize image size.

To customize image size

  1. Right-click WebListBox control and choose Properties.
  2. Go to Items and click the collection button.
  3. Add an item. Set DisplayMode to Image or TextAndImage and set Image to the image url you want to display.
  4. Expand ImageSize. Set Width and Height to any adjustment you want.
  5. Run the project.
You may also use LayoutSettings >> ImageSize to customize image size globally.

See Also

Tasks
{How-to Topics}

Other Resources
{Image Size}


How-to: Customize Item Height

How-to: Customize Item Height
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > Understanding WebListBox User Interface > Understanding WebListBox User Interface How-to Topics > How-to: Customize Item Height

Glossary Item Box

You can adjust item height globally and individually.

This topic will show you how to customize item height.

To customize item height

  1. Customize Display Mode.
  2. Set ItemHeight to any adjustment you want.
  3. Run the project.
You may also use LayoutSettings >> ItemHeight to customize item height globally. By default, the height is set to 80 pixels.

See Also

Tasks
How-to Topics

Other Resources
Item Height


How-to: Customize Item Height

How-to: Customize Item Height
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Understanding WebSlidingMenu User Interface > How-to: Customize Item Height

Glossary Item Box

WebSlidingMenu provides feature to adjust item height.

This topic will show you how to customize item height.

To customize item height

  1. Right-click on WebSlidingMenu control and choose Properties.
  2. Go to LayoutSettings and set ItemHeight to any size you prefer.
  3. To set individual item height, go to Items and click the collection button.
  4. Set ItemHeight to any size you prefer.
  5. Run the project.

See Also

Concepts
{Item Height}

Tasks
How-to: Customize Header Height
How-to: Show/Hide item next indicator
How-to: Show/Hide item previous indicator
{Walkthrough Topics}
{How-to Topics}


How-to: Customize WebCalendar WorkWeekSettings

How-to: Customize WebCalendar WorkWeekSettings
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebCalendar > WebCalendar How-to Topics > How-to: Customize WebCalendar WorkWeekSettings

Glossary Item Box

WebCalendar allows user to specify/determine workday through WorkWeekSettings property.

This topic will show you how to customize WebCalendar WorkWeekSettings.

To customize WorkWeekSettings

  1. Right click on WebCalendar control and choose Properties.
  2. Set HighlightMode to Week and WeekViewMode to WorkWeek.
  3. Run the project.

See Also

Tasks
How-to Topics

Other Resources
WorkWeekSettings


How-to: Customize WebSlider range behavior

How-to: Customize WebSlider range behavior
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlider > WebSlider How-to Topics > How-to: Customize WebSlider range behavior

Glossary Item Box

WebSlider provides two interaction mode for range behavior, which are Locked and Push.

This topic will show you how to customize WebSlider range behavior.

To customize WebSlider range behavior

  1. Enable range slider.
  2. Set ThumbsInteractionMode to either Locked or Push.
  3. Run the project.

See Also

Tasks
How-to Topics

Other Resources
Customizable Range Slider Behavior


How-to: Customize WebSlidingMenuHeader content mode from server side

How-to: Customize WebSlidingMenuHeader content mode from server side
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Understanding WebSlidingMenuLevel > How-to: Customize WebSlidingMenuHeader content mode from server side

Glossary Item Box

WebSlidingMenu allows user to customize header content mode from server-side.

This topic will show you how to perform the above scenario.

To customize WebSlidingMenuItem header content mode from server-side

  1. Drag WebSlidingMenu control from toolbox.
  2. Place the following code in server-side:
    C# Copy Code
    WebSlidingMenuLevel lvl = new WebSlidingMenuLevel();
lvl.Name = "Lvl1";
lvl.HeaderContentMode = WebSlidingMenuHeaderContentMode.Text;
lvl.HeaderText = "Level1";
lvl.Level = 0;

WebSlidingMenu1.Levels.Add(lvl);

  3. Run the project.

See Also

Tasks
{How-to: Use WebSlidingMenuHeader with Text content}
{How-to: Use WebSlidingMenuHeader with Inline content}
{Walkthrough Topics}
{How-to Topics}

Concepts
{Various Header's Content Mode}


How-to: Customize WebSlidingMenuItem content mode from server side

How-to: Customize WebSlidingMenuItem content mode from server side
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Understanding WebSlidingMenuItem > How-to: Customize WebSlidingMenuItem content mode from server side

Glossary Item Box

WebSlidingMenu allows user to customize content mode from server-side.

This topic will show you how to perform the above scenario.

To customize WebSlidingMenuItem content mode from server-side

  1. Drag WebSlidingMenu control from toolbox.
  2. Place the following code in server-side:
    C# Copy Code
    WebSlidingMenuItem itm = new WebSlidingMenuItem();
itm.Name = "itm1";
itm.ContentMode = WebSlidingMenuContentMode.Text;
itm.Text = "Item1";

WebSlidingMenu1.Items.Add(itm);

  3. Run the project.

See Also

Tasks
{How-to: Use WebSlidingMenuItem with Text content}
{How-to: Use WebSlidingMenuItem with Inline content}
{How-to: Use WebSlidingMenuItem with IFrame content}
{Walkthrough Topics}
{How-to Topics}

Concepts
{Various Item's Content Mode}


Data Binding

Data Binding
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Data Binding

Glossary Item Box

This section contains information about Data Binding concept and editor.

  • Concept
  • Data Binding Editor

Concept

Sharing a similar concept as a tree view control, WebSlidingMenu displays data in hierarchical mode using XML document. You can use XMLDataSource to connect your XML document to WebSlidingMenu.

WebSlidingMenu only support XMLDataSource control for the binding capability.
When bound, WebSlidingMenuItemBinding objects are added to WebSlidingMenuItemBinding collection to enables you further customize individual item. The settings are automatically mapped to WebSlidingMenuItem property.
There are three key properties that must be defined:
  1. DataMember
    This property specifies the XML element name.

  2. Depth
    Depth property controls the hierarchy level of the item.

  3. MaxDataBindDepth
    This property controls the maximum number of hierarchical level bound to WebSlidingMenu. For example: if the property is set to 2, WebSlidingMenu will only retrieve the root node and its child node. Other nodes are ignored.
You can set either DataMember or Depth, or you can set both of the properties.

Data Bindind Editor

The data binding editor lets you quickly connect your XML document and setup a WebSlidingMenu instance hassle-freely. You can control which field should be bound any many more.

To learn more about Data Binding, see Walkthrough: Performing WebSlidingMenu data binding.


Deploying project that does not use SmartWebResources

Deploying project that does not use SmartWebResources
Send comments on this topic.
Intersoft WebEssentials > Getting Started > Deployment > Deployment Guide > Deploying project that does not use SmartWebResources

Glossary Item Box

General

WebEssentials.NET Enterprise is built on the top of WebUI.NET Framework. It includes the common concept, functionalities and features implemented in the framework level.

WebEssentials Deployment Checklist

  1. RuntimeLicenseKey.
    This is a key required in order to license the components for deployment purpose in production environment.

    Runtime license key is different with design-time license key that you get during purchase.

    Use Deployment Manager to set the project's Web.config. There are 2 important things you need to notice:

    - If you set CommonLibrary folder as IIS Virtual Directory in development machine, you may refer to Using Deployment Manager topic for guidance.

    - If you copy the CommonLibrary folder to the project's directory in development machine, you may refer to Using Deployment Manager topic under Advanced section for guidance.

    Please obtain each licensed component's RuntimeLicenseKey from Intersoft Developer Network under My Component section. You only need to obtain once and reuse it in multiple projects. The login detail is provided in your purchase receipt. If you purchased from our resellers, it may take 24-48 hours for the verification and account creation process.
  2. CommonLibrary
    All subfolders and files inside CommonLibrary folder is required.
  3. Framework Assemblies.
    You are required to copy framework assemblies to your project's bin folder. The framework assemblies can be found in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebUI.NET Framework 3.0\Bin (Default installation directory). The framework assemblies are as following:
    * ISNet.dll
    * ISNet.WebUI.dll
  4. Component Assembly
    Component assembly is required to be copied to your project's bin folder. The component assembly can be found in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebEssentials.NET 1.0\Bin. The component assembly is as following:
    * ISNet.WebUI.WebEssentials.dll

WebEssentials Deployment Guide

  1. If you set CommonLibrary folder as IIS Virtual Directory in development machine
    - XCopy all your required web application files along with the bin folder (i.e. your project's directory) to a destination folder in your web server.
    - XCopy the CommonLibrary folder to your web server. It is recommended to place it under wwwroot folder (usually c:\inetpub\wwwroot). You need to map the destination folder to IIS Virtual Directory with name "CommonLibrary".
  2. If you copy the CommonLibrary folder to the project's directory in development machine
    - XCopy all your required web application files along with the bin and CommonLibrary folders (i.e. your project's directory) to a destination folder in your web server.

    Creating CommonLibrary as IIS Virtual Directory is not required in this case.


Deploying project that uses SmartWebResources

Deploying project that uses SmartWebResources
Send comments on this topic.
Intersoft WebEssentials > Getting Started > Deployment > Deployment Guide > Deploying project that uses SmartWebResources

Glossary Item Box

Intersoft Solutions constantly conduct extensive research and development to deliver new innovations that help developers become more productive by reducing the efforts and overwhelming complexity in both development and deployment stage.

SmartWebResources™ Framework is one of the great technology offered by Intersoft, which is used to eliminate the external physical resources such as scripts, images, etc.

WebEssentials Deployment Checklist

  1. RuntimeLicenseKey
    This is a key required in order to license the components for deployment purpose in production environment.

    Runtime license key is different with design-time license key that you get during purchase. Please obtain each licensed component's RuntimeLicenseKey from Intersoft Developer Network under My Component section. You only need to obtain once and reuse it in multiple projects. The login detail is provided in your purchase receipt. If you purchased from our resellers, it may take 24-48 hours for the verification and account creation process.
  2. Resources Assembly
    Ensure that you have copied the resources assemblies to your project's bin folder. The resources assembly can be found in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebEssentials.NET 1.0\Bin. The resources assemblies are:
    * ISNet.WebUI.WebEssentials.Resources.dll
  3. Framework Assemblies
    You are required to copy framework assemblies to your project's bin folder. The framework assemblies can be found in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebUI.NET Framework 3.0\Bin (Default installation directory). The framework assemblies are:
    * ISNet.dll
    * ISNet.WebUI.dll
  4. Component Assembly
    Component assembly is required to be copied to your project's bin folder. The component assembly can be found in C:\Program Files\Intersoft Solutions\WebUI Studio for ASP.NET\WebEssentials.NET 1.0\Bin. The component assembly is:
    * ISNet.WebUI.WebEssentials.dll

Deploying project that uses SmartWebResources?

Here are step-by-step instructions to deploy the project using SmartWebResources?:

  1. Before deploying the project, you have to configure SmartWebResources after you created a new web application. Click here for guidance.
  2. Next, you need to use Deployment Manager in order to set the web.config of your web application, such as defining Runtime License key. Please read Using Deployment Manager for more information.
  3. Finally, you simply need to XCopy all required web application files along with the bin folder (i.e. your project's directory) to a destination folder in your web server.


Deployment

Deployment
Send comments on this topic.
Intersoft WebEssentials > Getting Started > Deployment

Glossary Item Box

This section contains information on configuring the application and guiding user with a step-by-step Checklist instructions for deployment purposes.

In This Section

Deployment Guide
Information about Deployment Checklist that will list all the important tasks you need to do before deploying the project.

Application Wide Configurations
Read about the WebGrid's ability to configure deployment-related properties via web.config, such as ScriptDirectory and many others.


Deployment Guide

Deployment Guide
Send comments on this topic.
Intersoft WebEssentials > Getting Started > Deployment > Deployment Guide

Glossary Item Box

This section continues to guide you on how to deploy the project by using Deployment Manager and SmartWebResources?.

In This Section

Using Deployment Manager
Learn how to use deployment manager to set the web.config.

Deploying project that uses SmartWebResources™
Information about deploying project using SmartWebResources™.

Deploying project that does not use SmartWebResources™
Information about deploying project without using SmartWebResources™. In other words, you need to copy CommonLibrary, project's directory and assemblies.


How-to: Enable AutoPostBack in WebListBox

How-to: Enable AutoPostBack in WebListBox
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > WebListBox How-to Topics > How-to: Enable AutoPostBack in WebListBox

Glossary Item Box

WebListBox has built-in AutoPostBack property for client-server communication.

This topic will show how to enable AutoPostBack in WebListBox.

To enable AutoPostBack

  1. Right-click on WebListBox control and choose Properties.
  2. Set AutoPostBack to True and PostBackMode to either FullPostBack or FlyPostBack.
  3. Run the project.

See Also

Tasks
{How-to: Get Selected Values when AutoPostBack is enabled}
{How-to Topics}

Other Resources
{PostBack}


How to: Enable HTML5 Rendering Mode

How to: Enable HTML5 Rendering Mode
Send comments on this topic.
Intersoft WebEssentials > What's New in WebEssentials > How to: Enable HTML5 Rendering Mode

Glossary Item Box

This topic explains how to configure WebTextEditor to emit HTML5 compliance output.

Configure Doc Type

Each doctype declaration in HTML specification produces different results and behaviors, mostly in the layout and rendering aspects. WebEssentials supports most commonly used doctype and automatically adjust the behaviors and rendering results by detecting the doctype declaration of the HTML page.

In the latest version, WebEssentials has been significantly enhanced to deliver consistent behaviors and layout in HTML5 pages. All features should work exactly as in other doctype.

To enable HTML5 support in WebEssentials, make sure you have configured the HTML pages to use the proper doctype. The standard doctype for HTML5 is <!DOCTYPE html>.

The following code example shows how to use WebEssentials in a simple WebForm using HTML5 doctype.

ASPX Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="Default" %>
<%@ Register Assembly="ISNet.WebUI.WebEssentials" Namespace="ISNet.WebUI.WebEssentials" TagPrefix="ISWebEssentials" %>

<!DOCTYPE html>
<html>
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
    <div>
         <ISWebEssentials:WebRibbon  ID="WebRibbon1" runat="server">
         </ISWebEssentials:WebRibbon >
    </div>
    </form>
</body>
</html>

Note that the xmlns attribute is no longer necessary to be defined in the <html> tag. If you upgraded your existing pages, make sure the xmlns attribute is removed from the <html> tag.

Also, to enable percentage height in HTML5, you must define its height in body and html element. Here's the example

ASPX Copy Code
<head runat="server">
    <title></title>
    <style type="text/css">
    html, body
    {
        height: 100%;
        width: 100%;
        margin: 0;
        padding: 0;
    }
    </style>
</head>

In HTML5, height of an element is refer to its parent's height so this is necessary to define its parent element.

Configure Rendering Mode

To provide the best HTML5 support, WebEssentials needs to adjust several features that are commonly processed in the server-side such as markup rendering and AJAX callback response. Unfortunately, the HTML5 doctype cannot be automatically detected by the server-side browser capability. As such, WebEssentials introduces a new property called RenderingMode which you must set explicitly in order to activate HTML5 compliance output.

You can set the rendering mode in a WebEssentials instance individually by setting the RenderingMode property to HTML5 value, which is shown in the example below.

ASPX Copy Code
<ISWebEssentials:WebRibbon ID="WebRibbon1" runat="server" RenderingMode="HTML5">
</ISWebEssentials:WebRibbon>

Alternatively, you can also apply the rendering mode globally through the application-wide configuration, see the following example.

Web.config Copy Code
<add key="ISNet.WebUI.WebEssentials.v3_0_1000.RenderingMode" value="HTML5"/>
If your project is exclusively targeting HTML5, it's recommended to use application-wide configuration to apply the rendering mode to all WebEssentials instances in the project.

For more information about application-wide settings in WebEssentials, see Application Wide Configurations.


How-to: Enable keyboard support in WebCalendar

How-to: Enable keyboard support in WebCalendar
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebCalendar > WebCalendar How-to Topics > How-to: Enable keyboard support in WebCalendar

Glossary Item Box

The strong keyboard support gives users an effortless navigation when working with dates.

This topic will show you how to enable keyboard support in WebCalendar.

To enable keyboard support

  1. Right-click on WebCalendar control and choose Properties.
  2. Set EnableKeyboardSupport to True.

See Also

Tasks
How-to Topics

Other Resources
Strong keyboard support


How-to: Enable multiple selection in WebCalendar

How-to: Enable multiple selection in WebCalendar
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebCalendar > WebCalendar How-to Topics > How-to: Enable multiple selection in WebCalendar

Glossary Item Box

WebCalendar offers multiple selections for selecting multiple dates.

This topic will show you how to enable multiple selection in WebCalendar.

To enable multiple selection

  1. Right-click on WebCalendar control and choose Properties.
  2. Set ViewMode to Month and HighlightMode to Day.
  3. To enable multiple selection, set EnableMultipleSelection to True.
  4. To enable multiple selection using keyboard, set EnableKeyboardSupport to True.
  5. Run the project. Click and drag using mouse to select a range of dates, use the CTRL, SHIFT, or CTRL + SHIFT for more advanced selections.
Multiple Selection only works when ViewMode is set to Month.

See Also

Tasks
How-to Topics

Other Resources
Multiple selection


How-to: Enable/Disable highlights today date

How-to: Enable/Disable highlights today date
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebCalendar > WebCalendar How-to Topics > How-to: Enable/Disable highlights today date

Glossary Item Box

WebCalendar provides feature to highlight today's date.

This topic will show you how to enable/disable highlight today's date.

To enable/disable highlight today date

  1. Right-click on WebCalendar and choose Properties.
  2. Set HighlightTodayDate to True.
  3. Run the project. This property is only applicable when ViewMode is set to Month.
Today style is rendered based on TodayStyle property.

See Also

Tasks
How-to Topics

Other Resources
HighlightTodayDate


How-to: Enable/Disable range slider

How-to: Enable/Disable range slider
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlider > WebSlider How-to Topics > How-to: Enable/Disable range slider

Glossary Item Box

Range Slider is a unique feature for selecting a range of value, instead of a single value.

This topic will show you how to enable/disable range slider.

To enable/disable range slider

  1. Right-click on WebSlider control and choose Properties.
  2. Set EnableRange to True.
  3. You can customize StartValue and EndValue properties to show the range value.
  4. Run the project.

See Also

Tasks
How-to Topics

Other Resources
Supports Range Slider


How-to: Enable/Disable week number in WebCalendar

How-to: Enable/Disable week number in WebCalendar
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebCalendar > WebCalendar How-to Topics > How-to: Enable/Disable week number in WebCalendar

Glossary Item Box

WebCalendar provides feature to show week number in calendar.

This topic will show you how to enable/disable week number in WebCalendar.

To enable/disable week number

  1. Right-click on WebCalendar control and choose Properties.
  2. Set ShowWeekNumbers to True.
  3. Run the project. The week number depends on the FirstWeekOfYear property. ShowWeekNumbers property is only applicable when ViewMode is set to Month.

See Also

Tasks
How-to Topics

Other Resources
WorkWeekSettings
FirstDayOfWeek
FirstWeekOfYear
HighlightTodayDate


How-to: Get Selected Value when AutoPostBack is enabled

How-to: Get Selected Value when AutoPostBack is enabled
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > WebListBox How-to Topics > How-to: Get Selected Value when AutoPostBack is enabled

Glossary Item Box

When postback is enabled, OnSelectedItemChanged server-side event is raised. This enable you to obtain the selected items' index via the event arguments.

This topic will show you how to get selected value when AutoPostBack is enabled.

To get selected value

  1. Enable AutoPostBack.
  2. Use the following code in OnSelectedItemChanged server-side event to obtain the selected value.
    C# Copy Code
    protected void WebListBox1_SelectedItemChanged(object sender, WebListBoxSelectedItemChangedEventArgs e)
{
   int index = e.SelectedIndex;
   WebListBoxItem item = WebListBox1.Items[index] as WebListBoxItem;
   SetData(int.Parse(item.Value));
}

See Also

Tasks
{How-to: Enable AutoPostBack in WebListBox}
{How-to Topics}

Other Resources
{PostBack}


How-to: Get Selected Values on Button Click

How-to: Get Selected Values on Button Click
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > WebListBox How-to Topics > How-to: Get Selected Values on Button Click

Glossary Item Box

WebListBox provides property which allows user to get the selected values in client-side.

This topic will show you how to get selected values on button click.

To get selected values on button click

  1. Set selected items on load.
  2. Create GetValues() function to get the selected values.
    JavaScript Copy Code
    function GetValues()
{
   wlb = ISGetObject("WebListBox1");

   for (var i = 0; i < wlb.Values.length; i++)
   {
      alert(wlb.Values[i]);
   }
}

  3. Invoke GetValues() function in button onclick.

    <input type="button" id="wlbButton" value="Get Values" onclick="GetValues()" />

  4. Run the project. Click the button to get the selected values.

GetValues client-side API will return the selected values if the Value property in the items are not empty.

See Also

Tasks
{How-to Topics}

Other Resources
{Get Selected Value}


How-to Topics

How-to Topics
See Also Send comments on this topic.
Intersoft WebEssentials > How-to Topics

Glossary Item Box

The following list of How-to topics describes how to implement various features and enhancements in WebEssentials.

WebAccordion - Inline and IFrame content

The topics in this category provide direct instructions on how to use WebAccordion with Inline and IFrame content.

  • How-to: Use WebAccordion with Inline content
  • How-to: Use WebAccordion with IFrame content

WebAccordion - Flexible layout and behavioral customization

The topics in this category provide direct instructions on how to set/change WebAccordion's expand direction, expand index and interaction mode.

  • How-to: Set/Change WebAccordion's ExpandDirection
  • How-to: Set/Change WebAccordion's ExpandIndex
  • How-to: Set/Change WebAccordion InteractionMode

WebAccordion - Global and individual item settings

The topics in this category provide direct instructions on how to set WebAccordion's item using general/specific settings.

  • How-to: Set WebACcordion's Item through general settings
  • How-to: Set WebAccordion's item through specific settings

WebCalendar - View Customization

The topic in this category provides a direct instruction on how to set WebCalendar ViewMode.

  • How-to: Set/Change WebCalendar ViewMode

WebCalendar

The topics in this category provide direct instructions on how to set/change WebCalendar HighlightMode and WeekViewMode.

  • How-to: Set/Change WebCalendar HighlightMode
  • How-to: Set/Change WebCalendar WeekViewMode

WebCalendar - Behavioral Configuration - WorkWeekSettings

The topic in this category provides a direct instruction on how to customize WebCalendar WorkWeekSettings.

  • How-to: Customize WebCalendar WorkWeekSettings

WebCalendar - Behavioral Configuration - FirstDayOfWeek

The topic in this category provides a direct instruction on how to set/change WebCalendar FirstDayOfWeek.

  • How-to: Set/Change WebCalendar FirstDayOfWeek

WebCalendar - Behavioral Configuration - FirstWeekOfYear

The topic in this category provides a direct instruction on how to set/change WebCalendar FirstWeekOfYear.

  • How-to: Set/Change WebCalendar FirstWeekOfYear

WebCalendar - Behavioral Configuration - ShowWeekNumber

The topic in this category provides a direct instruction on how to enable/disable week number in WebCalendar.

  • How-to: Enable/Disable week number in WebCalendar

WebCalendar - Behavioral Configuration - HighlightTodayDate

The topic in this category provides a direct instruction on how to enable/disable highlights today date.

  • How-to: Enable/Disable highlights today date

WebCalendar - Supports holiday

The topic in this category provides a direct instruction on how to specify holiday(s) in WebCalendar.

  • How-to: Specify Holiday(s) in WebCalendar

WebCalendar - Localization and various text settings

The topic in this category provides a direct instruction on how to specify localization in WebCalendar.

  • How-to: Specify localization in WebCalendar

WebCalendar - Multiple Selection

The topic in this category provides a direct instruction on how to enable multiple selection.

  • How-to: Enable multiple selection in WebCalendar

WebCalendar - Integrated to FullPostback and FlyPostback (or AJAX)

The topics in this category provide direct instructions on how to perform FullPostback and FlyPostback in WebCalendar.

  • How-to: Perform FullPostback in WebCalendar
  • How-to: Perform FlyPostback in WebCalendar

WebCalendar - Strong Keyboard Support

The topic in this category provides a direct instruction on how to enable keyboard support in WebCalendar.

  • How-to: Enable keyboard support in WebCalendar

WebRating - Flexible Orientation and Direction

The topics in this category provide direct instructions on how to set/change WebRating's orientation and direction.

  • How-to: Set/Change WebRating Orientation
  • How-to: Set/Change WebRating Direction

WebRating - Flexible Number of Item

The topic in this category provides a direct instruction on how to set/change WebRating item number.

  • How-to: Set/Change WebRating Item number

WebRating - Customizable Rating Precision

The topic in this category provides a direct instruction on how to set/change WebRating precision behavior.

  • How-to: Set/Change WebRating precision behavior

WebRating - Integrated with FullPostback and FlyPostback (or AJAX)

The topics in this category provide direct instructions on how to perform FullPostback and FlyPostback in WebRating.

  • How-to: Perform FullPostback in WebRating
  • How-to: Perform FlyPostback in WebRating

WebSlider - Flexible Layout and Behavior Customization

The topics in this category provide direct instructions on how to set/change WebSlider Orientation and Direction.

  • How-to: Set/Change WebSlider Orientation
  • How-to: Set/Change WebSlider Direction

WebSlider - Item Alignment

The topic in this category provides a direct instruction on how to set/change item label alignment in WebSlider.

  • How-to: Set/Change Item label alignment in WebSlider

WebSlider - Custom WebSlider Item

The topic in this category provides a direct instruction on how to specify custom WebSlider item.

  • How-to: Specify custom WebSlider item

WebSlider - Supports Range Slider

The topic in this category provides a direct instruction on how to enable/disable range slider.

  • How-to: Enable/Disable range slider

WebSlider - Customizable Range Slider Behavior

The topic in this category provides a direct instruction on how to customize WebSlider range behavior.

  • How-to: Customize WebSlider range behavior

WebExpander - Flexible View Customization

The topic in this category provides a direct instruction on how to modify expand direction.

  • How-to: Modify WebExpander Expand Direction

WebExpander - Flexible Behavior Customization

The topic in this category provides a direct instruction on how to modify WebExpander mode.

  • How-to: Modify WebExpander Mode

WebExpander - Rich Content Support

The topics in this category provide direct instructions on how to use WebExpander with Inline and IFrame content.

  • How-to: Use WebExpander with Inline content
  • How-to: Use WebExpander with IFrame content

WebProgressBar - Flexible View Customization

The topic in this category provides a direct instruction on how to modify WebProgressBar orientation.

  • How-to: Modify WebProgressBar orientation

WebProgressBar - Flexible Behavior Customization

The topic in this category provides a direct instruction on how to modify WebProgressBar mode.

  • How-to: Modify WebProgressBar mode

WebProgressBar - Appearance and Styles

The topics in this category provide direct instructions on how to modify WebProgressBar appearance.

  • How-to: Modify WebProgressBar rounded corner
  • How-to: Modify WebProgressBar indeterminate animation

WebListBox - Display Mode

The topic in this category provides a direct instruction on how to customize display mode.

  • How-to: Customize Display Mode

WebListBox - Image Position

The topic in this category provides a direct instruction on how to customize image position.

  • How-to: Customize Image Position

WebListBox - Image Size

The topic in this category provides a direct instruction on how to customize image size.

  • How-to: Customize Image Size

WebListBox - Item Height

The topic in this category provides a direct instruction on how to customize item height.

  • How-to: Customize Item Height

WebListBox - Item Style

The topic in this category provides a direct instruction on how to specify custom item styles.

  • How-to: Specify Custom Item Styles for Specific Items

WebListBox - Scroll Mode

The topic in this category provides a direct instruction on how to configure scroll mode.

  • How-to: Configure Scroll Mode in WebListBox

WebListBox - Selection Mode

The topic in this category provides a direct instruction on how to configure selection mode.

  • How-to: Configure Selection Mode in WebListBox

WebListBox - Set Selected Item(s) On Load

The topic in this category provides a direct instruction on how to set selected item on load.

  • How-to: Set Selected Item on Load

WebListBox - Get Selected Value

The topic in this category provides a direct instruction on how to get selected value.

  • How-to: Get Selected Values on Button Click

WebListBox - PostBack

The topics in this category provide direct instructions on how to enable AutoPostBack and get selected values.

  • How-to: Enable AutoPostBack in WebListBox
  • How-to: Get Selected Values when AutoPostBack is enabled

WebListBox - Navigation

The topic in this category provides a direct instruction on how to configure navigation.

  • How-to: Configure Navigation in WebListBox

WebListBox - Data Binding

The topics in this category provide direct instructions on how to bind DataSource to WebListBox and create unbound.

  • How-to: Bind DataSource to WebListBox
  • How-to: Create Unbound WebListBox

WebSlidingMenu - User Interface

The topics in this category provides direct instructions on how to customize user interface elements.

  • How-to: Customize Item Height
  • How-to: Customize Header Height
  • How-to: Show/Hide item next indicator
  • How-to: Show/Hide item previous indicator
  • How-to: Specify Custom Item Styles

WebSlidingMenuItem - Various Item's Content Mode

The topics in this category provides direct instructions on how to customize WebSlidingMenuItem.

  • How-to: Use WebSlidingMenuItem with Text content
  • How-to: Use WebSlidingMenuItem with Inline content
  • How-to: Use WebSlidingMenuItem with IFrame content
  • How-to: Customize WebSlidingMenuItem content mode from server side

WebSlidingMenuItem - Navigation

The topic in this category provides a direct instruction on how to configure navigation.

  • How-to: Configure Navigation in WebSlidingMenu

WebSlidingMenuLevel - Various Header's Content Mode

The topics in this category provide direct instructions on how to customize WebSlidingMenuHeader.

  • How-to: Use WebSlidingMenuHeader with Text Content
  • How-to: Use WebSlidingMenuHeader with Inline Content
  • How-to: Customize WebSlidingMenuHeader content mode from server side

WebSlidingMenuLevel - Adjustable Header Level

The topic in this category provides a direct instruction on how to use WebSlidingMenuHeader with level properties.

  • How-to: Use WebSlidingMenuHeader with Level Properties

WebSlidingMenu - Powerful Load-On-Demand

The topic in this category provides a direct instruction on how to use LoadOnDemand.

  • How-to: Use LoadOnDemand to retrieve parent and child in WebSlidingMenu

See Also

Other Resources
{Walkthrough Topics}


Installation

Installation
Send comments on this topic.
Intersoft WebEssentials > Getting Started > Installation

Glossary Item Box

This section contains information on installing WebEssentials and specifying the system requirements needed by the component.

In This Section

Installation Guide
Information about installing WebEssentials on your PC.

System Requirements
Read about the Windows version, Visual Studio application, WebUI.NET Framework and other software requirements for installing WebEssentials.

Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
Informatin about installing WebEssential control to Visual STudio toolbox using Toolbox Utility tool.


Installation Guide

Installation Guide
See Also Send comments on this topic.
Intersoft WebEssentials > Getting Started > Installation > Installation Guide

Glossary Item Box

Installation Requirement

For system requirement, please see the System Requirements section.

Installing WebEssentials

Intersoft has released the new setup installer which includes WebUI Framework 3, WebGrid Enterprise 7, WebCombo 4, WebInput 4, WebDesktop 3, WebTreeView, ISDataSource, WebScheduler 3, WebAqua 2, WebEssentials, WebTextEditor and ClientUI components.

Here are the step-by-step instructions to install WebEssentials:

  1. Double click on the "intersoft webui studio 2010 r1.exe" icon to start the installation process. Read the instructions, and click next.

  2. Please read the license agreement. You must accept the terms in the license agreement in order to install WebEssentials.

  3. Fill in your details such as User Name and Organization. Click Next to proceed.

  4. You can select the product edition and setup type that you would like to install and perform.

    The product contains three editions such as WebUI Studio for ASP.NET, WebUI Studio for Silverlight and WebUI Studio for WPF.

  5. You can select the target environment for the samples, either Microsoft Visual Studio 2010 or Microsoft Visual Studio 2008 or Microsoft Visual Studio 2010.

  6. You can also customize the Start Menu group and choose to create shortcuts for all users or just for yourself.

  7. Click Next to proceed with the installation process.

  8. The wizard is installing WebUI Studio 2010 R1.

  9. A window showing the installation progress appears. It will list the status of components that are being installed.

  10. After the installation process has been finished, you will see a confirmation window. Click Finish to close the window. At this rate, you have successfully installed the Intersoft WebUI Studio 2010 RC.

  11. To install the full version of WebEssentials, proceed by using License Manager that can be triggered from Start menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> License Manager.

  12. Intersoft License Manager window will appear. Click "Add License" to proceed to the next step.

  13. Now, Select a product from the combo box. In this case, select WebEssentials.NET Version 1.0.1000 and enter the license according to the component.

  14. Click Add and it will automatically check the license with the server through internet connection. If it is correct, then you have successfully installed the full version of WebEssentials.

See Also

Other Resources
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
System Requirements


Assembly Overview

ISNet.WebUI.WebEssentials Assembly
See Also Send comments on this topic.

Glossary Item Box

Namespaces

Namespace | Description
ISNet.WebUI.WebEssentials |


Getting Started - Intersoft WebEssentials Documentation

Getting Started
Send comments on this topic.

Glossary Item Box


Introduction - Intersoft WebEssentials Documentation

Introduction
Send comments on this topic.

Glossary Item Box


PostBackMode Enumeration

[image]
Intersoft WebEssentials Documentation
PostBackMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : PostBackMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PostBackMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PostBackMode
C#
public enum PostBackMode : System.Enum
Delphi
public enum PostBackMode = class(System.Enum)
JScript
public enum PostBackMode extends System.Enum
Managed Extensions for C++
__value public enum PostBackMode : public System.Enum
C++/CLI
public enum class PostBackMode : public System.Enum

Members

Member | Description
FlyPostBack |
FullPostBack |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.PostBackMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebAccordion Class

[image]
Intersoft WebEssentials Documentation
WebAccordion Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordion Class

Glossary Item Box

Intersoft WebAccordion.

Object Model

WebAccordion Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.ToolboxDataAttribute("<{0}:WebAccordion runat=server Width="300px" Height="30px"></{0}:WebAccordion>")>
<ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebAccordion.js", Type=XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebAccordionDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.SerializableAttribute()>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebAccordion
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
C#
[System.Web.UI.ToolboxDataAttribute("<{0}:WebAccordion runat=server Width="300px" Height="30px"></{0}:WebAccordion>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebAccordion.js", Type=XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebAccordionDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebAccordion : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync
Delphi
public class WebAccordion = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync)
JScript
System.Web.UI.ToolboxDataAttribute("<{0}:WebAccordion runat=server Width="300px" Height="30px"></{0}:WebAccordion>")
ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebAccordion.js", Type=XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebAccordionDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.SerializableAttribute()
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebAccordion extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync
Managed Extensions for C++
[System.Web.UI.ToolboxDataAttribute("<{0}:WebAccordion runat=server Width="300px" Height="30px"></{0}:WebAccordion>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebAccordion.js", Type=XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebAccordionDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebAccordion : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync
C++/CLI
[System.Web.UI.ToolboxDataAttribute("<{0}:WebAccordion runat=server Width="300px" Height="30px"></{0}:WebAccordion>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebAccordion.js", Type=XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebAccordionDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebAccordion : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebEssentials.WebAccordion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Members
ISNet.WebUI.WebEssentials Namespace


WebAccordion Class Events

[image]
Intersoft WebEssentials Documentation
WebAccordion Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordion Class

Glossary Item Box

For a list of all members of this type, see WebAccordion members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebAccordion Class
ISNet.WebUI.WebEssentials Namespace


WebAccordion Class Members

[image]
Intersoft WebEssentials Documentation
WebAccordion Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordion Class

Glossary Item Box

The following tables list the members exposed by WebAccordion.

Public Constructors

 | Name | Description
Public Constructor | WebAccordion Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebAccordion.
Public Property | ContentHeight | Specifies the content height of WebAccordion's item.
Public Property | ContentWidth | Specifies the content width of WebAccordion's item.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | DisplayLatency | Specifies the display latency of WebAccordion with MouseOveer interaction mode.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ExpandDirection | Specifies WebAccordion expand direction.
Public Property | ExpandIndex | Specifies the expand index of WebAccordion.
Public Property | FrameStyle | Contains interactive style for Frame.
Public Property | HeaderHeight | Specifies the header height of WebAccordion's item.
Public Property | HeaderWidth | Specifies the header width of WebAccordion's item.
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | ImagesSettings | Provides the settings that control the images in WebAccordion.
Public Property | InteractionMode | Specifies WebAccordion interaction mode.
Public Property | ItemContentPanelStyle | Contains interactive style for item content panel.
Public Property | ItemContentStyle | Contains interactive style for item content.
Public Property | ItemHeaderContentStyle | Contains interactive style for item header content.
Public Property | ItemHeaderFrameStyle | Contains interactive style for item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.
Public Property | ItemHeaderLeftRightStyle | Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Left or Right).
Public Property | ItemHeaderStyle | Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Top or Down).
Public Property | Items | The item collection used by WebAccordion.
Public Property | ItemSettings | Provides the settings that control the default WebAccordion's item settings.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SelectedItemHeaderFrameStyle | Contains interactive style for selected item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseDefaultStyle | Determines whether or not WebAccordion is using default style.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | Overridden.
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebAccordion Class
ISNet.WebUI.WebEssentials Namespace


WebAccordion Class Methods

[image]
Intersoft WebEssentials Documentation
WebAccordion Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordion Class

Glossary Item Box

For a list of all members of this type, see WebAccordion members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

See Also

Reference

WebAccordion Class
ISNet.WebUI.WebEssentials Namespace


WebAccordion Class Properties

[image]
Intersoft WebEssentials Documentation
WebAccordion Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordion Class

Glossary Item Box

For a list of all members of this type, see WebAccordion members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebAccordion.
Public Property | ContentHeight | Specifies the content height of WebAccordion's item.
Public Property | ContentWidth | Specifies the content width of WebAccordion's item.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | DisplayLatency | Specifies the display latency of WebAccordion with MouseOveer interaction mode.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ExpandDirection | Specifies WebAccordion expand direction.
Public Property | ExpandIndex | Specifies the expand index of WebAccordion.
Public Property | FrameStyle | Contains interactive style for Frame.
Public Property | HeaderHeight | Specifies the header height of WebAccordion's item.
Public Property | HeaderWidth | Specifies the header width of WebAccordion's item.
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | ImagesSettings | Provides the settings that control the images in WebAccordion.
Public Property | InteractionMode | Specifies WebAccordion interaction mode.
Public Property | ItemContentPanelStyle | Contains interactive style for item content panel.
Public Property | ItemContentStyle | Contains interactive style for item content.
Public Property | ItemHeaderContentStyle | Contains interactive style for item header content.
Public Property | ItemHeaderFrameStyle | Contains interactive style for item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.
Public Property | ItemHeaderLeftRightStyle | Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Left or Right).
Public Property | ItemHeaderStyle | Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Top or Down).
Public Property | Items | The item collection used by WebAccordion.
Public Property | ItemSettings | Provides the settings that control the default WebAccordion's item settings.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SelectedItemHeaderFrameStyle | Contains interactive style for selected item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseDefaultStyle | Determines whether or not WebAccordion is using default style.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | Overridden.
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebAccordion Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionClientSideEvents Class

[image]
Intersoft WebEssentials Documentation
WebAccordionClientSideEvents Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionClientSideEvents Class

Glossary Item Box

A collection of WebAccordion's client side events.

Object Model

WebAccordionClientSideEvents Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebAccordionClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebAccordionClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebAccordionClientSideEvents = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebAccordionClientSideEvents extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebAccordionClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebAccordionClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebAccordionClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Members
ISNet.WebUI.WebEssentials Namespace


WebAccordionClientSideEvents Class Members

[image]
Intersoft WebEssentials Documentation
WebAccordionClientSideEvents Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebAccordionClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebAccordionClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnAfterExpandCollapse | Gets or sets the event handler after WebAccordion's Item is expanded and collapsed.
Public Property | OnBeforeExpandCollapse | Gets or sets the event handler before WebAccordion's Item is expanded and collapsed.
Public Property | OnClick | Gets or sets the event handler that will be invoked when WebAccordion is clicked.
Public Property | OnInitialize | Gets or sets the event handler that will be invoked when WebAccordion is initialized.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebAccordionClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionClientSideEvents Class Methods

[image]
Intersoft WebEssentials Documentation
WebAccordionClientSideEvents Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebAccordionClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebAccordionClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionClientSideEvents Class Properties

[image]
Intersoft WebEssentials Documentation
WebAccordionClientSideEvents Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebAccordionClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnAfterExpandCollapse | Gets or sets the event handler after WebAccordion's Item is expanded and collapsed.
Public Property | OnBeforeExpandCollapse | Gets or sets the event handler before WebAccordion's Item is expanded and collapsed.
Public Property | OnClick | Gets or sets the event handler that will be invoked when WebAccordion is clicked.
Public Property | OnInitialize | Gets or sets the event handler that will be invoked when WebAccordion is initialized.
Top

See Also

Reference

WebAccordionClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebAccordionClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : WebAccordionClientSideEvents Constructor

Glossary Item Box

Overload List

Overload | Description
WebAccordionClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


WebAccordionClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebAccordionClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : WebAccordionClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebAccordionClientSideEvents()
C#
public WebAccordionClientSideEvents()
Delphi
public WebAccordionClientSideEvents();
JScript
public function WebAccordionClientSideEvents();
Managed Extensions for C++
public: WebAccordionClientSideEvents();
C++/CLI
public:
WebAccordionClientSideEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


OnAfterExpandCollapse Property

[image]
Intersoft WebEssentials Documentation
OnAfterExpandCollapse Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : OnAfterExpandCollapse Property

Glossary Item Box

Gets or sets the event handler after WebAccordion's Item is expanded and collapsed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, prevItemIndex, currItemIndex")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after WebAccordion's Item is expanded and collapsed.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnAfterExpandCollapse As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents
Dim value As System.String

instance.OnAfterExpandCollapse = value

value = instance.OnAfterExpandCollapse
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, prevItemIndex, currItemIndex")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after WebAccordion's Item is expanded and collapsed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnAfterExpandCollapse {get; set;}
Delphi
public read-write property OnAfterExpandCollapse: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, prevItemIndex, currItemIndex")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after WebAccordion's Item is expanded and collapsed.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnAfterExpandCollapse : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, prevItemIndex, currItemIndex")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after WebAccordion's Item is expanded and collapsed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnAfterExpandCollapse();
public: __property void set_OnAfterExpandCollapse(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, prevItemIndex, currItemIndex")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after WebAccordion's Item is expanded and collapsed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnAfterExpandCollapse {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


OnBeforeExpandCollapse Property

[image]
Intersoft WebEssentials Documentation
OnBeforeExpandCollapse Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : OnBeforeExpandCollapse Property

Glossary Item Box

Gets or sets the event handler before WebAccordion's Item is expanded and collapsed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, currItemIndex, nextItemIndex")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before WebAccordion's Item is expanded and collapsed.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnBeforeExpandCollapse As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents
Dim value As System.String

instance.OnBeforeExpandCollapse = value

value = instance.OnBeforeExpandCollapse
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, currItemIndex, nextItemIndex")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before WebAccordion's Item is expanded and collapsed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnBeforeExpandCollapse {get; set;}
Delphi
public read-write property OnBeforeExpandCollapse: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, currItemIndex, nextItemIndex")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before WebAccordion's Item is expanded and collapsed.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnBeforeExpandCollapse : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, currItemIndex, nextItemIndex")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before WebAccordion's Item is expanded and collapsed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnBeforeExpandCollapse();
public: __property void set_OnBeforeExpandCollapse(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, currItemIndex, nextItemIndex")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before WebAccordion's Item is expanded and collapsed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnBeforeExpandCollapse {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


OnClick Property

[image]
Intersoft WebEssentials Documentation
OnClick Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : OnClick Property

Glossary Item Box

Gets or sets the event handler that will be invoked when WebAccordion is clicked.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, itemIndex")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebAccordion is clicked.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnClick As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents
Dim value As System.String

instance.OnClick = value

value = instance.OnClick
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, itemIndex")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebAccordion is clicked.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnClick {get; set;}
Delphi
public read-write property OnClick: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, itemIndex")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebAccordion is clicked.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnClick : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, itemIndex")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebAccordion is clicked.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnClick();
public: __property void set_OnClick(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, itemIndex")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebAccordion is clicked.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnClick {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebEssentials Documentation
OnInitialize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : OnInitialize Property

Glossary Item Box

Gets or sets the event handler that will be invoked when WebAccordion is initialized.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebAccordion is initialized.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents
Dim value As System.String

instance.OnInitialize = value

value = instance.OnInitialize
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebAccordion is initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnInitialize {get; set;}
Delphi
public read-write property OnInitialize: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebAccordion is initialized.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnInitialize : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebAccordion is initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnInitialize();
public: __property void set_OnInitialize(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebAccordion is initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionClientSideEvents
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionClientSideEvents Class
WebAccordionClientSideEvents Members


WebAccordionContentMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebAccordionContentMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionContentMode Enumeration

Glossary Item Box

Specifies WebAccordion content mode.

Syntax

Visual Basic (Declaration)
Public Enum WebAccordionContentMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionContentMode
C#
public enum WebAccordionContentMode : System.Enum
Delphi
public enum WebAccordionContentMode = class(System.Enum)
JScript
public enum WebAccordionContentMode extends System.Enum
Managed Extensions for C++
__value public enum WebAccordionContentMode : public System.Enum
C++/CLI
public enum class WebAccordionContentMode : public System.Enum

Members

Member | Description
Default |
IFrame |
Inline |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebAccordionContentMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebAccordionDefaultStyleMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebAccordionDefaultStyleMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionDefaultStyleMode Enumeration

Glossary Item Box

Specifies DefaultStyle mode in WebAccordion.

Syntax

Visual Basic (Declaration)
Public Enum WebAccordionDefaultStyleMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionDefaultStyleMode
C#
public enum WebAccordionDefaultStyleMode : System.Enum
Delphi
public enum WebAccordionDefaultStyleMode = class(System.Enum)
JScript
public enum WebAccordionDefaultStyleMode extends System.Enum
Managed Extensions for C++
__value public enum WebAccordionDefaultStyleMode : public System.Enum
C++/CLI
public enum class WebAccordionDefaultStyleMode : public System.Enum

Members

Member | Description
Default |
Silver |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebAccordionDefaultStyleMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebAccordionExpandDirection Enumeration

[image]
Intersoft WebEssentials Documentation
WebAccordionExpandDirection Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionExpandDirection Enumeration

Glossary Item Box

Specifies expand direction of WebAccordion.

Syntax

Visual Basic (Declaration)
Public Enum WebAccordionExpandDirection
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionExpandDirection
C#
public enum WebAccordionExpandDirection : System.Enum
Delphi
public enum WebAccordionExpandDirection = class(System.Enum)
JScript
public enum WebAccordionExpandDirection extends System.Enum
Managed Extensions for C++
__value public enum WebAccordionExpandDirection : public System.Enum
C++/CLI
public enum class WebAccordionExpandDirection : public System.Enum

Members

Member | Description
Bottom |
Left |
Right |
Top |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebAccordionExpandDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebAccordionHeaderContentMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebAccordionHeaderContentMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionHeaderContentMode Enumeration

Glossary Item Box

Specifies WebAccordion header content mode.

Syntax

Visual Basic (Declaration)
Public Enum WebAccordionHeaderContentMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionHeaderContentMode
C#
public enum WebAccordionHeaderContentMode : System.Enum
Delphi
public enum WebAccordionHeaderContentMode = class(System.Enum)
JScript
public enum WebAccordionHeaderContentMode extends System.Enum
Managed Extensions for C++
__value public enum WebAccordionHeaderContentMode : public System.Enum
C++/CLI
public enum class WebAccordionHeaderContentMode : public System.Enum

Members

Member | Description
Default |
Image |
Inline |
Text |
TextAndImage |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebAccordionHeaderContentMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebAccordionHeaderImageAlignment Enumeration

[image]
Intersoft WebEssentials Documentation
WebAccordionHeaderImageAlignment Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionHeaderImageAlignment Enumeration

Glossary Item Box

Specifies WebAccordion header image alignment.

Syntax

Visual Basic (Declaration)
Public Enum WebAccordionHeaderImageAlignment
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionHeaderImageAlignment
C#
public enum WebAccordionHeaderImageAlignment : System.Enum
Delphi
public enum WebAccordionHeaderImageAlignment = class(System.Enum)
JScript
public enum WebAccordionHeaderImageAlignment extends System.Enum
Managed Extensions for C++
__value public enum WebAccordionHeaderImageAlignment : public System.Enum
C++/CLI
public enum class WebAccordionHeaderImageAlignment : public System.Enum

Members

Member | Description
Default |
Left |
Right |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebAccordionHeaderImageAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebAccordionImagesSettings Class

[image]
Intersoft WebEssentials Documentation
WebAccordionImagesSettings Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionImagesSettings Class

Glossary Item Box

A collection of WebAccordion's images settings.

Object Model

WebAccordionImagesSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebAccordionImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionImagesSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebAccordionImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebAccordionImagesSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebAccordionImagesSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebAccordionImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebAccordionImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebAccordionImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionImagesSettings Members
ISNet.WebUI.WebEssentials Namespace


WebAccordionImagesSettings Class Members

[image]
Intersoft WebEssentials Documentation
WebAccordionImagesSettings Class Members
See Also Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebAccordionImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebAccordionImagesSettings Constructor |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebAccordionImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionImagesSettings Class Methods

[image]
Intersoft WebEssentials Documentation
WebAccordionImagesSettings Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebAccordionImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebAccordionImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionImagesSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebAccordionImagesSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionImagesSettings Class : WebAccordionImagesSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebAccordionImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionImagesSettings Class
WebAccordionImagesSettings Members


WebAccordionImagesSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebAccordionImagesSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionImagesSettings Class : WebAccordionImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebAccordionImagesSettings()
C#
public WebAccordionImagesSettings()
Delphi
public WebAccordionImagesSettings();
JScript
public function WebAccordionImagesSettings();
Managed Extensions for C++
public: WebAccordionImagesSettings();
C++/CLI
public:
WebAccordionImagesSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionImagesSettings Class
WebAccordionImagesSettings Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionImagesSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionImagesSettings Class
WebAccordionImagesSettings Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionImagesSettings Class
WebAccordionImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionImagesSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionImagesSettings Class
WebAccordionImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionImagesSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionImagesSettings Class
WebAccordionImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionImagesSettings Class
WebAccordionImagesSettings Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionImagesSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionImagesSettings Class
WebAccordionImagesSettings Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionImagesSettings Class
WebAccordionImagesSettings Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionImagesSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionImagesSettings Class
WebAccordionImagesSettings Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionImagesSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionImagesSettings Class
WebAccordionImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionImagesSettings Class
WebAccordionImagesSettings Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionImagesSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionImagesSettings Class
WebAccordionImagesSettings Members


WebAccordionInteractionMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebAccordionInteractionMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionInteractionMode Enumeration

Glossary Item Box

Specifies WebAccordion Interaction mode.

Syntax

Visual Basic (Declaration)
Public Enum WebAccordionInteractionMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionInteractionMode
C#
public enum WebAccordionInteractionMode : System.Enum
Delphi
public enum WebAccordionInteractionMode = class(System.Enum)
JScript
public enum WebAccordionInteractionMode extends System.Enum
Managed Extensions for C++
__value public enum WebAccordionInteractionMode : public System.Enum
C++/CLI
public enum class WebAccordionInteractionMode : public System.Enum

Members

Member | Description
Both |
Click |
MouseOver |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebAccordionInteractionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebAccordionItem Class

[image]
Intersoft WebEssentials Documentation
WebAccordionItem Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionItem Class

Glossary Item Box

A collection of WebAccordion's Items.

Object Model

WebAccordionItem Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebAccordionItem
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebAccordionItem : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebAccordionItem = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebAccordionItem extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebAccordionItem : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebAccordionItem : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebEssentials.WebAccordionItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Members
ISNet.WebUI.WebEssentials Namespace


WebAccordionItem Class Members

[image]
Intersoft WebEssentials Documentation
WebAccordionItem Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionItem Class

Glossary Item Box

The following tables list the members exposed by WebAccordionItem.

Public Constructors

 | Name | Description
Public Constructor | WebAccordionItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | ContentMode | Specifies the container mode of WebAccordion's item.
Public Property | ContentURL | Specifies the content url of of WebAccordion's item.
Public Property | HeaderContentMode | Specifies the header content mode of WebAccordion's item.
Public Property | HeaderImageAlignment | Specifies the header image alignment of WebAccordion's item.
Public Property | HeaderImageSize | Specifies the header image size of WebAccordion's item.
Public Property | HeaderImageURL | Specifies the header image url of WebAccordion's item.
Public Property | HeaderText | Specifies the header text of WebAccordion's item.
Public Property | Name | Overridden. Specifies the name of the item.
Public Property | Parent | Gets the WebAccordionItem object that own this Item.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebAccordionItem Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionItem Class Methods

[image]
Intersoft WebEssentials Documentation
WebAccordionItem Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionItem Class

Glossary Item Box

For a list of all members of this type, see WebAccordionItem members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebAccordionItem Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionItem Class Properties

[image]
Intersoft WebEssentials Documentation
WebAccordionItem Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionItem Class

Glossary Item Box

For a list of all members of this type, see WebAccordionItem members.

Public Properties

 | Name | Description
Public Property | ContentMode | Specifies the container mode of WebAccordion's item.
Public Property | ContentURL | Specifies the content url of of WebAccordion's item.
Public Property | HeaderContentMode | Specifies the header content mode of WebAccordion's item.
Public Property | HeaderImageAlignment | Specifies the header image alignment of WebAccordion's item.
Public Property | HeaderImageSize | Specifies the header image size of WebAccordion's item.
Public Property | HeaderImageURL | Specifies the header image url of WebAccordion's item.
Public Property | HeaderText | Specifies the header text of WebAccordion's item.
Public Property | Name | Overridden. Specifies the name of the item.
Public Property | Parent | Gets the WebAccordionItem object that own this Item.
Top

See Also

Reference

WebAccordionItem Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionItemCollection Class

[image]
Intersoft WebEssentials Documentation
WebAccordionItemCollection Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionItemCollection Class

Glossary Item Box

The data collection of Item used by WebAccordion.

Object Model

WebAccordionItemCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebAccordionItemCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebAccordionItem)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebAccordionItemCollection : ISNet.WebUI.ISGenericCollectionBase<WebAccordionItem>
Delphi
public class WebAccordionItemCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebAccordionItemCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebAccordionItemCollection : public ISNet.WebUI.ISGenericCollectionBase<WebAccordionItem>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebAccordionItemCollection : public ISNet.WebUI.ISGenericCollectionBase<WebAccordionItem>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebEssentials.WebAccordionItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Members
ISNet.WebUI.WebEssentials Namespace


WebAccordionItemCollection Class Members

[image]
Intersoft WebEssentials Documentation
WebAccordionItemCollection Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionItemCollection Class

Glossary Item Box

The following tables list the members exposed by WebAccordionItemCollection.

Public Constructors

 | Name | Description
Public Constructor | WebAccordionItemCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebAccordionItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebAccordionItem>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebAccordionItem>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebAccordionItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionItemCollection Class Methods

[image]
Intersoft WebEssentials Documentation
WebAccordionItemCollection Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebAccordionItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebAccordionItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebAccordionItem>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebAccordionItem>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebAccordionItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionItemCollection Class Properties

[image]
Intersoft WebEssentials Documentation
WebAccordionItemCollection Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebAccordionItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebAccordionItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionItemCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebAccordionItemCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : WebAccordionItemCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebAccordionItemCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


WebAccordionItemCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebAccordionItemCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : WebAccordionItemCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebAccordionItemCollection()
C#
public WebAccordionItemCollection()
Delphi
public WebAccordionItemCollection();
JScript
public function WebAccordionItemCollection();
Managed Extensions for C++
public: WebAccordionItemCollection();
C++/CLI
public:
WebAccordionItemCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


Add Method

[image]
Intersoft WebEssentials Documentation
Add Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


Clear Method

[image]
Intersoft WebEssentials Documentation
Clear Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


Contains Method

[image]
Intersoft WebEssentials Documentation
Contains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


CopyTo Method

[image]
Intersoft WebEssentials Documentation
CopyTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


Count Property

[image]
Intersoft WebEssentials Documentation
Count Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


CreateNewItem Method

[image]
Intersoft WebEssentials Documentation
CreateNewItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebAccordionItem
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim value As WebAccordionItem

value = instance.CreateNewItem()
C#
public WebAccordionItem CreateNewItem()
Delphi
public function CreateNewItem(): WebAccordionItem;
JScript
public function CreateNewItem() : WebAccordionItem;
Managed Extensions for C++
public: WebAccordionItem* CreateNewItem();
C++/CLI
public:
WebAccordionItem^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


GetEnumerator Method

[image]
Intersoft WebEssentials Documentation
GetEnumerator Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


GetNamedItem Method

[image]
Intersoft WebEssentials Documentation
GetNamedItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebAccordionItem
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim name As System.String
Dim value As WebAccordionItem

value = instance.GetNamedItem(name)
C#
public WebAccordionItem GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebAccordionItem;
JScript
public function GetNamedItem(
   name : System.String
) : WebAccordionItem;
Managed Extensions for C++
public: WebAccordionItem* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebAccordionItem^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


IndexOf Method

[image]
Intersoft WebEssentials Documentation
IndexOf Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


Insert Method

[image]
Intersoft WebEssentials Documentation
Insert Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


Item Property

[image]
Intersoft WebEssentials Documentation
Item Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


Parent Property

[image]
Intersoft WebEssentials Documentation
Parent Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


Remove Method

[image]
Intersoft WebEssentials Documentation
Remove Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


RemoveAt Method

[image]
Intersoft WebEssentials Documentation
RemoveAt Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


SerializerConstructor Method

[image]
Intersoft WebEssentials Documentation
SerializerConstructor Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


SetParent Method

[image]
Intersoft WebEssentials Documentation
SetParent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemCollection Class
WebAccordionItemCollection Members


WebAccordionItemSettings Class

[image]
Intersoft WebEssentials Documentation
WebAccordionItemSettings Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionItemSettings Class

Glossary Item Box

A collection of settings which controls the default WebAccordion's Item settings.

Object Model

WebAccordionItemSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebAccordionItemSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebAccordionItemSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebAccordionItemSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebAccordionItemSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebAccordionItemSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebAccordionItemSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebAccordionItemSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Members
ISNet.WebUI.WebEssentials Namespace


WebAccordionItemSettings Class Members

[image]
Intersoft WebEssentials Documentation
WebAccordionItemSettings Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionItemSettings Class

Glossary Item Box

The following tables list the members exposed by WebAccordionItemSettings.

Public Constructors

 | Name | Description
Public Constructor | WebAccordionItemSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | ContentMode | Specifies the default content mode of WebAccordion's item.
Public Property | HeaderContentMode | Specifies the default header content mode of WebAccordion's item.
Public Property | HeaderImageAlignment | Specifies the default header image alignment of WebAccordion's item.
Public Property | HeaderImageSize | Specifies the default header image size of WebAccordion's item.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebAccordionItemSettings Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionItemSettings Class Methods

[image]
Intersoft WebEssentials Documentation
WebAccordionItemSettings Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionItemSettings Class

Glossary Item Box

For a list of all members of this type, see WebAccordionItemSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebAccordionItemSettings Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionItemSettings Class Properties

[image]
Intersoft WebEssentials Documentation
WebAccordionItemSettings Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionItemSettings Class

Glossary Item Box

For a list of all members of this type, see WebAccordionItemSettings members.

Public Properties

 | Name | Description
Public Property | ContentMode | Specifies the default content mode of WebAccordion's item.
Public Property | HeaderContentMode | Specifies the default header content mode of WebAccordion's item.
Public Property | HeaderImageAlignment | Specifies the default header image alignment of WebAccordion's item.
Public Property | HeaderImageSize | Specifies the default header image size of WebAccordion's item.
Top

See Also

Reference

WebAccordionItemSettings Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionItemSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebAccordionItemSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : WebAccordionItemSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebAccordionItemSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


WebAccordionItemSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebAccordionItemSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : WebAccordionItemSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebAccordionItemSettings()
C#
public WebAccordionItemSettings()
Delphi
public WebAccordionItemSettings();
JScript
public function WebAccordionItemSettings();
Managed Extensions for C++
public: WebAccordionItemSettings();
C++/CLI
public:
WebAccordionItemSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


ContentMode Property

[image]
Intersoft WebEssentials Documentation
ContentMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : ContentMode Property

Glossary Item Box

Specifies the default content mode of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the default content mode of WebAccordion's item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ContentMode As WebAccordionContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings
Dim value As WebAccordionContentMode

instance.ContentMode = value

value = instance.ContentMode
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default content mode of WebAccordion's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebAccordionContentMode ContentMode {get; set;}
Delphi
public read-write property ContentMode: WebAccordionContentMode;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the default content mode of WebAccordion's item.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ContentMode : WebAccordionContentMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default content mode of WebAccordion's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebAccordionContentMode get_ContentMode();
public: __property void set_ContentMode(
   WebAccordionContentMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default content mode of WebAccordion's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebAccordionContentMode ContentMode {
   WebAccordionContentMode get();
   void set (    WebAccordionContentMode value);
}

Property Value

The default value is Inline.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


HeaderContentMode Property

[image]
Intersoft WebEssentials Documentation
HeaderContentMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : HeaderContentMode Property

Glossary Item Box

Specifies the default header content mode of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the default header image alignment of WebAccordion's item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property HeaderContentMode As WebAccordionHeaderContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings
Dim value As WebAccordionHeaderContentMode

instance.HeaderContentMode = value

value = instance.HeaderContentMode
C#
[System.ComponentModel.DescriptionAttribute("Specifies the default header image alignment of WebAccordion's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebAccordionHeaderContentMode HeaderContentMode {get; set;}
Delphi
public read-write property HeaderContentMode: WebAccordionHeaderContentMode;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the default header image alignment of WebAccordion's item.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set HeaderContentMode : WebAccordionHeaderContentMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the default header image alignment of WebAccordion's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebAccordionHeaderContentMode get_HeaderContentMode();
public: __property void set_HeaderContentMode(
   WebAccordionHeaderContentMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the default header image alignment of WebAccordion's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebAccordionHeaderContentMode HeaderContentMode {
   WebAccordionHeaderContentMode get();
   void set (    WebAccordionHeaderContentMode value);
}

Property Value

The default value is Text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


HeaderImageAlignment Property

[image]
Intersoft WebEssentials Documentation
HeaderImageAlignment Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : HeaderImageAlignment Property

Glossary Item Box

Specifies the default header image alignment of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the default header image alignment of WebAccordion's item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
Public Property HeaderImageAlignment As WebAccordionHeaderImageAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings
Dim value As WebAccordionHeaderImageAlignment

instance.HeaderImageAlignment = value

value = instance.HeaderImageAlignment
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default header image alignment of WebAccordion's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public WebAccordionHeaderImageAlignment HeaderImageAlignment {get; set;}
Delphi
public read-write property HeaderImageAlignment: WebAccordionHeaderImageAlignment;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the default header image alignment of WebAccordion's item.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set HeaderImageAlignment : WebAccordionHeaderImageAlignment
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default header image alignment of WebAccordion's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public: __property WebAccordionHeaderImageAlignment get_HeaderImageAlignment();
public: __property void set_HeaderImageAlignment(
   WebAccordionHeaderImageAlignment value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default header image alignment of WebAccordion's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public:
property WebAccordionHeaderImageAlignment HeaderImageAlignment {
   WebAccordionHeaderImageAlignment get();
   void set (    WebAccordionHeaderImageAlignment value);
}

Property Value

The default value is Left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


HeaderImageSize Property

[image]
Intersoft WebEssentials Documentation
HeaderImageSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : HeaderImageSize Property

Glossary Item Box

Specifies the default header image size of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the default header image size of WebAccordion's item.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property HeaderImageSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings
Dim value As System.Drawing.Size

instance.HeaderImageSize = value

value = instance.HeaderImageSize
C#
[System.ComponentModel.DescriptionAttribute("Specifies the default header image size of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.Drawing.Size HeaderImageSize {get; set;}
Delphi
public read-write property HeaderImageSize: System.Drawing.Size;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the default header image size of WebAccordion's item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set HeaderImageSize : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the default header image size of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.Drawing.Size get_HeaderImageSize();
public: __property void set_HeaderImageSize(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the default header image size of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.Drawing.Size HeaderImageSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItemSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItemSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItemSettings Class
WebAccordionItemSettings Members


WebAccordionItem Constructor

[image]
Intersoft WebEssentials Documentation
WebAccordionItem Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : WebAccordionItem Constructor

Glossary Item Box

Overload List

Overload | Description
WebAccordionItem Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


WebAccordionItem Constructor

[image]
Intersoft WebEssentials Documentation
WebAccordionItem Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : WebAccordionItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebAccordionItem()
C#
public WebAccordionItem()
Delphi
public WebAccordionItem();
JScript
public function WebAccordionItem();
Managed Extensions for C++
public: WebAccordionItem();
C++/CLI
public:
WebAccordionItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


ContentMode Property

[image]
Intersoft WebEssentials Documentation
ContentMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : ContentMode Property

Glossary Item Box

Specifies the container mode of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebAccordion's item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ContentMode As WebAccordionContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim value As WebAccordionContentMode

instance.ContentMode = value

value = instance.ContentMode
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebAccordionContentMode ContentMode {get; set;}
Delphi
public read-write property ContentMode: WebAccordionContentMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebAccordion's item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ContentMode : WebAccordionContentMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebAccordionContentMode get_ContentMode();
public: __property void set_ContentMode(
   WebAccordionContentMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebAccordionContentMode ContentMode {
   WebAccordionContentMode get();
   void set (    WebAccordionContentMode value);
}

Property Value

The default value is Inline.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


ContentURL Property

[image]
Intersoft WebEssentials Documentation
ContentURL Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : ContentURL Property

Glossary Item Box

Specifies the content url of of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the content url of of WebAccordion's item.")>
Public Property ContentURL As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim value As System.String

instance.ContentURL = value

value = instance.ContentURL
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the content url of of WebAccordion's item.")]
public System.string ContentURL {get; set;}
Delphi
public read-write property ContentURL: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the content url of of WebAccordion's item.")
public function get,set ContentURL : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the content url of of WebAccordion's item.")]
public: __property System.string* get_ContentURL();
public: __property void set_ContentURL(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the content url of of WebAccordion's item.")]
public:
property System.String^ ContentURL {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


HeaderContentMode Property

[image]
Intersoft WebEssentials Documentation
HeaderContentMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : HeaderContentMode Property

Glossary Item Box

Specifies the header content mode of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.TwoWay)>
<System.ComponentModel.DescriptionAttribute("Specifies the header content mode of WebAccordion's item.")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property HeaderContentMode As WebAccordionHeaderContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim value As WebAccordionHeaderContentMode

instance.HeaderContentMode = value

value = instance.HeaderContentMode
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.DescriptionAttribute("Specifies the header content mode of WebAccordion's item.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebAccordionHeaderContentMode HeaderContentMode {get; set;}
Delphi
public read-write property HeaderContentMode: WebAccordionHeaderContentMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.TwoWay)
System.ComponentModel.DescriptionAttribute("Specifies the header content mode of WebAccordion's item.")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set HeaderContentMode : WebAccordionHeaderContentMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.DescriptionAttribute("Specifies the header content mode of WebAccordion's item.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebAccordionHeaderContentMode get_HeaderContentMode();
public: __property void set_HeaderContentMode(
   WebAccordionHeaderContentMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.DescriptionAttribute("Specifies the header content mode of WebAccordion's item.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebAccordionHeaderContentMode HeaderContentMode {
   WebAccordionHeaderContentMode get();
   void set (    WebAccordionHeaderContentMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


HeaderImageAlignment Property

[image]
Intersoft WebEssentials Documentation
HeaderImageAlignment Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : HeaderImageAlignment Property

Glossary Item Box

Specifies the header image alignment of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.TwoWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the header image alignment of WebAccordion's item.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property HeaderImageAlignment As WebAccordionHeaderImageAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim value As WebAccordionHeaderImageAlignment

instance.HeaderImageAlignment = value

value = instance.HeaderImageAlignment
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the header image alignment of WebAccordion's item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebAccordionHeaderImageAlignment HeaderImageAlignment {get; set;}
Delphi
public read-write property HeaderImageAlignment: WebAccordionHeaderImageAlignment;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.TwoWay)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the header image alignment of WebAccordion's item.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set HeaderImageAlignment : WebAccordionHeaderImageAlignment
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the header image alignment of WebAccordion's item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebAccordionHeaderImageAlignment get_HeaderImageAlignment();
public: __property void set_HeaderImageAlignment(
   WebAccordionHeaderImageAlignment value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the header image alignment of WebAccordion's item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebAccordionHeaderImageAlignment HeaderImageAlignment {
   WebAccordionHeaderImageAlignment get();
   void set (    WebAccordionHeaderImageAlignment value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


HeaderImageSize Property

[image]
Intersoft WebEssentials Documentation
HeaderImageSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : HeaderImageSize Property

Glossary Item Box

Specifies the header image size of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the default header image size of WebAccordion's item.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HeaderImageSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim value As System.Drawing.Size

instance.HeaderImageSize = value

value = instance.HeaderImageSize
C#
[System.ComponentModel.DescriptionAttribute("Specifies the default header image size of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Size HeaderImageSize {get; set;}
Delphi
public read-write property HeaderImageSize: System.Drawing.Size;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the default header image size of WebAccordion's item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set HeaderImageSize : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the default header image size of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Size get_HeaderImageSize();
public: __property void set_HeaderImageSize(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the default header image size of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Size HeaderImageSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


HeaderImageURL Property

[image]
Intersoft WebEssentials Documentation
HeaderImageURL Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : HeaderImageURL Property

Glossary Item Box

Specifies the header image url of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the header image url of of WebAccordion's item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.TwoWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HeaderImageURL As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim value As System.String

instance.HeaderImageURL = value

value = instance.HeaderImageURL
C#
[System.ComponentModel.DescriptionAttribute("Specifies the header image url of of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string HeaderImageURL {get; set;}
Delphi
public read-write property HeaderImageURL: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the header image url of of WebAccordion's item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.TwoWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set HeaderImageURL : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the header image url of of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_HeaderImageURL();
public: __property void set_HeaderImageURL(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the header image url of of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ HeaderImageURL {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


HeaderText Property

[image]
Intersoft WebEssentials Documentation
HeaderText Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : HeaderText Property

Glossary Item Box

Specifies the header text of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the header text of WebAccordion's item.")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.TwoWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property HeaderText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim value As System.String

instance.HeaderText = value

value = instance.HeaderText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the header text of WebAccordion's item.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string HeaderText {get; set;}
Delphi
public read-write property HeaderText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the header text of WebAccordion's item.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.TwoWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set HeaderText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the header text of WebAccordion's item.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_HeaderText();
public: __property void set_HeaderText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the header text of WebAccordion's item.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ HeaderText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


Name Property

[image]
Intersoft WebEssentials Documentation
Name Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : Name Property

Glossary Item Box

Specifies the name of the item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BrowsableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public override function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


Parent Property

[image]
Intersoft WebEssentials Documentation
Parent Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : Parent Property

Glossary Item Box

Gets the WebAccordionItem object that own this Item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Gets the WebAccordionItem object that own this Item.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(True)>
Public Property Parent As WebAccordion
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim value As WebAccordion

instance.Parent = value

value = instance.Parent
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets the WebAccordionItem object that own this Item.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(true)]
public WebAccordion Parent {get; set;}
Delphi
public read-write property Parent: WebAccordion;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Gets the WebAccordionItem object that own this Item.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Parent : WebAccordion
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets the WebAccordionItem object that own this Item.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(true)]
public: __property WebAccordion* get_Parent();
public: __property void set_Parent(
   WebAccordion* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets the WebAccordionItem object that own this Item.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(true)]
public:
property WebAccordion^ Parent {
   WebAccordion^ get();
   void set (    WebAccordion^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionItem Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionItem
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionItem Class
WebAccordionItem Members


WebAccordionNewItemForm Class

[image]
Intersoft WebEssentials Documentation
WebAccordionNewItemForm Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionNewItemForm Class

Glossary Item Box

Object Model

WebAccordionNewItemForm Class

Syntax

Visual Basic (Declaration)
Public Class WebAccordionNewItemForm
   Inherits System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
C#
public class WebAccordionNewItemForm : System.Windows.Forms.Form
Delphi
public class WebAccordionNewItemForm = class(System.Windows.Forms.Form)
JScript
public class WebAccordionNewItemForm extends System.Windows.Forms.Form
Managed Extensions for C++
public __gc class WebAccordionNewItemForm : public System.Windows.Forms.Form
C++/CLI
public ref class WebAccordionNewItemForm : public System.Windows.Forms.Form

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ISNet.WebUI.WebEssentials.WebAccordionNewItemForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Members
ISNet.WebUI.WebEssentials Namespace


WebAccordionNewItemForm Class Events

[image]
Intersoft WebEssentials Documentation
WebAccordionNewItemForm Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionNewItemForm Class

Glossary Item Box

For a list of all members of this type, see WebAccordionNewItemForm members.

Public Events

 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

WebAccordionNewItemForm Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionNewItemForm Class Members

[image]
Intersoft WebEssentials Documentation
WebAccordionNewItemForm Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionNewItemForm Class

Glossary Item Box

The following tables list the members exposed by WebAccordionNewItemForm.

Public Constructors

 | Name | Description
Public Constructor | WebAccordionNewItemForm Constructor |
Top

Public Properties

 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top

Public Methods

 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top

Public Events

 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

WebAccordionNewItemForm Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionNewItemForm Class Methods

[image]
Intersoft WebEssentials Documentation
WebAccordionNewItemForm Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionNewItemForm Class

Glossary Item Box

For a list of all members of this type, see WebAccordionNewItemForm members.

Public Methods

 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top

See Also

Reference

WebAccordionNewItemForm Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionNewItemForm Class Properties

[image]
Intersoft WebEssentials Documentation
WebAccordionNewItemForm Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionNewItemForm Class

Glossary Item Box

For a list of all members of this type, see WebAccordionNewItemForm members.

Public Properties

 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top

See Also

Reference

WebAccordionNewItemForm Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionNewItemForm Constructor

[image]
Intersoft WebEssentials Documentation
WebAccordionNewItemForm Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : WebAccordionNewItemForm Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebAccordionNewItemForm()
C#
public WebAccordionNewItemForm()
Delphi
public WebAccordionNewItemForm();
JScript
public function WebAccordionNewItemForm();
Managed Extensions for C++
public: WebAccordionNewItemForm();
C++/CLI
public:
WebAccordionNewItemForm();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


AcceptButton Property

[image]
Intersoft WebEssentials Documentation
AcceptButton Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : AcceptButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")>
Public Property AcceptButton As System.Windows.Forms.IButtonControl
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.IButtonControl

instance.AcceptButton = value

value = instance.AcceptButton
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")]
public System.Windows.Forms.IButtonControl AcceptButton {get; set;}
Delphi
public read-write property AcceptButton: System.Windows.Forms.IButtonControl;
JScript
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")
public function get,set AcceptButton : System.Windows.Forms.IButtonControl
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")]
public: __property System.Windows.Forms.IButtonControl* get_AcceptButton();
public: __property void set_AcceptButton(
   System.Windows.Forms.IButtonControl* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")]
public:
property System.Windows.Forms.IButtonControl^ AcceptButton {
   System.Windows.Forms.IButtonControl^ get();
   void set (    System.Windows.Forms.IButtonControl^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


AccessibleDescription Property

[image]
Intersoft WebEssentials Documentation
AccessibleDescription Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : AccessibleDescription Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Accessibility")>
<SRDescriptionAttribute("The description that will be reported to accessibility clients.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AccessibleDescription As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.String

instance.AccessibleDescription = value

value = instance.AccessibleDescription
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The description that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string AccessibleDescription {get; set;}
Delphi
public read-write property AccessibleDescription: System.String;
JScript
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Accessibility")
SRDescriptionAttribute("The description that will be reported to accessibility clients.")
System.ComponentModel.DefaultValueAttribute()
public function get,set AccessibleDescription : System.String
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The description that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_AccessibleDescription();
public: __property void set_AccessibleDescription(
   System.string* value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The description that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ AccessibleDescription {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


AccessibleName Property

[image]
Intersoft WebEssentials Documentation
AccessibleName Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : AccessibleName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Accessibility")>
<SRDescriptionAttribute("The name that will be reported to accessibility clients.")>
Public Property AccessibleName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.String

instance.AccessibleName = value

value = instance.AccessibleName
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The name that will be reported to accessibility clients.")]
public System.string AccessibleName {get; set;}
Delphi
public read-write property AccessibleName: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Accessibility")
SRDescriptionAttribute("The name that will be reported to accessibility clients.")
public function get,set AccessibleName : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The name that will be reported to accessibility clients.")]
public: __property System.string* get_AccessibleName();
public: __property void set_AccessibleName(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The name that will be reported to accessibility clients.")]
public:
property System.String^ AccessibleName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


AccessibleRole Property

[image]
Intersoft WebEssentials Documentation
AccessibleRole Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : AccessibleRole Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The role that will be reported to accessibility clients.")>
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Accessibility")>
Public Property AccessibleRole As System.Windows.Forms.AccessibleRole
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.AccessibleRole

instance.AccessibleRole = value

value = instance.AccessibleRole
C#
[SRDescriptionAttribute("The role that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Accessibility")]
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}
Delphi
public read-write property AccessibleRole: System.Windows.Forms.AccessibleRole;
JScript
SRDescriptionAttribute("The role that will be reported to accessibility clients.")
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Accessibility")
public function get,set AccessibleRole : System.Windows.Forms.AccessibleRole
Managed Extensions for C++
[SRDescriptionAttribute("The role that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Accessibility")]
public: __property System.Windows.Forms.AccessibleRole get_AccessibleRole();
public: __property void set_AccessibleRole(
   System.Windows.Forms.AccessibleRole value
);
C++/CLI
[SRDescriptionAttribute("The role that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Accessibility")]
public:
property System.Windows.Forms.AccessibleRole AccessibleRole {
   System.Windows.Forms.AccessibleRole get();
   void set (    System.Windows.Forms.AccessibleRole value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Activate Method

[image]
Intersoft WebEssentials Documentation
Activate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Activate Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Activate()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.Activate()
C#
public void Activate()
Delphi
public procedure Activate();
JScript
public function Activate();
Managed Extensions for C++
public: void Activate();
C++/CLI
public:
void Activate();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Activated Event

[image]
Intersoft WebEssentials Documentation
Activated Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Activated Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Occurs whenever the form is activated.")>
Public Event Activated As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Activated, handler
C#
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is activated.")]
public event System.EventHandler Activated
Delphi
public event Activated: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is activated.")]
public: __event System.EventHandler* Activated
C++/CLI
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is activated.")]
public:
event System.EventHandler^ Activated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


AddOwnedForm Method

[image]
Intersoft WebEssentials Documentation
AddOwnedForm Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : AddOwnedForm Method

ownedForm

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub AddOwnedForm( _
   ByVal ownedForm As System.Windows.Forms.Form _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim ownedForm As System.Windows.Forms.Form

instance.AddOwnedForm(ownedForm)
C#
public void AddOwnedForm(
   System.Windows.Forms.Form ownedForm
)
Delphi
public procedure AddOwnedForm(
    ownedForm: System.Windows.Forms.Form
);
JScript
public function AddOwnedForm(
   ownedForm : System.Windows.Forms.Form
);
Managed Extensions for C++
public: void AddOwnedForm(
   System.Windows.Forms.Form* ownedForm
)
C++/CLI
public:
void AddOwnedForm(
   System.Windows.Forms.Form^ ownedForm
)

Parameters

ownedForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


AllowDrop Property

[image]
Intersoft WebEssentials Documentation
AllowDrop Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : AllowDrop Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")>
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Overridable Property AllowDrop As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
[SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public virtual System.bool AllowDrop {get; set;}
Delphi
public read-write property AllowDrop: System.Boolean; virtual;
JScript
SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Behavior")
public function get,set AllowDrop : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property virtual System.bool get_AllowDrop();
public: __property virtual void set_AllowDrop(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
virtual property System.bool AllowDrop {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Anchor Property

[image]
Intersoft WebEssentials Documentation
Anchor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Anchor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
Public Overridable Property Anchor As System.Windows.Forms.AnchorStyles
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.AnchorStyles

instance.Anchor = value

value = instance.Anchor
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}
Delphi
public read-write property Anchor: System.Windows.Forms.AnchorStyles; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")
SRCategoryAttribute("Layout")
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
public function get,set Anchor : System.Windows.Forms.AnchorStyles
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
public: __property virtual System.Windows.Forms.AnchorStyles get_Anchor();
public: __property virtual void set_Anchor(
   System.Windows.Forms.AnchorStyles value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
public:
virtual property System.Windows.Forms.AnchorStyles Anchor {
   System.Windows.Forms.AnchorStyles get();
   void set (    System.Windows.Forms.AnchorStyles value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


AutoScroll Property

[image]
Intersoft WebEssentials Documentation
AutoScroll Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : AutoScroll Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
Public Overridable Property AutoScroll As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.AutoScroll = value

value = instance.AutoScroll
C#
[System.ComponentModel.LocalizableAttribute(true)]
public virtual System.bool AutoScroll {get; set;}
Delphi
public read-write property AutoScroll: System.Boolean; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
public function get,set AutoScroll : System.boolean
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
public: __property virtual System.bool get_AutoScroll();
public: __property virtual void set_AutoScroll(
   System.bool value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
public:
virtual property System.bool AutoScroll {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


AutoScrollMargin Property

[image]
Intersoft WebEssentials Documentation
AutoScrollMargin Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : AutoScrollMargin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("The margin around controls during auto scroll.")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Property AutoScrollMargin As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Size

instance.AutoScrollMargin = value

value = instance.AutoScrollMargin
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The margin around controls during auto scroll.")]
[System.ComponentModel.LocalizableAttribute(true)]
public System.Drawing.Size AutoScrollMargin {get; set;}
Delphi
public read-write property AutoScrollMargin: System.Drawing.Size;
JScript
SRCategoryAttribute("Layout")
SRDescriptionAttribute("The margin around controls during auto scroll.")
System.ComponentModel.LocalizableAttribute()
public function get,set AutoScrollMargin : System.Drawing.Size
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The margin around controls during auto scroll.")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property System.Drawing.Size get_AutoScrollMargin();
public: __property void set_AutoScrollMargin(
   System.Drawing.Size value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The margin around controls during auto scroll.")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
property System.Drawing.Size AutoScrollMargin {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


AutoScrollMinSize Property

[image]
Intersoft WebEssentials Documentation
AutoScrollMinSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : AutoScrollMinSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The minimum logical size for the auto scroll region.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
Public Property AutoScrollMinSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Size

instance.AutoScrollMinSize = value

value = instance.AutoScrollMinSize
C#
[SRDescriptionAttribute("The minimum logical size for the auto scroll region.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public System.Drawing.Size AutoScrollMinSize {get; set;}
Delphi
public read-write property AutoScrollMinSize: System.Drawing.Size;
JScript
SRDescriptionAttribute("The minimum logical size for the auto scroll region.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Layout")
public function get,set AutoScrollMinSize : System.Drawing.Size
Managed Extensions for C++
[SRDescriptionAttribute("The minimum logical size for the auto scroll region.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public: __property System.Drawing.Size get_AutoScrollMinSize();
public: __property void set_AutoScrollMinSize(
   System.Drawing.Size value
);
C++/CLI
[SRDescriptionAttribute("The minimum logical size for the auto scroll region.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public:
property System.Drawing.Size AutoScrollMinSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


AutoSize Property

[image]
Intersoft WebEssentials Documentation
AutoSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : AutoSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.EditorBrowsableAttribute()>
Public Overridable Property AutoSize As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.AutoSize = value

value = instance.AutoSize
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.EditorBrowsableAttribute()]
public virtual System.bool AutoSize {get; set;}
Delphi
public read-write property AutoSize: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.EditorBrowsableAttribute()
public function get,set AutoSize : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.EditorBrowsableAttribute()]
public: __property virtual System.bool get_AutoSize();
public: __property virtual void set_AutoSize(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.EditorBrowsableAttribute()]
public:
virtual property System.bool AutoSize {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


AutoSizeChanged Event

[image]
Intersoft WebEssentials Documentation
AutoSizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : AutoSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<SRDescriptionAttribute("Occurs when the AutoSize property has changed.")>
<System.ComponentModel.EditorBrowsableAttribute()>
<SRCategoryAttribute("Property Changed")>
Public Event AutoSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.AutoSizeChanged, handler
C#
[System.ComponentModel.BrowsableAttribute(true)]
[SRDescriptionAttribute("Occurs when the AutoSize property has changed.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler AutoSizeChanged
Delphi
public event AutoSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[SRDescriptionAttribute("Occurs when the AutoSize property has changed.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* AutoSizeChanged
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[SRDescriptionAttribute("Occurs when the AutoSize property has changed.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ AutoSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


AutoSizeMode Property

[image]
Intersoft WebEssentials Documentation
AutoSizeMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : AutoSizeMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AutoSizeMode As System.Windows.Forms.AutoSizeMode
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.AutoSizeMode

instance.AutoSizeMode = value

value = instance.AutoSizeMode
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.Windows.Forms.AutoSizeMode AutoSizeMode {get; set;}
Delphi
public read-write property AutoSizeMode: System.Windows.Forms.AutoSizeMode;
JScript
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Layout")
SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AutoSizeMode : System.Windows.Forms.AutoSizeMode
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Windows.Forms.AutoSizeMode get_AutoSizeMode();
public: __property void set_AutoSizeMode(
   System.Windows.Forms.AutoSizeMode value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Windows.Forms.AutoSizeMode AutoSizeMode {
   System.Windows.Forms.AutoSizeMode get();
   void set (    System.Windows.Forms.AutoSizeMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


AutoValidate Property

[image]
Intersoft WebEssentials Documentation
AutoValidate Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : AutoValidate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property AutoValidate As System.Windows.Forms.AutoValidate
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.AutoValidate

instance.AutoValidate = value

value = instance.AutoValidate
C#
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.Windows.Forms.AutoValidate AutoValidate {get; set;}
Delphi
public read-write property AutoValidate: System.Windows.Forms.AutoValidate; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute()
System.ComponentModel.BrowsableAttribute()
public function get,set AutoValidate : System.Windows.Forms.AutoValidate
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.Windows.Forms.AutoValidate get_AutoValidate();
public: __property virtual void set_AutoValidate(
   System.Windows.Forms.AutoValidate value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.Windows.Forms.AutoValidate AutoValidate {
   System.Windows.Forms.AutoValidate get();
   void set (    System.Windows.Forms.AutoValidate value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


AutoValidateChanged Event

[image]
Intersoft WebEssentials Documentation
AutoValidateChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : AutoValidateChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
Public Event AutoValidateChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.AutoValidateChanged, handler
C#
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public event System.EventHandler AutoValidateChanged
Delphi
public event AutoValidateChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public: __event System.EventHandler* AutoValidateChanged
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public:
event System.EventHandler^ AutoValidateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


BackColor Property

[image]
Intersoft WebEssentials Documentation
BackColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : BackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public virtual System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; virtual;
JScript
public function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
C++/CLI
public:
virtual property System.Drawing.Color BackColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


BackColorChanged Event

[image]
Intersoft WebEssentials Documentation
BackColorChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : BackColorChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")>
Public Event BackColorChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.BackColorChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")]
public event System.EventHandler BackColorChanged
Delphi
public event BackColorChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")]
public: __event System.EventHandler* BackColorChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")]
public:
event System.EventHandler^ BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


BackgroundImage Property

[image]
Intersoft WebEssentials Documentation
BackgroundImage Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : BackgroundImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("The background image used for the control.")>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property BackgroundImage As System.Drawing.Image
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image used for the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Drawing.Image BackgroundImage {get; set;}
Delphi
public read-write property BackgroundImage: System.Drawing.Image; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("The background image used for the control.")
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
public function get,set BackgroundImage : System.Drawing.Image
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image used for the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Drawing.Image* get_BackgroundImage();
public: __property virtual void set_BackgroundImage(
   System.Drawing.Image* value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image used for the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Drawing.Image^ BackgroundImage {
   System.Drawing.Image^ get();
   void set (    System.Drawing.Image^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


BackgroundImageChanged Event

[image]
Intersoft WebEssentials Documentation
BackgroundImageChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : BackgroundImageChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")>
Public Event BackgroundImageChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")]
public event System.EventHandler BackgroundImageChanged
Delphi
public event BackgroundImageChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")]
public: __event System.EventHandler* BackgroundImageChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")]
public:
event System.EventHandler^ BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


BackgroundImageLayout Property

[image]
Intersoft WebEssentials Documentation
BackgroundImageLayout Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : BackgroundImageLayout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("The background image layout used for the component.")>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property BackgroundImageLayout As System.Windows.Forms.ImageLayout
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.ImageLayout

instance.BackgroundImageLayout = value

value = instance.BackgroundImageLayout
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image layout used for the component.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}
Delphi
public read-write property BackgroundImageLayout: System.Windows.Forms.ImageLayout; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("The background image layout used for the component.")
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
public function get,set BackgroundImageLayout : System.Windows.Forms.ImageLayout
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image layout used for the component.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Windows.Forms.ImageLayout get_BackgroundImageLayout();
public: __property virtual void set_BackgroundImageLayout(
   System.Windows.Forms.ImageLayout value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image layout used for the component.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Windows.Forms.ImageLayout BackgroundImageLayout {
   System.Windows.Forms.ImageLayout get();
   void set (    System.Windows.Forms.ImageLayout value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


BackgroundImageLayoutChanged Event

[image]
Intersoft WebEssentials Documentation
BackgroundImageLayoutChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event BackgroundImageLayoutChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageLayoutChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler BackgroundImageLayoutChanged
Delphi
public event BackgroundImageLayoutChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* BackgroundImageLayoutChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


BeginInvoke Method

[image]
Intersoft WebEssentials Documentation
BeginInvoke Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : BeginInvoke Method

Glossary Item Box

Overload List

Overload | Description
BeginInvoke(Delegate) | (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


BeginInvoke(Delegate) Method

[image]
Intersoft WebEssentials Documentation
BeginInvoke(Delegate) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate _
) As System.IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim method As System.Delegate
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)
Delphi
public function BeginInvoke(
    method: System.Delegate
): System.IAsyncResult;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function BeginInvoke(
   method : System.Delegate
) : System.IAsyncResult;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.IAsyncResult* BeginInvoke(
   System.Delegate* method
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.IAsyncResult^ BeginInvoke(
   System.Delegate^ method
)

Parameters

method

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
Intersoft WebEssentials Documentation
BeginInvoke(Delegate,Object[]) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method, args)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)
Delphi
public function BeginInvoke(
    method: System.Delegate;
   params  args: System.TObjectarray of
): System.IAsyncResult;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function BeginInvoke(
   method : System.Delegate,
   args : System.Object[]
) : System.IAsyncResult;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: System.IAsyncResult* BeginInvoke(
   System.Delegate* method,
   params System.Object*[]* args
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
System.IAsyncResult^ BeginInvoke(
   System.Delegate^ method,
   ... System.array<Object^>^ args
)

Parameters

method
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


BindingContextChanged Event

[image]
Intersoft WebEssentials Documentation
BindingContextChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : BindingContextChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")>
Public Event BindingContextChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.BindingContextChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")]
public event System.EventHandler BindingContextChanged
Delphi
public event BindingContextChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")]
public: __event System.EventHandler* BindingContextChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")]
public:
event System.EventHandler^ BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


BringToFront Method

[image]
Intersoft WebEssentials Documentation
BringToFront Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : BringToFront Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.BringToFront()
C#
public void BringToFront()
Delphi
public procedure BringToFront();
JScript
public function BringToFront();
Managed Extensions for C++
public: void BringToFront();
C++/CLI
public:
void BringToFront();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


CancelButton Property

[image]
Intersoft WebEssentials Documentation
CancelButton Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : CancelButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")>
Public Property CancelButton As System.Windows.Forms.IButtonControl
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.IButtonControl

instance.CancelButton = value

value = instance.CancelButton
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")]
public System.Windows.Forms.IButtonControl CancelButton {get; set;}
Delphi
public read-write property CancelButton: System.Windows.Forms.IButtonControl;
JScript
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")
public function get,set CancelButton : System.Windows.Forms.IButtonControl
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")]
public: __property System.Windows.Forms.IButtonControl* get_CancelButton();
public: __property void set_CancelButton(
   System.Windows.Forms.IButtonControl* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")]
public:
property System.Windows.Forms.IButtonControl^ CancelButton {
   System.Windows.Forms.IButtonControl^ get();
   void set (    System.Windows.Forms.IButtonControl^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


CausesValidation Property

[image]
Intersoft WebEssentials Documentation
CausesValidation Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : CausesValidation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Indicates whether this component raises validation events. ")>
Public Property CausesValidation As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.CausesValidation = value

value = instance.CausesValidation
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Indicates whether this component raises validation events. ")]
public System.bool CausesValidation {get; set;}
Delphi
public read-write property CausesValidation: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Focus")
SRDescriptionAttribute("Indicates whether this component raises validation events. ")
public function get,set CausesValidation : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Indicates whether this component raises validation events. ")]
public: __property System.bool get_CausesValidation();
public: __property void set_CausesValidation(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Indicates whether this component raises validation events. ")]
public:
property System.bool CausesValidation {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


CausesValidationChanged Event

[image]
Intersoft WebEssentials Documentation
CausesValidationChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : CausesValidationChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event CausesValidationChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.CausesValidationChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler CausesValidationChanged
Delphi
public event CausesValidationChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* CausesValidationChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ChangeUICues Event

[image]
Intersoft WebEssentials Documentation
ChangeUICues Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ChangeUICues Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")>
Public Event ChangeUICues As System.Windows.Forms.UICuesEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.UICuesEventHandler

AddHandler instance.ChangeUICues, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")]
public event System.Windows.Forms.UICuesEventHandler ChangeUICues
Delphi
public event ChangeUICues: System.Windows.Forms.UICuesEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")]
public: __event System.Windows.Forms.UICuesEventHandler* ChangeUICues
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")]
public:
event System.Windows.Forms.UICuesEventHandler^ ChangeUICues

Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Click Event

[image]
Intersoft WebEssentials Documentation
Click Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Click Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the component is clicked.")>
Public Event Click As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Click, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the component is clicked.")]
public event System.EventHandler Click
Delphi
public event Click: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the component is clicked.")]
public: __event System.EventHandler* Click
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the component is clicked.")]
public:
event System.EventHandler^ Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ClientSize Property

[image]
Intersoft WebEssentials Documentation
ClientSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ClientSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
Public Property ClientSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Size

instance.ClientSize = value

value = instance.ClientSize
C#
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public System.Drawing.Size ClientSize {get; set;}
Delphi
public read-write property ClientSize: System.Drawing.Size;
JScript
System.ComponentModel.LocalizableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
public function get,set ClientSize : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public: __property System.Drawing.Size get_ClientSize();
public: __property void set_ClientSize(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public:
property System.Drawing.Size ClientSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ClientSizeChanged Event

[image]
Intersoft WebEssentials Documentation
ClientSizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ClientSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")>
Public Event ClientSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.ClientSizeChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")]
public event System.EventHandler ClientSizeChanged
Delphi
public event ClientSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")]
public: __event System.EventHandler* ClientSizeChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")]
public:
event System.EventHandler^ ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Close Method

[image]
Intersoft WebEssentials Documentation
Close Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Close Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.Close()
C#
public void Close()
Delphi
public procedure Close();
JScript
public function Close();
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Contains Method

[image]
Intersoft WebEssentials Documentation
Contains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Contains Method

ctl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ctl As System.Windows.Forms.Control _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim ctl As System.Windows.Forms.Control
Dim value As System.Boolean

value = instance.Contains(ctl)
C#
public System.bool Contains(
   System.Windows.Forms.Control ctl
)
Delphi
public function Contains(
    ctl: System.Windows.Forms.Control
): System.Boolean;
JScript
public function Contains(
   ctl : System.Windows.Forms.Control
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   System.Windows.Forms.Control* ctl
)
C++/CLI
public:
System.bool Contains(
   System.Windows.Forms.Control^ ctl
)

Parameters

ctl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ContextMenuStrip Property

[image]
Intersoft WebEssentials Documentation
ContextMenuStrip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ContextMenuStrip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")>
Public Overridable Property ContextMenuStrip As System.Windows.Forms.ContextMenuStrip
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.ContextMenuStrip

instance.ContextMenuStrip = value

value = instance.ContextMenuStrip
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}
Delphi
public read-write property ContextMenuStrip: System.Windows.Forms.ContextMenuStrip; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Behavior")
SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")
public function get,set ContextMenuStrip : System.Windows.Forms.ContextMenuStrip
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public: __property virtual System.Windows.Forms.ContextMenuStrip* get_ContextMenuStrip();
public: __property virtual void set_ContextMenuStrip(
   System.Windows.Forms.ContextMenuStrip* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public:
virtual property System.Windows.Forms.ContextMenuStrip^ ContextMenuStrip {
   System.Windows.Forms.ContextMenuStrip^ get();
   void set (    System.Windows.Forms.ContextMenuStrip^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ContextMenuStripChanged Event

[image]
Intersoft WebEssentials Documentation
ContextMenuStripChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ContextMenuStripChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event ContextMenuStripChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.ContextMenuStripChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler ContextMenuStripChanged
Delphi
public event ContextMenuStripChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* ContextMenuStripChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ControlAdded Event

[image]
Intersoft WebEssentials Documentation
ControlAdded Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ControlAdded Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a control is added to this control.")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event ControlAdded As System.Windows.Forms.ControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlAdded, handler
C#
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a control is added to this control.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event System.Windows.Forms.ControlEventHandler ControlAdded
Delphi
public event ControlAdded: System.Windows.Forms.ControlEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a control is added to this control.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event System.Windows.Forms.ControlEventHandler* ControlAdded
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a control is added to this control.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event System.Windows.Forms.ControlEventHandler^ ControlAdded

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ControlBox Property

[image]
Intersoft WebEssentials Documentation
ControlBox Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ControlBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")>
Public Property ControlBox As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.ControlBox = value

value = instance.ControlBox
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")]
public System.bool ControlBox {get; set;}
Delphi
public read-write property ControlBox: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")
public function get,set ControlBox : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")]
public: __property System.bool get_ControlBox();
public: __property void set_ControlBox(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")]
public:
property System.bool ControlBox {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ControlRemoved Event

[image]
Intersoft WebEssentials Documentation
ControlRemoved Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ControlRemoved Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a control is removed from this control.")>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.BrowsableAttribute(True)>
Public Event ControlRemoved As System.Windows.Forms.ControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlRemoved, handler
C#
[SRDescriptionAttribute("Occurs when a control is removed from this control.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(true)]
public event System.Windows.Forms.ControlEventHandler ControlRemoved
Delphi
public event ControlRemoved: System.Windows.Forms.ControlEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a control is removed from this control.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(true)]
public: __event System.Windows.Forms.ControlEventHandler* ControlRemoved
C++/CLI
[SRDescriptionAttribute("Occurs when a control is removed from this control.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(true)]
public:
event System.Windows.Forms.ControlEventHandler^ ControlRemoved

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


CreateControl Method

[image]
Intersoft WebEssentials Documentation
CreateControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : CreateControl Method

Glossary Item Box

Overload List

Overload | Description
CreateControl | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


CreateControl() Method

[image]
Intersoft WebEssentials Documentation
CreateControl() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : CreateControl() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.CreateControl()
C#
public void CreateControl()
Delphi
public procedure CreateControl();
JScript
public function CreateControl();
Managed Extensions for C++
public: void CreateControl();
C++/CLI
public:
void CreateControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


CreateGraphics Method

[image]
Intersoft WebEssentials Documentation
CreateGraphics Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : CreateGraphics Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As System.Drawing.Graphics
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Graphics

value = instance.CreateGraphics()
C#
public System.Drawing.Graphics CreateGraphics()
Delphi
public function CreateGraphics(): System.Drawing.Graphics;
JScript
public function CreateGraphics() : System.Drawing.Graphics;
Managed Extensions for C++
public: System.Drawing.Graphics* CreateGraphics();
C++/CLI
public:
System.Drawing.Graphics^ CreateGraphics();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


CreateObjRef Method

[image]
Intersoft WebEssentials Documentation
CreateObjRef Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : CreateObjRef Method

requestedType

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
[System.Security.SecurityCriticalAttribute()]
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: System.Type
): System.Runtime.Remoting.ObjRef; virtual;
JScript
System.Security.SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : System.Type
) : System.Runtime.Remoting.ObjRef;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
virtual System.Runtime.Remoting.ObjRef^ CreateObjRef(
   System.Type^ requestedType
)

Parameters

requestedType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Cursor Property

[image]
Intersoft WebEssentials Documentation
Cursor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Cursor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.AmbientValueAttribute()>
Public Overridable Property Cursor As System.Windows.Forms.Cursor
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.Cursor

instance.Cursor = value

value = instance.Cursor
C#
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.AmbientValueAttribute()]
public virtual System.Windows.Forms.Cursor Cursor {get; set;}
Delphi
public read-write property Cursor: System.Windows.Forms.Cursor; virtual;
JScript
SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")
SRCategoryAttribute("Appearance")
System.ComponentModel.AmbientValueAttribute()
public function get,set Cursor : System.Windows.Forms.Cursor
Managed Extensions for C++
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.AmbientValueAttribute()]
public: __property virtual System.Windows.Forms.Cursor* get_Cursor();
public: __property virtual void set_Cursor(
   System.Windows.Forms.Cursor* value
);
C++/CLI
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.AmbientValueAttribute()]
public:
virtual property System.Windows.Forms.Cursor^ Cursor {
   System.Windows.Forms.Cursor^ get();
   void set (    System.Windows.Forms.Cursor^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


CursorChanged Event

[image]
Intersoft WebEssentials Documentation
CursorChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : CursorChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event CursorChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.CursorChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler CursorChanged
Delphi
public event CursorChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* CursorChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


DataBindings Property

[image]
Intersoft WebEssentials Documentation
DataBindings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : DataBindings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)>
<SRDescriptionAttribute("The data bindings for the control.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<SRCategoryAttribute("Data")>
Public ReadOnly Property DataBindings As System.Windows.Forms.ControlBindingsCollection
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.ControlBindingsCollection

value = instance.DataBindings
C#
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)]
[SRDescriptionAttribute("The data bindings for the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[SRCategoryAttribute("Data")]
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}
Delphi
public read-only property DataBindings: System.Windows.Forms.ControlBindingsCollection;
JScript
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)
SRDescriptionAttribute("The data bindings for the control.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.ParenthesizePropertyNameAttribute()
SRCategoryAttribute("Data")
public function get DataBindings : System.Windows.Forms.ControlBindingsCollection
Managed Extensions for C++
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)]
[SRDescriptionAttribute("The data bindings for the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[SRCategoryAttribute("Data")]
public: __property System.Windows.Forms.ControlBindingsCollection* get_DataBindings();
C++/CLI
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)]
[SRDescriptionAttribute("The data bindings for the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[SRCategoryAttribute("Data")]
public:
property System.Windows.Forms.ControlBindingsCollection^ DataBindings {
   System.Windows.Forms.ControlBindingsCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Deactivate Event

[image]
Intersoft WebEssentials Documentation
Deactivate Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Deactivate Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Occurs whenever the form is deactivated.")>
Public Event Deactivate As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Deactivate, handler
C#
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is deactivated.")]
public event System.EventHandler Deactivate
Delphi
public event Deactivate: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is deactivated.")]
public: __event System.EventHandler* Deactivate
C++/CLI
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is deactivated.")]
public:
event System.EventHandler^ Deactivate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


DisplayRectangle Property

[image]
Intersoft WebEssentials Documentation
DisplayRectangle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : DisplayRectangle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DisplayRectangle As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Rectangle

value = instance.DisplayRectangle
C#
public virtual System.Drawing.Rectangle DisplayRectangle {get;}
Delphi
public read-only property DisplayRectangle: System.Drawing.Rectangle; virtual;
JScript
public function get DisplayRectangle : System.Drawing.Rectangle
Managed Extensions for C++
public: __property virtual System.Drawing.Rectangle get_DisplayRectangle();
C++/CLI
public:
virtual property System.Drawing.Rectangle DisplayRectangle {
   System.Drawing.Rectangle get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Dispose Method

[image]
Intersoft WebEssentials Documentation
Dispose Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Dispose Method

Glossary Item Box

Clean up any resources being used.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Dispose() Method

[image]
Intersoft WebEssentials Documentation
Dispose() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.Dispose()
C#
public void Dispose()
Delphi
public procedure Dispose();
JScript
public function Dispose();
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Dock Property

[image]
Intersoft WebEssentials Documentation
Dock Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Dock Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property Dock As System.Windows.Forms.DockStyle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.DockStyle

instance.Dock = value

value = instance.Dock
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Windows.Forms.DockStyle Dock {get; set;}
Delphi
public read-write property Dock: System.Windows.Forms.DockStyle; virtual;
JScript
SRCategoryAttribute("Layout")
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")
System.ComponentModel.DefaultValueAttribute()
public function get,set Dock : System.Windows.Forms.DockStyle
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Windows.Forms.DockStyle get_Dock();
public: __property virtual void set_Dock(
   System.Windows.Forms.DockStyle value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Windows.Forms.DockStyle Dock {
   System.Windows.Forms.DockStyle get();
   void set (    System.Windows.Forms.DockStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


DockChanged Event

[image]
Intersoft WebEssentials Documentation
DockChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : DockChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event DockChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.DockChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler DockChanged
Delphi
public event DockChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* DockChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


DoDragDrop Method

[image]
Intersoft WebEssentials Documentation
DoDragDrop Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : DoDragDrop Method

data
allowedEffects

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Function DoDragDrop( _
   ByVal data As System.Object, _
   ByVal allowedEffects As System.Windows.Forms.DragDropEffects _
) As System.Windows.Forms.DragDropEffects
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim data As System.Object
Dim allowedEffects As System.Windows.Forms.DragDropEffects
Dim value As System.Windows.Forms.DragDropEffects

value = instance.DoDragDrop(data, allowedEffects)
C#
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)
Delphi
public function DoDragDrop(
    data: System.TObject;
    allowedEffects: System.Windows.Forms.DragDropEffects
): System.Windows.Forms.DragDropEffects;
JScript
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=)
public function DoDragDrop(
   data : System.Object,
   allowedEffects : System.Windows.Forms.DragDropEffects
) : System.Windows.Forms.DragDropEffects;
Managed Extensions for C++
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: System.Windows.Forms.DragDropEffects DoDragDrop(
   System.Object* data,
   System.Windows.Forms.DragDropEffects allowedEffects
)
C++/CLI
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
System.Windows.Forms.DragDropEffects DoDragDrop(
   System.Object^ data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
allowedEffects

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


DoubleClick Event

[image]
Intersoft WebEssentials Documentation
DoubleClick Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : DoubleClick Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the component is double-clicked.")>
<SRCategoryAttribute("Action")>
Public Event DoubleClick As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.DoubleClick, handler
C#
[SRDescriptionAttribute("Occurs when the component is double-clicked.")]
[SRCategoryAttribute("Action")]
public event System.EventHandler DoubleClick
Delphi
public event DoubleClick: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the component is double-clicked.")]
[SRCategoryAttribute("Action")]
public: __event System.EventHandler* DoubleClick
C++/CLI
[SRDescriptionAttribute("Occurs when the component is double-clicked.")]
[SRCategoryAttribute("Action")]
public:
event System.EventHandler^ DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


DragDrop Event

[image]
Intersoft WebEssentials Documentation
DragDrop Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : DragDrop Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")>
<SRCategoryAttribute("Drag Drop")>
Public Event DragDrop As System.Windows.Forms.DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragDrop, handler
C#
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
[SRCategoryAttribute("Drag Drop")]
public event System.Windows.Forms.DragEventHandler DragDrop
Delphi
public event DragDrop: System.Windows.Forms.DragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
[SRCategoryAttribute("Drag Drop")]
public: __event System.Windows.Forms.DragEventHandler* DragDrop
C++/CLI
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
[SRCategoryAttribute("Drag Drop")]
public:
event System.Windows.Forms.DragEventHandler^ DragDrop

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


DragEnter Event

[image]
Intersoft WebEssentials Documentation
DragEnter Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : DragEnter Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")>
Public Event DragEnter As System.Windows.Forms.DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragEnter, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")]
public event System.Windows.Forms.DragEventHandler DragEnter
Delphi
public event DragEnter: System.Windows.Forms.DragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")]
public: __event System.Windows.Forms.DragEventHandler* DragEnter
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")]
public:
event System.Windows.Forms.DragEventHandler^ DragEnter

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


DragLeave Event

[image]
Intersoft WebEssentials Documentation
DragLeave Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : DragLeave Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")>
Public Event DragLeave As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.DragLeave, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")]
public event System.EventHandler DragLeave
Delphi
public event DragLeave: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")]
public: __event System.EventHandler* DragLeave
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")]
public:
event System.EventHandler^ DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


DragOver Event

[image]
Intersoft WebEssentials Documentation
DragOver Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : DragOver Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")>
Public Event DragOver As System.Windows.Forms.DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragOver, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")]
public event System.Windows.Forms.DragEventHandler DragOver
Delphi
public event DragOver: System.Windows.Forms.DragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")]
public: __event System.Windows.Forms.DragEventHandler* DragOver
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")]
public:
event System.Windows.Forms.DragEventHandler^ DragOver

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


DrawToBitmap Method

[image]
Intersoft WebEssentials Documentation
DrawToBitmap Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : DrawToBitmap Method

bitmap
targetBounds

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows Or  _
    UIPermissionWindow.SafeTopLevelWindows Or  _
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Sub DrawToBitmap( _
   ByVal bitmap As System.Drawing.Bitmap, _
   ByVal targetBounds As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim bitmap As System.Drawing.Bitmap
Dim targetBounds As System.Drawing.Rectangle

instance.DrawToBitmap(bitmap, targetBounds)
C#
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public void DrawToBitmap(
   System.Drawing.Bitmap bitmap,
   System.Drawing.Rectangle targetBounds
)
Delphi
public procedure DrawToBitmap(
    bitmap: System.Drawing.Bitmap;
    targetBounds: System.Drawing.Rectangle
);
JScript
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=)
public function DrawToBitmap(
   bitmap : System.Drawing.Bitmap,
   targetBounds : System.Drawing.Rectangle
);
Managed Extensions for C++
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void DrawToBitmap(
   System.Drawing.Bitmap* bitmap,
   System.Drawing.Rectangle targetBounds
)
C++/CLI
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void DrawToBitmap(
   System.Drawing.Bitmap^ bitmap,
   System.Drawing.Rectangle targetBounds
)

Parameters

bitmap
targetBounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the control is enabled.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Behavior")>
<System.Runtime.InteropServices.DispIdAttribute(-514)>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[System.Runtime.InteropServices.DispIdAttribute(-514)]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
SRDescriptionAttribute("Indicates whether the control is enabled.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Behavior")
System.Runtime.InteropServices.DispIdAttribute(-514)
public function get,set Enabled : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[System.Runtime.InteropServices.DispIdAttribute(-514)]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[System.Runtime.InteropServices.DispIdAttribute(-514)]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


EnabledChanged Event

[image]
Intersoft WebEssentials Documentation
EnabledChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : EnabledChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the control's enabled state changes.")>
Public Event EnabledChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.EnabledChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's enabled state changes.")]
public event System.EventHandler EnabledChanged
Delphi
public event EnabledChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's enabled state changes.")]
public: __event System.EventHandler* EnabledChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's enabled state changes.")]
public:
event System.EventHandler^ EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


EndInvoke Method

[image]
Intersoft WebEssentials Documentation
EndInvoke Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : EndInvoke Method

asyncResult

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Function EndInvoke( _
   ByVal asyncResult As System.IAsyncResult _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim asyncResult As System.IAsyncResult
Dim value As System.Object

value = instance.EndInvoke(asyncResult)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)
Delphi
public function EndInvoke(
    asyncResult: System.IAsyncResult
): System.TObject;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function EndInvoke(
   asyncResult : System.IAsyncResult
) : System.Object;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: System.Object* EndInvoke(
   System.IAsyncResult* asyncResult
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
System.Object^ EndInvoke(
   System.IAsyncResult^ asyncResult
)

Parameters

asyncResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Enter Event

[image]
Intersoft WebEssentials Documentation
Enter Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Enter Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")>
<SRCategoryAttribute("Focus")>
Public Event Enter As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Enter, handler
C#
[SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")]
[SRCategoryAttribute("Focus")]
public event System.EventHandler Enter
Delphi
public event Enter: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")]
[SRCategoryAttribute("Focus")]
public: __event System.EventHandler* Enter
C++/CLI
[SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")]
[SRCategoryAttribute("Focus")]
public:
event System.EventHandler^ Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


FindForm Method

[image]
Intersoft WebEssentials Documentation
FindForm Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : FindForm Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows Or  _
    UIPermissionWindow.SafeTopLevelWindows Or  _
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Function FindForm() As System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.Form

value = instance.FindForm()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public System.Windows.Forms.Form FindForm()
Delphi
public function FindForm(): System.Windows.Forms.Form;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=)
public function FindForm() : System.Windows.Forms.Form;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: System.Windows.Forms.Form* FindForm();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
System.Windows.Forms.Form^ FindForm();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Focus Method

[image]
Intersoft WebEssentials Documentation
Focus Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Function Focus() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

value = instance.Focus()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.bool Focus()
Delphi
public function Focus(): System.Boolean;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function Focus() : System.boolean;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: System.bool Focus();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
System.bool Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Font Property

[image]
Intersoft WebEssentials Documentation
Font Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.LocalizableAttribute(True)>
<System.Runtime.InteropServices.DispIdAttribute(-512)>
<SRDescriptionAttribute("The font used to display text in the control.")>
Public Overridable Property Font As System.Drawing.Font
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
[System.ComponentModel.AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.LocalizableAttribute(true)]
[System.Runtime.InteropServices.DispIdAttribute(-512)]
[SRDescriptionAttribute("The font used to display text in the control.")]
public virtual System.Drawing.Font Font {get; set;}
Delphi
public read-write property Font: System.Drawing.Font; virtual;
JScript
System.ComponentModel.AmbientValueAttribute()
SRCategoryAttribute("Appearance")
System.ComponentModel.LocalizableAttribute()
System.Runtime.InteropServices.DispIdAttribute(-512)
SRDescriptionAttribute("The font used to display text in the control.")
public function get,set Font : System.Drawing.Font
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.LocalizableAttribute(true)]
[System.Runtime.InteropServices.DispIdAttribute(-512)]
[SRDescriptionAttribute("The font used to display text in the control.")]
public: __property virtual System.Drawing.Font* get_Font();
public: __property virtual void set_Font(
   System.Drawing.Font* value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.LocalizableAttribute(true)]
[System.Runtime.InteropServices.DispIdAttribute(-512)]
[SRDescriptionAttribute("The font used to display text in the control.")]
public:
virtual property System.Drawing.Font^ Font {
   System.Drawing.Font^ get();
   void set (    System.Drawing.Font^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


FontChanged Event

[image]
Intersoft WebEssentials Documentation
FontChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : FontChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event FontChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.FontChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler FontChanged
Delphi
public event FontChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* FontChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ForeColor Property

[image]
Intersoft WebEssentials Documentation
ForeColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ForeColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The foreground color of this component, which is used to display text.")>
<System.Runtime.InteropServices.DispIdAttribute(-513)>
<SRCategoryAttribute("Appearance")>
Public Overridable Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
[System.Runtime.InteropServices.DispIdAttribute(-513)]
[SRCategoryAttribute("Appearance")]
public virtual System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; virtual;
JScript
SRDescriptionAttribute("The foreground color of this component, which is used to display text.")
System.Runtime.InteropServices.DispIdAttribute(-513)
SRCategoryAttribute("Appearance")
public function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
[System.Runtime.InteropServices.DispIdAttribute(-513)]
[SRCategoryAttribute("Appearance")]
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
C++/CLI
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
[System.Runtime.InteropServices.DispIdAttribute(-513)]
[SRCategoryAttribute("Appearance")]
public:
virtual property System.Drawing.Color ForeColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ForeColorChanged Event

[image]
Intersoft WebEssentials Documentation
ForeColorChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ForeColorChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")>
Public Event ForeColorChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.ForeColorChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")]
public event System.EventHandler ForeColorChanged
Delphi
public event ForeColorChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")]
public: __event System.EventHandler* ForeColorChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")]
public:
event System.EventHandler^ ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


FormBorderStyle Property

[image]
Intersoft WebEssentials Documentation
FormBorderStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : FormBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")>
<System.Runtime.InteropServices.DispIdAttribute(-504)>
<SRCategoryAttribute("Appearance")>
Public Property FormBorderStyle As System.Windows.Forms.FormBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.FormBorderStyle

instance.FormBorderStyle = value

value = instance.FormBorderStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[System.Runtime.InteropServices.DispIdAttribute(-504)]
[SRCategoryAttribute("Appearance")]
public System.Windows.Forms.FormBorderStyle FormBorderStyle {get; set;}
Delphi
public read-write property FormBorderStyle: System.Windows.Forms.FormBorderStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")
System.Runtime.InteropServices.DispIdAttribute(-504)
SRCategoryAttribute("Appearance")
public function get,set FormBorderStyle : System.Windows.Forms.FormBorderStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[System.Runtime.InteropServices.DispIdAttribute(-504)]
[SRCategoryAttribute("Appearance")]
public: __property System.Windows.Forms.FormBorderStyle get_FormBorderStyle();
public: __property void set_FormBorderStyle(
   System.Windows.Forms.FormBorderStyle value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[System.Runtime.InteropServices.DispIdAttribute(-504)]
[SRCategoryAttribute("Appearance")]
public:
property System.Windows.Forms.FormBorderStyle FormBorderStyle {
   System.Windows.Forms.FormBorderStyle get();
   void set (    System.Windows.Forms.FormBorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


FormClosed Event

[image]
Intersoft WebEssentials Documentation
FormClosed Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : FormClosed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")>
Public Event FormClosed As System.Windows.Forms.FormClosedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.FormClosedEventHandler

AddHandler instance.FormClosed, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")]
public event System.Windows.Forms.FormClosedEventHandler FormClosed
Delphi
public event FormClosed: System.Windows.Forms.FormClosedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")]
public: __event System.Windows.Forms.FormClosedEventHandler* FormClosed
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")]
public:
event System.Windows.Forms.FormClosedEventHandler^ FormClosed

Event Data

The event handler receives an argument of type System.Windows.Forms.FormClosedEventArgs containing data related to this event. The following FormClosedEventArgs properties provide information specific to this event.

Property | Description
CloseReason | Gets a value that indicates why the form was closed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


FormClosing Event

[image]
Intersoft WebEssentials Documentation
FormClosing Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : FormClosing Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")>
<SRCategoryAttribute("Behavior")>
Public Event FormClosing As System.Windows.Forms.FormClosingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.FormClosingEventHandler

AddHandler instance.FormClosing, handler
C#
[SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")]
[SRCategoryAttribute("Behavior")]
public event System.Windows.Forms.FormClosingEventHandler FormClosing
Delphi
public event FormClosing: System.Windows.Forms.FormClosingEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")]
[SRCategoryAttribute("Behavior")]
public: __event System.Windows.Forms.FormClosingEventHandler* FormClosing
C++/CLI
[SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")]
[SRCategoryAttribute("Behavior")]
public:
event System.Windows.Forms.FormClosingEventHandler^ FormClosing

Event Data

The event handler receives an argument of type System.Windows.Forms.FormClosingEventArgs containing data related to this event. The following FormClosingEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
CloseReason | Gets a value that indicates why the form is being closed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


GetChildAtPoint Method

[image]
Intersoft WebEssentials Documentation
GetChildAtPoint Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : GetChildAtPoint Method

Glossary Item Box

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


GetChildAtPoint(Point) Method

[image]
Intersoft WebEssentials Documentation
GetChildAtPoint(Point) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetChildAtPoint( _
   ByVal pt As System.Drawing.Point _
) As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim pt As System.Drawing.Point
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt
)
Delphi
public function GetChildAtPoint(
    pt: System.Drawing.Point
): System.Windows.Forms.Control;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetChildAtPoint(
   pt : System.Drawing.Point
) : System.Windows.Forms.Control;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Windows.Forms.Control* GetChildAtPoint(
   System.Drawing.Point pt
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Windows.Forms.Control^ GetChildAtPoint(
   System.Drawing.Point pt
)

Parameters

pt

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
Intersoft WebEssentials Documentation
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
skipValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As System.Drawing.Point, _
   ByVal skipValue As System.Windows.Forms.GetChildAtPointSkip _
) As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim pt As System.Drawing.Point
Dim skipValue As System.Windows.Forms.GetChildAtPointSkip
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt, skipValue)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)
Delphi
public function GetChildAtPoint(
    pt: System.Drawing.Point;
    skipValue: System.Windows.Forms.GetChildAtPointSkip
): System.Windows.Forms.Control;
JScript
public function GetChildAtPoint(
   pt : System.Drawing.Point,
   skipValue : System.Windows.Forms.GetChildAtPointSkip
) : System.Windows.Forms.Control;
Managed Extensions for C++
public: System.Windows.Forms.Control* GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)
C++/CLI
public:
System.Windows.Forms.Control^ GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
skipValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


GetContainerControl Method

[image]
Intersoft WebEssentials Documentation
GetContainerControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : GetContainerControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As System.Windows.Forms.IContainerControl
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.IContainerControl

value = instance.GetContainerControl()
C#
public System.Windows.Forms.IContainerControl GetContainerControl()
Delphi
public function GetContainerControl(): System.Windows.Forms.IContainerControl;
JScript
public function GetContainerControl() : System.Windows.Forms.IContainerControl;
Managed Extensions for C++
public: System.Windows.Forms.IContainerControl* GetContainerControl();
C++/CLI
public:
System.Windows.Forms.IContainerControl^ GetContainerControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


GetLifetimeService Method

[image]
Intersoft WebEssentials Documentation
GetLifetimeService Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : GetLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Function GetLifetimeService() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Object

value = instance.GetLifetimeService()
C#
[System.Security.SecurityCriticalAttribute()]
public System.object GetLifetimeService()
Delphi
public function GetLifetimeService(): System.TObject;
JScript
System.Security.SecurityCriticalAttribute()
public function GetLifetimeService() : System.Object;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: System.Object* GetLifetimeService();
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
System.Object^ GetLifetimeService();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


GetNextControl Method

[image]
Intersoft WebEssentials Documentation
GetNextControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : GetNextControl Method

ctl
forward

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean _
) As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim value As System.Windows.Forms.Control

value = instance.GetNextControl(ctl, forward)
C#
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)
Delphi
public function GetNextControl(
    ctl: System.Windows.Forms.Control;
    forward: System.Boolean
): System.Windows.Forms.Control;
JScript
public function GetNextControl(
   ctl : System.Windows.Forms.Control,
   forward : System.boolean
) : System.Windows.Forms.Control;
Managed Extensions for C++
public: System.Windows.Forms.Control* GetNextControl(
   System.Windows.Forms.Control* ctl,
   System.bool forward
)
C++/CLI
public:
System.Windows.Forms.Control^ GetNextControl(
   System.Windows.Forms.Control^ ctl,
   System.bool forward
)

Parameters

ctl
forward

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


GetPreferredSize Method

[image]
Intersoft WebEssentials Documentation
GetPreferredSize Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : GetPreferredSize Method

proposedSize

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As System.Drawing.Size _
) As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim proposedSize As System.Drawing.Size
Dim value As System.Drawing.Size

value = instance.GetPreferredSize(proposedSize)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)
Delphi
public function GetPreferredSize(
    proposedSize: System.Drawing.Size
): System.Drawing.Size; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function GetPreferredSize(
   proposedSize : System.Drawing.Size
) : System.Drawing.Size;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)

Parameters

proposedSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


GiveFeedback Event

[image]
Intersoft WebEssentials Documentation
GiveFeedback Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : GiveFeedback Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")>
Public Event GiveFeedback As System.Windows.Forms.GiveFeedbackEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.GiveFeedbackEventHandler

AddHandler instance.GiveFeedback, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")]
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback
Delphi
public event GiveFeedback: System.Windows.Forms.GiveFeedbackEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")]
public: __event System.Windows.Forms.GiveFeedbackEventHandler* GiveFeedback
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")]
public:
event System.Windows.Forms.GiveFeedbackEventHandler^ GiveFeedback

Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


HelpButton Property

[image]
Intersoft WebEssentials Documentation
HelpButton Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : HelpButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HelpButton As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.HelpButton = value

value = instance.HelpButton
C#
[SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool HelpButton {get; set;}
Delphi
public read-write property HelpButton: System.Boolean;
JScript
SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
public function get,set HelpButton : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_HelpButton();
public: __property void set_HelpButton(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool HelpButton {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


HelpButtonClicked Event

[image]
Intersoft WebEssentials Documentation
HelpButtonClicked Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : HelpButtonClicked Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the help button is clicked.")>
<System.ComponentModel.EditorBrowsableAttribute()>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.BrowsableAttribute(True)>
Public Event HelpButtonClicked As System.ComponentModel.CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.HelpButtonClicked, handler
C#
[SRDescriptionAttribute("Event raised when the help button is clicked.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(true)]
public event System.ComponentModel.CancelEventHandler HelpButtonClicked
Delphi
public event HelpButtonClicked: System.ComponentModel.CancelEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the help button is clicked.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(true)]
public: __event System.ComponentModel.CancelEventHandler* HelpButtonClicked
C++/CLI
[SRDescriptionAttribute("Event raised when the help button is clicked.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(true)]
public:
event System.ComponentModel.CancelEventHandler^ HelpButtonClicked

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


HelpRequested Event

[image]
Intersoft WebEssentials Documentation
HelpRequested Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : HelpRequested Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the user invokes Help for the control.")>
<SRCategoryAttribute("Behavior")>
Public Event HelpRequested As System.Windows.Forms.HelpEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.HelpEventHandler

AddHandler instance.HelpRequested, handler
C#
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
[SRCategoryAttribute("Behavior")]
public event System.Windows.Forms.HelpEventHandler HelpRequested
Delphi
public event HelpRequested: System.Windows.Forms.HelpEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
[SRCategoryAttribute("Behavior")]
public: __event System.Windows.Forms.HelpEventHandler* HelpRequested
C++/CLI
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
[SRCategoryAttribute("Behavior")]
public:
event System.Windows.Forms.HelpEventHandler^ HelpRequested

Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Hide Method

[image]
Intersoft WebEssentials Documentation
Hide Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Hide Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Sub Hide()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.Hide()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Hide()
Delphi
public procedure Hide();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Hide();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Hide();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Hide();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Icon Property

[image]
Intersoft WebEssentials Documentation
Icon Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Icon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Property Icon As System.Drawing.Icon
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Icon

instance.Icon = value

value = instance.Icon
C#
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.LocalizableAttribute(true)]
public System.Drawing.Icon Icon {get; set;}
Delphi
public read-write property Icon: System.Drawing.Icon;
JScript
System.ComponentModel.AmbientValueAttribute()
SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")
SRCategoryAttribute("Window Style")
System.ComponentModel.LocalizableAttribute()
public function get,set Icon : System.Drawing.Icon
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property System.Drawing.Icon* get_Icon();
public: __property void set_Icon(
   System.Drawing.Icon* value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
property System.Drawing.Icon^ Icon {
   System.Drawing.Icon^ get();
   void set (    System.Drawing.Icon^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ImeMode Property

[image]
Intersoft WebEssentials Documentation
ImeMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ImeMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Property ImeMode As System.Windows.Forms.ImeMode
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.ImeMode

instance.ImeMode = value

value = instance.ImeMode
C#
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.LocalizableAttribute(true)]
public System.Windows.Forms.ImeMode ImeMode {get; set;}
Delphi
public read-write property ImeMode: System.Windows.Forms.ImeMode;
JScript
System.ComponentModel.AmbientValueAttribute()
SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")
SRCategoryAttribute("Behavior")
System.ComponentModel.LocalizableAttribute()
public function get,set ImeMode : System.Windows.Forms.ImeMode
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property System.Windows.Forms.ImeMode get_ImeMode();
public: __property void set_ImeMode(
   System.Windows.Forms.ImeMode value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
property System.Windows.Forms.ImeMode ImeMode {
   System.Windows.Forms.ImeMode get();
   void set (    System.Windows.Forms.ImeMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ImeModeChanged Event

[image]
Intersoft WebEssentials Documentation
ImeModeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ImeModeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WinCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")>
Public Event ImeModeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.ImeModeChanged, handler
C#
[WinCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")]
public event System.EventHandler ImeModeChanged
Delphi
public event ImeModeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WinCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")]
public: __event System.EventHandler* ImeModeChanged
C++/CLI
[WinCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")]
public:
event System.EventHandler^ ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


InitializeLifetimeService Method

[image]
Intersoft WebEssentials Documentation
InitializeLifetimeService Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : InitializeLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Object

value = instance.InitializeLifetimeService()
C#
[System.Security.SecurityCriticalAttribute()]
public virtual System.object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): System.TObject; virtual;
JScript
System.Security.SecurityCriticalAttribute()
public function InitializeLifetimeService() : System.Object;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: virtual System.Object* InitializeLifetimeService();
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
virtual System.Object^ InitializeLifetimeService();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


InputLanguageChanged Event

[image]
Intersoft WebEssentials Documentation
InputLanguageChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : InputLanguageChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")>
<SRCategoryAttribute("Behavior")>
Public Event InputLanguageChanged As System.Windows.Forms.InputLanguageChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.InputLanguageChangedEventHandler

AddHandler instance.InputLanguageChanged, handler
C#
[SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")]
[SRCategoryAttribute("Behavior")]
public event System.Windows.Forms.InputLanguageChangedEventHandler InputLanguageChanged
Delphi
public event InputLanguageChanged: System.Windows.Forms.InputLanguageChangedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")]
[SRCategoryAttribute("Behavior")]
public: __event System.Windows.Forms.InputLanguageChangedEventHandler* InputLanguageChanged
C++/CLI
[SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")]
[SRCategoryAttribute("Behavior")]
public:
event System.Windows.Forms.InputLanguageChangedEventHandler^ InputLanguageChanged

Event Data

The event handler receives an argument of type System.Windows.Forms.InputLanguageChangedEventArgs containing data related to this event. The following InputLanguageChangedEventArgs properties provide information specific to this event.

Property | Description
CharSet | Gets the character set associated with the new input language.
Culture | Gets the locale of the input language.
InputLanguage | Gets a value indicating the input language.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


InputLanguageChanging Event

[image]
Intersoft WebEssentials Documentation
InputLanguageChanging Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : InputLanguageChanging Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")>
Public Event InputLanguageChanging As System.Windows.Forms.InputLanguageChangingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.InputLanguageChangingEventHandler

AddHandler instance.InputLanguageChanging, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")]
public event System.Windows.Forms.InputLanguageChangingEventHandler InputLanguageChanging
Delphi
public event InputLanguageChanging: System.Windows.Forms.InputLanguageChangingEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")]
public: __event System.Windows.Forms.InputLanguageChangingEventHandler* InputLanguageChanging
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")]
public:
event System.Windows.Forms.InputLanguageChangingEventHandler^ InputLanguageChanging

Event Data

The event handler receives an argument of type System.Windows.Forms.InputLanguageChangingEventArgs containing data related to this event. The following InputLanguageChangingEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
Culture | Gets the locale of the requested input language.
InputLanguage | Gets a value indicating the input language.
SysCharSet | Gets a value indicating whether the system default font supports the character set required for the requested input language.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Invalidate Method

[image]
Intersoft WebEssentials Documentation
Invalidate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Invalidate Method

Glossary Item Box

Overload List

Overload | Description
Invalidate(Region) | (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate() | (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Invalidate() Method

[image]
Intersoft WebEssentials Documentation
Invalidate() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Invalidate()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.Invalidate()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Invalidate()
Delphi
public procedure Invalidate();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invalidate();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Invalidate();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Invalidate();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


Invalidate(Boolean) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim invalidateChildren As System.Boolean

instance.Invalidate(invalidateChildren)
C#
public void Invalidate(
   System.bool invalidateChildren
)
Delphi
public procedure Invalidate(
    invalidateChildren: System.Boolean
);
JScript
public function Invalidate(
   invalidateChildren : System.boolean
);
Managed Extensions for C++
public: void Invalidate(
   System.bool invalidateChildren
)
C++/CLI
public:
void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


Invalidate(Rectangle) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Rectangle) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > Invalidate Method : Invalidate(Rectangle) Method

rc

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Invalidate( _
   ByVal rc As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim rc As System.Drawing.Rectangle

instance.Invalidate(rc)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Invalidate(
   System.Drawing.Rectangle rc
)
Delphi
public procedure Invalidate(
    rc: System.Drawing.Rectangle
);
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invalidate(
   rc : System.Drawing.Rectangle
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Invalidate(
   System.Drawing.Rectangle rc
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Invalidate(
   System.Drawing.Rectangle rc
)

Parameters

rc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Rectangle,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
invalidateChildren

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As System.Drawing.Rectangle, _
   ByVal invalidateChildren As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim rc As System.Drawing.Rectangle
Dim invalidateChildren As System.Boolean

instance.Invalidate(rc, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)
Delphi
public procedure Invalidate(
    rc: System.Drawing.Rectangle;
    invalidateChildren: System.Boolean
);
JScript
public function Invalidate(
   rc : System.Drawing.Rectangle,
   invalidateChildren : System.boolean
);
Managed Extensions for C++
public: void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)
C++/CLI
public:
void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
invalidateChildren

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


Invalidate(Region) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Region) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > Invalidate Method : Invalidate(Region) Method

region

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Invalidate( _
   ByVal region As System.Drawing.Region _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim region As System.Drawing.Region

instance.Invalidate(region)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Invalidate(
   System.Drawing.Region region
)
Delphi
public procedure Invalidate(
    region: System.Drawing.Region
);
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invalidate(
   region : System.Drawing.Region
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Invalidate(
   System.Drawing.Region* region
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Invalidate(
   System.Drawing.Region^ region
)

Parameters

region

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


Invalidate(Region,Boolean) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Region,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
invalidateChildren

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As System.Drawing.Region, _
   ByVal invalidateChildren As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim region As System.Drawing.Region
Dim invalidateChildren As System.Boolean

instance.Invalidate(region, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Region region,
   System.bool invalidateChildren
)
Delphi
public procedure Invalidate(
    region: System.Drawing.Region;
    invalidateChildren: System.Boolean
);
JScript
public function Invalidate(
   region : System.Drawing.Region,
   invalidateChildren : System.boolean
);
Managed Extensions for C++
public: void Invalidate(
   System.Drawing.Region* region,
   System.bool invalidateChildren
)
C++/CLI
public:
void Invalidate(
   System.Drawing.Region^ region,
   System.bool invalidateChildren
)

Parameters

region
invalidateChildren

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


Invoke Method

[image]
Intersoft WebEssentials Documentation
Invoke Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Invoke Method

Glossary Item Box

Overload List

Overload | Description
Invoke(Delegate) | (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Invoke(Delegate) Method

[image]
Intersoft WebEssentials Documentation
Invoke(Delegate) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > Invoke Method : Invoke(Delegate) Method

method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function Invoke( _
   ByVal method As System.Delegate _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim method As System.Delegate
Dim value As System.Object

value = instance.Invoke(method)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object Invoke(
   System.Delegate method
)
Delphi
public function Invoke(
    method: System.Delegate
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invoke(
   method : System.Delegate
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* Invoke(
   System.Delegate* method
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ Invoke(
   System.Delegate^ method
)

Parameters

method

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
Intersoft WebEssentials Documentation
Invoke(Delegate,Object[]) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.Object

value = instance.Invoke(method, args)
C#
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)
Delphi
public function Invoke(
    method: System.Delegate;
   params  args: System.TObjectarray of
): System.TObject;
JScript
public function Invoke(
   method : System.Delegate,
   args : System.Object[]
) : System.Object;
Managed Extensions for C++
public: System.Object* Invoke(
   System.Delegate* method,
   params System.Object*[]* args
)
C++/CLI
public:
System.Object^ Invoke(
   System.Delegate^ method,
   ... System.array<Object^>^ args
)

Parameters

method
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


IsMdiContainer Property

[image]
Intersoft WebEssentials Documentation
IsMdiContainer Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : IsMdiContainer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Determines whether the form is an MDI container.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property IsMdiContainer As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.IsMdiContainer = value

value = instance.IsMdiContainer
C#
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool IsMdiContainer {get; set;}
Delphi
public read-write property IsMdiContainer: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Determines whether the form is an MDI container.")
System.ComponentModel.DefaultValueAttribute()
public function get,set IsMdiContainer : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_IsMdiContainer();
public: __property void set_IsMdiContainer(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool IsMdiContainer {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


KeyDown Event

[image]
Intersoft WebEssentials Documentation
KeyDown Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : KeyDown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a key is first pressed.")>
<SRCategoryAttribute("Key")>
Public Event KeyDown As System.Windows.Forms.KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyDown, handler
C#
[SRDescriptionAttribute("Occurs when a key is first pressed.")]
[SRCategoryAttribute("Key")]
public event System.Windows.Forms.KeyEventHandler KeyDown
Delphi
public event KeyDown: System.Windows.Forms.KeyEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a key is first pressed.")]
[SRCategoryAttribute("Key")]
public: __event System.Windows.Forms.KeyEventHandler* KeyDown
C++/CLI
[SRDescriptionAttribute("Occurs when a key is first pressed.")]
[SRCategoryAttribute("Key")]
public:
event System.Windows.Forms.KeyEventHandler^ KeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


KeyPress Event

[image]
Intersoft WebEssentials Documentation
KeyPress Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : KeyPress Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Key")>
<SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")>
Public Event KeyPress As System.Windows.Forms.KeyPressEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.KeyPressEventHandler

AddHandler instance.KeyPress, handler
C#
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")]
public event System.Windows.Forms.KeyPressEventHandler KeyPress
Delphi
public event KeyPress: System.Windows.Forms.KeyPressEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")]
public: __event System.Windows.Forms.KeyPressEventHandler* KeyPress
C++/CLI
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")]
public:
event System.Windows.Forms.KeyPressEventHandler^ KeyPress

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


KeyPreview Property

[image]
Intersoft WebEssentials Documentation
KeyPreview Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : KeyPreview Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property KeyPreview As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.KeyPreview = value

value = instance.KeyPreview
C#
[SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool KeyPreview {get; set;}
Delphi
public read-write property KeyPreview: System.Boolean;
JScript
SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")
System.ComponentModel.DefaultValueAttribute()
public function get,set KeyPreview : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_KeyPreview();
public: __property void set_KeyPreview(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool KeyPreview {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


KeyUp Event

[image]
Intersoft WebEssentials Documentation
KeyUp Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : KeyUp Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a key is released.")>
<SRCategoryAttribute("Key")>
Public Event KeyUp As System.Windows.Forms.KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyUp, handler
C#
[SRDescriptionAttribute("Occurs when a key is released.")]
[SRCategoryAttribute("Key")]
public event System.Windows.Forms.KeyEventHandler KeyUp
Delphi
public event KeyUp: System.Windows.Forms.KeyEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a key is released.")]
[SRCategoryAttribute("Key")]
public: __event System.Windows.Forms.KeyEventHandler* KeyUp
C++/CLI
[SRDescriptionAttribute("Occurs when a key is released.")]
[SRCategoryAttribute("Key")]
public:
event System.Windows.Forms.KeyEventHandler^ KeyUp

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Layout Event

[image]
Intersoft WebEssentials Documentation
Layout Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Layout Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")>
Public Event Layout As System.Windows.Forms.LayoutEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.LayoutEventHandler

AddHandler instance.Layout, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")]
public event System.Windows.Forms.LayoutEventHandler Layout
Delphi
public event Layout: System.Windows.Forms.LayoutEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")]
public: __event System.Windows.Forms.LayoutEventHandler* Layout
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")]
public:
event System.Windows.Forms.LayoutEventHandler^ Layout

Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


LayoutMdi Method

[image]
Intersoft WebEssentials Documentation
LayoutMdi Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : LayoutMdi Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub LayoutMdi( _
   ByVal value As System.Windows.Forms.MdiLayout _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.MdiLayout

instance.LayoutMdi(value)
C#
public void LayoutMdi(
   System.Windows.Forms.MdiLayout value
)
Delphi
public procedure LayoutMdi(
    value: System.Windows.Forms.MdiLayout
);
JScript
public function LayoutMdi(
   value : System.Windows.Forms.MdiLayout
);
Managed Extensions for C++
public: void LayoutMdi(
   System.Windows.Forms.MdiLayout value
)
C++/CLI
public:
void LayoutMdi(
   System.Windows.Forms.MdiLayout value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Leave Event

[image]
Intersoft WebEssentials Documentation
Leave Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Leave Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")>
Public Event Leave As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Leave, handler
C#
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")]
public event System.EventHandler Leave
Delphi
public event Leave: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")]
public: __event System.EventHandler* Leave
C++/CLI
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")]
public:
event System.EventHandler^ Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Load Event

[image]
Intersoft WebEssentials Documentation
Load Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the user loads the form.")>
<SRCategoryAttribute("Behavior")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[SRDescriptionAttribute("Occurs whenever the user loads the form.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the user loads the form.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* Load
C++/CLI
[SRDescriptionAttribute("Occurs whenever the user loads the form.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Location Property

[image]
Intersoft WebEssentials Documentation
Location Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Location Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.SettingsBindableAttribute(True)>
Public Property Location As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
C#
[System.ComponentModel.SettingsBindableAttribute(true)]
public System.Drawing.Point Location {get; set;}
Delphi
public read-write property Location: System.Drawing.Point;
JScript
System.ComponentModel.SettingsBindableAttribute()
public function get,set Location : System.Drawing.Point
Managed Extensions for C++
[System.ComponentModel.SettingsBindableAttribute(true)]
public: __property System.Drawing.Point get_Location();
public: __property void set_Location(
   System.Drawing.Point value
);
C++/CLI
[System.ComponentModel.SettingsBindableAttribute(true)]
public:
property System.Drawing.Point Location {
   System.Drawing.Point get();
   void set (    System.Drawing.Point value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


LocationChanged Event

[image]
Intersoft WebEssentials Documentation
LocationChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : LocationChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")>
Public Event LocationChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.LocationChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")]
public event System.EventHandler LocationChanged
Delphi
public event LocationChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")]
public: __event System.EventHandler* LocationChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")]
public:
event System.EventHandler^ LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MainMenuStrip Property

[image]
Intersoft WebEssentials Documentation
MainMenuStrip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MainMenuStrip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")>
Public Property MainMenuStrip As System.Windows.Forms.MenuStrip
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.MenuStrip

instance.MainMenuStrip = value

value = instance.MainMenuStrip
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")]
public System.Windows.Forms.MenuStrip MainMenuStrip {get; set;}
Delphi
public read-write property MainMenuStrip: System.Windows.Forms.MenuStrip;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")
public function get,set MainMenuStrip : System.Windows.Forms.MenuStrip
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")]
public: __property System.Windows.Forms.MenuStrip* get_MainMenuStrip();
public: __property void set_MainMenuStrip(
   System.Windows.Forms.MenuStrip* value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")]
public:
property System.Windows.Forms.MenuStrip^ MainMenuStrip {
   System.Windows.Forms.MenuStrip^ get();
   void set (    System.Windows.Forms.MenuStrip^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MaximizeBox Property

[image]
Intersoft WebEssentials Documentation
MaximizeBox Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MaximizeBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MaximizeBox As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.MaximizeBox = value

value = instance.MaximizeBox
C#
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool MaximizeBox {get; set;}
Delphi
public read-write property MaximizeBox: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")
System.ComponentModel.DefaultValueAttribute()
public function get,set MaximizeBox : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_MaximizeBox();
public: __property void set_MaximizeBox(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool MaximizeBox {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MaximizedBoundsChanged Event

[image]
Intersoft WebEssentials Documentation
MaximizedBoundsChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MaximizedBoundsChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")>
<SRCategoryAttribute("Property Changed")>
Public Event MaximizedBoundsChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MaximizedBoundsChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler MaximizedBoundsChanged
Delphi
public event MaximizedBoundsChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* MaximizedBoundsChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ MaximizedBoundsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MaximumSize Property

[image]
Intersoft WebEssentials Documentation
MaximumSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MaximumSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("The maximum size the form can be resized to.")>
Public Overridable Property MaximumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The maximum size the form can be resized to.")]
public virtual System.Drawing.Size MaximumSize {get; set;}
Delphi
public read-write property MaximumSize: System.Drawing.Size; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
SRCategoryAttribute("Layout")
SRDescriptionAttribute("The maximum size the form can be resized to.")
public function get,set MaximumSize : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The maximum size the form can be resized to.")]
public: __property virtual System.Drawing.Size get_MaximumSize();
public: __property virtual void set_MaximumSize(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The maximum size the form can be resized to.")]
public:
virtual property System.Drawing.Size MaximumSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MaximumSizeChanged Event

[image]
Intersoft WebEssentials Documentation
MaximumSizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MaximumSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")>
Public Event MaximumSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MaximumSizeChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")]
public event System.EventHandler MaximumSizeChanged
Delphi
public event MaximumSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")]
public: __event System.EventHandler* MaximumSizeChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")]
public:
event System.EventHandler^ MaximumSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MdiChildActivate Event

[image]
Intersoft WebEssentials Documentation
MdiChildActivate Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MdiChildActivate Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when an MDI Child window is activated.")>
Public Event MdiChildActivate As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MdiChildActivate, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when an MDI Child window is activated.")]
public event System.EventHandler MdiChildActivate
Delphi
public event MdiChildActivate: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when an MDI Child window is activated.")]
public: __event System.EventHandler* MdiChildActivate
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when an MDI Child window is activated.")]
public:
event System.EventHandler^ MdiChildActivate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MinimizeBox Property

[image]
Intersoft WebEssentials Documentation
MinimizeBox Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MinimizeBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")>
Public Property MinimizeBox As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.MinimizeBox = value

value = instance.MinimizeBox
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public System.bool MinimizeBox {get; set;}
Delphi
public read-write property MinimizeBox: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")
public function get,set MinimizeBox : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public: __property System.bool get_MinimizeBox();
public: __property void set_MinimizeBox(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public:
property System.bool MinimizeBox {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MinimumSize Property

[image]
Intersoft WebEssentials Documentation
MinimumSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MinimumSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The minimum size the form can be resized to.")>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Overridable Property MinimumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
[SRDescriptionAttribute("The minimum size the form can be resized to.")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
public virtual System.Drawing.Size MinimumSize {get; set;}
Delphi
public read-write property MinimumSize: System.Drawing.Size; virtual;
JScript
SRDescriptionAttribute("The minimum size the form can be resized to.")
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
SRCategoryAttribute("Layout")
System.ComponentModel.LocalizableAttribute()
public function get,set MinimumSize : System.Drawing.Size
Managed Extensions for C++
[SRDescriptionAttribute("The minimum size the form can be resized to.")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property virtual System.Drawing.Size get_MinimumSize();
public: __property virtual void set_MinimumSize(
   System.Drawing.Size value
);
C++/CLI
[SRDescriptionAttribute("The minimum size the form can be resized to.")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
virtual property System.Drawing.Size MinimumSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MinimumSizeChanged Event

[image]
Intersoft WebEssentials Documentation
MinimumSizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MinimumSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")>
<SRCategoryAttribute("Property Changed")>
Public Event MinimumSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MinimumSizeChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler MinimumSizeChanged
Delphi
public event MinimumSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* MinimumSizeChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ MinimumSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MouseCaptureChanged Event

[image]
Intersoft WebEssentials Documentation
MouseCaptureChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MouseCaptureChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs after the mouse capture is changed.")>
<SRCategoryAttribute("Action")>
Public Event MouseCaptureChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MouseCaptureChanged, handler
C#
[SRDescriptionAttribute("Occurs after the mouse capture is changed.")]
[SRCategoryAttribute("Action")]
public event System.EventHandler MouseCaptureChanged
Delphi
public event MouseCaptureChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs after the mouse capture is changed.")]
[SRCategoryAttribute("Action")]
public: __event System.EventHandler* MouseCaptureChanged
C++/CLI
[SRDescriptionAttribute("Occurs after the mouse capture is changed.")]
[SRCategoryAttribute("Action")]
public:
event System.EventHandler^ MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MouseClick Event

[image]
Intersoft WebEssentials Documentation
MouseClick Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MouseClick Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")>
<SRCategoryAttribute("Action")>
Public Event MouseClick As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseClick, handler
C#
[SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")]
[SRCategoryAttribute("Action")]
public event System.Windows.Forms.MouseEventHandler MouseClick
Delphi
public event MouseClick: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")]
[SRCategoryAttribute("Action")]
public: __event System.Windows.Forms.MouseEventHandler* MouseClick
C++/CLI
[SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")]
[SRCategoryAttribute("Action")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MouseDoubleClick Event

[image]
Intersoft WebEssentials Documentation
MouseDoubleClick Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MouseDoubleClick Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")>
Public Event MouseDoubleClick As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDoubleClick, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")]
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick
Delphi
public event MouseDoubleClick: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")]
public: __event System.Windows.Forms.MouseEventHandler* MouseDoubleClick
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseDoubleClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MouseDown Event

[image]
Intersoft WebEssentials Documentation
MouseDown Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MouseDown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseDown As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDown, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")]
[SRCategoryAttribute("Mouse")]
public event System.Windows.Forms.MouseEventHandler MouseDown
Delphi
public event MouseDown: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")]
[SRCategoryAttribute("Mouse")]
public: __event System.Windows.Forms.MouseEventHandler* MouseDown
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")]
[SRCategoryAttribute("Mouse")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseDown

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MouseEnter Event

[image]
Intersoft WebEssentials Documentation
MouseEnter Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MouseEnter Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseEnter As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MouseEnter, handler
C#
[SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")]
[SRCategoryAttribute("Mouse")]
public event System.EventHandler MouseEnter
Delphi
public event MouseEnter: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")]
[SRCategoryAttribute("Mouse")]
public: __event System.EventHandler* MouseEnter
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")]
[SRCategoryAttribute("Mouse")]
public:
event System.EventHandler^ MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MouseHover Event

[image]
Intersoft WebEssentials Documentation
MouseHover Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MouseHover Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")>
Public Event MouseHover As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MouseHover, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")]
public event System.EventHandler MouseHover
Delphi
public event MouseHover: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")]
public: __event System.EventHandler* MouseHover
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")]
public:
event System.EventHandler^ MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MouseLeave Event

[image]
Intersoft WebEssentials Documentation
MouseLeave Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MouseLeave Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")>
Public Event MouseLeave As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MouseLeave, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")]
public event System.EventHandler MouseLeave
Delphi
public event MouseLeave: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")]
public: __event System.EventHandler* MouseLeave
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")]
public:
event System.EventHandler^ MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MouseMove Event

[image]
Intersoft WebEssentials Documentation
MouseMove Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MouseMove Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseMove As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseMove, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")]
[SRCategoryAttribute("Mouse")]
public event System.Windows.Forms.MouseEventHandler MouseMove
Delphi
public event MouseMove: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")]
[SRCategoryAttribute("Mouse")]
public: __event System.Windows.Forms.MouseEventHandler* MouseMove
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")]
[SRCategoryAttribute("Mouse")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseMove

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


MouseUp Event

[image]
Intersoft WebEssentials Documentation
MouseUp Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : MouseUp Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseUp As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseUp, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")]
[SRCategoryAttribute("Mouse")]
public event System.Windows.Forms.MouseEventHandler MouseUp
Delphi
public event MouseUp: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")]
[SRCategoryAttribute("Mouse")]
public: __event System.Windows.Forms.MouseEventHandler* MouseUp
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")]
[SRCategoryAttribute("Mouse")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseUp

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Move Event

[image]
Intersoft WebEssentials Documentation
Move Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Move Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when a control is moved.")>
Public Event Move As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Move, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when a control is moved.")]
public event System.EventHandler Move
Delphi
public event Move: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when a control is moved.")]
public: __event System.EventHandler* Move
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when a control is moved.")]
public:
event System.EventHandler^ Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Opacity Property

[image]
Intersoft WebEssentials Documentation
Opacity Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Opacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("The opacity percentage of the control. ")>
<System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property Opacity As System.Double
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Double

instance.Opacity = value

value = instance.Opacity
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The opacity percentage of the control. ")]
[System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public System.double Opacity {get; set;}
Delphi
public read-write property Opacity: System.Double;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("The opacity percentage of the control. ")
System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set Opacity : System.double
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The opacity percentage of the control. ")]
[System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property System.double get_Opacity();
public: __property void set_Opacity(
   System.double value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The opacity percentage of the control. ")]
[System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property System.double Opacity {
   System.double get();
   void set (    System.double value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Padding Property

[image]
Intersoft WebEssentials Documentation
Padding Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Padding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Specifies the interior spacing of a control.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
Public Property Padding As System.Windows.Forms.Padding
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.Padding

instance.Padding = value

value = instance.Padding
C#
[SRDescriptionAttribute("Specifies the interior spacing of a control.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public System.Windows.Forms.Padding Padding {get; set;}
Delphi
public read-write property Padding: System.Windows.Forms.Padding;
JScript
SRDescriptionAttribute("Specifies the interior spacing of a control.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Layout")
public function get,set Padding : System.Windows.Forms.Padding
Managed Extensions for C++
[SRDescriptionAttribute("Specifies the interior spacing of a control.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public: __property System.Windows.Forms.Padding get_Padding();
public: __property void set_Padding(
   System.Windows.Forms.Padding value
);
C++/CLI
[SRDescriptionAttribute("Specifies the interior spacing of a control.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public:
property System.Windows.Forms.Padding Padding {
   System.Windows.Forms.Padding get();
   void set (    System.Windows.Forms.Padding value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


PaddingChanged Event

[image]
Intersoft WebEssentials Documentation
PaddingChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : PaddingChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when the Padding property has changed.")>
Public Event PaddingChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.PaddingChanged, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the Padding property has changed.")]
public event System.EventHandler PaddingChanged
Delphi
public event PaddingChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the Padding property has changed.")]
public: __event System.EventHandler* PaddingChanged
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the Padding property has changed.")]
public:
event System.EventHandler^ PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Paint Event

[image]
Intersoft WebEssentials Documentation
Paint Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Paint Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a control needs repainting.")>
<SRCategoryAttribute("Appearance")>
Public Event Paint As System.Windows.Forms.PaintEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.PaintEventHandler

AddHandler instance.Paint, handler
C#
[SRDescriptionAttribute("Occurs when a control needs repainting.")]
[SRCategoryAttribute("Appearance")]
public event System.Windows.Forms.PaintEventHandler Paint
Delphi
public event Paint: System.Windows.Forms.PaintEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a control needs repainting.")]
[SRCategoryAttribute("Appearance")]
public: __event System.Windows.Forms.PaintEventHandler* Paint
C++/CLI
[SRDescriptionAttribute("Occurs when a control needs repainting.")]
[SRCategoryAttribute("Appearance")]
public:
event System.Windows.Forms.PaintEventHandler^ Paint

Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ParentChanged Event

[image]
Intersoft WebEssentials Documentation
ParentChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ParentChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")>
Public Event ParentChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.ParentChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public event System.EventHandler ParentChanged
Delphi
public event ParentChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public: __event System.EventHandler* ParentChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public:
event System.EventHandler^ ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


PerformAutoScale Method

[image]
Intersoft WebEssentials Documentation
PerformAutoScale Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : PerformAutoScale Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Sub PerformAutoScale()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.PerformAutoScale()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void PerformAutoScale()
Delphi
public procedure PerformAutoScale();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function PerformAutoScale();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void PerformAutoScale();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void PerformAutoScale();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


PerformLayout Method

[image]
Intersoft WebEssentials Documentation
PerformLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : PerformLayout Method

Glossary Item Box

Overload List

Overload | Description
PerformLayout() | (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


PerformLayout() Method

[image]
Intersoft WebEssentials Documentation
PerformLayout() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Sub PerformLayout()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.PerformLayout()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void PerformLayout()
Delphi
public procedure PerformLayout();
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function PerformLayout();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void PerformLayout();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void PerformLayout();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


PerformLayout(Control,String) Method

[image]
Intersoft WebEssentials Documentation
PerformLayout(Control,String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
affectedProperty

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As System.Windows.Forms.Control, _
   ByVal affectedProperty As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim affectedControl As System.Windows.Forms.Control
Dim affectedProperty As System.String

instance.PerformLayout(affectedControl, affectedProperty)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)
Delphi
public procedure PerformLayout(
    affectedControl: System.Windows.Forms.Control;
    affectedProperty: System.String
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function PerformLayout(
   affectedControl : System.Windows.Forms.Control,
   affectedProperty : System.String
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void PerformLayout(
   System.Windows.Forms.Control* affectedControl,
   System.string* affectedProperty
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void PerformLayout(
   System.Windows.Forms.Control^ affectedControl,
   System.String^ affectedProperty
)

Parameters

affectedControl
affectedProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


PointToClient Method

[image]
Intersoft WebEssentials Documentation
PointToClient Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : PointToClient Method

p

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Function PointToClient( _
   ByVal p As System.Drawing.Point _
) As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToClient(p)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Drawing.Point PointToClient(
   System.Drawing.Point p
)
Delphi
public function PointToClient(
    p: System.Drawing.Point
): System.Drawing.Point;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function PointToClient(
   p : System.Drawing.Point
) : System.Drawing.Point;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Drawing.Point PointToClient(
   System.Drawing.Point p
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Drawing.Point PointToClient(
   System.Drawing.Point p
)

Parameters

p

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


PointToScreen Method

[image]
Intersoft WebEssentials Documentation
PointToScreen Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : PointToScreen Method

p

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As System.Drawing.Point _
) As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToScreen(p)
C#
public System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)
Delphi
public function PointToScreen(
    p: System.Drawing.Point
): System.Drawing.Point;
JScript
public function PointToScreen(
   p : System.Drawing.Point
) : System.Drawing.Point;
Managed Extensions for C++
public: System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)
C++/CLI
public:
System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)

Parameters

p

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


PreProcessControlMessage Method

[image]
Intersoft WebEssentials Documentation
PreProcessControlMessage Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : PreProcessControlMessage Method

msg

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
Public Function PreProcessControlMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Windows.Forms.PreProcessControlState
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim msg As System.Windows.Forms.Message
Dim value As System.Windows.Forms.PreProcessControlState

value = instance.PreProcessControlMessage(msg)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)
Delphi
public function PreProcessControlMessage(
   var  msg: System.Windows.Forms.Message
): System.Windows.Forms.PreProcessControlState;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
public function PreProcessControlMessage(
   msg : System.Windows.Forms.Message
) : System.Windows.Forms.PreProcessControlState;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public: System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public:
System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   System.Windows.Forms.Message% msg
)

Parameters

msg

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


PreProcessMessage Method

[image]
Intersoft WebEssentials Documentation
PreProcessMessage Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : PreProcessMessage Method

msg

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Overridable Function PreProcessMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim msg As System.Windows.Forms.Message
Dim value As System.Boolean

value = instance.PreProcessMessage(msg)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)
Delphi
public function PreProcessMessage(
   var  msg: System.Windows.Forms.Message
): System.Boolean; virtual;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public function PreProcessMessage(
   msg : System.Windows.Forms.Message
) : System.boolean;
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public: virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public:
virtual System.bool PreProcessMessage(
   System.Windows.Forms.Message% msg
)

Parameters

msg

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


PreviewKeyDown Event

[image]
Intersoft WebEssentials Documentation
PreviewKeyDown Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : PreviewKeyDown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Key")>
<SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")>
Public Event PreviewKeyDown As System.Windows.Forms.PreviewKeyDownEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.PreviewKeyDownEventHandler

AddHandler instance.PreviewKeyDown, handler
C#
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")]
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown
Delphi
public event PreviewKeyDown: System.Windows.Forms.PreviewKeyDownEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")]
public: __event System.Windows.Forms.PreviewKeyDownEventHandler* PreviewKeyDown
C++/CLI
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")]
public:
event System.Windows.Forms.PreviewKeyDownEventHandler^ PreviewKeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


QueryAccessibilityHelp Event

[image]
Intersoft WebEssentials Documentation
QueryAccessibilityHelp Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : QueryAccessibilityHelp Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")>
Public Event QueryAccessibilityHelp As System.Windows.Forms.QueryAccessibilityHelpEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.QueryAccessibilityHelpEventHandler

AddHandler instance.QueryAccessibilityHelp, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")]
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp
Delphi
public event QueryAccessibilityHelp: System.Windows.Forms.QueryAccessibilityHelpEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")]
public: __event System.Windows.Forms.QueryAccessibilityHelpEventHandler* QueryAccessibilityHelp
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")]
public:
event System.Windows.Forms.QueryAccessibilityHelpEventHandler^ QueryAccessibilityHelp

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


QueryContinueDrag Event

[image]
Intersoft WebEssentials Documentation
QueryContinueDrag Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : QueryContinueDrag Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")>
<SRCategoryAttribute("Drag Drop")>
Public Event QueryContinueDrag As System.Windows.Forms.QueryContinueDragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.QueryContinueDragEventHandler

AddHandler instance.QueryContinueDrag, handler
C#
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")]
[SRCategoryAttribute("Drag Drop")]
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag
Delphi
public event QueryContinueDrag: System.Windows.Forms.QueryContinueDragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")]
[SRCategoryAttribute("Drag Drop")]
public: __event System.Windows.Forms.QueryContinueDragEventHandler* QueryContinueDrag
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")]
[SRCategoryAttribute("Drag Drop")]
public:
event System.Windows.Forms.QueryContinueDragEventHandler^ QueryContinueDrag

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


RectangleToClient Method

[image]
Intersoft WebEssentials Documentation
RectangleToClient Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : RectangleToClient Method

r

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As System.Drawing.Rectangle _
) As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToClient(r)
C#
public System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)
Delphi
public function RectangleToClient(
    r: System.Drawing.Rectangle
): System.Drawing.Rectangle;
JScript
public function RectangleToClient(
   r : System.Drawing.Rectangle
) : System.Drawing.Rectangle;
Managed Extensions for C++
public: System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)
C++/CLI
public:
System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)

Parameters

r

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


RectangleToScreen Method

[image]
Intersoft WebEssentials Documentation
RectangleToScreen Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : RectangleToScreen Method

r

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As System.Drawing.Rectangle _
) As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToScreen(r)
C#
public System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)
Delphi
public function RectangleToScreen(
    r: System.Drawing.Rectangle
): System.Drawing.Rectangle;
JScript
public function RectangleToScreen(
   r : System.Drawing.Rectangle
) : System.Drawing.Rectangle;
Managed Extensions for C++
public: System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)
C++/CLI
public:
System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)

Parameters

r

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Refresh Method

[image]
Intersoft WebEssentials Documentation
Refresh Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Refresh Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.Refresh()
C#
public virtual void Refresh()
Delphi
public procedure Refresh(); virtual;
JScript
public function Refresh();
Managed Extensions for C++
public: virtual void Refresh();
C++/CLI
public:
virtual void Refresh();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


RegionChanged Event

[image]
Intersoft WebEssentials Documentation
RegionChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : RegionChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event RegionChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.RegionChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler RegionChanged
Delphi
public event RegionChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* RegionChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


RemoveOwnedForm Method

[image]
Intersoft WebEssentials Documentation
RemoveOwnedForm Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : RemoveOwnedForm Method

ownedForm

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RemoveOwnedForm( _
   ByVal ownedForm As System.Windows.Forms.Form _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim ownedForm As System.Windows.Forms.Form

instance.RemoveOwnedForm(ownedForm)
C#
public void RemoveOwnedForm(
   System.Windows.Forms.Form ownedForm
)
Delphi
public procedure RemoveOwnedForm(
    ownedForm: System.Windows.Forms.Form
);
JScript
public function RemoveOwnedForm(
   ownedForm : System.Windows.Forms.Form
);
Managed Extensions for C++
public: void RemoveOwnedForm(
   System.Windows.Forms.Form* ownedForm
)
C++/CLI
public:
void RemoveOwnedForm(
   System.Windows.Forms.Form^ ownedForm
)

Parameters

ownedForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ResetText Method

[image]
Intersoft WebEssentials Documentation
ResetText Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ResetText Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetText()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.ResetText()
C#
public virtual void ResetText()
Delphi
public procedure ResetText(); virtual;
JScript
public function ResetText();
Managed Extensions for C++
public: virtual void ResetText();
C++/CLI
public:
virtual void ResetText();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Resize Event

[image]
Intersoft WebEssentials Documentation
Resize Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Resize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Occurs when a control is resized.")>
Public Event Resize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Resize, handler
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when a control is resized.")]
public event System.EventHandler Resize
Delphi
public event Resize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when a control is resized.")]
public: __event System.EventHandler* Resize
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when a control is resized.")]
public:
event System.EventHandler^ Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ResizeBegin Event

[image]
Intersoft WebEssentials Documentation
ResizeBegin Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ResizeBegin Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")>
<SRCategoryAttribute("Action")>
Public Event ResizeBegin As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.ResizeBegin, handler
C#
[SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")]
[SRCategoryAttribute("Action")]
public event System.EventHandler ResizeBegin
Delphi
public event ResizeBegin: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")]
[SRCategoryAttribute("Action")]
public: __event System.EventHandler* ResizeBegin
C++/CLI
[SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")]
[SRCategoryAttribute("Action")]
public:
event System.EventHandler^ ResizeBegin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ResizeEnd Event

[image]
Intersoft WebEssentials Documentation
ResizeEnd Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ResizeEnd Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")>
Public Event ResizeEnd As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.ResizeEnd, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")]
public event System.EventHandler ResizeEnd
Delphi
public event ResizeEnd: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")]
public: __event System.EventHandler* ResizeEnd
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")]
public:
event System.EventHandler^ ResizeEnd

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ResumeLayout Method

[image]
Intersoft WebEssentials Documentation
ResumeLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ResumeLayout Method

Glossary Item Box

Overload List

Overload | Description
ResumeLayout() | (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ResumeLayout() Method

[image]
Intersoft WebEssentials Documentation
ResumeLayout() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub ResumeLayout()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.ResumeLayout()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void ResumeLayout()
Delphi
public procedure ResumeLayout();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ResumeLayout();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void ResumeLayout();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void ResumeLayout();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


ResumeLayout(Boolean) Method

[image]
Intersoft WebEssentials Documentation
ResumeLayout(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim performLayout As System.Boolean

instance.ResumeLayout(performLayout)
C#
public void ResumeLayout(
   System.bool performLayout
)
Delphi
public procedure ResumeLayout(
    performLayout: System.Boolean
);
JScript
public function ResumeLayout(
   performLayout : System.boolean
);
Managed Extensions for C++
public: void ResumeLayout(
   System.bool performLayout
)
C++/CLI
public:
void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


RightToLeft Property

[image]
Intersoft WebEssentials Documentation
RightToLeft Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : RightToLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")>
Public Overridable Property RightToLeft As System.Windows.Forms.RightToLeft
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
C#
[System.ComponentModel.AmbientValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}
Delphi
public read-write property RightToLeft: System.Windows.Forms.RightToLeft; virtual;
JScript
System.ComponentModel.AmbientValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Appearance")
SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")
public function get,set RightToLeft : System.Windows.Forms.RightToLeft
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
public: __property virtual System.Windows.Forms.RightToLeft get_RightToLeft();
public: __property virtual void set_RightToLeft(
   System.Windows.Forms.RightToLeft value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
public:
virtual property System.Windows.Forms.RightToLeft RightToLeft {
   System.Windows.Forms.RightToLeft get();
   void set (    System.Windows.Forms.RightToLeft value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


RightToLeftChanged Event

[image]
Intersoft WebEssentials Documentation
RightToLeftChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : RightToLeftChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event RightToLeftChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.RightToLeftChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler RightToLeftChanged
Delphi
public event RightToLeftChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* RightToLeftChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


RightToLeftLayout Property

[image]
Intersoft WebEssentials Documentation
RightToLeftLayout Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : RightToLeftLayout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")>
Public Overridable Property RightToLeftLayout As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.RightToLeftLayout = value

value = instance.RightToLeftLayout
C#
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")]
public virtual System.bool RightToLeftLayout {get; set;}
Delphi
public read-write property RightToLeftLayout: System.Boolean; virtual;
JScript
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")
public function get,set RightToLeftLayout : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")]
public: __property virtual System.bool get_RightToLeftLayout();
public: __property virtual void set_RightToLeftLayout(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")]
public:
virtual property System.bool RightToLeftLayout {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


RightToLeftLayoutChanged Event

[image]
Intersoft WebEssentials Documentation
RightToLeftLayoutChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : RightToLeftLayoutChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event RightToLeftLayoutChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.RightToLeftLayoutChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler RightToLeftLayoutChanged
Delphi
public event RightToLeftLayoutChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* RightToLeftLayoutChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ RightToLeftLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Scale Method

[image]
Intersoft WebEssentials Documentation
Scale Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Scale Method

Glossary Item Box

Overload List

Overload | Description
Scale | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Scale(SizeF) Method

[image]
Intersoft WebEssentials Documentation
Scale(SizeF) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > Scale Method : Scale(SizeF) Method

factor

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Sub Scale( _
   ByVal factor As System.Drawing.SizeF _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim factor As System.Drawing.SizeF

instance.Scale(factor)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void Scale(
   System.Drawing.SizeF factor
)
Delphi
public procedure Scale(
    factor: System.Drawing.SizeF
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function Scale(
   factor : System.Drawing.SizeF
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void Scale(
   System.Drawing.SizeF factor
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void Scale(
   System.Drawing.SizeF factor
)

Parameters

factor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


Scroll Event

[image]
Intersoft WebEssentials Documentation
Scroll Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Scroll Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the user moves the scroll box.")>
Public Event Scroll As System.Windows.Forms.ScrollEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.Windows.Forms.ScrollEventHandler

AddHandler instance.Scroll, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user moves the scroll box.")]
public event System.Windows.Forms.ScrollEventHandler Scroll
Delphi
public event Scroll: System.Windows.Forms.ScrollEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user moves the scroll box.")]
public: __event System.Windows.Forms.ScrollEventHandler* Scroll
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user moves the scroll box.")]
public:
event System.Windows.Forms.ScrollEventHandler^ Scroll

Event Data

The event handler receives an argument of type System.Windows.Forms.ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ScrollControlIntoView Method

[image]
Intersoft WebEssentials Documentation
ScrollControlIntoView Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ScrollControlIntoView Method

activeControl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ScrollControlIntoView( _
   ByVal activeControl As System.Windows.Forms.Control _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim activeControl As System.Windows.Forms.Control

instance.ScrollControlIntoView(activeControl)
C#
public void ScrollControlIntoView(
   System.Windows.Forms.Control activeControl
)
Delphi
public procedure ScrollControlIntoView(
    activeControl: System.Windows.Forms.Control
);
JScript
public function ScrollControlIntoView(
   activeControl : System.Windows.Forms.Control
);
Managed Extensions for C++
public: void ScrollControlIntoView(
   System.Windows.Forms.Control* activeControl
)
C++/CLI
public:
void ScrollControlIntoView(
   System.Windows.Forms.Control^ activeControl
)

Parameters

activeControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Select Method

[image]
Intersoft WebEssentials Documentation
Select Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Select Method

Glossary Item Box

Overload List

Overload | Description
Select | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Select() Method

[image]
Intersoft WebEssentials Documentation
Select() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Select() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Sub Select()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.Select()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Select()
Delphi
public procedure Select();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Select();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Select();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Select();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


SelectNextControl Method

[image]
Intersoft WebEssentials Documentation
SelectNextControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : SelectNextControl Method

ctl
forward
tabStopOnly
nested
wrap

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean, _
   ByVal tabStopOnly As System.Boolean, _
   ByVal nested As System.Boolean, _
   ByVal wrap As System.Boolean _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim tabStopOnly As System.Boolean
Dim nested As System.Boolean
Dim wrap As System.Boolean
Dim value As System.Boolean

value = instance.SelectNextControl(ctl, forward, tabStopOnly, nested, wrap)
C#
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)
Delphi
public function SelectNextControl(
    ctl: System.Windows.Forms.Control;
    forward: System.Boolean;
    tabStopOnly: System.Boolean;
    nested: System.Boolean;
    wrap: System.Boolean
): System.Boolean;
JScript
public function SelectNextControl(
   ctl : System.Windows.Forms.Control,
   forward : System.boolean,
   tabStopOnly : System.boolean,
   nested : System.boolean,
   wrap : System.boolean
) : System.boolean;
Managed Extensions for C++
public: System.bool SelectNextControl(
   System.Windows.Forms.Control* ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)
C++/CLI
public:
System.bool SelectNextControl(
   System.Windows.Forms.Control^ ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
forward
tabStopOnly
nested
wrap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


SendToBack Method

[image]
Intersoft WebEssentials Documentation
SendToBack Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : SendToBack Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.SendToBack()
C#
public void SendToBack()
Delphi
public procedure SendToBack();
JScript
public function SendToBack();
Managed Extensions for C++
public: void SendToBack();
C++/CLI
public:
void SendToBack();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


SetAutoScrollMargin Method

[image]
Intersoft WebEssentials Documentation
SetAutoScrollMargin Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : SetAutoScrollMargin Method

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetAutoScrollMargin( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim x As System.Integer
Dim y As System.Integer

instance.SetAutoScrollMargin(x, y)
C#
public void SetAutoScrollMargin(
   System.int x,
   System.int y
)
Delphi
public procedure SetAutoScrollMargin(
    x: System.Integer;
    y: System.Integer
);
JScript
public function SetAutoScrollMargin(
   x : System.int,
   y : System.int
);
Managed Extensions for C++
public: void SetAutoScrollMargin(
   System.int x,
   System.int y
)
C++/CLI
public:
void SetAutoScrollMargin(
   System.int x,
   System.int y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


SetBounds Method

[image]
Intersoft WebEssentials Documentation
SetBounds Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : SetBounds Method

Glossary Item Box

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


SetBounds(Int32,Int32,Int32,Int32) Method

[image]
Intersoft WebEssentials Documentation
SetBounds(Int32,Int32,Int32,Int32) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
y
width
height

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetBounds(x, y, width, height)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
Delphi
public procedure SetBounds(
    x: System.Integer;
    y: System.Integer;
    width: System.Integer;
    height: System.Integer
);
JScript
public function SetBounds(
   x : System.int,
   y : System.int,
   width : System.int,
   height : System.int
);
Managed Extensions for C++
public: void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
C++/CLI
public:
void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

[image]
Intersoft WebEssentials Documentation
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
y
width
height
specified

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer, _
   ByVal specified As System.Windows.Forms.BoundsSpecified _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer
Dim specified As System.Windows.Forms.BoundsSpecified

instance.SetBounds(x, y, width, height, specified)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)
Delphi
public procedure SetBounds(
    x: System.Integer;
    y: System.Integer;
    width: System.Integer;
    height: System.Integer;
    specified: System.Windows.Forms.BoundsSpecified
);
JScript
public function SetBounds(
   x : System.int,
   y : System.int,
   width : System.int,
   height : System.int,
   specified : System.Windows.Forms.BoundsSpecified
);
Managed Extensions for C++
public: void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)
C++/CLI
public:
void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
y
width
height
specified

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


SetDesktopBounds Method

[image]
Intersoft WebEssentials Documentation
SetDesktopBounds Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : SetDesktopBounds Method

x
y
width
height

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDesktopBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetDesktopBounds(x, y, width, height)
C#
public void SetDesktopBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
Delphi
public procedure SetDesktopBounds(
    x: System.Integer;
    y: System.Integer;
    width: System.Integer;
    height: System.Integer
);
JScript
public function SetDesktopBounds(
   x : System.int,
   y : System.int,
   width : System.int,
   height : System.int
);
Managed Extensions for C++
public: void SetDesktopBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
C++/CLI
public:
void SetDesktopBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


SetDesktopLocation Method

[image]
Intersoft WebEssentials Documentation
SetDesktopLocation Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : SetDesktopLocation Method

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDesktopLocation( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim x As System.Integer
Dim y As System.Integer

instance.SetDesktopLocation(x, y)
C#
public void SetDesktopLocation(
   System.int x,
   System.int y
)
Delphi
public procedure SetDesktopLocation(
    x: System.Integer;
    y: System.Integer
);
JScript
public function SetDesktopLocation(
   x : System.int,
   y : System.int
);
Managed Extensions for C++
public: void SetDesktopLocation(
   System.int x,
   System.int y
)
C++/CLI
public:
void SetDesktopLocation(
   System.int x,
   System.int y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Show Method

[image]
Intersoft WebEssentials Documentation
Show Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Show Method

Glossary Item Box

Overload List

Overload | Description
Show(IWin32Window) | (Inherited from System.Windows.Forms.Form)
Show() | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Show() Method

[image]
Intersoft WebEssentials Documentation
Show() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > Show Method : Show() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Show()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.Show()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Show()
Delphi
public procedure Show();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Show();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Show();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Show();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


Show(IWin32Window) Method

[image]
Intersoft WebEssentials Documentation
Show(IWin32Window) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > Show Method : Show(IWin32Window) Method

owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Show( _
   ByVal owner As System.Windows.Forms.IWin32Window _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim owner As System.Windows.Forms.IWin32Window

instance.Show(owner)
C#
public void Show(
   System.Windows.Forms.IWin32Window owner
)
Delphi
public procedure Show(
    owner: System.Windows.Forms.IWin32Window
);
JScript
public function Show(
   owner : System.Windows.Forms.IWin32Window
);
Managed Extensions for C++
public: void Show(
   System.Windows.Forms.IWin32Window* owner
)
C++/CLI
public:
void Show(
   System.Windows.Forms.IWin32Window^ owner
)

Parameters

owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


ShowDialog Method

[image]
Intersoft WebEssentials Documentation
ShowDialog Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ShowDialog Method

Glossary Item Box

Overload List

Overload | Description
ShowDialog() | (Inherited from System.Windows.Forms.Form)
ShowDialog(IWin32Window) | (Inherited from System.Windows.Forms.Form)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ShowDialog() Method

[image]
Intersoft WebEssentials Documentation
ShowDialog() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > ShowDialog Method : ShowDialog() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function ShowDialog() As System.Windows.Forms.DialogResult
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.DialogResult

value = instance.ShowDialog()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Windows.Forms.DialogResult ShowDialog()
Delphi
public function ShowDialog(): System.Windows.Forms.DialogResult;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ShowDialog() : System.Windows.Forms.DialogResult;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Windows.Forms.DialogResult ShowDialog();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Windows.Forms.DialogResult ShowDialog();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


ShowDialog(IWin32Window) Method

[image]
Intersoft WebEssentials Documentation
ShowDialog(IWin32Window) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > ShowDialog Method : ShowDialog(IWin32Window) Method

owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowDialog( _
   ByVal owner As System.Windows.Forms.IWin32Window _
) As System.Windows.Forms.DialogResult
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim owner As System.Windows.Forms.IWin32Window
Dim value As System.Windows.Forms.DialogResult

value = instance.ShowDialog(owner)
C#
public System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.IWin32Window owner
)
Delphi
public function ShowDialog(
    owner: System.Windows.Forms.IWin32Window
): System.Windows.Forms.DialogResult;
JScript
public function ShowDialog(
   owner : System.Windows.Forms.IWin32Window
) : System.Windows.Forms.DialogResult;
Managed Extensions for C++
public: System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.IWin32Window* owner
)
C++/CLI
public:
System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.IWin32Window^ owner
)

Parameters

owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


ShowIcon Property

[image]
Intersoft WebEssentials Documentation
ShowIcon Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ShowIcon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")>
Public Property ShowIcon As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.ShowIcon = value

value = instance.ShowIcon
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")]
public System.bool ShowIcon {get; set;}
Delphi
public read-write property ShowIcon: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")
public function get,set ShowIcon : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")]
public: __property System.bool get_ShowIcon();
public: __property void set_ShowIcon(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")]
public:
property System.bool ShowIcon {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ShowInTaskbar Property

[image]
Intersoft WebEssentials Documentation
ShowInTaskbar Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ShowInTaskbar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")>
Public Property ShowInTaskbar As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.ShowInTaskbar = value

value = instance.ShowInTaskbar
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public System.bool ShowInTaskbar {get; set;}
Delphi
public read-write property ShowInTaskbar: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")
public function get,set ShowInTaskbar : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public: __property System.bool get_ShowInTaskbar();
public: __property void set_ShowInTaskbar(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public:
property System.bool ShowInTaskbar {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Shown Event

[image]
Intersoft WebEssentials Documentation
Shown Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Shown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the form is first shown.")>
<SRCategoryAttribute("Behavior")>
Public Event Shown As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Shown, handler
C#
[SRDescriptionAttribute("Occurs whenever the form is first shown.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler Shown
Delphi
public event Shown: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the form is first shown.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* Shown
C++/CLI
[SRDescriptionAttribute("Occurs whenever the form is first shown.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ Shown

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Site Property

[image]
Intersoft WebEssentials Documentation
Site Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Property Site As System.ComponentModel.ISite
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual System.ComponentModel.ISite Site {get; set;}
Delphi
public read-write property Site: System.ComponentModel.ISite; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function get,set Site : System.ComponentModel.ISite
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual property System.ComponentModel.ISite^ Site {
   System.ComponentModel.ISite^ get();
   void set (    System.ComponentModel.ISite^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Size Property

[image]
Intersoft WebEssentials Documentation
Size Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Size Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Size As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Size

instance.Size = value

value = instance.Size
C#
[System.ComponentModel.LocalizableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Drawing.Size Size {get; set;}
Delphi
public read-write property Size: System.Drawing.Size;
JScript
System.ComponentModel.LocalizableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set Size : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Drawing.Size get_Size();
public: __property void set_Size(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Drawing.Size Size {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


SizeChanged Event

[image]
Intersoft WebEssentials Documentation
SizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : SizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event SizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.SizeChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler SizeChanged
Delphi
public event SizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* SizeChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


SizeGripStyle Property

[image]
Intersoft WebEssentials Documentation
SizeGripStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : SizeGripStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")>
Public Property SizeGripStyle As System.Windows.Forms.SizeGripStyle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.SizeGripStyle

instance.SizeGripStyle = value

value = instance.SizeGripStyle
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")]
public System.Windows.Forms.SizeGripStyle SizeGripStyle {get; set;}
Delphi
public read-write property SizeGripStyle: System.Windows.Forms.SizeGripStyle;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")
public function get,set SizeGripStyle : System.Windows.Forms.SizeGripStyle
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")]
public: __property System.Windows.Forms.SizeGripStyle get_SizeGripStyle();
public: __property void set_SizeGripStyle(
   System.Windows.Forms.SizeGripStyle value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")]
public:
property System.Windows.Forms.SizeGripStyle SizeGripStyle {
   System.Windows.Forms.SizeGripStyle get();
   void set (    System.Windows.Forms.SizeGripStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


StartPosition Property

[image]
Intersoft WebEssentials Documentation
StartPosition Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : StartPosition Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Determines the position of a form when it first appears.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property StartPosition As System.Windows.Forms.FormStartPosition
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.FormStartPosition

instance.StartPosition = value

value = instance.StartPosition
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Windows.Forms.FormStartPosition StartPosition {get; set;}
Delphi
public read-write property StartPosition: System.Windows.Forms.FormStartPosition;
JScript
SRCategoryAttribute("Layout")
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Determines the position of a form when it first appears.")
System.ComponentModel.DefaultValueAttribute()
public function get,set StartPosition : System.Windows.Forms.FormStartPosition
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Windows.Forms.FormStartPosition get_StartPosition();
public: __property void set_StartPosition(
   System.Windows.Forms.FormStartPosition value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Windows.Forms.FormStartPosition StartPosition {
   System.Windows.Forms.FormStartPosition get();
   void set (    System.Windows.Forms.FormStartPosition value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


StyleChanged Event

[image]
Intersoft WebEssentials Documentation
StyleChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : StyleChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the window style of a Control is changed.")>
<SRCategoryAttribute("Behavior")>
Public Event StyleChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.StyleChanged, handler
C#
[SRDescriptionAttribute("Event raised when the window style of a Control is changed.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler StyleChanged
Delphi
public event StyleChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the window style of a Control is changed.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* StyleChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the window style of a Control is changed.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


SuspendLayout Method

[image]
Intersoft WebEssentials Documentation
SuspendLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : SuspendLayout Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.SuspendLayout()
C#
public void SuspendLayout()
Delphi
public procedure SuspendLayout();
JScript
public function SuspendLayout();
Managed Extensions for C++
public: void SuspendLayout();
C++/CLI
public:
void SuspendLayout();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


SystemColorsChanged Event

[image]
Intersoft WebEssentials Documentation
SystemColorsChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : SystemColorsChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the system colors change.")>
<SRCategoryAttribute("Behavior")>
Public Event SystemColorsChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.SystemColorsChanged, handler
C#
[SRDescriptionAttribute("Event raised when the system colors change.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler SystemColorsChanged
Delphi
public event SystemColorsChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the system colors change.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* SystemColorsChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the system colors change.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Tag Property

[image]
Intersoft WebEssentials Documentation
Tag Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Tag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.LocalizableAttribute(False)>
<SRDescriptionAttribute("User-defined data associated with the object.")>
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
Public Property Tag As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public System.object Tag {get; set;}
Delphi
public read-write property Tag: System.TObject;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("User-defined data associated with the object.")
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Data")
public function get,set Tag : System.Object
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public: __property System.Object* get_Tag();
public: __property void set_Tag(
   System.Object* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public:
property System.Object^ Tag {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Text Property

[image]
Intersoft WebEssentials Documentation
Text Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.SettingsBindableAttribute(True)>
Public Overridable Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.SettingsBindableAttribute(true)]
public virtual System.string Text {get; set;}
Delphi
public read-write property Text: System.String; virtual;
JScript
System.ComponentModel.SettingsBindableAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.SettingsBindableAttribute(true)]
public: __property virtual System.string* get_Text();
public: __property virtual void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.SettingsBindableAttribute(true)]
public:
virtual property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


TextChanged Event

[image]
Intersoft WebEssentials Documentation
TextChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : TextChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")>
Public Event TextChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.TextChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")]
public event System.EventHandler TextChanged
Delphi
public event TextChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")]
public: __event System.EventHandler* TextChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")]
public:
event System.EventHandler^ TextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


TopMost Property

[image]
Intersoft WebEssentials Documentation
TopMost Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : TopMost Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TopMost As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.TopMost = value

value = instance.TopMost
C#
[SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool TopMost {get; set;}
Delphi
public read-write property TopMost: System.Boolean;
JScript
SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
public function get,set TopMost : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_TopMost();
public: __property void set_TopMost(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool TopMost {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


TransparencyKey Property

[image]
Intersoft WebEssentials Documentation
TransparencyKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : TransparencyKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("A color which will appear transparent when painted on the form.")>
<SRCategoryAttribute("Window Style")>
Public Property TransparencyKey As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Drawing.Color

instance.TransparencyKey = value

value = instance.TransparencyKey
C#
[SRDescriptionAttribute("A color which will appear transparent when painted on the form.")]
[SRCategoryAttribute("Window Style")]
public System.Drawing.Color TransparencyKey {get; set;}
Delphi
public read-write property TransparencyKey: System.Drawing.Color;
JScript
SRDescriptionAttribute("A color which will appear transparent when painted on the form.")
SRCategoryAttribute("Window Style")
public function get,set TransparencyKey : System.Drawing.Color
Managed Extensions for C++
[SRDescriptionAttribute("A color which will appear transparent when painted on the form.")]
[SRCategoryAttribute("Window Style")]
public: __property System.Drawing.Color get_TransparencyKey();
public: __property void set_TransparencyKey(
   System.Drawing.Color value
);
C++/CLI
[SRDescriptionAttribute("A color which will appear transparent when painted on the form.")]
[SRCategoryAttribute("Window Style")]
public:
property System.Drawing.Color TransparencyKey {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Update Method

[image]
Intersoft WebEssentials Documentation
Update Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Update Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Update()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm

instance.Update()
C#
public void Update()
Delphi
public procedure Update();
JScript
public function Update();
Managed Extensions for C++
public: void Update();
C++/CLI
public:
void Update();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


UseWaitCursor Property

[image]
Intersoft WebEssentials Documentation
UseWaitCursor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : UseWaitCursor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorBrowsableAttribute()>
<SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")>
Public Property UseWaitCursor As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.UseWaitCursor = value

value = instance.UseWaitCursor
C#
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")]
public System.bool UseWaitCursor {get; set;}
Delphi
public read-write property UseWaitCursor: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorBrowsableAttribute()
SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")
public function get,set UseWaitCursor : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")]
public: __property System.bool get_UseWaitCursor();
public: __property void set_UseWaitCursor(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")]
public:
property System.bool UseWaitCursor {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Validate Method

[image]
Intersoft WebEssentials Documentation
Validate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Validate Method

Glossary Item Box

Overload List

Overload | Description
Validate() | (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | (Inherited from System.Windows.Forms.ContainerControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Validate() Method

[image]
Intersoft WebEssentials Documentation
Validate() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > Validate Method : Validate() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function Validate() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

value = instance.Validate()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool Validate()
Delphi
public function Validate(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Validate() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool Validate();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool Validate();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


Validate(Boolean) Method

[image]
Intersoft WebEssentials Documentation
Validate(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > Validate Method : Validate(Boolean) Method

checkAutoValidate

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate( _
   ByVal checkAutoValidate As System.Boolean _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim checkAutoValidate As System.Boolean
Dim value As System.Boolean

value = instance.Validate(checkAutoValidate)
C#
public System.bool Validate(
   System.bool checkAutoValidate
)
Delphi
public function Validate(
    checkAutoValidate: System.Boolean
): System.Boolean;
JScript
public function Validate(
   checkAutoValidate : System.boolean
) : System.boolean;
Managed Extensions for C++
public: System.bool Validate(
   System.bool checkAutoValidate
)
C++/CLI
public:
System.bool Validate(
   System.bool checkAutoValidate
)

Parameters

checkAutoValidate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


ValidateChildren Method

[image]
Intersoft WebEssentials Documentation
ValidateChildren Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : ValidateChildren Method

Glossary Item Box

Overload List

Overload | Description
ValidateChildren() | (Inherited from System.Windows.Forms.Form)
ValidateChildren(ValidationConstraints) | (Inherited from System.Windows.Forms.Form)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


ValidateChildren() Method

[image]
Intersoft WebEssentials Documentation
ValidateChildren() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > ValidateChildren Method : ValidateChildren() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.EditorBrowsableAttribute()>
Public Overloads Overridable Function ValidateChildren() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

value = instance.ValidateChildren()
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public virtual System.bool ValidateChildren()
Delphi
public function ValidateChildren(): System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute()
public function ValidateChildren() : System.boolean;
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public: virtual System.bool ValidateChildren();
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public:
virtual System.bool ValidateChildren();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


ValidateChildren(ValidationConstraints) Method

[image]
Intersoft WebEssentials Documentation
ValidateChildren(ValidationConstraints) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method

validationConstraints

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.EditorBrowsableAttribute()>
Public Overloads Overridable Function ValidateChildren( _
   ByVal validationConstraints As System.Windows.Forms.ValidationConstraints _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim validationConstraints As System.Windows.Forms.ValidationConstraints
Dim value As System.Boolean

value = instance.ValidateChildren(validationConstraints)
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)
Delphi
public function ValidateChildren(
    validationConstraints: System.Windows.Forms.ValidationConstraints
): System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute()
public function ValidateChildren(
   validationConstraints : System.Windows.Forms.ValidationConstraints
) : System.boolean;
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public: virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public:
virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)

Parameters

validationConstraints

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members
Overload List


Validated Event

[image]
Intersoft WebEssentials Documentation
Validated Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Validated Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs after a control has been successfully validated.")>
<SRCategoryAttribute("Focus")>
Public Event Validated As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Validated, handler
C#
[SRDescriptionAttribute("Occurs after a control has been successfully validated.")]
[SRCategoryAttribute("Focus")]
public event System.EventHandler Validated
Delphi
public event Validated: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs after a control has been successfully validated.")]
[SRCategoryAttribute("Focus")]
public: __event System.EventHandler* Validated
C++/CLI
[SRDescriptionAttribute("Occurs after a control has been successfully validated.")]
[SRCategoryAttribute("Focus")]
public:
event System.EventHandler^ Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Validating Event

[image]
Intersoft WebEssentials Documentation
Validating Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Validating Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the control is validating.")>
<SRCategoryAttribute("Focus")>
Public Event Validating As System.ComponentModel.CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.Validating, handler
C#
[SRDescriptionAttribute("Occurs when the control is validating.")]
[SRCategoryAttribute("Focus")]
public event System.ComponentModel.CancelEventHandler Validating
Delphi
public event Validating: System.ComponentModel.CancelEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the control is validating.")]
[SRCategoryAttribute("Focus")]
public: __event System.ComponentModel.CancelEventHandler* Validating
C++/CLI
[SRDescriptionAttribute("Occurs when the control is validating.")]
[SRCategoryAttribute("Focus")]
public:
event System.ComponentModel.CancelEventHandler^ Validating

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether the control is visible or hidden.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Behavior")>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
SRDescriptionAttribute("Determines whether the control is visible or hidden.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


VisibleChanged Event

[image]
Intersoft WebEssentials Documentation
VisibleChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : VisibleChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the control's visibility changes.")>
Public Event VisibleChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim handler As System.EventHandler

AddHandler instance.VisibleChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
public event System.EventHandler VisibleChanged
Delphi
public event VisibleChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
public: __event System.EventHandler* VisibleChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
public:
event System.EventHandler^ VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


WindowState Property

[image]
Intersoft WebEssentials Documentation
WindowState Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionNewItemForm Class : WindowState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Determines the initial visual state of the form.")>
Public Property WindowState As System.Windows.Forms.FormWindowState
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionNewItemForm
Dim value As System.Windows.Forms.FormWindowState

instance.WindowState = value

value = instance.WindowState
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
public System.Windows.Forms.FormWindowState WindowState {get; set;}
Delphi
public read-write property WindowState: System.Windows.Forms.FormWindowState;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Layout")
SRDescriptionAttribute("Determines the initial visual state of the form.")
public function get,set WindowState : System.Windows.Forms.FormWindowState
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
public: __property System.Windows.Forms.FormWindowState get_WindowState();
public: __property void set_WindowState(
   System.Windows.Forms.FormWindowState value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
public:
property System.Windows.Forms.FormWindowState WindowState {
   System.Windows.Forms.FormWindowState get();
   void set (    System.Windows.Forms.FormWindowState value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionNewItemForm Class
WebAccordionNewItemForm Members


WebAccordionPresets Class

[image]
Intersoft WebEssentials Documentation
WebAccordionPresets Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionPresets Class

Glossary Item Box

Object Model

WebAccordionPresets Class

Syntax

Visual Basic (Declaration)
Public Class WebAccordionPresets
Visual Basic (Usage) Copy Code
Dim instance As WebAccordionPresets
C#
public class WebAccordionPresets
Delphi
public class WebAccordionPresets
JScript
public class WebAccordionPresets
Managed Extensions for C++
public __gc class WebAccordionPresets
C++/CLI
public ref class WebAccordionPresets

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebEssentials.WebAccordionPresets

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionPresets Members
ISNet.WebUI.WebEssentials Namespace


WebAccordionPresets Class Members

[image]
Intersoft WebEssentials Documentation
WebAccordionPresets Class Members
See Also Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionPresets Class

Glossary Item Box

The following tables list the members exposed by WebAccordionPresets.

Public Constructors

 | Name | Description
Public Constructor | WebAccordionPresets Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

WebAccordionPresets Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionPresets Class Methods

[image]
Intersoft WebEssentials Documentation
WebAccordionPresets Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebAccordionPresets Class

Glossary Item Box

For a list of all members of this type, see WebAccordionPresets members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

WebAccordionPresets Class
ISNet.WebUI.WebEssentials Namespace


WebAccordionPresets Constructor

[image]
Intersoft WebEssentials Documentation
WebAccordionPresets Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionPresets Class : WebAccordionPresets Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebAccordionPresets()
C#
public WebAccordionPresets()
Delphi
public WebAccordionPresets();
JScript
public function WebAccordionPresets();
Managed Extensions for C++
public: WebAccordionPresets();
C++/CLI
public:
WebAccordionPresets();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionPresets Class
WebAccordionPresets Members


GetDefaultStyle Method

[image]
Intersoft WebEssentials Documentation
GetDefaultStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionPresets Class : GetDefaultStyle Method

Glossary Item Box

Overload List

Overload | Description
GetDefaultStyle |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionPresets Class
WebAccordionPresets Members


GetDefaultStyle(WebAccordionDefaultStyleMode,String) Method

[image]
Intersoft WebEssentials Documentation
GetDefaultStyle(WebAccordionDefaultStyleMode,String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordionPresets Class : GetDefaultStyle(WebAccordionDefaultStyleMode,String) Method

mode
styleName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetDefaultStyle( _
   ByVal mode As WebAccordionDefaultStyleMode, _
   ByVal styleName As System.String _
) As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim mode As WebAccordionDefaultStyleMode
Dim styleName As System.String
Dim value As ISNet.WebUI.WebStyle

value = WebAccordionPresets.GetDefaultStyle(mode, styleName)
C#
public static ISNet.WebUI.WebStyle GetDefaultStyle(
   WebAccordionDefaultStyleMode mode,
   System.string styleName
)
Delphi
public function GetDefaultStyle(
    mode: WebAccordionDefaultStyleMode;
    styleName: System.String
): ISNet.WebUI.WebStyle; static;
JScript
public static function GetDefaultStyle(
   mode : WebAccordionDefaultStyleMode,
   styleName : System.String
) : ISNet.WebUI.WebStyle;
Managed Extensions for C++
public: static ISNet.WebUI.WebStyle* GetDefaultStyle(
   WebAccordionDefaultStyleMode mode,
   System.string* styleName
)
C++/CLI
public:
static ISNet.WebUI.WebStyle^ GetDefaultStyle(
   WebAccordionDefaultStyleMode mode,
   System.String^ styleName
)

Parameters

mode
styleName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordionPresets Class
WebAccordionPresets Members


WebAccordion Constructor

[image]
Intersoft WebEssentials Documentation
WebAccordion Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : WebAccordion Constructor

Glossary Item Box

Overload List

Overload | Description
WebAccordion Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


WebAccordion Constructor

[image]
Intersoft WebEssentials Documentation
WebAccordion Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : WebAccordion Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebAccordion()
C#
public WebAccordion()
Delphi
public WebAccordion();
JScript
public function WebAccordion();
Managed Extensions for C++
public: WebAccordion();
C++/CLI
public:
WebAccordion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


AccessKey Property

[image]
Intersoft WebEssentials Documentation
AccessKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set AccessKey : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


AllowDefaultStyleMerging Property

[image]
Intersoft WebEssentials Documentation
AllowDefaultStyleMerging Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : AllowDefaultStyleMerging Property

Glossary Item Box

Gets or sets the value that determines whether or not the default style can be merged with custom styles.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")>
Public Property AllowDefaultStyleMerging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

instance.AllowDefaultStyleMerging = value

value = instance.AllowDefaultStyleMerging
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
public System.bool AllowDefaultStyleMerging {get; set;}
Delphi
public read-write property AllowDefaultStyleMerging: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")
public function get,set AllowDefaultStyleMerging : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
public: __property System.bool get_AllowDefaultStyleMerging();
public: __property void set_AllowDefaultStyleMerging(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
public:
property System.bool AllowDefaultStyleMerging {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ApplyStyle Method

[image]
Intersoft WebEssentials Documentation
ApplyStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebEssentials Documentation
ApplyStyleSheetSkin Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


CanUseWebResources Method

[image]
Intersoft WebEssentials Documentation
CanUseWebResources Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.CanUseWebResources()
C#
public System.bool CanUseWebResources()
Delphi
public function CanUseWebResources(): System.Boolean;
JScript
public function CanUseWebResources() : System.boolean;
Managed Extensions for C++
public: System.bool CanUseWebResources();
C++/CLI
public:
System.bool CanUseWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


CheckConstrains Method

[image]
Intersoft WebEssentials Documentation
CheckConstrains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion

instance.CheckConstrains()
C#
public override void CheckConstrains()
Delphi
public procedure CheckConstrains(); override;
JScript
public override function CheckConstrains();
Managed Extensions for C++
public: void CheckConstrains(); override
C++/CLI
public:
void CheckConstrains(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ClientIDMode Property

[image]
Intersoft WebEssentials Documentation
ClientIDMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ClientSideEvents Property

[image]
Intersoft WebEssentials Documentation
ClientSideEvents Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ClientSideEvents Property

Glossary Item Box

Contains client side events supported by WebAccordion.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebAccordion.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property ClientSideEvents As WebAccordionClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As WebAccordionClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebAccordion.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public WebAccordionClientSideEvents ClientSideEvents {get; set;}
Delphi
public read-write property ClientSideEvents: WebAccordionClientSideEvents;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebAccordion.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set ClientSideEvents : WebAccordionClientSideEvents
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebAccordion.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property WebAccordionClientSideEvents* get_ClientSideEvents();
public: __property void set_ClientSideEvents(
   WebAccordionClientSideEvents* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebAccordion.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property WebAccordionClientSideEvents^ ClientSideEvents {
   WebAccordionClientSideEvents^ get();
   void set (    WebAccordionClientSideEvents^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ContentHeight Property

[image]
Intersoft WebEssentials Documentation
ContentHeight Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ContentHeight Property

Glossary Item Box

Specifies the content height of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Layout")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the content height of WebAccordion's item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ContentHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Integer

instance.ContentHeight = value

value = instance.ContentHeight
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the content height of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int ContentHeight {get; set;}
Delphi
public read-write property ContentHeight: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Layout")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the content height of WebAccordion's item.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ContentHeight : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the content height of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_ContentHeight();
public: __property void set_ContentHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the content height of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int ContentHeight {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 50.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ContentWidth Property

[image]
Intersoft WebEssentials Documentation
ContentWidth Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ContentWidth Property

Glossary Item Box

Specifies the content width of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Layout")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the content width of WebAccordion's item.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ContentWidth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Integer

instance.ContentWidth = value

value = instance.ContentWidth
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the content width of WebAccordion's item.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int ContentWidth {get; set;}
Delphi
public read-write property ContentWidth: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Layout")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the content width of WebAccordion's item.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ContentWidth : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the content width of WebAccordion's item.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_ContentWidth();
public: __property void set_ContentWidth(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the content width of WebAccordion's item.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int ContentWidth {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 120.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ControlDataTransferFormat Property

[image]
Intersoft WebEssentials Documentation
ControlDataTransferFormat Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


CopyBaseAttributes Method

[image]
Intersoft WebEssentials Documentation
CopyBaseAttributes Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members
Overload List


DataBind Method

[image]
Intersoft WebEssentials Documentation
DataBind Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


DataBind() Method

[image]
Intersoft WebEssentials Documentation
DataBind() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


DataBinding Event

[image]
Intersoft WebEssentials Documentation
DataBinding Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


DefaultStyleMode Property

[image]
Intersoft WebEssentials Documentation
DefaultStyleMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : DefaultStyleMode Property

Glossary Item Box

Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DefaultStyleMode As WebAccordionDefaultStyleMode
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As WebAccordionDefaultStyleMode

instance.DefaultStyleMode = value

value = instance.DefaultStyleMode
C#
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebAccordionDefaultStyleMode DefaultStyleMode {get; set;}
Delphi
public read-write property DefaultStyleMode: WebAccordionDefaultStyleMode;
JScript
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DefaultStyleMode : WebAccordionDefaultStyleMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebAccordionDefaultStyleMode get_DefaultStyleMode();
public: __property void set_DefaultStyleMode(
   WebAccordionDefaultStyleMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebAccordionDefaultStyleMode DefaultStyleMode {
   WebAccordionDefaultStyleMode get();
   void set (    WebAccordionDefaultStyleMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


DisplayLatency Property

[image]
Intersoft WebEssentials Documentation
DisplayLatency Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : DisplayLatency Property

Glossary Item Box

Specifies the display latency of WebAccordion with MouseOveer interaction mode.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the display latency of WebAccordion with MouseOver interaction mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DisplayLatency As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Integer

instance.DisplayLatency = value

value = instance.DisplayLatency
C#
[System.ComponentModel.DescriptionAttribute("Specifies the display latency of WebAccordion with MouseOver interaction mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int DisplayLatency {get; set;}
Delphi
public read-write property DisplayLatency: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the display latency of WebAccordion with MouseOver interaction mode.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set DisplayLatency : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the display latency of WebAccordion with MouseOver interaction mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_DisplayLatency();
public: __property void set_DisplayLatency(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the display latency of WebAccordion with MouseOver interaction mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int DisplayLatency {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 1000.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


Dispose Method

[image]
Intersoft WebEssentials Documentation
Dispose Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


Disposed Event

[image]
Intersoft WebEssentials Documentation
Disposed Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


EnableManagedTheming Property

[image]
Intersoft WebEssentials Documentation
EnableManagedTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable Property EnableManagedTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableManagedTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.bool EnableManagedTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


EnableTheming Property

[image]
Intersoft WebEssentials Documentation
EnableTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


EnableViewState Property

[image]
Intersoft WebEssentials Documentation
EnableViewState Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


EnableWebResources Property

[image]
Intersoft WebEssentials Documentation
EnableWebResources Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Web Resources")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Web Resources")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ExpandDirection Property

[image]
Intersoft WebEssentials Documentation
ExpandDirection Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ExpandDirection Property

Glossary Item Box

Specifies WebAccordion expand direction.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies WebAccordion expand direction.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ExpandDirection As WebAccordionExpandDirection
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As WebAccordionExpandDirection

instance.ExpandDirection = value

value = instance.ExpandDirection
C#
[System.ComponentModel.DescriptionAttribute("Specifies WebAccordion expand direction.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public WebAccordionExpandDirection ExpandDirection {get; set;}
Delphi
public read-write property ExpandDirection: WebAccordionExpandDirection;
JScript
System.ComponentModel.DescriptionAttribute("Specifies WebAccordion expand direction.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ExpandDirection : WebAccordionExpandDirection
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies WebAccordion expand direction.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebAccordionExpandDirection get_ExpandDirection();
public: __property void set_ExpandDirection(
   WebAccordionExpandDirection value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies WebAccordion expand direction.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebAccordionExpandDirection ExpandDirection {
   WebAccordionExpandDirection get();
   void set (    WebAccordionExpandDirection value);
}

Property Value

The default value is Bottom.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ExpandIndex Property

[image]
Intersoft WebEssentials Documentation
ExpandIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ExpandIndex Property

Glossary Item Box

Specifies the expand index of WebAccordion.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the expand index of WebAccordion.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ExpandIndex As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Integer

instance.ExpandIndex = value

value = instance.ExpandIndex
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the expand index of WebAccordion.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int ExpandIndex {get; set;}
Delphi
public read-write property ExpandIndex: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the expand index of WebAccordion.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ExpandIndex : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the expand index of WebAccordion.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_ExpandIndex();
public: __property void set_ExpandIndex(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the expand index of WebAccordion.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int ExpandIndex {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


FindControl Method

[image]
Intersoft WebEssentials Documentation
FindControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


FindControl(String) Method

[image]
Intersoft WebEssentials Documentation
FindControl(String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


Focus Method

[image]
Intersoft WebEssentials Documentation
Focus Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ForceDisableXmlCompression Method

[image]
Intersoft WebEssentials Documentation
ForceDisableXmlCompression Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


FrameStyle Property

[image]
Intersoft WebEssentials Documentation
FrameStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : FrameStyle Property

Glossary Item Box

Contains interactive style for Frame.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle FrameStyle {get; set;}
Delphi
public read-write property FrameStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.DefaultValueAttribute()
public function get,set FrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_FrameStyle();
public: __property void set_FrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ FrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetClientAction Method

[image]
Intersoft WebEssentials Documentation
GetClientAction Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebEssentials Documentation
GetCurrentControlLifeCycle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetCurrentTheme Method

[image]
Intersoft WebEssentials Documentation
GetCurrentTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetFrameworkDataFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkDataFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

value = instance.GetFrameworkDataFolder()
C#
public System.string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): System.String;
JScript
public function GetFrameworkDataFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkDataFolder();
C++/CLI
public:
System.String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetFrameworkFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

value = instance.GetFrameworkFolder()
C#
public System.string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): System.String;
JScript
public function GetFrameworkFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkFolder();
C++/CLI
public:
System.String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetFrameworkVersion Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkVersion Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Version

value = instance.GetFrameworkVersion()
C#
public System.Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): System.Version;
JScript
public function GetFrameworkVersion() : System.Version;
Managed Extensions for C++
public: System.Version* GetFrameworkVersion();
C++/CLI
public:
System.Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetIntersoftFolder Method

[image]
Intersoft WebEssentials Documentation
GetIntersoftFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

value = instance.GetIntersoftFolder()
C#
public System.string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): System.String;
JScript
public function GetIntersoftFolder() : System.String;
Managed Extensions for C++
public: System.string* GetIntersoftFolder();
C++/CLI
public:
System.String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetLayoutFolder Method

[image]
Intersoft WebEssentials Documentation
GetLayoutFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

value = instance.GetLayoutFolder()
C#
public System.string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): System.String;
JScript
public function GetLayoutFolder() : System.String;
Managed Extensions for C++
public: System.string* GetLayoutFolder();
C++/CLI
public:
System.String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetPostedXMLData Method

[image]
Intersoft WebEssentials Documentation
GetPostedXMLData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

value = instance.GetPostedXMLData()
C#
public System.string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): System.String;
JScript
public function GetPostedXMLData() : System.String;
Managed Extensions for C++
public: System.string* GetPostedXMLData();
C++/CLI
public:
System.String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetProductInfoKey Method

[image]
Intersoft WebEssentials Documentation
GetProductInfoKey Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

value = instance.GetProductInfoKey()
C#
public System.string GetProductInfoKey()
Delphi
public function GetProductInfoKey(): System.String;
JScript
public function GetProductInfoKey() : System.String;
Managed Extensions for C++
public: System.string* GetProductInfoKey();
C++/CLI
public:
System.String^ GetProductInfoKey();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetProductSimpleName Method

[image]
Intersoft WebEssentials Documentation
GetProductSimpleName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

value = instance.GetProductSimpleName()
C#
public System.string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): System.String;
JScript
public function GetProductSimpleName() : System.String;
Managed Extensions for C++
public: System.string* GetProductSimpleName();
C++/CLI
public:
System.String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetPropertyValue Method

[image]
Intersoft WebEssentials Documentation
GetPropertyValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As System.String, _
   ByVal propValue As System.String, _
   ByVal webConfigKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim defValue As System.String
Dim propValue As System.String
Dim webConfigKey As System.String
Dim value As System.String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public System.string GetPropertyValue(
   System.string defValue,
   System.string propValue,
   System.string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: System.String;
    propValue: System.String;
    webConfigKey: System.String
): System.String;
JScript
public function GetPropertyValue(
   defValue : System.String,
   propValue : System.String,
   webConfigKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetPropertyValue(
   System.string* defValue,
   System.string* propValue,
   System.string* webConfigKey
)
C++/CLI
public:
System.String^ GetPropertyValue(
   System.String^ defValue,
   System.String^ propValue,
   System.String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetResourceStream Method

[image]
Intersoft WebEssentials Documentation
GetResourceStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As System.String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim resourceUrl As System.String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   System.string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: System.String
): System.IO.Stream;
JScript
public function GetResourceStream(
   resourceUrl : System.String
) : System.IO.Stream;
Managed Extensions for C++
public: System.IO.Stream* GetResourceStream(
   System.string* resourceUrl
)
C++/CLI
public:
System.IO.Stream^ GetResourceStream(
   System.String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetRouteUrl Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


GetRouteUrl(Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebEssentials Documentation
GetUniqueIDRelativeTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


HasControls Method

[image]
Intersoft WebEssentials Documentation
HasControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


HeaderHeight Property

[image]
Intersoft WebEssentials Documentation
HeaderHeight Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : HeaderHeight Property

Glossary Item Box

Specifies the header height of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the header height of WebAccordion's item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property HeaderHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Integer

instance.HeaderHeight = value

value = instance.HeaderHeight
C#
[System.ComponentModel.DescriptionAttribute("Specifies the header height of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int HeaderHeight {get; set;}
Delphi
public read-write property HeaderHeight: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the header height of WebAccordion's item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set HeaderHeight : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the header height of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_HeaderHeight();
public: __property void set_HeaderHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the header height of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int HeaderHeight {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 28.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


HeaderWidth Property

[image]
Intersoft WebEssentials Documentation
HeaderWidth Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : HeaderWidth Property

Glossary Item Box

Specifies the header width of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the header width of WebAccordion's item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Layout")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HeaderWidth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Integer

instance.HeaderWidth = value

value = instance.HeaderWidth
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the header width of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.int HeaderWidth {get; set;}
Delphi
public read-write property HeaderWidth: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the header width of WebAccordion's item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Layout")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set HeaderWidth : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the header width of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_HeaderWidth();
public: __property void set_HeaderWidth(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the header width of WebAccordion's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int HeaderWidth {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 78.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


Height Property

[image]
Intersoft WebEssentials Documentation
Height Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Overrides Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public override System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; override;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public override function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.Web.UI.WebControls.Unit get_Height() override;
public: __property void set_Height(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ID Property

[image]
Intersoft WebEssentials Documentation
ID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ImagesDirectory Property

[image]
Intersoft WebEssentials Documentation
ImagesDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the images directory.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ImagesDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ImagesDirectory {get; set;}
Delphi
public read-write property ImagesDirectory: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ImagesDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ImagesDirectory();
public: __property void set_ImagesDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ImagesDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ImagesSettings Property

[image]
Intersoft WebEssentials Documentation
ImagesSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ImagesSettings Property

Glossary Item Box

Provides the settings that control the images in WebAccordion.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebAccordion.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")>
Public ReadOnly Property ImagesSettings As WebAccordionImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As WebAccordionImagesSettings

value = instance.ImagesSettings
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebAccordion.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
public WebAccordionImagesSettings ImagesSettings {get;}
Delphi
public read-only property ImagesSettings: WebAccordionImagesSettings;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebAccordion.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")
public function get ImagesSettings : WebAccordionImagesSettings
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebAccordion.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
public: __property WebAccordionImagesSettings* get_ImagesSettings();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebAccordion.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
public:
property WebAccordionImagesSettings^ ImagesSettings {
   WebAccordionImagesSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


Init Event

[image]
Intersoft WebEssentials Documentation
Init Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


InteractionMode Property

[image]
Intersoft WebEssentials Documentation
InteractionMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : InteractionMode Property

Glossary Item Box

Specifies WebAccordion interaction mode.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies WebAccordion interaction mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property InteractionMode As WebAccordionInteractionMode
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As WebAccordionInteractionMode

instance.InteractionMode = value

value = instance.InteractionMode
C#
[System.ComponentModel.DescriptionAttribute("Specifies WebAccordion interaction mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebAccordionInteractionMode InteractionMode {get; set;}
Delphi
public read-write property InteractionMode: WebAccordionInteractionMode;
JScript
System.ComponentModel.DescriptionAttribute("Specifies WebAccordion interaction mode.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set InteractionMode : WebAccordionInteractionMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies WebAccordion interaction mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebAccordionInteractionMode get_InteractionMode();
public: __property void set_InteractionMode(
   WebAccordionInteractionMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies WebAccordion interaction mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebAccordionInteractionMode InteractionMode {
   WebAccordionInteractionMode get();
   void set (    WebAccordionInteractionMode value);
}

Property Value

The default value is MouseOver.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


IsAtlasCallback Method

[image]
Intersoft WebEssentials Documentation
IsAtlasCallback Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.IsAtlasCallback()
C#
public System.bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): System.Boolean;
JScript
public function IsAtlasCallback() : System.boolean;
Managed Extensions for C++
public: System.bool IsAtlasCallback();
C++/CLI
public:
System.bool IsAtlasCallback();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


IsBetaRelease Method

[image]
Intersoft WebEssentials Documentation
IsBetaRelease Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.IsBetaRelease()
C#
public System.bool IsBetaRelease()
Delphi
public function IsBetaRelease(): System.Boolean;
JScript
public function IsBetaRelease() : System.boolean;
Managed Extensions for C++
public: System.bool IsBetaRelease();
C++/CLI
public:
System.bool IsBetaRelease();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


IsChromeBrowser Method

[image]
Intersoft WebEssentials Documentation
IsChromeBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.IsChromeBrowser()
C#
public System.bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): System.Boolean;
JScript
public function IsChromeBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsChromeBrowser();
C++/CLI
public:
System.bool IsChromeBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


IsFlyPostBackControl Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual System.bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): System.Boolean; virtual;
JScript
public function IsFlyPostBackControl() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackControl();
C++/CLI
public:
virtual System.bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


IsFlyPostBackRequest Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackRequest Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual System.bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): System.Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackRequest();
C++/CLI
public:
virtual System.bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebEssentials Documentation
IsGeckoBasedBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.IsGeckoBasedBrowser()
C#
public System.bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): System.Boolean;
JScript
public function IsGeckoBasedBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoBasedBrowser();
C++/CLI
public:
System.bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


IsGeckoVersion18 Method

[image]
Intersoft WebEssentials Documentation
IsGeckoVersion18 Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.IsGeckoVersion18()
C#
public System.bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): System.Boolean;
JScript
public function IsGeckoVersion18() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoVersion18();
C++/CLI
public:
System.bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


IsInDesignMode Method

[image]
Intersoft WebEssentials Documentation
IsInDesignMode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.IsInDesignMode()
C#
public System.bool IsInDesignMode()
Delphi
public function IsInDesignMode(): System.Boolean;
JScript
public function IsInDesignMode() : System.boolean;
Managed Extensions for C++
public: System.bool IsInDesignMode();
C++/CLI
public:
System.bool IsInDesignMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorer8Browser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.IsInternetExplorer8Browser()
C#
public System.bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): System.Boolean;
JScript
public function IsInternetExplorer8Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer8Browser();
C++/CLI
public:
System.bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorerBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.IsInternetExplorerBrowser()
C#
public System.bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): System.Boolean;
JScript
public function IsInternetExplorerBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorerBrowser();
C++/CLI
public:
System.bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


IsOperaBrowser Method

[image]
Intersoft WebEssentials Documentation
IsOperaBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.IsOperaBrowser()
C#
public System.bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): System.Boolean;
JScript
public function IsOperaBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsOperaBrowser();
C++/CLI
public:
System.bool IsOperaBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


IsSafariBrowser Method

[image]
Intersoft WebEssentials Documentation
IsSafariBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.IsSafariBrowser()
C#
public System.bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): System.Boolean;
JScript
public function IsSafariBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsSafariBrowser();
C++/CLI
public:
System.bool IsSafariBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


IsW3CStandardBrowser Method

[image]
Intersoft WebEssentials Documentation
IsW3CStandardBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.IsW3CStandardBrowser()
C#
public System.bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): System.Boolean;
JScript
public function IsW3CStandardBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsW3CStandardBrowser();
C++/CLI
public:
System.bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ItemContentPanelStyle Property

[image]
Intersoft WebEssentials Documentation
ItemContentPanelStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ItemContentPanelStyle Property

Glossary Item Box

Contains interactive style for item content panel.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for item content panel.")>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property ItemContentPanelStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.WebStyle

instance.ItemContentPanelStyle = value

value = instance.ItemContentPanelStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item content panel.")]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle ItemContentPanelStyle {get; set;}
Delphi
public read-write property ItemContentPanelStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for item content panel.")
System.ComponentModel.CategoryAttribute("Style")
public function get,set ItemContentPanelStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item content panel.")]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_ItemContentPanelStyle();
public: __property void set_ItemContentPanelStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item content panel.")]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ ItemContentPanelStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ItemContentStyle Property

[image]
Intersoft WebEssentials Documentation
ItemContentStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ItemContentStyle Property

Glossary Item Box

Contains interactive style for item content.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for item content.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property ItemContentStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.WebStyle

instance.ItemContentStyle = value

value = instance.ItemContentStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item content.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ISNet.WebUI.WebStyle ItemContentStyle {get; set;}
Delphi
public read-write property ItemContentStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DescriptionAttribute("Contains interactive style for item content.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set ItemContentStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item content.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ISNet.WebUI.WebStyle* get_ItemContentStyle();
public: __property void set_ItemContentStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item content.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ISNet.WebUI.WebStyle^ ItemContentStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ItemHeaderContentStyle Property

[image]
Intersoft WebEssentials Documentation
ItemHeaderContentStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ItemHeaderContentStyle Property

Glossary Item Box

Contains interactive style for item header content.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Contains interactive style for item header content.")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.CategoryAttribute("Style")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property ItemHeaderContentStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.WebStyle

instance.ItemHeaderContentStyle = value

value = instance.ItemHeaderContentStyle
C#
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item header content.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ISNet.WebUI.WebStyle ItemHeaderContentStyle {get; set;}
Delphi
public read-write property ItemHeaderContentStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DescriptionAttribute("Contains interactive style for item header content.")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.CategoryAttribute("Style")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set ItemHeaderContentStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item header content.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ISNet.WebUI.WebStyle* get_ItemHeaderContentStyle();
public: __property void set_ItemHeaderContentStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item header content.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ISNet.WebUI.WebStyle^ ItemHeaderContentStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ItemHeaderFrameStyle Property

[image]
Intersoft WebEssentials Documentation
ItemHeaderFrameStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ItemHeaderFrameStyle Property

Glossary Item Box

Contains interactive style for item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ItemHeaderFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.WebStyle

instance.ItemHeaderFrameStyle = value

value = instance.ItemHeaderFrameStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
public ISNet.WebUI.WebStyle ItemHeaderFrameStyle {get; set;}
Delphi
public read-write property ItemHeaderFrameStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.DescriptionAttribute("Contains interactive style for item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ItemHeaderFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ISNet.WebUI.WebStyle* get_ItemHeaderFrameStyle();
public: __property void set_ItemHeaderFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ISNet.WebUI.WebStyle^ ItemHeaderFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ItemHeaderLeftRightStyle Property

[image]
Intersoft WebEssentials Documentation
ItemHeaderLeftRightStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ItemHeaderLeftRightStyle Property

Glossary Item Box

Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Left or Right).

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Style")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Left or Right).")>
Public Property ItemHeaderLeftRightStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.DynamicStyle

instance.ItemHeaderLeftRightStyle = value

value = instance.ItemHeaderLeftRightStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Left or Right).")]
public ISNet.WebUI.DynamicStyle ItemHeaderLeftRightStyle {get; set;}
Delphi
public read-write property ItemHeaderLeftRightStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Style")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Left or Right).")
public function get,set ItemHeaderLeftRightStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Left or Right).")]
public: __property ISNet.WebUI.DynamicStyle* get_ItemHeaderLeftRightStyle();
public: __property void set_ItemHeaderLeftRightStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Left or Right).")]
public:
property ISNet.WebUI.DynamicStyle^ ItemHeaderLeftRightStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ItemHeaderStyle Property

[image]
Intersoft WebEssentials Documentation
ItemHeaderStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ItemHeaderStyle Property

Glossary Item Box

Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Top or Down).

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Style")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Top or Down).")>
Public Property ItemHeaderStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.DynamicStyle

instance.ItemHeaderStyle = value

value = instance.ItemHeaderStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Top or Down).")]
public ISNet.WebUI.DynamicStyle ItemHeaderStyle {get; set;}
Delphi
public read-write property ItemHeaderStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Style")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Top or Down).")
public function get,set ItemHeaderStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Top or Down).")]
public: __property ISNet.WebUI.DynamicStyle* get_ItemHeaderStyle();
public: __property void set_ItemHeaderStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebAccordion's item header. (Applied when ExpandDirection is Top or Down).")]
public:
property ISNet.WebUI.DynamicStyle^ ItemHeaderStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


Items Property

[image]
Intersoft WebEssentials Documentation
Items Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : Items Property

Glossary Item Box

The item collection used by WebAccordion.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setItems")>
<System.ComponentModel.DescriptionAttribute("The item collection used by WebAccordion.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property Items As WebAccordionItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As WebAccordionItemCollection

value = instance.Items
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[System.ComponentModel.DescriptionAttribute("The item collection used by WebAccordion.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebAccordionItemCollection Items {get;}
Delphi
public read-only property Items: WebAccordionItemCollection;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setItems")
System.ComponentModel.DescriptionAttribute("The item collection used by WebAccordion.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get Items : WebAccordionItemCollection
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[System.ComponentModel.DescriptionAttribute("The item collection used by WebAccordion.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebAccordionItemCollection* get_Items();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[System.ComponentModel.DescriptionAttribute("The item collection used by WebAccordion.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebAccordionItemCollection^ Items {
   WebAccordionItemCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ItemSettings Property

[image]
Intersoft WebEssentials Documentation
ItemSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ItemSettings Property

Glossary Item Box

Provides the settings that control the default WebAccordion's item settings.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the default WebAccordion's item settings.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute("setItemSettings")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property ItemSettings As WebAccordionItemSettings
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As WebAccordionItemSettings

value = instance.ItemSettings
C#
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the default WebAccordion's item settings.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setItemSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebAccordionItemSettings ItemSettings {get;}
Delphi
public read-only property ItemSettings: WebAccordionItemSettings;
JScript
System.ComponentModel.DescriptionAttribute("Provides the settings that control the default WebAccordion's item settings.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute("setItemSettings")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
public function get ItemSettings : WebAccordionItemSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the default WebAccordion's item settings.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setItemSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebAccordionItemSettings* get_ItemSettings();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the default WebAccordion's item settings.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setItemSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebAccordionItemSettings^ ItemSettings {
   WebAccordionItemSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


Load Event

[image]
Intersoft WebEssentials Documentation
Load Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


LoadLayout Method

[image]
Intersoft WebEssentials Documentation
LoadLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


LoadLayoutFromFile Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim filePath As System.String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   System.string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: System.String
); virtual;
JScript
public function LoadLayoutFromFile(
   filePath : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromFile(
   System.string* filePath
)
C++/CLI
public:
virtual void LoadLayoutFromFile(
   System.String^ filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromPredefinedName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim predefinedName As System.String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   System.string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: System.String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   System.string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   System.String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


LoadLayoutFromStream Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: System.IO.Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   System.IO.Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


LoadPostData Method

[image]
Intersoft WebEssentials Documentation
LoadPostData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function LoadPostData( _
   ByVal postDataKey As System.String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim postDataKey As System.String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As System.Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public virtual System.bool LoadPostData(
   System.string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)
Delphi
public function LoadPostData(
    postDataKey: System.String;
    postCollection: System.Collections.Specialized.NameValueCollection
): System.Boolean; virtual;
JScript
public function LoadPostData(
   postDataKey : System.String,
   postCollection : System.Collections.Specialized.NameValueCollection
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool LoadPostData(
   System.string* postDataKey,
   System.Collections.Specialized.NameValueCollection* postCollection
)
C++/CLI
public:
virtual System.bool LoadPostData(
   System.String^ postDataKey,
   System.Collections.Specialized.NameValueCollection^ postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


MergeStyle Method

[image]
Intersoft WebEssentials Documentation
MergeStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


OnInfoChanged Method

[image]
Intersoft WebEssentials Documentation
OnInfoChanged Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


OnPreInitialize Method

[image]
Intersoft WebEssentials Documentation
OnPreInitialize Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


Page Property

[image]
Intersoft WebEssentials Documentation
Page Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}
Delphi
public read-write property Page: System.Web.UI.Page; virtual;
JScript
public function get,set Page : System.Web.UI.Page
Managed Extensions for C++
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
C++/CLI
public:
virtual property System.Web.UI.Page^ Page {
   System.Web.UI.Page^ get();
   void set (    System.Web.UI.Page^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


PreInitialize Event

[image]
Intersoft WebEssentials Documentation
PreInitialize Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim handler As System.EventHandler

AddHandler instance.PreInitialize, handler
C#
public event System.EventHandler PreInitialize
Delphi
public event PreInitialize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* PreInitialize
C++/CLI
public:
event System.EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


PreRender Event

[image]
Intersoft WebEssentials Documentation
PreRender Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebEssentials Documentation
RaisePostDataChangedEvent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); virtual;
JScript
public function RaisePostDataChangedEvent();
Managed Extensions for C++
public: virtual void RaisePostDataChangedEvent();
C++/CLI
public:
virtual void RaisePostDataChangedEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ReadWebConfigValue Method

[image]
Intersoft WebEssentials Documentation
ReadWebConfigValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim key As System.String
Dim value As System.String

value = instance.ReadWebConfigValue(key)
C#
public System.string ReadWebConfigValue(
   System.string key
)
Delphi
public function ReadWebConfigValue(
    key: System.String
): System.String;
JScript
public function ReadWebConfigValue(
   key : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ReadWebConfigValue(
   System.string* key
)
C++/CLI
public:
System.String^ ReadWebConfigValue(
   System.String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RecreateChildControls Method

[image]
Intersoft WebEssentials Documentation
RecreateChildControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion

instance.RecreateChildControls()
C#
public void RecreateChildControls()
Delphi
public procedure RecreateChildControls();
JScript
public function RecreateChildControls();
Managed Extensions for C++
public: void RecreateChildControls();
C++/CLI
public:
void RecreateChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RegisterBoxSizing Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RegisterBoxSizing() Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim forceAll As System.Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   System.bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: System.Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : System.boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   System.bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   System.bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebEssentials Documentation
RegisterGlobalStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RegisterLink Method

[image]
Intersoft WebEssentials Documentation
RegisterLink Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As System.String, _
   ByVal url As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim name As System.String
Dim url As System.String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   System.string name,
   System.string url
)
Delphi
public procedure RegisterLink(
    name: System.String;
    url: System.String
);
JScript
public function RegisterLink(
   name : System.String,
   url : System.String
);
Managed Extensions for C++
public: void RegisterLink(
   System.string* name,
   System.string* url
)
C++/CLI
public:
void RegisterLink(
   System.String^ name,
   System.String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebEssentials Documentation
RegisterOptimizedCssClasses Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim runtimeStyleOnly As System.Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: System.Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : System.boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RegisterPreloadImage Method

[image]
Intersoft WebEssentials Documentation
RegisterPreloadImage Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim image As System.String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   System.string image
)
Delphi
public procedure RegisterPreloadImage(
    image: System.String
);
JScript
public function RegisterPreloadImage(
   image : System.String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   System.string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   System.String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RegisterScript Method

[image]
Intersoft WebEssentials Documentation
RegisterScript Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion

instance.RegisterScript()
C#
public override void RegisterScript()
Delphi
public procedure RegisterScript(); override;
JScript
public override function RegisterScript();
Managed Extensions for C++
public: void RegisterScript(); override
C++/CLI
public:
void RegisterScript(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RegisterSharePointHandler Method

[image]
Intersoft WebEssentials Documentation
RegisterSharePointHandler Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RenderBeginTag Method

[image]
Intersoft WebEssentials Documentation
RenderBeginTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RenderControl Method

[image]
Intersoft WebEssentials Documentation
RenderControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebEssentials Documentation
RenderControl(HtmlTextWriter) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RenderEndTag Method

[image]
Intersoft WebEssentials Documentation
RenderEndTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RenderingMode Property

[image]
Intersoft WebEssentials Documentation
RenderingMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ResolveClientUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveClientUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ResolveImagePath Method

[image]
Intersoft WebEssentials Documentation
ResolveImagePath Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As System.String, _
   ByVal image As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim folder As System.String
Dim image As System.String
Dim value As System.String

value = instance.ResolveImagePath(folder, image)
C#
public System.string ResolveImagePath(
   System.string folder,
   System.string image
)
Delphi
public function ResolveImagePath(
    folder: System.String;
    image: System.String
): System.String;
JScript
public function ResolveImagePath(
   folder : System.String,
   image : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveImagePath(
   System.string* folder,
   System.string* image
)
C++/CLI
public:
System.String^ ResolveImagePath(
   System.String^ folder,
   System.String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ResolveRelativeURL Method

[image]
Intersoft WebEssentials Documentation
ResolveRelativeURL Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim url As System.String
Dim value As System.String

value = instance.ResolveRelativeURL(url)
C#
public virtual System.string ResolveRelativeURL(
   System.string url
)
Delphi
public function ResolveRelativeURL(
    url: System.String
): System.String; virtual;
JScript
public function ResolveRelativeURL(
   url : System.String
) : System.String;
Managed Extensions for C++
public: virtual System.string* ResolveRelativeURL(
   System.string* url
)
C++/CLI
public:
virtual System.String^ ResolveRelativeURL(
   System.String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ResolveResourceUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveResourceUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As System.String, _
   ByVal currentFolder As System.String, _
   ByVal resourceName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As System.String
Dim currentFolder As System.String
Dim resourceName As System.String
Dim value As System.String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public System.string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string defaultFolder,
   System.string currentFolder,
   System.string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: System.String;
    currentFolder: System.String;
    resourceName: System.String
): System.String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : System.String,
   currentFolder : System.String,
   resourceName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string* defaultFolder,
   System.string* currentFolder,
   System.string* resourceName
)
C++/CLI
public:
System.String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.String^ defaultFolder,
   System.String^ currentFolder,
   System.String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ResolveUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


RuntimeLicenseKey Property

[image]
Intersoft WebEssentials Documentation
RuntimeLicenseKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
Public Overridable Property RuntimeLicenseKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public virtual System.string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: System.String; virtual;
JScript
ISNet.PersistLayoutAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
public function get,set RuntimeLicenseKey : System.String
Managed Extensions for C++
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public: __property virtual System.string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   System.string* value
);
C++/CLI
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public:
virtual property System.String^ RuntimeLicenseKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


SaveLayout Method

[image]
Intersoft WebEssentials Documentation
SaveLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


SaveLayoutToFile Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim filePath As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   System.string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   System.string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   System.String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


SaveLayoutToStream Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
ScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
Public Overrides Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public override System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String; override;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")
System.ComponentModel.CategoryAttribute("Client Script Directory")
public override function get,set ScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public: __property System.string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public:
property System.String^ ScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


SelectedItemHeaderFrameStyle Property

[image]
Intersoft WebEssentials Documentation
SelectedItemHeaderFrameStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : SelectedItemHeaderFrameStyle Property

Glossary Item Box

Contains interactive style for selected item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for selected item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.")>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property SelectedItemHeaderFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.WebStyle

instance.SelectedItemHeaderFrameStyle = value

value = instance.SelectedItemHeaderFrameStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for selected item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.")]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle SelectedItemHeaderFrameStyle {get; set;}
Delphi
public read-write property SelectedItemHeaderFrameStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for selected item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.")
System.ComponentModel.CategoryAttribute("Style")
public function get,set SelectedItemHeaderFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for selected item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.")]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_SelectedItemHeaderFrameStyle();
public: __property void set_SelectedItemHeaderFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for selected item header frame style. Note that this style is applicable when ExpandDirection is set to Left or Right.")]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ SelectedItemHeaderFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


SetRenderMethodDelegate Method

[image]
Intersoft WebEssentials Documentation
SetRenderMethodDelegate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


SetSessionTheme Method

[image]
Intersoft WebEssentials Documentation
SetSessionTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


SharedScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
SharedScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required framework scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")>
Public Overrides Property SharedScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
public override System.string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: System.String; override;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")
public override function get,set SharedScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
public: __property System.string* get_SharedScriptDirectory() override;
public: __property void set_SharedScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
public:
property System.String^ SharedScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ShouldReturnJson Method

[image]
Intersoft WebEssentials Documentation
ShouldReturnJson Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

value = instance.ShouldReturnJson()
C#
public virtual System.bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): System.Boolean; virtual;
JScript
public function ShouldReturnJson() : System.boolean;
Managed Extensions for C++
public: virtual System.bool ShouldReturnJson();
C++/CLI
public:
virtual System.bool ShouldReturnJson();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


SkinID Property

[image]
Intersoft WebEssentials Documentation
SkinID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


SynchronizeTemplatesFrom Method

[image]
Intersoft WebEssentials Documentation
SynchronizeTemplatesFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : SynchronizeTemplatesFrom Method

sourceObj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SynchronizeTemplatesFrom( _
   ByVal sourceObj As ISNet.WebUI.ISNetControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim sourceObj As ISNet.WebUI.ISNetControl

instance.SynchronizeTemplatesFrom(sourceObj)
C#
public virtual void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl sourceObj
)
Delphi
public procedure SynchronizeTemplatesFrom(
    sourceObj: ISNet.WebUI.ISNetControl
); virtual;
JScript
public function SynchronizeTemplatesFrom(
   sourceObj : ISNet.WebUI.ISNetControl
);
Managed Extensions for C++
public: virtual void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl* sourceObj
)
C++/CLI
public:
virtual void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl^ sourceObj
)

Parameters

sourceObj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


TabIndex Property

[image]
Intersoft WebEssentials Documentation
TabIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set TabIndex : System.short
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ToolTip Property

[image]
Intersoft WebEssentials Documentation
ToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


Unload Event

[image]
Intersoft WebEssentials Documentation
Unload Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


UseDefaultStyle Property

[image]
Intersoft WebEssentials Documentation
UseDefaultStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : UseDefaultStyle Property

Glossary Item Box

Determines whether or not WebAccordion is using default style.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Determines whether or not WebAccordion is using default style.")>
Public Property UseDefaultStyle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

instance.UseDefaultStyle = value

value = instance.UseDefaultStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebAccordion is using default style.")]
public System.bool UseDefaultStyle {get; set;}
Delphi
public read-write property UseDefaultStyle: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Determines whether or not WebAccordion is using default style.")
public function get,set UseDefaultStyle : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebAccordion is using default style.")]
public: __property System.bool get_UseDefaultStyle();
public: __property void set_UseDefaultStyle(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebAccordion is using default style.")]
public:
property System.bool UseDefaultStyle {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ValidateRequestMode Property

[image]
Intersoft WebEssentials Documentation
ValidateRequestMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ViewStateItems Property

[image]
Intersoft WebEssentials Documentation
ViewStateItems Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ViewStateItems Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ViewStateMode Property

[image]
Intersoft WebEssentials Documentation
ViewStateMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ViewStateServerConnection Property

[image]
Intersoft WebEssentials Documentation
ViewStateServerConnection Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ViewStateServerConnection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ViewStateServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: System.String; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
System.ComponentModel.CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ViewStateServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ViewStateServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


ViewStateStorage Property

[image]
Intersoft WebEssentials Documentation
ViewStateStorage Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : ViewStateStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
System.ComponentModel.CategoryAttribute("View State Settings")
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


Width Property

[image]
Intersoft WebEssentials Documentation
Width Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overrides Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public override System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; override;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public override function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.Web.UI.WebControls.Unit get_Width() override;
public: __property void set_Width(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


XmlCompressionEnabled Property

[image]
Intersoft WebEssentials Documentation
XmlCompressionEnabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebAccordion Class : XmlCompressionEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property XmlCompressionEnabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebAccordion
Dim value As System.Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: System.Boolean; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set XmlCompressionEnabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool XmlCompressionEnabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebAccordion Class
WebAccordion Members


WebCalendar Class

[image]
Intersoft WebEssentials Documentation
WebCalendar Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendar Class

Glossary Item Box

Intersoft WebCalendar.

Object Model

WebCalendar Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebCalendar.js;WebAnimation.js;Shared\CultureInfo.js;Shared\CoreValidator.js", Type=XmlSerializationType.ClientAndLayout)>
<System.Web.UI.ToolboxDataAttribute("<{0}:WebCalendar runat=server Width="170px" Height="190px"></{0}:WebCalendar>")>
<System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebCalendarDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.SerializableAttribute()>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebCalendar
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
C#
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebCalendar.js;WebAnimation.js;Shared\CultureInfo.js;Shared\CoreValidator.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebCalendar runat=server Width="170px" Height="190px"></{0}:WebCalendar>")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebCalendarDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebCalendar : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Delphi
public class WebCalendar = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings)
JScript
ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebCalendar.js;WebAnimation.js;Shared\CultureInfo.js;Shared\CoreValidator.js", Type=XmlSerializationType.ClientAndLayout)
System.Web.UI.ToolboxDataAttribute("<{0}:WebCalendar runat=server Width="170px" Height="190px"></{0}:WebCalendar>")
System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebCalendarDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.SerializableAttribute()
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebCalendar extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebCalendar.js;WebAnimation.js;Shared\CultureInfo.js;Shared\CoreValidator.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebCalendar runat=server Width="170px" Height="190px"></{0}:WebCalendar>")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebCalendarDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebCalendar : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebCalendar.js;WebAnimation.js;Shared\CultureInfo.js;Shared\CoreValidator.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebCalendar runat=server Width="170px" Height="190px"></{0}:WebCalendar>")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebCalendarDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebCalendar : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebEssentials.WebCalendar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Members
ISNet.WebUI.WebEssentials Namespace


WebCalendar Class Events

[image]
Intersoft WebEssentials Documentation
WebCalendar Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendar Class

Glossary Item Box

For a list of all members of this type, see WebCalendar members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | SelectedDateChanged | Fires when selected date is changed in WebCalendar.
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebCalendar Class
ISNet.WebUI.WebEssentials Namespace


WebCalendar Class Members

[image]
Intersoft WebEssentials Documentation
WebCalendar Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendar Class

Glossary Item Box

The following tables list the members exposed by WebCalendar.

Public Constructors

 | Name | Description
Public Constructor | WebCalendar Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | CalendarItemHeight | Specifies height of each WebCalendar's item.
Public Property | CalendarItemWidth | Specifies width of each WebCalendar's item.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebCalendar.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Culture | Specifies the culture setting for current WebScheduler instance.
Public Property | CustomHighlightedDays | Specifies number of days that will be applied on custom highlight.
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | EnableAnimation | Determines whether or not animation is enabled in WebCalendar.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableKeyboardSupport | Determines whether or not keyboard is supported in WebCalendar.
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableMultipleSelection | Determines whether or not multiple selection is enabled in WebCalendar.
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FirstDayOfWeek | Specifies WebCalendar first day of week.
Public Property | FirstWeekOfYear | Specifies WebCalendar first week of year.
Public Property | FlyPostBackSettings |
Public Property | FocusCellStyle | Contains interactive style for WebCalendar focus cell.
Public Property | FrameStyle | Contains interactive style for Frame.
Public Property | HeaderStyle | Contains interactive style for WebCalendar header.
Public Property | Height | Overridden.
Public Property | HighlightMode | Specifies WebCalendar highlight mode.
Public Property | HighlightTodayDate | Determines whether or not today date should be highlighted in WebCalendar.
Public Property | Holidays | The data collection used by WebCalendar to determine holiday(s).
Public Property | HolidayStyle | Contains interactive style for WebCalendar holiday cell.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | ImagesSettings | Provides the settings that control the images in WebCalendar.
Public Property | InboundCellStyle | Contains interactive style for WebCalendar inbound cell.
Public Property | InitialDisplayDate | Specifies the initial WebScheduler's Date and Time.
Public Property | NavigateMode | Determines whether or not WebCalendar's SelectedDate always change when navigation is triggered.
Public Property | NumberOfCalendarDisplayed | Specifies number of calendar displayed in WebCalendar.
Public Property | OutboundCellStyle | Contains interactive style for WebCalendar outbound cell.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PostBackMode | Specifies WebCalendar postback mode.
Public Property | ReadOnly | Determines whether or not WebCalendar is read only.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SelectedCellStyle | Contains interactive style for WebCalendar selected cell.
Public Property | SelectedDate | Specifies the initial WebScheduler's Date and Time.
Public Property | SelectedDates | The selected dates collection used by WebCalendar when multiple selections is enabled.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | ShowWeekNumbers | Determines whether or not week number should be displayed in WebCalendar.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TableStyle | Contains interactive style for WebCalendar table.
Public Property | TextSettings | Provides settings that control text that shown in WebCalendar.
Public Property | TodayStyle | Contains interactive style for WebCalendar today cell.
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseDefaultStyle | Determines whether or not WebCalendar is using default style.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewMode | Specifies WebCalendar highlight mode.
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WeekNameStyle | Contains interactive style for WebCalendar week name.
Public Property | WeekNumberStyle | Contains interactive style for WebCalendar week number.
Public Property | WeekViewMode | Specifies WebCalendar week view mode.
Public Property | Width | Overridden.
Public Property | WorkWeekSettings | Provides the settings that control the behaviors of the WorkWeek in WebCalendar.
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCulture |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetXMLCultureInfo | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | SelectedDateChanged | Fires when selected date is changed in WebCalendar.
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebCalendar Class
ISNet.WebUI.WebEssentials Namespace


WebCalendar Class Methods

[image]
Intersoft WebEssentials Documentation
WebCalendar Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendar Class

Glossary Item Box

For a list of all members of this type, see WebCalendar members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCulture |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetXMLCultureInfo | Overridden.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebCalendar Class
ISNet.WebUI.WebEssentials Namespace


WebCalendar Class Properties

[image]
Intersoft WebEssentials Documentation
WebCalendar Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendar Class

Glossary Item Box

For a list of all members of this type, see WebCalendar members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | CalendarItemHeight | Specifies height of each WebCalendar's item.
Public Property | CalendarItemWidth | Specifies width of each WebCalendar's item.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebCalendar.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Culture | Specifies the culture setting for current WebScheduler instance.
Public Property | CustomHighlightedDays | Specifies number of days that will be applied on custom highlight.
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | EnableAnimation | Determines whether or not animation is enabled in WebCalendar.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableKeyboardSupport | Determines whether or not keyboard is supported in WebCalendar.
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableMultipleSelection | Determines whether or not multiple selection is enabled in WebCalendar.
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FirstDayOfWeek | Specifies WebCalendar first day of week.
Public Property | FirstWeekOfYear | Specifies WebCalendar first week of year.
Public Property | FlyPostBackSettings |
Public Property | FocusCellStyle | Contains interactive style for WebCalendar focus cell.
Public Property | FrameStyle | Contains interactive style for Frame.
Public Property | HeaderStyle | Contains interactive style for WebCalendar header.
Public Property | Height | Overridden.
Public Property | HighlightMode | Specifies WebCalendar highlight mode.
Public Property | HighlightTodayDate | Determines whether or not today date should be highlighted in WebCalendar.
Public Property | Holidays | The data collection used by WebCalendar to determine holiday(s).
Public Property | HolidayStyle | Contains interactive style for WebCalendar holiday cell.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | ImagesSettings | Provides the settings that control the images in WebCalendar.
Public Property | InboundCellStyle | Contains interactive style for WebCalendar inbound cell.
Public Property | InitialDisplayDate | Specifies the initial WebScheduler's Date and Time.
Public Property | NavigateMode | Determines whether or not WebCalendar's SelectedDate always change when navigation is triggered.
Public Property | NumberOfCalendarDisplayed | Specifies number of calendar displayed in WebCalendar.
Public Property | OutboundCellStyle | Contains interactive style for WebCalendar outbound cell.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PostBackMode | Specifies WebCalendar postback mode.
Public Property | ReadOnly | Determines whether or not WebCalendar is read only.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SelectedCellStyle | Contains interactive style for WebCalendar selected cell.
Public Property | SelectedDate | Specifies the initial WebScheduler's Date and Time.
Public Property | SelectedDates | The selected dates collection used by WebCalendar when multiple selections is enabled.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | ShowWeekNumbers | Determines whether or not week number should be displayed in WebCalendar.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TableStyle | Contains interactive style for WebCalendar table.
Public Property | TextSettings | Provides settings that control text that shown in WebCalendar.
Public Property | TodayStyle | Contains interactive style for WebCalendar today cell.
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseDefaultStyle | Determines whether or not WebCalendar is using default style.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewMode | Specifies WebCalendar highlight mode.
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WeekNameStyle | Contains interactive style for WebCalendar week name.
Public Property | WeekNumberStyle | Contains interactive style for WebCalendar week number.
Public Property | WeekViewMode | Specifies WebCalendar week view mode.
Public Property | Width | Overridden.
Public Property | WorkWeekSettings | Provides the settings that control the behaviors of the WorkWeek in WebCalendar.
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebCalendar Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarClientSideEvents Class

[image]
Intersoft WebEssentials Documentation
WebCalendarClientSideEvents Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarClientSideEvents Class

Glossary Item Box

A collection of WebCalendar's client side events.

Object Model

WebCalendarClientSideEvents Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebCalendarClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebCalendarClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebCalendarClientSideEvents = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebCalendarClientSideEvents extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebCalendarClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebCalendarClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebCalendarClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Members
ISNet.WebUI.WebEssentials Namespace


WebCalendarClientSideEvents Class Members

[image]
Intersoft WebEssentials Documentation
WebCalendarClientSideEvents Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebCalendarClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebCalendarClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnAfterNavigation | Gets or sets the event handler after navigation is triggered in WebCalendar.
Public Property | OnAfterRender | Gets or sets the event handler when WebCalendar is rendered.
Public Property | OnBeforeNavigation | Gets or sets the event handler before navigation is triggered in WebCalendar.
Public Property | OnCellClicked | Gets or sets the event handler when calendar cell is clicked.
Public Property | OnInitialized | Gets or sets the event handler that will be invoked when WebCalendar is initialized.
Public Property | OnResponse | Gets or sets the event handler on response.
Public Property | OnSelectedDateChanged | Gets or sets the event handler when SelectedDate is changed.
Public Property | OnViewChanged | Gets or sets the event handler when WebCalendar view is changed.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCalendarClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarClientSideEvents Class Methods

[image]
Intersoft WebEssentials Documentation
WebCalendarClientSideEvents Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebCalendarClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCalendarClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarClientSideEvents Class Properties

[image]
Intersoft WebEssentials Documentation
WebCalendarClientSideEvents Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebCalendarClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnAfterNavigation | Gets or sets the event handler after navigation is triggered in WebCalendar.
Public Property | OnAfterRender | Gets or sets the event handler when WebCalendar is rendered.
Public Property | OnBeforeNavigation | Gets or sets the event handler before navigation is triggered in WebCalendar.
Public Property | OnCellClicked | Gets or sets the event handler when calendar cell is clicked.
Public Property | OnInitialized | Gets or sets the event handler that will be invoked when WebCalendar is initialized.
Public Property | OnResponse | Gets or sets the event handler on response.
Public Property | OnSelectedDateChanged | Gets or sets the event handler when SelectedDate is changed.
Public Property | OnViewChanged | Gets or sets the event handler when WebCalendar view is changed.
Top

See Also

Reference

WebCalendarClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : WebCalendarClientSideEvents Constructor

Glossary Item Box

Overload List

Overload | Description
WebCalendarClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


WebCalendarClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : WebCalendarClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCalendarClientSideEvents()
C#
public WebCalendarClientSideEvents()
Delphi
public WebCalendarClientSideEvents();
JScript
public function WebCalendarClientSideEvents();
Managed Extensions for C++
public: WebCalendarClientSideEvents();
C++/CLI
public:
WebCalendarClientSideEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


OnAfterNavigation Property

[image]
Intersoft WebEssentials Documentation
OnAfterNavigation Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : OnAfterNavigation Property

Glossary Item Box

Gets or sets the event handler after navigation is triggered in WebCalendar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after navigation is triggered in WebCalendar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, navigation, calendarType")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnAfterNavigation As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim value As System.String

instance.OnAfterNavigation = value

value = instance.OnAfterNavigation
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after navigation is triggered in WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, navigation, calendarType")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnAfterNavigation {get; set;}
Delphi
public read-write property OnAfterNavigation: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after navigation is triggered in WebCalendar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, navigation, calendarType")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnAfterNavigation : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after navigation is triggered in WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, navigation, calendarType")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnAfterNavigation();
public: __property void set_OnAfterNavigation(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after navigation is triggered in WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, navigation, calendarType")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnAfterNavigation {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


OnAfterRender Property

[image]
Intersoft WebEssentials Documentation
OnAfterRender Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : OnAfterRender Property

Glossary Item Box

Gets or sets the event handler when WebCalendar is rendered.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebCalendar view is changed.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, calendarType")>
Public Property OnAfterRender As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim value As System.String

instance.OnAfterRender = value

value = instance.OnAfterRender
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebCalendar view is changed.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, calendarType")]
public System.string OnAfterRender {get; set;}
Delphi
public read-write property OnAfterRender: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebCalendar view is changed.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, calendarType")
public function get,set OnAfterRender : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebCalendar view is changed.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, calendarType")]
public: __property System.string* get_OnAfterRender();
public: __property void set_OnAfterRender(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebCalendar view is changed.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, calendarType")]
public:
property System.String^ OnAfterRender {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


OnBeforeNavigation Property

[image]
Intersoft WebEssentials Documentation
OnBeforeNavigation Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : OnBeforeNavigation Property

Glossary Item Box

Gets or sets the event handler before navigation is triggered in WebCalendar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before navigation is triggered in WebCalendar.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, navigation, calendarType")>
Public Property OnBeforeNavigation As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim value As System.String

instance.OnBeforeNavigation = value

value = instance.OnBeforeNavigation
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before navigation is triggered in WebCalendar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, navigation, calendarType")]
public System.string OnBeforeNavigation {get; set;}
Delphi
public read-write property OnBeforeNavigation: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before navigation is triggered in WebCalendar.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, navigation, calendarType")
public function get,set OnBeforeNavigation : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before navigation is triggered in WebCalendar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, navigation, calendarType")]
public: __property System.string* get_OnBeforeNavigation();
public: __property void set_OnBeforeNavigation(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before navigation is triggered in WebCalendar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, navigation, calendarType")]
public:
property System.String^ OnBeforeNavigation {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


OnCellClicked Property

[image]
Intersoft WebEssentials Documentation
OnCellClicked Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : OnCellClicked Property

Glossary Item Box

Gets or sets the event handler when calendar cell is clicked.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when calendar cell is clicked.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, element, newDate")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnCellClicked As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim value As System.String

instance.OnCellClicked = value

value = instance.OnCellClicked
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when calendar cell is clicked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, element, newDate")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnCellClicked {get; set;}
Delphi
public read-write property OnCellClicked: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when calendar cell is clicked.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, element, newDate")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnCellClicked : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when calendar cell is clicked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, element, newDate")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnCellClicked();
public: __property void set_OnCellClicked(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when calendar cell is clicked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, element, newDate")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnCellClicked {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


OnInitialized Property

[image]
Intersoft WebEssentials Documentation
OnInitialized Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : OnInitialized Property

Glossary Item Box

Gets or sets the event handler that will be invoked when WebCalendar is initialized.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebCalendar is initialized.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnInitialized As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim value As System.String

instance.OnInitialized = value

value = instance.OnInitialized
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebCalendar is initialized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnInitialized {get; set;}
Delphi
public read-write property OnInitialized: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebCalendar is initialized.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnInitialized : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebCalendar is initialized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnInitialized();
public: __property void set_OnInitialized(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebCalendar is initialized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnInitialized {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


OnResponse Property

[image]
Intersoft WebEssentials Documentation
OnResponse Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : OnResponse Property

Glossary Item Box

Gets or sets the event handler on response.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId, action")>
Public Property OnResponse As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim value As System.String

instance.OnResponse = value

value = instance.OnResponse
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, action")]
public System.string OnResponse {get; set;}
Delphi
public read-write property OnResponse: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId, action")
public function get,set OnResponse : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, action")]
public: __property System.string* get_OnResponse();
public: __property void set_OnResponse(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, action")]
public:
property System.String^ OnResponse {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


OnSelectedDateChanged Property

[image]
Intersoft WebEssentials Documentation
OnSelectedDateChanged Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : OnSelectedDateChanged Property

Glossary Item Box

Gets or sets the event handler when SelectedDate is changed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when SelectedDate is changed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, oldDates, newDates")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnSelectedDateChanged As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim value As System.String

instance.OnSelectedDateChanged = value

value = instance.OnSelectedDateChanged
C#
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when SelectedDate is changed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, oldDates, newDates")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnSelectedDateChanged {get; set;}
Delphi
public read-write property OnSelectedDateChanged: System.String;
JScript
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when SelectedDate is changed.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, oldDates, newDates")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnSelectedDateChanged : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when SelectedDate is changed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, oldDates, newDates")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnSelectedDateChanged();
public: __property void set_OnSelectedDateChanged(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when SelectedDate is changed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, oldDates, newDates")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnSelectedDateChanged {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


OnViewChanged Property

[image]
Intersoft WebEssentials Documentation
OnViewChanged Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : OnViewChanged Property

Glossary Item Box

Gets or sets the event handler when WebCalendar view is changed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebCalendar view is changed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnViewChanged As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim value As System.String

instance.OnViewChanged = value

value = instance.OnViewChanged
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebCalendar view is changed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnViewChanged {get; set;}
Delphi
public read-write property OnViewChanged: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebCalendar view is changed.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnViewChanged : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebCalendar view is changed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnViewChanged();
public: __property void set_OnViewChanged(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebCalendar view is changed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnViewChanged {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarClientSideEvents
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarClientSideEvents Class
WebCalendarClientSideEvents Members


WebCalendarDefaultStyleMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebCalendarDefaultStyleMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarDefaultStyleMode Enumeration

Glossary Item Box

Specifies DefaultStyle mode in WebCalendar.

Syntax

Visual Basic (Declaration)
Public Enum WebCalendarDefaultStyleMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarDefaultStyleMode
C#
public enum WebCalendarDefaultStyleMode : System.Enum
Delphi
public enum WebCalendarDefaultStyleMode = class(System.Enum)
JScript
public enum WebCalendarDefaultStyleMode extends System.Enum
Managed Extensions for C++
__value public enum WebCalendarDefaultStyleMode : public System.Enum
C++/CLI
public enum class WebCalendarDefaultStyleMode : public System.Enum

Members

Member | Description
OliveGreen |
Outlook2007Black |
Outlook2007Blue |
Win7 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebCalendarDefaultStyleMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebCalendarFirstWeekOfYear Enumeration

[image]
Intersoft WebEssentials Documentation
WebCalendarFirstWeekOfYear Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarFirstWeekOfYear Enumeration

Glossary Item Box

Specifies FirstWeekOfYear in WebCalendar.

Syntax

Visual Basic (Declaration)
Public Enum WebCalendarFirstWeekOfYear
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarFirstWeekOfYear
C#
public enum WebCalendarFirstWeekOfYear : System.Enum
Delphi
public enum WebCalendarFirstWeekOfYear = class(System.Enum)
JScript
public enum WebCalendarFirstWeekOfYear extends System.Enum
Managed Extensions for C++
__value public enum WebCalendarFirstWeekOfYear : public System.Enum
C++/CLI
public enum class WebCalendarFirstWeekOfYear : public System.Enum

Members

Member | Description
First4DayWeek |
FirstFullWeek |
StartsOnJanuary1 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebCalendarFirstWeekOfYear

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebCalendarHighlightMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebCalendarHighlightMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarHighlightMode Enumeration

Glossary Item Box

Specifies HighlightMode in WebCalendar.

Syntax

Visual Basic (Declaration)
Public Enum WebCalendarHighlightMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHighlightMode
C#
public enum WebCalendarHighlightMode : System.Enum
Delphi
public enum WebCalendarHighlightMode = class(System.Enum)
JScript
public enum WebCalendarHighlightMode extends System.Enum
Managed Extensions for C++
__value public enum WebCalendarHighlightMode : public System.Enum
C++/CLI
public enum class WebCalendarHighlightMode : public System.Enum

Members

Member | Description
Custom |
Day |
Month |
Week |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebCalendarHighlightMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebCalendarHoliday Class

[image]
Intersoft WebEssentials Documentation
WebCalendarHoliday Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarHoliday Class

Glossary Item Box

A collection of Holiday in WebCalendar.

Object Model

WebCalendarHoliday Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebCalendarHoliday
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebCalendarHoliday : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebCalendarHoliday = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebCalendarHoliday extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebCalendarHoliday : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebCalendarHoliday : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebEssentials.WebCalendarHoliday

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Members
ISNet.WebUI.WebEssentials Namespace


WebCalendarHoliday Class Members

[image]
Intersoft WebEssentials Documentation
WebCalendarHoliday Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarHoliday Class

Glossary Item Box

The following tables list the members exposed by WebCalendarHoliday.

Public Constructors

 | Name | Description
Public Constructor | WebCalendarHoliday Constructor |
Top

Public Properties

 | Name | Description
Public Property | Date | Specifies the Date of the Holiday.
Public Property | Description | Specifies the Description of the Holiday.
Public Property | IsGeneral | Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year.
Public Property | Name | Overridden. Specifies the Name of the Holiday.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCalendarHoliday Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarHoliday Class Methods

[image]
Intersoft WebEssentials Documentation
WebCalendarHoliday Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarHoliday Class

Glossary Item Box

For a list of all members of this type, see WebCalendarHoliday members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCalendarHoliday Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarHoliday Class Properties

[image]
Intersoft WebEssentials Documentation
WebCalendarHoliday Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarHoliday Class

Glossary Item Box

For a list of all members of this type, see WebCalendarHoliday members.

Public Properties

 | Name | Description
Public Property | Date | Specifies the Date of the Holiday.
Public Property | Description | Specifies the Description of the Holiday.
Public Property | IsGeneral | Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year.
Public Property | Name | Overridden. Specifies the Name of the Holiday.
Top

See Also

Reference

WebCalendarHoliday Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarHolidayCollection Class

[image]
Intersoft WebEssentials Documentation
WebCalendarHolidayCollection Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarHolidayCollection Class

Glossary Item Box

A collection of holiday used by WebCalendar.

Object Model

WebCalendarHolidayCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebCalendarHolidayCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebCalendarHoliday)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebCalendarHolidayCollection : ISNet.WebUI.ISGenericCollectionBase<WebCalendarHoliday>
Delphi
public class WebCalendarHolidayCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebCalendarHolidayCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebCalendarHolidayCollection : public ISNet.WebUI.ISGenericCollectionBase<WebCalendarHoliday>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebCalendarHolidayCollection : public ISNet.WebUI.ISGenericCollectionBase<WebCalendarHoliday>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebEssentials.WebCalendarHolidayCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Members
ISNet.WebUI.WebEssentials Namespace


WebCalendarHolidayCollection Class Members

[image]
Intersoft WebEssentials Documentation
WebCalendarHolidayCollection Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarHolidayCollection Class

Glossary Item Box

The following tables list the members exposed by WebCalendarHolidayCollection.

Public Constructors

 | Name | Description
Public Constructor | WebCalendarHolidayCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebCalendarHoliday>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebCalendarHoliday>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebCalendarHoliday>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebCalendarHolidayCollection Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarHolidayCollection Class Methods

[image]
Intersoft WebEssentials Documentation
WebCalendarHolidayCollection Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarHolidayCollection Class

Glossary Item Box

For a list of all members of this type, see WebCalendarHolidayCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebCalendarHoliday>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebCalendarHoliday>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebCalendarHoliday>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebCalendarHolidayCollection Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarHolidayCollection Class Properties

[image]
Intersoft WebEssentials Documentation
WebCalendarHolidayCollection Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarHolidayCollection Class

Glossary Item Box

For a list of all members of this type, see WebCalendarHolidayCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebCalendarHolidayCollection Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarHolidayCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarHolidayCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : WebCalendarHolidayCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebCalendarHolidayCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


WebCalendarHolidayCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarHolidayCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : WebCalendarHolidayCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCalendarHolidayCollection()
C#
public WebCalendarHolidayCollection()
Delphi
public WebCalendarHolidayCollection();
JScript
public function WebCalendarHolidayCollection();
Managed Extensions for C++
public: WebCalendarHolidayCollection();
C++/CLI
public:
WebCalendarHolidayCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


Add Method

[image]
Intersoft WebEssentials Documentation
Add Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


Clear Method

[image]
Intersoft WebEssentials Documentation
Clear Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


Contains Method

[image]
Intersoft WebEssentials Documentation
Contains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


CopyTo Method

[image]
Intersoft WebEssentials Documentation
CopyTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


Count Property

[image]
Intersoft WebEssentials Documentation
Count Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


CreateNewItem Method

[image]
Intersoft WebEssentials Documentation
CreateNewItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebCalendarHoliday
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim value As WebCalendarHoliday

value = instance.CreateNewItem()
C#
public WebCalendarHoliday CreateNewItem()
Delphi
public function CreateNewItem(): WebCalendarHoliday;
JScript
public function CreateNewItem() : WebCalendarHoliday;
Managed Extensions for C++
public: WebCalendarHoliday* CreateNewItem();
C++/CLI
public:
WebCalendarHoliday^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


GetEnumerator Method

[image]
Intersoft WebEssentials Documentation
GetEnumerator Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


GetNamedItem Method

[image]
Intersoft WebEssentials Documentation
GetNamedItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebCalendarHoliday
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim name As System.String
Dim value As WebCalendarHoliday

value = instance.GetNamedItem(name)
C#
public WebCalendarHoliday GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebCalendarHoliday;
JScript
public function GetNamedItem(
   name : System.String
) : WebCalendarHoliday;
Managed Extensions for C++
public: WebCalendarHoliday* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebCalendarHoliday^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


IndexOf Method

[image]
Intersoft WebEssentials Documentation
IndexOf Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


Insert Method

[image]
Intersoft WebEssentials Documentation
Insert Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


Item Property

[image]
Intersoft WebEssentials Documentation
Item Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


Parent Property

[image]
Intersoft WebEssentials Documentation
Parent Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


Remove Method

[image]
Intersoft WebEssentials Documentation
Remove Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


RemoveAt Method

[image]
Intersoft WebEssentials Documentation
RemoveAt Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


SerializerConstructor Method

[image]
Intersoft WebEssentials Documentation
SerializerConstructor Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


SetParent Method

[image]
Intersoft WebEssentials Documentation
SetParent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHolidayCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHolidayCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHolidayCollection Class
WebCalendarHolidayCollection Members


WebCalendarHoliday Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarHoliday Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : WebCalendarHoliday Constructor

Glossary Item Box

Overload List

Overload | Description
WebCalendarHoliday Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


WebCalendarHoliday Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarHoliday Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : WebCalendarHoliday Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCalendarHoliday()
C#
public WebCalendarHoliday()
Delphi
public WebCalendarHoliday();
JScript
public function WebCalendarHoliday();
Managed Extensions for C++
public: WebCalendarHoliday();
C++/CLI
public:
WebCalendarHoliday();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members
Overload List


Date Property

[image]
Intersoft WebEssentials Documentation
Date Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : Date Property

Glossary Item Box

Specifies the Date of the Holiday.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the Date of the Holiday.")>
<System.ComponentModel.CategoryAttribute("Holiday")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Date As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday
Dim value As System.Date

instance.Date = value

value = instance.Date
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Date of the Holiday.")]
[System.ComponentModel.CategoryAttribute("Holiday")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.DateTime Date {get; set;}
Delphi
public read-write property Date: System.DateTime;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the Date of the Holiday.")
System.ComponentModel.CategoryAttribute("Holiday")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Date : System.DateTime
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Date of the Holiday.")]
[System.ComponentModel.CategoryAttribute("Holiday")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.DateTime get_Date();
public: __property void set_Date(
   System.DateTime value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Date of the Holiday.")]
[System.ComponentModel.CategoryAttribute("Holiday")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.DateTime Date {
   System.DateTime get();
   void set (    System.DateTime value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


Description Property

[image]
Intersoft WebEssentials Documentation
Description Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : Description Property

Glossary Item Box

Specifies the Description of the Holiday.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the Description of the Holiday.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Holiday")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Description As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday
Dim value As System.String

instance.Description = value

value = instance.Description
C#
[System.ComponentModel.DescriptionAttribute("Specifies the Description of the Holiday.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Description {get; set;}
Delphi
public read-write property Description: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the Description of the Holiday.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Holiday")
System.ComponentModel.DefaultValueAttribute()
public function get,set Description : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the Description of the Holiday.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Description();
public: __property void set_Description(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the Description of the Holiday.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Description {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


IsGeneral Property

[image]
Intersoft WebEssentials Documentation
IsGeneral Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : IsGeneral Property

Glossary Item Box

Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Holiday")>
Public Property IsGeneral As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday
Dim value As System.Boolean

instance.IsGeneral = value

value = instance.IsGeneral
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
public System.bool IsGeneral {get; set;}
Delphi
public read-write property IsGeneral: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Holiday")
public function get,set IsGeneral : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
public: __property System.bool get_IsGeneral();
public: __property void set_IsGeneral(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether the holiday will appear on the same date and same month, eventhough it is not the same year.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
public:
property System.bool IsGeneral {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


Name Property

[image]
Intersoft WebEssentials Documentation
Name Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : Name Property

Glossary Item Box

Specifies the Name of the Holiday.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Holiday")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the Name of the Holiday.")>
<System.ComponentModel.BrowsableAttribute(True)>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Name of the Holiday.")]
[System.ComponentModel.BrowsableAttribute(true)]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Holiday")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the Name of the Holiday.")
System.ComponentModel.BrowsableAttribute()
public override function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Name of the Holiday.")]
[System.ComponentModel.BrowsableAttribute(true)]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Holiday")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Name of the Holiday.")]
[System.ComponentModel.BrowsableAttribute(true)]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarHoliday Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarHoliday
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarHoliday Class
WebCalendarHoliday Members


WebCalendarImagesSettings Class

[image]
Intersoft WebEssentials Documentation
WebCalendarImagesSettings Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarImagesSettings Class

Glossary Item Box

A collection of WebCalendar's images settings.

Object Model

WebCalendarImagesSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebCalendarImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebCalendarImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebCalendarImagesSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebCalendarImagesSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebCalendarImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebCalendarImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebCalendarImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Members
ISNet.WebUI.WebEssentials Namespace


WebCalendarImagesSettings Class Members

[image]
Intersoft WebEssentials Documentation
WebCalendarImagesSettings Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebCalendarImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebCalendarImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | BlackNext |
Public Property | BlackPrev |
Public Property | BlueNext |
Public Property | BluePrev |
Public Property | GreenNext |
Public Property | GreenPrev |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCalendarImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarImagesSettings Class Methods

[image]
Intersoft WebEssentials Documentation
WebCalendarImagesSettings Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebCalendarImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCalendarImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarImagesSettings Class Properties

[image]
Intersoft WebEssentials Documentation
WebCalendarImagesSettings Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebCalendarImagesSettings members.

Public Properties

 | Name | Description
Public Property | BlackNext |
Public Property | BlackPrev |
Public Property | BlueNext |
Public Property | BluePrev |
Public Property | GreenNext |
Public Property | GreenPrev |
Top

See Also

Reference

WebCalendarImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarImagesSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarImagesSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : WebCalendarImagesSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebCalendarImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


WebCalendarImagesSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarImagesSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : WebCalendarImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCalendarImagesSettings()
C#
public WebCalendarImagesSettings()
Delphi
public WebCalendarImagesSettings();
JScript
public function WebCalendarImagesSettings();
Managed Extensions for C++
public: WebCalendarImagesSettings();
C++/CLI
public:
WebCalendarImagesSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


BlackNext Property

[image]
Intersoft WebEssentials Documentation
BlackNext Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : BlackNext Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the Office2007Black next image of WebCalendar.")>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<ISNet.MarkAsStyleAttribute(True)>
Public Property BlackNext As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim value As System.String

instance.BlackNext = value

value = instance.BlackNext
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the Office2007Black next image of WebCalendar.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
public System.string BlackNext {get; set;}
Delphi
public read-write property BlackNext: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Sets the Office2007Black next image of WebCalendar.")
System.ComponentModel.CategoryAttribute("ImagesSettings")
ISNet.MarkAsStyleAttribute()
public function get,set BlackNext : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the Office2007Black next image of WebCalendar.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
public: __property System.string* get_BlackNext();
public: __property void set_BlackNext(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the Office2007Black next image of WebCalendar.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
public:
property System.String^ BlackNext {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


BlackPrev Property

[image]
Intersoft WebEssentials Documentation
BlackPrev Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : BlackPrev Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the Office2007Black previous image of WebCalendar.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property BlackPrev As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim value As System.String

instance.BlackPrev = value

value = instance.BlackPrev
C#
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the Office2007Black previous image of WebCalendar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string BlackPrev {get; set;}
Delphi
public read-write property BlackPrev: System.String;
JScript
System.ComponentModel.CategoryAttribute("ImagesSettings")
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DescriptionAttribute("Sets the Office2007Black previous image of WebCalendar.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set BlackPrev : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the Office2007Black previous image of WebCalendar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_BlackPrev();
public: __property void set_BlackPrev(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the Office2007Black previous image of WebCalendar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ BlackPrev {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


BlueNext Property

[image]
Intersoft WebEssentials Documentation
BlueNext Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : BlueNext Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DescriptionAttribute("Sets the Office2007Blue next image of WebCalendar.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property BlueNext As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim value As System.String

instance.BlueNext = value

value = instance.BlueNext
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the Office2007Blue next image of WebCalendar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string BlueNext {get; set;}
Delphi
public read-write property BlueNext: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DescriptionAttribute("Sets the Office2007Blue next image of WebCalendar.")
System.ComponentModel.DefaultValueAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set BlueNext : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the Office2007Blue next image of WebCalendar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_BlueNext();
public: __property void set_BlueNext(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the Office2007Blue next image of WebCalendar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ BlueNext {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


BluePrev Property

[image]
Intersoft WebEssentials Documentation
BluePrev Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : BluePrev Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DescriptionAttribute("Sets the Office2007Blue previous image of WebCalendar.")>
Public Property BluePrev As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim value As System.String

instance.BluePrev = value

value = instance.BluePrev
C#
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the Office2007Blue previous image of WebCalendar.")]
public System.string BluePrev {get; set;}
Delphi
public read-write property BluePrev: System.String;
JScript
ISNet.MarkAsStyleAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DescriptionAttribute("Sets the Office2007Blue previous image of WebCalendar.")
public function get,set BluePrev : System.String
Managed Extensions for C++
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the Office2007Blue previous image of WebCalendar.")]
public: __property System.string* get_BluePrev();
public: __property void set_BluePrev(
   System.string* value
);
C++/CLI
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the Office2007Blue previous image of WebCalendar.")]
public:
property System.String^ BluePrev {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


GreenNext Property

[image]
Intersoft WebEssentials Documentation
GreenNext Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : GreenNext Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the OliveGreen next image of WebCalendar.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property GreenNext As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim value As System.String

instance.GreenNext = value

value = instance.GreenNext
C#
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the OliveGreen next image of WebCalendar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string GreenNext {get; set;}
Delphi
public read-write property GreenNext: System.String;
JScript
System.ComponentModel.CategoryAttribute("ImagesSettings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DescriptionAttribute("Sets the OliveGreen next image of WebCalendar.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set GreenNext : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the OliveGreen next image of WebCalendar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_GreenNext();
public: __property void set_GreenNext(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the OliveGreen next image of WebCalendar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ GreenNext {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


GreenPrev Property

[image]
Intersoft WebEssentials Documentation
GreenPrev Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : GreenPrev Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the OliveGreen previous image of WebCalendar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property GreenPrev As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim value As System.String

instance.GreenPrev = value

value = instance.GreenPrev
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the OliveGreen previous image of WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string GreenPrev {get; set;}
Delphi
public read-write property GreenPrev: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Sets the OliveGreen previous image of WebCalendar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set GreenPrev : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the OliveGreen previous image of WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_GreenPrev();
public: __property void set_GreenPrev(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the OliveGreen previous image of WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ GreenPrev {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarImagesSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarImagesSettings Class
WebCalendarImagesSettings Members


WebCalendarOnSelectedDateChangedEventHandler Delegate

[image]
Intersoft WebEssentials Documentation
WebCalendarOnSelectedDateChangedEventHandler Delegate
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarOnSelectedDateChangedEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the OnSelectedDateChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebCalendarOnSelectedDateChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebCalendarSelectedDateEventDataArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebCalendarOnSelectedDateChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebCalendarOnSelectedDateChangedEventHandler(
   System.object sender,
   WebCalendarSelectedDateEventDataArgs e
)
Delphi
public delegate WebCalendarOnSelectedDateChangedEventHandler(
    sender: System.TObject;
    e: WebCalendarSelectedDateEventDataArgs
);
JScript
public delegate WebCalendarOnSelectedDateChangedEventHandler(
   sender : System.Object,
   e : WebCalendarSelectedDateEventDataArgs
)
Managed Extensions for C++
public: __gc __delegate void WebCalendarOnSelectedDateChangedEventHandler(
   System.Object* sender,
   WebCalendarSelectedDateEventDataArgs* e
)
C++/CLI
public delegate void WebCalendarOnSelectedDateChangedEventHandler(
   System.Object^ sender,
   WebCalendarSelectedDateEventDataArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarOnSelectedDateChangedEventHandler Members
ISNet.WebUI.WebEssentials Namespace


WebCalendarPresets Class

[image]
Intersoft WebEssentials Documentation
WebCalendarPresets Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarPresets Class

Glossary Item Box

Object Model

WebCalendarPresets Class

Syntax

Visual Basic (Declaration)
Public Class WebCalendarPresets
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarPresets
C#
public class WebCalendarPresets
Delphi
public class WebCalendarPresets
JScript
public class WebCalendarPresets
Managed Extensions for C++
public __gc class WebCalendarPresets
C++/CLI
public ref class WebCalendarPresets

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebEssentials.WebCalendarPresets

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarPresets Members
ISNet.WebUI.WebEssentials Namespace


WebCalendarPresets Class Members

[image]
Intersoft WebEssentials Documentation
WebCalendarPresets Class Members
See Also Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarPresets Class

Glossary Item Box

The following tables list the members exposed by WebCalendarPresets.

Public Constructors

 | Name | Description
Public Constructor | WebCalendarPresets Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

WebCalendarPresets Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarPresets Class Methods

[image]
Intersoft WebEssentials Documentation
WebCalendarPresets Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarPresets Class

Glossary Item Box

For a list of all members of this type, see WebCalendarPresets members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

WebCalendarPresets Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarPresets Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarPresets Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarPresets Class : WebCalendarPresets Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCalendarPresets()
C#
public WebCalendarPresets()
Delphi
public WebCalendarPresets();
JScript
public function WebCalendarPresets();
Managed Extensions for C++
public: WebCalendarPresets();
C++/CLI
public:
WebCalendarPresets();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarPresets Class
WebCalendarPresets Members


GetDefaultStyle Method

[image]
Intersoft WebEssentials Documentation
GetDefaultStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarPresets Class : GetDefaultStyle Method

mode
styleName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetDefaultStyle( _
   ByVal mode As WebCalendarDefaultStyleMode, _
   ByVal styleName As System.String _
) As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim mode As WebCalendarDefaultStyleMode
Dim styleName As System.String
Dim value As ISNet.WebUI.WebStyle

value = WebCalendarPresets.GetDefaultStyle(mode, styleName)
C#
public static ISNet.WebUI.WebStyle GetDefaultStyle(
   WebCalendarDefaultStyleMode mode,
   System.string styleName
)
Delphi
public function GetDefaultStyle(
    mode: WebCalendarDefaultStyleMode;
    styleName: System.String
): ISNet.WebUI.WebStyle; static;
JScript
public static function GetDefaultStyle(
   mode : WebCalendarDefaultStyleMode,
   styleName : System.String
) : ISNet.WebUI.WebStyle;
Managed Extensions for C++
public: static ISNet.WebUI.WebStyle* GetDefaultStyle(
   WebCalendarDefaultStyleMode mode,
   System.string* styleName
)
C++/CLI
public:
static ISNet.WebUI.WebStyle^ GetDefaultStyle(
   WebCalendarDefaultStyleMode mode,
   System.String^ styleName
)

Parameters

mode
styleName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarPresets Class
WebCalendarPresets Members


WebCalendarSelectedDateEventDataArgs Class

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDateEventDataArgs Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarSelectedDateEventDataArgs Class

Glossary Item Box

Provides data for OnSelectedDateChanged event.

Object Model

WebCalendarSelectedDateEventDataArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebCalendarSelectedDateEventDataArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDateEventDataArgs
C#
public class WebCalendarSelectedDateEventDataArgs : System.EventArgs
Delphi
public class WebCalendarSelectedDateEventDataArgs = class(System.EventArgs)
JScript
public class WebCalendarSelectedDateEventDataArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebCalendarSelectedDateEventDataArgs : public System.EventArgs
C++/CLI
public ref class WebCalendarSelectedDateEventDataArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebEssentials.WebCalendarSelectedDateEventDataArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDateEventDataArgs Members
ISNet.WebUI.WebEssentials Namespace


WebCalendarSelectedDateEventDataArgs Class Members

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDateEventDataArgs Class Members
See Also Properties Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarSelectedDateEventDataArgs Class

Glossary Item Box

The following tables list the members exposed by WebCalendarSelectedDateEventDataArgs.

Public Constructors

 | Name | Description
Public Constructor | WebCalendarSelectedDateEventDataArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | NewDates |
Public Property | OldDates |
Top

See Also

Reference

WebCalendarSelectedDateEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarSelectedDateEventDataArgs Class Properties

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDateEventDataArgs Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarSelectedDateEventDataArgs Class

Glossary Item Box

For a list of all members of this type, see WebCalendarSelectedDateEventDataArgs members.

Public Properties

 | Name | Description
Public Property | NewDates |
Public Property | OldDates |
Top

See Also

Reference

WebCalendarSelectedDateEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarSelectedDateEventDataArgs Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDateEventDataArgs Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDateEventDataArgs Class : WebCalendarSelectedDateEventDataArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCalendarSelectedDateEventDataArgs()
C#
public WebCalendarSelectedDateEventDataArgs()
Delphi
public WebCalendarSelectedDateEventDataArgs();
JScript
public function WebCalendarSelectedDateEventDataArgs();
Managed Extensions for C++
public: WebCalendarSelectedDateEventDataArgs();
C++/CLI
public:
WebCalendarSelectedDateEventDataArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDateEventDataArgs Class
WebCalendarSelectedDateEventDataArgs Members


NewDates Property

[image]
Intersoft WebEssentials Documentation
NewDates Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDateEventDataArgs Class : NewDates Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property NewDates As System.Collections.Generic.List(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDateEventDataArgs
Dim value As System.Collections.Generic.List(Of Date)

instance.NewDates = value

value = instance.NewDates
C#
public System.Collections.Generic.List<DateTime> NewDates {get; set;}
Delphi
public read-write property NewDates: System.Collections.Generic.List;
JScript
public function get,set NewDates : System.Collections.Generic.List
Managed Extensions for C++
public: __property System.Collections.Generic.List<DateTime>* get_NewDates();
public: __property void set_NewDates(
   System.Collections.Generic.List<DateTime>* value
);
C++/CLI
public:
property System.Collections.Generic.List<DateTime>^ NewDates {
   System.Collections.Generic.List<DateTime>^ get();
   void set (    System.Collections.Generic.List<DateTime>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDateEventDataArgs Class
WebCalendarSelectedDateEventDataArgs Members


OldDates Property

[image]
Intersoft WebEssentials Documentation
OldDates Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDateEventDataArgs Class : OldDates Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property OldDates As System.Collections.Generic.List(Of Date)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDateEventDataArgs
Dim value As System.Collections.Generic.List(Of Date)

instance.OldDates = value

value = instance.OldDates
C#
public System.Collections.Generic.List<DateTime> OldDates {get; set;}
Delphi
public read-write property OldDates: System.Collections.Generic.List;
JScript
public function get,set OldDates : System.Collections.Generic.List
Managed Extensions for C++
public: __property System.Collections.Generic.List<DateTime>* get_OldDates();
public: __property void set_OldDates(
   System.Collections.Generic.List<DateTime>* value
);
C++/CLI
public:
property System.Collections.Generic.List<DateTime>^ OldDates {
   System.Collections.Generic.List<DateTime>^ get();
   void set (    System.Collections.Generic.List<DateTime>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDateEventDataArgs Class
WebCalendarSelectedDateEventDataArgs Members


WebCalendarSelectedDates Class

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDates Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarSelectedDates Class

Glossary Item Box

A collection of SelectedDates in WebCalendar.

Object Model

WebCalendarSelectedDates Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebCalendarSelectedDates
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDates
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebCalendarSelectedDates : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebCalendarSelectedDates = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebCalendarSelectedDates extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebCalendarSelectedDates : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebCalendarSelectedDates : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebEssentials.WebCalendarSelectedDates

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Members
ISNet.WebUI.WebEssentials Namespace


WebCalendarSelectedDates Class Members

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDates Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarSelectedDates Class

Glossary Item Box

The following tables list the members exposed by WebCalendarSelectedDates.

Public Constructors

 | Name | Description
Public Constructor | WebCalendarSelectedDates Constructor |
Top

Public Properties

 | Name | Description
Public Property | Date | Specifies the Date of the SelectedDates.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCalendarSelectedDates Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarSelectedDates Class Methods

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDates Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarSelectedDates Class

Glossary Item Box

For a list of all members of this type, see WebCalendarSelectedDates members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCalendarSelectedDates Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarSelectedDates Class Properties

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDates Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarSelectedDates Class

Glossary Item Box

For a list of all members of this type, see WebCalendarSelectedDates members.

Public Properties

 | Name | Description
Public Property | Date | Specifies the Date of the SelectedDates.
Top

See Also

Reference

WebCalendarSelectedDates Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarSelectedDatesCollection Class

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDatesCollection Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarSelectedDatesCollection Class

Glossary Item Box

A collection of SelectedDates used by WebCalendar.

Object Model

WebCalendarSelectedDatesCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebCalendarSelectedDatesCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebCalendarSelectedDates)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebCalendarSelectedDatesCollection : ISNet.WebUI.ISGenericCollectionBase<WebCalendarSelectedDates>
Delphi
public class WebCalendarSelectedDatesCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebCalendarSelectedDatesCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebCalendarSelectedDatesCollection : public ISNet.WebUI.ISGenericCollectionBase<WebCalendarSelectedDates>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebCalendarSelectedDatesCollection : public ISNet.WebUI.ISGenericCollectionBase<WebCalendarSelectedDates>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebEssentials.WebCalendarSelectedDatesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Members
ISNet.WebUI.WebEssentials Namespace


WebCalendarSelectedDatesCollection Class Members

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDatesCollection Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarSelectedDatesCollection Class

Glossary Item Box

The following tables list the members exposed by WebCalendarSelectedDatesCollection.

Public Constructors

 | Name | Description
Public Constructor | WebCalendarSelectedDatesCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebCalendarSelectedDates>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebCalendarSelectedDates>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebCalendarSelectedDates>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebCalendarSelectedDatesCollection Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarSelectedDatesCollection Class Methods

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDatesCollection Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarSelectedDatesCollection Class

Glossary Item Box

For a list of all members of this type, see WebCalendarSelectedDatesCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebCalendarSelectedDates>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebCalendarSelectedDates>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebCalendarSelectedDates>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebCalendarSelectedDatesCollection Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarSelectedDatesCollection Class Properties

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDatesCollection Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarSelectedDatesCollection Class

Glossary Item Box

For a list of all members of this type, see WebCalendarSelectedDatesCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebCalendarSelectedDatesCollection Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarSelectedDatesCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDatesCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : WebCalendarSelectedDatesCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebCalendarSelectedDatesCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


WebCalendarSelectedDatesCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDatesCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : WebCalendarSelectedDatesCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCalendarSelectedDatesCollection()
C#
public WebCalendarSelectedDatesCollection()
Delphi
public WebCalendarSelectedDatesCollection();
JScript
public function WebCalendarSelectedDatesCollection();
Managed Extensions for C++
public: WebCalendarSelectedDatesCollection();
C++/CLI
public:
WebCalendarSelectedDatesCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


Add Method

[image]
Intersoft WebEssentials Documentation
Add Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


Clear Method

[image]
Intersoft WebEssentials Documentation
Clear Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


Contains Method

[image]
Intersoft WebEssentials Documentation
Contains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


CopyTo Method

[image]
Intersoft WebEssentials Documentation
CopyTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


Count Property

[image]
Intersoft WebEssentials Documentation
Count Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


CreateNewItem Method

[image]
Intersoft WebEssentials Documentation
CreateNewItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebCalendarSelectedDates
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim value As WebCalendarSelectedDates

value = instance.CreateNewItem()
C#
public WebCalendarSelectedDates CreateNewItem()
Delphi
public function CreateNewItem(): WebCalendarSelectedDates;
JScript
public function CreateNewItem() : WebCalendarSelectedDates;
Managed Extensions for C++
public: WebCalendarSelectedDates* CreateNewItem();
C++/CLI
public:
WebCalendarSelectedDates^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


GetEnumerator Method

[image]
Intersoft WebEssentials Documentation
GetEnumerator Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


GetNamedItem Method

[image]
Intersoft WebEssentials Documentation
GetNamedItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebCalendarSelectedDates
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim name As System.String
Dim value As WebCalendarSelectedDates

value = instance.GetNamedItem(name)
C#
public WebCalendarSelectedDates GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebCalendarSelectedDates;
JScript
public function GetNamedItem(
   name : System.String
) : WebCalendarSelectedDates;
Managed Extensions for C++
public: WebCalendarSelectedDates* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebCalendarSelectedDates^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


IndexOf Method

[image]
Intersoft WebEssentials Documentation
IndexOf Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


Insert Method

[image]
Intersoft WebEssentials Documentation
Insert Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


Item Property

[image]
Intersoft WebEssentials Documentation
Item Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


Parent Property

[image]
Intersoft WebEssentials Documentation
Parent Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


Remove Method

[image]
Intersoft WebEssentials Documentation
Remove Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


RemoveAt Method

[image]
Intersoft WebEssentials Documentation
RemoveAt Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


SerializerConstructor Method

[image]
Intersoft WebEssentials Documentation
SerializerConstructor Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


SetParent Method

[image]
Intersoft WebEssentials Documentation
SetParent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDatesCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDatesCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDatesCollection Class
WebCalendarSelectedDatesCollection Members


WebCalendarSelectedDates Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDates Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDates Class : WebCalendarSelectedDates Constructor

Glossary Item Box

Overload List

Overload | Description
WebCalendarSelectedDates Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Class
WebCalendarSelectedDates Members


WebCalendarSelectedDates Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarSelectedDates Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDates Class : WebCalendarSelectedDates Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCalendarSelectedDates()
C#
public WebCalendarSelectedDates()
Delphi
public WebCalendarSelectedDates();
JScript
public function WebCalendarSelectedDates();
Managed Extensions for C++
public: WebCalendarSelectedDates();
C++/CLI
public:
WebCalendarSelectedDates();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Class
WebCalendarSelectedDates Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDates Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDates
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Class
WebCalendarSelectedDates Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDates Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Class
WebCalendarSelectedDates Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDates Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDates
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Class
WebCalendarSelectedDates Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDates Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDates
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Class
WebCalendarSelectedDates Members
Overload List


Date Property

[image]
Intersoft WebEssentials Documentation
Date Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDates Class : Date Property

Glossary Item Box

Specifies the Date of the SelectedDates.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the Date of the SelectedDates.")>
<System.ComponentModel.CategoryAttribute("SelectedDates")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Date As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDates
Dim value As System.Date

instance.Date = value

value = instance.Date
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Date of the SelectedDates.")]
[System.ComponentModel.CategoryAttribute("SelectedDates")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.DateTime Date {get; set;}
Delphi
public read-write property Date: System.DateTime;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the Date of the SelectedDates.")
System.ComponentModel.CategoryAttribute("SelectedDates")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Date : System.DateTime
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Date of the SelectedDates.")]
[System.ComponentModel.CategoryAttribute("SelectedDates")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.DateTime get_Date();
public: __property void set_Date(
   System.DateTime value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the Date of the SelectedDates.")]
[System.ComponentModel.CategoryAttribute("SelectedDates")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.DateTime Date {
   System.DateTime get();
   void set (    System.DateTime value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Class
WebCalendarSelectedDates Members


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDates Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDates
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Class
WebCalendarSelectedDates Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDates Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDates
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Class
WebCalendarSelectedDates Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDates Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDates
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Class
WebCalendarSelectedDates Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDates Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDates
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Class
WebCalendarSelectedDates Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDates Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDates

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Class
WebCalendarSelectedDates Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDates Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDates
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Class
WebCalendarSelectedDates Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarSelectedDates Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarSelectedDates
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarSelectedDates Class
WebCalendarSelectedDates Members


WebCalendarTextSettings Class

[image]
Intersoft WebEssentials Documentation
WebCalendarTextSettings Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarTextSettings Class

Glossary Item Box

A collection of settings which controls the text shown in WebCalendar.

Object Model

WebCalendarTextSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebCalendarTextSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarTextSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebCalendarTextSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebCalendarTextSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebCalendarTextSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebCalendarTextSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebCalendarTextSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebCalendarTextSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Members
ISNet.WebUI.WebEssentials Namespace


WebCalendarTextSettings Class Members

[image]
Intersoft WebEssentials Documentation
WebCalendarTextSettings Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarTextSettings Class

Glossary Item Box

The following tables list the members exposed by WebCalendarTextSettings.

Public Constructors

 | Name | Description
Public Constructor | WebCalendarTextSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | CalendarHeaderText | Specifies the tooltip text of WebCalendar header.
Public Property | CalendarNextArrowText | Specifies the tooltip text of WebCalendar next arrow.
Public Property | CalendarPrevArrowText | Specifies the tooltip text of WebCalendar previous arrow.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCalendarTextSettings Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarTextSettings Class Methods

[image]
Intersoft WebEssentials Documentation
WebCalendarTextSettings Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebCalendarTextSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCalendarTextSettings Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarTextSettings Class Properties

[image]
Intersoft WebEssentials Documentation
WebCalendarTextSettings Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebCalendarTextSettings members.

Public Properties

 | Name | Description
Public Property | CalendarHeaderText | Specifies the tooltip text of WebCalendar header.
Public Property | CalendarNextArrowText | Specifies the tooltip text of WebCalendar next arrow.
Public Property | CalendarPrevArrowText | Specifies the tooltip text of WebCalendar previous arrow.
Top

See Also

Reference

WebCalendarTextSettings Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarTextSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarTextSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class : WebCalendarTextSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebCalendarTextSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members


WebCalendarTextSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarTextSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class : WebCalendarTextSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCalendarTextSettings()
C#
public WebCalendarTextSettings()
Delphi
public WebCalendarTextSettings();
JScript
public function WebCalendarTextSettings();
Managed Extensions for C++
public: WebCalendarTextSettings();
C++/CLI
public:
WebCalendarTextSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members


CalendarHeaderText Property

[image]
Intersoft WebEssentials Documentation
CalendarHeaderText Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class : CalendarHeaderText Property

Glossary Item Box

Specifies the tooltip text of WebCalendar header.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("WebCalendar")>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar header.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CalendarHeaderText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarTextSettings
Dim value As System.String

instance.CalendarHeaderText = value

value = instance.CalendarHeaderText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("WebCalendar")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CalendarHeaderText {get; set;}
Delphi
public read-write property CalendarHeaderText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("WebCalendar")
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar header.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CalendarHeaderText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("WebCalendar")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CalendarHeaderText();
public: __property void set_CalendarHeaderText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("WebCalendar")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar header.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CalendarHeaderText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members


CalendarNextArrowText Property

[image]
Intersoft WebEssentials Documentation
CalendarNextArrowText Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class : CalendarNextArrowText Property

Glossary Item Box

Specifies the tooltip text of WebCalendar next arrow.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("WebCalendar")>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar next arrow.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CalendarNextArrowText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarTextSettings
Dim value As System.String

instance.CalendarNextArrowText = value

value = instance.CalendarNextArrowText
C#
[System.ComponentModel.CategoryAttribute("WebCalendar")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar next arrow.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string CalendarNextArrowText {get; set;}
Delphi
public read-write property CalendarNextArrowText: System.String;
JScript
System.ComponentModel.CategoryAttribute("WebCalendar")
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar next arrow.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CalendarNextArrowText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("WebCalendar")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar next arrow.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_CalendarNextArrowText();
public: __property void set_CalendarNextArrowText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("WebCalendar")]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar next arrow.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ CalendarNextArrowText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members


CalendarPrevArrowText Property

[image]
Intersoft WebEssentials Documentation
CalendarPrevArrowText Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class : CalendarPrevArrowText Property

Glossary Item Box

Specifies the tooltip text of WebCalendar previous arrow.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar previous arrow.")>
<System.ComponentModel.CategoryAttribute("WebCalendar")>
Public Property CalendarPrevArrowText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarTextSettings
Dim value As System.String

instance.CalendarPrevArrowText = value

value = instance.CalendarPrevArrowText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar previous arrow.")]
[System.ComponentModel.CategoryAttribute("WebCalendar")]
public System.string CalendarPrevArrowText {get; set;}
Delphi
public read-write property CalendarPrevArrowText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar previous arrow.")
System.ComponentModel.CategoryAttribute("WebCalendar")
public function get,set CalendarPrevArrowText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar previous arrow.")]
[System.ComponentModel.CategoryAttribute("WebCalendar")]
public: __property System.string* get_CalendarPrevArrowText();
public: __property void set_CalendarPrevArrowText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of WebCalendar previous arrow.")]
[System.ComponentModel.CategoryAttribute("WebCalendar")]
public:
property System.String^ CalendarPrevArrowText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarTextSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarTextSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarTextSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarTextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarTextSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarTextSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarTextSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarTextSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarTextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarTextSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarTextSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarTextSettings Class
WebCalendarTextSettings Members


WebCalendarViewType Enumeration

[image]
Intersoft WebEssentials Documentation
WebCalendarViewType Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarViewType Enumeration

Glossary Item Box

Specifies ViewMode in WebCalendar.

Syntax

Visual Basic (Declaration)
Public Enum WebCalendarViewType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarViewType
C#
public enum WebCalendarViewType : System.Enum
Delphi
public enum WebCalendarViewType = class(System.Enum)
JScript
public enum WebCalendarViewType extends System.Enum
Managed Extensions for C++
__value public enum WebCalendarViewType : public System.Enum
C++/CLI
public enum class WebCalendarViewType : public System.Enum

Members

Member | Description
Month |
Quarter |
Year |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebCalendarViewType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebCalendarWeekViewMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebCalendarWeekViewMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarWeekViewMode Enumeration

Glossary Item Box

Specifies WeekViewMode in WebCalendar.

Syntax

Visual Basic (Declaration)
Public Enum WebCalendarWeekViewMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWeekViewMode
C#
public enum WebCalendarWeekViewMode : System.Enum
Delphi
public enum WebCalendarWeekViewMode = class(System.Enum)
JScript
public enum WebCalendarWeekViewMode extends System.Enum
Managed Extensions for C++
__value public enum WebCalendarWeekViewMode : public System.Enum
C++/CLI
public enum class WebCalendarWeekViewMode : public System.Enum

Members

Member | Description
FullWeek |
WorkWeek |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebCalendarWeekViewMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebCalendarWorkWeekSettings Class

[image]
Intersoft WebEssentials Documentation
WebCalendarWorkWeekSettings Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarWorkWeekSettings Class

Glossary Item Box

A collection of WebCalendar's work week settings.

Object Model

WebCalendarWorkWeekSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebCalendarWorkWeekSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebCalendarWorkWeekSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebCalendarWorkWeekSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebCalendarWorkWeekSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebCalendarWorkWeekSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebCalendarWorkWeekSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebCalendarWorkWeekSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Members
ISNet.WebUI.WebEssentials Namespace


WebCalendarWorkWeekSettings Class Members

[image]
Intersoft WebEssentials Documentation
WebCalendarWorkWeekSettings Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarWorkWeekSettings Class

Glossary Item Box

The following tables list the members exposed by WebCalendarWorkWeekSettings.

Public Constructors

 | Name | Description
Public Constructor | WebCalendarWorkWeekSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Friday | Indicates whether Friday is work week.
Public Property | Monday | Indicates whether Monday is work week.
Public Property | Saturday | Indicates whether Saturday is work week.
Public Property | Sunday | Indicates whether Sunday is work week.
Public Property | Thursday | Indicates whether Thursday is work week.
Public Property | Tuesday | Indicates whether Tuesday is work week.
Public Property | Wednesday | Indicates whether Wednesday is work week.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCalendarWorkWeekSettings Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarWorkWeekSettings Class Methods

[image]
Intersoft WebEssentials Documentation
WebCalendarWorkWeekSettings Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarWorkWeekSettings Class

Glossary Item Box

For a list of all members of this type, see WebCalendarWorkWeekSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebCalendarWorkWeekSettings Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarWorkWeekSettings Class Properties

[image]
Intersoft WebEssentials Documentation
WebCalendarWorkWeekSettings Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebCalendarWorkWeekSettings Class

Glossary Item Box

For a list of all members of this type, see WebCalendarWorkWeekSettings members.

Public Properties

 | Name | Description
Public Property | Friday | Indicates whether Friday is work week.
Public Property | Monday | Indicates whether Monday is work week.
Public Property | Saturday | Indicates whether Saturday is work week.
Public Property | Sunday | Indicates whether Sunday is work week.
Public Property | Thursday | Indicates whether Thursday is work week.
Public Property | Tuesday | Indicates whether Tuesday is work week.
Public Property | Wednesday | Indicates whether Wednesday is work week.
Top

See Also

Reference

WebCalendarWorkWeekSettings Class
ISNet.WebUI.WebEssentials Namespace


WebCalendarWorkWeekSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarWorkWeekSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : WebCalendarWorkWeekSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebCalendarWorkWeekSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


WebCalendarWorkWeekSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendarWorkWeekSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : WebCalendarWorkWeekSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCalendarWorkWeekSettings()
C#
public WebCalendarWorkWeekSettings()
Delphi
public WebCalendarWorkWeekSettings();
JScript
public function WebCalendarWorkWeekSettings();
Managed Extensions for C++
public: WebCalendarWorkWeekSettings();
C++/CLI
public:
WebCalendarWorkWeekSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


Friday Property

[image]
Intersoft WebEssentials Documentation
Friday Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : Friday Property

Glossary Item Box

Indicates whether Friday is work week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Work Week")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Indicates whether Friday is work week.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Friday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim value As System.Boolean

instance.Friday = value

value = instance.Friday
C#
[System.ComponentModel.CategoryAttribute("Work Week")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether Friday is work week.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool Friday {get; set;}
Delphi
public read-write property Friday: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Work Week")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether Friday is work week.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Friday : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Work Week")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether Friday is work week.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_Friday();
public: __property void set_Friday(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Work Week")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether Friday is work week.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool Friday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


Monday Property

[image]
Intersoft WebEssentials Documentation
Monday Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : Monday Property

Glossary Item Box

Indicates whether Monday is work week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Work Week")>
<System.ComponentModel.DescriptionAttribute("Indicates whether Monday is work week.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Monday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim value As System.Boolean

instance.Monday = value

value = instance.Monday
C#
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Monday is work week.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool Monday {get; set;}
Delphi
public read-write property Monday: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Work Week")
System.ComponentModel.DescriptionAttribute("Indicates whether Monday is work week.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Monday : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Monday is work week.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_Monday();
public: __property void set_Monday(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Monday is work week.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool Monday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


Saturday Property

[image]
Intersoft WebEssentials Documentation
Saturday Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : Saturday Property

Glossary Item Box

Indicates whether Saturday is work week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether Saturday is work week.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Work Week")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Saturday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim value As System.Boolean

instance.Saturday = value

value = instance.Saturday
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether Saturday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Saturday {get; set;}
Delphi
public read-write property Saturday: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether Saturday is work week.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Work Week")
System.ComponentModel.DefaultValueAttribute()
public function get,set Saturday : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether Saturday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Saturday();
public: __property void set_Saturday(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether Saturday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Saturday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


Sunday Property

[image]
Intersoft WebEssentials Documentation
Sunday Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : Sunday Property

Glossary Item Box

Indicates whether Sunday is work week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether Sunday is work week.")>
<System.ComponentModel.CategoryAttribute("Work Week")>
Public Property Sunday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim value As System.Boolean

instance.Sunday = value

value = instance.Sunday
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether Sunday is work week.")]
[System.ComponentModel.CategoryAttribute("Work Week")]
public System.bool Sunday {get; set;}
Delphi
public read-write property Sunday: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether Sunday is work week.")
System.ComponentModel.CategoryAttribute("Work Week")
public function get,set Sunday : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether Sunday is work week.")]
[System.ComponentModel.CategoryAttribute("Work Week")]
public: __property System.bool get_Sunday();
public: __property void set_Sunday(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether Sunday is work week.")]
[System.ComponentModel.CategoryAttribute("Work Week")]
public:
property System.bool Sunday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


Thursday Property

[image]
Intersoft WebEssentials Documentation
Thursday Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : Thursday Property

Glossary Item Box

Indicates whether Thursday is work week.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether Thursday is work week.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Work Week")>
Public Property Thursday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim value As System.Boolean

instance.Thursday = value

value = instance.Thursday
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether Thursday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
public System.bool Thursday {get; set;}
Delphi
public read-write property Thursday: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether Thursday is work week.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Work Week")
public function get,set Thursday : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether Thursday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
public: __property System.bool get_Thursday();
public: __property void set_Thursday(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether Thursday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
public:
property System.bool Thursday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


Tuesday Property

[image]
Intersoft WebEssentials Documentation
Tuesday Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : Tuesday Property

Glossary Item Box

Indicates whether Tuesday is work week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Work Week")>
<System.ComponentModel.DescriptionAttribute("Indicates whether Tuesday is work week.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Tuesday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim value As System.Boolean

instance.Tuesday = value

value = instance.Tuesday
C#
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Tuesday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool Tuesday {get; set;}
Delphi
public read-write property Tuesday: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Work Week")
System.ComponentModel.DescriptionAttribute("Indicates whether Tuesday is work week.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Tuesday : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Tuesday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_Tuesday();
public: __property void set_Tuesday(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.DescriptionAttribute("Indicates whether Tuesday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool Tuesday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


Wednesday Property

[image]
Intersoft WebEssentials Documentation
Wednesday Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendarWorkWeekSettings Class : Wednesday Property

Glossary Item Box

Indicates whether Wednesday is work week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether Wednesday is work week.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Work Week")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Wednesday As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendarWorkWeekSettings
Dim value As System.Boolean

instance.Wednesday = value

value = instance.Wednesday
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether Wednesday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Wednesday {get; set;}
Delphi
public read-write property Wednesday: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether Wednesday is work week.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Work Week")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Wednesday : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether Wednesday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Wednesday();
public: __property void set_Wednesday(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether Wednesday is work week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Work Week")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Wednesday {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendarWorkWeekSettings Class
WebCalendarWorkWeekSettings Members


WebCalendar Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendar Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : WebCalendar Constructor

Glossary Item Box

Overload List

Overload | Description
WebCalendar Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


WebCalendar Constructor

[image]
Intersoft WebEssentials Documentation
WebCalendar Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : WebCalendar Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebCalendar()
C#
public WebCalendar()
Delphi
public WebCalendar();
JScript
public function WebCalendar();
Managed Extensions for C++
public: WebCalendar();
C++/CLI
public:
WebCalendar();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


AccessKey Property

[image]
Intersoft WebEssentials Documentation
AccessKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set AccessKey : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


AllowDefaultStyleMerging Property

[image]
Intersoft WebEssentials Documentation
AllowDefaultStyleMerging Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : AllowDefaultStyleMerging Property

Glossary Item Box

Gets or sets the value that determines whether or not the default style can be merged with custom styles.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowDefaultStyleMerging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.AllowDefaultStyleMerging = value

value = instance.AllowDefaultStyleMerging
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool AllowDefaultStyleMerging {get; set;}
Delphi
public read-write property AllowDefaultStyleMerging: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowDefaultStyleMerging : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_AllowDefaultStyleMerging();
public: __property void set_AllowDefaultStyleMerging(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool AllowDefaultStyleMerging {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ApplyStyle Method

[image]
Intersoft WebEssentials Documentation
ApplyStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebEssentials Documentation
ApplyStyleSheetSkin Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


CalendarItemHeight Property

[image]
Intersoft WebEssentials Documentation
CalendarItemHeight Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : CalendarItemHeight Property

Glossary Item Box

Specifies height of each WebCalendar's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specify calendar item height.")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Layout")>
Public Property CalendarItemHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Web.UI.WebControls.Unit

instance.CalendarItemHeight = value

value = instance.CalendarItemHeight
C#
[System.ComponentModel.DescriptionAttribute("Specify calendar item height.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
public System.Web.UI.WebControls.Unit CalendarItemHeight {get; set;}
Delphi
public read-write property CalendarItemHeight: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.DescriptionAttribute("Specify calendar item height.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Layout")
public function get,set CalendarItemHeight : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specify calendar item height.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
public: __property System.Web.UI.WebControls.Unit get_CalendarItemHeight();
public: __property void set_CalendarItemHeight(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specify calendar item height.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
public:
property System.Web.UI.WebControls.Unit CalendarItemHeight {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Property Value

The default value is 100%.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


CalendarItemWidth Property

[image]
Intersoft WebEssentials Documentation
CalendarItemWidth Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : CalendarItemWidth Property

Glossary Item Box

Specifies width of each WebCalendar's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specify calendar item width.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CalendarItemWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Web.UI.WebControls.Unit

instance.CalendarItemWidth = value

value = instance.CalendarItemWidth
C#
[System.ComponentModel.DescriptionAttribute("Specify calendar item width.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.Web.UI.WebControls.Unit CalendarItemWidth {get; set;}
Delphi
public read-write property CalendarItemWidth: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.DescriptionAttribute("Specify calendar item width.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CalendarItemWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specify calendar item width.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Web.UI.WebControls.Unit get_CalendarItemWidth();
public: __property void set_CalendarItemWidth(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specify calendar item width.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Web.UI.WebControls.Unit CalendarItemWidth {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Property Value

The default value is 170px.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


CanUseWebResources Method

[image]
Intersoft WebEssentials Documentation
CanUseWebResources Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.CanUseWebResources()
C#
public System.bool CanUseWebResources()
Delphi
public function CanUseWebResources(): System.Boolean;
JScript
public function CanUseWebResources() : System.boolean;
Managed Extensions for C++
public: System.bool CanUseWebResources();
C++/CLI
public:
System.bool CanUseWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


CheckConstrains Method

[image]
Intersoft WebEssentials Documentation
CheckConstrains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar

instance.CheckConstrains()
C#
public override void CheckConstrains()
Delphi
public procedure CheckConstrains(); override;
JScript
public override function CheckConstrains();
Managed Extensions for C++
public: void CheckConstrains(); override
C++/CLI
public:
void CheckConstrains(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ClientIDMode Property

[image]
Intersoft WebEssentials Documentation
ClientIDMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ClientSideEvents Property

[image]
Intersoft WebEssentials Documentation
ClientSideEvents Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ClientSideEvents Property

Glossary Item Box

Contains client side events supported by WebCalendar.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebCalendar.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ClientSideEvents As WebCalendarClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As WebCalendarClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebCalendar.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebCalendarClientSideEvents ClientSideEvents {get; set;}
Delphi
public read-write property ClientSideEvents: WebCalendarClientSideEvents;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebCalendar.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ClientSideEvents : WebCalendarClientSideEvents
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebCalendar.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebCalendarClientSideEvents* get_ClientSideEvents();
public: __property void set_ClientSideEvents(
   WebCalendarClientSideEvents* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebCalendar.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebCalendarClientSideEvents^ ClientSideEvents {
   WebCalendarClientSideEvents^ get();
   void set (    WebCalendarClientSideEvents^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ControlDataTransferFormat Property

[image]
Intersoft WebEssentials Documentation
ControlDataTransferFormat Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


CopyBaseAttributes Method

[image]
Intersoft WebEssentials Documentation
CopyBaseAttributes Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members
Overload List


Culture Property

[image]
Intersoft WebEssentials Documentation
Culture Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Culture Property

Glossary Item Box

Specifies the culture setting for current WebScheduler instance.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebCalendar instance.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Culture As System.Globalization.CultureInfo
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Globalization.CultureInfo

instance.Culture = value

value = instance.Culture
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebCalendar instance.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Globalization.CultureInfo Culture {get; set;}
Delphi
public read-write property Culture: System.Globalization.CultureInfo;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebCalendar instance.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Culture : System.Globalization.CultureInfo
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebCalendar instance.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Globalization.CultureInfo* get_Culture();
public: __property void set_Culture(
   System.Globalization.CultureInfo* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the culture setting for current WebCalendar instance.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Globalization.CultureInfo^ Culture {
   System.Globalization.CultureInfo^ get();
   void set (    System.Globalization.CultureInfo^ value);
}

Property Value

The default culture setting for current WebScheduler is English (United States).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


CustomHighlightedDays Property

[image]
Intersoft WebEssentials Documentation
CustomHighlightedDays Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : CustomHighlightedDays Property

Glossary Item Box

Specifies number of days that will be applied on custom highlight.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies number of days that will be applied on custom highlight.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CustomHighlightedDays As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Integer

instance.CustomHighlightedDays = value

value = instance.CustomHighlightedDays
C#
[System.ComponentModel.DescriptionAttribute("Specifies number of days that will be applied on custom highlight.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int CustomHighlightedDays {get; set;}
Delphi
public read-write property CustomHighlightedDays: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies number of days that will be applied on custom highlight.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CustomHighlightedDays : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies number of days that will be applied on custom highlight.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_CustomHighlightedDays();
public: __property void set_CustomHighlightedDays(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies number of days that will be applied on custom highlight.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int CustomHighlightedDays {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


DataBind Method

[image]
Intersoft WebEssentials Documentation
DataBind Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


DataBind() Method

[image]
Intersoft WebEssentials Documentation
DataBind() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


DataBinding Event

[image]
Intersoft WebEssentials Documentation
DataBinding Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


DefaultStyleMode Property

[image]
Intersoft WebEssentials Documentation
DefaultStyleMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : DefaultStyleMode Property

Glossary Item Box

Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DefaultStyleMode As WebCalendarDefaultStyleMode
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As WebCalendarDefaultStyleMode

instance.DefaultStyleMode = value

value = instance.DefaultStyleMode
C#
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebCalendarDefaultStyleMode DefaultStyleMode {get; set;}
Delphi
public read-write property DefaultStyleMode: WebCalendarDefaultStyleMode;
JScript
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DefaultStyleMode : WebCalendarDefaultStyleMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebCalendarDefaultStyleMode get_DefaultStyleMode();
public: __property void set_DefaultStyleMode(
   WebCalendarDefaultStyleMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebCalendarDefaultStyleMode DefaultStyleMode {
   WebCalendarDefaultStyleMode get();
   void set (    WebCalendarDefaultStyleMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


Dispose Method

[image]
Intersoft WebEssentials Documentation
Dispose Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


Disposed Event

[image]
Intersoft WebEssentials Documentation
Disposed Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


EnableAnimation Property

[image]
Intersoft WebEssentials Documentation
EnableAnimation Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : EnableAnimation Property

Glossary Item Box

Determines whether or not animation is enabled in WebCalendar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether or not animation is enabled in WebCalendar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableAnimation As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.EnableAnimation = value

value = instance.EnableAnimation
C#
[System.ComponentModel.DescriptionAttribute("Determines whether or not animation is enabled in WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableAnimation {get; set;}
Delphi
public read-write property EnableAnimation: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether or not animation is enabled in WebCalendar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableAnimation : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether or not animation is enabled in WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableAnimation();
public: __property void set_EnableAnimation(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether or not animation is enabled in WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableAnimation {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


EnableKeyboardSupport Property

[image]
Intersoft WebEssentials Documentation
EnableKeyboardSupport Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : EnableKeyboardSupport Property

Glossary Item Box

Determines whether or not keyboard is supported in WebCalendar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determines whether or not keyboard is supported in WebCalendar.")>
Public Property EnableKeyboardSupport As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.EnableKeyboardSupport = value

value = instance.EnableKeyboardSupport
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not keyboard is supported in WebCalendar.")]
public System.bool EnableKeyboardSupport {get; set;}
Delphi
public read-write property EnableKeyboardSupport: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not keyboard is supported in WebCalendar.")
public function get,set EnableKeyboardSupport : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not keyboard is supported in WebCalendar.")]
public: __property System.bool get_EnableKeyboardSupport();
public: __property void set_EnableKeyboardSupport(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not keyboard is supported in WebCalendar.")]
public:
property System.bool EnableKeyboardSupport {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


EnableManagedTheming Property

[image]
Intersoft WebEssentials Documentation
EnableManagedTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable Property EnableManagedTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableManagedTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.bool EnableManagedTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


EnableMultipleSelection Property

[image]
Intersoft WebEssentials Documentation
EnableMultipleSelection Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : EnableMultipleSelection Property

Glossary Item Box

Determines whether or not multiple selection is enabled in WebCalendar.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determines whether or not multiple selection is enabled in WebCalendar. (Applied if HighlightMode = Day and ViewMode = Month only).")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property EnableMultipleSelection As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.EnableMultipleSelection = value

value = instance.EnableMultipleSelection
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not multiple selection is enabled in WebCalendar. (Applied if HighlightMode = Day and ViewMode = Month only).")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool EnableMultipleSelection {get; set;}
Delphi
public read-write property EnableMultipleSelection: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not multiple selection is enabled in WebCalendar. (Applied if HighlightMode = Day and ViewMode = Month only).")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set EnableMultipleSelection : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not multiple selection is enabled in WebCalendar. (Applied if HighlightMode = Day and ViewMode = Month only).")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_EnableMultipleSelection();
public: __property void set_EnableMultipleSelection(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not multiple selection is enabled in WebCalendar. (Applied if HighlightMode = Day and ViewMode = Month only).")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool EnableMultipleSelection {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


EnableTheming Property

[image]
Intersoft WebEssentials Documentation
EnableTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


EnableViewState Property

[image]
Intersoft WebEssentials Documentation
EnableViewState Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


EnableWebResources Property

[image]
Intersoft WebEssentials Documentation
EnableWebResources Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Web Resources")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Web Resources")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


FindControl Method

[image]
Intersoft WebEssentials Documentation
FindControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


FindControl(String) Method

[image]
Intersoft WebEssentials Documentation
FindControl(String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


FirstDayOfWeek Property

[image]
Intersoft WebEssentials Documentation
FirstDayOfWeek Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : FirstDayOfWeek Property

Glossary Item Box

Specifies WebCalendar first day of week.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies WebCalendar first day of week.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property FirstDayOfWeek As System.DayOfWeek
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.DayOfWeek

instance.FirstDayOfWeek = value

value = instance.FirstDayOfWeek
C#
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar first day of week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.DayOfWeek FirstDayOfWeek {get; set;}
Delphi
public read-write property FirstDayOfWeek: System.DayOfWeek;
JScript
System.ComponentModel.DescriptionAttribute("Specifies WebCalendar first day of week.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set FirstDayOfWeek : System.DayOfWeek
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar first day of week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.DayOfWeek get_FirstDayOfWeek();
public: __property void set_FirstDayOfWeek(
   System.DayOfWeek value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar first day of week.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.DayOfWeek FirstDayOfWeek {
   System.DayOfWeek get();
   void set (    System.DayOfWeek value);
}

Property Value

The default value is Sunday.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


FirstWeekOfYear Property

[image]
Intersoft WebEssentials Documentation
FirstWeekOfYear Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : FirstWeekOfYear Property

Glossary Item Box

Specifies WebCalendar first week of year.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies WebCalendar first week of year.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property FirstWeekOfYear As WebCalendarFirstWeekOfYear
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As WebCalendarFirstWeekOfYear

instance.FirstWeekOfYear = value

value = instance.FirstWeekOfYear
C#
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar first week of year.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public WebCalendarFirstWeekOfYear FirstWeekOfYear {get; set;}
Delphi
public read-write property FirstWeekOfYear: WebCalendarFirstWeekOfYear;
JScript
System.ComponentModel.DescriptionAttribute("Specifies WebCalendar first week of year.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set FirstWeekOfYear : WebCalendarFirstWeekOfYear
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar first week of year.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebCalendarFirstWeekOfYear get_FirstWeekOfYear();
public: __property void set_FirstWeekOfYear(
   WebCalendarFirstWeekOfYear value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar first week of year.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebCalendarFirstWeekOfYear FirstWeekOfYear {
   WebCalendarFirstWeekOfYear get();
   void set (    WebCalendarFirstWeekOfYear value);
}

Property Value

The default value is First4DayWeek.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


FlyPostBackSettings Property

[image]
Intersoft WebEssentials Documentation
FlyPostBackSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : FlyPostBackSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}
Delphi
public read-only property FlyPostBackSettings: ISNet.WebUI.FlyPostBackSettings;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")
System.ComponentModel.DefaultValueAttribute()
public function get FlyPostBackSettings : ISNet.WebUI.FlyPostBackSettings
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.FlyPostBackSettings* get_FlyPostBackSettings();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.FlyPostBackSettings^ FlyPostBackSettings {
   ISNet.WebUI.FlyPostBackSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


Focus Method

[image]
Intersoft WebEssentials Documentation
Focus Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


FocusCellStyle Property

[image]
Intersoft WebEssentials Documentation
FocusCellStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : FocusCellStyle Property

Glossary Item Box

Contains interactive style for WebCalendar focus cell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar focus cell.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property FocusCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.WebStyle

instance.FocusCellStyle = value

value = instance.FocusCellStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar focus cell.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.WebStyle FocusCellStyle {get; set;}
Delphi
public read-write property FocusCellStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar focus cell.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set FocusCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar focus cell.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.WebStyle* get_FocusCellStyle();
public: __property void set_FocusCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar focus cell.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.WebStyle^ FocusCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ForceDisableXmlCompression Method

[image]
Intersoft WebEssentials Documentation
ForceDisableXmlCompression Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


FrameStyle Property

[image]
Intersoft WebEssentials Documentation
FrameStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : FrameStyle Property

Glossary Item Box

Contains interactive style for Frame.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle FrameStyle {get; set;}
Delphi
public read-write property FrameStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")
System.ComponentModel.CategoryAttribute("Style")
public function get,set FrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_FrameStyle();
public: __property void set_FrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ FrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetClientAction Method

[image]
Intersoft WebEssentials Documentation
GetClientAction Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetCulture Method

[image]
Intersoft WebEssentials Documentation
GetCulture Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetCulture Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCulture() As System.Globalization.CultureInfo
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Globalization.CultureInfo

value = instance.GetCulture()
C#
public System.Globalization.CultureInfo GetCulture()
Delphi
public function GetCulture(): System.Globalization.CultureInfo;
JScript
public function GetCulture() : System.Globalization.CultureInfo;
Managed Extensions for C++
public: System.Globalization.CultureInfo* GetCulture();
C++/CLI
public:
System.Globalization.CultureInfo^ GetCulture();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebEssentials Documentation
GetCurrentControlLifeCycle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetCurrentTheme Method

[image]
Intersoft WebEssentials Documentation
GetCurrentTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetFrameworkDataFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkDataFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

value = instance.GetFrameworkDataFolder()
C#
public System.string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): System.String;
JScript
public function GetFrameworkDataFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkDataFolder();
C++/CLI
public:
System.String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetFrameworkFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

value = instance.GetFrameworkFolder()
C#
public System.string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): System.String;
JScript
public function GetFrameworkFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkFolder();
C++/CLI
public:
System.String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetFrameworkVersion Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkVersion Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Version

value = instance.GetFrameworkVersion()
C#
public System.Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): System.Version;
JScript
public function GetFrameworkVersion() : System.Version;
Managed Extensions for C++
public: System.Version* GetFrameworkVersion();
C++/CLI
public:
System.Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetIntersoftFolder Method

[image]
Intersoft WebEssentials Documentation
GetIntersoftFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

value = instance.GetIntersoftFolder()
C#
public System.string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): System.String;
JScript
public function GetIntersoftFolder() : System.String;
Managed Extensions for C++
public: System.string* GetIntersoftFolder();
C++/CLI
public:
System.String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetLayoutFolder Method

[image]
Intersoft WebEssentials Documentation
GetLayoutFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

value = instance.GetLayoutFolder()
C#
public System.string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): System.String;
JScript
public function GetLayoutFolder() : System.String;
Managed Extensions for C++
public: System.string* GetLayoutFolder();
C++/CLI
public:
System.String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetPostedXMLData Method

[image]
Intersoft WebEssentials Documentation
GetPostedXMLData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

value = instance.GetPostedXMLData()
C#
public System.string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): System.String;
JScript
public function GetPostedXMLData() : System.String;
Managed Extensions for C++
public: System.string* GetPostedXMLData();
C++/CLI
public:
System.String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetProductInfoKey Method

[image]
Intersoft WebEssentials Documentation
GetProductInfoKey Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

value = instance.GetProductInfoKey()
C#
public System.string GetProductInfoKey()
Delphi
public function GetProductInfoKey(): System.String;
JScript
public function GetProductInfoKey() : System.String;
Managed Extensions for C++
public: System.string* GetProductInfoKey();
C++/CLI
public:
System.String^ GetProductInfoKey();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetProductSimpleName Method

[image]
Intersoft WebEssentials Documentation
GetProductSimpleName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

value = instance.GetProductSimpleName()
C#
public System.string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): System.String;
JScript
public function GetProductSimpleName() : System.String;
Managed Extensions for C++
public: System.string* GetProductSimpleName();
C++/CLI
public:
System.String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetPropertyValue Method

[image]
Intersoft WebEssentials Documentation
GetPropertyValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As System.String, _
   ByVal propValue As System.String, _
   ByVal webConfigKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim defValue As System.String
Dim propValue As System.String
Dim webConfigKey As System.String
Dim value As System.String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public System.string GetPropertyValue(
   System.string defValue,
   System.string propValue,
   System.string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: System.String;
    propValue: System.String;
    webConfigKey: System.String
): System.String;
JScript
public function GetPropertyValue(
   defValue : System.String,
   propValue : System.String,
   webConfigKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetPropertyValue(
   System.string* defValue,
   System.string* propValue,
   System.string* webConfigKey
)
C++/CLI
public:
System.String^ GetPropertyValue(
   System.String^ defValue,
   System.String^ propValue,
   System.String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetResourceStream Method

[image]
Intersoft WebEssentials Documentation
GetResourceStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As System.String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim resourceUrl As System.String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   System.string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: System.String
): System.IO.Stream;
JScript
public function GetResourceStream(
   resourceUrl : System.String
) : System.IO.Stream;
Managed Extensions for C++
public: System.IO.Stream* GetResourceStream(
   System.string* resourceUrl
)
C++/CLI
public:
System.IO.Stream^ GetResourceStream(
   System.String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetRouteUrl Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetRouteUrl(Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebEssentials Documentation
GetUniqueIDRelativeTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


GetXMLCultureInfo Method

[image]
Intersoft WebEssentials Documentation
GetXMLCultureInfo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : GetXMLCultureInfo Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetXMLCultureInfo() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Object

value = instance.GetXMLCultureInfo()
C#
public override System.object GetXMLCultureInfo()
Delphi
public function GetXMLCultureInfo(): System.TObject; override;
JScript
public override function GetXMLCultureInfo() : System.Object;
Managed Extensions for C++
public: System.Object* GetXMLCultureInfo(); override
C++/CLI
public:
System.Object^ GetXMLCultureInfo(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


HasControls Method

[image]
Intersoft WebEssentials Documentation
HasControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


HeaderStyle Property

[image]
Intersoft WebEssentials Documentation
HeaderStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : HeaderStyle Property

Glossary Item Box

Contains interactive style for WebCalendar header.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar header.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property HeaderStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.WebStyle

instance.HeaderStyle = value

value = instance.HeaderStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar header.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle HeaderStyle {get; set;}
Delphi
public read-write property HeaderStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar header.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Style")
public function get,set HeaderStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar header.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_HeaderStyle();
public: __property void set_HeaderStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar header.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ HeaderStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


Height Property

[image]
Intersoft WebEssentials Documentation
Height Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Overrides Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public override System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; override;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public override function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.Web.UI.WebControls.Unit get_Height() override;
public: __property void set_Height(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


HighlightMode Property

[image]
Intersoft WebEssentials Documentation
HighlightMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : HighlightMode Property

Glossary Item Box

Specifies WebCalendar highlight mode.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies WebCalendar week view mode.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property HighlightMode As WebCalendarHighlightMode
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As WebCalendarHighlightMode

instance.HighlightMode = value

value = instance.HighlightMode
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar week view mode.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebCalendarHighlightMode HighlightMode {get; set;}
Delphi
public read-write property HighlightMode: WebCalendarHighlightMode;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies WebCalendar week view mode.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set HighlightMode : WebCalendarHighlightMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar week view mode.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebCalendarHighlightMode get_HighlightMode();
public: __property void set_HighlightMode(
   WebCalendarHighlightMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar week view mode.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebCalendarHighlightMode HighlightMode {
   WebCalendarHighlightMode get();
   void set (    WebCalendarHighlightMode value);
}

Property Value

The default value is Day.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


HighlightTodayDate Property

[image]
Intersoft WebEssentials Documentation
HighlightTodayDate Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : HighlightTodayDate Property

Glossary Item Box

Determines whether or not today date should be highlighted in WebCalendar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether or not today date should be highlighted in WebCalendar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HighlightTodayDate As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.HighlightTodayDate = value

value = instance.HighlightTodayDate
C#
[System.ComponentModel.DescriptionAttribute("Determines whether or not today date should be highlighted in WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool HighlightTodayDate {get; set;}
Delphi
public read-write property HighlightTodayDate: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether or not today date should be highlighted in WebCalendar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set HighlightTodayDate : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether or not today date should be highlighted in WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_HighlightTodayDate();
public: __property void set_HighlightTodayDate(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether or not today date should be highlighted in WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool HighlightTodayDate {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


Holidays Property

[image]
Intersoft WebEssentials Documentation
Holidays Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Holidays Property

Glossary Item Box

The data collection used by WebCalendar to determine holiday(s).

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("The data collection used by WebCalendar to determine holiday(s).")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<ISNet.Serialization.BinarySerializableAttribute("setHolidays")>
Public ReadOnly Property Holidays As WebCalendarHolidayCollection
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As WebCalendarHolidayCollection

value = instance.Holidays
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebCalendar to determine holiday(s).")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.BinarySerializableAttribute("setHolidays")]
public WebCalendarHolidayCollection Holidays {get;}
Delphi
public read-only property Holidays: WebCalendarHolidayCollection;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("The data collection used by WebCalendar to determine holiday(s).")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
ISNet.Serialization.BinarySerializableAttribute("setHolidays")
public function get Holidays : WebCalendarHolidayCollection
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebCalendar to determine holiday(s).")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.BinarySerializableAttribute("setHolidays")]
public: __property WebCalendarHolidayCollection* get_Holidays();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The data collection used by WebCalendar to determine holiday(s).")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.BinarySerializableAttribute("setHolidays")]
public:
property WebCalendarHolidayCollection^ Holidays {
   WebCalendarHolidayCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


HolidayStyle Property

[image]
Intersoft WebEssentials Documentation
HolidayStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : HolidayStyle Property

Glossary Item Box

Contains interactive style for WebCalendar holiday cell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar holiday cell.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property HolidayStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.WebStyle

instance.HolidayStyle = value

value = instance.HolidayStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar holiday cell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.WebStyle HolidayStyle {get; set;}
Delphi
public read-write property HolidayStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar holiday cell.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set HolidayStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar holiday cell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.WebStyle* get_HolidayStyle();
public: __property void set_HolidayStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar holiday cell.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.WebStyle^ HolidayStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ID Property

[image]
Intersoft WebEssentials Documentation
ID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ImagesDirectory Property

[image]
Intersoft WebEssentials Documentation
ImagesDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the images directory.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ImagesDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ImagesDirectory {get; set;}
Delphi
public read-write property ImagesDirectory: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ImagesDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ImagesDirectory();
public: __property void set_ImagesDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ImagesDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ImagesSettings Property

[image]
Intersoft WebEssentials Documentation
ImagesSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ImagesSettings Property

Glossary Item Box

Provides the settings that control the images in WebCalendar.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebCalendar.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property ImagesSettings As WebCalendarImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As WebCalendarImagesSettings

value = instance.ImagesSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebCalendar.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebCalendarImagesSettings ImagesSettings {get;}
Delphi
public read-only property ImagesSettings: WebCalendarImagesSettings;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebCalendar.")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get ImagesSettings : WebCalendarImagesSettings
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebCalendar.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebCalendarImagesSettings* get_ImagesSettings();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebCalendar.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebCalendarImagesSettings^ ImagesSettings {
   WebCalendarImagesSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


InboundCellStyle Property

[image]
Intersoft WebEssentials Documentation
InboundCellStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : InboundCellStyle Property

Glossary Item Box

Contains interactive style for WebCalendar inbound cell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar inbound cell.")>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property InboundCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.WebStyle

instance.InboundCellStyle = value

value = instance.InboundCellStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar inbound cell.")]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle InboundCellStyle {get; set;}
Delphi
public read-write property InboundCellStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar inbound cell.")
System.ComponentModel.CategoryAttribute("Style")
public function get,set InboundCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar inbound cell.")]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_InboundCellStyle();
public: __property void set_InboundCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar inbound cell.")]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ InboundCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


Init Event

[image]
Intersoft WebEssentials Documentation
Init Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


InitialDisplayDate Property

[image]
Intersoft WebEssentials Documentation
InitialDisplayDate Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : InitialDisplayDate Property

Glossary Item Box

Specifies the initial WebScheduler's Date and Time.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the initial WebCalendar's Date and Time.")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.TwoWay)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property InitialDisplayDate As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Date

instance.InitialDisplayDate = value

value = instance.InitialDisplayDate
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebCalendar's Date and Time.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.DateTime InitialDisplayDate {get; set;}
Delphi
public read-write property InitialDisplayDate: System.DateTime;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the initial WebCalendar's Date and Time.")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.TwoWay)
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set InitialDisplayDate : System.DateTime
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebCalendar's Date and Time.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.DateTime get_InitialDisplayDate();
public: __property void set_InitialDisplayDate(
   System.DateTime value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebCalendar's Date and Time.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.DateTime InitialDisplayDate {
   System.DateTime get();
   void set (    System.DateTime value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


IsAtlasCallback Method

[image]
Intersoft WebEssentials Documentation
IsAtlasCallback Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.IsAtlasCallback()
C#
public System.bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): System.Boolean;
JScript
public function IsAtlasCallback() : System.boolean;
Managed Extensions for C++
public: System.bool IsAtlasCallback();
C++/CLI
public:
System.bool IsAtlasCallback();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


IsBetaRelease Method

[image]
Intersoft WebEssentials Documentation
IsBetaRelease Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.IsBetaRelease()
C#
public System.bool IsBetaRelease()
Delphi
public function IsBetaRelease(): System.Boolean;
JScript
public function IsBetaRelease() : System.boolean;
Managed Extensions for C++
public: System.bool IsBetaRelease();
C++/CLI
public:
System.bool IsBetaRelease();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


IsChromeBrowser Method

[image]
Intersoft WebEssentials Documentation
IsChromeBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.IsChromeBrowser()
C#
public System.bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): System.Boolean;
JScript
public function IsChromeBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsChromeBrowser();
C++/CLI
public:
System.bool IsChromeBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


IsFlyPostBackControl Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual System.bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): System.Boolean; virtual;
JScript
public function IsFlyPostBackControl() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackControl();
C++/CLI
public:
virtual System.bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


IsFlyPostBackRequest Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackRequest Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual System.bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): System.Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackRequest();
C++/CLI
public:
virtual System.bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebEssentials Documentation
IsGeckoBasedBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.IsGeckoBasedBrowser()
C#
public System.bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): System.Boolean;
JScript
public function IsGeckoBasedBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoBasedBrowser();
C++/CLI
public:
System.bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


IsGeckoVersion18 Method

[image]
Intersoft WebEssentials Documentation
IsGeckoVersion18 Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.IsGeckoVersion18()
C#
public System.bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): System.Boolean;
JScript
public function IsGeckoVersion18() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoVersion18();
C++/CLI
public:
System.bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


IsInDesignMode Method

[image]
Intersoft WebEssentials Documentation
IsInDesignMode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.IsInDesignMode()
C#
public System.bool IsInDesignMode()
Delphi
public function IsInDesignMode(): System.Boolean;
JScript
public function IsInDesignMode() : System.boolean;
Managed Extensions for C++
public: System.bool IsInDesignMode();
C++/CLI
public:
System.bool IsInDesignMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorer8Browser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.IsInternetExplorer8Browser()
C#
public System.bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): System.Boolean;
JScript
public function IsInternetExplorer8Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer8Browser();
C++/CLI
public:
System.bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorerBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.IsInternetExplorerBrowser()
C#
public System.bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): System.Boolean;
JScript
public function IsInternetExplorerBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorerBrowser();
C++/CLI
public:
System.bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


IsOperaBrowser Method

[image]
Intersoft WebEssentials Documentation
IsOperaBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.IsOperaBrowser()
C#
public System.bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): System.Boolean;
JScript
public function IsOperaBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsOperaBrowser();
C++/CLI
public:
System.bool IsOperaBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


IsSafariBrowser Method

[image]
Intersoft WebEssentials Documentation
IsSafariBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.IsSafariBrowser()
C#
public System.bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): System.Boolean;
JScript
public function IsSafariBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsSafariBrowser();
C++/CLI
public:
System.bool IsSafariBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


IsW3CStandardBrowser Method

[image]
Intersoft WebEssentials Documentation
IsW3CStandardBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.IsW3CStandardBrowser()
C#
public System.bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): System.Boolean;
JScript
public function IsW3CStandardBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsW3CStandardBrowser();
C++/CLI
public:
System.bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


Load Event

[image]
Intersoft WebEssentials Documentation
Load Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


LoadLayout Method

[image]
Intersoft WebEssentials Documentation
LoadLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


LoadLayoutFromFile Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim filePath As System.String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   System.string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: System.String
); virtual;
JScript
public function LoadLayoutFromFile(
   filePath : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromFile(
   System.string* filePath
)
C++/CLI
public:
virtual void LoadLayoutFromFile(
   System.String^ filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromPredefinedName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim predefinedName As System.String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   System.string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: System.String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   System.string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   System.String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


LoadLayoutFromStream Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: System.IO.Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   System.IO.Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


LoadPostData Method

[image]
Intersoft WebEssentials Documentation
LoadPostData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function LoadPostData( _
   ByVal postDataKey As System.String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim postDataKey As System.String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As System.Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public virtual System.bool LoadPostData(
   System.string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)
Delphi
public function LoadPostData(
    postDataKey: System.String;
    postCollection: System.Collections.Specialized.NameValueCollection
): System.Boolean; virtual;
JScript
public function LoadPostData(
   postDataKey : System.String,
   postCollection : System.Collections.Specialized.NameValueCollection
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool LoadPostData(
   System.string* postDataKey,
   System.Collections.Specialized.NameValueCollection* postCollection
)
C++/CLI
public:
virtual System.bool LoadPostData(
   System.String^ postDataKey,
   System.Collections.Specialized.NameValueCollection^ postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


MergeStyle Method

[image]
Intersoft WebEssentials Documentation
MergeStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


NavigateMode Property

[image]
Intersoft WebEssentials Documentation
NavigateMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : NavigateMode Property

Glossary Item Box

Determines whether or not WebCalendar's SelectedDate always change when navigation is triggered.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar's SelectedDate always change when navigation is triggered.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
Public Property NavigateMode As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.NavigateMode = value

value = instance.NavigateMode
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar's SelectedDate always change when navigation is triggered.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public System.bool NavigateMode {get; set;}
Delphi
public read-write property NavigateMode: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar's SelectedDate always change when navigation is triggered.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set NavigateMode : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar's SelectedDate always change when navigation is triggered.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.bool get_NavigateMode();
public: __property void set_NavigateMode(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar's SelectedDate always change when navigation is triggered.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.bool NavigateMode {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


NumberOfCalendarDisplayed Property

[image]
Intersoft WebEssentials Documentation
NumberOfCalendarDisplayed Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : NumberOfCalendarDisplayed Property

Glossary Item Box

Specifies number of calendar displayed in WebCalendar.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies number of month displayed in WebCalendar.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property NumberOfCalendarDisplayed As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Integer

instance.NumberOfCalendarDisplayed = value

value = instance.NumberOfCalendarDisplayed
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies number of month displayed in WebCalendar.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int NumberOfCalendarDisplayed {get; set;}
Delphi
public read-write property NumberOfCalendarDisplayed: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies number of month displayed in WebCalendar.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set NumberOfCalendarDisplayed : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies number of month displayed in WebCalendar.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_NumberOfCalendarDisplayed();
public: __property void set_NumberOfCalendarDisplayed(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies number of month displayed in WebCalendar.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int NumberOfCalendarDisplayed {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


OnInfoChanged Method

[image]
Intersoft WebEssentials Documentation
OnInfoChanged Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


OnPreInitialize Method

[image]
Intersoft WebEssentials Documentation
OnPreInitialize Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


OutboundCellStyle Property

[image]
Intersoft WebEssentials Documentation
OutboundCellStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : OutboundCellStyle Property

Glossary Item Box

Contains interactive style for WebCalendar outbound cell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar outbound cell.")>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property OutboundCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.WebStyle

instance.OutboundCellStyle = value

value = instance.OutboundCellStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar outbound cell.")]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle OutboundCellStyle {get; set;}
Delphi
public read-write property OutboundCellStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar outbound cell.")
System.ComponentModel.CategoryAttribute("Style")
public function get,set OutboundCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar outbound cell.")]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_OutboundCellStyle();
public: __property void set_OutboundCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar outbound cell.")]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ OutboundCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


Page Property

[image]
Intersoft WebEssentials Documentation
Page Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}
Delphi
public read-write property Page: System.Web.UI.Page; virtual;
JScript
public function get,set Page : System.Web.UI.Page
Managed Extensions for C++
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
C++/CLI
public:
virtual property System.Web.UI.Page^ Page {
   System.Web.UI.Page^ get();
   void set (    System.Web.UI.Page^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


PostBackMode Property

[image]
Intersoft WebEssentials Documentation
PostBackMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : PostBackMode Property

Glossary Item Box

Specifies WebCalendar postback mode.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies WebCalendar postback mode.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PostBackMode As PostBackMode
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As PostBackMode

instance.PostBackMode = value

value = instance.PostBackMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar postback mode.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public PostBackMode PostBackMode {get; set;}
Delphi
public read-write property PostBackMode: PostBackMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies WebCalendar postback mode.")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PostBackMode : PostBackMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar postback mode.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property PostBackMode get_PostBackMode();
public: __property void set_PostBackMode(
   PostBackMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar postback mode.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property PostBackMode PostBackMode {
   PostBackMode get();
   void set (    PostBackMode value);
}

Property Value

The default value is FlyPostBack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


PreInitialize Event

[image]
Intersoft WebEssentials Documentation
PreInitialize Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim handler As System.EventHandler

AddHandler instance.PreInitialize, handler
C#
public event System.EventHandler PreInitialize
Delphi
public event PreInitialize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* PreInitialize
C++/CLI
public:
event System.EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


PreRender Event

[image]
Intersoft WebEssentials Documentation
PreRender Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RaisePostBackEvent Method

[image]
Intersoft WebEssentials Documentation
RaisePostBackEvent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim eventArgument As System.String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   System.string eventArgument
)
Delphi
public procedure RaisePostBackEvent(
    eventArgument: System.String
);
JScript
public function RaisePostBackEvent(
   eventArgument : System.String
);
Managed Extensions for C++
public: void RaisePostBackEvent(
   System.string* eventArgument
)
C++/CLI
public:
void RaisePostBackEvent(
   System.String^ eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebEssentials Documentation
RaisePostDataChangedEvent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); virtual;
JScript
public function RaisePostDataChangedEvent();
Managed Extensions for C++
public: virtual void RaisePostDataChangedEvent();
C++/CLI
public:
virtual void RaisePostDataChangedEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ReadOnly Property

[image]
Intersoft WebEssentials Documentation
ReadOnly Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ReadOnly Property

Glossary Item Box

Determines whether or not WebCalendar is read only.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar is read only.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
Public Property ReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar is read only.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public System.bool ReadOnly {get; set;}
Delphi
public read-write property ReadOnly: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar is read only.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set ReadOnly : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar is read only.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.bool get_ReadOnly();
public: __property void set_ReadOnly(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar is read only.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.bool ReadOnly {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ReadWebConfigValue Method

[image]
Intersoft WebEssentials Documentation
ReadWebConfigValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim key As System.String
Dim value As System.String

value = instance.ReadWebConfigValue(key)
C#
public System.string ReadWebConfigValue(
   System.string key
)
Delphi
public function ReadWebConfigValue(
    key: System.String
): System.String;
JScript
public function ReadWebConfigValue(
   key : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ReadWebConfigValue(
   System.string* key
)
C++/CLI
public:
System.String^ ReadWebConfigValue(
   System.String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RecreateChildControls Method

[image]
Intersoft WebEssentials Documentation
RecreateChildControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar

instance.RecreateChildControls()
C#
public void RecreateChildControls()
Delphi
public procedure RecreateChildControls();
JScript
public function RecreateChildControls();
Managed Extensions for C++
public: void RecreateChildControls();
C++/CLI
public:
void RecreateChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RegisterBoxSizing Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RegisterBoxSizing() Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim forceAll As System.Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   System.bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: System.Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : System.boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   System.bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   System.bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebEssentials Documentation
RegisterGlobalStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RegisterLink Method

[image]
Intersoft WebEssentials Documentation
RegisterLink Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As System.String, _
   ByVal url As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim name As System.String
Dim url As System.String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   System.string name,
   System.string url
)
Delphi
public procedure RegisterLink(
    name: System.String;
    url: System.String
);
JScript
public function RegisterLink(
   name : System.String,
   url : System.String
);
Managed Extensions for C++
public: void RegisterLink(
   System.string* name,
   System.string* url
)
C++/CLI
public:
void RegisterLink(
   System.String^ name,
   System.String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebEssentials Documentation
RegisterOptimizedCssClasses Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim runtimeStyleOnly As System.Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: System.Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : System.boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RegisterPreloadImage Method

[image]
Intersoft WebEssentials Documentation
RegisterPreloadImage Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim image As System.String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   System.string image
)
Delphi
public procedure RegisterPreloadImage(
    image: System.String
);
JScript
public function RegisterPreloadImage(
   image : System.String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   System.string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   System.String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RegisterScript Method

[image]
Intersoft WebEssentials Documentation
RegisterScript Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar

instance.RegisterScript()
C#
public override void RegisterScript()
Delphi
public procedure RegisterScript(); override;
JScript
public override function RegisterScript();
Managed Extensions for C++
public: void RegisterScript(); override
C++/CLI
public:
void RegisterScript(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RegisterSharePointHandler Method

[image]
Intersoft WebEssentials Documentation
RegisterSharePointHandler Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RenderBeginTag Method

[image]
Intersoft WebEssentials Documentation
RenderBeginTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RenderControl Method

[image]
Intersoft WebEssentials Documentation
RenderControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebEssentials Documentation
RenderControl(HtmlTextWriter) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RenderEndTag Method

[image]
Intersoft WebEssentials Documentation
RenderEndTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RenderingMode Property

[image]
Intersoft WebEssentials Documentation
RenderingMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ResolveClientUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveClientUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ResolveImagePath Method

[image]
Intersoft WebEssentials Documentation
ResolveImagePath Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As System.String, _
   ByVal image As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim folder As System.String
Dim image As System.String
Dim value As System.String

value = instance.ResolveImagePath(folder, image)
C#
public System.string ResolveImagePath(
   System.string folder,
   System.string image
)
Delphi
public function ResolveImagePath(
    folder: System.String;
    image: System.String
): System.String;
JScript
public function ResolveImagePath(
   folder : System.String,
   image : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveImagePath(
   System.string* folder,
   System.string* image
)
C++/CLI
public:
System.String^ ResolveImagePath(
   System.String^ folder,
   System.String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ResolveRelativeURL Method

[image]
Intersoft WebEssentials Documentation
ResolveRelativeURL Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim url As System.String
Dim value As System.String

value = instance.ResolveRelativeURL(url)
C#
public virtual System.string ResolveRelativeURL(
   System.string url
)
Delphi
public function ResolveRelativeURL(
    url: System.String
): System.String; virtual;
JScript
public function ResolveRelativeURL(
   url : System.String
) : System.String;
Managed Extensions for C++
public: virtual System.string* ResolveRelativeURL(
   System.string* url
)
C++/CLI
public:
virtual System.String^ ResolveRelativeURL(
   System.String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ResolveResourceUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveResourceUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As System.String, _
   ByVal currentFolder As System.String, _
   ByVal resourceName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As System.String
Dim currentFolder As System.String
Dim resourceName As System.String
Dim value As System.String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public System.string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string defaultFolder,
   System.string currentFolder,
   System.string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: System.String;
    currentFolder: System.String;
    resourceName: System.String
): System.String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : System.String,
   currentFolder : System.String,
   resourceName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string* defaultFolder,
   System.string* currentFolder,
   System.string* resourceName
)
C++/CLI
public:
System.String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.String^ defaultFolder,
   System.String^ currentFolder,
   System.String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ResolveUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


RuntimeLicenseKey Property

[image]
Intersoft WebEssentials Documentation
RuntimeLicenseKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
Public Overridable Property RuntimeLicenseKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public virtual System.string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: System.String; virtual;
JScript
ISNet.PersistLayoutAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
public function get,set RuntimeLicenseKey : System.String
Managed Extensions for C++
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public: __property virtual System.string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   System.string* value
);
C++/CLI
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public:
virtual property System.String^ RuntimeLicenseKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


SaveLayout Method

[image]
Intersoft WebEssentials Documentation
SaveLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


SaveLayoutToFile Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim filePath As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   System.string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   System.string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   System.String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


SaveLayoutToStream Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
ScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Overrides Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public override System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String; override;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")
System.ComponentModel.CategoryAttribute("Client Script Directory")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public override function get,set ScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


SelectedCellStyle Property

[image]
Intersoft WebEssentials Documentation
SelectedCellStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : SelectedCellStyle Property

Glossary Item Box

Contains interactive style for WebCalendar selected cell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar selected cell.")>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property SelectedCellStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.WebStyle

instance.SelectedCellStyle = value

value = instance.SelectedCellStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar selected cell.")]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle SelectedCellStyle {get; set;}
Delphi
public read-write property SelectedCellStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar selected cell.")
System.ComponentModel.CategoryAttribute("Style")
public function get,set SelectedCellStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar selected cell.")]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_SelectedCellStyle();
public: __property void set_SelectedCellStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar selected cell.")]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ SelectedCellStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


SelectedDate Property

[image]
Intersoft WebEssentials Documentation
SelectedDate Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : SelectedDate Property

Glossary Item Box

Specifies the initial WebScheduler's Date and Time.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.TwoWay)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the initial WebCalendar's Date and Time.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property SelectedDate As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Date

instance.SelectedDate = value

value = instance.SelectedDate
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebCalendar's Date and Time.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.DateTime SelectedDate {get; set;}
Delphi
public read-write property SelectedDate: System.DateTime;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.TwoWay)
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the initial WebCalendar's Date and Time.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set SelectedDate : System.DateTime
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebCalendar's Date and Time.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.DateTime get_SelectedDate();
public: __property void set_SelectedDate(
   System.DateTime value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.TwoWay)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the initial WebCalendar's Date and Time.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.DateTime SelectedDate {
   System.DateTime get();
   void set (    System.DateTime value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


SelectedDateChanged Event

[image]
Intersoft WebEssentials Documentation
SelectedDateChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : SelectedDateChanged Event

Glossary Item Box

Fires when selected date is changed in WebCalendar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires when WebCalendar selected date is changed")>
<System.ComponentModel.CategoryAttribute("Interaction")>
Public Event SelectedDateChanged As WebCalendarOnSelectedDateChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim handler As WebCalendarOnSelectedDateChangedEventHandler

AddHandler instance.SelectedDateChanged, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires when WebCalendar selected date is changed")]
[System.ComponentModel.CategoryAttribute("Interaction")]
public event WebCalendarOnSelectedDateChangedEventHandler SelectedDateChanged
Delphi
public event SelectedDateChanged: WebCalendarOnSelectedDateChangedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires when WebCalendar selected date is changed")]
[System.ComponentModel.CategoryAttribute("Interaction")]
public: __event WebCalendarOnSelectedDateChangedEventHandler* SelectedDateChanged
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires when WebCalendar selected date is changed")]
[System.ComponentModel.CategoryAttribute("Interaction")]
public:
event WebCalendarOnSelectedDateChangedEventHandler^ SelectedDateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


SelectedDates Property

[image]
Intersoft WebEssentials Documentation
SelectedDates Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : SelectedDates Property

Glossary Item Box

The selected dates collection used by WebCalendar when multiple selections is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setSelectedDates")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The selected dates collection used by WebCalendar when multiple selections is enabled.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property SelectedDates As WebCalendarSelectedDatesCollection
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As WebCalendarSelectedDatesCollection

value = instance.SelectedDates
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSelectedDates")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The selected dates collection used by WebCalendar when multiple selections is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebCalendarSelectedDatesCollection SelectedDates {get;}
Delphi
public read-only property SelectedDates: WebCalendarSelectedDatesCollection;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("setSelectedDates")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("The selected dates collection used by WebCalendar when multiple selections is enabled.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get SelectedDates : WebCalendarSelectedDatesCollection
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSelectedDates")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The selected dates collection used by WebCalendar when multiple selections is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebCalendarSelectedDatesCollection* get_SelectedDates();
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setSelectedDates")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The selected dates collection used by WebCalendar when multiple selections is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebCalendarSelectedDatesCollection^ SelectedDates {
   WebCalendarSelectedDatesCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


SetRenderMethodDelegate Method

[image]
Intersoft WebEssentials Documentation
SetRenderMethodDelegate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


SetSessionTheme Method

[image]
Intersoft WebEssentials Documentation
SetSessionTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


SharedScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
SharedScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required framework scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")>
Public Overrides Property SharedScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
public override System.string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: System.String; override;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")
public override function get,set SharedScriptDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
public: __property System.string* get_SharedScriptDirectory() override;
public: __property void set_SharedScriptDirectory(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
public:
property System.String^ SharedScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ShouldReturnJson Method

[image]
Intersoft WebEssentials Documentation
ShouldReturnJson Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

value = instance.ShouldReturnJson()
C#
public virtual System.bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): System.Boolean; virtual;
JScript
public function ShouldReturnJson() : System.boolean;
Managed Extensions for C++
public: virtual System.bool ShouldReturnJson();
C++/CLI
public:
virtual System.bool ShouldReturnJson();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ShowWeekNumbers Property

[image]
Intersoft WebEssentials Documentation
ShowWeekNumbers Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ShowWeekNumbers Property

Glossary Item Box

Determines whether or not week number should be displayed in WebCalendar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determines whether or not week number should be displayed in WebCalendar.")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ShowWeekNumbers As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.ShowWeekNumbers = value

value = instance.ShowWeekNumbers
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not week number should be displayed in WebCalendar.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool ShowWeekNumbers {get; set;}
Delphi
public read-write property ShowWeekNumbers: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not week number should be displayed in WebCalendar.")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ShowWeekNumbers : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not week number should be displayed in WebCalendar.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_ShowWeekNumbers();
public: __property void set_ShowWeekNumbers(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not week number should be displayed in WebCalendar.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool ShowWeekNumbers {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


SkinID Property

[image]
Intersoft WebEssentials Documentation
SkinID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


TabIndex Property

[image]
Intersoft WebEssentials Documentation
TabIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set TabIndex : System.short
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


TableStyle Property

[image]
Intersoft WebEssentials Documentation
TableStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : TableStyle Property

Glossary Item Box

Contains interactive style for WebCalendar table.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar table.")>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property TableStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.WebStyle

instance.TableStyle = value

value = instance.TableStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar table.")]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle TableStyle {get; set;}
Delphi
public read-write property TableStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar table.")
System.ComponentModel.CategoryAttribute("Style")
public function get,set TableStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar table.")]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_TableStyle();
public: __property void set_TableStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar table.")]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ TableStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


TextSettings Property

[image]
Intersoft WebEssentials Documentation
TextSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : TextSettings Property

Glossary Item Box

Provides settings that control text that shown in WebCalendar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the text that shown in WebCalendar.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setTextSettings")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property TextSettings As WebCalendarTextSettings
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As WebCalendarTextSettings

value = instance.TextSettings
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the text that shown in WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setTextSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebCalendarTextSettings TextSettings {get;}
Delphi
public read-only property TextSettings: WebCalendarTextSettings;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Provides the settings that control the text that shown in WebCalendar.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setTextSettings")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get TextSettings : WebCalendarTextSettings
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the text that shown in WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setTextSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebCalendarTextSettings* get_TextSettings();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the text that shown in WebCalendar.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setTextSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebCalendarTextSettings^ TextSettings {
   WebCalendarTextSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


TodayStyle Property

[image]
Intersoft WebEssentials Documentation
TodayStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : TodayStyle Property

Glossary Item Box

Contains interactive style for WebCalendar today cell.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar today cell.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TodayStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.WebStyle

instance.TodayStyle = value

value = instance.TodayStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar today cell.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle TodayStyle {get; set;}
Delphi
public read-write property TodayStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar today cell.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.DefaultValueAttribute()
public function get,set TodayStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar today cell.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_TodayStyle();
public: __property void set_TodayStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar today cell.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ TodayStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ToolTip Property

[image]
Intersoft WebEssentials Documentation
ToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


Unload Event

[image]
Intersoft WebEssentials Documentation
Unload Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


UseDefaultStyle Property

[image]
Intersoft WebEssentials Documentation
UseDefaultStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : UseDefaultStyle Property

Glossary Item Box

Determines whether or not WebCalendar is using default style.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar is using default style.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property UseDefaultStyle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.UseDefaultStyle = value

value = instance.UseDefaultStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar is using default style.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool UseDefaultStyle {get; set;}
Delphi
public read-write property UseDefaultStyle: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar is using default style.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set UseDefaultStyle : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar is using default style.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_UseDefaultStyle();
public: __property void set_UseDefaultStyle(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebCalendar is using default style.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool UseDefaultStyle {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ValidateRequestMode Property

[image]
Intersoft WebEssentials Documentation
ValidateRequestMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ViewMode Property

[image]
Intersoft WebEssentials Documentation
ViewMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ViewMode Property

Glossary Item Box

Specifies WebCalendar highlight mode.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies WebCalendar view mode.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ViewMode As WebCalendarViewType
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As WebCalendarViewType

instance.ViewMode = value

value = instance.ViewMode
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar view mode.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebCalendarViewType ViewMode {get; set;}
Delphi
public read-write property ViewMode: WebCalendarViewType;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies WebCalendar view mode.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ViewMode : WebCalendarViewType
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar view mode.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebCalendarViewType get_ViewMode();
public: __property void set_ViewMode(
   WebCalendarViewType value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar view mode.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebCalendarViewType ViewMode {
   WebCalendarViewType get();
   void set (    WebCalendarViewType value);
}

Property Value

The default value is Day.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ViewStateItems Property

[image]
Intersoft WebEssentials Documentation
ViewStateItems Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ViewStateItems Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ViewStateMode Property

[image]
Intersoft WebEssentials Documentation
ViewStateMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ViewStateServerConnection Property

[image]
Intersoft WebEssentials Documentation
ViewStateServerConnection Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ViewStateServerConnection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ViewStateServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: System.String; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
System.ComponentModel.CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ViewStateServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ViewStateServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


ViewStateStorage Property

[image]
Intersoft WebEssentials Documentation
ViewStateStorage Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : ViewStateStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
System.ComponentModel.CategoryAttribute("View State Settings")
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


WeekNameStyle Property

[image]
Intersoft WebEssentials Documentation
WeekNameStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : WeekNameStyle Property

Glossary Item Box

Contains interactive style for WebCalendar week name.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar week name.")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property WeekNameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.WebStyle

instance.WeekNameStyle = value

value = instance.WeekNameStyle
C#
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar week name.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle WeekNameStyle {get; set;}
Delphi
public read-write property WeekNameStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar week name.")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Style")
public function get,set WeekNameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar week name.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_WeekNameStyle();
public: __property void set_WeekNameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar week name.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ WeekNameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


WeekNumberStyle Property

[image]
Intersoft WebEssentials Documentation
WeekNumberStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : WeekNumberStyle Property

Glossary Item Box

Contains interactive style for WebCalendar week number.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar week number.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property WeekNumberStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As ISNet.WebUI.WebStyle

instance.WeekNumberStyle = value

value = instance.WeekNumberStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar week number.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle WeekNumberStyle {get; set;}
Delphi
public read-write property WeekNumberStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar week number.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style")
public function get,set WeekNumberStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar week number.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_WeekNumberStyle();
public: __property void set_WeekNumberStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebCalendar week number.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ WeekNumberStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


WeekViewMode Property

[image]
Intersoft WebEssentials Documentation
WeekViewMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : WeekViewMode Property

Glossary Item Box

Specifies WebCalendar week view mode.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies WebCalendar week view mode.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property WeekViewMode As WebCalendarWeekViewMode
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As WebCalendarWeekViewMode

instance.WeekViewMode = value

value = instance.WeekViewMode
C#
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar week view mode.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebCalendarWeekViewMode WeekViewMode {get; set;}
Delphi
public read-write property WeekViewMode: WebCalendarWeekViewMode;
JScript
System.ComponentModel.DescriptionAttribute("Specifies WebCalendar week view mode.")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set WeekViewMode : WebCalendarWeekViewMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar week view mode.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebCalendarWeekViewMode get_WeekViewMode();
public: __property void set_WeekViewMode(
   WebCalendarWeekViewMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies WebCalendar week view mode.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebCalendarWeekViewMode WeekViewMode {
   WebCalendarWeekViewMode get();
   void set (    WebCalendarWeekViewMode value);
}

Property Value

The default value is FullWeek.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


Width Property

[image]
Intersoft WebEssentials Documentation
Width Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overrides Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public override System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; override;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public override function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.Web.UI.WebControls.Unit get_Width() override;
public: __property void set_Width(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


WorkWeekSettings Property

[image]
Intersoft WebEssentials Documentation
WorkWeekSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : WorkWeekSettings Property

Glossary Item Box

Provides the settings that control the behaviors of the WorkWeek in WebCalendar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the WorkWeek in WebCalendar.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setWorkWeekSettings")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property WorkWeekSettings As WebCalendarWorkWeekSettings
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As WebCalendarWorkWeekSettings

value = instance.WorkWeekSettings
C#
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the WorkWeek in WebCalendar.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setWorkWeekSettings")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebCalendarWorkWeekSettings WorkWeekSettings {get;}
Delphi
public read-only property WorkWeekSettings: WebCalendarWorkWeekSettings;
JScript
System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the WorkWeek in WebCalendar.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setWorkWeekSettings")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get WorkWeekSettings : WebCalendarWorkWeekSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the WorkWeek in WebCalendar.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setWorkWeekSettings")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebCalendarWorkWeekSettings* get_WorkWeekSettings();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the WorkWeek in WebCalendar.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setWorkWeekSettings")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebCalendarWorkWeekSettings^ WorkWeekSettings {
   WebCalendarWorkWeekSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


XmlCompressionEnabled Property

[image]
Intersoft WebEssentials Documentation
XmlCompressionEnabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebCalendar Class : XmlCompressionEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property XmlCompressionEnabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebCalendar
Dim value As System.Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: System.Boolean; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set XmlCompressionEnabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool XmlCompressionEnabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebCalendar Class
WebCalendar Members


WebContainerViewItem Class

[image]
Intersoft WebEssentials Documentation
WebContainerViewItem Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebContainerViewItem Class

Glossary Item Box

Object Model

WebContainerViewItem Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class WebContainerViewItem
   Inherits System.Web.UI.WebControls.Panel
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
C#
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class WebContainerViewItem : System.Web.UI.WebControls.Panel
Delphi
public class WebContainerViewItem = class(System.Web.UI.WebControls.Panel)
JScript
System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")
public class WebContainerViewItem extends System.Web.UI.WebControls.Panel
Managed Extensions for C++
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class WebContainerViewItem : public System.Web.UI.WebControls.Panel
C++/CLI
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class WebContainerViewItem : public System.Web.UI.WebControls.Panel

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.Panel
ISNet.WebUI.WebEssentials.WebContainerViewItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Members
ISNet.WebUI.WebEssentials Namespace


WebContainerViewItem Class Events

[image]
Intersoft WebEssentials Documentation
WebContainerViewItem Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebContainerViewItem Class

Glossary Item Box

For a list of all members of this type, see WebContainerViewItem members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebContainerViewItem Class
ISNet.WebUI.WebEssentials Namespace


WebContainerViewItem Class Members

[image]
Intersoft WebEssentials Documentation
WebContainerViewItem Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebContainerViewItem Class

Glossary Item Box

The following tables list the members exposed by WebContainerViewItem.

Public Constructors

 | Name | Description
Public Constructor | WebContainerViewItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackImageUrl | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DefaultButton | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Direction | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | GroupingText | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HorizontalAlign | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ScrollBars | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Wrap | (Inherited from System.Web.UI.WebControls.Panel)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | Overridden.
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebContainerViewItem Class
ISNet.WebUI.WebEssentials Namespace


WebContainerViewItem Class Methods

[image]
Intersoft WebEssentials Documentation
WebContainerViewItem Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebContainerViewItem Class

Glossary Item Box

For a list of all members of this type, see WebContainerViewItem members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | Overridden.
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebContainerViewItem Class
ISNet.WebUI.WebEssentials Namespace


WebContainerViewItem Class Properties

[image]
Intersoft WebEssentials Documentation
WebContainerViewItem Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebContainerViewItem Class

Glossary Item Box

For a list of all members of this type, see WebContainerViewItem members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackImageUrl | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DefaultButton | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Direction | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | GroupingText | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HorizontalAlign | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ScrollBars | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Wrap | (Inherited from System.Web.UI.WebControls.Panel)
Top

See Also

Reference

WebContainerViewItem Class
ISNet.WebUI.WebEssentials Namespace


WebContainerViewItemBound Class

[image]
Intersoft WebEssentials Documentation
WebContainerViewItemBound Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebContainerViewItemBound Class

Glossary Item Box

Object Model

WebContainerViewItemBound Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class WebContainerViewItemBound
   Inherits System.Web.UI.WebControls.Panel
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
C#
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class WebContainerViewItemBound : System.Web.UI.WebControls.Panel
Delphi
public class WebContainerViewItemBound = class(System.Web.UI.WebControls.Panel)
JScript
System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")
public class WebContainerViewItemBound extends System.Web.UI.WebControls.Panel
Managed Extensions for C++
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class WebContainerViewItemBound : public System.Web.UI.WebControls.Panel
C++/CLI
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class WebContainerViewItemBound : public System.Web.UI.WebControls.Panel

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.Panel
ISNet.WebUI.WebEssentials.WebContainerViewItemBound

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Members
ISNet.WebUI.WebEssentials Namespace


WebContainerViewItemBound Class Events

[image]
Intersoft WebEssentials Documentation
WebContainerViewItemBound Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebContainerViewItemBound Class

Glossary Item Box

For a list of all members of this type, see WebContainerViewItemBound members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebContainerViewItemBound Class
ISNet.WebUI.WebEssentials Namespace


WebContainerViewItemBound Class Members

[image]
Intersoft WebEssentials Documentation
WebContainerViewItemBound Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebContainerViewItemBound Class

Glossary Item Box

The following tables list the members exposed by WebContainerViewItemBound.

Public Constructors

 | Name | Description
Public Constructor | WebContainerViewItemBound Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackImageUrl | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DataItem |
Public Property | DataItemIndex |
Public Property | DefaultButton | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Direction | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | DisplayIndex |
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | GroupingText | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HorizontalAlign | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ScrollBars | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Wrap | (Inherited from System.Web.UI.WebControls.Panel)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | Overridden.
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebContainerViewItemBound Class
ISNet.WebUI.WebEssentials Namespace


WebContainerViewItemBound Class Methods

[image]
Intersoft WebEssentials Documentation
WebContainerViewItemBound Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebContainerViewItemBound Class

Glossary Item Box

For a list of all members of this type, see WebContainerViewItemBound members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | Overridden.
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebContainerViewItemBound Class
ISNet.WebUI.WebEssentials Namespace


WebContainerViewItemBound Class Properties

[image]
Intersoft WebEssentials Documentation
WebContainerViewItemBound Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebContainerViewItemBound Class

Glossary Item Box

For a list of all members of this type, see WebContainerViewItemBound members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackImageUrl | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DataItem |
Public Property | DataItemIndex |
Public Property | DefaultButton | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Direction | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | DisplayIndex |
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | GroupingText | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HorizontalAlign | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ScrollBars | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.Panel)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Wrap | (Inherited from System.Web.UI.WebControls.Panel)
Top

See Also

Reference

WebContainerViewItemBound Class
ISNet.WebUI.WebEssentials Namespace


WebContainerViewItemBound Constructor

[image]
Intersoft WebEssentials Documentation
WebContainerViewItemBound Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : WebContainerViewItemBound Constructor

Glossary Item Box

Overload List

Overload | Description
WebContainerViewItemBound Constructor() |
WebContainerViewItemBound Constructor(Object,Int32,Int32) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


WebContainerViewItemBound Constructor()

[image]
Intersoft WebEssentials Documentation
WebContainerViewItemBound Constructor()
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class > WebContainerViewItemBound Constructor : WebContainerViewItemBound Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebContainerViewItemBound()
C#
public WebContainerViewItemBound()
Delphi
public WebContainerViewItemBound();
JScript
public function WebContainerViewItemBound();
Managed Extensions for C++
public: WebContainerViewItemBound();
C++/CLI
public:
WebContainerViewItemBound();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members
Overload List


WebContainerViewItemBound Constructor(Object,Int32,Int32)

[image]
Intersoft WebEssentials Documentation
WebContainerViewItemBound Constructor(Object,Int32,Int32)
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class > WebContainerViewItemBound Constructor : WebContainerViewItemBound Constructor(Object,Int32,Int32)

DataItem
DataItemIndex
DisplayIndex

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal DataItem As System.Object, _
   ByVal DataItemIndex As System.Integer, _
   ByVal DisplayIndex As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim DataItem As System.Object
Dim DataItemIndex As System.Integer
Dim DisplayIndex As System.Integer

Dim instance As New WebContainerViewItemBound(DataItem, DataItemIndex, DisplayIndex)
C#
public WebContainerViewItemBound(
   System.object DataItem,
   System.int DataItemIndex,
   System.int DisplayIndex
)
Delphi
public WebContainerViewItemBound(
    DataItem: System.TObject;
    DataItemIndex: System.Integer;
    DisplayIndex: System.Integer
);
JScript
public function WebContainerViewItemBound(
   DataItem : System.Object,
   DataItemIndex : System.int,
   DisplayIndex : System.int
);
Managed Extensions for C++
public: WebContainerViewItemBound(
   System.Object* DataItem,
   System.int DataItemIndex,
   System.int DisplayIndex
)
C++/CLI
public:
WebContainerViewItemBound(
   System.Object^ DataItem,
   System.int DataItemIndex,
   System.int DisplayIndex
)

Parameters

DataItem
DataItemIndex
DisplayIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members
Overload List


AccessKey Property

[image]
Intersoft WebEssentials Documentation
AccessKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Accessibility")>
<WebSysDescriptionAttribute("Keyboard shortcut used by the control.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[WebCategoryAttribute("Accessibility")]
[WebSysDescriptionAttribute("Keyboard shortcut used by the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
WebCategoryAttribute("Accessibility")
WebSysDescriptionAttribute("Keyboard shortcut used by the control.")
System.ComponentModel.DefaultValueAttribute()
public function get,set AccessKey : System.String
Managed Extensions for C++
[WebCategoryAttribute("Accessibility")]
[WebSysDescriptionAttribute("Keyboard shortcut used by the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[WebCategoryAttribute("Accessibility")]
[WebSysDescriptionAttribute("Keyboard shortcut used by the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


ApplyStyle Method

[image]
Intersoft WebEssentials Documentation
ApplyStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebEssentials Documentation
ApplyStyleSheetSkin Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


BackColor Property

[image]
Intersoft WebEssentials Documentation
BackColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : BackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("Color of the background of the control.")>
<System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Overridable Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the background of the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public virtual System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("Color of the background of the control.")
System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
public function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the background of the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the background of the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public:
virtual property System.Drawing.Color BackColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


BackImageUrl Property

[image]
Intersoft WebEssentials Documentation
BackImageUrl Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : BackImageUrl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The background image of the panel.")>
<System.Web.UI.UrlPropertyAttribute()>
<WebCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Overridable Property BackImageUrl As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.String

instance.BackImageUrl = value

value = instance.BackImageUrl
C#
[WebSysDescriptionAttribute("The background image of the panel.")]
[System.Web.UI.UrlPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public virtual System.string BackImageUrl {get; set;}
Delphi
public read-write property BackImageUrl: System.String; virtual;
JScript
WebSysDescriptionAttribute("The background image of the panel.")
System.Web.UI.UrlPropertyAttribute()
WebCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
public function get,set BackImageUrl : System.String
Managed Extensions for C++
[WebSysDescriptionAttribute("The background image of the panel.")]
[System.Web.UI.UrlPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public: __property virtual System.string* get_BackImageUrl();
public: __property virtual void set_BackImageUrl(
   System.string* value
);
C++/CLI
[WebSysDescriptionAttribute("The background image of the panel.")]
[System.Web.UI.UrlPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public:
virtual property System.String^ BackImageUrl {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


BorderColor Property

[image]
Intersoft WebEssentials Documentation
BorderColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : BorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("Color of the border around the control.")>
<System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Overridable Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the border around the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public virtual System.Drawing.Color BorderColor {get; set;}
Delphi
public read-write property BorderColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("Color of the border around the control.")
System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
public function get,set BorderColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the border around the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the border around the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public:
virtual property System.Drawing.Color BorderColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


BorderStyle Property

[image]
Intersoft WebEssentials Documentation
BorderStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("Style of the border around the control.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Style of the border around the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
Delphi
public read-write property BorderStyle: System.Web.UI.WebControls.BorderStyle; virtual;
JScript
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("Style of the border around the control.")
System.ComponentModel.DefaultValueAttribute()
public function get,set BorderStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Style of the border around the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
C++/CLI
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Style of the border around the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.WebControls.BorderStyle BorderStyle {
   System.Web.UI.WebControls.BorderStyle get();
   void set (    System.Web.UI.WebControls.BorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


BorderWidth Property

[image]
Intersoft WebEssentials Documentation
BorderWidth Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : BorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("Width of the border around the control.")>
Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Width of the border around the control.")]
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
Delphi
public read-write property BorderWidth: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("Width of the border around the control.")
public function get,set BorderWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Width of the border around the control.")]
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Width of the border around the control.")]
public:
virtual property System.Web.UI.WebControls.Unit BorderWidth {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


ClientIDMode Property

[image]
Intersoft WebEssentials Documentation
ClientIDMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


CopyBaseAttributes Method

[image]
Intersoft WebEssentials Documentation
CopyBaseAttributes Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


CssClass Property

[image]
Intersoft WebEssentials Documentation
CssClass Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : CssClass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("CSS Class name applied to the control.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.CssClassPropertyAttribute()>
<WebCategoryAttribute("Appearance")>
Public Overridable Property CssClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
C#
[WebSysDescriptionAttribute("CSS Class name applied to the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.CssClassPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
public virtual System.string CssClass {get; set;}
Delphi
public read-write property CssClass: System.String; virtual;
JScript
WebSysDescriptionAttribute("CSS Class name applied to the control.")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.CssClassPropertyAttribute()
WebCategoryAttribute("Appearance")
public function get,set CssClass : System.String
Managed Extensions for C++
[WebSysDescriptionAttribute("CSS Class name applied to the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.CssClassPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
C++/CLI
[WebSysDescriptionAttribute("CSS Class name applied to the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.CssClassPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
public:
virtual property System.String^ CssClass {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


DataBind Method

[image]
Intersoft WebEssentials Documentation
DataBind Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


DataBind() Method

[image]
Intersoft WebEssentials Documentation
DataBind() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


DataBinding Event

[image]
Intersoft WebEssentials Documentation
DataBinding Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


DataItem Property

[image]
Intersoft WebEssentials Documentation
DataItem Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : DataItem Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataItem As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Object

value = instance.DataItem
C#
public System.object DataItem {get;}
Delphi
public read-only property DataItem: System.TObject;
JScript
public function get DataItem : System.Object
Managed Extensions for C++
public: __property System.Object* get_DataItem();
C++/CLI
public:
property System.Object^ DataItem {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


DataItemIndex Property

[image]
Intersoft WebEssentials Documentation
DataItemIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : DataItemIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataItemIndex As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Integer

value = instance.DataItemIndex
C#
public System.int DataItemIndex {get;}
Delphi
public read-only property DataItemIndex: System.Integer;
JScript
public function get DataItemIndex : System.int
Managed Extensions for C++
public: __property System.int get_DataItemIndex();
C++/CLI
public:
property System.int DataItemIndex {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


DefaultButton Property

[image]
Intersoft WebEssentials Documentation
DefaultButton Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : DefaultButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("The default button for the panel.")>
Public Overridable Property DefaultButton As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.String

instance.DefaultButton = value

value = instance.DefaultButton
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("The default button for the panel.")]
public virtual System.string DefaultButton {get; set;}
Delphi
public read-write property DefaultButton: System.String; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("The default button for the panel.")
public function get,set DefaultButton : System.String
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("The default button for the panel.")]
public: __property virtual System.string* get_DefaultButton();
public: __property virtual void set_DefaultButton(
   System.string* value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("The default button for the panel.")]
public:
virtual property System.String^ DefaultButton {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


Direction Property

[image]
Intersoft WebEssentials Documentation
Direction Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : Direction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The direction of text in the panel.")>
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Layout")>
Public Overridable Property Direction As System.Web.UI.WebControls.ContentDirection
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Web.UI.WebControls.ContentDirection

instance.Direction = value

value = instance.Direction
C#
[WebSysDescriptionAttribute("The direction of text in the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
public virtual System.Web.UI.WebControls.ContentDirection Direction {get; set;}
Delphi
public read-write property Direction: System.Web.UI.WebControls.ContentDirection; virtual;
JScript
WebSysDescriptionAttribute("The direction of text in the panel.")
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Layout")
public function get,set Direction : System.Web.UI.WebControls.ContentDirection
Managed Extensions for C++
[WebSysDescriptionAttribute("The direction of text in the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
public: __property virtual System.Web.UI.WebControls.ContentDirection get_Direction();
public: __property virtual void set_Direction(
   System.Web.UI.WebControls.ContentDirection value
);
C++/CLI
[WebSysDescriptionAttribute("The direction of text in the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
public:
virtual property System.Web.UI.WebControls.ContentDirection Direction {
   System.Web.UI.WebControls.ContentDirection get();
   void set (    System.Web.UI.WebControls.ContentDirection value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


DisplayIndex Property

[image]
Intersoft WebEssentials Documentation
DisplayIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : DisplayIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayIndex As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Integer

value = instance.DisplayIndex
C#
public System.int DisplayIndex {get;}
Delphi
public read-only property DisplayIndex: System.Integer;
JScript
public function get DisplayIndex : System.int
Managed Extensions for C++
public: __property System.int get_DisplayIndex();
C++/CLI
public:
property System.int DisplayIndex {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


Dispose Method

[image]
Intersoft WebEssentials Documentation
Dispose Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


Disposed Event

[image]
Intersoft WebEssentials Documentation
Disposed Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<WebSysDescriptionAttribute("Enabled state of the control.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("Enabled state of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
WebSysDescriptionAttribute("Enabled state of the control.")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("Enabled state of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("Enabled state of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


EnableTheming Property

[image]
Intersoft WebEssentials Documentation
EnableTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


EnableViewState Property

[image]
Intersoft WebEssentials Documentation
EnableViewState Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")>
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


FindControl Method

[image]
Intersoft WebEssentials Documentation
FindControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


FindControl(String) Method

[image]
Intersoft WebEssentials Documentation
FindControl(String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


Focus Method

[image]
Intersoft WebEssentials Documentation
Focus Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


Font Property

[image]
Intersoft WebEssentials Documentation
Font Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("The font used for text within the control.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("The font used for text within the control.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
Delphi
public read-only property Font: System.Web.UI.WebControls.FontInfo; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("The font used for text within the control.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get Font : System.Web.UI.WebControls.FontInfo
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("The font used for text within the control.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.Web.UI.WebControls.FontInfo* get_Font();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("The font used for text within the control.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.Web.UI.WebControls.FontInfo^ Font {
   System.Web.UI.WebControls.FontInfo^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


ForeColor Property

[image]
Intersoft WebEssentials Documentation
ForeColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : ForeColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("Color of the text within the control.")>
Public Overridable Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the text within the control.")]
public virtual System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("Color of the text within the control.")
public function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the text within the control.")]
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the text within the control.")]
public:
virtual property System.Drawing.Color ForeColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


GetRouteUrl Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


GetRouteUrl(Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebEssentials Documentation
GetUniqueIDRelativeTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


GroupingText Property

[image]
Intersoft WebEssentials Documentation
GroupingText Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : GroupingText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<WebSysDescriptionAttribute("The text of group box around this control's contents.")>
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Appearance")>
Public Overridable Property GroupingText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.String

instance.GroupingText = value

value = instance.GroupingText
C#
[System.ComponentModel.LocalizableAttribute(true)]
[WebSysDescriptionAttribute("The text of group box around this control's contents.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
public virtual System.string GroupingText {get; set;}
Delphi
public read-write property GroupingText: System.String; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
WebSysDescriptionAttribute("The text of group box around this control's contents.")
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Appearance")
public function get,set GroupingText : System.String
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[WebSysDescriptionAttribute("The text of group box around this control's contents.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
public: __property virtual System.string* get_GroupingText();
public: __property virtual void set_GroupingText(
   System.string* value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[WebSysDescriptionAttribute("The text of group box around this control's contents.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
public:
virtual property System.String^ GroupingText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


HasControls Method

[image]
Intersoft WebEssentials Documentation
HasControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


Height Property

[image]
Intersoft WebEssentials Documentation
Height Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The height of the control.")>
<WebCategoryAttribute("Layout")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[WebSysDescriptionAttribute("The height of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; virtual;
JScript
WebSysDescriptionAttribute("The height of the control.")
WebCategoryAttribute("Layout")
System.ComponentModel.DefaultValueAttribute()
public function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[WebSysDescriptionAttribute("The height of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[WebSysDescriptionAttribute("The height of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


HorizontalAlign Property

[image]
Intersoft WebEssentials Documentation
HorizontalAlign Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : HorizontalAlign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The horizontal alignment of the content.")>
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Layout")>
Public Overridable Property HorizontalAlign As System.Web.UI.WebControls.HorizontalAlign
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Web.UI.WebControls.HorizontalAlign

instance.HorizontalAlign = value

value = instance.HorizontalAlign
C#
[WebSysDescriptionAttribute("The horizontal alignment of the content.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
public virtual System.Web.UI.WebControls.HorizontalAlign HorizontalAlign {get; set;}
Delphi
public read-write property HorizontalAlign: System.Web.UI.WebControls.HorizontalAlign; virtual;
JScript
WebSysDescriptionAttribute("The horizontal alignment of the content.")
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Layout")
public function get,set HorizontalAlign : System.Web.UI.WebControls.HorizontalAlign
Managed Extensions for C++
[WebSysDescriptionAttribute("The horizontal alignment of the content.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
public: __property virtual System.Web.UI.WebControls.HorizontalAlign get_HorizontalAlign();
public: __property virtual void set_HorizontalAlign(
   System.Web.UI.WebControls.HorizontalAlign value
);
C++/CLI
[WebSysDescriptionAttribute("The horizontal alignment of the content.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
public:
virtual property System.Web.UI.WebControls.HorizontalAlign HorizontalAlign {
   System.Web.UI.WebControls.HorizontalAlign get();
   void set (    System.Web.UI.WebControls.HorizontalAlign value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


ID Property

[image]
Intersoft WebEssentials Documentation
ID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


Init Event

[image]
Intersoft WebEssentials Documentation
Init Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


Load Event

[image]
Intersoft WebEssentials Documentation
Load Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


MergeStyle Method

[image]
Intersoft WebEssentials Documentation
MergeStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


PreRender Event

[image]
Intersoft WebEssentials Documentation
PreRender Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


RenderBeginTag Method

[image]
Intersoft WebEssentials Documentation
RenderBeginTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public override void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


RenderControl Method

[image]
Intersoft WebEssentials Documentation
RenderControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebEssentials Documentation
RenderControl(HtmlTextWriter) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


RenderEndTag Method

[image]
Intersoft WebEssentials Documentation
RenderEndTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


ResolveClientUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveClientUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


ResolveUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


ScrollBars Property

[image]
Intersoft WebEssentials Documentation
ScrollBars Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : ScrollBars Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Layout")>
<WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ScrollBars As System.Web.UI.WebControls.ScrollBars
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Web.UI.WebControls.ScrollBars

instance.ScrollBars = value

value = instance.ScrollBars
C#
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.WebControls.ScrollBars ScrollBars {get; set;}
Delphi
public read-write property ScrollBars: System.Web.UI.WebControls.ScrollBars; virtual;
JScript
WebCategoryAttribute("Layout")
WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ScrollBars : System.Web.UI.WebControls.ScrollBars
Managed Extensions for C++
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.WebControls.ScrollBars get_ScrollBars();
public: __property virtual void set_ScrollBars(
   System.Web.UI.WebControls.ScrollBars value
);
C++/CLI
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.WebControls.ScrollBars ScrollBars {
   System.Web.UI.WebControls.ScrollBars get();
   void set (    System.Web.UI.WebControls.ScrollBars value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


SetRenderMethodDelegate Method

[image]
Intersoft WebEssentials Documentation
SetRenderMethodDelegate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


SkinID Property

[image]
Intersoft WebEssentials Documentation
SkinID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


SupportsDisabledAttribute Property

[image]
Intersoft WebEssentials Documentation
SupportsDisabledAttribute Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : SupportsDisabledAttribute Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Boolean

value = instance.SupportsDisabledAttribute
C#
public virtual System.bool SupportsDisabledAttribute {get;}
Delphi
public read-only property SupportsDisabledAttribute: System.Boolean; virtual;
JScript
public function get SupportsDisabledAttribute : System.boolean
Managed Extensions for C++
public: __property virtual System.bool get_SupportsDisabledAttribute();
C++/CLI
public:
virtual property System.bool SupportsDisabledAttribute {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


TabIndex Property

[image]
Intersoft WebEssentials Documentation
TabIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Accessibility")>
<WebSysDescriptionAttribute("The tab order of the control.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[WebCategoryAttribute("Accessibility")]
[WebSysDescriptionAttribute("The tab order of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
WebCategoryAttribute("Accessibility")
WebSysDescriptionAttribute("The tab order of the control.")
System.ComponentModel.DefaultValueAttribute()
public function get,set TabIndex : System.short
Managed Extensions for C++
[WebCategoryAttribute("Accessibility")]
[WebSysDescriptionAttribute("The tab order of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[WebCategoryAttribute("Accessibility")]
[WebSysDescriptionAttribute("The tab order of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


ToolTip Property

[image]
Intersoft WebEssentials Documentation
ToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.LocalizableAttribute(true)]
[WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


Unload Event

[image]
Intersoft WebEssentials Documentation
Unload Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


ValidateRequestMode Property

[image]
Intersoft WebEssentials Documentation
ValidateRequestMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


ViewStateMode Property

[image]
Intersoft WebEssentials Documentation
ViewStateMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


Width Property

[image]
Intersoft WebEssentials Documentation
Width Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The width of the control.")>
<WebCategoryAttribute("Layout")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[WebSysDescriptionAttribute("The width of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; virtual;
JScript
WebSysDescriptionAttribute("The width of the control.")
WebCategoryAttribute("Layout")
System.ComponentModel.DefaultValueAttribute()
public function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[WebSysDescriptionAttribute("The width of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[WebSysDescriptionAttribute("The width of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


Wrap Property

[image]
Intersoft WebEssentials Documentation
Wrap Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItemBound Class : Wrap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Layout")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Whether the content should wrap or not.")>
Public Overridable Property Wrap As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItemBound
Dim value As System.Boolean

instance.Wrap = value

value = instance.Wrap
C#
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the content should wrap or not.")]
public virtual System.bool Wrap {get; set;}
Delphi
public read-write property Wrap: System.Boolean; virtual;
JScript
WebCategoryAttribute("Layout")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Whether the content should wrap or not.")
public function get,set Wrap : System.boolean
Managed Extensions for C++
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the content should wrap or not.")]
public: __property virtual System.bool get_Wrap();
public: __property virtual void set_Wrap(
   System.bool value
);
C++/CLI
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the content should wrap or not.")]
public:
virtual property System.bool Wrap {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItemBound Class
WebContainerViewItemBound Members


WebContainerViewItem Constructor

[image]
Intersoft WebEssentials Documentation
WebContainerViewItem Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : WebContainerViewItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebContainerViewItem()
C#
public WebContainerViewItem()
Delphi
public WebContainerViewItem();
JScript
public function WebContainerViewItem();
Managed Extensions for C++
public: WebContainerViewItem();
C++/CLI
public:
WebContainerViewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


AccessKey Property

[image]
Intersoft WebEssentials Documentation
AccessKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Accessibility")>
<WebSysDescriptionAttribute("Keyboard shortcut used by the control.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[WebCategoryAttribute("Accessibility")]
[WebSysDescriptionAttribute("Keyboard shortcut used by the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
WebCategoryAttribute("Accessibility")
WebSysDescriptionAttribute("Keyboard shortcut used by the control.")
System.ComponentModel.DefaultValueAttribute()
public function get,set AccessKey : System.String
Managed Extensions for C++
[WebCategoryAttribute("Accessibility")]
[WebSysDescriptionAttribute("Keyboard shortcut used by the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[WebCategoryAttribute("Accessibility")]
[WebSysDescriptionAttribute("Keyboard shortcut used by the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


ApplyStyle Method

[image]
Intersoft WebEssentials Documentation
ApplyStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebEssentials Documentation
ApplyStyleSheetSkin Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


BackColor Property

[image]
Intersoft WebEssentials Documentation
BackColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : BackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("Color of the background of the control.")>
<System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Overridable Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the background of the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public virtual System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("Color of the background of the control.")
System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
public function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the background of the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the background of the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public:
virtual property System.Drawing.Color BackColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


BackImageUrl Property

[image]
Intersoft WebEssentials Documentation
BackImageUrl Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : BackImageUrl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The background image of the panel.")>
<System.Web.UI.UrlPropertyAttribute()>
<WebCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Overridable Property BackImageUrl As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.String

instance.BackImageUrl = value

value = instance.BackImageUrl
C#
[WebSysDescriptionAttribute("The background image of the panel.")]
[System.Web.UI.UrlPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public virtual System.string BackImageUrl {get; set;}
Delphi
public read-write property BackImageUrl: System.String; virtual;
JScript
WebSysDescriptionAttribute("The background image of the panel.")
System.Web.UI.UrlPropertyAttribute()
WebCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
public function get,set BackImageUrl : System.String
Managed Extensions for C++
[WebSysDescriptionAttribute("The background image of the panel.")]
[System.Web.UI.UrlPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public: __property virtual System.string* get_BackImageUrl();
public: __property virtual void set_BackImageUrl(
   System.string* value
);
C++/CLI
[WebSysDescriptionAttribute("The background image of the panel.")]
[System.Web.UI.UrlPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.ImageUrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public:
virtual property System.String^ BackImageUrl {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


BorderColor Property

[image]
Intersoft WebEssentials Documentation
BorderColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : BorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("Color of the border around the control.")>
<System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Overridable Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the border around the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public virtual System.Drawing.Color BorderColor {get; set;}
Delphi
public read-write property BorderColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("Color of the border around the control.")
System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
public function get,set BorderColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the border around the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the border around the control.")]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public:
virtual property System.Drawing.Color BorderColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


BorderStyle Property

[image]
Intersoft WebEssentials Documentation
BorderStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("Style of the border around the control.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Style of the border around the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
Delphi
public read-write property BorderStyle: System.Web.UI.WebControls.BorderStyle; virtual;
JScript
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("Style of the border around the control.")
System.ComponentModel.DefaultValueAttribute()
public function get,set BorderStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Style of the border around the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
C++/CLI
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Style of the border around the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.WebControls.BorderStyle BorderStyle {
   System.Web.UI.WebControls.BorderStyle get();
   void set (    System.Web.UI.WebControls.BorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


BorderWidth Property

[image]
Intersoft WebEssentials Documentation
BorderWidth Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : BorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("Width of the border around the control.")>
Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Width of the border around the control.")]
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
Delphi
public read-write property BorderWidth: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("Width of the border around the control.")
public function get,set BorderWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Width of the border around the control.")]
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Width of the border around the control.")]
public:
virtual property System.Web.UI.WebControls.Unit BorderWidth {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


ClientIDMode Property

[image]
Intersoft WebEssentials Documentation
ClientIDMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


CopyBaseAttributes Method

[image]
Intersoft WebEssentials Documentation
CopyBaseAttributes Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


CssClass Property

[image]
Intersoft WebEssentials Documentation
CssClass Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : CssClass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("CSS Class name applied to the control.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.CssClassPropertyAttribute()>
<WebCategoryAttribute("Appearance")>
Public Overridable Property CssClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
C#
[WebSysDescriptionAttribute("CSS Class name applied to the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.CssClassPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
public virtual System.string CssClass {get; set;}
Delphi
public read-write property CssClass: System.String; virtual;
JScript
WebSysDescriptionAttribute("CSS Class name applied to the control.")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.CssClassPropertyAttribute()
WebCategoryAttribute("Appearance")
public function get,set CssClass : System.String
Managed Extensions for C++
[WebSysDescriptionAttribute("CSS Class name applied to the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.CssClassPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
C++/CLI
[WebSysDescriptionAttribute("CSS Class name applied to the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.CssClassPropertyAttribute()]
[WebCategoryAttribute("Appearance")]
public:
virtual property System.String^ CssClass {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


DataBind Method

[image]
Intersoft WebEssentials Documentation
DataBind Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


DataBind() Method

[image]
Intersoft WebEssentials Documentation
DataBind() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


DataBinding Event

[image]
Intersoft WebEssentials Documentation
DataBinding Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


DefaultButton Property

[image]
Intersoft WebEssentials Documentation
DefaultButton Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : DefaultButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("The default button for the panel.")>
Public Overridable Property DefaultButton As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.String

instance.DefaultButton = value

value = instance.DefaultButton
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("The default button for the panel.")]
public virtual System.string DefaultButton {get; set;}
Delphi
public read-write property DefaultButton: System.String; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("The default button for the panel.")
public function get,set DefaultButton : System.String
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("The default button for the panel.")]
public: __property virtual System.string* get_DefaultButton();
public: __property virtual void set_DefaultButton(
   System.string* value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("The default button for the panel.")]
public:
virtual property System.String^ DefaultButton {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


Direction Property

[image]
Intersoft WebEssentials Documentation
Direction Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : Direction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The direction of text in the panel.")>
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Layout")>
Public Overridable Property Direction As System.Web.UI.WebControls.ContentDirection
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Web.UI.WebControls.ContentDirection

instance.Direction = value

value = instance.Direction
C#
[WebSysDescriptionAttribute("The direction of text in the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
public virtual System.Web.UI.WebControls.ContentDirection Direction {get; set;}
Delphi
public read-write property Direction: System.Web.UI.WebControls.ContentDirection; virtual;
JScript
WebSysDescriptionAttribute("The direction of text in the panel.")
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Layout")
public function get,set Direction : System.Web.UI.WebControls.ContentDirection
Managed Extensions for C++
[WebSysDescriptionAttribute("The direction of text in the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
public: __property virtual System.Web.UI.WebControls.ContentDirection get_Direction();
public: __property virtual void set_Direction(
   System.Web.UI.WebControls.ContentDirection value
);
C++/CLI
[WebSysDescriptionAttribute("The direction of text in the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
public:
virtual property System.Web.UI.WebControls.ContentDirection Direction {
   System.Web.UI.WebControls.ContentDirection get();
   void set (    System.Web.UI.WebControls.ContentDirection value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


Dispose Method

[image]
Intersoft WebEssentials Documentation
Dispose Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


Disposed Event

[image]
Intersoft WebEssentials Documentation
Disposed Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<WebSysDescriptionAttribute("Enabled state of the control.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("Enabled state of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
WebSysDescriptionAttribute("Enabled state of the control.")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("Enabled state of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("Enabled state of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


EnableTheming Property

[image]
Intersoft WebEssentials Documentation
EnableTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


EnableViewState Property

[image]
Intersoft WebEssentials Documentation
EnableViewState Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")>
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")]
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


FindControl Method

[image]
Intersoft WebEssentials Documentation
FindControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


FindControl(String) Method

[image]
Intersoft WebEssentials Documentation
FindControl(String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


Focus Method

[image]
Intersoft WebEssentials Documentation
Focus Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


Font Property

[image]
Intersoft WebEssentials Documentation
Font Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("The font used for text within the control.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("The font used for text within the control.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
Delphi
public read-only property Font: System.Web.UI.WebControls.FontInfo; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("The font used for text within the control.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get Font : System.Web.UI.WebControls.FontInfo
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("The font used for text within the control.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.Web.UI.WebControls.FontInfo* get_Font();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("The font used for text within the control.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.Web.UI.WebControls.FontInfo^ Font {
   System.Web.UI.WebControls.FontInfo^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


ForeColor Property

[image]
Intersoft WebEssentials Documentation
ForeColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : ForeColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Appearance")>
<WebSysDescriptionAttribute("Color of the text within the control.")>
Public Overridable Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the text within the control.")]
public virtual System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Appearance")
WebSysDescriptionAttribute("Color of the text within the control.")
public function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the text within the control.")]
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.WebColorConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
[WebSysDescriptionAttribute("Color of the text within the control.")]
public:
virtual property System.Drawing.Color ForeColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


GetRouteUrl Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


GetRouteUrl(Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebEssentials Documentation
GetUniqueIDRelativeTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


GroupingText Property

[image]
Intersoft WebEssentials Documentation
GroupingText Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : GroupingText Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<WebSysDescriptionAttribute("The text of group box around this control's contents.")>
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Appearance")>
Public Overridable Property GroupingText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.String

instance.GroupingText = value

value = instance.GroupingText
C#
[System.ComponentModel.LocalizableAttribute(true)]
[WebSysDescriptionAttribute("The text of group box around this control's contents.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
public virtual System.string GroupingText {get; set;}
Delphi
public read-write property GroupingText: System.String; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
WebSysDescriptionAttribute("The text of group box around this control's contents.")
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Appearance")
public function get,set GroupingText : System.String
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[WebSysDescriptionAttribute("The text of group box around this control's contents.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
public: __property virtual System.string* get_GroupingText();
public: __property virtual void set_GroupingText(
   System.string* value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[WebSysDescriptionAttribute("The text of group box around this control's contents.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Appearance")]
public:
virtual property System.String^ GroupingText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


HasControls Method

[image]
Intersoft WebEssentials Documentation
HasControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


Height Property

[image]
Intersoft WebEssentials Documentation
Height Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The height of the control.")>
<WebCategoryAttribute("Layout")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[WebSysDescriptionAttribute("The height of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; virtual;
JScript
WebSysDescriptionAttribute("The height of the control.")
WebCategoryAttribute("Layout")
System.ComponentModel.DefaultValueAttribute()
public function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[WebSysDescriptionAttribute("The height of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[WebSysDescriptionAttribute("The height of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


HorizontalAlign Property

[image]
Intersoft WebEssentials Documentation
HorizontalAlign Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : HorizontalAlign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The horizontal alignment of the content.")>
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Layout")>
Public Overridable Property HorizontalAlign As System.Web.UI.WebControls.HorizontalAlign
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Web.UI.WebControls.HorizontalAlign

instance.HorizontalAlign = value

value = instance.HorizontalAlign
C#
[WebSysDescriptionAttribute("The horizontal alignment of the content.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
public virtual System.Web.UI.WebControls.HorizontalAlign HorizontalAlign {get; set;}
Delphi
public read-write property HorizontalAlign: System.Web.UI.WebControls.HorizontalAlign; virtual;
JScript
WebSysDescriptionAttribute("The horizontal alignment of the content.")
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Layout")
public function get,set HorizontalAlign : System.Web.UI.WebControls.HorizontalAlign
Managed Extensions for C++
[WebSysDescriptionAttribute("The horizontal alignment of the content.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
public: __property virtual System.Web.UI.WebControls.HorizontalAlign get_HorizontalAlign();
public: __property virtual void set_HorizontalAlign(
   System.Web.UI.WebControls.HorizontalAlign value
);
C++/CLI
[WebSysDescriptionAttribute("The horizontal alignment of the content.")]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Layout")]
public:
virtual property System.Web.UI.WebControls.HorizontalAlign HorizontalAlign {
   System.Web.UI.WebControls.HorizontalAlign get();
   void set (    System.Web.UI.WebControls.HorizontalAlign value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


ID Property

[image]
Intersoft WebEssentials Documentation
ID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


Init Event

[image]
Intersoft WebEssentials Documentation
Init Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


Load Event

[image]
Intersoft WebEssentials Documentation
Load Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


MergeStyle Method

[image]
Intersoft WebEssentials Documentation
MergeStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


PreRender Event

[image]
Intersoft WebEssentials Documentation
PreRender Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


RenderBeginTag Method

[image]
Intersoft WebEssentials Documentation
RenderBeginTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public override void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


RenderControl Method

[image]
Intersoft WebEssentials Documentation
RenderControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebEssentials Documentation
RenderControl(HtmlTextWriter) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


RenderEndTag Method

[image]
Intersoft WebEssentials Documentation
RenderEndTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


ResolveClientUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveClientUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


ResolveUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


ScrollBars Property

[image]
Intersoft WebEssentials Documentation
ScrollBars Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : ScrollBars Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Layout")>
<WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ScrollBars As System.Web.UI.WebControls.ScrollBars
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Web.UI.WebControls.ScrollBars

instance.ScrollBars = value

value = instance.ScrollBars
C#
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.WebControls.ScrollBars ScrollBars {get; set;}
Delphi
public read-write property ScrollBars: System.Web.UI.WebControls.ScrollBars; virtual;
JScript
WebCategoryAttribute("Layout")
WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ScrollBars : System.Web.UI.WebControls.ScrollBars
Managed Extensions for C++
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.WebControls.ScrollBars get_ScrollBars();
public: __property virtual void set_ScrollBars(
   System.Web.UI.WebControls.ScrollBars value
);
C++/CLI
[WebCategoryAttribute("Layout")]
[WebSysDescriptionAttribute("The appearance of scrollbars for the panel.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.WebControls.ScrollBars ScrollBars {
   System.Web.UI.WebControls.ScrollBars get();
   void set (    System.Web.UI.WebControls.ScrollBars value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


SetRenderMethodDelegate Method

[image]
Intersoft WebEssentials Documentation
SetRenderMethodDelegate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


SkinID Property

[image]
Intersoft WebEssentials Documentation
SkinID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


SupportsDisabledAttribute Property

[image]
Intersoft WebEssentials Documentation
SupportsDisabledAttribute Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : SupportsDisabledAttribute Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Boolean

value = instance.SupportsDisabledAttribute
C#
public virtual System.bool SupportsDisabledAttribute {get;}
Delphi
public read-only property SupportsDisabledAttribute: System.Boolean; virtual;
JScript
public function get SupportsDisabledAttribute : System.boolean
Managed Extensions for C++
public: __property virtual System.bool get_SupportsDisabledAttribute();
C++/CLI
public:
virtual property System.bool SupportsDisabledAttribute {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


TabIndex Property

[image]
Intersoft WebEssentials Documentation
TabIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Accessibility")>
<WebSysDescriptionAttribute("The tab order of the control.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[WebCategoryAttribute("Accessibility")]
[WebSysDescriptionAttribute("The tab order of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
WebCategoryAttribute("Accessibility")
WebSysDescriptionAttribute("The tab order of the control.")
System.ComponentModel.DefaultValueAttribute()
public function get,set TabIndex : System.short
Managed Extensions for C++
[WebCategoryAttribute("Accessibility")]
[WebSysDescriptionAttribute("The tab order of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[WebCategoryAttribute("Accessibility")]
[WebSysDescriptionAttribute("The tab order of the control.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


ToolTip Property

[image]
Intersoft WebEssentials Documentation
ToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.LocalizableAttribute(true)]
[WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[WebSysDescriptionAttribute("The tooltip displayed when the mouse is over the control.")]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


Unload Event

[image]
Intersoft WebEssentials Documentation
Unload Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


ValidateRequestMode Property

[image]
Intersoft WebEssentials Documentation
ValidateRequestMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


ViewStateMode Property

[image]
Intersoft WebEssentials Documentation
ViewStateMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
<WebCategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
WebCategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[WebSysDescriptionAttribute("Indicates whether the control is visible and rendered.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[WebCategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


Width Property

[image]
Intersoft WebEssentials Documentation
Width Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The width of the control.")>
<WebCategoryAttribute("Layout")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[WebSysDescriptionAttribute("The width of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; virtual;
JScript
WebSysDescriptionAttribute("The width of the control.")
WebCategoryAttribute("Layout")
System.ComponentModel.DefaultValueAttribute()
public function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[WebSysDescriptionAttribute("The width of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[WebSysDescriptionAttribute("The width of the control.")]
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


Wrap Property

[image]
Intersoft WebEssentials Documentation
Wrap Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebContainerViewItem Class : Wrap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Layout")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Whether the content should wrap or not.")>
Public Overridable Property Wrap As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebContainerViewItem
Dim value As System.Boolean

instance.Wrap = value

value = instance.Wrap
C#
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the content should wrap or not.")]
public virtual System.bool Wrap {get; set;}
Delphi
public read-write property Wrap: System.Boolean; virtual;
JScript
WebCategoryAttribute("Layout")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Whether the content should wrap or not.")
public function get,set Wrap : System.boolean
Managed Extensions for C++
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the content should wrap or not.")]
public: __property virtual System.bool get_Wrap();
public: __property virtual void set_Wrap(
   System.bool value
);
C++/CLI
[WebCategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Whether the content should wrap or not.")]
public:
virtual property System.bool Wrap {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebContainerViewItem Class
WebContainerViewItem Members


WebExpander Class

[image]
Intersoft WebEssentials Documentation
WebExpander Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpander Class

Glossary Item Box

Intersoft WebExpander.

Object Model

WebExpander Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultEventAttribute("Clicked")>
<ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebExpander.js", Type=XmlSerializationType.ClientAndLayout)>
<System.Web.UI.ToolboxDataAttribute("<{0}:WebExpander runat="server" Width="600px" ></{0}:WebExpander>")>
<System.ComponentModel.DefaultPropertyAttribute("Text")>
<System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebExpanderDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.SerializableAttribute()>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebExpander
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
C#
[System.ComponentModel.DefaultEventAttribute("Clicked")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebExpander.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebExpander runat="server" Width="600px" ></{0}:WebExpander>")]
[System.ComponentModel.DefaultPropertyAttribute("Text")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebExpanderDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebExpander : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Delphi
public class WebExpander = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings)
JScript
System.ComponentModel.DefaultEventAttribute("Clicked")
ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebExpander.js", Type=XmlSerializationType.ClientAndLayout)
System.Web.UI.ToolboxDataAttribute("<{0}:WebExpander runat="server" Width="600px" ></{0}:WebExpander>")
System.ComponentModel.DefaultPropertyAttribute("Text")
System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebExpanderDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.SerializableAttribute()
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebExpander extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Managed Extensions for C++
[System.ComponentModel.DefaultEventAttribute("Clicked")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebExpander.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebExpander runat="server" Width="600px" ></{0}:WebExpander>")]
[System.ComponentModel.DefaultPropertyAttribute("Text")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebExpanderDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebExpander : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
C++/CLI
[System.ComponentModel.DefaultEventAttribute("Clicked")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebExpander.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebExpander runat="server" Width="600px" ></{0}:WebExpander>")]
[System.ComponentModel.DefaultPropertyAttribute("Text")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebExpanderDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebExpander : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebEssentials.WebExpander

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Members
ISNet.WebUI.WebEssentials Namespace


WebExpander Class Events

[image]
Intersoft WebEssentials Documentation
WebExpander Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpander Class

Glossary Item Box

For a list of all members of this type, see WebExpander members.

Public Events

 | Name | Description
Public Event | Click |
Public Event | Collapsed |
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Expanded |
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebExpander Class
ISNet.WebUI.WebEssentials Namespace


WebExpander Class Members

[image]
Intersoft WebEssentials Documentation
WebExpander Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpander Class

Glossary Item Box

The following tables list the members exposed by WebExpander.

Public Constructors

 | Name | Description
Public Constructor | WebExpander Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | AnimationDuration | Gets or sets the animation durion during item Expand or Collapse.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Gets or sets client side events for WebExpander.
Public Property | ContainerStyle | Gets or sets the the style of the expander item content.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Flow | Gets or sets a value indicating whether the flow of the expansion of the control is Left, Right, Up, or Down.
Public Property | FlyPostBackSettings |
Public Property | FrameStyle | Gets or sets the the style of the WebExpander frame.
Public Property | HeaderCaptionStyle | Gets or sets the the applied style for all the header caption in the expander.
Public Property | HeaderStyle | Gets or sets the the applied default style for all the header item in the expander.
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | IndicatorStyle | Gets or sets the the style of the WebExpander item indicator style.
Public Property | Items | Gets or sets the collection of content item for WebExpander.
Public Property | ItemSettings | Provides the settings that control the default WebExpander's item settings.
Public Property | Mode | Gets or sets a value indicating whether the expander mode is Fixed or Flow.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PostBackMode | Gets or sets the PostBack mode for WebExpander.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden.
Public Property | SharedScriptDirectory | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseDefaultStyle | Determines whether or not WebExpander is using default style.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | Overridden.
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | Click |
Public Event | Collapsed |
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Expanded |
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebExpander Class
ISNet.WebUI.WebEssentials Namespace


WebExpander Class Methods

[image]
Intersoft WebEssentials Documentation
WebExpander Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpander Class

Glossary Item Box

For a list of all members of this type, see WebExpander members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebExpander Class
ISNet.WebUI.WebEssentials Namespace


WebExpander Class Properties

[image]
Intersoft WebEssentials Documentation
WebExpander Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpander Class

Glossary Item Box

For a list of all members of this type, see WebExpander members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | AnimationDuration | Gets or sets the animation durion during item Expand or Collapse.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Gets or sets client side events for WebExpander.
Public Property | ContainerStyle | Gets or sets the the style of the expander item content.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Flow | Gets or sets a value indicating whether the flow of the expansion of the control is Left, Right, Up, or Down.
Public Property | FlyPostBackSettings |
Public Property | FrameStyle | Gets or sets the the style of the WebExpander frame.
Public Property | HeaderCaptionStyle | Gets or sets the the applied style for all the header caption in the expander.
Public Property | HeaderStyle | Gets or sets the the applied default style for all the header item in the expander.
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | IndicatorStyle | Gets or sets the the style of the WebExpander item indicator style.
Public Property | Items | Gets or sets the collection of content item for WebExpander.
Public Property | ItemSettings | Provides the settings that control the default WebExpander's item settings.
Public Property | Mode | Gets or sets a value indicating whether the expander mode is Fixed or Flow.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PostBackMode | Gets or sets the PostBack mode for WebExpander.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden.
Public Property | SharedScriptDirectory | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseDefaultStyle | Determines whether or not WebExpander is using default style.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | Overridden.
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebExpander Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderChangedEventDataArgs Class

[image]
Intersoft WebEssentials Documentation
WebExpanderChangedEventDataArgs Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderChangedEventDataArgs Class

Glossary Item Box

Represents the WebExpander collapsed and expanded event argument.

Object Model

WebExpanderChangedEventDataArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebExpanderChangedEventDataArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderChangedEventDataArgs
C#
public class WebExpanderChangedEventDataArgs : System.EventArgs
Delphi
public class WebExpanderChangedEventDataArgs = class(System.EventArgs)
JScript
public class WebExpanderChangedEventDataArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebExpanderChangedEventDataArgs : public System.EventArgs
C++/CLI
public ref class WebExpanderChangedEventDataArgs : public System.EventArgs

Remarks

This class contains property for the WebExpander collapsed and expanded event argument.

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebEssentials.WebExpanderChangedEventDataArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderChangedEventDataArgs Members
ISNet.WebUI.WebEssentials Namespace


WebExpanderChangedEventDataArgs Class Members

[image]
Intersoft WebEssentials Documentation
WebExpanderChangedEventDataArgs Class Members
See Also Properties Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderChangedEventDataArgs Class

Glossary Item Box

The following tables list the members exposed by WebExpanderChangedEventDataArgs.

Public Constructors

 | Name | Description
Public Constructor | WebExpanderChangedEventDataArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Expander | The WebExpander object.
Public Property | Item | The WebExpanderItem collapsed or expanded object.
Top

See Also

Reference

WebExpanderChangedEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderChangedEventDataArgs Class Properties

[image]
Intersoft WebEssentials Documentation
WebExpanderChangedEventDataArgs Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderChangedEventDataArgs Class

Glossary Item Box

For a list of all members of this type, see WebExpanderChangedEventDataArgs members.

Public Properties

 | Name | Description
Public Property | Expander | The WebExpander object.
Public Property | Item | The WebExpanderItem collapsed or expanded object.
Top

See Also

Reference

WebExpanderChangedEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderChangedEventDataArgs Constructor

[image]
Intersoft WebEssentials Documentation
WebExpanderChangedEventDataArgs Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderChangedEventDataArgs Class : WebExpanderChangedEventDataArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExpanderChangedEventDataArgs()
C#
public WebExpanderChangedEventDataArgs()
Delphi
public WebExpanderChangedEventDataArgs();
JScript
public function WebExpanderChangedEventDataArgs();
Managed Extensions for C++
public: WebExpanderChangedEventDataArgs();
C++/CLI
public:
WebExpanderChangedEventDataArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderChangedEventDataArgs Class
WebExpanderChangedEventDataArgs Members


Expander Property

[image]
Intersoft WebEssentials Documentation
Expander Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderChangedEventDataArgs Class : Expander Property

Glossary Item Box

The WebExpander object.

Syntax

Visual Basic (Declaration)
Public Property Expander As WebExpander
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderChangedEventDataArgs
Dim value As WebExpander

instance.Expander = value

value = instance.Expander
C#
public WebExpander Expander {get; set;}
Delphi
public read-write property Expander: WebExpander;
JScript
public function get,set Expander : WebExpander
Managed Extensions for C++
public: __property WebExpander* get_Expander();
public: __property void set_Expander(
   WebExpander* value
);
C++/CLI
public:
property WebExpander^ Expander {
   WebExpander^ get();
   void set (    WebExpander^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderChangedEventDataArgs Class
WebExpanderChangedEventDataArgs Members


Item Property

[image]
Intersoft WebEssentials Documentation
Item Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderChangedEventDataArgs Class : Item Property

Glossary Item Box

The WebExpanderItem collapsed or expanded object.

Syntax

Visual Basic (Declaration)
Public Property Item As WebExpanderItem
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderChangedEventDataArgs
Dim value As WebExpanderItem

instance.Item = value

value = instance.Item
C#
public WebExpanderItem Item {get; set;}
Delphi
public read-write property Item: WebExpanderItem;
JScript
public function get,set Item : WebExpanderItem
Managed Extensions for C++
public: __property WebExpanderItem* get_Item();
public: __property void set_Item(
   WebExpanderItem* value
);
C++/CLI
public:
property WebExpanderItem^ Item {
   WebExpanderItem^ get();
   void set (    WebExpanderItem^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderChangedEventDataArgs Class
WebExpanderChangedEventDataArgs Members


WebExpanderClickEventDataArgs Class

[image]
Intersoft WebEssentials Documentation
WebExpanderClickEventDataArgs Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderClickEventDataArgs Class

Glossary Item Box

Represents the WebExpander click event argument.

Object Model

WebExpanderClickEventDataArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebExpanderClickEventDataArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClickEventDataArgs
C#
public class WebExpanderClickEventDataArgs : System.EventArgs
Delphi
public class WebExpanderClickEventDataArgs = class(System.EventArgs)
JScript
public class WebExpanderClickEventDataArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebExpanderClickEventDataArgs : public System.EventArgs
C++/CLI
public ref class WebExpanderClickEventDataArgs : public System.EventArgs

Remarks

This class contains property for the WebExpander click event argument.

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebEssentials.WebExpanderClickEventDataArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClickEventDataArgs Members
ISNet.WebUI.WebEssentials Namespace


WebExpanderClickEventDataArgs Class Members

[image]
Intersoft WebEssentials Documentation
WebExpanderClickEventDataArgs Class Members
See Also Properties Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderClickEventDataArgs Class

Glossary Item Box

The following tables list the members exposed by WebExpanderClickEventDataArgs.

Public Constructors

 | Name | Description
Public Constructor | WebExpanderClickEventDataArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Expander | The WebExpander object.
Public Property | Item | The WebExpanderItem clicked object.
Public Property | ReturnValue | The return value of the click event handler.
Top

See Also

Reference

WebExpanderClickEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderClickEventDataArgs Class Properties

[image]
Intersoft WebEssentials Documentation
WebExpanderClickEventDataArgs Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderClickEventDataArgs Class

Glossary Item Box

For a list of all members of this type, see WebExpanderClickEventDataArgs members.

Public Properties

 | Name | Description
Public Property | Expander | The WebExpander object.
Public Property | Item | The WebExpanderItem clicked object.
Public Property | ReturnValue | The return value of the click event handler.
Top

See Also

Reference

WebExpanderClickEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderClickEventDataArgs Constructor

[image]
Intersoft WebEssentials Documentation
WebExpanderClickEventDataArgs Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClickEventDataArgs Class : WebExpanderClickEventDataArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExpanderClickEventDataArgs()
C#
public WebExpanderClickEventDataArgs()
Delphi
public WebExpanderClickEventDataArgs();
JScript
public function WebExpanderClickEventDataArgs();
Managed Extensions for C++
public: WebExpanderClickEventDataArgs();
C++/CLI
public:
WebExpanderClickEventDataArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClickEventDataArgs Class
WebExpanderClickEventDataArgs Members


Expander Property

[image]
Intersoft WebEssentials Documentation
Expander Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClickEventDataArgs Class : Expander Property

Glossary Item Box

The WebExpander object.

Syntax

Visual Basic (Declaration)
Public Property Expander As WebExpander
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClickEventDataArgs
Dim value As WebExpander

instance.Expander = value

value = instance.Expander
C#
public WebExpander Expander {get; set;}
Delphi
public read-write property Expander: WebExpander;
JScript
public function get,set Expander : WebExpander
Managed Extensions for C++
public: __property WebExpander* get_Expander();
public: __property void set_Expander(
   WebExpander* value
);
C++/CLI
public:
property WebExpander^ Expander {
   WebExpander^ get();
   void set (    WebExpander^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClickEventDataArgs Class
WebExpanderClickEventDataArgs Members


Item Property

[image]
Intersoft WebEssentials Documentation
Item Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClickEventDataArgs Class : Item Property

Glossary Item Box

The WebExpanderItem clicked object.

Syntax

Visual Basic (Declaration)
Public Property Item As WebExpanderItem
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClickEventDataArgs
Dim value As WebExpanderItem

instance.Item = value

value = instance.Item
C#
public WebExpanderItem Item {get; set;}
Delphi
public read-write property Item: WebExpanderItem;
JScript
public function get,set Item : WebExpanderItem
Managed Extensions for C++
public: __property WebExpanderItem* get_Item();
public: __property void set_Item(
   WebExpanderItem* value
);
C++/CLI
public:
property WebExpanderItem^ Item {
   WebExpanderItem^ get();
   void set (    WebExpanderItem^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClickEventDataArgs Class
WebExpanderClickEventDataArgs Members


ReturnValue Property

[image]
Intersoft WebEssentials Documentation
ReturnValue Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClickEventDataArgs Class : ReturnValue Property

Glossary Item Box

The return value of the click event handler.

Syntax

Visual Basic (Declaration)
Public Property ReturnValue As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClickEventDataArgs
Dim value As System.Boolean

instance.ReturnValue = value

value = instance.ReturnValue
C#
public System.bool ReturnValue {get; set;}
Delphi
public read-write property ReturnValue: System.Boolean;
JScript
public function get,set ReturnValue : System.boolean
Managed Extensions for C++
public: __property System.bool get_ReturnValue();
public: __property void set_ReturnValue(
   System.bool value
);
C++/CLI
public:
property System.bool ReturnValue {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClickEventDataArgs Class
WebExpanderClickEventDataArgs Members


WebExpanderClientSideEvents Class

[image]
Intersoft WebEssentials Documentation
WebExpanderClientSideEvents Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderClientSideEvents Class

Glossary Item Box

Represents the client side (Javascript) WebExpander html element events.

Object Model

WebExpanderClientSideEvents Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Represents the client side (Javascript) WebExpander html element events")>
<System.SerializableAttribute()>
Public Class WebExpanderClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
C#
[System.ComponentModel.DescriptionAttribute("Represents the client side (Javascript) WebExpander html element events")]
[System.SerializableAttribute()]
public class WebExpanderClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebExpanderClientSideEvents = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.ComponentModel.DescriptionAttribute("Represents the client side (Javascript) WebExpander html element events")
System.SerializableAttribute()
public class WebExpanderClientSideEvents extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Represents the client side (Javascript) WebExpander html element events")]
[System.SerializableAttribute()]
public __gc class WebExpanderClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.ComponentModel.DescriptionAttribute("Represents the client side (Javascript) WebExpander html element events")]
[System.SerializableAttribute()]
public ref class WebExpanderClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

This class wraps some common event handlers of WebExpander element.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebExpanderClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Members
ISNet.WebUI.WebEssentials Namespace


WebExpanderClientSideEvents Class Members

[image]
Intersoft WebEssentials Documentation
WebExpanderClientSideEvents Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebExpanderClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebExpanderClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnClick | Specifies the client side (JavaScript) function name that will be invoked when header expander item is clicked
Public Property | OnCollapsed | Specifies the client side (JavaScript) function name that will be invoked when expander item is collapsed
Public Property | OnExpanded | Specifies the client side (JavaScript) function name that will be invoked when expander item is expanded
Public Property | OnResponse | Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response.
Public Property | OnResponseError | Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebExpanderClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderClientSideEvents Class Methods

[image]
Intersoft WebEssentials Documentation
WebExpanderClientSideEvents Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebExpanderClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebExpanderClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderClientSideEvents Class Properties

[image]
Intersoft WebEssentials Documentation
WebExpanderClientSideEvents Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebExpanderClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnClick | Specifies the client side (JavaScript) function name that will be invoked when header expander item is clicked
Public Property | OnCollapsed | Specifies the client side (JavaScript) function name that will be invoked when expander item is collapsed
Public Property | OnExpanded | Specifies the client side (JavaScript) function name that will be invoked when expander item is expanded
Public Property | OnResponse | Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response.
Public Property | OnResponseError | Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response.
Top

See Also

Reference

WebExpanderClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebExpanderClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : WebExpanderClientSideEvents Constructor

Glossary Item Box

Overload List

Overload | Description
WebExpanderClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


WebExpanderClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebExpanderClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : WebExpanderClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExpanderClientSideEvents()
C#
public WebExpanderClientSideEvents()
Delphi
public WebExpanderClientSideEvents();
JScript
public function WebExpanderClientSideEvents();
Managed Extensions for C++
public: WebExpanderClientSideEvents();
C++/CLI
public:
WebExpanderClientSideEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


OnClick Property

[image]
Intersoft WebEssentials Documentation
OnClick Property
See Also Example Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : OnClick Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when header expander item is clicked

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId,itemName")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when header expander item value is clicked. Parameters (controlId,itemName)")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnClick As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
Dim value As System.String

instance.OnClick = value

value = instance.OnClick
C#
[ISNet.EventParameterAttribute("controlId,itemName")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when header expander item value is clicked. Parameters (controlId,itemName)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnClick {get; set;}
Delphi
public read-write property OnClick: System.String;
JScript
ISNet.EventParameterAttribute("controlId,itemName")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when header expander item value is clicked. Parameters (controlId,itemName)")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnClick : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId,itemName")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when header expander item value is clicked. Parameters (controlId,itemName)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnClick();
public: __property void set_OnClick(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId,itemName")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when header expander item value is clicked. Parameters (controlId,itemName)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnClick {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string
  • itemName - string

Example

C# Copy Code
function onClicked(controlId,itemName)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


OnCollapsed Property

[image]
Intersoft WebEssentials Documentation
OnCollapsed Property
See Also Example Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : OnCollapsed Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when expander item is collapsed

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId,itemName")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when expander item is collapsed. Parameters (controlId,itemName)")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnCollapsed As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
Dim value As System.String

instance.OnCollapsed = value

value = instance.OnCollapsed
C#
[ISNet.EventParameterAttribute("controlId,itemName")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when expander item is collapsed. Parameters (controlId,itemName)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnCollapsed {get; set;}
Delphi
public read-write property OnCollapsed: System.String;
JScript
ISNet.EventParameterAttribute("controlId,itemName")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when expander item is collapsed. Parameters (controlId,itemName)")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnCollapsed : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId,itemName")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when expander item is collapsed. Parameters (controlId,itemName)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnCollapsed();
public: __property void set_OnCollapsed(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId,itemName")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when expander item is collapsed. Parameters (controlId,itemName)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnCollapsed {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string
  • itemName - string

Example

C# Copy Code
function onCollapsed(controlId,itemName)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


OnExpanded Property

[image]
Intersoft WebEssentials Documentation
OnExpanded Property
See Also Example Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : OnExpanded Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when expander item is expanded

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId,itemName")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when expander item is expanded. Parameters (controlId,itemName)")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnExpanded As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
Dim value As System.String

instance.OnExpanded = value

value = instance.OnExpanded
C#
[ISNet.EventParameterAttribute("controlId,itemName")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when expander item is expanded. Parameters (controlId,itemName)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnExpanded {get; set;}
Delphi
public read-write property OnExpanded: System.String;
JScript
ISNet.EventParameterAttribute("controlId,itemName")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when expander item is expanded. Parameters (controlId,itemName)")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnExpanded : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId,itemName")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when expander item is expanded. Parameters (controlId,itemName)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnExpanded();
public: __property void set_OnExpanded(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId,itemName")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when expander item is expanded. Parameters (controlId,itemName)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnExpanded {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string
  • itemName - string

Example

C# Copy Code
function onExpanded(controlId,itemName)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


OnResponse Property

[image]
Intersoft WebEssentials Documentation
OnResponse Property
See Also Example Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : OnResponse Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response.

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId, action, xmlResponse")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response. Parameters (controlId, value, xmlResponse)")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnResponse As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
Dim value As System.String

instance.OnResponse = value

value = instance.OnResponse
C#
[ISNet.EventParameterAttribute("controlId, action, xmlResponse")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response. Parameters (controlId, value, xmlResponse)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnResponse {get; set;}
Delphi
public read-write property OnResponse: System.String;
JScript
ISNet.EventParameterAttribute("controlId, action, xmlResponse")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response. Parameters (controlId, value, xmlResponse)")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnResponse : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId, action, xmlResponse")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response. Parameters (controlId, value, xmlResponse)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnResponse();
public: __property void set_OnResponse(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId, action, xmlResponse")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response. Parameters (controlId, value, xmlResponse)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnResponse {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string
  • value - string
  • xmlResponse - string

Example

C# Copy Code
function onResponse(controlId, value, xmlResponse)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


OnResponseError Property

[image]
Intersoft WebEssentials Documentation
OnResponseError Property
See Also Example Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : OnResponseError Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response.

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId, value")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response. Parameters (controlId, value)")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnResponseError As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
Dim value As System.String

instance.OnResponseError = value

value = instance.OnResponseError
C#
[ISNet.EventParameterAttribute("controlId, value")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response. Parameters (controlId, value)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnResponseError {get; set;}
Delphi
public read-write property OnResponseError: System.String;
JScript
ISNet.EventParameterAttribute("controlId, value")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response. Parameters (controlId, value)")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnResponseError : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId, value")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response. Parameters (controlId, value)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnResponseError();
public: __property void set_OnResponseError(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId, value")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response. Parameters (controlId, value)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnResponseError {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string
  • value - string

Example

C# Copy Code
function onResponseError(controlId, value)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderClientSideEvents
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderClientSideEvents Class
WebExpanderClientSideEvents Members


WebExpanderContentType Enumeration

[image]
Intersoft WebEssentials Documentation
WebExpanderContentType Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderContentType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebExpanderContentType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderContentType
C#
public enum WebExpanderContentType : System.Enum
Delphi
public enum WebExpanderContentType = class(System.Enum)
JScript
public enum WebExpanderContentType extends System.Enum
Managed Extensions for C++
__value public enum WebExpanderContentType : public System.Enum
C++/CLI
public enum class WebExpanderContentType : public System.Enum

Members

Member | Description
Default |
IFrame |
Inline |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebExpanderContentType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebExpanderFlow Enumeration

[image]
Intersoft WebEssentials Documentation
WebExpanderFlow Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderFlow Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebExpanderFlow
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderFlow
C#
public enum WebExpanderFlow : System.Enum
Delphi
public enum WebExpanderFlow = class(System.Enum)
JScript
public enum WebExpanderFlow extends System.Enum
Managed Extensions for C++
__value public enum WebExpanderFlow : public System.Enum
C++/CLI
public enum class WebExpanderFlow : public System.Enum

Members

Member | Description
Down |
Left |
Right |
Up |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebExpanderFlow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebExpanderHeaderContentMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebExpanderHeaderContentMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderHeaderContentMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebExpanderHeaderContentMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderHeaderContentMode
C#
public enum WebExpanderHeaderContentMode : System.Enum
Delphi
public enum WebExpanderHeaderContentMode = class(System.Enum)
JScript
public enum WebExpanderHeaderContentMode extends System.Enum
Managed Extensions for C++
__value public enum WebExpanderHeaderContentMode : public System.Enum
C++/CLI
public enum class WebExpanderHeaderContentMode : public System.Enum

Members

Member | Description
Default |
Inline |
Text |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebExpanderHeaderContentMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebExpanderIndicatorPosition Enumeration

[image]
Intersoft WebEssentials Documentation
WebExpanderIndicatorPosition Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderIndicatorPosition Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebExpanderIndicatorPosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderIndicatorPosition
C#
public enum WebExpanderIndicatorPosition : System.Enum
Delphi
public enum WebExpanderIndicatorPosition = class(System.Enum)
JScript
public enum WebExpanderIndicatorPosition extends System.Enum
Managed Extensions for C++
__value public enum WebExpanderIndicatorPosition : public System.Enum
C++/CLI
public enum class WebExpanderIndicatorPosition : public System.Enum

Members

Member | Description
Default |
Hidden |
Left |
Right |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebExpanderIndicatorPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebExpanderItem Class

[image]
Intersoft WebEssentials Documentation
WebExpanderItem Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderItem Class

Glossary Item Box

Object Model

WebExpanderItem Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebExpanderItem
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebExpanderItem : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebExpanderItem = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebExpanderItem extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebExpanderItem : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebExpanderItem : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebEssentials.WebExpanderItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Members
ISNet.WebUI.WebEssentials Namespace


WebExpanderItem Class Members

[image]
Intersoft WebEssentials Documentation
WebExpanderItem Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderItem Class

Glossary Item Box

The following tables list the members exposed by WebExpanderItem.

Public Constructors

 | Name | Description
Public Constructor | WebExpanderItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowCollapse | Gets or sets the collapse permission of a WebExpander item.
Public Property | ContentType | Gets or sets the content type of the expander item.
Public Property | ContentURL | Gets or sets the content URL of the iFrame content mode expander item.
Public Property | Header | Gets or sets the header text of the expander item.
Public Property | HeaderContentMode | Gets or sets the header type of the expander item.
Public Property | IndicatorPosition | Gets or sets the indicator position of the expander item.
Public Property | ItemHeaderStyle | Gets or sets the the applied style for the header item in the expander.
Public Property | Name | Overridden.
Public Property | Parent | Gets the WebExpanderItem object that own this Item.
Public Property | State | Gets or sets the initial state of the expander item.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebExpanderItem Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderItem Class Methods

[image]
Intersoft WebEssentials Documentation
WebExpanderItem Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderItem Class

Glossary Item Box

For a list of all members of this type, see WebExpanderItem members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebExpanderItem Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderItem Class Properties

[image]
Intersoft WebEssentials Documentation
WebExpanderItem Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderItem Class

Glossary Item Box

For a list of all members of this type, see WebExpanderItem members.

Public Properties

 | Name | Description
Public Property | AllowCollapse | Gets or sets the collapse permission of a WebExpander item.
Public Property | ContentType | Gets or sets the content type of the expander item.
Public Property | ContentURL | Gets or sets the content URL of the iFrame content mode expander item.
Public Property | Header | Gets or sets the header text of the expander item.
Public Property | HeaderContentMode | Gets or sets the header type of the expander item.
Public Property | IndicatorPosition | Gets or sets the indicator position of the expander item.
Public Property | ItemHeaderStyle | Gets or sets the the applied style for the header item in the expander.
Public Property | Name | Overridden.
Public Property | Parent | Gets the WebExpanderItem object that own this Item.
Public Property | State | Gets or sets the initial state of the expander item.
Top

See Also

Reference

WebExpanderItem Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderItemCollection Class

[image]
Intersoft WebEssentials Documentation
WebExpanderItemCollection Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderItemCollection Class

Glossary Item Box

Object Model

WebExpanderItemCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebExpanderItemCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebExpanderItem)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebExpanderItemCollection : ISNet.WebUI.ISGenericCollectionBase<WebExpanderItem>
Delphi
public class WebExpanderItemCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebExpanderItemCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebExpanderItemCollection : public ISNet.WebUI.ISGenericCollectionBase<WebExpanderItem>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebExpanderItemCollection : public ISNet.WebUI.ISGenericCollectionBase<WebExpanderItem>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebEssentials.WebExpanderItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Members
ISNet.WebUI.WebEssentials Namespace


WebExpanderItemCollection Class Members

[image]
Intersoft WebEssentials Documentation
WebExpanderItemCollection Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderItemCollection Class

Glossary Item Box

The following tables list the members exposed by WebExpanderItemCollection.

Public Constructors

 | Name | Description
Public Constructor | WebExpanderItemCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebExpanderItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebExpanderItem>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebExpanderItem>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebExpanderItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderItemCollection Class Methods

[image]
Intersoft WebEssentials Documentation
WebExpanderItemCollection Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebExpanderItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebExpanderItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebExpanderItem>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebExpanderItem>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebExpanderItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderItemCollection Class Properties

[image]
Intersoft WebEssentials Documentation
WebExpanderItemCollection Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebExpanderItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebExpanderItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderItemCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebExpanderItemCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : WebExpanderItemCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebExpanderItemCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


WebExpanderItemCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebExpanderItemCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : WebExpanderItemCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExpanderItemCollection()
C#
public WebExpanderItemCollection()
Delphi
public WebExpanderItemCollection();
JScript
public function WebExpanderItemCollection();
Managed Extensions for C++
public: WebExpanderItemCollection();
C++/CLI
public:
WebExpanderItemCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


Add Method

[image]
Intersoft WebEssentials Documentation
Add Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


Clear Method

[image]
Intersoft WebEssentials Documentation
Clear Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


Contains Method

[image]
Intersoft WebEssentials Documentation
Contains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


CopyTo Method

[image]
Intersoft WebEssentials Documentation
CopyTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


Count Property

[image]
Intersoft WebEssentials Documentation
Count Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


CreateNewItem Method

[image]
Intersoft WebEssentials Documentation
CreateNewItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebExpanderItem
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim value As WebExpanderItem

value = instance.CreateNewItem()
C#
public WebExpanderItem CreateNewItem()
Delphi
public function CreateNewItem(): WebExpanderItem;
JScript
public function CreateNewItem() : WebExpanderItem;
Managed Extensions for C++
public: WebExpanderItem* CreateNewItem();
C++/CLI
public:
WebExpanderItem^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


GetEnumerator Method

[image]
Intersoft WebEssentials Documentation
GetEnumerator Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


GetNamedItem Method

[image]
Intersoft WebEssentials Documentation
GetNamedItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebExpanderItem
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim name As System.String
Dim value As WebExpanderItem

value = instance.GetNamedItem(name)
C#
public WebExpanderItem GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebExpanderItem;
JScript
public function GetNamedItem(
   name : System.String
) : WebExpanderItem;
Managed Extensions for C++
public: WebExpanderItem* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebExpanderItem^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


IndexOf Method

[image]
Intersoft WebEssentials Documentation
IndexOf Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


Insert Method

[image]
Intersoft WebEssentials Documentation
Insert Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


Item Property

[image]
Intersoft WebEssentials Documentation
Item Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


Parent Property

[image]
Intersoft WebEssentials Documentation
Parent Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


Remove Method

[image]
Intersoft WebEssentials Documentation
Remove Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


RemoveAt Method

[image]
Intersoft WebEssentials Documentation
RemoveAt Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


SerializerConstructor Method

[image]
Intersoft WebEssentials Documentation
SerializerConstructor Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


SetParent Method

[image]
Intersoft WebEssentials Documentation
SetParent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemCollection Class
WebExpanderItemCollection Members


WebExpanderItemSettings Class

[image]
Intersoft WebEssentials Documentation
WebExpanderItemSettings Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderItemSettings Class

Glossary Item Box

Object Model

WebExpanderItemSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebExpanderItemSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebExpanderItemSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebExpanderItemSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebExpanderItemSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebExpanderItemSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebExpanderItemSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebExpanderItemSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Members
ISNet.WebUI.WebEssentials Namespace


WebExpanderItemSettings Class Members

[image]
Intersoft WebEssentials Documentation
WebExpanderItemSettings Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderItemSettings Class

Glossary Item Box

The following tables list the members exposed by WebExpanderItemSettings.

Public Constructors

 | Name | Description
Public Constructor | WebExpanderItemSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | ContentType | Specifies the default content type of WebAccordion's item.
Public Property | HeaderContentMode | Specifies the default header type of WebAccordion's item.
Public Property | IndicatorPosition | Specifies the default indicator position of WebAccordion's item.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebExpanderItemSettings Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderItemSettings Class Methods

[image]
Intersoft WebEssentials Documentation
WebExpanderItemSettings Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderItemSettings Class

Glossary Item Box

For a list of all members of this type, see WebExpanderItemSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebExpanderItemSettings Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderItemSettings Class Properties

[image]
Intersoft WebEssentials Documentation
WebExpanderItemSettings Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderItemSettings Class

Glossary Item Box

For a list of all members of this type, see WebExpanderItemSettings members.

Public Properties

 | Name | Description
Public Property | ContentType | Specifies the default content type of WebAccordion's item.
Public Property | HeaderContentMode | Specifies the default header type of WebAccordion's item.
Public Property | IndicatorPosition | Specifies the default indicator position of WebAccordion's item.
Top

See Also

Reference

WebExpanderItemSettings Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderItemSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebExpanderItemSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class : WebExpanderItemSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebExpanderItemSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members


WebExpanderItemSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebExpanderItemSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class : WebExpanderItemSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExpanderItemSettings()
C#
public WebExpanderItemSettings()
Delphi
public WebExpanderItemSettings();
JScript
public function WebExpanderItemSettings();
Managed Extensions for C++
public: WebExpanderItemSettings();
C++/CLI
public:
WebExpanderItemSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members


ContentType Property

[image]
Intersoft WebEssentials Documentation
ContentType Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class : ContentType Property

Glossary Item Box

Specifies the default content type of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the default content type of WebExpander's item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ContentType As WebExpanderContentType
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemSettings
Dim value As WebExpanderContentType

instance.ContentType = value

value = instance.ContentType
C#
[System.ComponentModel.DescriptionAttribute("Specifies the default content type of WebExpander's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public WebExpanderContentType ContentType {get; set;}
Delphi
public read-write property ContentType: WebExpanderContentType;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the default content type of WebExpander's item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ContentType : WebExpanderContentType
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the default content type of WebExpander's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebExpanderContentType get_ContentType();
public: __property void set_ContentType(
   WebExpanderContentType value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the default content type of WebExpander's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebExpanderContentType ContentType {
   WebExpanderContentType get();
   void set (    WebExpanderContentType value);
}

Property Value

The default value is Template.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members


HeaderContentMode Property

[image]
Intersoft WebEssentials Documentation
HeaderContentMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class : HeaderContentMode Property

Glossary Item Box

Specifies the default header type of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the default header type of WebExpander's item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HeaderContentMode As WebExpanderHeaderContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemSettings
Dim value As WebExpanderHeaderContentMode

instance.HeaderContentMode = value

value = instance.HeaderContentMode
C#
[System.ComponentModel.DescriptionAttribute("Specifies the default header type of WebExpander's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public WebExpanderHeaderContentMode HeaderContentMode {get; set;}
Delphi
public read-write property HeaderContentMode: WebExpanderHeaderContentMode;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the default header type of WebExpander's item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set HeaderContentMode : WebExpanderHeaderContentMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the default header type of WebExpander's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebExpanderHeaderContentMode get_HeaderContentMode();
public: __property void set_HeaderContentMode(
   WebExpanderHeaderContentMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the default header type of WebExpander's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebExpanderHeaderContentMode HeaderContentMode {
   WebExpanderHeaderContentMode get();
   void set (    WebExpanderHeaderContentMode value);
}

Property Value

The default value is Text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members


IndicatorPosition Property

[image]
Intersoft WebEssentials Documentation
IndicatorPosition Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class : IndicatorPosition Property

Glossary Item Box

Specifies the default indicator position of WebAccordion's item.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the default indicator position of WebExpander's item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property IndicatorPosition As WebExpanderIndicatorPosition
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemSettings
Dim value As WebExpanderIndicatorPosition

instance.IndicatorPosition = value

value = instance.IndicatorPosition
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the default indicator position of WebExpander's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebExpanderIndicatorPosition IndicatorPosition {get; set;}
Delphi
public read-write property IndicatorPosition: WebExpanderIndicatorPosition;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the default indicator position of WebExpander's item.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set IndicatorPosition : WebExpanderIndicatorPosition
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the default indicator position of WebExpander's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebExpanderIndicatorPosition get_IndicatorPosition();
public: __property void set_IndicatorPosition(
   WebExpanderIndicatorPosition value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the default indicator position of WebExpander's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebExpanderIndicatorPosition IndicatorPosition {
   WebExpanderIndicatorPosition get();
   void set (    WebExpanderIndicatorPosition value);
}

Property Value

The default value is Right.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItemSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItemSettings Class
WebExpanderItemSettings Members


WebExpanderItemState Enumeration

[image]
Intersoft WebEssentials Documentation
WebExpanderItemState Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderItemState Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebExpanderItemState
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemState
C#
public enum WebExpanderItemState : System.Enum
Delphi
public enum WebExpanderItemState = class(System.Enum)
JScript
public enum WebExpanderItemState extends System.Enum
Managed Extensions for C++
__value public enum WebExpanderItemState : public System.Enum
C++/CLI
public enum class WebExpanderItemState : public System.Enum

Members

Member | Description
Collapsed |
Expanded |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebExpanderItemState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebExpanderItemType Enumeration

[image]
Intersoft WebEssentials Documentation
WebExpanderItemType Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderItemType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebExpanderItemType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItemType
C#
public enum WebExpanderItemType : System.Enum
Delphi
public enum WebExpanderItemType = class(System.Enum)
JScript
public enum WebExpanderItemType extends System.Enum
Managed Extensions for C++
__value public enum WebExpanderItemType : public System.Enum
C++/CLI
public enum class WebExpanderItemType : public System.Enum

Members

Member | Description
Content |
Header |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebExpanderItemType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebExpanderItem Constructor

[image]
Intersoft WebEssentials Documentation
WebExpanderItem Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : WebExpanderItem Constructor

Glossary Item Box

Overload List

Overload | Description
WebExpanderItem Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


WebExpanderItem Constructor

[image]
Intersoft WebEssentials Documentation
WebExpanderItem Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : WebExpanderItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExpanderItem()
C#
public WebExpanderItem()
Delphi
public WebExpanderItem();
JScript
public function WebExpanderItem();
Managed Extensions for C++
public: WebExpanderItem();
C++/CLI
public:
WebExpanderItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


AllowCollapse Property

[image]
Intersoft WebEssentials Documentation
AllowCollapse Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : AllowCollapse Property

Glossary Item Box

Gets or sets the collapse permission of a WebExpander item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the collapse permission of a WebExpander item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AllowCollapse As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim value As System.Boolean

instance.AllowCollapse = value

value = instance.AllowCollapse
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the collapse permission of a WebExpander item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool AllowCollapse {get; set;}
Delphi
public read-write property AllowCollapse: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the collapse permission of a WebExpander item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
public function get,set AllowCollapse : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the collapse permission of a WebExpander item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_AllowCollapse();
public: __property void set_AllowCollapse(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the collapse permission of a WebExpander item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool AllowCollapse {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


ContentType Property

[image]
Intersoft WebEssentials Documentation
ContentType Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : ContentType Property

Glossary Item Box

Gets or sets the content type of the expander item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the content type of the expander item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ContentType As WebExpanderContentType
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim value As WebExpanderContentType

instance.ContentType = value

value = instance.ContentType
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the content type of the expander item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public WebExpanderContentType ContentType {get; set;}
Delphi
public read-write property ContentType: WebExpanderContentType;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the content type of the expander item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ContentType : WebExpanderContentType
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the content type of the expander item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebExpanderContentType get_ContentType();
public: __property void set_ContentType(
   WebExpanderContentType value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the content type of the expander item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebExpanderContentType ContentType {
   WebExpanderContentType get();
   void set (    WebExpanderContentType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


ContentURL Property

[image]
Intersoft WebEssentials Documentation
ContentURL Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : ContentURL Property

Glossary Item Box

Gets or sets the content URL of the iFrame content mode expander item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the content URL of the content mode expander item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ContentURL As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim value As System.String

instance.ContentURL = value

value = instance.ContentURL
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the content URL of the content mode expander item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ContentURL {get; set;}
Delphi
public read-write property ContentURL: System.String;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Gets or sets the content URL of the content mode expander item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ContentURL : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the content URL of the content mode expander item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ContentURL();
public: __property void set_ContentURL(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the content URL of the content mode expander item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ContentURL {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


Header Property

[image]
Intersoft WebEssentials Documentation
Header Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : Header Property

Glossary Item Box

Gets or sets the header text of the expander item.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the header text of the expander item.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Header As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim value As System.String

instance.Header = value

value = instance.Header
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the header text of the expander item.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Header {get; set;}
Delphi
public read-write property Header: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Gets or sets the header text of the expander item.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Header : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the header text of the expander item.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Header();
public: __property void set_Header(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the header text of the expander item.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Header {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


HeaderContentMode Property

[image]
Intersoft WebEssentials Documentation
HeaderContentMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : HeaderContentMode Property

Glossary Item Box

Gets or sets the header type of the expander item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the header type of the expander item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HeaderContentMode As WebExpanderHeaderContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim value As WebExpanderHeaderContentMode

instance.HeaderContentMode = value

value = instance.HeaderContentMode
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the header type of the expander item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public WebExpanderHeaderContentMode HeaderContentMode {get; set;}
Delphi
public read-write property HeaderContentMode: WebExpanderHeaderContentMode;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the header type of the expander item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
public function get,set HeaderContentMode : WebExpanderHeaderContentMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the header type of the expander item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebExpanderHeaderContentMode get_HeaderContentMode();
public: __property void set_HeaderContentMode(
   WebExpanderHeaderContentMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the header type of the expander item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebExpanderHeaderContentMode HeaderContentMode {
   WebExpanderHeaderContentMode get();
   void set (    WebExpanderHeaderContentMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


IndicatorPosition Property

[image]
Intersoft WebEssentials Documentation
IndicatorPosition Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : IndicatorPosition Property

Glossary Item Box

Gets or sets the indicator position of the expander item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the indicator post of the expander item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property IndicatorPosition As WebExpanderIndicatorPosition
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim value As WebExpanderIndicatorPosition

instance.IndicatorPosition = value

value = instance.IndicatorPosition
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the indicator post of the expander item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebExpanderIndicatorPosition IndicatorPosition {get; set;}
Delphi
public read-write property IndicatorPosition: WebExpanderIndicatorPosition;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Gets or sets the indicator post of the expander item.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set IndicatorPosition : WebExpanderIndicatorPosition
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the indicator post of the expander item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebExpanderIndicatorPosition get_IndicatorPosition();
public: __property void set_IndicatorPosition(
   WebExpanderIndicatorPosition value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the indicator post of the expander item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebExpanderIndicatorPosition IndicatorPosition {
   WebExpanderIndicatorPosition get();
   void set (    WebExpanderIndicatorPosition value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


ItemHeaderStyle Property

[image]
Intersoft WebEssentials Documentation
ItemHeaderStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : ItemHeaderStyle Property

Glossary Item Box

Gets or sets the the applied style for the header item in the expander.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the applied style for the header item in the expander.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ItemHeaderStyle As CustomStyle
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim value As CustomStyle

instance.ItemHeaderStyle = value

value = instance.ItemHeaderStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the applied style for the header item in the expander.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public CustomStyle ItemHeaderStyle {get; set;}
Delphi
public read-write property ItemHeaderStyle: CustomStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DescriptionAttribute("Gets or sets the applied style for the header item in the expander.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ItemHeaderStyle : CustomStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the applied style for the header item in the expander.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property CustomStyle* get_ItemHeaderStyle();
public: __property void set_ItemHeaderStyle(
   CustomStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the applied style for the header item in the expander.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property CustomStyle^ ItemHeaderStyle {
   CustomStyle^ get();
   void set (    CustomStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


Name Property

[image]
Intersoft WebEssentials Documentation
Name Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public override function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


Parent Property

[image]
Intersoft WebEssentials Documentation
Parent Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : Parent Property

Glossary Item Box

Gets the WebExpanderItem object that own this Item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Gets the WebExpanderItem object that own this Item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Parent As WebExpander
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim value As WebExpander

instance.Parent = value

value = instance.Parent
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets the WebExpanderItem object that own this Item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public WebExpander Parent {get; set;}
Delphi
public read-write property Parent: WebExpander;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Gets the WebExpanderItem object that own this Item.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set Parent : WebExpander
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets the WebExpanderItem object that own this Item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property WebExpander* get_Parent();
public: __property void set_Parent(
   WebExpander* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets the WebExpanderItem object that own this Item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property WebExpander^ Parent {
   WebExpander^ get();
   void set (    WebExpander^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


State Property

[image]
Intersoft WebEssentials Documentation
State Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : State Property

Glossary Item Box

Gets or sets the initial state of the expander item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the initial state of the expander item.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property State As WebExpanderItemState
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim value As WebExpanderItemState

instance.State = value

value = instance.State
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the initial state of the expander item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public WebExpanderItemState State {get; set;}
Delphi
public read-write property State: WebExpanderItemState;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the initial state of the expander item.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set State : WebExpanderItemState
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the initial state of the expander item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property WebExpanderItemState get_State();
public: __property void set_State(
   WebExpanderItemState value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the initial state of the expander item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property WebExpanderItemState State {
   WebExpanderItemState get();
   void set (    WebExpanderItemState value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderItem Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderItem
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderItem Class
WebExpanderItem Members


WebExpanderMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebExpanderMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebExpanderMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderMode
C#
public enum WebExpanderMode : System.Enum
Delphi
public enum WebExpanderMode = class(System.Enum)
JScript
public enum WebExpanderMode extends System.Enum
Managed Extensions for C++
__value public enum WebExpanderMode : public System.Enum
C++/CLI
public enum class WebExpanderMode : public System.Enum

Members

Member | Description
Fixed |
Flow |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebExpanderMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebExpanderNewItemForm Class

[image]
Intersoft WebEssentials Documentation
WebExpanderNewItemForm Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderNewItemForm Class

Glossary Item Box

Object Model

WebExpanderNewItemForm Class

Syntax

Visual Basic (Declaration)
Public Class WebExpanderNewItemForm
   Inherits System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
C#
public class WebExpanderNewItemForm : System.Windows.Forms.Form
Delphi
public class WebExpanderNewItemForm = class(System.Windows.Forms.Form)
JScript
public class WebExpanderNewItemForm extends System.Windows.Forms.Form
Managed Extensions for C++
public __gc class WebExpanderNewItemForm : public System.Windows.Forms.Form
C++/CLI
public ref class WebExpanderNewItemForm : public System.Windows.Forms.Form

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ISNet.WebUI.WebEssentials.WebExpanderNewItemForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Members
ISNet.WebUI.WebEssentials Namespace


WebExpanderNewItemForm Class Events

[image]
Intersoft WebEssentials Documentation
WebExpanderNewItemForm Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderNewItemForm Class

Glossary Item Box

For a list of all members of this type, see WebExpanderNewItemForm members.

Public Events

 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

WebExpanderNewItemForm Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderNewItemForm Class Members

[image]
Intersoft WebEssentials Documentation
WebExpanderNewItemForm Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderNewItemForm Class

Glossary Item Box

The following tables list the members exposed by WebExpanderNewItemForm.

Public Constructors

 | Name | Description
Public Constructor | WebExpanderNewItemForm Constructor |
Top

Public Properties

 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | Header |
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | Type |
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top

Public Methods

 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top

Public Events

 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

WebExpanderNewItemForm Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderNewItemForm Class Methods

[image]
Intersoft WebEssentials Documentation
WebExpanderNewItemForm Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderNewItemForm Class

Glossary Item Box

For a list of all members of this type, see WebExpanderNewItemForm members.

Public Methods

 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top

See Also

Reference

WebExpanderNewItemForm Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderNewItemForm Class Properties

[image]
Intersoft WebEssentials Documentation
WebExpanderNewItemForm Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderNewItemForm Class

Glossary Item Box

For a list of all members of this type, see WebExpanderNewItemForm members.

Public Properties

 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | Header |
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | Type |
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top

See Also

Reference

WebExpanderNewItemForm Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderNewItemForm Constructor

[image]
Intersoft WebEssentials Documentation
WebExpanderNewItemForm Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : WebExpanderNewItemForm Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExpanderNewItemForm()
C#
public WebExpanderNewItemForm()
Delphi
public WebExpanderNewItemForm();
JScript
public function WebExpanderNewItemForm();
Managed Extensions for C++
public: WebExpanderNewItemForm();
C++/CLI
public:
WebExpanderNewItemForm();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


AcceptButton Property

[image]
Intersoft WebEssentials Documentation
AcceptButton Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : AcceptButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")>
Public Property AcceptButton As System.Windows.Forms.IButtonControl
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.IButtonControl

instance.AcceptButton = value

value = instance.AcceptButton
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")]
public System.Windows.Forms.IButtonControl AcceptButton {get; set;}
Delphi
public read-write property AcceptButton: System.Windows.Forms.IButtonControl;
JScript
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")
public function get,set AcceptButton : System.Windows.Forms.IButtonControl
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")]
public: __property System.Windows.Forms.IButtonControl* get_AcceptButton();
public: __property void set_AcceptButton(
   System.Windows.Forms.IButtonControl* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")]
public:
property System.Windows.Forms.IButtonControl^ AcceptButton {
   System.Windows.Forms.IButtonControl^ get();
   void set (    System.Windows.Forms.IButtonControl^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


AccessibleDescription Property

[image]
Intersoft WebEssentials Documentation
AccessibleDescription Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : AccessibleDescription Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Accessibility")>
<SRDescriptionAttribute("The description that will be reported to accessibility clients.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AccessibleDescription As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.String

instance.AccessibleDescription = value

value = instance.AccessibleDescription
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The description that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string AccessibleDescription {get; set;}
Delphi
public read-write property AccessibleDescription: System.String;
JScript
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Accessibility")
SRDescriptionAttribute("The description that will be reported to accessibility clients.")
System.ComponentModel.DefaultValueAttribute()
public function get,set AccessibleDescription : System.String
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The description that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_AccessibleDescription();
public: __property void set_AccessibleDescription(
   System.string* value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The description that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ AccessibleDescription {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


AccessibleName Property

[image]
Intersoft WebEssentials Documentation
AccessibleName Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : AccessibleName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Accessibility")>
<SRDescriptionAttribute("The name that will be reported to accessibility clients.")>
Public Property AccessibleName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.String

instance.AccessibleName = value

value = instance.AccessibleName
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The name that will be reported to accessibility clients.")]
public System.string AccessibleName {get; set;}
Delphi
public read-write property AccessibleName: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Accessibility")
SRDescriptionAttribute("The name that will be reported to accessibility clients.")
public function get,set AccessibleName : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The name that will be reported to accessibility clients.")]
public: __property System.string* get_AccessibleName();
public: __property void set_AccessibleName(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The name that will be reported to accessibility clients.")]
public:
property System.String^ AccessibleName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


AccessibleRole Property

[image]
Intersoft WebEssentials Documentation
AccessibleRole Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : AccessibleRole Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The role that will be reported to accessibility clients.")>
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Accessibility")>
Public Property AccessibleRole As System.Windows.Forms.AccessibleRole
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.AccessibleRole

instance.AccessibleRole = value

value = instance.AccessibleRole
C#
[SRDescriptionAttribute("The role that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Accessibility")]
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}
Delphi
public read-write property AccessibleRole: System.Windows.Forms.AccessibleRole;
JScript
SRDescriptionAttribute("The role that will be reported to accessibility clients.")
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Accessibility")
public function get,set AccessibleRole : System.Windows.Forms.AccessibleRole
Managed Extensions for C++
[SRDescriptionAttribute("The role that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Accessibility")]
public: __property System.Windows.Forms.AccessibleRole get_AccessibleRole();
public: __property void set_AccessibleRole(
   System.Windows.Forms.AccessibleRole value
);
C++/CLI
[SRDescriptionAttribute("The role that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Accessibility")]
public:
property System.Windows.Forms.AccessibleRole AccessibleRole {
   System.Windows.Forms.AccessibleRole get();
   void set (    System.Windows.Forms.AccessibleRole value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Activate Method

[image]
Intersoft WebEssentials Documentation
Activate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Activate Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Activate()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.Activate()
C#
public void Activate()
Delphi
public procedure Activate();
JScript
public function Activate();
Managed Extensions for C++
public: void Activate();
C++/CLI
public:
void Activate();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Activated Event

[image]
Intersoft WebEssentials Documentation
Activated Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Activated Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Occurs whenever the form is activated.")>
Public Event Activated As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Activated, handler
C#
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is activated.")]
public event System.EventHandler Activated
Delphi
public event Activated: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is activated.")]
public: __event System.EventHandler* Activated
C++/CLI
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is activated.")]
public:
event System.EventHandler^ Activated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


AddOwnedForm Method

[image]
Intersoft WebEssentials Documentation
AddOwnedForm Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : AddOwnedForm Method

ownedForm

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub AddOwnedForm( _
   ByVal ownedForm As System.Windows.Forms.Form _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim ownedForm As System.Windows.Forms.Form

instance.AddOwnedForm(ownedForm)
C#
public void AddOwnedForm(
   System.Windows.Forms.Form ownedForm
)
Delphi
public procedure AddOwnedForm(
    ownedForm: System.Windows.Forms.Form
);
JScript
public function AddOwnedForm(
   ownedForm : System.Windows.Forms.Form
);
Managed Extensions for C++
public: void AddOwnedForm(
   System.Windows.Forms.Form* ownedForm
)
C++/CLI
public:
void AddOwnedForm(
   System.Windows.Forms.Form^ ownedForm
)

Parameters

ownedForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


AllowDrop Property

[image]
Intersoft WebEssentials Documentation
AllowDrop Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : AllowDrop Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")>
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Overridable Property AllowDrop As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
[SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public virtual System.bool AllowDrop {get; set;}
Delphi
public read-write property AllowDrop: System.Boolean; virtual;
JScript
SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Behavior")
public function get,set AllowDrop : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property virtual System.bool get_AllowDrop();
public: __property virtual void set_AllowDrop(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
virtual property System.bool AllowDrop {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Anchor Property

[image]
Intersoft WebEssentials Documentation
Anchor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Anchor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
Public Overridable Property Anchor As System.Windows.Forms.AnchorStyles
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.AnchorStyles

instance.Anchor = value

value = instance.Anchor
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}
Delphi
public read-write property Anchor: System.Windows.Forms.AnchorStyles; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")
SRCategoryAttribute("Layout")
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
public function get,set Anchor : System.Windows.Forms.AnchorStyles
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
public: __property virtual System.Windows.Forms.AnchorStyles get_Anchor();
public: __property virtual void set_Anchor(
   System.Windows.Forms.AnchorStyles value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
public:
virtual property System.Windows.Forms.AnchorStyles Anchor {
   System.Windows.Forms.AnchorStyles get();
   void set (    System.Windows.Forms.AnchorStyles value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


AutoScroll Property

[image]
Intersoft WebEssentials Documentation
AutoScroll Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : AutoScroll Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
Public Overridable Property AutoScroll As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.AutoScroll = value

value = instance.AutoScroll
C#
[System.ComponentModel.LocalizableAttribute(true)]
public virtual System.bool AutoScroll {get; set;}
Delphi
public read-write property AutoScroll: System.Boolean; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
public function get,set AutoScroll : System.boolean
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
public: __property virtual System.bool get_AutoScroll();
public: __property virtual void set_AutoScroll(
   System.bool value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
public:
virtual property System.bool AutoScroll {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


AutoScrollMargin Property

[image]
Intersoft WebEssentials Documentation
AutoScrollMargin Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : AutoScrollMargin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("The margin around controls during auto scroll.")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Property AutoScrollMargin As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Size

instance.AutoScrollMargin = value

value = instance.AutoScrollMargin
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The margin around controls during auto scroll.")]
[System.ComponentModel.LocalizableAttribute(true)]
public System.Drawing.Size AutoScrollMargin {get; set;}
Delphi
public read-write property AutoScrollMargin: System.Drawing.Size;
JScript
SRCategoryAttribute("Layout")
SRDescriptionAttribute("The margin around controls during auto scroll.")
System.ComponentModel.LocalizableAttribute()
public function get,set AutoScrollMargin : System.Drawing.Size
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The margin around controls during auto scroll.")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property System.Drawing.Size get_AutoScrollMargin();
public: __property void set_AutoScrollMargin(
   System.Drawing.Size value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The margin around controls during auto scroll.")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
property System.Drawing.Size AutoScrollMargin {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


AutoScrollMinSize Property

[image]
Intersoft WebEssentials Documentation
AutoScrollMinSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : AutoScrollMinSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The minimum logical size for the auto scroll region.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
Public Property AutoScrollMinSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Size

instance.AutoScrollMinSize = value

value = instance.AutoScrollMinSize
C#
[SRDescriptionAttribute("The minimum logical size for the auto scroll region.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public System.Drawing.Size AutoScrollMinSize {get; set;}
Delphi
public read-write property AutoScrollMinSize: System.Drawing.Size;
JScript
SRDescriptionAttribute("The minimum logical size for the auto scroll region.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Layout")
public function get,set AutoScrollMinSize : System.Drawing.Size
Managed Extensions for C++
[SRDescriptionAttribute("The minimum logical size for the auto scroll region.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public: __property System.Drawing.Size get_AutoScrollMinSize();
public: __property void set_AutoScrollMinSize(
   System.Drawing.Size value
);
C++/CLI
[SRDescriptionAttribute("The minimum logical size for the auto scroll region.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public:
property System.Drawing.Size AutoScrollMinSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


AutoSize Property

[image]
Intersoft WebEssentials Documentation
AutoSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : AutoSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.EditorBrowsableAttribute()>
Public Overridable Property AutoSize As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.AutoSize = value

value = instance.AutoSize
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.EditorBrowsableAttribute()]
public virtual System.bool AutoSize {get; set;}
Delphi
public read-write property AutoSize: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.EditorBrowsableAttribute()
public function get,set AutoSize : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.EditorBrowsableAttribute()]
public: __property virtual System.bool get_AutoSize();
public: __property virtual void set_AutoSize(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.EditorBrowsableAttribute()]
public:
virtual property System.bool AutoSize {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


AutoSizeChanged Event

[image]
Intersoft WebEssentials Documentation
AutoSizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : AutoSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<SRDescriptionAttribute("Occurs when the AutoSize property has changed.")>
<System.ComponentModel.EditorBrowsableAttribute()>
<SRCategoryAttribute("Property Changed")>
Public Event AutoSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.AutoSizeChanged, handler
C#
[System.ComponentModel.BrowsableAttribute(true)]
[SRDescriptionAttribute("Occurs when the AutoSize property has changed.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler AutoSizeChanged
Delphi
public event AutoSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[SRDescriptionAttribute("Occurs when the AutoSize property has changed.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* AutoSizeChanged
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[SRDescriptionAttribute("Occurs when the AutoSize property has changed.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ AutoSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


AutoSizeMode Property

[image]
Intersoft WebEssentials Documentation
AutoSizeMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : AutoSizeMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AutoSizeMode As System.Windows.Forms.AutoSizeMode
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.AutoSizeMode

instance.AutoSizeMode = value

value = instance.AutoSizeMode
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.Windows.Forms.AutoSizeMode AutoSizeMode {get; set;}
Delphi
public read-write property AutoSizeMode: System.Windows.Forms.AutoSizeMode;
JScript
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Layout")
SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AutoSizeMode : System.Windows.Forms.AutoSizeMode
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Windows.Forms.AutoSizeMode get_AutoSizeMode();
public: __property void set_AutoSizeMode(
   System.Windows.Forms.AutoSizeMode value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Windows.Forms.AutoSizeMode AutoSizeMode {
   System.Windows.Forms.AutoSizeMode get();
   void set (    System.Windows.Forms.AutoSizeMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


AutoValidate Property

[image]
Intersoft WebEssentials Documentation
AutoValidate Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : AutoValidate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property AutoValidate As System.Windows.Forms.AutoValidate
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.AutoValidate

instance.AutoValidate = value

value = instance.AutoValidate
C#
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.Windows.Forms.AutoValidate AutoValidate {get; set;}
Delphi
public read-write property AutoValidate: System.Windows.Forms.AutoValidate; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute()
System.ComponentModel.BrowsableAttribute()
public function get,set AutoValidate : System.Windows.Forms.AutoValidate
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.Windows.Forms.AutoValidate get_AutoValidate();
public: __property virtual void set_AutoValidate(
   System.Windows.Forms.AutoValidate value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.Windows.Forms.AutoValidate AutoValidate {
   System.Windows.Forms.AutoValidate get();
   void set (    System.Windows.Forms.AutoValidate value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


AutoValidateChanged Event

[image]
Intersoft WebEssentials Documentation
AutoValidateChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : AutoValidateChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
Public Event AutoValidateChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.AutoValidateChanged, handler
C#
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public event System.EventHandler AutoValidateChanged
Delphi
public event AutoValidateChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public: __event System.EventHandler* AutoValidateChanged
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public:
event System.EventHandler^ AutoValidateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


BackColor Property

[image]
Intersoft WebEssentials Documentation
BackColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : BackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public virtual System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; virtual;
JScript
public function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
C++/CLI
public:
virtual property System.Drawing.Color BackColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


BackColorChanged Event

[image]
Intersoft WebEssentials Documentation
BackColorChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : BackColorChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")>
Public Event BackColorChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.BackColorChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")]
public event System.EventHandler BackColorChanged
Delphi
public event BackColorChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")]
public: __event System.EventHandler* BackColorChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")]
public:
event System.EventHandler^ BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


BackgroundImage Property

[image]
Intersoft WebEssentials Documentation
BackgroundImage Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : BackgroundImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("The background image used for the control.")>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property BackgroundImage As System.Drawing.Image
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image used for the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Drawing.Image BackgroundImage {get; set;}
Delphi
public read-write property BackgroundImage: System.Drawing.Image; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("The background image used for the control.")
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
public function get,set BackgroundImage : System.Drawing.Image
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image used for the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Drawing.Image* get_BackgroundImage();
public: __property virtual void set_BackgroundImage(
   System.Drawing.Image* value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image used for the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Drawing.Image^ BackgroundImage {
   System.Drawing.Image^ get();
   void set (    System.Drawing.Image^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


BackgroundImageChanged Event

[image]
Intersoft WebEssentials Documentation
BackgroundImageChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : BackgroundImageChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")>
Public Event BackgroundImageChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")]
public event System.EventHandler BackgroundImageChanged
Delphi
public event BackgroundImageChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")]
public: __event System.EventHandler* BackgroundImageChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")]
public:
event System.EventHandler^ BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


BackgroundImageLayout Property

[image]
Intersoft WebEssentials Documentation
BackgroundImageLayout Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : BackgroundImageLayout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("The background image layout used for the component.")>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property BackgroundImageLayout As System.Windows.Forms.ImageLayout
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.ImageLayout

instance.BackgroundImageLayout = value

value = instance.BackgroundImageLayout
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image layout used for the component.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}
Delphi
public read-write property BackgroundImageLayout: System.Windows.Forms.ImageLayout; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("The background image layout used for the component.")
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
public function get,set BackgroundImageLayout : System.Windows.Forms.ImageLayout
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image layout used for the component.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Windows.Forms.ImageLayout get_BackgroundImageLayout();
public: __property virtual void set_BackgroundImageLayout(
   System.Windows.Forms.ImageLayout value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image layout used for the component.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Windows.Forms.ImageLayout BackgroundImageLayout {
   System.Windows.Forms.ImageLayout get();
   void set (    System.Windows.Forms.ImageLayout value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


BackgroundImageLayoutChanged Event

[image]
Intersoft WebEssentials Documentation
BackgroundImageLayoutChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event BackgroundImageLayoutChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageLayoutChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler BackgroundImageLayoutChanged
Delphi
public event BackgroundImageLayoutChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* BackgroundImageLayoutChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


BeginInvoke Method

[image]
Intersoft WebEssentials Documentation
BeginInvoke Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : BeginInvoke Method

Glossary Item Box

Overload List

Overload | Description
BeginInvoke(Delegate) | (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


BeginInvoke(Delegate) Method

[image]
Intersoft WebEssentials Documentation
BeginInvoke(Delegate) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate _
) As System.IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim method As System.Delegate
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)
Delphi
public function BeginInvoke(
    method: System.Delegate
): System.IAsyncResult;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function BeginInvoke(
   method : System.Delegate
) : System.IAsyncResult;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.IAsyncResult* BeginInvoke(
   System.Delegate* method
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.IAsyncResult^ BeginInvoke(
   System.Delegate^ method
)

Parameters

method

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
Intersoft WebEssentials Documentation
BeginInvoke(Delegate,Object[]) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method, args)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)
Delphi
public function BeginInvoke(
    method: System.Delegate;
   params  args: System.TObjectarray of
): System.IAsyncResult;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function BeginInvoke(
   method : System.Delegate,
   args : System.Object[]
) : System.IAsyncResult;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: System.IAsyncResult* BeginInvoke(
   System.Delegate* method,
   params System.Object*[]* args
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
System.IAsyncResult^ BeginInvoke(
   System.Delegate^ method,
   ... System.array<Object^>^ args
)

Parameters

method
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


BindingContextChanged Event

[image]
Intersoft WebEssentials Documentation
BindingContextChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : BindingContextChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")>
Public Event BindingContextChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.BindingContextChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")]
public event System.EventHandler BindingContextChanged
Delphi
public event BindingContextChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")]
public: __event System.EventHandler* BindingContextChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")]
public:
event System.EventHandler^ BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


BringToFront Method

[image]
Intersoft WebEssentials Documentation
BringToFront Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : BringToFront Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.BringToFront()
C#
public void BringToFront()
Delphi
public procedure BringToFront();
JScript
public function BringToFront();
Managed Extensions for C++
public: void BringToFront();
C++/CLI
public:
void BringToFront();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


CancelButton Property

[image]
Intersoft WebEssentials Documentation
CancelButton Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : CancelButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")>
Public Property CancelButton As System.Windows.Forms.IButtonControl
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.IButtonControl

instance.CancelButton = value

value = instance.CancelButton
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")]
public System.Windows.Forms.IButtonControl CancelButton {get; set;}
Delphi
public read-write property CancelButton: System.Windows.Forms.IButtonControl;
JScript
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")
public function get,set CancelButton : System.Windows.Forms.IButtonControl
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")]
public: __property System.Windows.Forms.IButtonControl* get_CancelButton();
public: __property void set_CancelButton(
   System.Windows.Forms.IButtonControl* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")]
public:
property System.Windows.Forms.IButtonControl^ CancelButton {
   System.Windows.Forms.IButtonControl^ get();
   void set (    System.Windows.Forms.IButtonControl^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


CausesValidation Property

[image]
Intersoft WebEssentials Documentation
CausesValidation Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : CausesValidation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Indicates whether this component raises validation events. ")>
Public Property CausesValidation As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.CausesValidation = value

value = instance.CausesValidation
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Indicates whether this component raises validation events. ")]
public System.bool CausesValidation {get; set;}
Delphi
public read-write property CausesValidation: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Focus")
SRDescriptionAttribute("Indicates whether this component raises validation events. ")
public function get,set CausesValidation : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Indicates whether this component raises validation events. ")]
public: __property System.bool get_CausesValidation();
public: __property void set_CausesValidation(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Indicates whether this component raises validation events. ")]
public:
property System.bool CausesValidation {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


CausesValidationChanged Event

[image]
Intersoft WebEssentials Documentation
CausesValidationChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : CausesValidationChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event CausesValidationChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.CausesValidationChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler CausesValidationChanged
Delphi
public event CausesValidationChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* CausesValidationChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ChangeUICues Event

[image]
Intersoft WebEssentials Documentation
ChangeUICues Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ChangeUICues Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")>
Public Event ChangeUICues As System.Windows.Forms.UICuesEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.UICuesEventHandler

AddHandler instance.ChangeUICues, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")]
public event System.Windows.Forms.UICuesEventHandler ChangeUICues
Delphi
public event ChangeUICues: System.Windows.Forms.UICuesEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")]
public: __event System.Windows.Forms.UICuesEventHandler* ChangeUICues
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")]
public:
event System.Windows.Forms.UICuesEventHandler^ ChangeUICues

Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Click Event

[image]
Intersoft WebEssentials Documentation
Click Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Click Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the component is clicked.")>
Public Event Click As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Click, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the component is clicked.")]
public event System.EventHandler Click
Delphi
public event Click: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the component is clicked.")]
public: __event System.EventHandler* Click
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the component is clicked.")]
public:
event System.EventHandler^ Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ClientSize Property

[image]
Intersoft WebEssentials Documentation
ClientSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ClientSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
Public Property ClientSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Size

instance.ClientSize = value

value = instance.ClientSize
C#
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public System.Drawing.Size ClientSize {get; set;}
Delphi
public read-write property ClientSize: System.Drawing.Size;
JScript
System.ComponentModel.LocalizableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
public function get,set ClientSize : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public: __property System.Drawing.Size get_ClientSize();
public: __property void set_ClientSize(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public:
property System.Drawing.Size ClientSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ClientSizeChanged Event

[image]
Intersoft WebEssentials Documentation
ClientSizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ClientSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")>
Public Event ClientSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.ClientSizeChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")]
public event System.EventHandler ClientSizeChanged
Delphi
public event ClientSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")]
public: __event System.EventHandler* ClientSizeChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")]
public:
event System.EventHandler^ ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Close Method

[image]
Intersoft WebEssentials Documentation
Close Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Close Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.Close()
C#
public void Close()
Delphi
public procedure Close();
JScript
public function Close();
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Contains Method

[image]
Intersoft WebEssentials Documentation
Contains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Contains Method

ctl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ctl As System.Windows.Forms.Control _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim ctl As System.Windows.Forms.Control
Dim value As System.Boolean

value = instance.Contains(ctl)
C#
public System.bool Contains(
   System.Windows.Forms.Control ctl
)
Delphi
public function Contains(
    ctl: System.Windows.Forms.Control
): System.Boolean;
JScript
public function Contains(
   ctl : System.Windows.Forms.Control
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   System.Windows.Forms.Control* ctl
)
C++/CLI
public:
System.bool Contains(
   System.Windows.Forms.Control^ ctl
)

Parameters

ctl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ContextMenuStrip Property

[image]
Intersoft WebEssentials Documentation
ContextMenuStrip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ContextMenuStrip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")>
Public Overridable Property ContextMenuStrip As System.Windows.Forms.ContextMenuStrip
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.ContextMenuStrip

instance.ContextMenuStrip = value

value = instance.ContextMenuStrip
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}
Delphi
public read-write property ContextMenuStrip: System.Windows.Forms.ContextMenuStrip; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Behavior")
SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")
public function get,set ContextMenuStrip : System.Windows.Forms.ContextMenuStrip
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public: __property virtual System.Windows.Forms.ContextMenuStrip* get_ContextMenuStrip();
public: __property virtual void set_ContextMenuStrip(
   System.Windows.Forms.ContextMenuStrip* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public:
virtual property System.Windows.Forms.ContextMenuStrip^ ContextMenuStrip {
   System.Windows.Forms.ContextMenuStrip^ get();
   void set (    System.Windows.Forms.ContextMenuStrip^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ContextMenuStripChanged Event

[image]
Intersoft WebEssentials Documentation
ContextMenuStripChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ContextMenuStripChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event ContextMenuStripChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.ContextMenuStripChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler ContextMenuStripChanged
Delphi
public event ContextMenuStripChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* ContextMenuStripChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ControlAdded Event

[image]
Intersoft WebEssentials Documentation
ControlAdded Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ControlAdded Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a control is added to this control.")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event ControlAdded As System.Windows.Forms.ControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlAdded, handler
C#
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a control is added to this control.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event System.Windows.Forms.ControlEventHandler ControlAdded
Delphi
public event ControlAdded: System.Windows.Forms.ControlEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a control is added to this control.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event System.Windows.Forms.ControlEventHandler* ControlAdded
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a control is added to this control.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event System.Windows.Forms.ControlEventHandler^ ControlAdded

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ControlBox Property

[image]
Intersoft WebEssentials Documentation
ControlBox Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ControlBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")>
Public Property ControlBox As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.ControlBox = value

value = instance.ControlBox
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")]
public System.bool ControlBox {get; set;}
Delphi
public read-write property ControlBox: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")
public function get,set ControlBox : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")]
public: __property System.bool get_ControlBox();
public: __property void set_ControlBox(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")]
public:
property System.bool ControlBox {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ControlRemoved Event

[image]
Intersoft WebEssentials Documentation
ControlRemoved Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ControlRemoved Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a control is removed from this control.")>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.BrowsableAttribute(True)>
Public Event ControlRemoved As System.Windows.Forms.ControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlRemoved, handler
C#
[SRDescriptionAttribute("Occurs when a control is removed from this control.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(true)]
public event System.Windows.Forms.ControlEventHandler ControlRemoved
Delphi
public event ControlRemoved: System.Windows.Forms.ControlEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a control is removed from this control.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(true)]
public: __event System.Windows.Forms.ControlEventHandler* ControlRemoved
C++/CLI
[SRDescriptionAttribute("Occurs when a control is removed from this control.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(true)]
public:
event System.Windows.Forms.ControlEventHandler^ ControlRemoved

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


CreateControl Method

[image]
Intersoft WebEssentials Documentation
CreateControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : CreateControl Method

Glossary Item Box

Overload List

Overload | Description
CreateControl | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


CreateControl() Method

[image]
Intersoft WebEssentials Documentation
CreateControl() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : CreateControl() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.CreateControl()
C#
public void CreateControl()
Delphi
public procedure CreateControl();
JScript
public function CreateControl();
Managed Extensions for C++
public: void CreateControl();
C++/CLI
public:
void CreateControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


CreateGraphics Method

[image]
Intersoft WebEssentials Documentation
CreateGraphics Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : CreateGraphics Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As System.Drawing.Graphics
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Graphics

value = instance.CreateGraphics()
C#
public System.Drawing.Graphics CreateGraphics()
Delphi
public function CreateGraphics(): System.Drawing.Graphics;
JScript
public function CreateGraphics() : System.Drawing.Graphics;
Managed Extensions for C++
public: System.Drawing.Graphics* CreateGraphics();
C++/CLI
public:
System.Drawing.Graphics^ CreateGraphics();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


CreateObjRef Method

[image]
Intersoft WebEssentials Documentation
CreateObjRef Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : CreateObjRef Method

requestedType

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
[System.Security.SecurityCriticalAttribute()]
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: System.Type
): System.Runtime.Remoting.ObjRef; virtual;
JScript
System.Security.SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : System.Type
) : System.Runtime.Remoting.ObjRef;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
virtual System.Runtime.Remoting.ObjRef^ CreateObjRef(
   System.Type^ requestedType
)

Parameters

requestedType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Cursor Property

[image]
Intersoft WebEssentials Documentation
Cursor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Cursor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.AmbientValueAttribute()>
Public Overridable Property Cursor As System.Windows.Forms.Cursor
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.Cursor

instance.Cursor = value

value = instance.Cursor
C#
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.AmbientValueAttribute()]
public virtual System.Windows.Forms.Cursor Cursor {get; set;}
Delphi
public read-write property Cursor: System.Windows.Forms.Cursor; virtual;
JScript
SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")
SRCategoryAttribute("Appearance")
System.ComponentModel.AmbientValueAttribute()
public function get,set Cursor : System.Windows.Forms.Cursor
Managed Extensions for C++
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.AmbientValueAttribute()]
public: __property virtual System.Windows.Forms.Cursor* get_Cursor();
public: __property virtual void set_Cursor(
   System.Windows.Forms.Cursor* value
);
C++/CLI
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.AmbientValueAttribute()]
public:
virtual property System.Windows.Forms.Cursor^ Cursor {
   System.Windows.Forms.Cursor^ get();
   void set (    System.Windows.Forms.Cursor^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


CursorChanged Event

[image]
Intersoft WebEssentials Documentation
CursorChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : CursorChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event CursorChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.CursorChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler CursorChanged
Delphi
public event CursorChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* CursorChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


DataBindings Property

[image]
Intersoft WebEssentials Documentation
DataBindings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : DataBindings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)>
<SRDescriptionAttribute("The data bindings for the control.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<SRCategoryAttribute("Data")>
Public ReadOnly Property DataBindings As System.Windows.Forms.ControlBindingsCollection
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.ControlBindingsCollection

value = instance.DataBindings
C#
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)]
[SRDescriptionAttribute("The data bindings for the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[SRCategoryAttribute("Data")]
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}
Delphi
public read-only property DataBindings: System.Windows.Forms.ControlBindingsCollection;
JScript
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)
SRDescriptionAttribute("The data bindings for the control.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.ParenthesizePropertyNameAttribute()
SRCategoryAttribute("Data")
public function get DataBindings : System.Windows.Forms.ControlBindingsCollection
Managed Extensions for C++
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)]
[SRDescriptionAttribute("The data bindings for the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[SRCategoryAttribute("Data")]
public: __property System.Windows.Forms.ControlBindingsCollection* get_DataBindings();
C++/CLI
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)]
[SRDescriptionAttribute("The data bindings for the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[SRCategoryAttribute("Data")]
public:
property System.Windows.Forms.ControlBindingsCollection^ DataBindings {
   System.Windows.Forms.ControlBindingsCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Deactivate Event

[image]
Intersoft WebEssentials Documentation
Deactivate Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Deactivate Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Occurs whenever the form is deactivated.")>
Public Event Deactivate As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Deactivate, handler
C#
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is deactivated.")]
public event System.EventHandler Deactivate
Delphi
public event Deactivate: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is deactivated.")]
public: __event System.EventHandler* Deactivate
C++/CLI
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is deactivated.")]
public:
event System.EventHandler^ Deactivate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


DisplayRectangle Property

[image]
Intersoft WebEssentials Documentation
DisplayRectangle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : DisplayRectangle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DisplayRectangle As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Rectangle

value = instance.DisplayRectangle
C#
public virtual System.Drawing.Rectangle DisplayRectangle {get;}
Delphi
public read-only property DisplayRectangle: System.Drawing.Rectangle; virtual;
JScript
public function get DisplayRectangle : System.Drawing.Rectangle
Managed Extensions for C++
public: __property virtual System.Drawing.Rectangle get_DisplayRectangle();
C++/CLI
public:
virtual property System.Drawing.Rectangle DisplayRectangle {
   System.Drawing.Rectangle get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Dispose Method

[image]
Intersoft WebEssentials Documentation
Dispose Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Dispose Method

Glossary Item Box

Clean up any resources being used.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Dispose() Method

[image]
Intersoft WebEssentials Documentation
Dispose() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.Dispose()
C#
public void Dispose()
Delphi
public procedure Dispose();
JScript
public function Dispose();
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Dock Property

[image]
Intersoft WebEssentials Documentation
Dock Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Dock Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property Dock As System.Windows.Forms.DockStyle
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.DockStyle

instance.Dock = value

value = instance.Dock
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Windows.Forms.DockStyle Dock {get; set;}
Delphi
public read-write property Dock: System.Windows.Forms.DockStyle; virtual;
JScript
SRCategoryAttribute("Layout")
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")
System.ComponentModel.DefaultValueAttribute()
public function get,set Dock : System.Windows.Forms.DockStyle
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Windows.Forms.DockStyle get_Dock();
public: __property virtual void set_Dock(
   System.Windows.Forms.DockStyle value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Windows.Forms.DockStyle Dock {
   System.Windows.Forms.DockStyle get();
   void set (    System.Windows.Forms.DockStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


DockChanged Event

[image]
Intersoft WebEssentials Documentation
DockChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : DockChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event DockChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.DockChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler DockChanged
Delphi
public event DockChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* DockChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


DoDragDrop Method

[image]
Intersoft WebEssentials Documentation
DoDragDrop Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : DoDragDrop Method

data
allowedEffects

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Function DoDragDrop( _
   ByVal data As System.Object, _
   ByVal allowedEffects As System.Windows.Forms.DragDropEffects _
) As System.Windows.Forms.DragDropEffects
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim data As System.Object
Dim allowedEffects As System.Windows.Forms.DragDropEffects
Dim value As System.Windows.Forms.DragDropEffects

value = instance.DoDragDrop(data, allowedEffects)
C#
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)
Delphi
public function DoDragDrop(
    data: System.TObject;
    allowedEffects: System.Windows.Forms.DragDropEffects
): System.Windows.Forms.DragDropEffects;
JScript
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=)
public function DoDragDrop(
   data : System.Object,
   allowedEffects : System.Windows.Forms.DragDropEffects
) : System.Windows.Forms.DragDropEffects;
Managed Extensions for C++
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: System.Windows.Forms.DragDropEffects DoDragDrop(
   System.Object* data,
   System.Windows.Forms.DragDropEffects allowedEffects
)
C++/CLI
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
System.Windows.Forms.DragDropEffects DoDragDrop(
   System.Object^ data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
allowedEffects

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


DoubleClick Event

[image]
Intersoft WebEssentials Documentation
DoubleClick Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : DoubleClick Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the component is double-clicked.")>
<SRCategoryAttribute("Action")>
Public Event DoubleClick As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.DoubleClick, handler
C#
[SRDescriptionAttribute("Occurs when the component is double-clicked.")]
[SRCategoryAttribute("Action")]
public event System.EventHandler DoubleClick
Delphi
public event DoubleClick: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the component is double-clicked.")]
[SRCategoryAttribute("Action")]
public: __event System.EventHandler* DoubleClick
C++/CLI
[SRDescriptionAttribute("Occurs when the component is double-clicked.")]
[SRCategoryAttribute("Action")]
public:
event System.EventHandler^ DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


DragDrop Event

[image]
Intersoft WebEssentials Documentation
DragDrop Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : DragDrop Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")>
<SRCategoryAttribute("Drag Drop")>
Public Event DragDrop As System.Windows.Forms.DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragDrop, handler
C#
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
[SRCategoryAttribute("Drag Drop")]
public event System.Windows.Forms.DragEventHandler DragDrop
Delphi
public event DragDrop: System.Windows.Forms.DragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
[SRCategoryAttribute("Drag Drop")]
public: __event System.Windows.Forms.DragEventHandler* DragDrop
C++/CLI
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
[SRCategoryAttribute("Drag Drop")]
public:
event System.Windows.Forms.DragEventHandler^ DragDrop

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


DragEnter Event

[image]
Intersoft WebEssentials Documentation
DragEnter Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : DragEnter Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")>
Public Event DragEnter As System.Windows.Forms.DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragEnter, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")]
public event System.Windows.Forms.DragEventHandler DragEnter
Delphi
public event DragEnter: System.Windows.Forms.DragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")]
public: __event System.Windows.Forms.DragEventHandler* DragEnter
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")]
public:
event System.Windows.Forms.DragEventHandler^ DragEnter

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


DragLeave Event

[image]
Intersoft WebEssentials Documentation
DragLeave Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : DragLeave Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")>
Public Event DragLeave As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.DragLeave, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")]
public event System.EventHandler DragLeave
Delphi
public event DragLeave: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")]
public: __event System.EventHandler* DragLeave
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")]
public:
event System.EventHandler^ DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


DragOver Event

[image]
Intersoft WebEssentials Documentation
DragOver Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : DragOver Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")>
Public Event DragOver As System.Windows.Forms.DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragOver, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")]
public event System.Windows.Forms.DragEventHandler DragOver
Delphi
public event DragOver: System.Windows.Forms.DragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")]
public: __event System.Windows.Forms.DragEventHandler* DragOver
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")]
public:
event System.Windows.Forms.DragEventHandler^ DragOver

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


DrawToBitmap Method

[image]
Intersoft WebEssentials Documentation
DrawToBitmap Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : DrawToBitmap Method

bitmap
targetBounds

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows Or  _
    UIPermissionWindow.SafeTopLevelWindows Or  _
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Sub DrawToBitmap( _
   ByVal bitmap As System.Drawing.Bitmap, _
   ByVal targetBounds As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim bitmap As System.Drawing.Bitmap
Dim targetBounds As System.Drawing.Rectangle

instance.DrawToBitmap(bitmap, targetBounds)
C#
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public void DrawToBitmap(
   System.Drawing.Bitmap bitmap,
   System.Drawing.Rectangle targetBounds
)
Delphi
public procedure DrawToBitmap(
    bitmap: System.Drawing.Bitmap;
    targetBounds: System.Drawing.Rectangle
);
JScript
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=)
public function DrawToBitmap(
   bitmap : System.Drawing.Bitmap,
   targetBounds : System.Drawing.Rectangle
);
Managed Extensions for C++
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void DrawToBitmap(
   System.Drawing.Bitmap* bitmap,
   System.Drawing.Rectangle targetBounds
)
C++/CLI
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void DrawToBitmap(
   System.Drawing.Bitmap^ bitmap,
   System.Drawing.Rectangle targetBounds
)

Parameters

bitmap
targetBounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the control is enabled.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Behavior")>
<System.Runtime.InteropServices.DispIdAttribute(-514)>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[System.Runtime.InteropServices.DispIdAttribute(-514)]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
SRDescriptionAttribute("Indicates whether the control is enabled.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Behavior")
System.Runtime.InteropServices.DispIdAttribute(-514)
public function get,set Enabled : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[System.Runtime.InteropServices.DispIdAttribute(-514)]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[System.Runtime.InteropServices.DispIdAttribute(-514)]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


EnabledChanged Event

[image]
Intersoft WebEssentials Documentation
EnabledChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : EnabledChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the control's enabled state changes.")>
Public Event EnabledChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.EnabledChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's enabled state changes.")]
public event System.EventHandler EnabledChanged
Delphi
public event EnabledChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's enabled state changes.")]
public: __event System.EventHandler* EnabledChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's enabled state changes.")]
public:
event System.EventHandler^ EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


EndInvoke Method

[image]
Intersoft WebEssentials Documentation
EndInvoke Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : EndInvoke Method

asyncResult

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Function EndInvoke( _
   ByVal asyncResult As System.IAsyncResult _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim asyncResult As System.IAsyncResult
Dim value As System.Object

value = instance.EndInvoke(asyncResult)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)
Delphi
public function EndInvoke(
    asyncResult: System.IAsyncResult
): System.TObject;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function EndInvoke(
   asyncResult : System.IAsyncResult
) : System.Object;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: System.Object* EndInvoke(
   System.IAsyncResult* asyncResult
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
System.Object^ EndInvoke(
   System.IAsyncResult^ asyncResult
)

Parameters

asyncResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Enter Event

[image]
Intersoft WebEssentials Documentation
Enter Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Enter Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")>
<SRCategoryAttribute("Focus")>
Public Event Enter As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Enter, handler
C#
[SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")]
[SRCategoryAttribute("Focus")]
public event System.EventHandler Enter
Delphi
public event Enter: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")]
[SRCategoryAttribute("Focus")]
public: __event System.EventHandler* Enter
C++/CLI
[SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")]
[SRCategoryAttribute("Focus")]
public:
event System.EventHandler^ Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


FindForm Method

[image]
Intersoft WebEssentials Documentation
FindForm Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : FindForm Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows Or  _
    UIPermissionWindow.SafeTopLevelWindows Or  _
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Function FindForm() As System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.Form

value = instance.FindForm()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public System.Windows.Forms.Form FindForm()
Delphi
public function FindForm(): System.Windows.Forms.Form;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=)
public function FindForm() : System.Windows.Forms.Form;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: System.Windows.Forms.Form* FindForm();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
System.Windows.Forms.Form^ FindForm();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Focus Method

[image]
Intersoft WebEssentials Documentation
Focus Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Function Focus() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

value = instance.Focus()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.bool Focus()
Delphi
public function Focus(): System.Boolean;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function Focus() : System.boolean;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: System.bool Focus();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
System.bool Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Font Property

[image]
Intersoft WebEssentials Documentation
Font Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.LocalizableAttribute(True)>
<System.Runtime.InteropServices.DispIdAttribute(-512)>
<SRDescriptionAttribute("The font used to display text in the control.")>
Public Overridable Property Font As System.Drawing.Font
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
[System.ComponentModel.AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.LocalizableAttribute(true)]
[System.Runtime.InteropServices.DispIdAttribute(-512)]
[SRDescriptionAttribute("The font used to display text in the control.")]
public virtual System.Drawing.Font Font {get; set;}
Delphi
public read-write property Font: System.Drawing.Font; virtual;
JScript
System.ComponentModel.AmbientValueAttribute()
SRCategoryAttribute("Appearance")
System.ComponentModel.LocalizableAttribute()
System.Runtime.InteropServices.DispIdAttribute(-512)
SRDescriptionAttribute("The font used to display text in the control.")
public function get,set Font : System.Drawing.Font
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.LocalizableAttribute(true)]
[System.Runtime.InteropServices.DispIdAttribute(-512)]
[SRDescriptionAttribute("The font used to display text in the control.")]
public: __property virtual System.Drawing.Font* get_Font();
public: __property virtual void set_Font(
   System.Drawing.Font* value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.LocalizableAttribute(true)]
[System.Runtime.InteropServices.DispIdAttribute(-512)]
[SRDescriptionAttribute("The font used to display text in the control.")]
public:
virtual property System.Drawing.Font^ Font {
   System.Drawing.Font^ get();
   void set (    System.Drawing.Font^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


FontChanged Event

[image]
Intersoft WebEssentials Documentation
FontChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : FontChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event FontChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.FontChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler FontChanged
Delphi
public event FontChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* FontChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ForeColor Property

[image]
Intersoft WebEssentials Documentation
ForeColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ForeColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The foreground color of this component, which is used to display text.")>
<System.Runtime.InteropServices.DispIdAttribute(-513)>
<SRCategoryAttribute("Appearance")>
Public Overridable Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
[System.Runtime.InteropServices.DispIdAttribute(-513)]
[SRCategoryAttribute("Appearance")]
public virtual System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; virtual;
JScript
SRDescriptionAttribute("The foreground color of this component, which is used to display text.")
System.Runtime.InteropServices.DispIdAttribute(-513)
SRCategoryAttribute("Appearance")
public function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
[System.Runtime.InteropServices.DispIdAttribute(-513)]
[SRCategoryAttribute("Appearance")]
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
C++/CLI
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
[System.Runtime.InteropServices.DispIdAttribute(-513)]
[SRCategoryAttribute("Appearance")]
public:
virtual property System.Drawing.Color ForeColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ForeColorChanged Event

[image]
Intersoft WebEssentials Documentation
ForeColorChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ForeColorChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")>
Public Event ForeColorChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.ForeColorChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")]
public event System.EventHandler ForeColorChanged
Delphi
public event ForeColorChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")]
public: __event System.EventHandler* ForeColorChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")]
public:
event System.EventHandler^ ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


FormBorderStyle Property

[image]
Intersoft WebEssentials Documentation
FormBorderStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : FormBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")>
<System.Runtime.InteropServices.DispIdAttribute(-504)>
<SRCategoryAttribute("Appearance")>
Public Property FormBorderStyle As System.Windows.Forms.FormBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.FormBorderStyle

instance.FormBorderStyle = value

value = instance.FormBorderStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[System.Runtime.InteropServices.DispIdAttribute(-504)]
[SRCategoryAttribute("Appearance")]
public System.Windows.Forms.FormBorderStyle FormBorderStyle {get; set;}
Delphi
public read-write property FormBorderStyle: System.Windows.Forms.FormBorderStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")
System.Runtime.InteropServices.DispIdAttribute(-504)
SRCategoryAttribute("Appearance")
public function get,set FormBorderStyle : System.Windows.Forms.FormBorderStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[System.Runtime.InteropServices.DispIdAttribute(-504)]
[SRCategoryAttribute("Appearance")]
public: __property System.Windows.Forms.FormBorderStyle get_FormBorderStyle();
public: __property void set_FormBorderStyle(
   System.Windows.Forms.FormBorderStyle value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[System.Runtime.InteropServices.DispIdAttribute(-504)]
[SRCategoryAttribute("Appearance")]
public:
property System.Windows.Forms.FormBorderStyle FormBorderStyle {
   System.Windows.Forms.FormBorderStyle get();
   void set (    System.Windows.Forms.FormBorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


FormClosed Event

[image]
Intersoft WebEssentials Documentation
FormClosed Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : FormClosed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")>
Public Event FormClosed As System.Windows.Forms.FormClosedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.FormClosedEventHandler

AddHandler instance.FormClosed, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")]
public event System.Windows.Forms.FormClosedEventHandler FormClosed
Delphi
public event FormClosed: System.Windows.Forms.FormClosedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")]
public: __event System.Windows.Forms.FormClosedEventHandler* FormClosed
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")]
public:
event System.Windows.Forms.FormClosedEventHandler^ FormClosed

Event Data

The event handler receives an argument of type System.Windows.Forms.FormClosedEventArgs containing data related to this event. The following FormClosedEventArgs properties provide information specific to this event.

Property | Description
CloseReason | Gets a value that indicates why the form was closed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


FormClosing Event

[image]
Intersoft WebEssentials Documentation
FormClosing Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : FormClosing Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")>
<SRCategoryAttribute("Behavior")>
Public Event FormClosing As System.Windows.Forms.FormClosingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.FormClosingEventHandler

AddHandler instance.FormClosing, handler
C#
[SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")]
[SRCategoryAttribute("Behavior")]
public event System.Windows.Forms.FormClosingEventHandler FormClosing
Delphi
public event FormClosing: System.Windows.Forms.FormClosingEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")]
[SRCategoryAttribute("Behavior")]
public: __event System.Windows.Forms.FormClosingEventHandler* FormClosing
C++/CLI
[SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")]
[SRCategoryAttribute("Behavior")]
public:
event System.Windows.Forms.FormClosingEventHandler^ FormClosing

Event Data

The event handler receives an argument of type System.Windows.Forms.FormClosingEventArgs containing data related to this event. The following FormClosingEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
CloseReason | Gets a value that indicates why the form is being closed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


GetChildAtPoint Method

[image]
Intersoft WebEssentials Documentation
GetChildAtPoint Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : GetChildAtPoint Method

Glossary Item Box

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


GetChildAtPoint(Point) Method

[image]
Intersoft WebEssentials Documentation
GetChildAtPoint(Point) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetChildAtPoint( _
   ByVal pt As System.Drawing.Point _
) As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim pt As System.Drawing.Point
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt
)
Delphi
public function GetChildAtPoint(
    pt: System.Drawing.Point
): System.Windows.Forms.Control;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetChildAtPoint(
   pt : System.Drawing.Point
) : System.Windows.Forms.Control;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Windows.Forms.Control* GetChildAtPoint(
   System.Drawing.Point pt
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Windows.Forms.Control^ GetChildAtPoint(
   System.Drawing.Point pt
)

Parameters

pt

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
Intersoft WebEssentials Documentation
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
skipValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As System.Drawing.Point, _
   ByVal skipValue As System.Windows.Forms.GetChildAtPointSkip _
) As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim pt As System.Drawing.Point
Dim skipValue As System.Windows.Forms.GetChildAtPointSkip
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt, skipValue)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)
Delphi
public function GetChildAtPoint(
    pt: System.Drawing.Point;
    skipValue: System.Windows.Forms.GetChildAtPointSkip
): System.Windows.Forms.Control;
JScript
public function GetChildAtPoint(
   pt : System.Drawing.Point,
   skipValue : System.Windows.Forms.GetChildAtPointSkip
) : System.Windows.Forms.Control;
Managed Extensions for C++
public: System.Windows.Forms.Control* GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)
C++/CLI
public:
System.Windows.Forms.Control^ GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
skipValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


GetContainerControl Method

[image]
Intersoft WebEssentials Documentation
GetContainerControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : GetContainerControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As System.Windows.Forms.IContainerControl
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.IContainerControl

value = instance.GetContainerControl()
C#
public System.Windows.Forms.IContainerControl GetContainerControl()
Delphi
public function GetContainerControl(): System.Windows.Forms.IContainerControl;
JScript
public function GetContainerControl() : System.Windows.Forms.IContainerControl;
Managed Extensions for C++
public: System.Windows.Forms.IContainerControl* GetContainerControl();
C++/CLI
public:
System.Windows.Forms.IContainerControl^ GetContainerControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


GetLifetimeService Method

[image]
Intersoft WebEssentials Documentation
GetLifetimeService Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : GetLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Function GetLifetimeService() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Object

value = instance.GetLifetimeService()
C#
[System.Security.SecurityCriticalAttribute()]
public System.object GetLifetimeService()
Delphi
public function GetLifetimeService(): System.TObject;
JScript
System.Security.SecurityCriticalAttribute()
public function GetLifetimeService() : System.Object;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: System.Object* GetLifetimeService();
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
System.Object^ GetLifetimeService();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


GetNextControl Method

[image]
Intersoft WebEssentials Documentation
GetNextControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : GetNextControl Method

ctl
forward

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean _
) As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim value As System.Windows.Forms.Control

value = instance.GetNextControl(ctl, forward)
C#
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)
Delphi
public function GetNextControl(
    ctl: System.Windows.Forms.Control;
    forward: System.Boolean
): System.Windows.Forms.Control;
JScript
public function GetNextControl(
   ctl : System.Windows.Forms.Control,
   forward : System.boolean
) : System.Windows.Forms.Control;
Managed Extensions for C++
public: System.Windows.Forms.Control* GetNextControl(
   System.Windows.Forms.Control* ctl,
   System.bool forward
)
C++/CLI
public:
System.Windows.Forms.Control^ GetNextControl(
   System.Windows.Forms.Control^ ctl,
   System.bool forward
)

Parameters

ctl
forward

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


GetPreferredSize Method

[image]
Intersoft WebEssentials Documentation
GetPreferredSize Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : GetPreferredSize Method

proposedSize

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As System.Drawing.Size _
) As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim proposedSize As System.Drawing.Size
Dim value As System.Drawing.Size

value = instance.GetPreferredSize(proposedSize)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)
Delphi
public function GetPreferredSize(
    proposedSize: System.Drawing.Size
): System.Drawing.Size; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function GetPreferredSize(
   proposedSize : System.Drawing.Size
) : System.Drawing.Size;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)

Parameters

proposedSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


GiveFeedback Event

[image]
Intersoft WebEssentials Documentation
GiveFeedback Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : GiveFeedback Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")>
Public Event GiveFeedback As System.Windows.Forms.GiveFeedbackEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.GiveFeedbackEventHandler

AddHandler instance.GiveFeedback, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")]
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback
Delphi
public event GiveFeedback: System.Windows.Forms.GiveFeedbackEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")]
public: __event System.Windows.Forms.GiveFeedbackEventHandler* GiveFeedback
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")]
public:
event System.Windows.Forms.GiveFeedbackEventHandler^ GiveFeedback

Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Header Property

[image]
Intersoft WebEssentials Documentation
Header Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Header Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Header As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.String

instance.Header = value

value = instance.Header
C#
public System.string Header {get; set;}
Delphi
public read-write property Header: System.String;
JScript
public function get,set Header : System.String
Managed Extensions for C++
public: __property System.string* get_Header();
public: __property void set_Header(
   System.string* value
);
C++/CLI
public:
property System.String^ Header {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


HelpButton Property

[image]
Intersoft WebEssentials Documentation
HelpButton Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : HelpButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HelpButton As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.HelpButton = value

value = instance.HelpButton
C#
[SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool HelpButton {get; set;}
Delphi
public read-write property HelpButton: System.Boolean;
JScript
SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
public function get,set HelpButton : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_HelpButton();
public: __property void set_HelpButton(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool HelpButton {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


HelpButtonClicked Event

[image]
Intersoft WebEssentials Documentation
HelpButtonClicked Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : HelpButtonClicked Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the help button is clicked.")>
<System.ComponentModel.EditorBrowsableAttribute()>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.BrowsableAttribute(True)>
Public Event HelpButtonClicked As System.ComponentModel.CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.HelpButtonClicked, handler
C#
[SRDescriptionAttribute("Event raised when the help button is clicked.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(true)]
public event System.ComponentModel.CancelEventHandler HelpButtonClicked
Delphi
public event HelpButtonClicked: System.ComponentModel.CancelEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the help button is clicked.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(true)]
public: __event System.ComponentModel.CancelEventHandler* HelpButtonClicked
C++/CLI
[SRDescriptionAttribute("Event raised when the help button is clicked.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(true)]
public:
event System.ComponentModel.CancelEventHandler^ HelpButtonClicked

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


HelpRequested Event

[image]
Intersoft WebEssentials Documentation
HelpRequested Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : HelpRequested Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the user invokes Help for the control.")>
<SRCategoryAttribute("Behavior")>
Public Event HelpRequested As System.Windows.Forms.HelpEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.HelpEventHandler

AddHandler instance.HelpRequested, handler
C#
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
[SRCategoryAttribute("Behavior")]
public event System.Windows.Forms.HelpEventHandler HelpRequested
Delphi
public event HelpRequested: System.Windows.Forms.HelpEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
[SRCategoryAttribute("Behavior")]
public: __event System.Windows.Forms.HelpEventHandler* HelpRequested
C++/CLI
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
[SRCategoryAttribute("Behavior")]
public:
event System.Windows.Forms.HelpEventHandler^ HelpRequested

Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Hide Method

[image]
Intersoft WebEssentials Documentation
Hide Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Hide Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Sub Hide()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.Hide()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Hide()
Delphi
public procedure Hide();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Hide();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Hide();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Hide();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Icon Property

[image]
Intersoft WebEssentials Documentation
Icon Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Icon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Property Icon As System.Drawing.Icon
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Icon

instance.Icon = value

value = instance.Icon
C#
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.LocalizableAttribute(true)]
public System.Drawing.Icon Icon {get; set;}
Delphi
public read-write property Icon: System.Drawing.Icon;
JScript
System.ComponentModel.AmbientValueAttribute()
SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")
SRCategoryAttribute("Window Style")
System.ComponentModel.LocalizableAttribute()
public function get,set Icon : System.Drawing.Icon
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property System.Drawing.Icon* get_Icon();
public: __property void set_Icon(
   System.Drawing.Icon* value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
property System.Drawing.Icon^ Icon {
   System.Drawing.Icon^ get();
   void set (    System.Drawing.Icon^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ImeMode Property

[image]
Intersoft WebEssentials Documentation
ImeMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ImeMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Property ImeMode As System.Windows.Forms.ImeMode
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.ImeMode

instance.ImeMode = value

value = instance.ImeMode
C#
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.LocalizableAttribute(true)]
public System.Windows.Forms.ImeMode ImeMode {get; set;}
Delphi
public read-write property ImeMode: System.Windows.Forms.ImeMode;
JScript
System.ComponentModel.AmbientValueAttribute()
SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")
SRCategoryAttribute("Behavior")
System.ComponentModel.LocalizableAttribute()
public function get,set ImeMode : System.Windows.Forms.ImeMode
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property System.Windows.Forms.ImeMode get_ImeMode();
public: __property void set_ImeMode(
   System.Windows.Forms.ImeMode value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
property System.Windows.Forms.ImeMode ImeMode {
   System.Windows.Forms.ImeMode get();
   void set (    System.Windows.Forms.ImeMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ImeModeChanged Event

[image]
Intersoft WebEssentials Documentation
ImeModeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ImeModeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WinCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")>
Public Event ImeModeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.ImeModeChanged, handler
C#
[WinCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")]
public event System.EventHandler ImeModeChanged
Delphi
public event ImeModeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WinCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")]
public: __event System.EventHandler* ImeModeChanged
C++/CLI
[WinCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")]
public:
event System.EventHandler^ ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


InitializeLifetimeService Method

[image]
Intersoft WebEssentials Documentation
InitializeLifetimeService Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : InitializeLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Object

value = instance.InitializeLifetimeService()
C#
[System.Security.SecurityCriticalAttribute()]
public virtual System.object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): System.TObject; virtual;
JScript
System.Security.SecurityCriticalAttribute()
public function InitializeLifetimeService() : System.Object;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: virtual System.Object* InitializeLifetimeService();
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
virtual System.Object^ InitializeLifetimeService();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


InputLanguageChanged Event

[image]
Intersoft WebEssentials Documentation
InputLanguageChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : InputLanguageChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")>
<SRCategoryAttribute("Behavior")>
Public Event InputLanguageChanged As System.Windows.Forms.InputLanguageChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.InputLanguageChangedEventHandler

AddHandler instance.InputLanguageChanged, handler
C#
[SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")]
[SRCategoryAttribute("Behavior")]
public event System.Windows.Forms.InputLanguageChangedEventHandler InputLanguageChanged
Delphi
public event InputLanguageChanged: System.Windows.Forms.InputLanguageChangedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")]
[SRCategoryAttribute("Behavior")]
public: __event System.Windows.Forms.InputLanguageChangedEventHandler* InputLanguageChanged
C++/CLI
[SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")]
[SRCategoryAttribute("Behavior")]
public:
event System.Windows.Forms.InputLanguageChangedEventHandler^ InputLanguageChanged

Event Data

The event handler receives an argument of type System.Windows.Forms.InputLanguageChangedEventArgs containing data related to this event. The following InputLanguageChangedEventArgs properties provide information specific to this event.

Property | Description
CharSet | Gets the character set associated with the new input language.
Culture | Gets the locale of the input language.
InputLanguage | Gets a value indicating the input language.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


InputLanguageChanging Event

[image]
Intersoft WebEssentials Documentation
InputLanguageChanging Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : InputLanguageChanging Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")>
Public Event InputLanguageChanging As System.Windows.Forms.InputLanguageChangingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.InputLanguageChangingEventHandler

AddHandler instance.InputLanguageChanging, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")]
public event System.Windows.Forms.InputLanguageChangingEventHandler InputLanguageChanging
Delphi
public event InputLanguageChanging: System.Windows.Forms.InputLanguageChangingEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")]
public: __event System.Windows.Forms.InputLanguageChangingEventHandler* InputLanguageChanging
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")]
public:
event System.Windows.Forms.InputLanguageChangingEventHandler^ InputLanguageChanging

Event Data

The event handler receives an argument of type System.Windows.Forms.InputLanguageChangingEventArgs containing data related to this event. The following InputLanguageChangingEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
Culture | Gets the locale of the requested input language.
InputLanguage | Gets a value indicating the input language.
SysCharSet | Gets a value indicating whether the system default font supports the character set required for the requested input language.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Invalidate Method

[image]
Intersoft WebEssentials Documentation
Invalidate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Invalidate Method

Glossary Item Box

Overload List

Overload | Description
Invalidate(Region) | (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate() | (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Invalidate() Method

[image]
Intersoft WebEssentials Documentation
Invalidate() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Invalidate()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.Invalidate()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Invalidate()
Delphi
public procedure Invalidate();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invalidate();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Invalidate();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Invalidate();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


Invalidate(Boolean) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim invalidateChildren As System.Boolean

instance.Invalidate(invalidateChildren)
C#
public void Invalidate(
   System.bool invalidateChildren
)
Delphi
public procedure Invalidate(
    invalidateChildren: System.Boolean
);
JScript
public function Invalidate(
   invalidateChildren : System.boolean
);
Managed Extensions for C++
public: void Invalidate(
   System.bool invalidateChildren
)
C++/CLI
public:
void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


Invalidate(Rectangle) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Rectangle) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > Invalidate Method : Invalidate(Rectangle) Method

rc

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Invalidate( _
   ByVal rc As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim rc As System.Drawing.Rectangle

instance.Invalidate(rc)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Invalidate(
   System.Drawing.Rectangle rc
)
Delphi
public procedure Invalidate(
    rc: System.Drawing.Rectangle
);
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invalidate(
   rc : System.Drawing.Rectangle
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Invalidate(
   System.Drawing.Rectangle rc
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Invalidate(
   System.Drawing.Rectangle rc
)

Parameters

rc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Rectangle,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
invalidateChildren

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As System.Drawing.Rectangle, _
   ByVal invalidateChildren As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim rc As System.Drawing.Rectangle
Dim invalidateChildren As System.Boolean

instance.Invalidate(rc, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)
Delphi
public procedure Invalidate(
    rc: System.Drawing.Rectangle;
    invalidateChildren: System.Boolean
);
JScript
public function Invalidate(
   rc : System.Drawing.Rectangle,
   invalidateChildren : System.boolean
);
Managed Extensions for C++
public: void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)
C++/CLI
public:
void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
invalidateChildren

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


Invalidate(Region) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Region) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > Invalidate Method : Invalidate(Region) Method

region

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Invalidate( _
   ByVal region As System.Drawing.Region _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim region As System.Drawing.Region

instance.Invalidate(region)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Invalidate(
   System.Drawing.Region region
)
Delphi
public procedure Invalidate(
    region: System.Drawing.Region
);
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invalidate(
   region : System.Drawing.Region
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Invalidate(
   System.Drawing.Region* region
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Invalidate(
   System.Drawing.Region^ region
)

Parameters

region

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


Invalidate(Region,Boolean) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Region,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
invalidateChildren

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As System.Drawing.Region, _
   ByVal invalidateChildren As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim region As System.Drawing.Region
Dim invalidateChildren As System.Boolean

instance.Invalidate(region, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Region region,
   System.bool invalidateChildren
)
Delphi
public procedure Invalidate(
    region: System.Drawing.Region;
    invalidateChildren: System.Boolean
);
JScript
public function Invalidate(
   region : System.Drawing.Region,
   invalidateChildren : System.boolean
);
Managed Extensions for C++
public: void Invalidate(
   System.Drawing.Region* region,
   System.bool invalidateChildren
)
C++/CLI
public:
void Invalidate(
   System.Drawing.Region^ region,
   System.bool invalidateChildren
)

Parameters

region
invalidateChildren

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


Invoke Method

[image]
Intersoft WebEssentials Documentation
Invoke Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Invoke Method

Glossary Item Box

Overload List

Overload | Description
Invoke(Delegate) | (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Invoke(Delegate) Method

[image]
Intersoft WebEssentials Documentation
Invoke(Delegate) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > Invoke Method : Invoke(Delegate) Method

method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function Invoke( _
   ByVal method As System.Delegate _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim method As System.Delegate
Dim value As System.Object

value = instance.Invoke(method)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object Invoke(
   System.Delegate method
)
Delphi
public function Invoke(
    method: System.Delegate
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invoke(
   method : System.Delegate
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* Invoke(
   System.Delegate* method
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ Invoke(
   System.Delegate^ method
)

Parameters

method

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
Intersoft WebEssentials Documentation
Invoke(Delegate,Object[]) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.Object

value = instance.Invoke(method, args)
C#
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)
Delphi
public function Invoke(
    method: System.Delegate;
   params  args: System.TObjectarray of
): System.TObject;
JScript
public function Invoke(
   method : System.Delegate,
   args : System.Object[]
) : System.Object;
Managed Extensions for C++
public: System.Object* Invoke(
   System.Delegate* method,
   params System.Object*[]* args
)
C++/CLI
public:
System.Object^ Invoke(
   System.Delegate^ method,
   ... System.array<Object^>^ args
)

Parameters

method
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


IsMdiContainer Property

[image]
Intersoft WebEssentials Documentation
IsMdiContainer Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : IsMdiContainer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Determines whether the form is an MDI container.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property IsMdiContainer As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.IsMdiContainer = value

value = instance.IsMdiContainer
C#
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool IsMdiContainer {get; set;}
Delphi
public read-write property IsMdiContainer: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Determines whether the form is an MDI container.")
System.ComponentModel.DefaultValueAttribute()
public function get,set IsMdiContainer : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_IsMdiContainer();
public: __property void set_IsMdiContainer(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool IsMdiContainer {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


KeyDown Event

[image]
Intersoft WebEssentials Documentation
KeyDown Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : KeyDown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a key is first pressed.")>
<SRCategoryAttribute("Key")>
Public Event KeyDown As System.Windows.Forms.KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyDown, handler
C#
[SRDescriptionAttribute("Occurs when a key is first pressed.")]
[SRCategoryAttribute("Key")]
public event System.Windows.Forms.KeyEventHandler KeyDown
Delphi
public event KeyDown: System.Windows.Forms.KeyEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a key is first pressed.")]
[SRCategoryAttribute("Key")]
public: __event System.Windows.Forms.KeyEventHandler* KeyDown
C++/CLI
[SRDescriptionAttribute("Occurs when a key is first pressed.")]
[SRCategoryAttribute("Key")]
public:
event System.Windows.Forms.KeyEventHandler^ KeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


KeyPress Event

[image]
Intersoft WebEssentials Documentation
KeyPress Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : KeyPress Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Key")>
<SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")>
Public Event KeyPress As System.Windows.Forms.KeyPressEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.KeyPressEventHandler

AddHandler instance.KeyPress, handler
C#
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")]
public event System.Windows.Forms.KeyPressEventHandler KeyPress
Delphi
public event KeyPress: System.Windows.Forms.KeyPressEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")]
public: __event System.Windows.Forms.KeyPressEventHandler* KeyPress
C++/CLI
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")]
public:
event System.Windows.Forms.KeyPressEventHandler^ KeyPress

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


KeyPreview Property

[image]
Intersoft WebEssentials Documentation
KeyPreview Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : KeyPreview Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property KeyPreview As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.KeyPreview = value

value = instance.KeyPreview
C#
[SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool KeyPreview {get; set;}
Delphi
public read-write property KeyPreview: System.Boolean;
JScript
SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")
System.ComponentModel.DefaultValueAttribute()
public function get,set KeyPreview : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_KeyPreview();
public: __property void set_KeyPreview(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool KeyPreview {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


KeyUp Event

[image]
Intersoft WebEssentials Documentation
KeyUp Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : KeyUp Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a key is released.")>
<SRCategoryAttribute("Key")>
Public Event KeyUp As System.Windows.Forms.KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyUp, handler
C#
[SRDescriptionAttribute("Occurs when a key is released.")]
[SRCategoryAttribute("Key")]
public event System.Windows.Forms.KeyEventHandler KeyUp
Delphi
public event KeyUp: System.Windows.Forms.KeyEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a key is released.")]
[SRCategoryAttribute("Key")]
public: __event System.Windows.Forms.KeyEventHandler* KeyUp
C++/CLI
[SRDescriptionAttribute("Occurs when a key is released.")]
[SRCategoryAttribute("Key")]
public:
event System.Windows.Forms.KeyEventHandler^ KeyUp

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Layout Event

[image]
Intersoft WebEssentials Documentation
Layout Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Layout Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")>
Public Event Layout As System.Windows.Forms.LayoutEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.LayoutEventHandler

AddHandler instance.Layout, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")]
public event System.Windows.Forms.LayoutEventHandler Layout
Delphi
public event Layout: System.Windows.Forms.LayoutEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")]
public: __event System.Windows.Forms.LayoutEventHandler* Layout
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")]
public:
event System.Windows.Forms.LayoutEventHandler^ Layout

Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


LayoutMdi Method

[image]
Intersoft WebEssentials Documentation
LayoutMdi Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : LayoutMdi Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub LayoutMdi( _
   ByVal value As System.Windows.Forms.MdiLayout _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.MdiLayout

instance.LayoutMdi(value)
C#
public void LayoutMdi(
   System.Windows.Forms.MdiLayout value
)
Delphi
public procedure LayoutMdi(
    value: System.Windows.Forms.MdiLayout
);
JScript
public function LayoutMdi(
   value : System.Windows.Forms.MdiLayout
);
Managed Extensions for C++
public: void LayoutMdi(
   System.Windows.Forms.MdiLayout value
)
C++/CLI
public:
void LayoutMdi(
   System.Windows.Forms.MdiLayout value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Leave Event

[image]
Intersoft WebEssentials Documentation
Leave Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Leave Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")>
Public Event Leave As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Leave, handler
C#
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")]
public event System.EventHandler Leave
Delphi
public event Leave: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")]
public: __event System.EventHandler* Leave
C++/CLI
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")]
public:
event System.EventHandler^ Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Load Event

[image]
Intersoft WebEssentials Documentation
Load Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the user loads the form.")>
<SRCategoryAttribute("Behavior")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[SRDescriptionAttribute("Occurs whenever the user loads the form.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the user loads the form.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* Load
C++/CLI
[SRDescriptionAttribute("Occurs whenever the user loads the form.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Location Property

[image]
Intersoft WebEssentials Documentation
Location Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Location Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.SettingsBindableAttribute(True)>
Public Property Location As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
C#
[System.ComponentModel.SettingsBindableAttribute(true)]
public System.Drawing.Point Location {get; set;}
Delphi
public read-write property Location: System.Drawing.Point;
JScript
System.ComponentModel.SettingsBindableAttribute()
public function get,set Location : System.Drawing.Point
Managed Extensions for C++
[System.ComponentModel.SettingsBindableAttribute(true)]
public: __property System.Drawing.Point get_Location();
public: __property void set_Location(
   System.Drawing.Point value
);
C++/CLI
[System.ComponentModel.SettingsBindableAttribute(true)]
public:
property System.Drawing.Point Location {
   System.Drawing.Point get();
   void set (    System.Drawing.Point value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


LocationChanged Event

[image]
Intersoft WebEssentials Documentation
LocationChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : LocationChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")>
Public Event LocationChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.LocationChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")]
public event System.EventHandler LocationChanged
Delphi
public event LocationChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")]
public: __event System.EventHandler* LocationChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")]
public:
event System.EventHandler^ LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MainMenuStrip Property

[image]
Intersoft WebEssentials Documentation
MainMenuStrip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MainMenuStrip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")>
Public Property MainMenuStrip As System.Windows.Forms.MenuStrip
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.MenuStrip

instance.MainMenuStrip = value

value = instance.MainMenuStrip
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")]
public System.Windows.Forms.MenuStrip MainMenuStrip {get; set;}
Delphi
public read-write property MainMenuStrip: System.Windows.Forms.MenuStrip;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")
public function get,set MainMenuStrip : System.Windows.Forms.MenuStrip
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")]
public: __property System.Windows.Forms.MenuStrip* get_MainMenuStrip();
public: __property void set_MainMenuStrip(
   System.Windows.Forms.MenuStrip* value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")]
public:
property System.Windows.Forms.MenuStrip^ MainMenuStrip {
   System.Windows.Forms.MenuStrip^ get();
   void set (    System.Windows.Forms.MenuStrip^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MaximizeBox Property

[image]
Intersoft WebEssentials Documentation
MaximizeBox Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MaximizeBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MaximizeBox As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.MaximizeBox = value

value = instance.MaximizeBox
C#
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool MaximizeBox {get; set;}
Delphi
public read-write property MaximizeBox: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")
System.ComponentModel.DefaultValueAttribute()
public function get,set MaximizeBox : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_MaximizeBox();
public: __property void set_MaximizeBox(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool MaximizeBox {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MaximizedBoundsChanged Event

[image]
Intersoft WebEssentials Documentation
MaximizedBoundsChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MaximizedBoundsChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")>
<SRCategoryAttribute("Property Changed")>
Public Event MaximizedBoundsChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MaximizedBoundsChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler MaximizedBoundsChanged
Delphi
public event MaximizedBoundsChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* MaximizedBoundsChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ MaximizedBoundsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MaximumSize Property

[image]
Intersoft WebEssentials Documentation
MaximumSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MaximumSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("The maximum size the form can be resized to.")>
Public Overridable Property MaximumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The maximum size the form can be resized to.")]
public virtual System.Drawing.Size MaximumSize {get; set;}
Delphi
public read-write property MaximumSize: System.Drawing.Size; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
SRCategoryAttribute("Layout")
SRDescriptionAttribute("The maximum size the form can be resized to.")
public function get,set MaximumSize : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The maximum size the form can be resized to.")]
public: __property virtual System.Drawing.Size get_MaximumSize();
public: __property virtual void set_MaximumSize(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The maximum size the form can be resized to.")]
public:
virtual property System.Drawing.Size MaximumSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MaximumSizeChanged Event

[image]
Intersoft WebEssentials Documentation
MaximumSizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MaximumSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")>
Public Event MaximumSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MaximumSizeChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")]
public event System.EventHandler MaximumSizeChanged
Delphi
public event MaximumSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")]
public: __event System.EventHandler* MaximumSizeChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")]
public:
event System.EventHandler^ MaximumSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MdiChildActivate Event

[image]
Intersoft WebEssentials Documentation
MdiChildActivate Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MdiChildActivate Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when an MDI Child window is activated.")>
Public Event MdiChildActivate As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MdiChildActivate, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when an MDI Child window is activated.")]
public event System.EventHandler MdiChildActivate
Delphi
public event MdiChildActivate: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when an MDI Child window is activated.")]
public: __event System.EventHandler* MdiChildActivate
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when an MDI Child window is activated.")]
public:
event System.EventHandler^ MdiChildActivate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MinimizeBox Property

[image]
Intersoft WebEssentials Documentation
MinimizeBox Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MinimizeBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")>
Public Property MinimizeBox As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.MinimizeBox = value

value = instance.MinimizeBox
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public System.bool MinimizeBox {get; set;}
Delphi
public read-write property MinimizeBox: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")
public function get,set MinimizeBox : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public: __property System.bool get_MinimizeBox();
public: __property void set_MinimizeBox(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public:
property System.bool MinimizeBox {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MinimumSize Property

[image]
Intersoft WebEssentials Documentation
MinimumSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MinimumSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The minimum size the form can be resized to.")>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Overridable Property MinimumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
[SRDescriptionAttribute("The minimum size the form can be resized to.")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
public virtual System.Drawing.Size MinimumSize {get; set;}
Delphi
public read-write property MinimumSize: System.Drawing.Size; virtual;
JScript
SRDescriptionAttribute("The minimum size the form can be resized to.")
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
SRCategoryAttribute("Layout")
System.ComponentModel.LocalizableAttribute()
public function get,set MinimumSize : System.Drawing.Size
Managed Extensions for C++
[SRDescriptionAttribute("The minimum size the form can be resized to.")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property virtual System.Drawing.Size get_MinimumSize();
public: __property virtual void set_MinimumSize(
   System.Drawing.Size value
);
C++/CLI
[SRDescriptionAttribute("The minimum size the form can be resized to.")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
virtual property System.Drawing.Size MinimumSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MinimumSizeChanged Event

[image]
Intersoft WebEssentials Documentation
MinimumSizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MinimumSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")>
<SRCategoryAttribute("Property Changed")>
Public Event MinimumSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MinimumSizeChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler MinimumSizeChanged
Delphi
public event MinimumSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* MinimumSizeChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ MinimumSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MouseCaptureChanged Event

[image]
Intersoft WebEssentials Documentation
MouseCaptureChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MouseCaptureChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs after the mouse capture is changed.")>
<SRCategoryAttribute("Action")>
Public Event MouseCaptureChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MouseCaptureChanged, handler
C#
[SRDescriptionAttribute("Occurs after the mouse capture is changed.")]
[SRCategoryAttribute("Action")]
public event System.EventHandler MouseCaptureChanged
Delphi
public event MouseCaptureChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs after the mouse capture is changed.")]
[SRCategoryAttribute("Action")]
public: __event System.EventHandler* MouseCaptureChanged
C++/CLI
[SRDescriptionAttribute("Occurs after the mouse capture is changed.")]
[SRCategoryAttribute("Action")]
public:
event System.EventHandler^ MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MouseClick Event

[image]
Intersoft WebEssentials Documentation
MouseClick Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MouseClick Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")>
<SRCategoryAttribute("Action")>
Public Event MouseClick As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseClick, handler
C#
[SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")]
[SRCategoryAttribute("Action")]
public event System.Windows.Forms.MouseEventHandler MouseClick
Delphi
public event MouseClick: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")]
[SRCategoryAttribute("Action")]
public: __event System.Windows.Forms.MouseEventHandler* MouseClick
C++/CLI
[SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")]
[SRCategoryAttribute("Action")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MouseDoubleClick Event

[image]
Intersoft WebEssentials Documentation
MouseDoubleClick Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MouseDoubleClick Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")>
Public Event MouseDoubleClick As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDoubleClick, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")]
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick
Delphi
public event MouseDoubleClick: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")]
public: __event System.Windows.Forms.MouseEventHandler* MouseDoubleClick
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseDoubleClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MouseDown Event

[image]
Intersoft WebEssentials Documentation
MouseDown Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MouseDown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseDown As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDown, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")]
[SRCategoryAttribute("Mouse")]
public event System.Windows.Forms.MouseEventHandler MouseDown
Delphi
public event MouseDown: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")]
[SRCategoryAttribute("Mouse")]
public: __event System.Windows.Forms.MouseEventHandler* MouseDown
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")]
[SRCategoryAttribute("Mouse")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseDown

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MouseEnter Event

[image]
Intersoft WebEssentials Documentation
MouseEnter Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MouseEnter Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseEnter As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MouseEnter, handler
C#
[SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")]
[SRCategoryAttribute("Mouse")]
public event System.EventHandler MouseEnter
Delphi
public event MouseEnter: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")]
[SRCategoryAttribute("Mouse")]
public: __event System.EventHandler* MouseEnter
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")]
[SRCategoryAttribute("Mouse")]
public:
event System.EventHandler^ MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MouseHover Event

[image]
Intersoft WebEssentials Documentation
MouseHover Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MouseHover Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")>
Public Event MouseHover As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MouseHover, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")]
public event System.EventHandler MouseHover
Delphi
public event MouseHover: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")]
public: __event System.EventHandler* MouseHover
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")]
public:
event System.EventHandler^ MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MouseLeave Event

[image]
Intersoft WebEssentials Documentation
MouseLeave Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MouseLeave Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")>
Public Event MouseLeave As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.MouseLeave, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")]
public event System.EventHandler MouseLeave
Delphi
public event MouseLeave: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")]
public: __event System.EventHandler* MouseLeave
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")]
public:
event System.EventHandler^ MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MouseMove Event

[image]
Intersoft WebEssentials Documentation
MouseMove Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MouseMove Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseMove As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseMove, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")]
[SRCategoryAttribute("Mouse")]
public event System.Windows.Forms.MouseEventHandler MouseMove
Delphi
public event MouseMove: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")]
[SRCategoryAttribute("Mouse")]
public: __event System.Windows.Forms.MouseEventHandler* MouseMove
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")]
[SRCategoryAttribute("Mouse")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseMove

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


MouseUp Event

[image]
Intersoft WebEssentials Documentation
MouseUp Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : MouseUp Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseUp As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseUp, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")]
[SRCategoryAttribute("Mouse")]
public event System.Windows.Forms.MouseEventHandler MouseUp
Delphi
public event MouseUp: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")]
[SRCategoryAttribute("Mouse")]
public: __event System.Windows.Forms.MouseEventHandler* MouseUp
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")]
[SRCategoryAttribute("Mouse")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseUp

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Move Event

[image]
Intersoft WebEssentials Documentation
Move Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Move Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when a control is moved.")>
Public Event Move As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Move, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when a control is moved.")]
public event System.EventHandler Move
Delphi
public event Move: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when a control is moved.")]
public: __event System.EventHandler* Move
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when a control is moved.")]
public:
event System.EventHandler^ Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Opacity Property

[image]
Intersoft WebEssentials Documentation
Opacity Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Opacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("The opacity percentage of the control. ")>
<System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property Opacity As System.Double
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Double

instance.Opacity = value

value = instance.Opacity
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The opacity percentage of the control. ")]
[System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public System.double Opacity {get; set;}
Delphi
public read-write property Opacity: System.Double;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("The opacity percentage of the control. ")
System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set Opacity : System.double
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The opacity percentage of the control. ")]
[System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property System.double get_Opacity();
public: __property void set_Opacity(
   System.double value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The opacity percentage of the control. ")]
[System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property System.double Opacity {
   System.double get();
   void set (    System.double value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Padding Property

[image]
Intersoft WebEssentials Documentation
Padding Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Padding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Specifies the interior spacing of a control.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
Public Property Padding As System.Windows.Forms.Padding
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.Padding

instance.Padding = value

value = instance.Padding
C#
[SRDescriptionAttribute("Specifies the interior spacing of a control.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public System.Windows.Forms.Padding Padding {get; set;}
Delphi
public read-write property Padding: System.Windows.Forms.Padding;
JScript
SRDescriptionAttribute("Specifies the interior spacing of a control.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Layout")
public function get,set Padding : System.Windows.Forms.Padding
Managed Extensions for C++
[SRDescriptionAttribute("Specifies the interior spacing of a control.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public: __property System.Windows.Forms.Padding get_Padding();
public: __property void set_Padding(
   System.Windows.Forms.Padding value
);
C++/CLI
[SRDescriptionAttribute("Specifies the interior spacing of a control.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public:
property System.Windows.Forms.Padding Padding {
   System.Windows.Forms.Padding get();
   void set (    System.Windows.Forms.Padding value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


PaddingChanged Event

[image]
Intersoft WebEssentials Documentation
PaddingChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : PaddingChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when the Padding property has changed.")>
Public Event PaddingChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.PaddingChanged, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the Padding property has changed.")]
public event System.EventHandler PaddingChanged
Delphi
public event PaddingChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the Padding property has changed.")]
public: __event System.EventHandler* PaddingChanged
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the Padding property has changed.")]
public:
event System.EventHandler^ PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Paint Event

[image]
Intersoft WebEssentials Documentation
Paint Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Paint Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a control needs repainting.")>
<SRCategoryAttribute("Appearance")>
Public Event Paint As System.Windows.Forms.PaintEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.PaintEventHandler

AddHandler instance.Paint, handler
C#
[SRDescriptionAttribute("Occurs when a control needs repainting.")]
[SRCategoryAttribute("Appearance")]
public event System.Windows.Forms.PaintEventHandler Paint
Delphi
public event Paint: System.Windows.Forms.PaintEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a control needs repainting.")]
[SRCategoryAttribute("Appearance")]
public: __event System.Windows.Forms.PaintEventHandler* Paint
C++/CLI
[SRDescriptionAttribute("Occurs when a control needs repainting.")]
[SRCategoryAttribute("Appearance")]
public:
event System.Windows.Forms.PaintEventHandler^ Paint

Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ParentChanged Event

[image]
Intersoft WebEssentials Documentation
ParentChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ParentChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")>
Public Event ParentChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.ParentChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public event System.EventHandler ParentChanged
Delphi
public event ParentChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public: __event System.EventHandler* ParentChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public:
event System.EventHandler^ ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


PerformAutoScale Method

[image]
Intersoft WebEssentials Documentation
PerformAutoScale Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : PerformAutoScale Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Sub PerformAutoScale()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.PerformAutoScale()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void PerformAutoScale()
Delphi
public procedure PerformAutoScale();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function PerformAutoScale();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void PerformAutoScale();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void PerformAutoScale();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


PerformLayout Method

[image]
Intersoft WebEssentials Documentation
PerformLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : PerformLayout Method

Glossary Item Box

Overload List

Overload | Description
PerformLayout() | (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


PerformLayout() Method

[image]
Intersoft WebEssentials Documentation
PerformLayout() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Sub PerformLayout()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.PerformLayout()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void PerformLayout()
Delphi
public procedure PerformLayout();
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function PerformLayout();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void PerformLayout();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void PerformLayout();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


PerformLayout(Control,String) Method

[image]
Intersoft WebEssentials Documentation
PerformLayout(Control,String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
affectedProperty

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As System.Windows.Forms.Control, _
   ByVal affectedProperty As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim affectedControl As System.Windows.Forms.Control
Dim affectedProperty As System.String

instance.PerformLayout(affectedControl, affectedProperty)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)
Delphi
public procedure PerformLayout(
    affectedControl: System.Windows.Forms.Control;
    affectedProperty: System.String
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function PerformLayout(
   affectedControl : System.Windows.Forms.Control,
   affectedProperty : System.String
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void PerformLayout(
   System.Windows.Forms.Control* affectedControl,
   System.string* affectedProperty
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void PerformLayout(
   System.Windows.Forms.Control^ affectedControl,
   System.String^ affectedProperty
)

Parameters

affectedControl
affectedProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


PointToClient Method

[image]
Intersoft WebEssentials Documentation
PointToClient Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : PointToClient Method

p

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Function PointToClient( _
   ByVal p As System.Drawing.Point _
) As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToClient(p)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Drawing.Point PointToClient(
   System.Drawing.Point p
)
Delphi
public function PointToClient(
    p: System.Drawing.Point
): System.Drawing.Point;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function PointToClient(
   p : System.Drawing.Point
) : System.Drawing.Point;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Drawing.Point PointToClient(
   System.Drawing.Point p
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Drawing.Point PointToClient(
   System.Drawing.Point p
)

Parameters

p

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


PointToScreen Method

[image]
Intersoft WebEssentials Documentation
PointToScreen Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : PointToScreen Method

p

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As System.Drawing.Point _
) As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToScreen(p)
C#
public System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)
Delphi
public function PointToScreen(
    p: System.Drawing.Point
): System.Drawing.Point;
JScript
public function PointToScreen(
   p : System.Drawing.Point
) : System.Drawing.Point;
Managed Extensions for C++
public: System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)
C++/CLI
public:
System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)

Parameters

p

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


PreProcessControlMessage Method

[image]
Intersoft WebEssentials Documentation
PreProcessControlMessage Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : PreProcessControlMessage Method

msg

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
Public Function PreProcessControlMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Windows.Forms.PreProcessControlState
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim msg As System.Windows.Forms.Message
Dim value As System.Windows.Forms.PreProcessControlState

value = instance.PreProcessControlMessage(msg)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)
Delphi
public function PreProcessControlMessage(
   var  msg: System.Windows.Forms.Message
): System.Windows.Forms.PreProcessControlState;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
public function PreProcessControlMessage(
   msg : System.Windows.Forms.Message
) : System.Windows.Forms.PreProcessControlState;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public: System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public:
System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   System.Windows.Forms.Message% msg
)

Parameters

msg

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


PreProcessMessage Method

[image]
Intersoft WebEssentials Documentation
PreProcessMessage Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : PreProcessMessage Method

msg

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Overridable Function PreProcessMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim msg As System.Windows.Forms.Message
Dim value As System.Boolean

value = instance.PreProcessMessage(msg)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)
Delphi
public function PreProcessMessage(
   var  msg: System.Windows.Forms.Message
): System.Boolean; virtual;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public function PreProcessMessage(
   msg : System.Windows.Forms.Message
) : System.boolean;
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public: virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public:
virtual System.bool PreProcessMessage(
   System.Windows.Forms.Message% msg
)

Parameters

msg

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


PreviewKeyDown Event

[image]
Intersoft WebEssentials Documentation
PreviewKeyDown Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : PreviewKeyDown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Key")>
<SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")>
Public Event PreviewKeyDown As System.Windows.Forms.PreviewKeyDownEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.PreviewKeyDownEventHandler

AddHandler instance.PreviewKeyDown, handler
C#
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")]
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown
Delphi
public event PreviewKeyDown: System.Windows.Forms.PreviewKeyDownEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")]
public: __event System.Windows.Forms.PreviewKeyDownEventHandler* PreviewKeyDown
C++/CLI
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")]
public:
event System.Windows.Forms.PreviewKeyDownEventHandler^ PreviewKeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


QueryAccessibilityHelp Event

[image]
Intersoft WebEssentials Documentation
QueryAccessibilityHelp Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : QueryAccessibilityHelp Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")>
Public Event QueryAccessibilityHelp As System.Windows.Forms.QueryAccessibilityHelpEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.QueryAccessibilityHelpEventHandler

AddHandler instance.QueryAccessibilityHelp, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")]
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp
Delphi
public event QueryAccessibilityHelp: System.Windows.Forms.QueryAccessibilityHelpEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")]
public: __event System.Windows.Forms.QueryAccessibilityHelpEventHandler* QueryAccessibilityHelp
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")]
public:
event System.Windows.Forms.QueryAccessibilityHelpEventHandler^ QueryAccessibilityHelp

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


QueryContinueDrag Event

[image]
Intersoft WebEssentials Documentation
QueryContinueDrag Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : QueryContinueDrag Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")>
<SRCategoryAttribute("Drag Drop")>
Public Event QueryContinueDrag As System.Windows.Forms.QueryContinueDragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.QueryContinueDragEventHandler

AddHandler instance.QueryContinueDrag, handler
C#
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")]
[SRCategoryAttribute("Drag Drop")]
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag
Delphi
public event QueryContinueDrag: System.Windows.Forms.QueryContinueDragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")]
[SRCategoryAttribute("Drag Drop")]
public: __event System.Windows.Forms.QueryContinueDragEventHandler* QueryContinueDrag
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")]
[SRCategoryAttribute("Drag Drop")]
public:
event System.Windows.Forms.QueryContinueDragEventHandler^ QueryContinueDrag

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


RectangleToClient Method

[image]
Intersoft WebEssentials Documentation
RectangleToClient Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : RectangleToClient Method

r

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As System.Drawing.Rectangle _
) As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToClient(r)
C#
public System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)
Delphi
public function RectangleToClient(
    r: System.Drawing.Rectangle
): System.Drawing.Rectangle;
JScript
public function RectangleToClient(
   r : System.Drawing.Rectangle
) : System.Drawing.Rectangle;
Managed Extensions for C++
public: System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)
C++/CLI
public:
System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)

Parameters

r

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


RectangleToScreen Method

[image]
Intersoft WebEssentials Documentation
RectangleToScreen Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : RectangleToScreen Method

r

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As System.Drawing.Rectangle _
) As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToScreen(r)
C#
public System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)
Delphi
public function RectangleToScreen(
    r: System.Drawing.Rectangle
): System.Drawing.Rectangle;
JScript
public function RectangleToScreen(
   r : System.Drawing.Rectangle
) : System.Drawing.Rectangle;
Managed Extensions for C++
public: System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)
C++/CLI
public:
System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)

Parameters

r

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Refresh Method

[image]
Intersoft WebEssentials Documentation
Refresh Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Refresh Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.Refresh()
C#
public virtual void Refresh()
Delphi
public procedure Refresh(); virtual;
JScript
public function Refresh();
Managed Extensions for C++
public: virtual void Refresh();
C++/CLI
public:
virtual void Refresh();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


RegionChanged Event

[image]
Intersoft WebEssentials Documentation
RegionChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : RegionChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event RegionChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.RegionChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler RegionChanged
Delphi
public event RegionChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* RegionChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


RemoveOwnedForm Method

[image]
Intersoft WebEssentials Documentation
RemoveOwnedForm Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : RemoveOwnedForm Method

ownedForm

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RemoveOwnedForm( _
   ByVal ownedForm As System.Windows.Forms.Form _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim ownedForm As System.Windows.Forms.Form

instance.RemoveOwnedForm(ownedForm)
C#
public void RemoveOwnedForm(
   System.Windows.Forms.Form ownedForm
)
Delphi
public procedure RemoveOwnedForm(
    ownedForm: System.Windows.Forms.Form
);
JScript
public function RemoveOwnedForm(
   ownedForm : System.Windows.Forms.Form
);
Managed Extensions for C++
public: void RemoveOwnedForm(
   System.Windows.Forms.Form* ownedForm
)
C++/CLI
public:
void RemoveOwnedForm(
   System.Windows.Forms.Form^ ownedForm
)

Parameters

ownedForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ResetText Method

[image]
Intersoft WebEssentials Documentation
ResetText Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ResetText Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetText()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.ResetText()
C#
public virtual void ResetText()
Delphi
public procedure ResetText(); virtual;
JScript
public function ResetText();
Managed Extensions for C++
public: virtual void ResetText();
C++/CLI
public:
virtual void ResetText();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Resize Event

[image]
Intersoft WebEssentials Documentation
Resize Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Resize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Occurs when a control is resized.")>
Public Event Resize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Resize, handler
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when a control is resized.")]
public event System.EventHandler Resize
Delphi
public event Resize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when a control is resized.")]
public: __event System.EventHandler* Resize
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when a control is resized.")]
public:
event System.EventHandler^ Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ResizeBegin Event

[image]
Intersoft WebEssentials Documentation
ResizeBegin Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ResizeBegin Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")>
<SRCategoryAttribute("Action")>
Public Event ResizeBegin As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.ResizeBegin, handler
C#
[SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")]
[SRCategoryAttribute("Action")]
public event System.EventHandler ResizeBegin
Delphi
public event ResizeBegin: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")]
[SRCategoryAttribute("Action")]
public: __event System.EventHandler* ResizeBegin
C++/CLI
[SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")]
[SRCategoryAttribute("Action")]
public:
event System.EventHandler^ ResizeBegin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ResizeEnd Event

[image]
Intersoft WebEssentials Documentation
ResizeEnd Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ResizeEnd Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")>
Public Event ResizeEnd As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.ResizeEnd, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")]
public event System.EventHandler ResizeEnd
Delphi
public event ResizeEnd: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")]
public: __event System.EventHandler* ResizeEnd
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")]
public:
event System.EventHandler^ ResizeEnd

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ResumeLayout Method

[image]
Intersoft WebEssentials Documentation
ResumeLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ResumeLayout Method

Glossary Item Box

Overload List

Overload | Description
ResumeLayout() | (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ResumeLayout() Method

[image]
Intersoft WebEssentials Documentation
ResumeLayout() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub ResumeLayout()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.ResumeLayout()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void ResumeLayout()
Delphi
public procedure ResumeLayout();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ResumeLayout();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void ResumeLayout();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void ResumeLayout();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


ResumeLayout(Boolean) Method

[image]
Intersoft WebEssentials Documentation
ResumeLayout(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim performLayout As System.Boolean

instance.ResumeLayout(performLayout)
C#
public void ResumeLayout(
   System.bool performLayout
)
Delphi
public procedure ResumeLayout(
    performLayout: System.Boolean
);
JScript
public function ResumeLayout(
   performLayout : System.boolean
);
Managed Extensions for C++
public: void ResumeLayout(
   System.bool performLayout
)
C++/CLI
public:
void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


RightToLeft Property

[image]
Intersoft WebEssentials Documentation
RightToLeft Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : RightToLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")>
Public Overridable Property RightToLeft As System.Windows.Forms.RightToLeft
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
C#
[System.ComponentModel.AmbientValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}
Delphi
public read-write property RightToLeft: System.Windows.Forms.RightToLeft; virtual;
JScript
System.ComponentModel.AmbientValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Appearance")
SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")
public function get,set RightToLeft : System.Windows.Forms.RightToLeft
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
public: __property virtual System.Windows.Forms.RightToLeft get_RightToLeft();
public: __property virtual void set_RightToLeft(
   System.Windows.Forms.RightToLeft value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
public:
virtual property System.Windows.Forms.RightToLeft RightToLeft {
   System.Windows.Forms.RightToLeft get();
   void set (    System.Windows.Forms.RightToLeft value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


RightToLeftChanged Event

[image]
Intersoft WebEssentials Documentation
RightToLeftChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : RightToLeftChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event RightToLeftChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.RightToLeftChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler RightToLeftChanged
Delphi
public event RightToLeftChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* RightToLeftChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


RightToLeftLayout Property

[image]
Intersoft WebEssentials Documentation
RightToLeftLayout Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : RightToLeftLayout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")>
Public Overridable Property RightToLeftLayout As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.RightToLeftLayout = value

value = instance.RightToLeftLayout
C#
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")]
public virtual System.bool RightToLeftLayout {get; set;}
Delphi
public read-write property RightToLeftLayout: System.Boolean; virtual;
JScript
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")
public function get,set RightToLeftLayout : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")]
public: __property virtual System.bool get_RightToLeftLayout();
public: __property virtual void set_RightToLeftLayout(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")]
public:
virtual property System.bool RightToLeftLayout {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


RightToLeftLayoutChanged Event

[image]
Intersoft WebEssentials Documentation
RightToLeftLayoutChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : RightToLeftLayoutChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event RightToLeftLayoutChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.RightToLeftLayoutChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler RightToLeftLayoutChanged
Delphi
public event RightToLeftLayoutChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* RightToLeftLayoutChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ RightToLeftLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Scale Method

[image]
Intersoft WebEssentials Documentation
Scale Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Scale Method

Glossary Item Box

Overload List

Overload | Description
Scale | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Scale(SizeF) Method

[image]
Intersoft WebEssentials Documentation
Scale(SizeF) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > Scale Method : Scale(SizeF) Method

factor

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Sub Scale( _
   ByVal factor As System.Drawing.SizeF _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim factor As System.Drawing.SizeF

instance.Scale(factor)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void Scale(
   System.Drawing.SizeF factor
)
Delphi
public procedure Scale(
    factor: System.Drawing.SizeF
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function Scale(
   factor : System.Drawing.SizeF
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void Scale(
   System.Drawing.SizeF factor
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void Scale(
   System.Drawing.SizeF factor
)

Parameters

factor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


Scroll Event

[image]
Intersoft WebEssentials Documentation
Scroll Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Scroll Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the user moves the scroll box.")>
Public Event Scroll As System.Windows.Forms.ScrollEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.Windows.Forms.ScrollEventHandler

AddHandler instance.Scroll, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user moves the scroll box.")]
public event System.Windows.Forms.ScrollEventHandler Scroll
Delphi
public event Scroll: System.Windows.Forms.ScrollEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user moves the scroll box.")]
public: __event System.Windows.Forms.ScrollEventHandler* Scroll
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user moves the scroll box.")]
public:
event System.Windows.Forms.ScrollEventHandler^ Scroll

Event Data

The event handler receives an argument of type System.Windows.Forms.ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ScrollControlIntoView Method

[image]
Intersoft WebEssentials Documentation
ScrollControlIntoView Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ScrollControlIntoView Method

activeControl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ScrollControlIntoView( _
   ByVal activeControl As System.Windows.Forms.Control _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim activeControl As System.Windows.Forms.Control

instance.ScrollControlIntoView(activeControl)
C#
public void ScrollControlIntoView(
   System.Windows.Forms.Control activeControl
)
Delphi
public procedure ScrollControlIntoView(
    activeControl: System.Windows.Forms.Control
);
JScript
public function ScrollControlIntoView(
   activeControl : System.Windows.Forms.Control
);
Managed Extensions for C++
public: void ScrollControlIntoView(
   System.Windows.Forms.Control* activeControl
)
C++/CLI
public:
void ScrollControlIntoView(
   System.Windows.Forms.Control^ activeControl
)

Parameters

activeControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Select Method

[image]
Intersoft WebEssentials Documentation
Select Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Select Method

Glossary Item Box

Overload List

Overload | Description
Select | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Select() Method

[image]
Intersoft WebEssentials Documentation
Select() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Select() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Sub Select()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.Select()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Select()
Delphi
public procedure Select();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Select();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Select();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Select();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


SelectNextControl Method

[image]
Intersoft WebEssentials Documentation
SelectNextControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : SelectNextControl Method

ctl
forward
tabStopOnly
nested
wrap

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean, _
   ByVal tabStopOnly As System.Boolean, _
   ByVal nested As System.Boolean, _
   ByVal wrap As System.Boolean _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim tabStopOnly As System.Boolean
Dim nested As System.Boolean
Dim wrap As System.Boolean
Dim value As System.Boolean

value = instance.SelectNextControl(ctl, forward, tabStopOnly, nested, wrap)
C#
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)
Delphi
public function SelectNextControl(
    ctl: System.Windows.Forms.Control;
    forward: System.Boolean;
    tabStopOnly: System.Boolean;
    nested: System.Boolean;
    wrap: System.Boolean
): System.Boolean;
JScript
public function SelectNextControl(
   ctl : System.Windows.Forms.Control,
   forward : System.boolean,
   tabStopOnly : System.boolean,
   nested : System.boolean,
   wrap : System.boolean
) : System.boolean;
Managed Extensions for C++
public: System.bool SelectNextControl(
   System.Windows.Forms.Control* ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)
C++/CLI
public:
System.bool SelectNextControl(
   System.Windows.Forms.Control^ ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
forward
tabStopOnly
nested
wrap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


SendToBack Method

[image]
Intersoft WebEssentials Documentation
SendToBack Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : SendToBack Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.SendToBack()
C#
public void SendToBack()
Delphi
public procedure SendToBack();
JScript
public function SendToBack();
Managed Extensions for C++
public: void SendToBack();
C++/CLI
public:
void SendToBack();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


SetAutoScrollMargin Method

[image]
Intersoft WebEssentials Documentation
SetAutoScrollMargin Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : SetAutoScrollMargin Method

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetAutoScrollMargin( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim x As System.Integer
Dim y As System.Integer

instance.SetAutoScrollMargin(x, y)
C#
public void SetAutoScrollMargin(
   System.int x,
   System.int y
)
Delphi
public procedure SetAutoScrollMargin(
    x: System.Integer;
    y: System.Integer
);
JScript
public function SetAutoScrollMargin(
   x : System.int,
   y : System.int
);
Managed Extensions for C++
public: void SetAutoScrollMargin(
   System.int x,
   System.int y
)
C++/CLI
public:
void SetAutoScrollMargin(
   System.int x,
   System.int y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


SetBounds Method

[image]
Intersoft WebEssentials Documentation
SetBounds Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : SetBounds Method

Glossary Item Box

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


SetBounds(Int32,Int32,Int32,Int32) Method

[image]
Intersoft WebEssentials Documentation
SetBounds(Int32,Int32,Int32,Int32) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
y
width
height

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetBounds(x, y, width, height)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
Delphi
public procedure SetBounds(
    x: System.Integer;
    y: System.Integer;
    width: System.Integer;
    height: System.Integer
);
JScript
public function SetBounds(
   x : System.int,
   y : System.int,
   width : System.int,
   height : System.int
);
Managed Extensions for C++
public: void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
C++/CLI
public:
void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

[image]
Intersoft WebEssentials Documentation
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
y
width
height
specified

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer, _
   ByVal specified As System.Windows.Forms.BoundsSpecified _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer
Dim specified As System.Windows.Forms.BoundsSpecified

instance.SetBounds(x, y, width, height, specified)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)
Delphi
public procedure SetBounds(
    x: System.Integer;
    y: System.Integer;
    width: System.Integer;
    height: System.Integer;
    specified: System.Windows.Forms.BoundsSpecified
);
JScript
public function SetBounds(
   x : System.int,
   y : System.int,
   width : System.int,
   height : System.int,
   specified : System.Windows.Forms.BoundsSpecified
);
Managed Extensions for C++
public: void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)
C++/CLI
public:
void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
y
width
height
specified

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


SetDesktopBounds Method

[image]
Intersoft WebEssentials Documentation
SetDesktopBounds Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : SetDesktopBounds Method

x
y
width
height

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDesktopBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetDesktopBounds(x, y, width, height)
C#
public void SetDesktopBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
Delphi
public procedure SetDesktopBounds(
    x: System.Integer;
    y: System.Integer;
    width: System.Integer;
    height: System.Integer
);
JScript
public function SetDesktopBounds(
   x : System.int,
   y : System.int,
   width : System.int,
   height : System.int
);
Managed Extensions for C++
public: void SetDesktopBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
C++/CLI
public:
void SetDesktopBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


SetDesktopLocation Method

[image]
Intersoft WebEssentials Documentation
SetDesktopLocation Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : SetDesktopLocation Method

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDesktopLocation( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim x As System.Integer
Dim y As System.Integer

instance.SetDesktopLocation(x, y)
C#
public void SetDesktopLocation(
   System.int x,
   System.int y
)
Delphi
public procedure SetDesktopLocation(
    x: System.Integer;
    y: System.Integer
);
JScript
public function SetDesktopLocation(
   x : System.int,
   y : System.int
);
Managed Extensions for C++
public: void SetDesktopLocation(
   System.int x,
   System.int y
)
C++/CLI
public:
void SetDesktopLocation(
   System.int x,
   System.int y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Show Method

[image]
Intersoft WebEssentials Documentation
Show Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Show Method

Glossary Item Box

Overload List

Overload | Description
Show(IWin32Window) | (Inherited from System.Windows.Forms.Form)
Show() | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Show() Method

[image]
Intersoft WebEssentials Documentation
Show() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > Show Method : Show() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Show()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.Show()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Show()
Delphi
public procedure Show();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Show();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Show();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Show();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


Show(IWin32Window) Method

[image]
Intersoft WebEssentials Documentation
Show(IWin32Window) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > Show Method : Show(IWin32Window) Method

owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Show( _
   ByVal owner As System.Windows.Forms.IWin32Window _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim owner As System.Windows.Forms.IWin32Window

instance.Show(owner)
C#
public void Show(
   System.Windows.Forms.IWin32Window owner
)
Delphi
public procedure Show(
    owner: System.Windows.Forms.IWin32Window
);
JScript
public function Show(
   owner : System.Windows.Forms.IWin32Window
);
Managed Extensions for C++
public: void Show(
   System.Windows.Forms.IWin32Window* owner
)
C++/CLI
public:
void Show(
   System.Windows.Forms.IWin32Window^ owner
)

Parameters

owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


ShowDialog Method

[image]
Intersoft WebEssentials Documentation
ShowDialog Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ShowDialog Method

Glossary Item Box

Overload List

Overload | Description
ShowDialog() | (Inherited from System.Windows.Forms.Form)
ShowDialog(IWin32Window) | (Inherited from System.Windows.Forms.Form)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ShowDialog() Method

[image]
Intersoft WebEssentials Documentation
ShowDialog() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > ShowDialog Method : ShowDialog() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function ShowDialog() As System.Windows.Forms.DialogResult
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.DialogResult

value = instance.ShowDialog()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Windows.Forms.DialogResult ShowDialog()
Delphi
public function ShowDialog(): System.Windows.Forms.DialogResult;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ShowDialog() : System.Windows.Forms.DialogResult;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Windows.Forms.DialogResult ShowDialog();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Windows.Forms.DialogResult ShowDialog();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


ShowDialog(IWin32Window) Method

[image]
Intersoft WebEssentials Documentation
ShowDialog(IWin32Window) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > ShowDialog Method : ShowDialog(IWin32Window) Method

owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowDialog( _
   ByVal owner As System.Windows.Forms.IWin32Window _
) As System.Windows.Forms.DialogResult
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim owner As System.Windows.Forms.IWin32Window
Dim value As System.Windows.Forms.DialogResult

value = instance.ShowDialog(owner)
C#
public System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.IWin32Window owner
)
Delphi
public function ShowDialog(
    owner: System.Windows.Forms.IWin32Window
): System.Windows.Forms.DialogResult;
JScript
public function ShowDialog(
   owner : System.Windows.Forms.IWin32Window
) : System.Windows.Forms.DialogResult;
Managed Extensions for C++
public: System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.IWin32Window* owner
)
C++/CLI
public:
System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.IWin32Window^ owner
)

Parameters

owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


ShowIcon Property

[image]
Intersoft WebEssentials Documentation
ShowIcon Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ShowIcon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")>
Public Property ShowIcon As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.ShowIcon = value

value = instance.ShowIcon
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")]
public System.bool ShowIcon {get; set;}
Delphi
public read-write property ShowIcon: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")
public function get,set ShowIcon : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")]
public: __property System.bool get_ShowIcon();
public: __property void set_ShowIcon(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")]
public:
property System.bool ShowIcon {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ShowInTaskbar Property

[image]
Intersoft WebEssentials Documentation
ShowInTaskbar Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ShowInTaskbar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")>
Public Property ShowInTaskbar As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.ShowInTaskbar = value

value = instance.ShowInTaskbar
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public System.bool ShowInTaskbar {get; set;}
Delphi
public read-write property ShowInTaskbar: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")
public function get,set ShowInTaskbar : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public: __property System.bool get_ShowInTaskbar();
public: __property void set_ShowInTaskbar(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public:
property System.bool ShowInTaskbar {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Shown Event

[image]
Intersoft WebEssentials Documentation
Shown Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Shown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the form is first shown.")>
<SRCategoryAttribute("Behavior")>
Public Event Shown As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Shown, handler
C#
[SRDescriptionAttribute("Occurs whenever the form is first shown.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler Shown
Delphi
public event Shown: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the form is first shown.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* Shown
C++/CLI
[SRDescriptionAttribute("Occurs whenever the form is first shown.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ Shown

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Site Property

[image]
Intersoft WebEssentials Documentation
Site Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Property Site As System.ComponentModel.ISite
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual System.ComponentModel.ISite Site {get; set;}
Delphi
public read-write property Site: System.ComponentModel.ISite; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function get,set Site : System.ComponentModel.ISite
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual property System.ComponentModel.ISite^ Site {
   System.ComponentModel.ISite^ get();
   void set (    System.ComponentModel.ISite^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Size Property

[image]
Intersoft WebEssentials Documentation
Size Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Size Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Size As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Size

instance.Size = value

value = instance.Size
C#
[System.ComponentModel.LocalizableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Drawing.Size Size {get; set;}
Delphi
public read-write property Size: System.Drawing.Size;
JScript
System.ComponentModel.LocalizableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set Size : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Drawing.Size get_Size();
public: __property void set_Size(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Drawing.Size Size {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


SizeChanged Event

[image]
Intersoft WebEssentials Documentation
SizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : SizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event SizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.SizeChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler SizeChanged
Delphi
public event SizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* SizeChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


SizeGripStyle Property

[image]
Intersoft WebEssentials Documentation
SizeGripStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : SizeGripStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")>
Public Property SizeGripStyle As System.Windows.Forms.SizeGripStyle
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.SizeGripStyle

instance.SizeGripStyle = value

value = instance.SizeGripStyle
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")]
public System.Windows.Forms.SizeGripStyle SizeGripStyle {get; set;}
Delphi
public read-write property SizeGripStyle: System.Windows.Forms.SizeGripStyle;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")
public function get,set SizeGripStyle : System.Windows.Forms.SizeGripStyle
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")]
public: __property System.Windows.Forms.SizeGripStyle get_SizeGripStyle();
public: __property void set_SizeGripStyle(
   System.Windows.Forms.SizeGripStyle value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")]
public:
property System.Windows.Forms.SizeGripStyle SizeGripStyle {
   System.Windows.Forms.SizeGripStyle get();
   void set (    System.Windows.Forms.SizeGripStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


StartPosition Property

[image]
Intersoft WebEssentials Documentation
StartPosition Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : StartPosition Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Determines the position of a form when it first appears.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property StartPosition As System.Windows.Forms.FormStartPosition
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.FormStartPosition

instance.StartPosition = value

value = instance.StartPosition
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Windows.Forms.FormStartPosition StartPosition {get; set;}
Delphi
public read-write property StartPosition: System.Windows.Forms.FormStartPosition;
JScript
SRCategoryAttribute("Layout")
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Determines the position of a form when it first appears.")
System.ComponentModel.DefaultValueAttribute()
public function get,set StartPosition : System.Windows.Forms.FormStartPosition
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Windows.Forms.FormStartPosition get_StartPosition();
public: __property void set_StartPosition(
   System.Windows.Forms.FormStartPosition value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Windows.Forms.FormStartPosition StartPosition {
   System.Windows.Forms.FormStartPosition get();
   void set (    System.Windows.Forms.FormStartPosition value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


StyleChanged Event

[image]
Intersoft WebEssentials Documentation
StyleChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : StyleChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the window style of a Control is changed.")>
<SRCategoryAttribute("Behavior")>
Public Event StyleChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.StyleChanged, handler
C#
[SRDescriptionAttribute("Event raised when the window style of a Control is changed.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler StyleChanged
Delphi
public event StyleChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the window style of a Control is changed.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* StyleChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the window style of a Control is changed.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


SuspendLayout Method

[image]
Intersoft WebEssentials Documentation
SuspendLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : SuspendLayout Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.SuspendLayout()
C#
public void SuspendLayout()
Delphi
public procedure SuspendLayout();
JScript
public function SuspendLayout();
Managed Extensions for C++
public: void SuspendLayout();
C++/CLI
public:
void SuspendLayout();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


SystemColorsChanged Event

[image]
Intersoft WebEssentials Documentation
SystemColorsChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : SystemColorsChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the system colors change.")>
<SRCategoryAttribute("Behavior")>
Public Event SystemColorsChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.SystemColorsChanged, handler
C#
[SRDescriptionAttribute("Event raised when the system colors change.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler SystemColorsChanged
Delphi
public event SystemColorsChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the system colors change.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* SystemColorsChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the system colors change.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Tag Property

[image]
Intersoft WebEssentials Documentation
Tag Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Tag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.LocalizableAttribute(False)>
<SRDescriptionAttribute("User-defined data associated with the object.")>
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
Public Property Tag As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public System.object Tag {get; set;}
Delphi
public read-write property Tag: System.TObject;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("User-defined data associated with the object.")
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Data")
public function get,set Tag : System.Object
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public: __property System.Object* get_Tag();
public: __property void set_Tag(
   System.Object* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public:
property System.Object^ Tag {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Text Property

[image]
Intersoft WebEssentials Documentation
Text Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.SettingsBindableAttribute(True)>
Public Overridable Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.SettingsBindableAttribute(true)]
public virtual System.string Text {get; set;}
Delphi
public read-write property Text: System.String; virtual;
JScript
System.ComponentModel.SettingsBindableAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.SettingsBindableAttribute(true)]
public: __property virtual System.string* get_Text();
public: __property virtual void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.SettingsBindableAttribute(true)]
public:
virtual property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


TextChanged Event

[image]
Intersoft WebEssentials Documentation
TextChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : TextChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")>
Public Event TextChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.TextChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")]
public event System.EventHandler TextChanged
Delphi
public event TextChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")]
public: __event System.EventHandler* TextChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")]
public:
event System.EventHandler^ TextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


TopMost Property

[image]
Intersoft WebEssentials Documentation
TopMost Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : TopMost Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TopMost As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.TopMost = value

value = instance.TopMost
C#
[SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool TopMost {get; set;}
Delphi
public read-write property TopMost: System.Boolean;
JScript
SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
public function get,set TopMost : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_TopMost();
public: __property void set_TopMost(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool TopMost {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


TransparencyKey Property

[image]
Intersoft WebEssentials Documentation
TransparencyKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : TransparencyKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("A color which will appear transparent when painted on the form.")>
<SRCategoryAttribute("Window Style")>
Public Property TransparencyKey As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Drawing.Color

instance.TransparencyKey = value

value = instance.TransparencyKey
C#
[SRDescriptionAttribute("A color which will appear transparent when painted on the form.")]
[SRCategoryAttribute("Window Style")]
public System.Drawing.Color TransparencyKey {get; set;}
Delphi
public read-write property TransparencyKey: System.Drawing.Color;
JScript
SRDescriptionAttribute("A color which will appear transparent when painted on the form.")
SRCategoryAttribute("Window Style")
public function get,set TransparencyKey : System.Drawing.Color
Managed Extensions for C++
[SRDescriptionAttribute("A color which will appear transparent when painted on the form.")]
[SRCategoryAttribute("Window Style")]
public: __property System.Drawing.Color get_TransparencyKey();
public: __property void set_TransparencyKey(
   System.Drawing.Color value
);
C++/CLI
[SRDescriptionAttribute("A color which will appear transparent when painted on the form.")]
[SRCategoryAttribute("Window Style")]
public:
property System.Drawing.Color TransparencyKey {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Type Property

[image]
Intersoft WebEssentials Documentation
Type Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As WebExpanderContentType
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As WebExpanderContentType

value = instance.Type
C#
public WebExpanderContentType Type {get;}
Delphi
public read-only property Type: WebExpanderContentType;
JScript
public function get Type : WebExpanderContentType
Managed Extensions for C++
public: __property WebExpanderContentType get_Type();
C++/CLI
public:
property WebExpanderContentType Type {
   WebExpanderContentType get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Update Method

[image]
Intersoft WebEssentials Documentation
Update Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Update Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Update()
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm

instance.Update()
C#
public void Update()
Delphi
public procedure Update();
JScript
public function Update();
Managed Extensions for C++
public: void Update();
C++/CLI
public:
void Update();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


UseWaitCursor Property

[image]
Intersoft WebEssentials Documentation
UseWaitCursor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : UseWaitCursor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorBrowsableAttribute()>
<SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")>
Public Property UseWaitCursor As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.UseWaitCursor = value

value = instance.UseWaitCursor
C#
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")]
public System.bool UseWaitCursor {get; set;}
Delphi
public read-write property UseWaitCursor: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorBrowsableAttribute()
SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")
public function get,set UseWaitCursor : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")]
public: __property System.bool get_UseWaitCursor();
public: __property void set_UseWaitCursor(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")]
public:
property System.bool UseWaitCursor {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Validate Method

[image]
Intersoft WebEssentials Documentation
Validate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Validate Method

Glossary Item Box

Overload List

Overload | Description
Validate() | (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | (Inherited from System.Windows.Forms.ContainerControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Validate() Method

[image]
Intersoft WebEssentials Documentation
Validate() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > Validate Method : Validate() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function Validate() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

value = instance.Validate()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool Validate()
Delphi
public function Validate(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Validate() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool Validate();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool Validate();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


Validate(Boolean) Method

[image]
Intersoft WebEssentials Documentation
Validate(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > Validate Method : Validate(Boolean) Method

checkAutoValidate

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate( _
   ByVal checkAutoValidate As System.Boolean _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim checkAutoValidate As System.Boolean
Dim value As System.Boolean

value = instance.Validate(checkAutoValidate)
C#
public System.bool Validate(
   System.bool checkAutoValidate
)
Delphi
public function Validate(
    checkAutoValidate: System.Boolean
): System.Boolean;
JScript
public function Validate(
   checkAutoValidate : System.boolean
) : System.boolean;
Managed Extensions for C++
public: System.bool Validate(
   System.bool checkAutoValidate
)
C++/CLI
public:
System.bool Validate(
   System.bool checkAutoValidate
)

Parameters

checkAutoValidate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


ValidateChildren Method

[image]
Intersoft WebEssentials Documentation
ValidateChildren Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : ValidateChildren Method

Glossary Item Box

Overload List

Overload | Description
ValidateChildren() | (Inherited from System.Windows.Forms.Form)
ValidateChildren(ValidationConstraints) | (Inherited from System.Windows.Forms.Form)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


ValidateChildren() Method

[image]
Intersoft WebEssentials Documentation
ValidateChildren() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > ValidateChildren Method : ValidateChildren() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.EditorBrowsableAttribute()>
Public Overloads Overridable Function ValidateChildren() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

value = instance.ValidateChildren()
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public virtual System.bool ValidateChildren()
Delphi
public function ValidateChildren(): System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute()
public function ValidateChildren() : System.boolean;
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public: virtual System.bool ValidateChildren();
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public:
virtual System.bool ValidateChildren();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


ValidateChildren(ValidationConstraints) Method

[image]
Intersoft WebEssentials Documentation
ValidateChildren(ValidationConstraints) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method

validationConstraints

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.EditorBrowsableAttribute()>
Public Overloads Overridable Function ValidateChildren( _
   ByVal validationConstraints As System.Windows.Forms.ValidationConstraints _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim validationConstraints As System.Windows.Forms.ValidationConstraints
Dim value As System.Boolean

value = instance.ValidateChildren(validationConstraints)
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)
Delphi
public function ValidateChildren(
    validationConstraints: System.Windows.Forms.ValidationConstraints
): System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute()
public function ValidateChildren(
   validationConstraints : System.Windows.Forms.ValidationConstraints
) : System.boolean;
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public: virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public:
virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)

Parameters

validationConstraints

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members
Overload List


Validated Event

[image]
Intersoft WebEssentials Documentation
Validated Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Validated Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs after a control has been successfully validated.")>
<SRCategoryAttribute("Focus")>
Public Event Validated As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.Validated, handler
C#
[SRDescriptionAttribute("Occurs after a control has been successfully validated.")]
[SRCategoryAttribute("Focus")]
public event System.EventHandler Validated
Delphi
public event Validated: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs after a control has been successfully validated.")]
[SRCategoryAttribute("Focus")]
public: __event System.EventHandler* Validated
C++/CLI
[SRDescriptionAttribute("Occurs after a control has been successfully validated.")]
[SRCategoryAttribute("Focus")]
public:
event System.EventHandler^ Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Validating Event

[image]
Intersoft WebEssentials Documentation
Validating Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Validating Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the control is validating.")>
<SRCategoryAttribute("Focus")>
Public Event Validating As System.ComponentModel.CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.Validating, handler
C#
[SRDescriptionAttribute("Occurs when the control is validating.")]
[SRCategoryAttribute("Focus")]
public event System.ComponentModel.CancelEventHandler Validating
Delphi
public event Validating: System.ComponentModel.CancelEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the control is validating.")]
[SRCategoryAttribute("Focus")]
public: __event System.ComponentModel.CancelEventHandler* Validating
C++/CLI
[SRDescriptionAttribute("Occurs when the control is validating.")]
[SRCategoryAttribute("Focus")]
public:
event System.ComponentModel.CancelEventHandler^ Validating

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether the control is visible or hidden.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Behavior")>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
SRDescriptionAttribute("Determines whether the control is visible or hidden.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


VisibleChanged Event

[image]
Intersoft WebEssentials Documentation
VisibleChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : VisibleChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the control's visibility changes.")>
Public Event VisibleChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim handler As System.EventHandler

AddHandler instance.VisibleChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
public event System.EventHandler VisibleChanged
Delphi
public event VisibleChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
public: __event System.EventHandler* VisibleChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
public:
event System.EventHandler^ VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


WindowState Property

[image]
Intersoft WebEssentials Documentation
WindowState Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderNewItemForm Class : WindowState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Determines the initial visual state of the form.")>
Public Property WindowState As System.Windows.Forms.FormWindowState
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderNewItemForm
Dim value As System.Windows.Forms.FormWindowState

instance.WindowState = value

value = instance.WindowState
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
public System.Windows.Forms.FormWindowState WindowState {get; set;}
Delphi
public read-write property WindowState: System.Windows.Forms.FormWindowState;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Layout")
SRDescriptionAttribute("Determines the initial visual state of the form.")
public function get,set WindowState : System.Windows.Forms.FormWindowState
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
public: __property System.Windows.Forms.FormWindowState get_WindowState();
public: __property void set_WindowState(
   System.Windows.Forms.FormWindowState value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
public:
property System.Windows.Forms.FormWindowState WindowState {
   System.Windows.Forms.FormWindowState get();
   void set (    System.Windows.Forms.FormWindowState value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderNewItemForm Class
WebExpanderNewItemForm Members


WebExpanderOnClickEventHandler Delegate

[image]
Intersoft WebEssentials Documentation
WebExpanderOnClickEventHandler Delegate
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderOnClickEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebExpanderOnClickEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebExpanderClickEventDataArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebExpanderOnClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebExpanderOnClickEventHandler(
   System.object sender,
   WebExpanderClickEventDataArgs e
)
Delphi
public delegate WebExpanderOnClickEventHandler(
    sender: System.TObject;
    e: WebExpanderClickEventDataArgs
);
JScript
public delegate WebExpanderOnClickEventHandler(
   sender : System.Object,
   e : WebExpanderClickEventDataArgs
)
Managed Extensions for C++
public: __gc __delegate void WebExpanderOnClickEventHandler(
   System.Object* sender,
   WebExpanderClickEventDataArgs* e
)
C++/CLI
public delegate void WebExpanderOnClickEventHandler(
   System.Object^ sender,
   WebExpanderClickEventDataArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderOnClickEventHandler Members
ISNet.WebUI.WebEssentials Namespace


WebExpanderOnCollapsedEventHandler Delegate

[image]
Intersoft WebEssentials Documentation
WebExpanderOnCollapsedEventHandler Delegate
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderOnCollapsedEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebExpanderOnCollapsedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebExpanderChangedEventDataArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebExpanderOnCollapsedEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebExpanderOnCollapsedEventHandler(
   System.object sender,
   WebExpanderChangedEventDataArgs e
)
Delphi
public delegate WebExpanderOnCollapsedEventHandler(
    sender: System.TObject;
    e: WebExpanderChangedEventDataArgs
);
JScript
public delegate WebExpanderOnCollapsedEventHandler(
   sender : System.Object,
   e : WebExpanderChangedEventDataArgs
)
Managed Extensions for C++
public: __gc __delegate void WebExpanderOnCollapsedEventHandler(
   System.Object* sender,
   WebExpanderChangedEventDataArgs* e
)
C++/CLI
public delegate void WebExpanderOnCollapsedEventHandler(
   System.Object^ sender,
   WebExpanderChangedEventDataArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderOnCollapsedEventHandler Members
ISNet.WebUI.WebEssentials Namespace


WebExpanderOnExpandedEventHandler Delegate

[image]
Intersoft WebEssentials Documentation
WebExpanderOnExpandedEventHandler Delegate
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderOnExpandedEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebExpanderOnExpandedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebExpanderChangedEventDataArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebExpanderOnExpandedEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebExpanderOnExpandedEventHandler(
   System.object sender,
   WebExpanderChangedEventDataArgs e
)
Delphi
public delegate WebExpanderOnExpandedEventHandler(
    sender: System.TObject;
    e: WebExpanderChangedEventDataArgs
);
JScript
public delegate WebExpanderOnExpandedEventHandler(
   sender : System.Object,
   e : WebExpanderChangedEventDataArgs
)
Managed Extensions for C++
public: __gc __delegate void WebExpanderOnExpandedEventHandler(
   System.Object* sender,
   WebExpanderChangedEventDataArgs* e
)
C++/CLI
public delegate void WebExpanderOnExpandedEventHandler(
   System.Object^ sender,
   WebExpanderChangedEventDataArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderOnExpandedEventHandler Members
ISNet.WebUI.WebEssentials Namespace


WebExpanderPresets Class

[image]
Intersoft WebEssentials Documentation
WebExpanderPresets Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderPresets Class

Glossary Item Box

Object Model

WebExpanderPresets Class

Syntax

Visual Basic (Declaration)
Public Class WebExpanderPresets
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderPresets
C#
public class WebExpanderPresets
Delphi
public class WebExpanderPresets
JScript
public class WebExpanderPresets
Managed Extensions for C++
public __gc class WebExpanderPresets
C++/CLI
public ref class WebExpanderPresets

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebEssentials.WebExpanderPresets

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderPresets Members
ISNet.WebUI.WebEssentials Namespace


WebExpanderPresets Class Members

[image]
Intersoft WebEssentials Documentation
WebExpanderPresets Class Members
See Also Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderPresets Class

Glossary Item Box

The following tables list the members exposed by WebExpanderPresets.

Public Constructors

 | Name | Description
Public Constructor | WebExpanderPresets Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

WebExpanderPresets Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderPresets Class Methods

[image]
Intersoft WebEssentials Documentation
WebExpanderPresets Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderPresets Class

Glossary Item Box

For a list of all members of this type, see WebExpanderPresets members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

WebExpanderPresets Class
ISNet.WebUI.WebEssentials Namespace


WebExpanderPresets Constructor

[image]
Intersoft WebEssentials Documentation
WebExpanderPresets Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderPresets Class : WebExpanderPresets Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExpanderPresets()
C#
public WebExpanderPresets()
Delphi
public WebExpanderPresets();
JScript
public function WebExpanderPresets();
Managed Extensions for C++
public: WebExpanderPresets();
C++/CLI
public:
WebExpanderPresets();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderPresets Class
WebExpanderPresets Members


GetDefaultStyle Method

[image]
Intersoft WebEssentials Documentation
GetDefaultStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderPresets Class : GetDefaultStyle Method

Glossary Item Box

Overload List

Overload | Description
GetDefaultStyle |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderPresets Class
WebExpanderPresets Members


GetDefaultStyle(WebExpanderStyleMode,String) Method

[image]
Intersoft WebEssentials Documentation
GetDefaultStyle(WebExpanderStyleMode,String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpanderPresets Class : GetDefaultStyle(WebExpanderStyleMode,String) Method

mode
styleName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetDefaultStyle( _
   ByVal mode As WebExpanderStyleMode, _
   ByVal styleName As System.String _
) As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim mode As WebExpanderStyleMode
Dim styleName As System.String
Dim value As ISNet.WebUI.WebStyle

value = WebExpanderPresets.GetDefaultStyle(mode, styleName)
C#
public static ISNet.WebUI.WebStyle GetDefaultStyle(
   WebExpanderStyleMode mode,
   System.string styleName
)
Delphi
public function GetDefaultStyle(
    mode: WebExpanderStyleMode;
    styleName: System.String
): ISNet.WebUI.WebStyle; static;
JScript
public static function GetDefaultStyle(
   mode : WebExpanderStyleMode,
   styleName : System.String
) : ISNet.WebUI.WebStyle;
Managed Extensions for C++
public: static ISNet.WebUI.WebStyle* GetDefaultStyle(
   WebExpanderStyleMode mode,
   System.string* styleName
)
C++/CLI
public:
static ISNet.WebUI.WebStyle^ GetDefaultStyle(
   WebExpanderStyleMode mode,
   System.String^ styleName
)

Parameters

mode
styleName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpanderPresets Class
WebExpanderPresets Members


WebExpanderStyleMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebExpanderStyleMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebExpanderStyleMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebExpanderStyleMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebExpanderStyleMode
C#
public enum WebExpanderStyleMode : System.Enum
Delphi
public enum WebExpanderStyleMode = class(System.Enum)
JScript
public enum WebExpanderStyleMode extends System.Enum
Managed Extensions for C++
__value public enum WebExpanderStyleMode : public System.Enum
C++/CLI
public enum class WebExpanderStyleMode : public System.Enum

Members

Member | Description
Default |
OfficeBlack |
Silver |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebExpanderStyleMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebExpander Constructor

[image]
Intersoft WebEssentials Documentation
WebExpander Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : WebExpander Constructor

Glossary Item Box

Overload List

Overload | Description
WebExpander Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


WebExpander Constructor

[image]
Intersoft WebEssentials Documentation
WebExpander Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : WebExpander Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebExpander()
C#
public WebExpander()
Delphi
public WebExpander();
JScript
public function WebExpander();
Managed Extensions for C++
public: WebExpander();
C++/CLI
public:
WebExpander();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


AccessKey Property

[image]
Intersoft WebEssentials Documentation
AccessKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set AccessKey : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


AllowDefaultStyleMerging Property

[image]
Intersoft WebEssentials Documentation
AllowDefaultStyleMerging Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : AllowDefaultStyleMerging Property

Glossary Item Box

Gets or sets the value that determines whether or not the default style can be merged with custom styles.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AllowDefaultStyleMerging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

instance.AllowDefaultStyleMerging = value

value = instance.AllowDefaultStyleMerging
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool AllowDefaultStyleMerging {get; set;}
Delphi
public read-write property AllowDefaultStyleMerging: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AllowDefaultStyleMerging : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_AllowDefaultStyleMerging();
public: __property void set_AllowDefaultStyleMerging(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool AllowDefaultStyleMerging {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


AnimationDuration Property

[image]
Intersoft WebEssentials Documentation
AnimationDuration Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : AnimationDuration Property

Glossary Item Box

Gets or sets the animation durion during item Expand or Collapse.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the animation duration during item Expand or Collapse.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property AnimationDuration As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Integer

instance.AnimationDuration = value

value = instance.AnimationDuration
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the animation duration during item Expand or Collapse.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.int AnimationDuration {get; set;}
Delphi
public read-write property AnimationDuration: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the animation duration during item Expand or Collapse.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set AnimationDuration : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the animation duration during item Expand or Collapse.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.int get_AnimationDuration();
public: __property void set_AnimationDuration(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the animation duration during item Expand or Collapse.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.int AnimationDuration {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ApplyStyle Method

[image]
Intersoft WebEssentials Documentation
ApplyStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebEssentials Documentation
ApplyStyleSheetSkin Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


CanUseWebResources Method

[image]
Intersoft WebEssentials Documentation
CanUseWebResources Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.CanUseWebResources()
C#
public System.bool CanUseWebResources()
Delphi
public function CanUseWebResources(): System.Boolean;
JScript
public function CanUseWebResources() : System.boolean;
Managed Extensions for C++
public: System.bool CanUseWebResources();
C++/CLI
public:
System.bool CanUseWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Click Event

[image]
Intersoft WebEssentials Documentation
Click Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Click Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Interaction")>
<System.ComponentModel.DescriptionAttribute("Fires when WebExpander item header is clicked")>
Public Event Click As WebExpanderOnClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim handler As WebExpanderOnClickEventHandler

AddHandler instance.Click, handler
C#
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebExpander item header is clicked")]
public event WebExpanderOnClickEventHandler Click
Delphi
public event Click: WebExpanderOnClickEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebExpander item header is clicked")]
public: __event WebExpanderOnClickEventHandler* Click
C++/CLI
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebExpander item header is clicked")]
public:
event WebExpanderOnClickEventHandler^ Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ClientIDMode Property

[image]
Intersoft WebEssentials Documentation
ClientIDMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ClientSideEvents Property

[image]
Intersoft WebEssentials Documentation
ClientSideEvents Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ClientSideEvents Property

Glossary Item Box

Gets or sets client side events for WebExpander.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DescriptionAttribute("Gets or sets client side events for WebExpander.")>
Public Property ClientSideEvents As WebExpanderClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As WebExpanderClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets client side events for WebExpander.")]
public WebExpanderClientSideEvents ClientSideEvents {get; set;}
Delphi
public read-write property ClientSideEvents: WebExpanderClientSideEvents;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DescriptionAttribute("Gets or sets client side events for WebExpander.")
public function get,set ClientSideEvents : WebExpanderClientSideEvents
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets client side events for WebExpander.")]
public: __property WebExpanderClientSideEvents* get_ClientSideEvents();
public: __property void set_ClientSideEvents(
   WebExpanderClientSideEvents* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets client side events for WebExpander.")]
public:
property WebExpanderClientSideEvents^ ClientSideEvents {
   WebExpanderClientSideEvents^ get();
   void set (    WebExpanderClientSideEvents^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Collapsed Event

[image]
Intersoft WebEssentials Documentation
Collapsed Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Collapsed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires when WebExpander item is collapsed")>
<System.ComponentModel.CategoryAttribute("Interaction")>
Public Event Collapsed As WebExpanderOnCollapsedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim handler As WebExpanderOnCollapsedEventHandler

AddHandler instance.Collapsed, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires when WebExpander item is collapsed")]
[System.ComponentModel.CategoryAttribute("Interaction")]
public event WebExpanderOnCollapsedEventHandler Collapsed
Delphi
public event Collapsed: WebExpanderOnCollapsedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires when WebExpander item is collapsed")]
[System.ComponentModel.CategoryAttribute("Interaction")]
public: __event WebExpanderOnCollapsedEventHandler* Collapsed
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires when WebExpander item is collapsed")]
[System.ComponentModel.CategoryAttribute("Interaction")]
public:
event WebExpanderOnCollapsedEventHandler^ Collapsed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ContainerStyle Property

[image]
Intersoft WebEssentials Documentation
ContainerStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ContainerStyle Property

Glossary Item Box

Gets or sets the the style of the expander item content.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the content item of the expander.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public Property ContainerStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As ISNet.WebUI.WebStyle

instance.ContainerStyle = value

value = instance.ContainerStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the content item of the expander.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ISNet.WebUI.WebStyle ContainerStyle {get; set;}
Delphi
public read-write property ContainerStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the content item of the expander.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
public function get,set ContainerStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the content item of the expander.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property ISNet.WebUI.WebStyle* get_ContainerStyle();
public: __property void set_ContainerStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the content item of the expander.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property ISNet.WebUI.WebStyle^ ContainerStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ControlDataTransferFormat Property

[image]
Intersoft WebEssentials Documentation
ControlDataTransferFormat Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


CopyBaseAttributes Method

[image]
Intersoft WebEssentials Documentation
CopyBaseAttributes Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members
Overload List


DataBind Method

[image]
Intersoft WebEssentials Documentation
DataBind Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


DataBind() Method

[image]
Intersoft WebEssentials Documentation
DataBind() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebExpander

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


DataBinding Event

[image]
Intersoft WebEssentials Documentation
DataBinding Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


DefaultStyleMode Property

[image]
Intersoft WebEssentials Documentation
DefaultStyleMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : DefaultStyleMode Property

Glossary Item Box

Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DefaultStyleMode As WebExpanderStyleMode
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As WebExpanderStyleMode

instance.DefaultStyleMode = value

value = instance.DefaultStyleMode
C#
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebExpanderStyleMode DefaultStyleMode {get; set;}
Delphi
public read-write property DefaultStyleMode: WebExpanderStyleMode;
JScript
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DefaultStyleMode : WebExpanderStyleMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebExpanderStyleMode get_DefaultStyleMode();
public: __property void set_DefaultStyleMode(
   WebExpanderStyleMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebExpanderStyleMode DefaultStyleMode {
   WebExpanderStyleMode get();
   void set (    WebExpanderStyleMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Dispose Method

[image]
Intersoft WebEssentials Documentation
Dispose Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebExpander

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Disposed Event

[image]
Intersoft WebEssentials Documentation
Disposed Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


EnableManagedTheming Property

[image]
Intersoft WebEssentials Documentation
EnableManagedTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable Property EnableManagedTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableManagedTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.bool EnableManagedTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


EnableTheming Property

[image]
Intersoft WebEssentials Documentation
EnableTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


EnableViewState Property

[image]
Intersoft WebEssentials Documentation
EnableViewState Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


EnableWebResources Property

[image]
Intersoft WebEssentials Documentation
EnableWebResources Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Web Resources")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Web Resources")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Expanded Event

[image]
Intersoft WebEssentials Documentation
Expanded Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Expanded Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Interaction")>
<System.ComponentModel.DescriptionAttribute("Fires when WebExpander item is expanded")>
Public Event Expanded As WebExpanderOnExpandedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim handler As WebExpanderOnExpandedEventHandler

AddHandler instance.Expanded, handler
C#
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebExpander item is expanded")]
public event WebExpanderOnExpandedEventHandler Expanded
Delphi
public event Expanded: WebExpanderOnExpandedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebExpander item is expanded")]
public: __event WebExpanderOnExpandedEventHandler* Expanded
C++/CLI
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebExpander item is expanded")]
public:
event WebExpanderOnExpandedEventHandler^ Expanded

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


FindControl Method

[image]
Intersoft WebEssentials Documentation
FindControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


FindControl(String) Method

[image]
Intersoft WebEssentials Documentation
FindControl(String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Flow Property

[image]
Intersoft WebEssentials Documentation
Flow Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Flow Property

Glossary Item Box

Gets or sets a value indicating whether the flow of the expansion of the control is Left, Right, Up, or Down.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the WebExpander expansion flow.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Flow As WebExpanderFlow
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As WebExpanderFlow

instance.Flow = value

value = instance.Flow
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the WebExpander expansion flow.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebExpanderFlow Flow {get; set;}
Delphi
public read-write property Flow: WebExpanderFlow;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Gets or sets the WebExpander expansion flow.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Flow : WebExpanderFlow
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the WebExpander expansion flow.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebExpanderFlow get_Flow();
public: __property void set_Flow(
   WebExpanderFlow value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the WebExpander expansion flow.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebExpanderFlow Flow {
   WebExpanderFlow get();
   void set (    WebExpanderFlow value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


FlyPostBackSettings Property

[image]
Intersoft WebEssentials Documentation
FlyPostBackSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : FlyPostBackSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}
Delphi
public read-only property FlyPostBackSettings: ISNet.WebUI.FlyPostBackSettings;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
public function get FlyPostBackSettings : ISNet.WebUI.FlyPostBackSettings
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ISNet.WebUI.FlyPostBackSettings* get_FlyPostBackSettings();
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ISNet.WebUI.FlyPostBackSettings^ FlyPostBackSettings {
   ISNet.WebUI.FlyPostBackSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Focus Method

[image]
Intersoft WebEssentials Documentation
Focus Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebExpander

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ForceDisableXmlCompression Method

[image]
Intersoft WebEssentials Documentation
ForceDisableXmlCompression Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebExpander

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


FrameStyle Property

[image]
Intersoft WebEssentials Documentation
FrameStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : FrameStyle Property

Glossary Item Box

Gets or sets the the style of the WebExpander frame.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the frame of the expander.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the frame of the expander.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ISNet.WebUI.WebStyle FrameStyle {get; set;}
Delphi
public read-write property FrameStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the frame of the expander.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
public function get,set FrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the frame of the expander.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property ISNet.WebUI.WebStyle* get_FrameStyle();
public: __property void set_FrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the frame of the expander.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property ISNet.WebUI.WebStyle^ FrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetClientAction Method

[image]
Intersoft WebEssentials Documentation
GetClientAction Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebEssentials Documentation
GetCurrentControlLifeCycle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetCurrentTheme Method

[image]
Intersoft WebEssentials Documentation
GetCurrentTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetFrameworkDataFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkDataFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

value = instance.GetFrameworkDataFolder()
C#
public System.string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): System.String;
JScript
public function GetFrameworkDataFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkDataFolder();
C++/CLI
public:
System.String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetFrameworkFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

value = instance.GetFrameworkFolder()
C#
public System.string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): System.String;
JScript
public function GetFrameworkFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkFolder();
C++/CLI
public:
System.String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetFrameworkVersion Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkVersion Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Version

value = instance.GetFrameworkVersion()
C#
public System.Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): System.Version;
JScript
public function GetFrameworkVersion() : System.Version;
Managed Extensions for C++
public: System.Version* GetFrameworkVersion();
C++/CLI
public:
System.Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetIntersoftFolder Method

[image]
Intersoft WebEssentials Documentation
GetIntersoftFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

value = instance.GetIntersoftFolder()
C#
public System.string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): System.String;
JScript
public function GetIntersoftFolder() : System.String;
Managed Extensions for C++
public: System.string* GetIntersoftFolder();
C++/CLI
public:
System.String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetLayoutFolder Method

[image]
Intersoft WebEssentials Documentation
GetLayoutFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

value = instance.GetLayoutFolder()
C#
public System.string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): System.String;
JScript
public function GetLayoutFolder() : System.String;
Managed Extensions for C++
public: System.string* GetLayoutFolder();
C++/CLI
public:
System.String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetPostedXMLData Method

[image]
Intersoft WebEssentials Documentation
GetPostedXMLData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

value = instance.GetPostedXMLData()
C#
public System.string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): System.String;
JScript
public function GetPostedXMLData() : System.String;
Managed Extensions for C++
public: System.string* GetPostedXMLData();
C++/CLI
public:
System.String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetProductInfoKey Method

[image]
Intersoft WebEssentials Documentation
GetProductInfoKey Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

value = instance.GetProductInfoKey()
C#
public System.string GetProductInfoKey()
Delphi
public function GetProductInfoKey(): System.String;
JScript
public function GetProductInfoKey() : System.String;
Managed Extensions for C++
public: System.string* GetProductInfoKey();
C++/CLI
public:
System.String^ GetProductInfoKey();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetProductSimpleName Method

[image]
Intersoft WebEssentials Documentation
GetProductSimpleName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

value = instance.GetProductSimpleName()
C#
public System.string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): System.String;
JScript
public function GetProductSimpleName() : System.String;
Managed Extensions for C++
public: System.string* GetProductSimpleName();
C++/CLI
public:
System.String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetPropertyValue Method

[image]
Intersoft WebEssentials Documentation
GetPropertyValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As System.String, _
   ByVal propValue As System.String, _
   ByVal webConfigKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim defValue As System.String
Dim propValue As System.String
Dim webConfigKey As System.String
Dim value As System.String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public System.string GetPropertyValue(
   System.string defValue,
   System.string propValue,
   System.string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: System.String;
    propValue: System.String;
    webConfigKey: System.String
): System.String;
JScript
public function GetPropertyValue(
   defValue : System.String,
   propValue : System.String,
   webConfigKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetPropertyValue(
   System.string* defValue,
   System.string* propValue,
   System.string* webConfigKey
)
C++/CLI
public:
System.String^ GetPropertyValue(
   System.String^ defValue,
   System.String^ propValue,
   System.String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetResourceStream Method

[image]
Intersoft WebEssentials Documentation
GetResourceStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As System.String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim resourceUrl As System.String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   System.string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: System.String
): System.IO.Stream;
JScript
public function GetResourceStream(
   resourceUrl : System.String
) : System.IO.Stream;
Managed Extensions for C++
public: System.IO.Stream* GetResourceStream(
   System.string* resourceUrl
)
C++/CLI
public:
System.IO.Stream^ GetResourceStream(
   System.String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetRouteUrl Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


GetRouteUrl(Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebEssentials Documentation
GetUniqueIDRelativeTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


HasControls Method

[image]
Intersoft WebEssentials Documentation
HasControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


HeaderCaptionStyle Property

[image]
Intersoft WebEssentials Documentation
HeaderCaptionStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : HeaderCaptionStyle Property

Glossary Item Box

Gets or sets the the applied style for all the header caption in the expander.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the applied style for all the header caption in the expander.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public Property HeaderCaptionStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As ISNet.WebUI.WebStyle

instance.HeaderCaptionStyle = value

value = instance.HeaderCaptionStyle
C#
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the applied style for all the header caption in the expander.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ISNet.WebUI.WebStyle HeaderCaptionStyle {get; set;}
Delphi
public read-write property HeaderCaptionStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the applied style for all the header caption in the expander.")
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
public function get,set HeaderCaptionStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the applied style for all the header caption in the expander.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property ISNet.WebUI.WebStyle* get_HeaderCaptionStyle();
public: __property void set_HeaderCaptionStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the applied style for all the header caption in the expander.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property ISNet.WebUI.WebStyle^ HeaderCaptionStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


HeaderStyle Property

[image]
Intersoft WebEssentials Documentation
HeaderStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : HeaderStyle Property

Glossary Item Box

Gets or sets the the applied default style for all the header item in the expander.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the the applied default style for all the header item in the expander.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Style")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public Property HeaderStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As ISNet.WebUI.DynamicStyle

instance.HeaderStyle = value

value = instance.HeaderStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the the applied default style for all the header item in the expander.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ISNet.WebUI.DynamicStyle HeaderStyle {get; set;}
Delphi
public read-write property HeaderStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the the applied default style for all the header item in the expander.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Style")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
public function get,set HeaderStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the the applied default style for all the header item in the expander.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property ISNet.WebUI.DynamicStyle* get_HeaderStyle();
public: __property void set_HeaderStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the the applied default style for all the header item in the expander.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property ISNet.WebUI.DynamicStyle^ HeaderStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Height Property

[image]
Intersoft WebEssentials Documentation
Height Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overrides Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public override System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; override;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public override function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.Web.UI.WebControls.Unit get_Height() override;
public: __property void set_Height(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ID Property

[image]
Intersoft WebEssentials Documentation
ID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ImagesDirectory Property

[image]
Intersoft WebEssentials Documentation
ImagesDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the images directory.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ImagesDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ImagesDirectory {get; set;}
Delphi
public read-write property ImagesDirectory: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ImagesDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ImagesDirectory();
public: __property void set_ImagesDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ImagesDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IndicatorStyle Property

[image]
Intersoft WebEssentials Documentation
IndicatorStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IndicatorStyle Property

Glossary Item Box

Gets or sets the the style of the WebExpander item indicator style.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the indicator of the expander item.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public Property IndicatorStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As ISNet.WebUI.DynamicStyle

instance.IndicatorStyle = value

value = instance.IndicatorStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the indicator of the expander item.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ISNet.WebUI.DynamicStyle IndicatorStyle {get; set;}
Delphi
public read-write property IndicatorStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the indicator of the expander item.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
public function get,set IndicatorStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the indicator of the expander item.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property ISNet.WebUI.DynamicStyle* get_IndicatorStyle();
public: __property void set_IndicatorStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the indicator of the expander item.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property ISNet.WebUI.DynamicStyle^ IndicatorStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Init Event

[image]
Intersoft WebEssentials Documentation
Init Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IsAtlasCallback Method

[image]
Intersoft WebEssentials Documentation
IsAtlasCallback Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.IsAtlasCallback()
C#
public System.bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): System.Boolean;
JScript
public function IsAtlasCallback() : System.boolean;
Managed Extensions for C++
public: System.bool IsAtlasCallback();
C++/CLI
public:
System.bool IsAtlasCallback();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IsBetaRelease Method

[image]
Intersoft WebEssentials Documentation
IsBetaRelease Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.IsBetaRelease()
C#
public System.bool IsBetaRelease()
Delphi
public function IsBetaRelease(): System.Boolean;
JScript
public function IsBetaRelease() : System.boolean;
Managed Extensions for C++
public: System.bool IsBetaRelease();
C++/CLI
public:
System.bool IsBetaRelease();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IsChromeBrowser Method

[image]
Intersoft WebEssentials Documentation
IsChromeBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.IsChromeBrowser()
C#
public System.bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): System.Boolean;
JScript
public function IsChromeBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsChromeBrowser();
C++/CLI
public:
System.bool IsChromeBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IsFlyPostBackControl Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual System.bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): System.Boolean; virtual;
JScript
public function IsFlyPostBackControl() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackControl();
C++/CLI
public:
virtual System.bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IsFlyPostBackRequest Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackRequest Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual System.bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): System.Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackRequest();
C++/CLI
public:
virtual System.bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebEssentials Documentation
IsGeckoBasedBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.IsGeckoBasedBrowser()
C#
public System.bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): System.Boolean;
JScript
public function IsGeckoBasedBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoBasedBrowser();
C++/CLI
public:
System.bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IsGeckoVersion18 Method

[image]
Intersoft WebEssentials Documentation
IsGeckoVersion18 Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.IsGeckoVersion18()
C#
public System.bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): System.Boolean;
JScript
public function IsGeckoVersion18() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoVersion18();
C++/CLI
public:
System.bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IsInDesignMode Method

[image]
Intersoft WebEssentials Documentation
IsInDesignMode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.IsInDesignMode()
C#
public System.bool IsInDesignMode()
Delphi
public function IsInDesignMode(): System.Boolean;
JScript
public function IsInDesignMode() : System.boolean;
Managed Extensions for C++
public: System.bool IsInDesignMode();
C++/CLI
public:
System.bool IsInDesignMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorer8Browser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.IsInternetExplorer8Browser()
C#
public System.bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): System.Boolean;
JScript
public function IsInternetExplorer8Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer8Browser();
C++/CLI
public:
System.bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorerBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.IsInternetExplorerBrowser()
C#
public System.bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): System.Boolean;
JScript
public function IsInternetExplorerBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorerBrowser();
C++/CLI
public:
System.bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IsOperaBrowser Method

[image]
Intersoft WebEssentials Documentation
IsOperaBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.IsOperaBrowser()
C#
public System.bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): System.Boolean;
JScript
public function IsOperaBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsOperaBrowser();
C++/CLI
public:
System.bool IsOperaBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IsSafariBrowser Method

[image]
Intersoft WebEssentials Documentation
IsSafariBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.IsSafariBrowser()
C#
public System.bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): System.Boolean;
JScript
public function IsSafariBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsSafariBrowser();
C++/CLI
public:
System.bool IsSafariBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


IsW3CStandardBrowser Method

[image]
Intersoft WebEssentials Documentation
IsW3CStandardBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.IsW3CStandardBrowser()
C#
public System.bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): System.Boolean;
JScript
public function IsW3CStandardBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsW3CStandardBrowser();
C++/CLI
public:
System.bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Items Property

[image]
Intersoft WebEssentials Documentation
Items Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Items Property

Glossary Item Box

Gets or sets the collection of content item for WebExpander.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the collection of content item.")>
<ISNet.Serialization.BinarySerializableAttribute("setItems")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property Items As WebExpanderItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As WebExpanderItemCollection

value = instance.Items
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the collection of content item.")]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebExpanderItemCollection Items {get;}
Delphi
public read-only property Items: WebExpanderItemCollection;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the collection of content item.")
ISNet.Serialization.BinarySerializableAttribute("setItems")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get Items : WebExpanderItemCollection
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the collection of content item.")]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebExpanderItemCollection* get_Items();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the collection of content item.")]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebExpanderItemCollection^ Items {
   WebExpanderItemCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ItemSettings Property

[image]
Intersoft WebEssentials Documentation
ItemSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ItemSettings Property

Glossary Item Box

Provides the settings that control the default WebExpander's item settings.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the default WebExpander's item settings.")>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property ItemSettings As WebExpanderItemSettings
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As WebExpanderItemSettings

value = instance.ItemSettings
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the default WebExpander's item settings.")]
[System.ComponentModel.CategoryAttribute("General")]
public WebExpanderItemSettings ItemSettings {get;}
Delphi
public read-only property ItemSettings: WebExpanderItemSettings;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Provides the settings that control the default WebExpander's item settings.")
System.ComponentModel.CategoryAttribute("General")
public function get ItemSettings : WebExpanderItemSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the default WebExpander's item settings.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property WebExpanderItemSettings* get_ItemSettings();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the default WebExpander's item settings.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property WebExpanderItemSettings^ ItemSettings {
   WebExpanderItemSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Load Event

[image]
Intersoft WebEssentials Documentation
Load Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


LoadLayout Method

[image]
Intersoft WebEssentials Documentation
LoadLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


LoadLayoutFromFile Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim filePath As System.String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   System.string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: System.String
); virtual;
JScript
public function LoadLayoutFromFile(
   filePath : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromFile(
   System.string* filePath
)
C++/CLI
public:
virtual void LoadLayoutFromFile(
   System.String^ filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromPredefinedName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim predefinedName As System.String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   System.string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: System.String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   System.string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   System.String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


LoadLayoutFromStream Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: System.IO.Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   System.IO.Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


LoadPostData Method

[image]
Intersoft WebEssentials Documentation
LoadPostData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function LoadPostData( _
   ByVal postDataKey As System.String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim postDataKey As System.String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As System.Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public virtual System.bool LoadPostData(
   System.string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)
Delphi
public function LoadPostData(
    postDataKey: System.String;
    postCollection: System.Collections.Specialized.NameValueCollection
): System.Boolean; virtual;
JScript
public function LoadPostData(
   postDataKey : System.String,
   postCollection : System.Collections.Specialized.NameValueCollection
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool LoadPostData(
   System.string* postDataKey,
   System.Collections.Specialized.NameValueCollection* postCollection
)
C++/CLI
public:
virtual System.bool LoadPostData(
   System.String^ postDataKey,
   System.Collections.Specialized.NameValueCollection^ postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


MergeStyle Method

[image]
Intersoft WebEssentials Documentation
MergeStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Mode Property

[image]
Intersoft WebEssentials Documentation
Mode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Mode Property

Glossary Item Box

Gets or sets a value indicating whether the expander mode is Fixed or Flow.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the WebExpander mode")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Mode As WebExpanderMode
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As WebExpanderMode

instance.Mode = value

value = instance.Mode
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the WebExpander mode")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebExpanderMode Mode {get; set;}
Delphi
public read-write property Mode: WebExpanderMode;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the WebExpander mode")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Mode : WebExpanderMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the WebExpander mode")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebExpanderMode get_Mode();
public: __property void set_Mode(
   WebExpanderMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the WebExpander mode")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebExpanderMode Mode {
   WebExpanderMode get();
   void set (    WebExpanderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


OnInfoChanged Method

[image]
Intersoft WebEssentials Documentation
OnInfoChanged Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


OnPreInitialize Method

[image]
Intersoft WebEssentials Documentation
OnPreInitialize Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebExpander

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Page Property

[image]
Intersoft WebEssentials Documentation
Page Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}
Delphi
public read-write property Page: System.Web.UI.Page; virtual;
JScript
public function get,set Page : System.Web.UI.Page
Managed Extensions for C++
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
C++/CLI
public:
virtual property System.Web.UI.Page^ Page {
   System.Web.UI.Page^ get();
   void set (    System.Web.UI.Page^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


PostBackMode Property

[image]
Intersoft WebEssentials Documentation
PostBackMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : PostBackMode Property

Glossary Item Box

Gets or sets the PostBack mode for WebExpander.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the PostBack mode for WebExpander.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PostBackMode As PostBackMode
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As PostBackMode

instance.PostBackMode = value

value = instance.PostBackMode
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the PostBack mode for WebExpander.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public PostBackMode PostBackMode {get; set;}
Delphi
public read-write property PostBackMode: PostBackMode;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the PostBack mode for WebExpander.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PostBackMode : PostBackMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the PostBack mode for WebExpander.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property PostBackMode get_PostBackMode();
public: __property void set_PostBackMode(
   PostBackMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the PostBack mode for WebExpander.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property PostBackMode PostBackMode {
   PostBackMode get();
   void set (    PostBackMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


PreInitialize Event

[image]
Intersoft WebEssentials Documentation
PreInitialize Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim handler As System.EventHandler

AddHandler instance.PreInitialize, handler
C#
public event System.EventHandler PreInitialize
Delphi
public event PreInitialize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* PreInitialize
C++/CLI
public:
event System.EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


PreRender Event

[image]
Intersoft WebEssentials Documentation
PreRender Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RaisePostBackEvent Method

[image]
Intersoft WebEssentials Documentation
RaisePostBackEvent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim eventArgument As System.String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   System.string eventArgument
)
Delphi
public procedure RaisePostBackEvent(
    eventArgument: System.String
);
JScript
public function RaisePostBackEvent(
   eventArgument : System.String
);
Managed Extensions for C++
public: void RaisePostBackEvent(
   System.string* eventArgument
)
C++/CLI
public:
void RaisePostBackEvent(
   System.String^ eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebEssentials Documentation
RaisePostDataChangedEvent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebExpander

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); virtual;
JScript
public function RaisePostDataChangedEvent();
Managed Extensions for C++
public: virtual void RaisePostDataChangedEvent();
C++/CLI
public:
virtual void RaisePostDataChangedEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ReadWebConfigValue Method

[image]
Intersoft WebEssentials Documentation
ReadWebConfigValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim key As System.String
Dim value As System.String

value = instance.ReadWebConfigValue(key)
C#
public System.string ReadWebConfigValue(
   System.string key
)
Delphi
public function ReadWebConfigValue(
    key: System.String
): System.String;
JScript
public function ReadWebConfigValue(
   key : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ReadWebConfigValue(
   System.string* key
)
C++/CLI
public:
System.String^ ReadWebConfigValue(
   System.String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RecreateChildControls Method

[image]
Intersoft WebEssentials Documentation
RecreateChildControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebExpander

instance.RecreateChildControls()
C#
public void RecreateChildControls()
Delphi
public procedure RecreateChildControls();
JScript
public function RecreateChildControls();
Managed Extensions for C++
public: void RecreateChildControls();
C++/CLI
public:
void RecreateChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RegisterBoxSizing Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RegisterBoxSizing() Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebExpander

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim forceAll As System.Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   System.bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: System.Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : System.boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   System.bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   System.bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebEssentials Documentation
RegisterGlobalStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RegisterLink Method

[image]
Intersoft WebEssentials Documentation
RegisterLink Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As System.String, _
   ByVal url As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim name As System.String
Dim url As System.String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   System.string name,
   System.string url
)
Delphi
public procedure RegisterLink(
    name: System.String;
    url: System.String
);
JScript
public function RegisterLink(
   name : System.String,
   url : System.String
);
Managed Extensions for C++
public: void RegisterLink(
   System.string* name,
   System.string* url
)
C++/CLI
public:
void RegisterLink(
   System.String^ name,
   System.String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebEssentials Documentation
RegisterOptimizedCssClasses Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim runtimeStyleOnly As System.Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: System.Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : System.boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RegisterPreloadImage Method

[image]
Intersoft WebEssentials Documentation
RegisterPreloadImage Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim image As System.String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   System.string image
)
Delphi
public procedure RegisterPreloadImage(
    image: System.String
);
JScript
public function RegisterPreloadImage(
   image : System.String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   System.string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   System.String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RegisterSharePointHandler Method

[image]
Intersoft WebEssentials Documentation
RegisterSharePointHandler Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebExpander

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RenderBeginTag Method

[image]
Intersoft WebEssentials Documentation
RenderBeginTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RenderControl Method

[image]
Intersoft WebEssentials Documentation
RenderControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebEssentials Documentation
RenderControl(HtmlTextWriter) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RenderEndTag Method

[image]
Intersoft WebEssentials Documentation
RenderEndTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RenderingMode Property

[image]
Intersoft WebEssentials Documentation
RenderingMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebExpander

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ResolveClientUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveClientUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ResolveImagePath Method

[image]
Intersoft WebEssentials Documentation
ResolveImagePath Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As System.String, _
   ByVal image As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim folder As System.String
Dim image As System.String
Dim value As System.String

value = instance.ResolveImagePath(folder, image)
C#
public System.string ResolveImagePath(
   System.string folder,
   System.string image
)
Delphi
public function ResolveImagePath(
    folder: System.String;
    image: System.String
): System.String;
JScript
public function ResolveImagePath(
   folder : System.String,
   image : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveImagePath(
   System.string* folder,
   System.string* image
)
C++/CLI
public:
System.String^ ResolveImagePath(
   System.String^ folder,
   System.String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ResolveRelativeURL Method

[image]
Intersoft WebEssentials Documentation
ResolveRelativeURL Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim url As System.String
Dim value As System.String

value = instance.ResolveRelativeURL(url)
C#
public virtual System.string ResolveRelativeURL(
   System.string url
)
Delphi
public function ResolveRelativeURL(
    url: System.String
): System.String; virtual;
JScript
public function ResolveRelativeURL(
   url : System.String
) : System.String;
Managed Extensions for C++
public: virtual System.string* ResolveRelativeURL(
   System.string* url
)
C++/CLI
public:
virtual System.String^ ResolveRelativeURL(
   System.String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ResolveResourceUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveResourceUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As System.String, _
   ByVal currentFolder As System.String, _
   ByVal resourceName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As System.String
Dim currentFolder As System.String
Dim resourceName As System.String
Dim value As System.String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public System.string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string defaultFolder,
   System.string currentFolder,
   System.string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: System.String;
    currentFolder: System.String;
    resourceName: System.String
): System.String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : System.String,
   currentFolder : System.String,
   resourceName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string* defaultFolder,
   System.string* currentFolder,
   System.string* resourceName
)
C++/CLI
public:
System.String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.String^ defaultFolder,
   System.String^ currentFolder,
   System.String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ResolveUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


RuntimeLicenseKey Property

[image]
Intersoft WebEssentials Documentation
RuntimeLicenseKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
Public Overridable Property RuntimeLicenseKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public virtual System.string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: System.String; virtual;
JScript
ISNet.PersistLayoutAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
public function get,set RuntimeLicenseKey : System.String
Managed Extensions for C++
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public: __property virtual System.string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   System.string* value
);
C++/CLI
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public:
virtual property System.String^ RuntimeLicenseKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


SaveLayout Method

[image]
Intersoft WebEssentials Documentation
SaveLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


SaveLayoutToFile Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim filePath As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   System.string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   System.string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   System.String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


SaveLayoutToStream Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
ScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overrides Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
public override System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String; override;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.DefaultValueAttribute()
public override function get,set ScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


SetRenderMethodDelegate Method

[image]
Intersoft WebEssentials Documentation
SetRenderMethodDelegate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


SetSessionTheme Method

[image]
Intersoft WebEssentials Documentation
SetSessionTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


SharedScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
SharedScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : SharedScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all shared scripts for Intersoft controls are stored.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property SharedScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all shared scripts for Intersoft controls are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: System.String; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all shared scripts for Intersoft controls are stored.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set SharedScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all shared scripts for Intersoft controls are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.string* get_SharedScriptDirectory();
public: __property virtual void set_SharedScriptDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all shared scripts for Intersoft controls are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.String^ SharedScriptDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ShouldReturnJson Method

[image]
Intersoft WebEssentials Documentation
ShouldReturnJson Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

value = instance.ShouldReturnJson()
C#
public virtual System.bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): System.Boolean; virtual;
JScript
public function ShouldReturnJson() : System.boolean;
Managed Extensions for C++
public: virtual System.bool ShouldReturnJson();
C++/CLI
public:
virtual System.bool ShouldReturnJson();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


SkinID Property

[image]
Intersoft WebEssentials Documentation
SkinID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


TabIndex Property

[image]
Intersoft WebEssentials Documentation
TabIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set TabIndex : System.short
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ToolTip Property

[image]
Intersoft WebEssentials Documentation
ToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Unload Event

[image]
Intersoft WebEssentials Documentation
Unload Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


UseDefaultStyle Property

[image]
Intersoft WebEssentials Documentation
UseDefaultStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : UseDefaultStyle Property

Glossary Item Box

Determines whether or not WebExpander is using default style.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not WebExpander is using default style.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property UseDefaultStyle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

instance.UseDefaultStyle = value

value = instance.UseDefaultStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebExpander is using default style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool UseDefaultStyle {get; set;}
Delphi
public read-write property UseDefaultStyle: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not WebExpander is using default style.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set UseDefaultStyle : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebExpander is using default style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_UseDefaultStyle();
public: __property void set_UseDefaultStyle(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebExpander is using default style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool UseDefaultStyle {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ValidateRequestMode Property

[image]
Intersoft WebEssentials Documentation
ValidateRequestMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ViewStateItems Property

[image]
Intersoft WebEssentials Documentation
ViewStateItems Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ViewStateItems Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ViewStateMode Property

[image]
Intersoft WebEssentials Documentation
ViewStateMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ViewStateServerConnection Property

[image]
Intersoft WebEssentials Documentation
ViewStateServerConnection Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ViewStateServerConnection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ViewStateServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: System.String; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
System.ComponentModel.CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ViewStateServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ViewStateServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


ViewStateStorage Property

[image]
Intersoft WebEssentials Documentation
ViewStateStorage Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : ViewStateStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
System.ComponentModel.CategoryAttribute("View State Settings")
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


Width Property

[image]
Intersoft WebEssentials Documentation
Width Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overrides Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public override System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; override;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public override function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.Web.UI.WebControls.Unit get_Width() override;
public: __property void set_Width(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


XmlCompressionEnabled Property

[image]
Intersoft WebEssentials Documentation
XmlCompressionEnabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebExpander Class : XmlCompressionEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property XmlCompressionEnabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebExpander
Dim value As System.Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: System.Boolean; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set XmlCompressionEnabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool XmlCompressionEnabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebExpander Class
WebExpander Members


WebListBox Class

[image]
Intersoft WebEssentials Documentation
WebListBox Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBox Class

Glossary Item Box

Object Model

WebListBox Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebListBox.js;", Type=XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebListBoxDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.ComponentModel.DefaultPropertyAttribute("DataSourceID")>
<System.Web.UI.ToolboxDataAttribute("<{0}:WebListBox runat=server Width="100px" Height="400px"></{0}:WebListBox>")>
<System.ComponentModel.DefaultEventAttribute("SelectedItemChanged")>
<System.SerializableAttribute()>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebListBox
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
C#
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebListBox.js;", Type=XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebListBoxDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DefaultPropertyAttribute("DataSourceID")]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebListBox runat=server Width="100px" Height="400px"></{0}:WebListBox>")]
[System.ComponentModel.DefaultEventAttribute("SelectedItemChanged")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebListBox : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Delphi
public class WebListBox = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings)
JScript
ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebListBox.js;", Type=XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebListBoxDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.ComponentModel.DefaultPropertyAttribute("DataSourceID")
System.Web.UI.ToolboxDataAttribute("<{0}:WebListBox runat=server Width="100px" Height="400px"></{0}:WebListBox>")
System.ComponentModel.DefaultEventAttribute("SelectedItemChanged")
System.SerializableAttribute()
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebListBox extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebListBox.js;", Type=XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebListBoxDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DefaultPropertyAttribute("DataSourceID")]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebListBox runat=server Width="100px" Height="400px"></{0}:WebListBox>")]
[System.ComponentModel.DefaultEventAttribute("SelectedItemChanged")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebListBox : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebListBox.js;", Type=XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebListBoxDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DefaultPropertyAttribute("DataSourceID")]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebListBox runat=server Width="100px" Height="400px"></{0}:WebListBox>")]
[System.ComponentModel.DefaultEventAttribute("SelectedItemChanged")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebListBox : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebEssentials.WebListBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Members
ISNet.WebUI.WebEssentials Namespace


WebListBox.PostBackAction Class

[image]
Intersoft WebEssentials Documentation
WebListBox.PostBackAction Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBox.PostBackAction Class

Glossary Item Box

Specifies PostBackAction of WebListBox.

Object Model

WebListBox.PostBackAction Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies PostBackAction of WebListBox.")>
Public Class WebListBox.PostBackAction
Visual Basic (Usage) Copy Code
Dim instance As WebListBox.PostBackAction
C#
[System.ComponentModel.DescriptionAttribute("Specifies PostBackAction of WebListBox.")]
public class WebListBox.PostBackAction
Delphi
public class WebListBox.PostBackAction
JScript
System.ComponentModel.DescriptionAttribute("Specifies PostBackAction of WebListBox.")
public class WebListBox.PostBackAction
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies PostBackAction of WebListBox.")]
public __gc class WebListBox.PostBackAction
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies PostBackAction of WebListBox.")]
public ref class WebListBox.PostBackAction

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebEssentials.WebListBox.PostBackAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox.PostBackAction Members
ISNet.WebUI.WebEssentials Namespace


WebListBox.PostBackAction Class Fields

[image]
Intersoft WebEssentials Documentation
WebListBox.PostBackAction Class Fields
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBox.PostBackAction Class

Glossary Item Box

For a list of all members of this type, see WebListBox.PostBackAction members.

Public Fields

 | Name | Description
Public Field | SelectedItemChanged |
Top

See Also

Reference

WebListBox.PostBackAction Class
ISNet.WebUI.WebEssentials Namespace


WebListBox.PostBackAction Class Members

[image]
Intersoft WebEssentials Documentation
WebListBox.PostBackAction Class Members
See Also Fields Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBox.PostBackAction Class

Glossary Item Box

The following tables list the members exposed by WebListBox.PostBackAction.

Public Constructors

 | Name | Description
Public Constructor | WebListBox.PostBackAction Constructor |
Top

Public Fields

 | Name | Description
Public Field | SelectedItemChanged |
Top

See Also

Reference

WebListBox.PostBackAction Class
ISNet.WebUI.WebEssentials Namespace


WebListBox.PostBackAction Constructor

[image]
Intersoft WebEssentials Documentation
WebListBox.PostBackAction Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox.PostBackAction Class : WebListBox.PostBackAction Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebListBox.PostBackAction()
C#
public WebListBox.PostBackAction()
Delphi
public WebListBox.PostBackAction();
JScript
public function WebListBox.PostBackAction();
Managed Extensions for C++
public: WebListBox.PostBackAction();
C++/CLI
public:
WebListBox.PostBackAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox.PostBackAction Class
WebListBox.PostBackAction Members


SelectedItemChanged Field

[image]
Intersoft WebEssentials Documentation
SelectedItemChanged Field
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox.PostBackAction Class : SelectedItemChanged Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const SelectedItemChanged As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = WebListBox.PostBackAction.SelectedItemChanged
C#
public const System.string SelectedItemChanged
Delphi
public field SelectedItemChanged: System.String; Const
JScript
public constvar SelectedItemChanged : System.String;
Managed Extensions for C++
public: const System.string* SelectedItemChanged
C++/CLI
public:
const System.String^ SelectedItemChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox.PostBackAction Class
WebListBox.PostBackAction Members


WebListBox Class Events

[image]
Intersoft WebEssentials Documentation
WebListBox Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBox Class

Glossary Item Box

For a list of all members of this type, see WebListBox members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | ItemDataBound | Fires when each item is being bound.
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | SelectedItemChanged | Fires when when the selected item is changed.
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebListBox Class
ISNet.WebUI.WebEssentials Namespace


WebListBox Class Members

[image]
Intersoft WebEssentials Documentation
WebListBox Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBox Class

Glossary Item Box

The following tables list the members exposed by WebListBox.

Public Constructors

 | Name | Description
Public Constructor | WebListBox Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | AutoPostBack | Automatically postback to the server after selection is changed. Applicable when selection mode is set to single.
Public Property | BottomScrollerStyle | Contains interactive style for top scroller style.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebListBox
Public Property | ContentFrameStyle | Contains interactive style for the content frame of WebListBox.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DataMember | Gets or sets the data member of WebListBox.
Public Property | DataSourceID | Gets or sets the data source id of WebListBox.
Public Property | DataSourceManager | Overridden.
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableKeyboardSupport | Gets or sets the value that determines whether keyboard support is enabled.
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback.
Public Property | FrameStyle | Contains interactive style for the frame of WebListBox.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImageFieldDataMember | Sets the image field data member.
Public Property | ImageFieldFormatString | Sets the format string of image field.
Public Property | ImagesDirectory | Gets or sets the images directory for ImagesSettings.
Public Property | ImagesSettings | Provides the settings that control the images in WebListBox.
Public Property | IndicatorStyle | Contains interactive style for the active item's indicator style.
Public Property | ItemImageStyle | Contains interactive style for the item image style.
Public Property | Items | The item collection of WebListBoxItem
Public Property | ItemStyle | Contains interactive style for item style.
Public Property | ItemTextStyle | Contains interactive style for the item text style.
Public Property | LayoutSettings | Provides the settings that control the behaviors of the layout in WebListBox.
Public Property | NameFieldDataMember | Sets the name field data member.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PostBackMode | Gets or sets the value that determines the postback mode when AutoPostBack is enabled.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SelectedIndex | Gets or sets the index that determines the selected item.
Public Property | SelectionMode | Gets or sets the value that determines whether to use single or multiple selection mode.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TargetURLFieldDataMember | Sets the target url field date member.
Public Property | TextFieldDataMember | Sets the text field data member.
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TopScrollerStyle | Contains interactive style for top scroller style.
Public Property | UseDefaultStyle | Specifies whether WebListBox should apply embedded default style for its appearance.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ValueFieldDataMember | Sets the value field data member.
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction | Gets ClientAction class.
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetValues | Gets the selected value collection.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetValue | Sets the selected value of WebListBox.
Public Method | SetValues | Sets the selected values of WebListBox.
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | ItemDataBound | Fires when each item is being bound.
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | SelectedItemChanged | Fires when when the selected item is changed.
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebListBox Class
ISNet.WebUI.WebEssentials Namespace


WebListBox Class Methods

[image]
Intersoft WebEssentials Documentation
WebListBox Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBox Class

Glossary Item Box

For a list of all members of this type, see WebListBox members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CustomDeserialize |
Public Method | CustomSerialize |
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction | Gets ClientAction class.
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | GetValues | Gets the selected value collection.
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetValue | Sets the selected value of WebListBox.
Public Method | SetValues | Sets the selected values of WebListBox.
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebListBox Class
ISNet.WebUI.WebEssentials Namespace


WebListBox Class Properties

[image]
Intersoft WebEssentials Documentation
WebListBox Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBox Class

Glossary Item Box

For a list of all members of this type, see WebListBox members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | AutoPostBack | Automatically postback to the server after selection is changed. Applicable when selection mode is set to single.
Public Property | BottomScrollerStyle | Contains interactive style for top scroller style.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebListBox
Public Property | ContentFrameStyle | Contains interactive style for the content frame of WebListBox.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DataMember | Gets or sets the data member of WebListBox.
Public Property | DataSourceID | Gets or sets the data source id of WebListBox.
Public Property | DataSourceManager | Overridden.
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableKeyboardSupport | Gets or sets the value that determines whether keyboard support is enabled.
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback.
Public Property | FrameStyle | Contains interactive style for the frame of WebListBox.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImageFieldDataMember | Sets the image field data member.
Public Property | ImageFieldFormatString | Sets the format string of image field.
Public Property | ImagesDirectory | Gets or sets the images directory for ImagesSettings.
Public Property | ImagesSettings | Provides the settings that control the images in WebListBox.
Public Property | IndicatorStyle | Contains interactive style for the active item's indicator style.
Public Property | ItemImageStyle | Contains interactive style for the item image style.
Public Property | Items | The item collection of WebListBoxItem
Public Property | ItemStyle | Contains interactive style for item style.
Public Property | ItemTextStyle | Contains interactive style for the item text style.
Public Property | LayoutSettings | Provides the settings that control the behaviors of the layout in WebListBox.
Public Property | NameFieldDataMember | Sets the name field data member.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PostBackMode | Gets or sets the value that determines the postback mode when AutoPostBack is enabled.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SelectedIndex | Gets or sets the index that determines the selected item.
Public Property | SelectionMode | Gets or sets the value that determines whether to use single or multiple selection mode.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TargetURLFieldDataMember | Sets the target url field date member.
Public Property | TextFieldDataMember | Sets the text field data member.
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TopScrollerStyle | Contains interactive style for top scroller style.
Public Property | UseDefaultStyle | Specifies whether WebListBox should apply embedded default style for its appearance.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ValueFieldDataMember | Sets the value field data member.
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebListBox Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxClientSideEvents Class

[image]
Intersoft WebEssentials Documentation
WebListBoxClientSideEvents Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxClientSideEvents Class

Glossary Item Box

A collection of WebListBox's client side events.

Object Model

WebListBoxClientSideEvents Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("A collection of WebListBox's client side events.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebListBoxClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
C#
[System.ComponentModel.DescriptionAttribute("A collection of WebListBox's client side events.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebListBoxClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebListBoxClientSideEvents = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.ComponentModel.DescriptionAttribute("A collection of WebListBox's client side events.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebListBoxClientSideEvents extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("A collection of WebListBox's client side events.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebListBoxClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.ComponentModel.DescriptionAttribute("A collection of WebListBox's client side events.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebListBoxClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebListBoxClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Members
ISNet.WebUI.WebEssentials Namespace


WebListBoxClientSideEvents Class Members

[image]
Intersoft WebEssentials Documentation
WebListBoxClientSideEvents Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebListBoxClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebListBoxClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnAfterItemSelected | Gets or sets the event handler after item(s) are selected.
Public Property | OnBeforeItemSelected | Gets or sets the event handler before item(s) are selected.
Public Property | OnInitialize | Gets or sets the event handler when the control is being initialized.
Public Property | OnItemMouseOut | Gets or sets the event handler when mouse out action is performed to an item.
Public Property | OnItemMouseOver | Gets or sets the event handler when an item is hovered.
Public Property | OnKeyUp | Gets or sets the event handler that will be invoked in key up action.
Public Property | OnResponse | Gets or sets the event handler on response.
Public Property | OnResponseError | Gets or sets the event handler that will be invoked when the callback action returns error response.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebListBoxClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxClientSideEvents Class Methods

[image]
Intersoft WebEssentials Documentation
WebListBoxClientSideEvents Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebListBoxClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebListBoxClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxClientSideEvents Class Properties

[image]
Intersoft WebEssentials Documentation
WebListBoxClientSideEvents Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebListBoxClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnAfterItemSelected | Gets or sets the event handler after item(s) are selected.
Public Property | OnBeforeItemSelected | Gets or sets the event handler before item(s) are selected.
Public Property | OnInitialize | Gets or sets the event handler when the control is being initialized.
Public Property | OnItemMouseOut | Gets or sets the event handler when mouse out action is performed to an item.
Public Property | OnItemMouseOver | Gets or sets the event handler when an item is hovered.
Public Property | OnKeyUp | Gets or sets the event handler that will be invoked in key up action.
Public Property | OnResponse | Gets or sets the event handler on response.
Public Property | OnResponseError | Gets or sets the event handler that will be invoked when the callback action returns error response.
Top

See Also

Reference

WebListBoxClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebListBoxClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : WebListBoxClientSideEvents Constructor

Glossary Item Box

Overload List

Overload | Description
WebListBoxClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


WebListBoxClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebListBoxClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : WebListBoxClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebListBoxClientSideEvents()
C#
public WebListBoxClientSideEvents()
Delphi
public WebListBoxClientSideEvents();
JScript
public function WebListBoxClientSideEvents();
Managed Extensions for C++
public: WebListBoxClientSideEvents();
C++/CLI
public:
WebListBoxClientSideEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


OnAfterItemSelected Property

[image]
Intersoft WebEssentials Documentation
OnAfterItemSelected Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : OnAfterItemSelected Property

Glossary Item Box

Gets or sets the event handler after item(s) are selected.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after item(s) are selected.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.EventParameterAttribute("controlId, selectedItems")>
Public Property OnAfterItemSelected As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim value As System.String

instance.OnAfterItemSelected = value

value = instance.OnAfterItemSelected
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after item(s) are selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, selectedItems")]
public System.string OnAfterItemSelected {get; set;}
Delphi
public read-write property OnAfterItemSelected: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after item(s) are selected.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
ISNet.EventParameterAttribute("controlId, selectedItems")
public function get,set OnAfterItemSelected : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after item(s) are selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, selectedItems")]
public: __property System.string* get_OnAfterItemSelected();
public: __property void set_OnAfterItemSelected(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after item(s) are selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.EventParameterAttribute("controlId, selectedItems")]
public:
property System.String^ OnAfterItemSelected {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


OnBeforeItemSelected Property

[image]
Intersoft WebEssentials Documentation
OnBeforeItemSelected Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : OnBeforeItemSelected Property

Glossary Item Box

Gets or sets the event handler before item(s) are selected.

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId, selectedItem")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before item(s) are selected.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnBeforeItemSelected As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim value As System.String

instance.OnBeforeItemSelected = value

value = instance.OnBeforeItemSelected
C#
[ISNet.EventParameterAttribute("controlId, selectedItem")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before item(s) are selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnBeforeItemSelected {get; set;}
Delphi
public read-write property OnBeforeItemSelected: System.String;
JScript
ISNet.EventParameterAttribute("controlId, selectedItem")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before item(s) are selected.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set OnBeforeItemSelected : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId, selectedItem")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before item(s) are selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnBeforeItemSelected();
public: __property void set_OnBeforeItemSelected(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId, selectedItem")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before item(s) are selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnBeforeItemSelected {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebEssentials Documentation
OnInitialize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : OnInitialize Property

Glossary Item Box

Gets or sets the event handler when the control is being initialized.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the control is being initialized.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim value As System.String

instance.OnInitialize = value

value = instance.OnInitialize
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the control is being initialized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnInitialize {get; set;}
Delphi
public read-write property OnInitialize: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the control is being initialized.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnInitialize : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the control is being initialized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnInitialize();
public: __property void set_OnInitialize(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the control is being initialized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


OnItemMouseOut Property

[image]
Intersoft WebEssentials Documentation
OnItemMouseOut Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : OnItemMouseOut Property

Glossary Item Box

Gets or sets the event handler when mouse out action is performed to an item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, itemObject, itemElement")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when mouse out action is performed to an item.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnItemMouseOut As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim value As System.String

instance.OnItemMouseOut = value

value = instance.OnItemMouseOut
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, itemObject, itemElement")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when mouse out action is performed to an item.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnItemMouseOut {get; set;}
Delphi
public read-write property OnItemMouseOut: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId, itemObject, itemElement")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when mouse out action is performed to an item.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnItemMouseOut : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, itemObject, itemElement")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when mouse out action is performed to an item.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnItemMouseOut();
public: __property void set_OnItemMouseOut(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, itemObject, itemElement")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when mouse out action is performed to an item.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnItemMouseOut {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


OnItemMouseOver Property

[image]
Intersoft WebEssentials Documentation
OnItemMouseOver Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : OnItemMouseOver Property

Glossary Item Box

Gets or sets the event handler when an item is hovered.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an item is hovered.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.EventParameterAttribute("controlId, itemObject, itemElement")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnItemMouseOver As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim value As System.String

instance.OnItemMouseOver = value

value = instance.OnItemMouseOver
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an item is hovered.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, itemObject, itemElement")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnItemMouseOver {get; set;}
Delphi
public read-write property OnItemMouseOver: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an item is hovered.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.EventParameterAttribute("controlId, itemObject, itemElement")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnItemMouseOver : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an item is hovered.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, itemObject, itemElement")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnItemMouseOver();
public: __property void set_OnItemMouseOver(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an item is hovered.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, itemObject, itemElement")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnItemMouseOver {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


OnKeyUp Property

[image]
Intersoft WebEssentials Documentation
OnKeyUp Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : OnKeyUp Property

Glossary Item Box

Gets or sets the event handler that will be invoked in key up action.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, keyCode")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked in key up action.")>
Public Property OnKeyUp As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim value As System.String

instance.OnKeyUp = value

value = instance.OnKeyUp
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, keyCode")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked in key up action.")]
public System.string OnKeyUp {get; set;}
Delphi
public read-write property OnKeyUp: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, keyCode")
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked in key up action.")
public function get,set OnKeyUp : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, keyCode")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked in key up action.")]
public: __property System.string* get_OnKeyUp();
public: __property void set_OnKeyUp(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, keyCode")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked in key up action.")]
public:
property System.String^ OnKeyUp {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


OnResponse Property

[image]
Intersoft WebEssentials Documentation
OnResponse Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : OnResponse Property

Glossary Item Box

Gets or sets the event handler on response.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.EventParameterAttribute("controlId, action")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")>
Public Property OnResponse As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim value As System.String

instance.OnResponse = value

value = instance.OnResponse
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
public System.string OnResponse {get; set;}
Delphi
public read-write property OnResponse: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.EventParameterAttribute("controlId, action")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")
public function get,set OnResponse : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
public: __property System.string* get_OnResponse();
public: __property void set_OnResponse(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
public:
property System.String^ OnResponse {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


OnResponseError Property

[image]
Intersoft WebEssentials Documentation
OnResponseError Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : OnResponseError Property

Glossary Item Box

Gets or sets the event handler that will be invoked when the callback action returns error response.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, action, errorMessage")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the callback action returns error response.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnResponseError As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim value As System.String

instance.OnResponseError = value

value = instance.OnResponseError
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, action, errorMessage")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the callback action returns error response.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnResponseError {get; set;}
Delphi
public read-write property OnResponseError: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, action, errorMessage")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the callback action returns error response.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnResponseError : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, action, errorMessage")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the callback action returns error response.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnResponseError();
public: __property void set_OnResponseError(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, action, errorMessage")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the callback action returns error response.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnResponseError {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxClientSideEvents
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxClientSideEvents Class
WebListBoxClientSideEvents Members


WebListBoxDataSourceInfo Class

[image]
Intersoft WebEssentials Documentation
WebListBoxDataSourceInfo Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxDataSourceInfo Class

Glossary Item Box

Sets the data source info of WebListBox.

Object Model

WebListBoxDataSourceInfo Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the data source info of WebListBox.")>
Public Class WebListBoxDataSourceInfo
   Inherits ISNet.WebUI.DataSourceInfo
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
C#
[System.ComponentModel.DescriptionAttribute("Sets the data source info of WebListBox.")]
public class WebListBoxDataSourceInfo : ISNet.WebUI.DataSourceInfo
Delphi
public class WebListBoxDataSourceInfo = class(ISNet.WebUI.DataSourceInfo)
JScript
System.ComponentModel.DescriptionAttribute("Sets the data source info of WebListBox.")
public class WebListBoxDataSourceInfo extends ISNet.WebUI.DataSourceInfo
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the data source info of WebListBox.")]
public __gc class WebListBoxDataSourceInfo : public ISNet.WebUI.DataSourceInfo
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the data source info of WebListBox.")]
public ref class WebListBoxDataSourceInfo : public ISNet.WebUI.DataSourceInfo

Inheritance Hierarchy

System.Object
ISNet.WebUI.DataSourceInfo
ISNet.WebUI.WebEssentials.WebListBoxDataSourceInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Members
ISNet.WebUI.WebEssentials Namespace


WebListBoxDataSourceInfo Class Events

[image]
Intersoft WebEssentials Documentation
WebListBoxDataSourceInfo Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxDataSourceInfo Class

Glossary Item Box

For a list of all members of this type, see WebListBoxDataSourceInfo members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Event | DataBound | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

See Also

Reference

WebListBoxDataSourceInfo Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxDataSourceInfo Class Members

[image]
Intersoft WebEssentials Documentation
WebListBoxDataSourceInfo Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxDataSourceInfo Class

Glossary Item Box

The following tables list the members exposed by WebListBoxDataSourceInfo.

Public Constructors

 | Name | Description
Public Constructor | WebListBoxDataSourceInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | Control | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | CurrentDataSource | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IgnoreDataSourceViewChanged | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IsBoundUsingDataSourceID | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IsDataSourceViewValid | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | RequiresDataBinding | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | SelectArguments | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

Public Methods

 | Name | Description
Public Method | DataBind | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | EnsureDataBound | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | FindControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetData | Overloaded. (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetDataSourceControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetDataSourceID | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetSelectParameters | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetTable | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | IsIntersoftDataSourceControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | SetViewValid | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | ValidateDataSource | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Event | DataBound | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

See Also

Reference

WebListBoxDataSourceInfo Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxDataSourceInfo Class Methods

[image]
Intersoft WebEssentials Documentation
WebListBoxDataSourceInfo Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxDataSourceInfo Class

Glossary Item Box

For a list of all members of this type, see WebListBoxDataSourceInfo members.

Public Methods

 | Name | Description
Public Method | DataBind | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | EnsureDataBound | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | FindControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetData | Overloaded. (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetDataSourceControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetDataSourceID | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetSelectParameters | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetTable | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | IsIntersoftDataSourceControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | SetViewValid | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | ValidateDataSource | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

See Also

Reference

WebListBoxDataSourceInfo Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxDataSourceInfo Class Properties

[image]
Intersoft WebEssentials Documentation
WebListBoxDataSourceInfo Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxDataSourceInfo Class

Glossary Item Box

For a list of all members of this type, see WebListBoxDataSourceInfo members.

Public Properties

 | Name | Description
Public Property | Control | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | CurrentDataSource | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IgnoreDataSourceViewChanged | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IsBoundUsingDataSourceID | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IsDataSourceViewValid | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | RequiresDataBinding | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | SelectArguments | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

See Also

Reference

WebListBoxDataSourceInfo Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxDataSourceInfo Constructor

[image]
Intersoft WebEssentials Documentation
WebListBoxDataSourceInfo Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : WebListBoxDataSourceInfo Constructor

listBox

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal listBox As WebListBox _
)
Visual Basic (Usage) Copy Code
Dim listBox As WebListBox

Dim instance As New WebListBoxDataSourceInfo(listBox)
C#
public WebListBoxDataSourceInfo(
   WebListBox listBox
)
Delphi
public WebListBoxDataSourceInfo(
    listBox: WebListBox
);
JScript
public function WebListBoxDataSourceInfo(
   listBox : WebListBox
);
Managed Extensions for C++
public: WebListBoxDataSourceInfo(
   WebListBox* listBox
)
C++/CLI
public:
WebListBoxDataSourceInfo(
   WebListBox^ listBox
)

Parameters

listBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


Control Property

[image]
Intersoft WebEssentials Documentation
Control Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : Control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As ISNet.WebUI.ISNetControl
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim value As ISNet.WebUI.ISNetControl

value = instance.Control
C#
public ISNet.WebUI.ISNetControl Control {get;}
Delphi
public read-only property Control: ISNet.WebUI.ISNetControl;
JScript
public function get Control : ISNet.WebUI.ISNetControl
Managed Extensions for C++
public: __property ISNet.WebUI.ISNetControl* get_Control();
C++/CLI
public:
property ISNet.WebUI.ISNetControl^ Control {
   ISNet.WebUI.ISNetControl^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


CurrentDataSource Property

[image]
Intersoft WebEssentials Documentation
CurrentDataSource Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : CurrentDataSource Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentDataSource As System.Collections.IEnumerable
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim value As System.Collections.IEnumerable

value = instance.CurrentDataSource
C#
public System.Collections.IEnumerable CurrentDataSource {get;}
Delphi
public read-only property CurrentDataSource: System.Collections.IEnumerable;
JScript
public function get CurrentDataSource : System.Collections.IEnumerable
Managed Extensions for C++
public: __property System.Collections.IEnumerable* get_CurrentDataSource();
C++/CLI
public:
property System.Collections.IEnumerable^ CurrentDataSource {
   System.Collections.IEnumerable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


DataBind Method

[image]
Intersoft WebEssentials Documentation
DataBind Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : DataBind Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo

instance.DataBind()
C#
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
public function DataBind();
Managed Extensions for C++
public: virtual void DataBind();
C++/CLI
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


DataBinding Event

[image]
Intersoft WebEssentials Documentation
DataBinding Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* DataBinding
C++/CLI
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


DataBound Event

[image]
Intersoft WebEssentials Documentation
DataBound Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : DataBound Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBound As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim handler As System.EventHandler

AddHandler instance.DataBound, handler
C#
public event System.EventHandler DataBound
Delphi
public event DataBound: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* DataBound
C++/CLI
public:
event System.EventHandler^ DataBound

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


EnsureDataBound Method

[image]
Intersoft WebEssentials Documentation
EnsureDataBound Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : EnsureDataBound Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub EnsureDataBound()
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo

instance.EnsureDataBound()
C#
public virtual void EnsureDataBound()
Delphi
public procedure EnsureDataBound(); virtual;
JScript
public function EnsureDataBound();
Managed Extensions for C++
public: virtual void EnsureDataBound();
C++/CLI
public:
virtual void EnsureDataBound();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


FindControl Method

[image]
Intersoft WebEssentials Documentation
FindControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : FindControl Method

control
controlID

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function FindControl( _
   ByVal control As System.Web.UI.Control, _
   ByVal controlID As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim control As System.Web.UI.Control
Dim controlID As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(control, controlID)
C#
public System.Web.UI.Control FindControl(
   System.Web.UI.Control control,
   System.string controlID
)
Delphi
public function FindControl(
    control: System.Web.UI.Control;
    controlID: System.String
): System.Web.UI.Control;
JScript
public function FindControl(
   control : System.Web.UI.Control,
   controlID : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: System.Web.UI.Control* FindControl(
   System.Web.UI.Control* control,
   System.string* controlID
)
C++/CLI
public:
System.Web.UI.Control^ FindControl(
   System.Web.UI.Control^ control,
   System.String^ controlID
)

Parameters

control
controlID

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


GetData Method

[image]
Intersoft WebEssentials Documentation
GetData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : GetData Method

Glossary Item Box

Overload List

Overload | Description
GetData() | (Inherited from ISNet.WebUI.DataSourceInfo)
GetData(String) | (Inherited from ISNet.WebUI.DataSourceInfo)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


GetData() Method

[image]
Intersoft WebEssentials Documentation
GetData() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class > GetData Method : GetData() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetData() As System.Web.UI.DataSourceView
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim value As System.Web.UI.DataSourceView

value = instance.GetData()
C#
public System.Web.UI.DataSourceView GetData()
Delphi
public function GetData(): System.Web.UI.DataSourceView;
JScript
public function GetData() : System.Web.UI.DataSourceView;
Managed Extensions for C++
public: System.Web.UI.DataSourceView* GetData();
C++/CLI
public:
System.Web.UI.DataSourceView^ GetData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members
Overload List


GetData(String) Method

[image]
Intersoft WebEssentials Documentation
GetData(String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class > GetData Method : GetData(String) Method

viewName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetData( _
   ByVal viewName As System.String _
) As System.Web.UI.DataSourceView
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim viewName As System.String
Dim value As System.Web.UI.DataSourceView

value = instance.GetData(viewName)
C#
public System.Web.UI.DataSourceView GetData(
   System.string viewName
)
Delphi
public function GetData(
    viewName: System.String
): System.Web.UI.DataSourceView;
JScript
public function GetData(
   viewName : System.String
) : System.Web.UI.DataSourceView;
Managed Extensions for C++
public: System.Web.UI.DataSourceView* GetData(
   System.string* viewName
)
C++/CLI
public:
System.Web.UI.DataSourceView^ GetData(
   System.String^ viewName
)

Parameters

viewName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members
Overload List


GetDataSourceControl Method

[image]
Intersoft WebEssentials Documentation
GetDataSourceControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : GetDataSourceControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetDataSourceControl() As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim value As System.Web.UI.Control

value = instance.GetDataSourceControl()
C#
public System.Web.UI.Control GetDataSourceControl()
Delphi
public function GetDataSourceControl(): System.Web.UI.Control;
JScript
public function GetDataSourceControl() : System.Web.UI.Control;
Managed Extensions for C++
public: System.Web.UI.Control* GetDataSourceControl();
C++/CLI
public:
System.Web.UI.Control^ GetDataSourceControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


GetDataSourceID Method

[image]
Intersoft WebEssentials Documentation
GetDataSourceID Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : GetDataSourceID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetDataSourceID() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim value As System.String

value = instance.GetDataSourceID()
C#
public System.string GetDataSourceID()
Delphi
public function GetDataSourceID(): System.String;
JScript
public function GetDataSourceID() : System.String;
Managed Extensions for C++
public: System.string* GetDataSourceID();
C++/CLI
public:
System.String^ GetDataSourceID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


GetSelectParameters Method

[image]
Intersoft WebEssentials Documentation
GetSelectParameters Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : GetSelectParameters Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetSelectParameters() As System.Web.UI.WebControls.ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim value As System.Web.UI.WebControls.ParameterCollection

value = instance.GetSelectParameters()
C#
public System.Web.UI.WebControls.ParameterCollection GetSelectParameters()
Delphi
public function GetSelectParameters(): System.Web.UI.WebControls.ParameterCollection;
JScript
public function GetSelectParameters() : System.Web.UI.WebControls.ParameterCollection;
Managed Extensions for C++
public: System.Web.UI.WebControls.ParameterCollection* GetSelectParameters();
C++/CLI
public:
System.Web.UI.WebControls.ParameterCollection^ GetSelectParameters();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


GetTable Method

[image]
Intersoft WebEssentials Documentation
GetTable Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : GetTable Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetTable( _
   ByVal name As System.String _
) As ISNet.WebUI.IDataSourceTable
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim name As System.String
Dim value As ISNet.WebUI.IDataSourceTable

value = instance.GetTable(name)
C#
public ISNet.WebUI.IDataSourceTable GetTable(
   System.string name
)
Delphi
public function GetTable(
    name: System.String
): ISNet.WebUI.IDataSourceTable;
JScript
public function GetTable(
   name : System.String
) : ISNet.WebUI.IDataSourceTable;
Managed Extensions for C++
public: ISNet.WebUI.IDataSourceTable* GetTable(
   System.string* name
)
C++/CLI
public:
ISNet.WebUI.IDataSourceTable^ GetTable(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


IgnoreDataSourceViewChanged Property

[image]
Intersoft WebEssentials Documentation
IgnoreDataSourceViewChanged Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : IgnoreDataSourceViewChanged Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public WriteOnly Property IgnoreDataSourceViewChanged As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo

instance.IgnoreDataSourceViewChanged = value
C#
public System.bool IgnoreDataSourceViewChanged {set;}
Delphi
public write-only property IgnoreDataSourceViewChanged: System.Boolean;
JScript
public function set IgnoreDataSourceViewChanged : System.boolean
Managed Extensions for C++
public: __property void set_IgnoreDataSourceViewChanged(
   System.bool value
);
C++/CLI
public:
property System.bool IgnoreDataSourceViewChanged {
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


IsBoundUsingDataSourceID Property

[image]
Intersoft WebEssentials Documentation
IsBoundUsingDataSourceID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : IsBoundUsingDataSourceID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsBoundUsingDataSourceID As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim value As System.Boolean

value = instance.IsBoundUsingDataSourceID
C#
public System.bool IsBoundUsingDataSourceID {get;}
Delphi
public read-only property IsBoundUsingDataSourceID: System.Boolean;
JScript
public function get IsBoundUsingDataSourceID : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsBoundUsingDataSourceID();
C++/CLI
public:
property System.bool IsBoundUsingDataSourceID {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


IsDataSourceViewValid Property

[image]
Intersoft WebEssentials Documentation
IsDataSourceViewValid Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : IsDataSourceViewValid Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDataSourceViewValid As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim value As System.Boolean

value = instance.IsDataSourceViewValid
C#
public System.bool IsDataSourceViewValid {get;}
Delphi
public read-only property IsDataSourceViewValid: System.Boolean;
JScript
public function get IsDataSourceViewValid : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsDataSourceViewValid();
C++/CLI
public:
property System.bool IsDataSourceViewValid {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


IsIntersoftDataSourceControl Method

[image]
Intersoft WebEssentials Documentation
IsIntersoftDataSourceControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : IsIntersoftDataSourceControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsIntersoftDataSourceControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim value As System.Boolean

value = instance.IsIntersoftDataSourceControl()
C#
public System.bool IsIntersoftDataSourceControl()
Delphi
public function IsIntersoftDataSourceControl(): System.Boolean;
JScript
public function IsIntersoftDataSourceControl() : System.boolean;
Managed Extensions for C++
public: System.bool IsIntersoftDataSourceControl();
C++/CLI
public:
System.bool IsIntersoftDataSourceControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


RequiresDataBinding Property

[image]
Intersoft WebEssentials Documentation
RequiresDataBinding Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : RequiresDataBinding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property RequiresDataBinding As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim value As System.Boolean

instance.RequiresDataBinding = value

value = instance.RequiresDataBinding
C#
public System.bool RequiresDataBinding {get; set;}
Delphi
public read-write property RequiresDataBinding: System.Boolean;
JScript
public function get,set RequiresDataBinding : System.boolean
Managed Extensions for C++
public: __property System.bool get_RequiresDataBinding();
public: __property void set_RequiresDataBinding(
   System.bool value
);
C++/CLI
public:
property System.bool RequiresDataBinding {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


SelectArguments Property

[image]
Intersoft WebEssentials Documentation
SelectArguments Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : SelectArguments Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectArguments As System.Web.UI.DataSourceSelectArguments
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim value As System.Web.UI.DataSourceSelectArguments

value = instance.SelectArguments
C#
public System.Web.UI.DataSourceSelectArguments SelectArguments {get;}
Delphi
public read-only property SelectArguments: System.Web.UI.DataSourceSelectArguments;
JScript
public function get SelectArguments : System.Web.UI.DataSourceSelectArguments
Managed Extensions for C++
public: __property System.Web.UI.DataSourceSelectArguments* get_SelectArguments();
C++/CLI
public:
property System.Web.UI.DataSourceSelectArguments^ SelectArguments {
   System.Web.UI.DataSourceSelectArguments^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


SetViewValid Method

[image]
Intersoft WebEssentials Documentation
SetViewValid Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : SetViewValid Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetViewValid()
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo

instance.SetViewValid()
C#
public void SetViewValid()
Delphi
public procedure SetViewValid();
JScript
public function SetViewValid();
Managed Extensions for C++
public: void SetViewValid();
C++/CLI
public:
void SetViewValid();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


ValidateDataSource Method

[image]
Intersoft WebEssentials Documentation
ValidateDataSource Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxDataSourceInfo Class : ValidateDataSource Method

dataSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ValidateDataSource( _
   ByVal dataSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDataSourceInfo
Dim dataSource As System.Object

instance.ValidateDataSource(dataSource)
C#
public void ValidateDataSource(
   System.object dataSource
)
Delphi
public procedure ValidateDataSource(
    dataSource: System.TObject
);
JScript
public function ValidateDataSource(
   dataSource : System.Object
);
Managed Extensions for C++
public: void ValidateDataSource(
   System.Object* dataSource
)
C++/CLI
public:
void ValidateDataSource(
   System.Object^ dataSource
)

Parameters

dataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxDataSourceInfo Class
WebListBoxDataSourceInfo Members


WebListBoxDefaultStyleMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebListBoxDefaultStyleMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxDefaultStyleMode Enumeration

Glossary Item Box

Specifies default style mode in WebListBox.

Syntax

Visual Basic (Declaration)
Public Enum WebListBoxDefaultStyleMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDefaultStyleMode
C#
public enum WebListBoxDefaultStyleMode : System.Enum
Delphi
public enum WebListBoxDefaultStyleMode = class(System.Enum)
JScript
public enum WebListBoxDefaultStyleMode extends System.Enum
Managed Extensions for C++
__value public enum WebListBoxDefaultStyleMode : public System.Enum
C++/CLI
public enum class WebListBoxDefaultStyleMode : public System.Enum

Members

Member | Description
Minimalist |
Natural |
OutlookBlue |
Silver |
Win7 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebListBoxDefaultStyleMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebListBoxDisplayMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebListBoxDisplayMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxDisplayMode Enumeration

Glossary Item Box

Specifies display mode in WebListBox.

Syntax

Visual Basic (Declaration)
Public Enum WebListBoxDisplayMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxDisplayMode
C#
public enum WebListBoxDisplayMode : System.Enum
Delphi
public enum WebListBoxDisplayMode = class(System.Enum)
JScript
public enum WebListBoxDisplayMode extends System.Enum
Managed Extensions for C++
__value public enum WebListBoxDisplayMode : public System.Enum
C++/CLI
public enum class WebListBoxDisplayMode : public System.Enum

Members

Member | Description
Default |
Image |
Text |
TextAndImage |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebListBoxDisplayMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebListBoxImagePosition Enumeration

[image]
Intersoft WebEssentials Documentation
WebListBoxImagePosition Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxImagePosition Enumeration

Glossary Item Box

Specifies image position in WebListBox.

Syntax

Visual Basic (Declaration)
Public Enum WebListBoxImagePosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxImagePosition
C#
public enum WebListBoxImagePosition : System.Enum
Delphi
public enum WebListBoxImagePosition = class(System.Enum)
JScript
public enum WebListBoxImagePosition extends System.Enum
Managed Extensions for C++
__value public enum WebListBoxImagePosition : public System.Enum
C++/CLI
public enum class WebListBoxImagePosition : public System.Enum

Members

Member | Description
AboveText |
AfterText |
BeforeText |
BelowText |
Default |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebListBoxImagePosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebListBoxImagesSettings Class

[image]
Intersoft WebEssentials Documentation
WebListBoxImagesSettings Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxImagesSettings Class

Glossary Item Box

A collection of WebListBox's images settings.

Object Model

WebListBoxImagesSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("A collection of WebListBox's images settings.")>
<System.SerializableAttribute()>
Public Class WebListBoxImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxImagesSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("A collection of WebListBox's images settings.")]
[System.SerializableAttribute()]
public class WebListBoxImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebListBoxImagesSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("A collection of WebListBox's images settings.")
System.SerializableAttribute()
public class WebListBoxImagesSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("A collection of WebListBox's images settings.")]
[System.SerializableAttribute()]
public __gc class WebListBoxImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("A collection of WebListBox's images settings.")]
[System.SerializableAttribute()]
public ref class WebListBoxImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebListBoxImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Members
ISNet.WebUI.WebEssentials Namespace


WebListBoxImagesSettings Class Members

[image]
Intersoft WebEssentials Documentation
WebListBoxImagesSettings Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebListBoxImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebListBoxImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | BottomScroller | Gets or sets the default image used for bottom scroller.
Public Property | TopScroller | Gets or sets the default image used for top scroller.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebListBoxImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxImagesSettings Class Methods

[image]
Intersoft WebEssentials Documentation
WebListBoxImagesSettings Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebListBoxImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebListBoxImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxImagesSettings Class Properties

[image]
Intersoft WebEssentials Documentation
WebListBoxImagesSettings Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebListBoxImagesSettings members.

Public Properties

 | Name | Description
Public Property | BottomScroller | Gets or sets the default image used for bottom scroller.
Public Property | TopScroller | Gets or sets the default image used for top scroller.
Top

See Also

Reference

WebListBoxImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxImagesSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebListBoxImagesSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class : WebListBoxImagesSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebListBoxImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members


WebListBoxImagesSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebListBoxImagesSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class : WebListBoxImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebListBoxImagesSettings()
C#
public WebListBoxImagesSettings()
Delphi
public WebListBoxImagesSettings();
JScript
public function WebListBoxImagesSettings();
Managed Extensions for C++
public: WebListBoxImagesSettings();
C++/CLI
public:
WebListBoxImagesSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members


BottomScroller Property

[image]
Intersoft WebEssentials Documentation
BottomScroller Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class : BottomScroller Property

Glossary Item Box

Gets or sets the default image used for bottom scroller.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for bottom scroller.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property BottomScroller As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxImagesSettings
Dim value As System.String

instance.BottomScroller = value

value = instance.BottomScroller
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for bottom scroller.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string BottomScroller {get; set;}
Delphi
public read-write property BottomScroller: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for bottom scroller.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set BottomScroller : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for bottom scroller.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_BottomScroller();
public: __property void set_BottomScroller(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for bottom scroller.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ BottomScroller {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxImagesSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxImagesSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxImagesSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxImagesSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxImagesSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxImagesSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members


TopScroller Property

[image]
Intersoft WebEssentials Documentation
TopScroller Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class : TopScroller Property

Glossary Item Box

Gets or sets the default image used for top scroller.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for top scroller.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property TopScroller As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxImagesSettings
Dim value As System.String

instance.TopScroller = value

value = instance.TopScroller
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for top scroller.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string TopScroller {get; set;}
Delphi
public read-write property TopScroller: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for top scroller.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set TopScroller : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for top scroller.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_TopScroller();
public: __property void set_TopScroller(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for top scroller.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ TopScroller {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxImagesSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxImagesSettings Class
WebListBoxImagesSettings Members


WebListBoxItem Class

[image]
Intersoft WebEssentials Documentation
WebListBoxItem Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxItem Class

Glossary Item Box

WebListBoxItem object of WebListBox.

Object Model

WebListBoxItem Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebListBoxItem
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebListBoxItem : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebListBoxItem = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebListBoxItem extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebListBoxItem : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebListBoxItem : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebEssentials.WebListBoxItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Members
ISNet.WebUI.WebEssentials Namespace


WebListBoxItem Class Members

[image]
Intersoft WebEssentials Documentation
WebListBoxItem Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxItem Class

Glossary Item Box

The following tables list the members exposed by WebListBoxItem.

Public Constructors

 | Name | Description
Public Constructor | WebListBoxItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | CustomAttributes | Gets or sets the tooltip of item.
Public Property | DisplayMode | Gets or sets the display mode of item.
Public Property | Enabled | Gets or sets the value that determines whether or not an item is enabled.
Public Property | Image | Gets or sets the image url of item.
Public Property | ImagePosition | Gets or sets the value that determines the position of image in an item.
Public Property | ImageSize | Gets or sets the value that determines the image size of an item.
Public Property | ItemActiveClass | Gets or sets the css class applied to item in active state.
Public Property | ItemAlignment | Gets or sets the alignment of item.
Public Property | ItemHeight | Gets or sets the height of item.
Public Property | ItemHoverClass | Gets or sets the css class applied to item in hover state.
Public Property | ItemImageClass | Gets or sets the css class applied to the image of item.
Public Property | ItemNormalClass | Gets or sets the css class applied to item in normal state.
Public Property | ItemTextClass | Gets or sets the css class applied to the text of item.
Public Property | Name | Overridden. Specifies the name of the item.
Public Property | Selected | Gets or sets the value that determines whether or not the item is selected.
Public Property | TargetURL | Gets or sets the target url when item is selected. Applicable when selection mode is set to single.
Public Property | TargetWindow | Gets or sets the target window when item is selected. Applicable when selection mode is set to single.
Public Property | Text | Gets or sets the text of item.
Public Property | ToolTip | Gets or sets the tooltip of item.
Public Property | Value | Gets or sets the value of item.
Public Property | Visible | Gets or sets the value that determines whether or not an item is visible.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebListBoxItem Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxItem Class Methods

[image]
Intersoft WebEssentials Documentation
WebListBoxItem Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxItem Class

Glossary Item Box

For a list of all members of this type, see WebListBoxItem members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebListBoxItem Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxItem Class Properties

[image]
Intersoft WebEssentials Documentation
WebListBoxItem Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxItem Class

Glossary Item Box

For a list of all members of this type, see WebListBoxItem members.

Public Properties

 | Name | Description
Public Property | CustomAttributes | Gets or sets the tooltip of item.
Public Property | DisplayMode | Gets or sets the display mode of item.
Public Property | Enabled | Gets or sets the value that determines whether or not an item is enabled.
Public Property | Image | Gets or sets the image url of item.
Public Property | ImagePosition | Gets or sets the value that determines the position of image in an item.
Public Property | ImageSize | Gets or sets the value that determines the image size of an item.
Public Property | ItemActiveClass | Gets or sets the css class applied to item in active state.
Public Property | ItemAlignment | Gets or sets the alignment of item.
Public Property | ItemHeight | Gets or sets the height of item.
Public Property | ItemHoverClass | Gets or sets the css class applied to item in hover state.
Public Property | ItemImageClass | Gets or sets the css class applied to the image of item.
Public Property | ItemNormalClass | Gets or sets the css class applied to item in normal state.
Public Property | ItemTextClass | Gets or sets the css class applied to the text of item.
Public Property | Name | Overridden. Specifies the name of the item.
Public Property | Selected | Gets or sets the value that determines whether or not the item is selected.
Public Property | TargetURL | Gets or sets the target url when item is selected. Applicable when selection mode is set to single.
Public Property | TargetWindow | Gets or sets the target window when item is selected. Applicable when selection mode is set to single.
Public Property | Text | Gets or sets the text of item.
Public Property | ToolTip | Gets or sets the tooltip of item.
Public Property | Value | Gets or sets the value of item.
Public Property | Visible | Gets or sets the value that determines whether or not an item is visible.
Top

See Also

Reference

WebListBoxItem Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxItemAlignment Enumeration

[image]
Intersoft WebEssentials Documentation
WebListBoxItemAlignment Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxItemAlignment Enumeration

Glossary Item Box

Specifies item alignment in WebListBox.

Syntax

Visual Basic (Declaration)
Public Enum WebListBoxItemAlignment
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemAlignment
C#
public enum WebListBoxItemAlignment : System.Enum
Delphi
public enum WebListBoxItemAlignment = class(System.Enum)
JScript
public enum WebListBoxItemAlignment extends System.Enum
Managed Extensions for C++
__value public enum WebListBoxItemAlignment : public System.Enum
C++/CLI
public enum class WebListBoxItemAlignment : public System.Enum

Members

Member | Description
Center |
Default |
Left |
Right |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebListBoxItemAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebListBoxItemCollection Class

[image]
Intersoft WebEssentials Documentation
WebListBoxItemCollection Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxItemCollection Class

Glossary Item Box

The collection of WebListBoxItem in WebListBox

Object Model

WebListBoxItemCollection Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebListBoxItemCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebListBoxItem)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebListBoxItemCollection : ISNet.WebUI.ISGenericCollectionBase<WebListBoxItem>
Delphi
public class WebListBoxItemCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebListBoxItemCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebListBoxItemCollection : public ISNet.WebUI.ISGenericCollectionBase<WebListBoxItem>
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebListBoxItemCollection : public ISNet.WebUI.ISGenericCollectionBase<WebListBoxItem>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebEssentials.WebListBoxItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Members
ISNet.WebUI.WebEssentials Namespace


WebListBoxItemCollection Class Members

[image]
Intersoft WebEssentials Documentation
WebListBoxItemCollection Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxItemCollection Class

Glossary Item Box

The following tables list the members exposed by WebListBoxItemCollection.

Public Constructors

 | Name | Description
Public Constructor | WebListBoxItemCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebListBoxItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | Overloaded.
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebListBoxItem>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebListBoxItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxItemCollection Class Methods

[image]
Intersoft WebEssentials Documentation
WebListBoxItemCollection Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebListBoxItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebListBoxItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | Overloaded.
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebListBoxItem>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebListBoxItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxItemCollection Class Properties

[image]
Intersoft WebEssentials Documentation
WebListBoxItemCollection Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebListBoxItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebListBoxItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxItemCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebListBoxItemCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : WebListBoxItemCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebListBoxItemCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


WebListBoxItemCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebListBoxItemCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : WebListBoxItemCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebListBoxItemCollection()
C#
public WebListBoxItemCollection()
Delphi
public WebListBoxItemCollection();
JScript
public function WebListBoxItemCollection();
Managed Extensions for C++
public: WebListBoxItemCollection();
C++/CLI
public:
WebListBoxItemCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


Add Method

[image]
Intersoft WebEssentials Documentation
Add Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


Clear Method

[image]
Intersoft WebEssentials Documentation
Clear Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


Contains Method

[image]
Intersoft WebEssentials Documentation
Contains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


CopyTo Method

[image]
Intersoft WebEssentials Documentation
CopyTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


Count Property

[image]
Intersoft WebEssentials Documentation
Count Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


CreateNewItem Method

[image]
Intersoft WebEssentials Documentation
CreateNewItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebListBoxItem
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim value As WebListBoxItem

value = instance.CreateNewItem()
C#
public WebListBoxItem CreateNewItem()
Delphi
public function CreateNewItem(): WebListBoxItem;
JScript
public function CreateNewItem() : WebListBoxItem;
Managed Extensions for C++
public: WebListBoxItem* CreateNewItem();
C++/CLI
public:
WebListBoxItem^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


GetEnumerator Method

[image]
Intersoft WebEssentials Documentation
GetEnumerator Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


GetNamedItem Method

[image]
Intersoft WebEssentials Documentation
GetNamedItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : GetNamedItem Method

Glossary Item Box

Overload List

Overload | Description
GetNamedItem(String,Boolean) |
GetNamedItem(String) | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebListBoxItem>)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


GetNamedItem(String) Method

[image]
Intersoft WebEssentials Documentation
GetNamedItem(String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class > GetNamedItem Method : GetNamedItem(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetNamedItem( _
   ByVal name As System.String _
) As WebListBoxItem
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim name As System.String
Dim value As WebListBoxItem

value = instance.GetNamedItem(name)
C#
public WebListBoxItem GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebListBoxItem;
JScript
public function GetNamedItem(
   name : System.String
) : WebListBoxItem;
Managed Extensions for C++
public: WebListBoxItem* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebListBoxItem^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members
Overload List


GetNamedItem(String,Boolean) Method

[image]
Intersoft WebEssentials Documentation
GetNamedItem(String,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class > GetNamedItem Method : GetNamedItem(String,Boolean) Method

name
ignoreCase

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetNamedItem( _
   ByVal name As System.String, _
   ByVal ignoreCase As System.Boolean _
) As WebListBoxItem
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim name As System.String
Dim ignoreCase As System.Boolean
Dim value As WebListBoxItem

value = instance.GetNamedItem(name, ignoreCase)
C#
public WebListBoxItem GetNamedItem(
   System.string name,
   System.bool ignoreCase
)
Delphi
public function GetNamedItem(
    name: System.String;
    ignoreCase: System.Boolean
): WebListBoxItem;
JScript
public function GetNamedItem(
   name : System.String,
   ignoreCase : System.boolean
) : WebListBoxItem;
Managed Extensions for C++
public: WebListBoxItem* GetNamedItem(
   System.string* name,
   System.bool ignoreCase
)
C++/CLI
public:
WebListBoxItem^ GetNamedItem(
   System.String^ name,
   System.bool ignoreCase
)

Parameters

name
ignoreCase

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members
Overload List


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


IndexOf Method

[image]
Intersoft WebEssentials Documentation
IndexOf Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


Insert Method

[image]
Intersoft WebEssentials Documentation
Insert Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


Item Property

[image]
Intersoft WebEssentials Documentation
Item Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


Parent Property

[image]
Intersoft WebEssentials Documentation
Parent Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


Remove Method

[image]
Intersoft WebEssentials Documentation
Remove Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


RemoveAt Method

[image]
Intersoft WebEssentials Documentation
RemoveAt Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


SerializerConstructor Method

[image]
Intersoft WebEssentials Documentation
SerializerConstructor Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


SetParent Method

[image]
Intersoft WebEssentials Documentation
SetParent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemCollection Class
WebListBoxItemCollection Members


WebListBoxItemDataBoundEventArgs Class

[image]
Intersoft WebEssentials Documentation
WebListBoxItemDataBoundEventArgs Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxItemDataBoundEventArgs Class

Glossary Item Box

Provides data for event when each item is being bound.

Object Model

WebListBoxItemDataBoundEventArgs Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Provides data for event when each item is being bound.")>
Public Class WebListBoxItemDataBoundEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemDataBoundEventArgs
C#
[System.ComponentModel.DescriptionAttribute("Provides data for event when each item is being bound.")]
public class WebListBoxItemDataBoundEventArgs : System.EventArgs
Delphi
public class WebListBoxItemDataBoundEventArgs = class(System.EventArgs)
JScript
System.ComponentModel.DescriptionAttribute("Provides data for event when each item is being bound.")
public class WebListBoxItemDataBoundEventArgs extends System.EventArgs
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Provides data for event when each item is being bound.")]
public __gc class WebListBoxItemDataBoundEventArgs : public System.EventArgs
C++/CLI
[System.ComponentModel.DescriptionAttribute("Provides data for event when each item is being bound.")]
public ref class WebListBoxItemDataBoundEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebEssentials.WebListBoxItemDataBoundEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemDataBoundEventArgs Members
ISNet.WebUI.WebEssentials Namespace


WebListBoxItemDataBoundEventArgs Class Members

[image]
Intersoft WebEssentials Documentation
WebListBoxItemDataBoundEventArgs Class Members
See Also Properties Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxItemDataBoundEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebListBoxItemDataBoundEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WebListBoxItemDataBoundEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | DataRow | Gets the data object of the specified item.
Public Property | Item | Gets the item object that is being bound.
Top

See Also

Reference

WebListBoxItemDataBoundEventArgs Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxItemDataBoundEventArgs Class Properties

[image]
Intersoft WebEssentials Documentation
WebListBoxItemDataBoundEventArgs Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxItemDataBoundEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebListBoxItemDataBoundEventArgs members.

Public Properties

 | Name | Description
Public Property | DataRow | Gets the data object of the specified item.
Public Property | Item | Gets the item object that is being bound.
Top

See Also

Reference

WebListBoxItemDataBoundEventArgs Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxItemDataBoundEventArgs Constructor

[image]
Intersoft WebEssentials Documentation
WebListBoxItemDataBoundEventArgs Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemDataBoundEventArgs Class : WebListBoxItemDataBoundEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebListBoxItemDataBoundEventArgs()
C#
public WebListBoxItemDataBoundEventArgs()
Delphi
public WebListBoxItemDataBoundEventArgs();
JScript
public function WebListBoxItemDataBoundEventArgs();
Managed Extensions for C++
public: WebListBoxItemDataBoundEventArgs();
C++/CLI
public:
WebListBoxItemDataBoundEventArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemDataBoundEventArgs Class
WebListBoxItemDataBoundEventArgs Members


DataRow Property

[image]
Intersoft WebEssentials Documentation
DataRow Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemDataBoundEventArgs Class : DataRow Property

Glossary Item Box

Gets the data object of the specified item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets the data object of the specified item.")>
Public Property DataRow As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemDataBoundEventArgs
Dim value As System.Object

instance.DataRow = value

value = instance.DataRow
C#
[System.ComponentModel.DescriptionAttribute("Gets the data object of the specified item.")]
public System.object DataRow {get; set;}
Delphi
public read-write property DataRow: System.TObject;
JScript
System.ComponentModel.DescriptionAttribute("Gets the data object of the specified item.")
public function get,set DataRow : System.Object
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets the data object of the specified item.")]
public: __property System.Object* get_DataRow();
public: __property void set_DataRow(
   System.Object* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets the data object of the specified item.")]
public:
property System.Object^ DataRow {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemDataBoundEventArgs Class
WebListBoxItemDataBoundEventArgs Members


Item Property

[image]
Intersoft WebEssentials Documentation
Item Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItemDataBoundEventArgs Class : Item Property

Glossary Item Box

Gets the item object that is being bound.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets the item object that is being bound.")>
Public Property Item As WebListBoxItem
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItemDataBoundEventArgs
Dim value As WebListBoxItem

instance.Item = value

value = instance.Item
C#
[System.ComponentModel.DescriptionAttribute("Gets the item object that is being bound.")]
public WebListBoxItem Item {get; set;}
Delphi
public read-write property Item: WebListBoxItem;
JScript
System.ComponentModel.DescriptionAttribute("Gets the item object that is being bound.")
public function get,set Item : WebListBoxItem
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets the item object that is being bound.")]
public: __property WebListBoxItem* get_Item();
public: __property void set_Item(
   WebListBoxItem* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets the item object that is being bound.")]
public:
property WebListBoxItem^ Item {
   WebListBoxItem^ get();
   void set (    WebListBoxItem^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemDataBoundEventArgs Class
WebListBoxItemDataBoundEventArgs Members


WebListBoxItemDataBoundEventHandler Delegate

[image]
Intersoft WebEssentials Documentation
WebListBoxItemDataBoundEventHandler Delegate
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxItemDataBoundEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the event when each item is being bound.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Delegates that handles the event when each item is being bound.")>
Public Delegate Sub WebListBoxItemDataBoundEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebListBoxItemDataBoundEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebListBoxItemDataBoundEventHandler(AddressOf HandlerMethod)
C#
[System.ComponentModel.DescriptionAttribute("Delegates that handles the event when each item is being bound.")]
public delegate void WebListBoxItemDataBoundEventHandler(
   System.object sender,
   WebListBoxItemDataBoundEventArgs e
)
Delphi
public delegate WebListBoxItemDataBoundEventHandler(
    sender: System.TObject;
    e: WebListBoxItemDataBoundEventArgs
);
JScript
System.ComponentModel.DescriptionAttribute("Delegates that handles the event when each item is being bound.")
public delegate WebListBoxItemDataBoundEventHandler(
   sender : System.Object,
   e : WebListBoxItemDataBoundEventArgs
)
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Delegates that handles the event when each item is being bound.")]
public: __gc __delegate void WebListBoxItemDataBoundEventHandler(
   System.Object* sender,
   WebListBoxItemDataBoundEventArgs* e
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Delegates that handles the event when each item is being bound.")]
public delegate void WebListBoxItemDataBoundEventHandler(
   System.Object^ sender,
   WebListBoxItemDataBoundEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItemDataBoundEventHandler Members
ISNet.WebUI.WebEssentials Namespace


WebListBoxItem Constructor

[image]
Intersoft WebEssentials Documentation
WebListBoxItem Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : WebListBoxItem Constructor

Glossary Item Box

Overload List

Overload | Description
WebListBoxItem Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


WebListBoxItem Constructor

[image]
Intersoft WebEssentials Documentation
WebListBoxItem Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : WebListBoxItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebListBoxItem()
C#
public WebListBoxItem()
Delphi
public WebListBoxItem();
JScript
public function WebListBoxItem();
Managed Extensions for C++
public: WebListBoxItem();
C++/CLI
public:
WebListBoxItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members
Overload List


CustomAttributes Property

[image]
Intersoft WebEssentials Documentation
CustomAttributes Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : CustomAttributes Property

Glossary Item Box

Gets or sets the tooltip of item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CustomAttributes As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.String

instance.CustomAttributes = value

value = instance.CustomAttributes
C#
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string CustomAttributes {get; set;}
Delphi
public read-write property CustomAttributes: System.String;
JScript
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CustomAttributes : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_CustomAttributes();
public: __property void set_CustomAttributes(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ CustomAttributes {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


DisplayMode Property

[image]
Intersoft WebEssentials Documentation
DisplayMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : DisplayMode Property

Glossary Item Box

Gets or sets the display mode of item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the display mode of item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DisplayMode As WebListBoxDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As WebListBoxDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the display mode of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public WebListBoxDisplayMode DisplayMode {get; set;}
Delphi
public read-write property DisplayMode: WebListBoxDisplayMode;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the display mode of item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set DisplayMode : WebListBoxDisplayMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the display mode of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebListBoxDisplayMode get_DisplayMode();
public: __property void set_DisplayMode(
   WebListBoxDisplayMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the display mode of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebListBoxDisplayMode DisplayMode {
   WebListBoxDisplayMode get();
   void set (    WebListBoxDisplayMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : Enabled Property

Glossary Item Box

Gets or sets the value that determines whether or not an item is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is enabled.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.DefaultValueAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


Image Property

[image]
Intersoft WebEssentials Documentation
Image Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : Image Property

Glossary Item Box

Gets or sets the image url of item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the image url of item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Image As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.String

instance.Image = value

value = instance.Image
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the image url of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Image {get; set;}
Delphi
public read-write property Image: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the image url of item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.DefaultValueAttribute()
public function get,set Image : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the image url of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Image();
public: __property void set_Image(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the image url of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Image {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


ImagePosition Property

[image]
Intersoft WebEssentials Documentation
ImagePosition Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : ImagePosition Property

Glossary Item Box

Gets or sets the value that determines the position of image in an item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the position of image in an item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ImagePosition As WebListBoxImagePosition
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As WebListBoxImagePosition

instance.ImagePosition = value

value = instance.ImagePosition
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the position of image in an item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public WebListBoxImagePosition ImagePosition {get; set;}
Delphi
public read-write property ImagePosition: WebListBoxImagePosition;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the position of image in an item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.DefaultValueAttribute()
public function get,set ImagePosition : WebListBoxImagePosition
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the position of image in an item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebListBoxImagePosition get_ImagePosition();
public: __property void set_ImagePosition(
   WebListBoxImagePosition value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the position of image in an item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebListBoxImagePosition ImagePosition {
   WebListBoxImagePosition get();
   void set (    WebListBoxImagePosition value);
}

Property Value

The default value is AboveText.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


ImageSize Property

[image]
Intersoft WebEssentials Documentation
ImageSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : ImageSize Property

Glossary Item Box

Gets or sets the value that determines the image size of an item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the image size of an item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.CategoryAttribute("Item Details")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ImageSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.Drawing.Size

instance.ImageSize = value

value = instance.ImageSize
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the image size of an item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Drawing.Size ImageSize {get; set;}
Delphi
public read-write property ImageSize: System.Drawing.Size;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the image size of an item.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ImageSize : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the image size of an item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Drawing.Size get_ImageSize();
public: __property void set_ImageSize(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the image size of an item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Drawing.Size ImageSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


ItemActiveClass Property

[image]
Intersoft WebEssentials Documentation
ItemActiveClass Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : ItemActiveClass Property

Glossary Item Box

Gets or sets the css class applied to item in active state.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Item Styles")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in active state.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ItemActiveClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.String

instance.ItemActiveClass = value

value = instance.ItemActiveClass
C#
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in active state.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ItemActiveClass {get; set;}
Delphi
public read-write property ItemActiveClass: System.String;
JScript
System.ComponentModel.CategoryAttribute("Item Styles")
System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in active state.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ItemActiveClass : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in active state.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ItemActiveClass();
public: __property void set_ItemActiveClass(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in active state.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ItemActiveClass {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


ItemAlignment Property

[image]
Intersoft WebEssentials Documentation
ItemAlignment Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : ItemAlignment Property

Glossary Item Box

Gets or sets the alignment of item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ItemAlignment As WebListBoxItemAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As WebListBoxItemAlignment

instance.ItemAlignment = value

value = instance.ItemAlignment
C#
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebListBoxItemAlignment ItemAlignment {get; set;}
Delphi
public read-write property ItemAlignment: WebListBoxItemAlignment;
JScript
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ItemAlignment : WebListBoxItemAlignment
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebListBoxItemAlignment get_ItemAlignment();
public: __property void set_ItemAlignment(
   WebListBoxItemAlignment value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the alignment of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebListBoxItemAlignment ItemAlignment {
   WebListBoxItemAlignment get();
   void set (    WebListBoxItemAlignment value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


ItemHeight Property

[image]
Intersoft WebEssentials Documentation
ItemHeight Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : ItemHeight Property

Glossary Item Box

Gets or sets the height of item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the height of item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ItemHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.Integer

instance.ItemHeight = value

value = instance.ItemHeight
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the height of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int ItemHeight {get; set;}
Delphi
public read-write property ItemHeight: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the height of item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.DefaultValueAttribute()
public function get,set ItemHeight : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the height of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_ItemHeight();
public: __property void set_ItemHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the height of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int ItemHeight {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


ItemHoverClass Property

[image]
Intersoft WebEssentials Documentation
ItemHoverClass Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : ItemHoverClass Property

Glossary Item Box

Gets or sets the css class applied to item in hover state.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in hover state.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Item Styles")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ItemHoverClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.String

instance.ItemHoverClass = value

value = instance.ItemHoverClass
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in hover state.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ItemHoverClass {get; set;}
Delphi
public read-write property ItemHoverClass: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in hover state.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Item Styles")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ItemHoverClass : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in hover state.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ItemHoverClass();
public: __property void set_ItemHoverClass(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in hover state.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ItemHoverClass {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


ItemImageClass Property

[image]
Intersoft WebEssentials Documentation
ItemImageClass Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : ItemImageClass Property

Glossary Item Box

Gets or sets the css class applied to the image of item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to the image of item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Item Styles")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ItemImageClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.String

instance.ItemImageClass = value

value = instance.ItemImageClass
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to the image of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ItemImageClass {get; set;}
Delphi
public read-write property ItemImageClass: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to the image of item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Item Styles")
System.ComponentModel.DefaultValueAttribute()
public function get,set ItemImageClass : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to the image of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ItemImageClass();
public: __property void set_ItemImageClass(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to the image of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ItemImageClass {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


ItemNormalClass Property

[image]
Intersoft WebEssentials Documentation
ItemNormalClass Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : ItemNormalClass Property

Glossary Item Box

Gets or sets the css class applied to item in normal state.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in normal state.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Item Styles")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ItemNormalClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.String

instance.ItemNormalClass = value

value = instance.ItemNormalClass
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in normal state.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ItemNormalClass {get; set;}
Delphi
public read-write property ItemNormalClass: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in normal state.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Item Styles")
System.ComponentModel.DefaultValueAttribute()
public function get,set ItemNormalClass : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in normal state.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ItemNormalClass();
public: __property void set_ItemNormalClass(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to item in normal state.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ItemNormalClass {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


ItemTextClass Property

[image]
Intersoft WebEssentials Documentation
ItemTextClass Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : ItemTextClass Property

Glossary Item Box

Gets or sets the css class applied to the text of item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to the text of item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Item Styles")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ItemTextClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.String

instance.ItemTextClass = value

value = instance.ItemTextClass
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to the text of item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ItemTextClass {get; set;}
Delphi
public read-write property ItemTextClass: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to the text of item.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Item Styles")
System.ComponentModel.DefaultValueAttribute()
public function get,set ItemTextClass : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to the text of item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ItemTextClass();
public: __property void set_ItemTextClass(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the css class applied to the text of item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Styles")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ItemTextClass {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


Name Property

[image]
Intersoft WebEssentials Documentation
Name Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : Name Property

Glossary Item Box

Specifies the name of the item.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")
public override function get,set Name : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


Selected Property

[image]
Intersoft WebEssentials Documentation
Selected Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : Selected Property

Glossary Item Box

Gets or sets the value that determines whether or not the item is selected.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the item is selected.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Selected As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.Boolean

instance.Selected = value

value = instance.Selected
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the item is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Selected {get; set;}
Delphi
public read-write property Selected: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the item is selected.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.DefaultValueAttribute()
public function get,set Selected : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the item is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Selected();
public: __property void set_Selected(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the item is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Selected {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


TargetURL Property

[image]
Intersoft WebEssentials Documentation
TargetURL Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : TargetURL Property

Glossary Item Box

Gets or sets the target url when item is selected. Applicable when selection mode is set to single.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the target url when item is selected. Applicable when selection mode is set to single.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Item Details")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TargetURL As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.String

instance.TargetURL = value

value = instance.TargetURL
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the target url when item is selected. Applicable when selection mode is set to single.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TargetURL {get; set;}
Delphi
public read-write property TargetURL: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the target url when item is selected. Applicable when selection mode is set to single.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set TargetURL : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the target url when item is selected. Applicable when selection mode is set to single.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TargetURL();
public: __property void set_TargetURL(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the target url when item is selected. Applicable when selection mode is set to single.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TargetURL {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


TargetWindow Property

[image]
Intersoft WebEssentials Documentation
TargetWindow Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : TargetWindow Property

Glossary Item Box

Gets or sets the target window when item is selected. Applicable when selection mode is set to single.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the target window when item is selected. Applicable when selection mode is set to single.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TargetWindow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.String

instance.TargetWindow = value

value = instance.TargetWindow
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the target window when item is selected. Applicable when selection mode is set to single.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TargetWindow {get; set;}
Delphi
public read-write property TargetWindow: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the target window when item is selected. Applicable when selection mode is set to single.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.DefaultValueAttribute()
public function get,set TargetWindow : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the target window when item is selected. Applicable when selection mode is set to single.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TargetWindow();
public: __property void set_TargetWindow(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the target window when item is selected. Applicable when selection mode is set to single.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TargetWindow {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


Text Property

[image]
Intersoft WebEssentials Documentation
Text Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : Text Property

Glossary Item Box

Gets or sets the text of item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the text of item.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the text of item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the text of item.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the text of item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the text of item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


ToolTip Property

[image]
Intersoft WebEssentials Documentation
ToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : ToolTip Property

Glossary Item Box

Gets or sets the tooltip of item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ToolTip();
public: __property void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


Value Property

[image]
Intersoft WebEssentials Documentation
Value Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : Value Property

Glossary Item Box

Gets or sets the value of item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Item Details")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value of item.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Value As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.String

instance.Value = value

value = instance.Value
C#
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value of item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Value {get; set;}
Delphi
public read-write property Value: System.String;
JScript
System.ComponentModel.CategoryAttribute("Item Details")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value of item.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Value : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value of item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Value();
public: __property void set_Value(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value of item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Value {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxItem Class : Visible Property

Glossary Item Box

Gets or sets the value that determines whether or not an item is visible.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is visible.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Item Details")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxItem
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is visible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is visible.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is visible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is visible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxItem Class
WebListBoxItem Members


WebListBoxLayoutSettings Class

[image]
Intersoft WebEssentials Documentation
WebListBoxLayoutSettings Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxLayoutSettings Class

Glossary Item Box

A collection of WebListBox's layout settings.

Object Model

WebListBoxLayoutSettings Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("A collection of WebListBox's layout settings.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebListBoxLayoutSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
C#
[System.ComponentModel.DescriptionAttribute("A collection of WebListBox's layout settings.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebListBoxLayoutSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebListBoxLayoutSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.ComponentModel.DescriptionAttribute("A collection of WebListBox's layout settings.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebListBoxLayoutSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("A collection of WebListBox's layout settings.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebListBoxLayoutSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.ComponentModel.DescriptionAttribute("A collection of WebListBox's layout settings.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebListBoxLayoutSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebListBoxLayoutSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Members
ISNet.WebUI.WebEssentials Namespace


WebListBoxLayoutSettings Class Members

[image]
Intersoft WebEssentials Documentation
WebListBoxLayoutSettings Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxLayoutSettings Class

Glossary Item Box

The following tables list the members exposed by WebListBoxLayoutSettings.

Public Constructors

 | Name | Description
Public Constructor | WebListBoxLayoutSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | DisplayActiveItemIndicator | Gets or sets the value that determines whether active item indicator is displayed.
Public Property | DisplayMode | Gets or sets the value that determines the display mode of items.
Public Property | ImagePosition | Gets or sets the value that determines the position of image in an item.
Public Property | ImageSize | Gets or sets the value that determines the image size of an item.
Public Property | ItemAlignment | Gets or sets the value that determines the alignment of items.
Public Property | ItemHeight | Gets or sets the value that determines the height of an item.
Public Property | ScrollMode | Gets or sets the value that determines the scroll mode of WebListBox.
Public Property | TargetWindow | Gets or sets the value that determines the global target window when items are clicked.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebListBoxLayoutSettings Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxLayoutSettings Class Methods

[image]
Intersoft WebEssentials Documentation
WebListBoxLayoutSettings Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxLayoutSettings Class

Glossary Item Box

For a list of all members of this type, see WebListBoxLayoutSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebListBoxLayoutSettings Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxLayoutSettings Class Properties

[image]
Intersoft WebEssentials Documentation
WebListBoxLayoutSettings Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxLayoutSettings Class

Glossary Item Box

For a list of all members of this type, see WebListBoxLayoutSettings members.

Public Properties

 | Name | Description
Public Property | DisplayActiveItemIndicator | Gets or sets the value that determines whether active item indicator is displayed.
Public Property | DisplayMode | Gets or sets the value that determines the display mode of items.
Public Property | ImagePosition | Gets or sets the value that determines the position of image in an item.
Public Property | ImageSize | Gets or sets the value that determines the image size of an item.
Public Property | ItemAlignment | Gets or sets the value that determines the alignment of items.
Public Property | ItemHeight | Gets or sets the value that determines the height of an item.
Public Property | ScrollMode | Gets or sets the value that determines the scroll mode of WebListBox.
Public Property | TargetWindow | Gets or sets the value that determines the global target window when items are clicked.
Top

See Also

Reference

WebListBoxLayoutSettings Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxLayoutSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebListBoxLayoutSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : WebListBoxLayoutSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebListBoxLayoutSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


WebListBoxLayoutSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebListBoxLayoutSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : WebListBoxLayoutSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebListBoxLayoutSettings()
C#
public WebListBoxLayoutSettings()
Delphi
public WebListBoxLayoutSettings();
JScript
public function WebListBoxLayoutSettings();
Managed Extensions for C++
public: WebListBoxLayoutSettings();
C++/CLI
public:
WebListBoxLayoutSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


DisplayActiveItemIndicator Property

[image]
Intersoft WebEssentials Documentation
DisplayActiveItemIndicator Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : DisplayActiveItemIndicator Property

Glossary Item Box

Gets or sets the value that determines whether active item indicator is displayed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether active item indicator is displayed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DisplayActiveItemIndicator As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim value As System.Boolean

instance.DisplayActiveItemIndicator = value

value = instance.DisplayActiveItemIndicator
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether active item indicator is displayed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool DisplayActiveItemIndicator {get; set;}
Delphi
public read-write property DisplayActiveItemIndicator: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether active item indicator is displayed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Layout Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DisplayActiveItemIndicator : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether active item indicator is displayed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_DisplayActiveItemIndicator();
public: __property void set_DisplayActiveItemIndicator(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether active item indicator is displayed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool DisplayActiveItemIndicator {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


DisplayMode Property

[image]
Intersoft WebEssentials Documentation
DisplayMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : DisplayMode Property

Glossary Item Box

Gets or sets the value that determines the display mode of items.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the display mode of items.")>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DisplayMode As WebListBoxDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim value As WebListBoxDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the display mode of items.")]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebListBoxDisplayMode DisplayMode {get; set;}
Delphi
public read-write property DisplayMode: WebListBoxDisplayMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the display mode of items.")
System.ComponentModel.CategoryAttribute("Layout Settings")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DisplayMode : WebListBoxDisplayMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the display mode of items.")]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebListBoxDisplayMode get_DisplayMode();
public: __property void set_DisplayMode(
   WebListBoxDisplayMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the display mode of items.")]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebListBoxDisplayMode DisplayMode {
   WebListBoxDisplayMode get();
   void set (    WebListBoxDisplayMode value);
}

Property Value

The default value is TextAndImage.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


ImagePosition Property

[image]
Intersoft WebEssentials Documentation
ImagePosition Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : ImagePosition Property

Glossary Item Box

Gets or sets the value that determines the position of image in an item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the position of image in an item.")>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ImagePosition As WebListBoxImagePosition
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim value As WebListBoxImagePosition

instance.ImagePosition = value

value = instance.ImagePosition
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the position of image in an item.")]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebListBoxImagePosition ImagePosition {get; set;}
Delphi
public read-write property ImagePosition: WebListBoxImagePosition;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the position of image in an item.")
System.ComponentModel.CategoryAttribute("Layout Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ImagePosition : WebListBoxImagePosition
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the position of image in an item.")]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebListBoxImagePosition get_ImagePosition();
public: __property void set_ImagePosition(
   WebListBoxImagePosition value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the position of image in an item.")]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebListBoxImagePosition ImagePosition {
   WebListBoxImagePosition get();
   void set (    WebListBoxImagePosition value);
}

Property Value

The default value is AboveText.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


ImageSize Property

[image]
Intersoft WebEssentials Documentation
ImageSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : ImageSize Property

Glossary Item Box

Gets or sets the value that determines the image size of an item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the image size of an item.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ImageSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim value As System.Drawing.Size

instance.ImageSize = value

value = instance.ImageSize
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the image size of an item.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Drawing.Size ImageSize {get; set;}
Delphi
public read-write property ImageSize: System.Drawing.Size;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Layout Settings")
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the image size of an item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ImageSize : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the image size of an item.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Drawing.Size get_ImageSize();
public: __property void set_ImageSize(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the image size of an item.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Drawing.Size ImageSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


ItemAlignment Property

[image]
Intersoft WebEssentials Documentation
ItemAlignment Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : ItemAlignment Property

Glossary Item Box

Gets or sets the value that determines the alignment of items.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the alignment of items.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ItemAlignment As WebListBoxItemAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim value As WebListBoxItemAlignment

instance.ItemAlignment = value

value = instance.ItemAlignment
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the alignment of items.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public WebListBoxItemAlignment ItemAlignment {get; set;}
Delphi
public read-write property ItemAlignment: WebListBoxItemAlignment;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the alignment of items.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Layout Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set ItemAlignment : WebListBoxItemAlignment
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the alignment of items.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebListBoxItemAlignment get_ItemAlignment();
public: __property void set_ItemAlignment(
   WebListBoxItemAlignment value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the alignment of items.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebListBoxItemAlignment ItemAlignment {
   WebListBoxItemAlignment get();
   void set (    WebListBoxItemAlignment value);
}

Property Value

The default value is Left.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


ItemHeight Property

[image]
Intersoft WebEssentials Documentation
ItemHeight Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : ItemHeight Property

Glossary Item Box

Gets or sets the value that determines the height of an item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of an item.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ItemHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim value As System.Integer

instance.ItemHeight = value

value = instance.ItemHeight
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of an item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int ItemHeight {get; set;}
Delphi
public read-write property ItemHeight: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Layout Settings")
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of an item.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ItemHeight : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of an item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_ItemHeight();
public: __property void set_ItemHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of an item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int ItemHeight {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 100.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


ScrollMode Property

[image]
Intersoft WebEssentials Documentation
ScrollMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : ScrollMode Property

Glossary Item Box

Gets or sets the value that determines the scroll mode of WebListBox.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the scroll mode of WebListBox.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ScrollMode As WebListBoxScrollMode
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim value As WebListBoxScrollMode

instance.ScrollMode = value

value = instance.ScrollMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the scroll mode of WebListBox.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebListBoxScrollMode ScrollMode {get; set;}
Delphi
public read-write property ScrollMode: WebListBoxScrollMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Layout Settings")
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the scroll mode of WebListBox.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ScrollMode : WebListBoxScrollMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the scroll mode of WebListBox.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebListBoxScrollMode get_ScrollMode();
public: __property void set_ScrollMode(
   WebListBoxScrollMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the scroll mode of WebListBox.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebListBoxScrollMode ScrollMode {
   WebListBoxScrollMode get();
   void set (    WebListBoxScrollMode value);
}

Property Value

The default value is Scroller.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


TargetWindow Property

[image]
Intersoft WebEssentials Documentation
TargetWindow Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : TargetWindow Property

Glossary Item Box

Gets or sets the value that determines the global target window when items are clicked.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the global target window when items are clicked.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TargetWindow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim value As System.String

instance.TargetWindow = value

value = instance.TargetWindow
C#
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the global target window when items are clicked.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TargetWindow {get; set;}
Delphi
public read-write property TargetWindow: System.String;
JScript
System.ComponentModel.CategoryAttribute("Layout Settings")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the global target window when items are clicked.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TargetWindow : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the global target window when items are clicked.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TargetWindow();
public: __property void set_TargetWindow(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the global target window when items are clicked.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TargetWindow {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is "".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxLayoutSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxLayoutSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxLayoutSettings Class
WebListBoxLayoutSettings Members


WebListBoxPostBackMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebListBoxPostBackMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxPostBackMode Enumeration

Glossary Item Box

Specifies postback mode in WebListBox.

Syntax

Visual Basic (Declaration)
Public Enum WebListBoxPostBackMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxPostBackMode
C#
public enum WebListBoxPostBackMode : System.Enum
Delphi
public enum WebListBoxPostBackMode = class(System.Enum)
JScript
public enum WebListBoxPostBackMode extends System.Enum
Managed Extensions for C++
__value public enum WebListBoxPostBackMode : public System.Enum
C++/CLI
public enum class WebListBoxPostBackMode : public System.Enum

Members

Member | Description
FlyPostBack |
FullPostBack |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebListBoxPostBackMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebListBoxPresets Class

[image]
Intersoft WebEssentials Documentation
WebListBoxPresets Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxPresets Class

Glossary Item Box

Object Model

WebListBoxPresets Class

Syntax

Visual Basic (Declaration)
Public Class WebListBoxPresets
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxPresets
C#
public class WebListBoxPresets
Delphi
public class WebListBoxPresets
JScript
public class WebListBoxPresets
Managed Extensions for C++
public __gc class WebListBoxPresets
C++/CLI
public ref class WebListBoxPresets

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebEssentials.WebListBoxPresets

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxPresets Members
ISNet.WebUI.WebEssentials Namespace


WebListBoxPresets Class Members

[image]
Intersoft WebEssentials Documentation
WebListBoxPresets Class Members
See Also Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxPresets Class

Glossary Item Box

The following tables list the members exposed by WebListBoxPresets.

Public Constructors

 | Name | Description
Public Constructor | WebListBoxPresets Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

WebListBoxPresets Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxPresets Class Methods

[image]
Intersoft WebEssentials Documentation
WebListBoxPresets Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxPresets Class

Glossary Item Box

For a list of all members of this type, see WebListBoxPresets members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

WebListBoxPresets Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxPresets Constructor

[image]
Intersoft WebEssentials Documentation
WebListBoxPresets Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxPresets Class : WebListBoxPresets Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebListBoxPresets()
C#
public WebListBoxPresets()
Delphi
public WebListBoxPresets();
JScript
public function WebListBoxPresets();
Managed Extensions for C++
public: WebListBoxPresets();
C++/CLI
public:
WebListBoxPresets();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxPresets Class
WebListBoxPresets Members


GetDefaultStyle Method

[image]
Intersoft WebEssentials Documentation
GetDefaultStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxPresets Class : GetDefaultStyle Method

mode
styleName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetDefaultStyle( _
   ByVal mode As WebListBoxDefaultStyleMode, _
   ByVal styleName As System.String _
) As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim mode As WebListBoxDefaultStyleMode
Dim styleName As System.String
Dim value As ISNet.WebUI.WebStyle

value = WebListBoxPresets.GetDefaultStyle(mode, styleName)
C#
public static ISNet.WebUI.WebStyle GetDefaultStyle(
   WebListBoxDefaultStyleMode mode,
   System.string styleName
)
Delphi
public function GetDefaultStyle(
    mode: WebListBoxDefaultStyleMode;
    styleName: System.String
): ISNet.WebUI.WebStyle; static;
JScript
public static function GetDefaultStyle(
   mode : WebListBoxDefaultStyleMode,
   styleName : System.String
) : ISNet.WebUI.WebStyle;
Managed Extensions for C++
public: static ISNet.WebUI.WebStyle* GetDefaultStyle(
   WebListBoxDefaultStyleMode mode,
   System.string* styleName
)
C++/CLI
public:
static ISNet.WebUI.WebStyle^ GetDefaultStyle(
   WebListBoxDefaultStyleMode mode,
   System.String^ styleName
)

Parameters

mode
styleName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxPresets Class
WebListBoxPresets Members


WebListBoxScrollMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebListBoxScrollMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxScrollMode Enumeration

Glossary Item Box

Specifies scroll mode in WebListBox.

Syntax

Visual Basic (Declaration)
Public Enum WebListBoxScrollMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxScrollMode
C#
public enum WebListBoxScrollMode : System.Enum
Delphi
public enum WebListBoxScrollMode = class(System.Enum)
JScript
public enum WebListBoxScrollMode extends System.Enum
Managed Extensions for C++
__value public enum WebListBoxScrollMode : public System.Enum
C++/CLI
public enum class WebListBoxScrollMode : public System.Enum

Members

Member | Description
None |
ScrollBar |
Scroller |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebListBoxScrollMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebListBoxSelectedItemChangedEventArgs Class

[image]
Intersoft WebEssentials Documentation
WebListBoxSelectedItemChangedEventArgs Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxSelectedItemChangedEventArgs Class

Glossary Item Box

Provides data for event when selected item is changed.

Object Model

WebListBoxSelectedItemChangedEventArgs Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Provides data for event when selected item is changed.")>
Public Class WebListBoxSelectedItemChangedEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxSelectedItemChangedEventArgs
C#
[System.ComponentModel.DescriptionAttribute("Provides data for event when selected item is changed.")]
public class WebListBoxSelectedItemChangedEventArgs : System.EventArgs
Delphi
public class WebListBoxSelectedItemChangedEventArgs = class(System.EventArgs)
JScript
System.ComponentModel.DescriptionAttribute("Provides data for event when selected item is changed.")
public class WebListBoxSelectedItemChangedEventArgs extends System.EventArgs
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Provides data for event when selected item is changed.")]
public __gc class WebListBoxSelectedItemChangedEventArgs : public System.EventArgs
C++/CLI
[System.ComponentModel.DescriptionAttribute("Provides data for event when selected item is changed.")]
public ref class WebListBoxSelectedItemChangedEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebEssentials.WebListBoxSelectedItemChangedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxSelectedItemChangedEventArgs Members
ISNet.WebUI.WebEssentials Namespace


WebListBoxSelectedItemChangedEventArgs Class Members

[image]
Intersoft WebEssentials Documentation
WebListBoxSelectedItemChangedEventArgs Class Members
See Also Properties Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxSelectedItemChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebListBoxSelectedItemChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WebListBoxSelectedItemChangedEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | SelectedIndex | Gets the selected index.
Top

See Also

Reference

WebListBoxSelectedItemChangedEventArgs Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxSelectedItemChangedEventArgs Class Properties

[image]
Intersoft WebEssentials Documentation
WebListBoxSelectedItemChangedEventArgs Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxSelectedItemChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebListBoxSelectedItemChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | SelectedIndex | Gets the selected index.
Top

See Also

Reference

WebListBoxSelectedItemChangedEventArgs Class
ISNet.WebUI.WebEssentials Namespace


WebListBoxSelectedItemChangedEventArgs Constructor

[image]
Intersoft WebEssentials Documentation
WebListBoxSelectedItemChangedEventArgs Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxSelectedItemChangedEventArgs Class : WebListBoxSelectedItemChangedEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebListBoxSelectedItemChangedEventArgs()
C#
public WebListBoxSelectedItemChangedEventArgs()
Delphi
public WebListBoxSelectedItemChangedEventArgs();
JScript
public function WebListBoxSelectedItemChangedEventArgs();
Managed Extensions for C++
public: WebListBoxSelectedItemChangedEventArgs();
C++/CLI
public:
WebListBoxSelectedItemChangedEventArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxSelectedItemChangedEventArgs Class
WebListBoxSelectedItemChangedEventArgs Members


SelectedIndex Property

[image]
Intersoft WebEssentials Documentation
SelectedIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBoxSelectedItemChangedEventArgs Class : SelectedIndex Property

Glossary Item Box

Gets the selected index.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets the selected index.")>
Public ReadOnly Property SelectedIndex As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxSelectedItemChangedEventArgs
Dim value As System.Integer

value = instance.SelectedIndex
C#
[System.ComponentModel.DescriptionAttribute("Gets the selected index.")]
public System.int SelectedIndex {get;}
Delphi
public read-only property SelectedIndex: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Gets the selected index.")
public function get SelectedIndex : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets the selected index.")]
public: __property System.int get_SelectedIndex();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets the selected index.")]
public:
property System.int SelectedIndex {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxSelectedItemChangedEventArgs Class
WebListBoxSelectedItemChangedEventArgs Members


WebListBoxSelectedItemChangedEventHandler Delegate

[image]
Intersoft WebEssentials Documentation
WebListBoxSelectedItemChangedEventHandler Delegate
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxSelectedItemChangedEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the event when selected item is changed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Delegates that handles the event when selected item is changed.")>
Public Delegate Sub WebListBoxSelectedItemChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebListBoxSelectedItemChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebListBoxSelectedItemChangedEventHandler(AddressOf HandlerMethod)
C#
[System.ComponentModel.DescriptionAttribute("Delegates that handles the event when selected item is changed.")]
public delegate void WebListBoxSelectedItemChangedEventHandler(
   System.object sender,
   WebListBoxSelectedItemChangedEventArgs e
)
Delphi
public delegate WebListBoxSelectedItemChangedEventHandler(
    sender: System.TObject;
    e: WebListBoxSelectedItemChangedEventArgs
);
JScript
System.ComponentModel.DescriptionAttribute("Delegates that handles the event when selected item is changed.")
public delegate WebListBoxSelectedItemChangedEventHandler(
   sender : System.Object,
   e : WebListBoxSelectedItemChangedEventArgs
)
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Delegates that handles the event when selected item is changed.")]
public: __gc __delegate void WebListBoxSelectedItemChangedEventHandler(
   System.Object* sender,
   WebListBoxSelectedItemChangedEventArgs* e
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Delegates that handles the event when selected item is changed.")]
public delegate void WebListBoxSelectedItemChangedEventHandler(
   System.Object^ sender,
   WebListBoxSelectedItemChangedEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBoxSelectedItemChangedEventHandler Members
ISNet.WebUI.WebEssentials Namespace


WebListBoxSelectionMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebListBoxSelectionMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebListBoxSelectionMode Enumeration

Glossary Item Box

Specifies selection mode in WebListBox.

Syntax

Visual Basic (Declaration)
Public Enum WebListBoxSelectionMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebListBoxSelectionMode
C#
public enum WebListBoxSelectionMode : System.Enum
Delphi
public enum WebListBoxSelectionMode = class(System.Enum)
JScript
public enum WebListBoxSelectionMode extends System.Enum
Managed Extensions for C++
__value public enum WebListBoxSelectionMode : public System.Enum
C++/CLI
public enum class WebListBoxSelectionMode : public System.Enum

Members

Member | Description
Multiple |
Single |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebListBoxSelectionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebListBox Constructor

[image]
Intersoft WebEssentials Documentation
WebListBox Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : WebListBox Constructor

Glossary Item Box

Overload List

Overload | Description
WebListBox Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


WebListBox Constructor

[image]
Intersoft WebEssentials Documentation
WebListBox Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : WebListBox Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebListBox()
C#
public WebListBox()
Delphi
public WebListBox();
JScript
public function WebListBox();
Managed Extensions for C++
public: WebListBox();
C++/CLI
public:
WebListBox();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


AccessKey Property

[image]
Intersoft WebEssentials Documentation
AccessKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set AccessKey : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


AllowDefaultStyleMerging Property

[image]
Intersoft WebEssentials Documentation
AllowDefaultStyleMerging Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : AllowDefaultStyleMerging Property

Glossary Item Box

Gets or sets the value that determines whether or not the default style can be merged with custom styles.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AllowDefaultStyleMerging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

instance.AllowDefaultStyleMerging = value

value = instance.AllowDefaultStyleMerging
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool AllowDefaultStyleMerging {get; set;}
Delphi
public read-write property AllowDefaultStyleMerging: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set AllowDefaultStyleMerging : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_AllowDefaultStyleMerging();
public: __property void set_AllowDefaultStyleMerging(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool AllowDefaultStyleMerging {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ApplyStyle Method

[image]
Intersoft WebEssentials Documentation
ApplyStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebEssentials Documentation
ApplyStyleSheetSkin Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


AutoPostBack Property

[image]
Intersoft WebEssentials Documentation
AutoPostBack Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : AutoPostBack Property

Glossary Item Box

Automatically postback to the server after selection is changed. Applicable when selection mode is set to single.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Automatically postback to the server after selection is changed. Applicable when selection mode is set to single.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AutoPostBack As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

instance.AutoPostBack = value

value = instance.AutoPostBack
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Automatically postback to the server after selection is changed. Applicable when selection mode is set to single.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool AutoPostBack {get; set;}
Delphi
public read-write property AutoPostBack: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Automatically postback to the server after selection is changed. Applicable when selection mode is set to single.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AutoPostBack : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Automatically postback to the server after selection is changed. Applicable when selection mode is set to single.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_AutoPostBack();
public: __property void set_AutoPostBack(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Automatically postback to the server after selection is changed. Applicable when selection mode is set to single.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool AutoPostBack {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


BottomScrollerStyle Property

[image]
Intersoft WebEssentials Documentation
BottomScrollerStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : BottomScrollerStyle Property

Glossary Item Box

Contains interactive style for top scroller style.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Style")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for bottom scroller style.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property BottomScrollerStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.WebStyle

instance.BottomScrollerStyle = value

value = instance.BottomScrollerStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for bottom scroller style.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ISNet.WebUI.WebStyle BottomScrollerStyle {get; set;}
Delphi
public read-write property BottomScrollerStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Style")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for bottom scroller style.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set BottomScrollerStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for bottom scroller style.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ISNet.WebUI.WebStyle* get_BottomScrollerStyle();
public: __property void set_BottomScrollerStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for bottom scroller style.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ISNet.WebUI.WebStyle^ BottomScrollerStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


CanUseWebResources Method

[image]
Intersoft WebEssentials Documentation
CanUseWebResources Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.CanUseWebResources()
C#
public System.bool CanUseWebResources()
Delphi
public function CanUseWebResources(): System.Boolean;
JScript
public function CanUseWebResources() : System.boolean;
Managed Extensions for C++
public: System.bool CanUseWebResources();
C++/CLI
public:
System.bool CanUseWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


CheckConstrains Method

[image]
Intersoft WebEssentials Documentation
CheckConstrains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebListBox

instance.CheckConstrains()
C#
public override void CheckConstrains()
Delphi
public procedure CheckConstrains(); override;
JScript
public override function CheckConstrains();
Managed Extensions for C++
public: void CheckConstrains(); override
C++/CLI
public:
void CheckConstrains(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ClientIDMode Property

[image]
Intersoft WebEssentials Documentation
ClientIDMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ClientSideEvents Property

[image]
Intersoft WebEssentials Documentation
ClientSideEvents Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ClientSideEvents Property

Glossary Item Box

Contains client side events supported by WebListBox

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebListBox.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public ReadOnly Property ClientSideEvents As WebListBoxClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As WebListBoxClientSideEvents

value = instance.ClientSideEvents
C#
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebListBox.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public WebListBoxClientSideEvents ClientSideEvents {get;}
Delphi
public read-only property ClientSideEvents: WebListBoxClientSideEvents;
JScript
System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebListBox.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get ClientSideEvents : WebListBoxClientSideEvents
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebListBox.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property WebListBoxClientSideEvents* get_ClientSideEvents();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebListBox.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property WebListBoxClientSideEvents^ ClientSideEvents {
   WebListBoxClientSideEvents^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ContentFrameStyle Property

[image]
Intersoft WebEssentials Documentation
ContentFrameStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ContentFrameStyle Property

Glossary Item Box

Contains interactive style for the content frame of WebListBox.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for the content frame of WebListBox.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Style")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public Property ContentFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.WebStyle

instance.ContentFrameStyle = value

value = instance.ContentFrameStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the content frame of WebListBox.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public ISNet.WebUI.WebStyle ContentFrameStyle {get; set;}
Delphi
public read-write property ContentFrameStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DescriptionAttribute("Contains interactive style for the content frame of WebListBox.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Style")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get,set ContentFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the content frame of WebListBox.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property ISNet.WebUI.WebStyle* get_ContentFrameStyle();
public: __property void set_ContentFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the content frame of WebListBox.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property ISNet.WebUI.WebStyle^ ContentFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ControlDataTransferFormat Property

[image]
Intersoft WebEssentials Documentation
ControlDataTransferFormat Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


CopyBaseAttributes Method

[image]
Intersoft WebEssentials Documentation
CopyBaseAttributes Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members
Overload List


CustomDeserialize Method

[image]
Intersoft WebEssentials Documentation
CustomDeserialize Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : CustomDeserialize Method

mi
currentObj
parentNode
currentNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomDeserialize( _
   ByVal mi As System.Reflection.MemberInfo, _
   ByVal currentObj As System.Object, _
   ByVal parentNode As System.Xml.XmlNode, _
   ByVal currentNode As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim mi As System.Reflection.MemberInfo
Dim currentObj As System.Object
Dim parentNode As System.Xml.XmlNode
Dim currentNode As System.Xml.XmlNode

instance.CustomDeserialize(mi, currentObj, parentNode, currentNode)
C#
public void CustomDeserialize(
   System.Reflection.MemberInfo mi,
   System.object currentObj,
   System.Xml.XmlNode parentNode,
   System.Xml.XmlNode currentNode
)
Delphi
public procedure CustomDeserialize(
    mi: System.Reflection.MemberInfo;
    currentObj: System.TObject;
    parentNode: System.Xml.XmlNode;
    currentNode: System.Xml.XmlNode
);
JScript
public function CustomDeserialize(
   mi : System.Reflection.MemberInfo,
   currentObj : System.Object,
   parentNode : System.Xml.XmlNode,
   currentNode : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomDeserialize(
   System.Reflection.MemberInfo* mi,
   System.Object* currentObj,
   System.Xml.XmlNode* parentNode,
   System.Xml.XmlNode* currentNode
)
C++/CLI
public:
void CustomDeserialize(
   System.Reflection.MemberInfo^ mi,
   System.Object^ currentObj,
   System.Xml.XmlNode^ parentNode,
   System.Xml.XmlNode^ currentNode
)

Parameters

mi
currentObj
parentNode
currentNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


CustomSerialize Method

[image]
Intersoft WebEssentials Documentation
CustomSerialize Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : CustomSerialize Method

xmlDoc
node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CustomSerialize( _
   ByVal xmlDoc As System.Xml.XmlDocument, _
   ByVal node As System.Xml.XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim xmlDoc As System.Xml.XmlDocument
Dim node As System.Xml.XmlNode

instance.CustomSerialize(xmlDoc, node)
C#
public void CustomSerialize(
   System.Xml.XmlDocument xmlDoc,
   System.Xml.XmlNode node
)
Delphi
public procedure CustomSerialize(
    xmlDoc: System.Xml.XmlDocument;
    node: System.Xml.XmlNode
);
JScript
public function CustomSerialize(
   xmlDoc : System.Xml.XmlDocument,
   node : System.Xml.XmlNode
);
Managed Extensions for C++
public: void CustomSerialize(
   System.Xml.XmlDocument* xmlDoc,
   System.Xml.XmlNode* node
)
C++/CLI
public:
void CustomSerialize(
   System.Xml.XmlDocument^ xmlDoc,
   System.Xml.XmlNode^ node
)

Parameters

xmlDoc
node

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


DataBind Method

[image]
Intersoft WebEssentials Documentation
DataBind Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


DataBind() Method

[image]
Intersoft WebEssentials Documentation
DataBind() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebListBox

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


DataBinding Event

[image]
Intersoft WebEssentials Documentation
DataBinding Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


DataMember Property

[image]
Intersoft WebEssentials Documentation
DataMember Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : DataMember Property

Glossary Item Box

Gets or sets the data member of WebListBox.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the data member of WebListBox.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.PersistLayoutAttribute(False)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
Public Property DataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.DataMember = value

value = instance.DataMember
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the data member of WebListBox.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public System.string DataMember {get; set;}
Delphi
public read-write property DataMember: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the data member of WebListBox.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.PersistLayoutAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Data")
public function get,set DataMember : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the data member of WebListBox.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public: __property System.string* get_DataMember();
public: __property void set_DataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the data member of WebListBox.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public:
property System.String^ DataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


DataSourceID Property

[image]
Intersoft WebEssentials Documentation
DataSourceID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : DataSourceID Property

Glossary Item Box

Gets or sets the data source id of WebListBox.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the data source id of WebListBox.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DataSourceID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.DataSourceID = value

value = instance.DataSourceID
C#
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data source id of WebListBox.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DataSourceID {get; set;}
Delphi
public read-write property DataSourceID: System.String;
JScript
System.ComponentModel.CategoryAttribute("Data")
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)
System.ComponentModel.DescriptionAttribute("Gets or sets the data source id of WebListBox.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DataSourceID : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data source id of WebListBox.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DataSourceID();
public: __property void set_DataSourceID(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data source id of WebListBox.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DataSourceID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


DataSourceManager Property

[image]
Intersoft WebEssentials Documentation
DataSourceManager Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : DataSourceManager Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DataSourceManager As ISNet.WebUI.DataSourceInfo
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.DataSourceInfo

value = instance.DataSourceManager
C#
public override ISNet.WebUI.DataSourceInfo DataSourceManager {get;}
Delphi
public read-only property DataSourceManager: ISNet.WebUI.DataSourceInfo; override;
JScript
public override function get DataSourceManager : ISNet.WebUI.DataSourceInfo
Managed Extensions for C++
public: __property ISNet.WebUI.DataSourceInfo* get_DataSourceManager() override;
C++/CLI
public:
property ISNet.WebUI.DataSourceInfo^ DataSourceManager {
   ISNet.WebUI.DataSourceInfo^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


DefaultStyleMode Property

[image]
Intersoft WebEssentials Documentation
DefaultStyleMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : DefaultStyleMode Property

Glossary Item Box

Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")>
Public Property DefaultStyleMode As WebListBoxDefaultStyleMode
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As WebListBoxDefaultStyleMode

instance.DefaultStyleMode = value

value = instance.DefaultStyleMode
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
public WebListBoxDefaultStyleMode DefaultStyleMode {get; set;}
Delphi
public read-write property DefaultStyleMode: WebListBoxDefaultStyleMode;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")
public function get,set DefaultStyleMode : WebListBoxDefaultStyleMode
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
public: __property WebListBoxDefaultStyleMode get_DefaultStyleMode();
public: __property void set_DefaultStyleMode(
   WebListBoxDefaultStyleMode value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
public:
property WebListBoxDefaultStyleMode DefaultStyleMode {
   WebListBoxDefaultStyleMode get();
   void set (    WebListBoxDefaultStyleMode value);
}

Property Value

There are two default styles in WebListBox, Standard and Win7.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


Dispose Method

[image]
Intersoft WebEssentials Documentation
Dispose Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebListBox

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


Disposed Event

[image]
Intersoft WebEssentials Documentation
Disposed Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


EnableKeyboardSupport Property

[image]
Intersoft WebEssentials Documentation
EnableKeyboardSupport Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : EnableKeyboardSupport Property

Glossary Item Box

Gets or sets the value that determines whether keyboard support is enabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether keyboard support is enabled.")>
Public Property EnableKeyboardSupport As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

instance.EnableKeyboardSupport = value

value = instance.EnableKeyboardSupport
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether keyboard support is enabled.")]
public System.bool EnableKeyboardSupport {get; set;}
Delphi
public read-write property EnableKeyboardSupport: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether keyboard support is enabled.")
public function get,set EnableKeyboardSupport : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether keyboard support is enabled.")]
public: __property System.bool get_EnableKeyboardSupport();
public: __property void set_EnableKeyboardSupport(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether keyboard support is enabled.")]
public:
property System.bool EnableKeyboardSupport {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


EnableManagedTheming Property

[image]
Intersoft WebEssentials Documentation
EnableManagedTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable Property EnableManagedTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableManagedTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.bool EnableManagedTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


EnableTheming Property

[image]
Intersoft WebEssentials Documentation
EnableTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


EnableViewState Property

[image]
Intersoft WebEssentials Documentation
EnableViewState Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


EnableWebResources Property

[image]
Intersoft WebEssentials Documentation
EnableWebResources Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Web Resources")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Web Resources")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


FindControl Method

[image]
Intersoft WebEssentials Documentation
FindControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


FindControl(String) Method

[image]
Intersoft WebEssentials Documentation
FindControl(String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


FlyPostBackSettings Property

[image]
Intersoft WebEssentials Documentation
FlyPostBackSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : FlyPostBackSettings Property

Glossary Item Box

Configures the settings used by the control when performing OnTheFly postback.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}
Delphi
public read-only property FlyPostBackSettings: ISNet.WebUI.FlyPostBackSettings;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Behavior")
public function get FlyPostBackSettings : ISNet.WebUI.FlyPostBackSettings
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property ISNet.WebUI.FlyPostBackSettings* get_FlyPostBackSettings();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property ISNet.WebUI.FlyPostBackSettings^ FlyPostBackSettings {
   ISNet.WebUI.FlyPostBackSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


Focus Method

[image]
Intersoft WebEssentials Documentation
Focus Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebListBox

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ForceDisableXmlCompression Method

[image]
Intersoft WebEssentials Documentation
ForceDisableXmlCompression Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebListBox

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


FrameStyle Property

[image]
Intersoft WebEssentials Documentation
FrameStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : FrameStyle Property

Glossary Item Box

Contains interactive style for the frame of WebListBox.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Contains interactive style for the frame of WebListBox.")>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the frame of WebListBox.")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.WebStyle FrameStyle {get; set;}
Delphi
public read-write property FrameStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DescriptionAttribute("Contains interactive style for the frame of WebListBox.")
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set FrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the frame of WebListBox.")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.WebStyle* get_FrameStyle();
public: __property void set_FrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the frame of WebListBox.")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.WebStyle^ FrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetClientAction Method

[image]
Intersoft WebEssentials Documentation
GetClientAction Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetClientAction Method

Glossary Item Box

Gets ClientAction class.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets ClientAction class.")>
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
[System.ComponentModel.DescriptionAttribute("Gets ClientAction class.")]
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
System.ComponentModel.DescriptionAttribute("Gets ClientAction class.")
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets ClientAction class.")]
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets ClientAction class.")]
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebEssentials Documentation
GetCurrentControlLifeCycle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetCurrentTheme Method

[image]
Intersoft WebEssentials Documentation
GetCurrentTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetFrameworkDataFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkDataFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

value = instance.GetFrameworkDataFolder()
C#
public System.string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): System.String;
JScript
public function GetFrameworkDataFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkDataFolder();
C++/CLI
public:
System.String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetFrameworkFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

value = instance.GetFrameworkFolder()
C#
public System.string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): System.String;
JScript
public function GetFrameworkFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkFolder();
C++/CLI
public:
System.String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetFrameworkVersion Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkVersion Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Version

value = instance.GetFrameworkVersion()
C#
public System.Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): System.Version;
JScript
public function GetFrameworkVersion() : System.Version;
Managed Extensions for C++
public: System.Version* GetFrameworkVersion();
C++/CLI
public:
System.Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetIntersoftFolder Method

[image]
Intersoft WebEssentials Documentation
GetIntersoftFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

value = instance.GetIntersoftFolder()
C#
public System.string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): System.String;
JScript
public function GetIntersoftFolder() : System.String;
Managed Extensions for C++
public: System.string* GetIntersoftFolder();
C++/CLI
public:
System.String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetLayoutFolder Method

[image]
Intersoft WebEssentials Documentation
GetLayoutFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

value = instance.GetLayoutFolder()
C#
public System.string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): System.String;
JScript
public function GetLayoutFolder() : System.String;
Managed Extensions for C++
public: System.string* GetLayoutFolder();
C++/CLI
public:
System.String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetPostedXMLData Method

[image]
Intersoft WebEssentials Documentation
GetPostedXMLData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

value = instance.GetPostedXMLData()
C#
public System.string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): System.String;
JScript
public function GetPostedXMLData() : System.String;
Managed Extensions for C++
public: System.string* GetPostedXMLData();
C++/CLI
public:
System.String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetProductInfoKey Method

[image]
Intersoft WebEssentials Documentation
GetProductInfoKey Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

value = instance.GetProductInfoKey()
C#
public System.string GetProductInfoKey()
Delphi
public function GetProductInfoKey(): System.String;
JScript
public function GetProductInfoKey() : System.String;
Managed Extensions for C++
public: System.string* GetProductInfoKey();
C++/CLI
public:
System.String^ GetProductInfoKey();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetProductSimpleName Method

[image]
Intersoft WebEssentials Documentation
GetProductSimpleName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

value = instance.GetProductSimpleName()
C#
public System.string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): System.String;
JScript
public function GetProductSimpleName() : System.String;
Managed Extensions for C++
public: System.string* GetProductSimpleName();
C++/CLI
public:
System.String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetPropertyValue Method

[image]
Intersoft WebEssentials Documentation
GetPropertyValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As System.String, _
   ByVal propValue As System.String, _
   ByVal webConfigKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim defValue As System.String
Dim propValue As System.String
Dim webConfigKey As System.String
Dim value As System.String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public System.string GetPropertyValue(
   System.string defValue,
   System.string propValue,
   System.string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: System.String;
    propValue: System.String;
    webConfigKey: System.String
): System.String;
JScript
public function GetPropertyValue(
   defValue : System.String,
   propValue : System.String,
   webConfigKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetPropertyValue(
   System.string* defValue,
   System.string* propValue,
   System.string* webConfigKey
)
C++/CLI
public:
System.String^ GetPropertyValue(
   System.String^ defValue,
   System.String^ propValue,
   System.String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetResourceStream Method

[image]
Intersoft WebEssentials Documentation
GetResourceStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As System.String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim resourceUrl As System.String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   System.string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: System.String
): System.IO.Stream;
JScript
public function GetResourceStream(
   resourceUrl : System.String
) : System.IO.Stream;
Managed Extensions for C++
public: System.IO.Stream* GetResourceStream(
   System.string* resourceUrl
)
C++/CLI
public:
System.IO.Stream^ GetResourceStream(
   System.String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetRouteUrl Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetRouteUrl(Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebEssentials Documentation
GetUniqueIDRelativeTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


GetValues Method

[image]
Intersoft WebEssentials Documentation
GetValues Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : GetValues Method

Glossary Item Box

Gets the selected value collection.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets the selected value collection.")>
Public Function GetValues() As System.Collections.Generic.List(Of String)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Collections.Generic.List(Of String)

value = instance.GetValues()
C#
[System.ComponentModel.DescriptionAttribute("Gets the selected value collection.")]
public System.Collections.Generic.List<string> GetValues()
Delphi
public function GetValues(): System.Collections.Generic.List;
JScript
System.ComponentModel.DescriptionAttribute("Gets the selected value collection.")
public function GetValues() : System.Collections.Generic.List;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets the selected value collection.")]
public: System.Collections.Generic.List<string*>* GetValues();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets the selected value collection.")]
public:
System.Collections.Generic.List<String^>^ GetValues();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


HasControls Method

[image]
Intersoft WebEssentials Documentation
HasControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


Height Property

[image]
Intersoft WebEssentials Documentation
Height Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ID Property

[image]
Intersoft WebEssentials Documentation
ID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ImageFieldDataMember Property

[image]
Intersoft WebEssentials Documentation
ImageFieldDataMember Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ImageFieldDataMember Property

Glossary Item Box

Sets the image field data member.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the image field data member.")>
<System.ComponentModel.CategoryAttribute("Data")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ImageFieldDataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.ImageFieldDataMember = value

value = instance.ImageFieldDataMember
C#
[System.ComponentModel.DescriptionAttribute("Sets the image field data member.")]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ImageFieldDataMember {get; set;}
Delphi
public read-write property ImageFieldDataMember: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Sets the image field data member.")
System.ComponentModel.CategoryAttribute("Data")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ImageFieldDataMember : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the image field data member.")]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ImageFieldDataMember();
public: __property void set_ImageFieldDataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the image field data member.")]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ImageFieldDataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ImageFieldFormatString Property

[image]
Intersoft WebEssentials Documentation
ImageFieldFormatString Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ImageFieldFormatString Property

Glossary Item Box

Sets the format string of image field.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the format string of image field.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ImageFieldFormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.ImageFieldFormatString = value

value = instance.ImageFieldFormatString
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the format string of image field.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ImageFieldFormatString {get; set;}
Delphi
public read-write property ImageFieldFormatString: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Sets the format string of image field.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ImageFieldFormatString : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the format string of image field.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ImageFieldFormatString();
public: __property void set_ImageFieldFormatString(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the format string of image field.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ImageFieldFormatString {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ImagesDirectory Property

[image]
Intersoft WebEssentials Documentation
ImagesDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the images directory for ImagesSettings.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSettings.")>
Public Property ImagesDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSettings.")]
public System.string ImagesDirectory {get; set;}
Delphi
public read-write property ImagesDirectory: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSettings.")
public function get,set ImagesDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSettings.")]
public: __property System.string* get_ImagesDirectory();
public: __property void set_ImagesDirectory(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSettings.")]
public:
property System.String^ ImagesDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ImagesSettings Property

[image]
Intersoft WebEssentials Documentation
ImagesSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ImagesSettings Property

Glossary Item Box

Provides the settings that control the images in WebListBox.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebListBox.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property ImagesSettings As WebListBoxImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As WebListBoxImagesSettings

value = instance.ImagesSettings
C#
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebListBox.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public WebListBoxImagesSettings ImagesSettings {get;}
Delphi
public read-only property ImagesSettings: WebListBoxImagesSettings;
JScript
System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebListBox.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get ImagesSettings : WebListBoxImagesSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebListBox.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebListBoxImagesSettings* get_ImagesSettings();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebListBox.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebListBoxImagesSettings^ ImagesSettings {
   WebListBoxImagesSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IndicatorStyle Property

[image]
Intersoft WebEssentials Documentation
IndicatorStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IndicatorStyle Property

Glossary Item Box

Contains interactive style for the active item's indicator style.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for the active item's indicator style.")>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property IndicatorStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.WebStyle

instance.IndicatorStyle = value

value = instance.IndicatorStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the active item's indicator style.")]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle IndicatorStyle {get; set;}
Delphi
public read-write property IndicatorStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for the active item's indicator style.")
System.ComponentModel.CategoryAttribute("Style")
public function get,set IndicatorStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the active item's indicator style.")]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_IndicatorStyle();
public: __property void set_IndicatorStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the active item's indicator style.")]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ IndicatorStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


Init Event

[image]
Intersoft WebEssentials Documentation
Init Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IsAtlasCallback Method

[image]
Intersoft WebEssentials Documentation
IsAtlasCallback Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.IsAtlasCallback()
C#
public System.bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): System.Boolean;
JScript
public function IsAtlasCallback() : System.boolean;
Managed Extensions for C++
public: System.bool IsAtlasCallback();
C++/CLI
public:
System.bool IsAtlasCallback();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IsBetaRelease Method

[image]
Intersoft WebEssentials Documentation
IsBetaRelease Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.IsBetaRelease()
C#
public System.bool IsBetaRelease()
Delphi
public function IsBetaRelease(): System.Boolean;
JScript
public function IsBetaRelease() : System.boolean;
Managed Extensions for C++
public: System.bool IsBetaRelease();
C++/CLI
public:
System.bool IsBetaRelease();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IsChromeBrowser Method

[image]
Intersoft WebEssentials Documentation
IsChromeBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.IsChromeBrowser()
C#
public System.bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): System.Boolean;
JScript
public function IsChromeBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsChromeBrowser();
C++/CLI
public:
System.bool IsChromeBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IsFlyPostBackControl Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual System.bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): System.Boolean; virtual;
JScript
public function IsFlyPostBackControl() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackControl();
C++/CLI
public:
virtual System.bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IsFlyPostBackRequest Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackRequest Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual System.bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): System.Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackRequest();
C++/CLI
public:
virtual System.bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebEssentials Documentation
IsGeckoBasedBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.IsGeckoBasedBrowser()
C#
public System.bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): System.Boolean;
JScript
public function IsGeckoBasedBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoBasedBrowser();
C++/CLI
public:
System.bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IsGeckoVersion18 Method

[image]
Intersoft WebEssentials Documentation
IsGeckoVersion18 Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.IsGeckoVersion18()
C#
public System.bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): System.Boolean;
JScript
public function IsGeckoVersion18() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoVersion18();
C++/CLI
public:
System.bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IsInDesignMode Method

[image]
Intersoft WebEssentials Documentation
IsInDesignMode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.IsInDesignMode()
C#
public System.bool IsInDesignMode()
Delphi
public function IsInDesignMode(): System.Boolean;
JScript
public function IsInDesignMode() : System.boolean;
Managed Extensions for C++
public: System.bool IsInDesignMode();
C++/CLI
public:
System.bool IsInDesignMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorer8Browser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.IsInternetExplorer8Browser()
C#
public System.bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): System.Boolean;
JScript
public function IsInternetExplorer8Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer8Browser();
C++/CLI
public:
System.bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorerBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.IsInternetExplorerBrowser()
C#
public System.bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): System.Boolean;
JScript
public function IsInternetExplorerBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorerBrowser();
C++/CLI
public:
System.bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IsOperaBrowser Method

[image]
Intersoft WebEssentials Documentation
IsOperaBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.IsOperaBrowser()
C#
public System.bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): System.Boolean;
JScript
public function IsOperaBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsOperaBrowser();
C++/CLI
public:
System.bool IsOperaBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IsSafariBrowser Method

[image]
Intersoft WebEssentials Documentation
IsSafariBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.IsSafariBrowser()
C#
public System.bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): System.Boolean;
JScript
public function IsSafariBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsSafariBrowser();
C++/CLI
public:
System.bool IsSafariBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


IsW3CStandardBrowser Method

[image]
Intersoft WebEssentials Documentation
IsW3CStandardBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.IsW3CStandardBrowser()
C#
public System.bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): System.Boolean;
JScript
public function IsW3CStandardBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsW3CStandardBrowser();
C++/CLI
public:
System.bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ItemDataBound Event

[image]
Intersoft WebEssentials Documentation
ItemDataBound Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ItemDataBound Event

Glossary Item Box

Fires when each item is being bound.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires when each item is being bound.")>
<System.ComponentModel.CategoryAttribute("Action")>
Public Event ItemDataBound As WebListBoxItemDataBoundEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim handler As WebListBoxItemDataBoundEventHandler

AddHandler instance.ItemDataBound, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires when each item is being bound.")]
[System.ComponentModel.CategoryAttribute("Action")]
public event WebListBoxItemDataBoundEventHandler ItemDataBound
Delphi
public event ItemDataBound: WebListBoxItemDataBoundEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires when each item is being bound.")]
[System.ComponentModel.CategoryAttribute("Action")]
public: __event WebListBoxItemDataBoundEventHandler* ItemDataBound
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires when each item is being bound.")]
[System.ComponentModel.CategoryAttribute("Action")]
public:
event WebListBoxItemDataBoundEventHandler^ ItemDataBound

Event Data

The event handler receives an argument of type WebListBoxItemDataBoundEventArgs containing data related to this event. The following WebListBoxItemDataBoundEventArgs properties provide information specific to this event.

Property | Description
DataRow | Gets the data object of the specified item.
Item | Gets the item object that is being bound.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ItemImageStyle Property

[image]
Intersoft WebEssentials Documentation
ItemImageStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ItemImageStyle Property

Glossary Item Box

Contains interactive style for the item image style.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for the item image style.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property ItemImageStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.WebStyle

instance.ItemImageStyle = value

value = instance.ItemImageStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the item image style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle ItemImageStyle {get; set;}
Delphi
public read-write property ItemImageStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Contains interactive style for the item image style.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.CategoryAttribute("Style")
public function get,set ItemImageStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the item image style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_ItemImageStyle();
public: __property void set_ItemImageStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the item image style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ ItemImageStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


Items Property

[image]
Intersoft WebEssentials Documentation
Items Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : Items Property

Glossary Item Box

The item collection of WebListBoxItem

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setItems")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Gets the collection of WebListBoxItem Item")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property Items As WebListBoxItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As WebListBoxItemCollection

value = instance.Items
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets the collection of WebListBoxItem Item")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public WebListBoxItemCollection Items {get;}
Delphi
public read-only property Items: WebListBoxItemCollection;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setItems")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Gets the collection of WebListBoxItem Item")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DefaultValueAttribute()
public function get Items : WebListBoxItemCollection
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets the collection of WebListBoxItem Item")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebListBoxItemCollection* get_Items();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets the collection of WebListBoxItem Item")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebListBoxItemCollection^ Items {
   WebListBoxItemCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ItemStyle Property

[image]
Intersoft WebEssentials Documentation
ItemStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ItemStyle Property

Glossary Item Box

Contains interactive style for item style.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Style")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for item style.")>
Public Property ItemStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.DynamicStyle

instance.ItemStyle = value

value = instance.ItemStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item style.")]
public ISNet.WebUI.DynamicStyle ItemStyle {get; set;}
Delphi
public read-write property ItemStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Style")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Contains interactive style for item style.")
public function get,set ItemStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item style.")]
public: __property ISNet.WebUI.DynamicStyle* get_ItemStyle();
public: __property void set_ItemStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item style.")]
public:
property ISNet.WebUI.DynamicStyle^ ItemStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ItemTextStyle Property

[image]
Intersoft WebEssentials Documentation
ItemTextStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ItemTextStyle Property

Glossary Item Box

Contains interactive style for the item text style.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for the item text style.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ItemTextStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.WebStyle

instance.ItemTextStyle = value

value = instance.ItemTextStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the item text style.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle ItemTextStyle {get; set;}
Delphi
public read-write property ItemTextStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for the item text style.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.DefaultValueAttribute()
public function get,set ItemTextStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the item text style.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_ItemTextStyle();
public: __property void set_ItemTextStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the item text style.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ ItemTextStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


LayoutSettings Property

[image]
Intersoft WebEssentials Documentation
LayoutSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : LayoutSettings Property

Glossary Item Box

Provides the settings that control the behaviors of the layout in WebListBox.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebListBox.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property LayoutSettings As WebListBoxLayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As WebListBoxLayoutSettings

value = instance.LayoutSettings
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebListBox.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebListBoxLayoutSettings LayoutSettings {get;}
Delphi
public read-only property LayoutSettings: WebListBoxLayoutSettings;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebListBox.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get LayoutSettings : WebListBoxLayoutSettings
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebListBox.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebListBoxLayoutSettings* get_LayoutSettings();
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebListBox.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebListBoxLayoutSettings^ LayoutSettings {
   WebListBoxLayoutSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


Load Event

[image]
Intersoft WebEssentials Documentation
Load Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


LoadLayout Method

[image]
Intersoft WebEssentials Documentation
LoadLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


LoadLayoutFromFile Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim filePath As System.String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   System.string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: System.String
); virtual;
JScript
public function LoadLayoutFromFile(
   filePath : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromFile(
   System.string* filePath
)
C++/CLI
public:
virtual void LoadLayoutFromFile(
   System.String^ filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromPredefinedName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim predefinedName As System.String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   System.string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: System.String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   System.string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   System.String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


LoadLayoutFromStream Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: System.IO.Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   System.IO.Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


LoadPostData Method

[image]
Intersoft WebEssentials Documentation
LoadPostData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As System.String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim postDataKey As System.String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As System.Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override System.bool LoadPostData(
   System.string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)
Delphi
public function LoadPostData(
    postDataKey: System.String;
    postCollection: System.Collections.Specialized.NameValueCollection
): System.Boolean; override;
JScript
public override function LoadPostData(
   postDataKey : System.String,
   postCollection : System.Collections.Specialized.NameValueCollection
) : System.boolean;
Managed Extensions for C++
public: System.bool LoadPostData(
   System.string* postDataKey,
   System.Collections.Specialized.NameValueCollection* postCollection
) override
C++/CLI
public:
System.bool LoadPostData(
   System.String^ postDataKey,
   System.Collections.Specialized.NameValueCollection^ postCollection
) override

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


MergeStyle Method

[image]
Intersoft WebEssentials Documentation
MergeStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


NameFieldDataMember Property

[image]
Intersoft WebEssentials Documentation
NameFieldDataMember Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : NameFieldDataMember Property

Glossary Item Box

Sets the name field data member.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the name field data member.")>
Public Property NameFieldDataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.NameFieldDataMember = value

value = instance.NameFieldDataMember
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the name field data member.")]
public System.string NameFieldDataMember {get; set;}
Delphi
public read-write property NameFieldDataMember: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Sets the name field data member.")
public function get,set NameFieldDataMember : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the name field data member.")]
public: __property System.string* get_NameFieldDataMember();
public: __property void set_NameFieldDataMember(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the name field data member.")]
public:
property System.String^ NameFieldDataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


OnInfoChanged Method

[image]
Intersoft WebEssentials Documentation
OnInfoChanged Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


OnPreInitialize Method

[image]
Intersoft WebEssentials Documentation
OnPreInitialize Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebListBox

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


Page Property

[image]
Intersoft WebEssentials Documentation
Page Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}
Delphi
public read-write property Page: System.Web.UI.Page; virtual;
JScript
public function get,set Page : System.Web.UI.Page
Managed Extensions for C++
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
C++/CLI
public:
virtual property System.Web.UI.Page^ Page {
   System.Web.UI.Page^ get();
   void set (    System.Web.UI.Page^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


PostBackMode Property

[image]
Intersoft WebEssentials Documentation
PostBackMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : PostBackMode Property

Glossary Item Box

Gets or sets the value that determines the postback mode when AutoPostBack is enabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the postback mode when AutoPostBack is enabled.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property PostBackMode As WebListBoxPostBackMode
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As WebListBoxPostBackMode

instance.PostBackMode = value

value = instance.PostBackMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the postback mode when AutoPostBack is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebListBoxPostBackMode PostBackMode {get; set;}
Delphi
public read-write property PostBackMode: WebListBoxPostBackMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the postback mode when AutoPostBack is enabled.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set PostBackMode : WebListBoxPostBackMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the postback mode when AutoPostBack is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebListBoxPostBackMode get_PostBackMode();
public: __property void set_PostBackMode(
   WebListBoxPostBackMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the postback mode when AutoPostBack is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebListBoxPostBackMode PostBackMode {
   WebListBoxPostBackMode get();
   void set (    WebListBoxPostBackMode value);
}

Property Value

The default value is FullPostBack.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


PreInitialize Event

[image]
Intersoft WebEssentials Documentation
PreInitialize Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim handler As System.EventHandler

AddHandler instance.PreInitialize, handler
C#
public event System.EventHandler PreInitialize
Delphi
public event PreInitialize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* PreInitialize
C++/CLI
public:
event System.EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


PreRender Event

[image]
Intersoft WebEssentials Documentation
PreRender Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RaisePostBackEvent Method

[image]
Intersoft WebEssentials Documentation
RaisePostBackEvent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim eventArgument As System.String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   System.string eventArgument
)
Delphi
public procedure RaisePostBackEvent(
    eventArgument: System.String
);
JScript
public function RaisePostBackEvent(
   eventArgument : System.String
);
Managed Extensions for C++
public: void RaisePostBackEvent(
   System.string* eventArgument
)
C++/CLI
public:
void RaisePostBackEvent(
   System.String^ eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebEssentials Documentation
RaisePostDataChangedEvent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebListBox

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); virtual;
JScript
public function RaisePostDataChangedEvent();
Managed Extensions for C++
public: virtual void RaisePostDataChangedEvent();
C++/CLI
public:
virtual void RaisePostDataChangedEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ReadWebConfigValue Method

[image]
Intersoft WebEssentials Documentation
ReadWebConfigValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim key As System.String
Dim value As System.String

value = instance.ReadWebConfigValue(key)
C#
public System.string ReadWebConfigValue(
   System.string key
)
Delphi
public function ReadWebConfigValue(
    key: System.String
): System.String;
JScript
public function ReadWebConfigValue(
   key : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ReadWebConfigValue(
   System.string* key
)
C++/CLI
public:
System.String^ ReadWebConfigValue(
   System.String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RecreateChildControls Method

[image]
Intersoft WebEssentials Documentation
RecreateChildControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebListBox

instance.RecreateChildControls()
C#
public void RecreateChildControls()
Delphi
public procedure RecreateChildControls();
JScript
public function RecreateChildControls();
Managed Extensions for C++
public: void RecreateChildControls();
C++/CLI
public:
void RecreateChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RegisterBoxSizing Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RegisterBoxSizing() Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebListBox

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim forceAll As System.Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   System.bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: System.Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : System.boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   System.bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   System.bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebEssentials Documentation
RegisterGlobalStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RegisterLink Method

[image]
Intersoft WebEssentials Documentation
RegisterLink Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As System.String, _
   ByVal url As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim name As System.String
Dim url As System.String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   System.string name,
   System.string url
)
Delphi
public procedure RegisterLink(
    name: System.String;
    url: System.String
);
JScript
public function RegisterLink(
   name : System.String,
   url : System.String
);
Managed Extensions for C++
public: void RegisterLink(
   System.string* name,
   System.string* url
)
C++/CLI
public:
void RegisterLink(
   System.String^ name,
   System.String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebEssentials Documentation
RegisterOptimizedCssClasses Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim runtimeStyleOnly As System.Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: System.Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : System.boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RegisterPreloadImage Method

[image]
Intersoft WebEssentials Documentation
RegisterPreloadImage Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim image As System.String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   System.string image
)
Delphi
public procedure RegisterPreloadImage(
    image: System.String
);
JScript
public function RegisterPreloadImage(
   image : System.String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   System.string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   System.String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RegisterScript Method

[image]
Intersoft WebEssentials Documentation
RegisterScript Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebListBox

instance.RegisterScript()
C#
public override void RegisterScript()
Delphi
public procedure RegisterScript(); override;
JScript
public override function RegisterScript();
Managed Extensions for C++
public: void RegisterScript(); override
C++/CLI
public:
void RegisterScript(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RegisterSharePointHandler Method

[image]
Intersoft WebEssentials Documentation
RegisterSharePointHandler Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebListBox

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RenderBeginTag Method

[image]
Intersoft WebEssentials Documentation
RenderBeginTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RenderControl Method

[image]
Intersoft WebEssentials Documentation
RenderControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebEssentials Documentation
RenderControl(HtmlTextWriter) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RenderEndTag Method

[image]
Intersoft WebEssentials Documentation
RenderEndTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RenderingMode Property

[image]
Intersoft WebEssentials Documentation
RenderingMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebListBox

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ResolveClientUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveClientUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ResolveImagePath Method

[image]
Intersoft WebEssentials Documentation
ResolveImagePath Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As System.String, _
   ByVal image As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim folder As System.String
Dim image As System.String
Dim value As System.String

value = instance.ResolveImagePath(folder, image)
C#
public System.string ResolveImagePath(
   System.string folder,
   System.string image
)
Delphi
public function ResolveImagePath(
    folder: System.String;
    image: System.String
): System.String;
JScript
public function ResolveImagePath(
   folder : System.String,
   image : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveImagePath(
   System.string* folder,
   System.string* image
)
C++/CLI
public:
System.String^ ResolveImagePath(
   System.String^ folder,
   System.String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ResolveRelativeURL Method

[image]
Intersoft WebEssentials Documentation
ResolveRelativeURL Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim url As System.String
Dim value As System.String

value = instance.ResolveRelativeURL(url)
C#
public virtual System.string ResolveRelativeURL(
   System.string url
)
Delphi
public function ResolveRelativeURL(
    url: System.String
): System.String; virtual;
JScript
public function ResolveRelativeURL(
   url : System.String
) : System.String;
Managed Extensions for C++
public: virtual System.string* ResolveRelativeURL(
   System.string* url
)
C++/CLI
public:
virtual System.String^ ResolveRelativeURL(
   System.String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ResolveResourceUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveResourceUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As System.String, _
   ByVal currentFolder As System.String, _
   ByVal resourceName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As System.String
Dim currentFolder As System.String
Dim resourceName As System.String
Dim value As System.String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public System.string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string defaultFolder,
   System.string currentFolder,
   System.string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: System.String;
    currentFolder: System.String;
    resourceName: System.String
): System.String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : System.String,
   currentFolder : System.String,
   resourceName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string* defaultFolder,
   System.string* currentFolder,
   System.string* resourceName
)
C++/CLI
public:
System.String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.String^ defaultFolder,
   System.String^ currentFolder,
   System.String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ResolveUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


RuntimeLicenseKey Property

[image]
Intersoft WebEssentials Documentation
RuntimeLicenseKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
Public Overridable Property RuntimeLicenseKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public virtual System.string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: System.String; virtual;
JScript
ISNet.PersistLayoutAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
public function get,set RuntimeLicenseKey : System.String
Managed Extensions for C++
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public: __property virtual System.string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   System.string* value
);
C++/CLI
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public:
virtual property System.String^ RuntimeLicenseKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


SaveLayout Method

[image]
Intersoft WebEssentials Documentation
SaveLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


SaveLayoutToFile Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim filePath As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   System.string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   System.string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   System.String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


SaveLayoutToStream Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
ScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overrides Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public override System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String; override;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public override function get,set ScriptDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.String^ ScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


SelectedIndex Property

[image]
Intersoft WebEssentials Documentation
SelectedIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : SelectedIndex Property

Glossary Item Box

Gets or sets the index that determines the selected item.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the index that determines the selected item.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property SelectedIndex As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the index that determines the selected item.")]
[System.ComponentModel.CategoryAttribute("General")]
public System.int SelectedIndex {get; set;}
Delphi
public read-write property SelectedIndex: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the index that determines the selected item.")
System.ComponentModel.CategoryAttribute("General")
public function get,set SelectedIndex : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the index that determines the selected item.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.int get_SelectedIndex();
public: __property void set_SelectedIndex(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the index that determines the selected item.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.int SelectedIndex {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


SelectedItemChanged Event

[image]
Intersoft WebEssentials Documentation
SelectedItemChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : SelectedItemChanged Event

Glossary Item Box

Fires when when the selected item is changed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires when the selected item is changed.")>
<System.ComponentModel.CategoryAttribute("Action")>
Public Event SelectedItemChanged As WebListBoxSelectedItemChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim handler As WebListBoxSelectedItemChangedEventHandler

AddHandler instance.SelectedItemChanged, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires when the selected item is changed.")]
[System.ComponentModel.CategoryAttribute("Action")]
public event WebListBoxSelectedItemChangedEventHandler SelectedItemChanged
Delphi
public event SelectedItemChanged: WebListBoxSelectedItemChangedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires when the selected item is changed.")]
[System.ComponentModel.CategoryAttribute("Action")]
public: __event WebListBoxSelectedItemChangedEventHandler* SelectedItemChanged
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires when the selected item is changed.")]
[System.ComponentModel.CategoryAttribute("Action")]
public:
event WebListBoxSelectedItemChangedEventHandler^ SelectedItemChanged

Event Data

The event handler receives an argument of type WebListBoxSelectedItemChangedEventArgs containing data related to this event. The following WebListBoxSelectedItemChangedEventArgs properties provide information specific to this event.

Property | Description
SelectedIndex | Gets the selected index.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


SelectionMode Property

[image]
Intersoft WebEssentials Documentation
SelectionMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : SelectionMode Property

Glossary Item Box

Gets or sets the value that determines whether to use single or multiple selection mode.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether to use single or multiple selection mode.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SelectionMode As WebListBoxSelectionMode
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As WebListBoxSelectionMode

instance.SelectionMode = value

value = instance.SelectionMode
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether to use single or multiple selection mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public WebListBoxSelectionMode SelectionMode {get; set;}
Delphi
public read-write property SelectionMode: WebListBoxSelectionMode;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether to use single or multiple selection mode.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set SelectionMode : WebListBoxSelectionMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether to use single or multiple selection mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebListBoxSelectionMode get_SelectionMode();
public: __property void set_SelectionMode(
   WebListBoxSelectionMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether to use single or multiple selection mode.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebListBoxSelectionMode SelectionMode {
   WebListBoxSelectionMode get();
   void set (    WebListBoxSelectionMode value);
}

Property Value

The default value is Single.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


SetRenderMethodDelegate Method

[image]
Intersoft WebEssentials Documentation
SetRenderMethodDelegate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


SetSessionTheme Method

[image]
Intersoft WebEssentials Documentation
SetSessionTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


SetValue Method

[image]
Intersoft WebEssentials Documentation
SetValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : SetValue Method

value

Glossary Item Box

Sets the selected value of WebListBox.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the selected value of WebListBox.")>
Public Sub SetValue( _
   ByVal value As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.SetValue(value)
C#
[System.ComponentModel.DescriptionAttribute("Sets the selected value of WebListBox.")]
public void SetValue(
   System.string value
)
Delphi
public procedure SetValue(
    value: System.String
);
JScript
System.ComponentModel.DescriptionAttribute("Sets the selected value of WebListBox.")
public function SetValue(
   value : System.String
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the selected value of WebListBox.")]
public: void SetValue(
   System.string* value
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the selected value of WebListBox.")]
public:
void SetValue(
   System.String^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


SetValues Method

[image]
Intersoft WebEssentials Documentation
SetValues Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : SetValues Method

values

Glossary Item Box

Sets the selected values of WebListBox.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the selected values of WebListBox.")>
Public Sub SetValues( _
   ByVal values As System.Collections.Generic.List(Of String) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim values As System.Collections.Generic.List(Of String)

instance.SetValues(values)
C#
[System.ComponentModel.DescriptionAttribute("Sets the selected values of WebListBox.")]
public void SetValues(
   System.Collections.Generic.List<string> values
)
Delphi
public procedure SetValues(
    values: System.Collections.Generic.List
);
JScript
System.ComponentModel.DescriptionAttribute("Sets the selected values of WebListBox.")
public function SetValues(
   values : System.Collections.Generic.List
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the selected values of WebListBox.")]
public: void SetValues(
   System.Collections.Generic.List<string*>* values
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the selected values of WebListBox.")]
public:
void SetValues(
   System.Collections.Generic.List<String^>^ values
)

Parameters

values

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


SharedScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
SharedScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required framework scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Overrides Property SharedScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.XmlSerializableAttribute()]
public override System.string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: System.String; override;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
ISNet.Serialization.XmlSerializableAttribute()
public override function get,set SharedScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_SharedScriptDirectory() override;
public: __property void set_SharedScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ SharedScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ShouldReturnJson Method

[image]
Intersoft WebEssentials Documentation
ShouldReturnJson Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

value = instance.ShouldReturnJson()
C#
public virtual System.bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): System.Boolean; virtual;
JScript
public function ShouldReturnJson() : System.boolean;
Managed Extensions for C++
public: virtual System.bool ShouldReturnJson();
C++/CLI
public:
virtual System.bool ShouldReturnJson();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


SkinID Property

[image]
Intersoft WebEssentials Documentation
SkinID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


TabIndex Property

[image]
Intersoft WebEssentials Documentation
TabIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set TabIndex : System.short
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


TargetURLFieldDataMember Property

[image]
Intersoft WebEssentials Documentation
TargetURLFieldDataMember Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : TargetURLFieldDataMember Property

Glossary Item Box

Sets the target url field date member.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DescriptionAttribute("Sets the target url field date member.")>
Public Property TargetURLFieldDataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.TargetURLFieldDataMember = value

value = instance.TargetURLFieldDataMember
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Sets the target url field date member.")]
public System.string TargetURLFieldDataMember {get; set;}
Delphi
public read-write property TargetURLFieldDataMember: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DescriptionAttribute("Sets the target url field date member.")
public function get,set TargetURLFieldDataMember : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Sets the target url field date member.")]
public: __property System.string* get_TargetURLFieldDataMember();
public: __property void set_TargetURLFieldDataMember(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Sets the target url field date member.")]
public:
property System.String^ TargetURLFieldDataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


TextFieldDataMember Property

[image]
Intersoft WebEssentials Documentation
TextFieldDataMember Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : TextFieldDataMember Property

Glossary Item Box

Sets the text field data member.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the text field data member.")>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TextFieldDataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.TextFieldDataMember = value

value = instance.TextFieldDataMember
C#
[System.ComponentModel.DescriptionAttribute("Sets the text field data member.")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TextFieldDataMember {get; set;}
Delphi
public read-write property TextFieldDataMember: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Sets the text field data member.")
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set TextFieldDataMember : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the text field data member.")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TextFieldDataMember();
public: __property void set_TextFieldDataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the text field data member.")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TextFieldDataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ToolTip Property

[image]
Intersoft WebEssentials Documentation
ToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


TopScrollerStyle Property

[image]
Intersoft WebEssentials Documentation
TopScrollerStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : TopScrollerStyle Property

Glossary Item Box

Contains interactive style for top scroller style.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for top scroller style.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TopScrollerStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.WebStyle

instance.TopScrollerStyle = value

value = instance.TopScrollerStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for top scroller style.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.WebStyle TopScrollerStyle {get; set;}
Delphi
public read-write property TopScrollerStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Contains interactive style for top scroller style.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TopScrollerStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for top scroller style.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.WebStyle* get_TopScrollerStyle();
public: __property void set_TopScrollerStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for top scroller style.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.WebStyle^ TopScrollerStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


Unload Event

[image]
Intersoft WebEssentials Documentation
Unload Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


UseDefaultStyle Property

[image]
Intersoft WebEssentials Documentation
UseDefaultStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : UseDefaultStyle Property

Glossary Item Box

Specifies whether WebListBox should apply embedded default style for its appearance.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether WebListBox should apply embedded default style for its appearance.")>
Public Property UseDefaultStyle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

instance.UseDefaultStyle = value

value = instance.UseDefaultStyle
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebListBox should apply embedded default style for its appearance.")]
public System.bool UseDefaultStyle {get; set;}
Delphi
public read-write property UseDefaultStyle: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether WebListBox should apply embedded default style for its appearance.")
public function get,set UseDefaultStyle : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebListBox should apply embedded default style for its appearance.")]
public: __property System.bool get_UseDefaultStyle();
public: __property void set_UseDefaultStyle(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebListBox should apply embedded default style for its appearance.")]
public:
property System.bool UseDefaultStyle {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ValidateRequestMode Property

[image]
Intersoft WebEssentials Documentation
ValidateRequestMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ValueFieldDataMember Property

[image]
Intersoft WebEssentials Documentation
ValueFieldDataMember Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ValueFieldDataMember Property

Glossary Item Box

Sets the value field data member.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DescriptionAttribute("Sets the value field data member.")>
Public Property ValueFieldDataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.ValueFieldDataMember = value

value = instance.ValueFieldDataMember
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Sets the value field data member.")]
public System.string ValueFieldDataMember {get; set;}
Delphi
public read-write property ValueFieldDataMember: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DescriptionAttribute("Sets the value field data member.")
public function get,set ValueFieldDataMember : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Sets the value field data member.")]
public: __property System.string* get_ValueFieldDataMember();
public: __property void set_ValueFieldDataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Sets the value field data member.")]
public:
property System.String^ ValueFieldDataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ViewStateItems Property

[image]
Intersoft WebEssentials Documentation
ViewStateItems Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ViewStateItems Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ViewStateMode Property

[image]
Intersoft WebEssentials Documentation
ViewStateMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ViewStateServerConnection Property

[image]
Intersoft WebEssentials Documentation
ViewStateServerConnection Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ViewStateServerConnection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ViewStateServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: System.String; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
System.ComponentModel.CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ViewStateServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ViewStateServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


ViewStateStorage Property

[image]
Intersoft WebEssentials Documentation
ViewStateStorage Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : ViewStateStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
System.ComponentModel.CategoryAttribute("View State Settings")
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


Width Property

[image]
Intersoft WebEssentials Documentation
Width Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.CategoryAttribute("Layout")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


XmlCompressionEnabled Property

[image]
Intersoft WebEssentials Documentation
XmlCompressionEnabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebListBox Class : XmlCompressionEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property XmlCompressionEnabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebListBox
Dim value As System.Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: System.Boolean; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set XmlCompressionEnabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool XmlCompressionEnabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebListBox Class
WebListBox Members


WebProgressBar Class

[image]
Intersoft WebEssentials Documentation
WebProgressBar Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBar Class

Glossary Item Box

Intersoft WebProgressBar.

Object Model

WebProgressBar Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebProgressBarDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.ComponentModel.DefaultEventAttribute("Clicked")>
<ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebProgressBar.js", Type=XmlSerializationType.ClientAndLayout)>
<System.Web.UI.ToolboxDataAttribute("<{0}:WebProgressBar runat=server Width="200px" Height="24px"></{0}:WebProgressBar>")>
<System.ComponentModel.DefaultPropertyAttribute("Text")>
<System.SerializableAttribute()>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebProgressBar
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
C#
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebProgressBarDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DefaultEventAttribute("Clicked")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebProgressBar.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebProgressBar runat=server Width="200px" Height="24px"></{0}:WebProgressBar>")]
[System.ComponentModel.DefaultPropertyAttribute("Text")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebProgressBar : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Delphi
public class WebProgressBar = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings)
JScript
System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebProgressBarDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.ComponentModel.DefaultEventAttribute("Clicked")
ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebProgressBar.js", Type=XmlSerializationType.ClientAndLayout)
System.Web.UI.ToolboxDataAttribute("<{0}:WebProgressBar runat=server Width="200px" Height="24px"></{0}:WebProgressBar>")
System.ComponentModel.DefaultPropertyAttribute("Text")
System.SerializableAttribute()
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebProgressBar extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Managed Extensions for C++
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebProgressBarDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DefaultEventAttribute("Clicked")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebProgressBar.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebProgressBar runat=server Width="200px" Height="24px"></{0}:WebProgressBar>")]
[System.ComponentModel.DefaultPropertyAttribute("Text")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebProgressBar : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
C++/CLI
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebProgressBarDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DefaultEventAttribute("Clicked")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebProgressBar.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebProgressBar runat=server Width="200px" Height="24px"></{0}:WebProgressBar>")]
[System.ComponentModel.DefaultPropertyAttribute("Text")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebProgressBar : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebEssentials.WebProgressBar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Members
ISNet.WebUI.WebEssentials Namespace


WebProgressBar Class Events

[image]
Intersoft WebEssentials Documentation
WebProgressBar Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBar Class

Glossary Item Box

For a list of all members of this type, see WebProgressBar members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Finished |
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | ProgressInterval |
Public Event | Start |
Public Event | Unload | (Inherited from System.Web.UI.Control)
Public Event | ValueChanged |
Top

See Also

Reference

WebProgressBar Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBar Class Members

[image]
Intersoft WebEssentials Documentation
WebProgressBar Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBar Class

Glossary Item Box

The following tables list the members exposed by WebProgressBar.

Public Constructors

 | Name | Description
Public Constructor | WebProgressBar Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | AnimationLatency | Gets or sets the Progress Bar animation refresh rate in ms. Apply in Indeterminate mode only.
Public Property | Caption | Gets or sets the Progress Bar caption text.
Public Property | CaptionOrientation | Gets or sets a value indicating whether the caption orientation of the control is Horizontal or Vertical.
Public Property | CaptionStyle | Gets or sets the the style of the Progress Bar caption frame.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Gets or sets client side events for WebProgressBar.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings |
Public Property | FrameStyle | Gets or sets the the style of the Progress Bar frame.
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | Interval | Gets or sets the Progress Bar interval value for ProgressInterval event handler.
Public Property | MaxSliderDimension | Gets or sets the width of the slider when the progress bar is in Indeterminate mode.
Public Property | MaxValue | Gets or sets the Progress Bar maximum value.
Public Property | Mode | Gets or sets a value indicating whether the progress bar mode is Determinate or Indeterminate.
Public Property | Orientation | Gets or sets a value indicating whether the orientation of the control is Horizontal or Vertical.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ProgressBarStyle | Gets or sets the the style of the ProgressBar.
Public Property | ProgressContainerBarStyle | Gets or sets the the style of the ProgressBar background container bar.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden.
Public Property | SharedScriptDirectory | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Step | Gets or sets the Progress Bar step increment. Apply in Indeterminate mode only.
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseDefaultStyle | Determines whether or not WebProgressBar is using default style.
Public Property | UseRoundCorner | Determines whether or not WebProgressBar is using rounder corner style.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | Value | Gets or sets the Progress Bar current value.
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | Overridden.
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Finished |
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | ProgressInterval |
Public Event | Start |
Public Event | Unload | (Inherited from System.Web.UI.Control)
Public Event | ValueChanged |
Top

See Also

Reference

WebProgressBar Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBar Class Methods

[image]
Intersoft WebEssentials Documentation
WebProgressBar Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBar Class

Glossary Item Box

For a list of all members of this type, see WebProgressBar members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebProgressBar Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBar Class Properties

[image]
Intersoft WebEssentials Documentation
WebProgressBar Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBar Class

Glossary Item Box

For a list of all members of this type, see WebProgressBar members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | AnimationLatency | Gets or sets the Progress Bar animation refresh rate in ms. Apply in Indeterminate mode only.
Public Property | Caption | Gets or sets the Progress Bar caption text.
Public Property | CaptionOrientation | Gets or sets a value indicating whether the caption orientation of the control is Horizontal or Vertical.
Public Property | CaptionStyle | Gets or sets the the style of the Progress Bar caption frame.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Gets or sets client side events for WebProgressBar.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings |
Public Property | FrameStyle | Gets or sets the the style of the Progress Bar frame.
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | Interval | Gets or sets the Progress Bar interval value for ProgressInterval event handler.
Public Property | MaxSliderDimension | Gets or sets the width of the slider when the progress bar is in Indeterminate mode.
Public Property | MaxValue | Gets or sets the Progress Bar maximum value.
Public Property | Mode | Gets or sets a value indicating whether the progress bar mode is Determinate or Indeterminate.
Public Property | Orientation | Gets or sets a value indicating whether the orientation of the control is Horizontal or Vertical.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ProgressBarStyle | Gets or sets the the style of the ProgressBar.
Public Property | ProgressContainerBarStyle | Gets or sets the the style of the ProgressBar background container bar.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden.
Public Property | SharedScriptDirectory | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Step | Gets or sets the Progress Bar step increment. Apply in Indeterminate mode only.
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseDefaultStyle | Determines whether or not WebProgressBar is using default style.
Public Property | UseRoundCorner | Determines whether or not WebProgressBar is using rounder corner style.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | Value | Gets or sets the Progress Bar current value.
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | Overridden.
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebProgressBar Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBarClientSideEvents Class

[image]
Intersoft WebEssentials Documentation
WebProgressBarClientSideEvents Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarClientSideEvents Class

Glossary Item Box

Represents the client side (Javascript) WebProgressBar html element events.

Object Model

WebProgressBarClientSideEvents Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Represents the client side (Javascript) WebProgressBar html element events")>
<System.SerializableAttribute()>
Public Class WebProgressBarClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Represents the client side (Javascript) WebProgressBar html element events")]
[System.SerializableAttribute()]
public class WebProgressBarClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebProgressBarClientSideEvents = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Represents the client side (Javascript) WebProgressBar html element events")
System.SerializableAttribute()
public class WebProgressBarClientSideEvents extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Represents the client side (Javascript) WebProgressBar html element events")]
[System.SerializableAttribute()]
public __gc class WebProgressBarClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Represents the client side (Javascript) WebProgressBar html element events")]
[System.SerializableAttribute()]
public ref class WebProgressBarClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Remarks

This class wraps some common event handlers of WebProgressBar element.

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebProgressBarClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Members
ISNet.WebUI.WebEssentials Namespace


WebProgressBarClientSideEvents Class Members

[image]
Intersoft WebEssentials Documentation
WebProgressBarClientSideEvents Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebProgressBarClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebProgressBarClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnFinished | Specifies the client side (JavaScript) function name that will be invoked when progress has finished.
Public Property | OnInitialize | Specifies the client side (JavaScript) function name that will be invoked when WebExpander has finished the initializing process.
Public Property | OnProgressInterval | Specifies the client side (JavaScript) function name that will be invoked when certain interval has passed.
Public Property | OnResponse | Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response.
Public Property | OnResponseError | Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response.
Public Property | OnValueChanged | Specifies the client side (JavaScript) function name that will be invoked when control value is changed
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebProgressBarClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBarClientSideEvents Class Methods

[image]
Intersoft WebEssentials Documentation
WebProgressBarClientSideEvents Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebProgressBarClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebProgressBarClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBarClientSideEvents Class Properties

[image]
Intersoft WebEssentials Documentation
WebProgressBarClientSideEvents Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebProgressBarClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnFinished | Specifies the client side (JavaScript) function name that will be invoked when progress has finished.
Public Property | OnInitialize | Specifies the client side (JavaScript) function name that will be invoked when WebExpander has finished the initializing process.
Public Property | OnProgressInterval | Specifies the client side (JavaScript) function name that will be invoked when certain interval has passed.
Public Property | OnResponse | Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response.
Public Property | OnResponseError | Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response.
Public Property | OnValueChanged | Specifies the client side (JavaScript) function name that will be invoked when control value is changed
Top

See Also

Reference

WebProgressBarClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBarClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebProgressBarClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : WebProgressBarClientSideEvents Constructor

Glossary Item Box

Overload List

Overload | Description
WebProgressBarClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


WebProgressBarClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebProgressBarClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : WebProgressBarClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebProgressBarClientSideEvents()
C#
public WebProgressBarClientSideEvents()
Delphi
public WebProgressBarClientSideEvents();
JScript
public function WebProgressBarClientSideEvents();
Managed Extensions for C++
public: WebProgressBarClientSideEvents();
C++/CLI
public:
WebProgressBarClientSideEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


OnFinished Property

[image]
Intersoft WebEssentials Documentation
OnFinished Property
See Also Example Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : OnFinished Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when progress has finished.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, endTime, value, caption")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when progress has finished. Parameters (controlId, endTime, value, caption)")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnFinished As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim value As System.String

instance.OnFinished = value

value = instance.OnFinished
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, endTime, value, caption")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when progress has finished. Parameters (controlId, endTime, value, caption)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnFinished {get; set;}
Delphi
public read-write property OnFinished: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, endTime, value, caption")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when progress has finished. Parameters (controlId, endTime, value, caption)")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnFinished : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, endTime, value, caption")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when progress has finished. Parameters (controlId, endTime, value, caption)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnFinished();
public: __property void set_OnFinished(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, endTime, value, caption")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when progress has finished. Parameters (controlId, endTime, value, caption)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnFinished {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string
  • endTime - int
  • value - int
  • caption - string

Example

C# Copy Code
function onFinished(controlId, endTime, value, caption)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebEssentials Documentation
OnInitialize Property
See Also Example Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : OnInitialize Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when WebExpander has finished the initializing process.

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when WebProgressBar has finished the initializing process. Parameters (controlId)")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim value As System.String

instance.OnInitialize = value

value = instance.OnInitialize
C#
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when WebProgressBar has finished the initializing process. Parameters (controlId)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnInitialize {get; set;}
Delphi
public read-write property OnInitialize: System.String;
JScript
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when WebProgressBar has finished the initializing process. Parameters (controlId)")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnInitialize : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when WebProgressBar has finished the initializing process. Parameters (controlId)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnInitialize();
public: __property void set_OnInitialize(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when WebProgressBar has finished the initializing process. Parameters (controlId)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function onInitialize(controlId)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


OnProgressInterval Property

[image]
Intersoft WebEssentials Documentation
OnProgressInterval Property
See Also Example Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : OnProgressInterval Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when certain interval has passed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, value, caption")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when certain interval has passed. Parameters (controlId, value, caption)")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnProgressInterval As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim value As System.String

instance.OnProgressInterval = value

value = instance.OnProgressInterval
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, value, caption")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when certain interval has passed. Parameters (controlId, value, caption)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string OnProgressInterval {get; set;}
Delphi
public read-write property OnProgressInterval: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, value, caption")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when certain interval has passed. Parameters (controlId, value, caption)")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnProgressInterval : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, value, caption")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when certain interval has passed. Parameters (controlId, value, caption)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_OnProgressInterval();
public: __property void set_OnProgressInterval(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, value, caption")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when certain interval has passed. Parameters (controlId, value, caption)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ OnProgressInterval {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string
  • value - int
  • caption - string

Example

C# Copy Code
function onProgressInterval(controlId, value, caption)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


OnResponse Property

[image]
Intersoft WebEssentials Documentation
OnResponse Property
See Also Example Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : OnResponse Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, action, xmlResponse")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response. Parameters (controlId, value)")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnResponse As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim value As System.String

instance.OnResponse = value

value = instance.OnResponse
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action, xmlResponse")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response. Parameters (controlId, value)")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnResponse {get; set;}
Delphi
public read-write property OnResponse: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, action, xmlResponse")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response. Parameters (controlId, value)")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnResponse : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action, xmlResponse")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response. Parameters (controlId, value)")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnResponse();
public: __property void set_OnResponse(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action, xmlResponse")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent a successful response. Parameters (controlId, value)")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnResponse {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string
  • value - string

Example

C# Copy Code
function onResponse(controlId, value)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


OnResponseError Property

[image]
Intersoft WebEssentials Documentation
OnResponseError Property
See Also Example Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : OnResponseError Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, value")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response. Parameters (controlId, value)")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnResponseError As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim value As System.String

instance.OnResponseError = value

value = instance.OnResponseError
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, value")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response. Parameters (controlId, value)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnResponseError {get; set;}
Delphi
public read-write property OnResponseError: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, value")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response. Parameters (controlId, value)")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnResponseError : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, value")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response. Parameters (controlId, value)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnResponseError();
public: __property void set_OnResponseError(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, value")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when FlyPostBack has sent an error response. Parameters (controlId, value)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnResponseError {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string
  • value - string

Example

C# Copy Code
function onResponseError(controlId, value)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


OnValueChanged Property

[image]
Intersoft WebEssentials Documentation
OnValueChanged Property
See Also Example Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : OnValueChanged Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when control value is changed

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId,value")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control value is changed. Parameters (controlId,value)")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnValueChanged As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim value As System.String

instance.OnValueChanged = value

value = instance.OnValueChanged
C#
[ISNet.EventParameterAttribute("controlId,value")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control value is changed. Parameters (controlId,value)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnValueChanged {get; set;}
Delphi
public read-write property OnValueChanged: System.String;
JScript
ISNet.EventParameterAttribute("controlId,value")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control value is changed. Parameters (controlId,value)")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnValueChanged : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId,value")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control value is changed. Parameters (controlId,value)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnValueChanged();
public: __property void set_OnValueChanged(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId,value")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control value is changed. Parameters (controlId,value)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnValueChanged {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string
  • value - int

Example

C# Copy Code
function onValueChanged(controlId,value)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarClientSideEvents
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarClientSideEvents Class
WebProgressBarClientSideEvents Members


WebProgressBarFinishedEventDataArgs Class

[image]
Intersoft WebEssentials Documentation
WebProgressBarFinishedEventDataArgs Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarFinishedEventDataArgs Class

Glossary Item Box

Represents the WebProgressBar finish event argument.

Object Model

WebProgressBarFinishedEventDataArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebProgressBarFinishedEventDataArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarFinishedEventDataArgs
C#
public class WebProgressBarFinishedEventDataArgs : System.EventArgs
Delphi
public class WebProgressBarFinishedEventDataArgs = class(System.EventArgs)
JScript
public class WebProgressBarFinishedEventDataArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebProgressBarFinishedEventDataArgs : public System.EventArgs
C++/CLI
public ref class WebProgressBarFinishedEventDataArgs : public System.EventArgs

Remarks

This class contains property for the WebProgressBar finish event argument.

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebEssentials.WebProgressBarFinishedEventDataArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarFinishedEventDataArgs Members
ISNet.WebUI.WebEssentials Namespace


WebProgressBarFinishedEventDataArgs Class Members

[image]
Intersoft WebEssentials Documentation
WebProgressBarFinishedEventDataArgs Class Members
See Also Properties Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarFinishedEventDataArgs Class

Glossary Item Box

The following tables list the members exposed by WebProgressBarFinishedEventDataArgs.

Public Constructors

 | Name | Description
Public Constructor | WebProgressBarFinishedEventDataArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Caption | The current caption of the WebProgressbar.
Public Property | EndTime | The end time of WebProgressbar progress in ticks.
Public Property | Value | The maximum value of the WebProgressbar.
Top

See Also

Reference

WebProgressBarFinishedEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBarFinishedEventDataArgs Class Properties

[image]
Intersoft WebEssentials Documentation
WebProgressBarFinishedEventDataArgs Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarFinishedEventDataArgs Class

Glossary Item Box

For a list of all members of this type, see WebProgressBarFinishedEventDataArgs members.

Public Properties

 | Name | Description
Public Property | Caption | The current caption of the WebProgressbar.
Public Property | EndTime | The end time of WebProgressbar progress in ticks.
Public Property | Value | The maximum value of the WebProgressbar.
Top

See Also

Reference

WebProgressBarFinishedEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBarFinishedEventDataArgs Constructor

[image]
Intersoft WebEssentials Documentation
WebProgressBarFinishedEventDataArgs Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarFinishedEventDataArgs Class : WebProgressBarFinishedEventDataArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebProgressBarFinishedEventDataArgs()
C#
public WebProgressBarFinishedEventDataArgs()
Delphi
public WebProgressBarFinishedEventDataArgs();
JScript
public function WebProgressBarFinishedEventDataArgs();
Managed Extensions for C++
public: WebProgressBarFinishedEventDataArgs();
C++/CLI
public:
WebProgressBarFinishedEventDataArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarFinishedEventDataArgs Class
WebProgressBarFinishedEventDataArgs Members


Caption Property

[image]
Intersoft WebEssentials Documentation
Caption Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarFinishedEventDataArgs Class : Caption Property

Glossary Item Box

The current caption of the WebProgressbar.

Syntax

Visual Basic (Declaration)
Public Property Caption As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarFinishedEventDataArgs
Dim value As System.String

instance.Caption = value

value = instance.Caption
C#
public System.string Caption {get; set;}
Delphi
public read-write property Caption: System.String;
JScript
public function get,set Caption : System.String
Managed Extensions for C++
public: __property System.string* get_Caption();
public: __property void set_Caption(
   System.string* value
);
C++/CLI
public:
property System.String^ Caption {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarFinishedEventDataArgs Class
WebProgressBarFinishedEventDataArgs Members


EndTime Property

[image]
Intersoft WebEssentials Documentation
EndTime Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarFinishedEventDataArgs Class : EndTime Property

Glossary Item Box

The end time of WebProgressbar progress in ticks.

Syntax

Visual Basic (Declaration)
Public Property EndTime As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarFinishedEventDataArgs
Dim value As System.Integer

instance.EndTime = value

value = instance.EndTime
C#
public System.int EndTime {get; set;}
Delphi
public read-write property EndTime: System.Integer;
JScript
public function get,set EndTime : System.int
Managed Extensions for C++
public: __property System.int get_EndTime();
public: __property void set_EndTime(
   System.int value
);
C++/CLI
public:
property System.int EndTime {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarFinishedEventDataArgs Class
WebProgressBarFinishedEventDataArgs Members


Value Property

[image]
Intersoft WebEssentials Documentation
Value Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarFinishedEventDataArgs Class : Value Property

Glossary Item Box

The maximum value of the WebProgressbar.

Syntax

Visual Basic (Declaration)
Public Property Value As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarFinishedEventDataArgs
Dim value As System.Integer

instance.Value = value

value = instance.Value
C#
public System.int Value {get; set;}
Delphi
public read-write property Value: System.Integer;
JScript
public function get,set Value : System.int
Managed Extensions for C++
public: __property System.int get_Value();
public: __property void set_Value(
   System.int value
);
C++/CLI
public:
property System.int Value {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarFinishedEventDataArgs Class
WebProgressBarFinishedEventDataArgs Members


WebProgressBarMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebProgressBarMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebProgressBarMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarMode
C#
public enum WebProgressBarMode : System.Enum
Delphi
public enum WebProgressBarMode = class(System.Enum)
JScript
public enum WebProgressBarMode extends System.Enum
Managed Extensions for C++
__value public enum WebProgressBarMode : public System.Enum
C++/CLI
public enum class WebProgressBarMode : public System.Enum

Members

Member | Description
Determinate |
Indeterminate |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebProgressBarMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebProgressBarOnFinishedEventHandler Delegate

[image]
Intersoft WebEssentials Documentation
WebProgressBarOnFinishedEventHandler Delegate
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarOnFinishedEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebProgressBarOnFinishedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebProgressBarFinishedEventDataArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebProgressBarOnFinishedEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebProgressBarOnFinishedEventHandler(
   System.object sender,
   WebProgressBarFinishedEventDataArgs e
)
Delphi
public delegate WebProgressBarOnFinishedEventHandler(
    sender: System.TObject;
    e: WebProgressBarFinishedEventDataArgs
);
JScript
public delegate WebProgressBarOnFinishedEventHandler(
   sender : System.Object,
   e : WebProgressBarFinishedEventDataArgs
)
Managed Extensions for C++
public: __gc __delegate void WebProgressBarOnFinishedEventHandler(
   System.Object* sender,
   WebProgressBarFinishedEventDataArgs* e
)
C++/CLI
public delegate void WebProgressBarOnFinishedEventHandler(
   System.Object^ sender,
   WebProgressBarFinishedEventDataArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarOnFinishedEventHandler Members
ISNet.WebUI.WebEssentials Namespace


WebProgressBarOnProgressIntervalEventHandler Delegate

[image]
Intersoft WebEssentials Documentation
WebProgressBarOnProgressIntervalEventHandler Delegate
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarOnProgressIntervalEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebProgressBarOnProgressIntervalEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebProgressBarProgressIntervalEventDataArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebProgressBarOnProgressIntervalEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebProgressBarOnProgressIntervalEventHandler(
   System.object sender,
   WebProgressBarProgressIntervalEventDataArgs e
)
Delphi
public delegate WebProgressBarOnProgressIntervalEventHandler(
    sender: System.TObject;
    e: WebProgressBarProgressIntervalEventDataArgs
);
JScript
public delegate WebProgressBarOnProgressIntervalEventHandler(
   sender : System.Object,
   e : WebProgressBarProgressIntervalEventDataArgs
)
Managed Extensions for C++
public: __gc __delegate void WebProgressBarOnProgressIntervalEventHandler(
   System.Object* sender,
   WebProgressBarProgressIntervalEventDataArgs* e
)
C++/CLI
public delegate void WebProgressBarOnProgressIntervalEventHandler(
   System.Object^ sender,
   WebProgressBarProgressIntervalEventDataArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarOnProgressIntervalEventHandler Members
ISNet.WebUI.WebEssentials Namespace


WebProgressBarOnStartEventHandler Delegate

[image]
Intersoft WebEssentials Documentation
WebProgressBarOnStartEventHandler Delegate
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarOnStartEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebProgressBarOnStartEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebProgressBarStartEventDataArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebProgressBarOnStartEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebProgressBarOnStartEventHandler(
   System.object sender,
   WebProgressBarStartEventDataArgs e
)
Delphi
public delegate WebProgressBarOnStartEventHandler(
    sender: System.TObject;
    e: WebProgressBarStartEventDataArgs
);
JScript
public delegate WebProgressBarOnStartEventHandler(
   sender : System.Object,
   e : WebProgressBarStartEventDataArgs
)
Managed Extensions for C++
public: __gc __delegate void WebProgressBarOnStartEventHandler(
   System.Object* sender,
   WebProgressBarStartEventDataArgs* e
)
C++/CLI
public delegate void WebProgressBarOnStartEventHandler(
   System.Object^ sender,
   WebProgressBarStartEventDataArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarOnStartEventHandler Members
ISNet.WebUI.WebEssentials Namespace


WebProgressBarOnValueChangedEventHandler Delegate

[image]
Intersoft WebEssentials Documentation
WebProgressBarOnValueChangedEventHandler Delegate
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarOnValueChangedEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebProgressBarOnValueChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebProgressBarValueChangedEventDataArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebProgressBarOnValueChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebProgressBarOnValueChangedEventHandler(
   System.object sender,
   WebProgressBarValueChangedEventDataArgs e
)
Delphi
public delegate WebProgressBarOnValueChangedEventHandler(
    sender: System.TObject;
    e: WebProgressBarValueChangedEventDataArgs
);
JScript
public delegate WebProgressBarOnValueChangedEventHandler(
   sender : System.Object,
   e : WebProgressBarValueChangedEventDataArgs
)
Managed Extensions for C++
public: __gc __delegate void WebProgressBarOnValueChangedEventHandler(
   System.Object* sender,
   WebProgressBarValueChangedEventDataArgs* e
)
C++/CLI
public delegate void WebProgressBarOnValueChangedEventHandler(
   System.Object^ sender,
   WebProgressBarValueChangedEventDataArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarOnValueChangedEventHandler Members
ISNet.WebUI.WebEssentials Namespace


WebProgressBarOrientation Enumeration

[image]
Intersoft WebEssentials Documentation
WebProgressBarOrientation Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarOrientation Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebProgressBarOrientation
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarOrientation
C#
public enum WebProgressBarOrientation : System.Enum
Delphi
public enum WebProgressBarOrientation = class(System.Enum)
JScript
public enum WebProgressBarOrientation extends System.Enum
Managed Extensions for C++
__value public enum WebProgressBarOrientation : public System.Enum
C++/CLI
public enum class WebProgressBarOrientation : public System.Enum

Members

Member | Description
Horizontal |
Vertical |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebProgressBarOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebProgressBarProgressIntervalEventDataArgs Class

[image]
Intersoft WebEssentials Documentation
WebProgressBarProgressIntervalEventDataArgs Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarProgressIntervalEventDataArgs Class

Glossary Item Box

Represents the WebProgressBar progress interval event argument.

Object Model

WebProgressBarProgressIntervalEventDataArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebProgressBarProgressIntervalEventDataArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarProgressIntervalEventDataArgs
C#
public class WebProgressBarProgressIntervalEventDataArgs : System.EventArgs
Delphi
public class WebProgressBarProgressIntervalEventDataArgs = class(System.EventArgs)
JScript
public class WebProgressBarProgressIntervalEventDataArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebProgressBarProgressIntervalEventDataArgs : public System.EventArgs
C++/CLI
public ref class WebProgressBarProgressIntervalEventDataArgs : public System.EventArgs

Remarks

This class contains property for the WebProgressBar progress interval event argument.

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebEssentials.WebProgressBarProgressIntervalEventDataArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarProgressIntervalEventDataArgs Members
ISNet.WebUI.WebEssentials Namespace


WebProgressBarProgressIntervalEventDataArgs Class Members

[image]
Intersoft WebEssentials Documentation
WebProgressBarProgressIntervalEventDataArgs Class Members
See Also Properties Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarProgressIntervalEventDataArgs Class

Glossary Item Box

The following tables list the members exposed by WebProgressBarProgressIntervalEventDataArgs.

Public Constructors

 | Name | Description
Public Constructor | WebProgressBarProgressIntervalEventDataArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Caption | The current caption of the WebProgressbar.
Public Property | Value | The current value of the WebProgressbar.
Top

See Also

Reference

WebProgressBarProgressIntervalEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBarProgressIntervalEventDataArgs Class Properties

[image]
Intersoft WebEssentials Documentation
WebProgressBarProgressIntervalEventDataArgs Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarProgressIntervalEventDataArgs Class

Glossary Item Box

For a list of all members of this type, see WebProgressBarProgressIntervalEventDataArgs members.

Public Properties

 | Name | Description
Public Property | Caption | The current caption of the WebProgressbar.
Public Property | Value | The current value of the WebProgressbar.
Top

See Also

Reference

WebProgressBarProgressIntervalEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBarProgressIntervalEventDataArgs Constructor

[image]
Intersoft WebEssentials Documentation
WebProgressBarProgressIntervalEventDataArgs Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarProgressIntervalEventDataArgs Class : WebProgressBarProgressIntervalEventDataArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebProgressBarProgressIntervalEventDataArgs()
C#
public WebProgressBarProgressIntervalEventDataArgs()
Delphi
public WebProgressBarProgressIntervalEventDataArgs();
JScript
public function WebProgressBarProgressIntervalEventDataArgs();
Managed Extensions for C++
public: WebProgressBarProgressIntervalEventDataArgs();
C++/CLI
public:
WebProgressBarProgressIntervalEventDataArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarProgressIntervalEventDataArgs Class
WebProgressBarProgressIntervalEventDataArgs Members


Caption Property

[image]
Intersoft WebEssentials Documentation
Caption Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarProgressIntervalEventDataArgs Class : Caption Property

Glossary Item Box

The current caption of the WebProgressbar.

Syntax

Visual Basic (Declaration)
Public Property Caption As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarProgressIntervalEventDataArgs
Dim value As System.String

instance.Caption = value

value = instance.Caption
C#
public System.string Caption {get; set;}
Delphi
public read-write property Caption: System.String;
JScript
public function get,set Caption : System.String
Managed Extensions for C++
public: __property System.string* get_Caption();
public: __property void set_Caption(
   System.string* value
);
C++/CLI
public:
property System.String^ Caption {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarProgressIntervalEventDataArgs Class
WebProgressBarProgressIntervalEventDataArgs Members


Value Property

[image]
Intersoft WebEssentials Documentation
Value Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarProgressIntervalEventDataArgs Class : Value Property

Glossary Item Box

The current value of the WebProgressbar.

Syntax

Visual Basic (Declaration)
Public Property Value As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarProgressIntervalEventDataArgs
Dim value As System.Integer

instance.Value = value

value = instance.Value
C#
public System.int Value {get; set;}
Delphi
public read-write property Value: System.Integer;
JScript
public function get,set Value : System.int
Managed Extensions for C++
public: __property System.int get_Value();
public: __property void set_Value(
   System.int value
);
C++/CLI
public:
property System.int Value {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarProgressIntervalEventDataArgs Class
WebProgressBarProgressIntervalEventDataArgs Members


WebProgressBarStartEventDataArgs Class

[image]
Intersoft WebEssentials Documentation
WebProgressBarStartEventDataArgs Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarStartEventDataArgs Class

Glossary Item Box

Represents the WebProgressBar start event argument.

Object Model

WebProgressBarStartEventDataArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebProgressBarStartEventDataArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarStartEventDataArgs
C#
public class WebProgressBarStartEventDataArgs : System.EventArgs
Delphi
public class WebProgressBarStartEventDataArgs = class(System.EventArgs)
JScript
public class WebProgressBarStartEventDataArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebProgressBarStartEventDataArgs : public System.EventArgs
C++/CLI
public ref class WebProgressBarStartEventDataArgs : public System.EventArgs

Remarks

This class contains property for the WebProgressBar start event argument.

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebEssentials.WebProgressBarStartEventDataArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarStartEventDataArgs Members
ISNet.WebUI.WebEssentials Namespace


WebProgressBarStartEventDataArgs Class Members

[image]
Intersoft WebEssentials Documentation
WebProgressBarStartEventDataArgs Class Members
See Also Properties Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarStartEventDataArgs Class

Glossary Item Box

The following tables list the members exposed by WebProgressBarStartEventDataArgs.

Public Constructors

 | Name | Description
Public Constructor | WebProgressBarStartEventDataArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Caption | The current caption of the WebProgressbar.
Public Property | StartTime | The start time of WebProgressbar progress in ticks.
Public Property | Value | The current value of the WebProgressbar.
Top

See Also

Reference

WebProgressBarStartEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBarStartEventDataArgs Class Properties

[image]
Intersoft WebEssentials Documentation
WebProgressBarStartEventDataArgs Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarStartEventDataArgs Class

Glossary Item Box

For a list of all members of this type, see WebProgressBarStartEventDataArgs members.

Public Properties

 | Name | Description
Public Property | Caption | The current caption of the WebProgressbar.
Public Property | StartTime | The start time of WebProgressbar progress in ticks.
Public Property | Value | The current value of the WebProgressbar.
Top

See Also

Reference

WebProgressBarStartEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBarStartEventDataArgs Constructor

[image]
Intersoft WebEssentials Documentation
WebProgressBarStartEventDataArgs Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarStartEventDataArgs Class : WebProgressBarStartEventDataArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebProgressBarStartEventDataArgs()
C#
public WebProgressBarStartEventDataArgs()
Delphi
public WebProgressBarStartEventDataArgs();
JScript
public function WebProgressBarStartEventDataArgs();
Managed Extensions for C++
public: WebProgressBarStartEventDataArgs();
C++/CLI
public:
WebProgressBarStartEventDataArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarStartEventDataArgs Class
WebProgressBarStartEventDataArgs Members


Caption Property

[image]
Intersoft WebEssentials Documentation
Caption Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarStartEventDataArgs Class : Caption Property

Glossary Item Box

The current caption of the WebProgressbar.

Syntax

Visual Basic (Declaration)
Public Property Caption As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarStartEventDataArgs
Dim value As System.String

instance.Caption = value

value = instance.Caption
C#
public System.string Caption {get; set;}
Delphi
public read-write property Caption: System.String;
JScript
public function get,set Caption : System.String
Managed Extensions for C++
public: __property System.string* get_Caption();
public: __property void set_Caption(
   System.string* value
);
C++/CLI
public:
property System.String^ Caption {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarStartEventDataArgs Class
WebProgressBarStartEventDataArgs Members


StartTime Property

[image]
Intersoft WebEssentials Documentation
StartTime Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarStartEventDataArgs Class : StartTime Property

Glossary Item Box

The start time of WebProgressbar progress in ticks.

Syntax

Visual Basic (Declaration)
Public Property StartTime As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarStartEventDataArgs
Dim value As System.Integer

instance.StartTime = value

value = instance.StartTime
C#
public System.int StartTime {get; set;}
Delphi
public read-write property StartTime: System.Integer;
JScript
public function get,set StartTime : System.int
Managed Extensions for C++
public: __property System.int get_StartTime();
public: __property void set_StartTime(
   System.int value
);
C++/CLI
public:
property System.int StartTime {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarStartEventDataArgs Class
WebProgressBarStartEventDataArgs Members


Value Property

[image]
Intersoft WebEssentials Documentation
Value Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarStartEventDataArgs Class : Value Property

Glossary Item Box

The current value of the WebProgressbar.

Syntax

Visual Basic (Declaration)
Public Property Value As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarStartEventDataArgs
Dim value As System.Integer

instance.Value = value

value = instance.Value
C#
public System.int Value {get; set;}
Delphi
public read-write property Value: System.Integer;
JScript
public function get,set Value : System.int
Managed Extensions for C++
public: __property System.int get_Value();
public: __property void set_Value(
   System.int value
);
C++/CLI
public:
property System.int Value {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarStartEventDataArgs Class
WebProgressBarStartEventDataArgs Members


WebProgressBarStyleMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebProgressBarStyleMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarStyleMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebProgressBarStyleMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarStyleMode
C#
public enum WebProgressBarStyleMode : System.Enum
Delphi
public enum WebProgressBarStyleMode = class(System.Enum)
JScript
public enum WebProgressBarStyleMode extends System.Enum
Managed Extensions for C++
__value public enum WebProgressBarStyleMode : public System.Enum
C++/CLI
public enum class WebProgressBarStyleMode : public System.Enum

Members

Member | Description
Default |
Office2007 |
Safari |
Win7 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebProgressBarStyleMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebProgressBarValueChangedEventDataArgs Class

[image]
Intersoft WebEssentials Documentation
WebProgressBarValueChangedEventDataArgs Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarValueChangedEventDataArgs Class

Glossary Item Box

Represents the WebProgressBar value changed event argument.

Object Model

WebProgressBarValueChangedEventDataArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebProgressBarValueChangedEventDataArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarValueChangedEventDataArgs
C#
public class WebProgressBarValueChangedEventDataArgs : System.EventArgs
Delphi
public class WebProgressBarValueChangedEventDataArgs = class(System.EventArgs)
JScript
public class WebProgressBarValueChangedEventDataArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebProgressBarValueChangedEventDataArgs : public System.EventArgs
C++/CLI
public ref class WebProgressBarValueChangedEventDataArgs : public System.EventArgs

Remarks

This class contains property for the WebProgressBar value changed event argument.

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebEssentials.WebProgressBarValueChangedEventDataArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarValueChangedEventDataArgs Members
ISNet.WebUI.WebEssentials Namespace


WebProgressBarValueChangedEventDataArgs Class Members

[image]
Intersoft WebEssentials Documentation
WebProgressBarValueChangedEventDataArgs Class Members
See Also Properties Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarValueChangedEventDataArgs Class

Glossary Item Box

The following tables list the members exposed by WebProgressBarValueChangedEventDataArgs.

Public Constructors

 | Name | Description
Public Constructor | WebProgressBarValueChangedEventDataArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Caption | The current caption of the WebProgressbar.
Public Property | Value | The current value of the WebProgressbar.
Top

See Also

Reference

WebProgressBarValueChangedEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBarValueChangedEventDataArgs Class Properties

[image]
Intersoft WebEssentials Documentation
WebProgressBarValueChangedEventDataArgs Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebProgressBarValueChangedEventDataArgs Class

Glossary Item Box

For a list of all members of this type, see WebProgressBarValueChangedEventDataArgs members.

Public Properties

 | Name | Description
Public Property | Caption | The current caption of the WebProgressbar.
Public Property | Value | The current value of the WebProgressbar.
Top

See Also

Reference

WebProgressBarValueChangedEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebProgressBarValueChangedEventDataArgs Constructor

[image]
Intersoft WebEssentials Documentation
WebProgressBarValueChangedEventDataArgs Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarValueChangedEventDataArgs Class : WebProgressBarValueChangedEventDataArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebProgressBarValueChangedEventDataArgs()
C#
public WebProgressBarValueChangedEventDataArgs()
Delphi
public WebProgressBarValueChangedEventDataArgs();
JScript
public function WebProgressBarValueChangedEventDataArgs();
Managed Extensions for C++
public: WebProgressBarValueChangedEventDataArgs();
C++/CLI
public:
WebProgressBarValueChangedEventDataArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarValueChangedEventDataArgs Class
WebProgressBarValueChangedEventDataArgs Members


Caption Property

[image]
Intersoft WebEssentials Documentation
Caption Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarValueChangedEventDataArgs Class : Caption Property

Glossary Item Box

The current caption of the WebProgressbar.

Syntax

Visual Basic (Declaration)
Public Property Caption As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarValueChangedEventDataArgs
Dim value As System.String

instance.Caption = value

value = instance.Caption
C#
public System.string Caption {get; set;}
Delphi
public read-write property Caption: System.String;
JScript
public function get,set Caption : System.String
Managed Extensions for C++
public: __property System.string* get_Caption();
public: __property void set_Caption(
   System.string* value
);
C++/CLI
public:
property System.String^ Caption {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarValueChangedEventDataArgs Class
WebProgressBarValueChangedEventDataArgs Members


Value Property

[image]
Intersoft WebEssentials Documentation
Value Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBarValueChangedEventDataArgs Class : Value Property

Glossary Item Box

The current value of the WebProgressbar.

Syntax

Visual Basic (Declaration)
Public Property Value As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBarValueChangedEventDataArgs
Dim value As System.Integer

instance.Value = value

value = instance.Value
C#
public System.int Value {get; set;}
Delphi
public read-write property Value: System.Integer;
JScript
public function get,set Value : System.int
Managed Extensions for C++
public: __property System.int get_Value();
public: __property void set_Value(
   System.int value
);
C++/CLI
public:
property System.int Value {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBarValueChangedEventDataArgs Class
WebProgressBarValueChangedEventDataArgs Members


WebProgressBar Constructor

[image]
Intersoft WebEssentials Documentation
WebProgressBar Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : WebProgressBar Constructor

Glossary Item Box

Overload List

Overload | Description
WebProgressBar Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


WebProgressBar Constructor

[image]
Intersoft WebEssentials Documentation
WebProgressBar Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : WebProgressBar Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebProgressBar()
C#
public WebProgressBar()
Delphi
public WebProgressBar();
JScript
public function WebProgressBar();
Managed Extensions for C++
public: WebProgressBar();
C++/CLI
public:
WebProgressBar();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


AccessKey Property

[image]
Intersoft WebEssentials Documentation
AccessKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set AccessKey : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


AllowDefaultStyleMerging Property

[image]
Intersoft WebEssentials Documentation
AllowDefaultStyleMerging Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : AllowDefaultStyleMerging Property

Glossary Item Box

Gets or sets the value that determines whether or not the default style can be merged with custom styles.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AllowDefaultStyleMerging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

instance.AllowDefaultStyleMerging = value

value = instance.AllowDefaultStyleMerging
C#
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool AllowDefaultStyleMerging {get; set;}
Delphi
public read-write property AllowDefaultStyleMerging: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AllowDefaultStyleMerging : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_AllowDefaultStyleMerging();
public: __property void set_AllowDefaultStyleMerging(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool AllowDefaultStyleMerging {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


AnimationLatency Property

[image]
Intersoft WebEssentials Documentation
AnimationLatency Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : AnimationLatency Property

Glossary Item Box

Gets or sets the Progress Bar animation refresh rate in ms. Apply in Indeterminate mode only.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar animation refresh rate in ms. Apply in Indeterminate mode only.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AnimationLatency As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Integer

instance.AnimationLatency = value

value = instance.AnimationLatency
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar animation refresh rate in ms. Apply in Indeterminate mode only.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int AnimationLatency {get; set;}
Delphi
public read-write property AnimationLatency: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar animation refresh rate in ms. Apply in Indeterminate mode only.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set AnimationLatency : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar animation refresh rate in ms. Apply in Indeterminate mode only.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_AnimationLatency();
public: __property void set_AnimationLatency(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar animation refresh rate in ms. Apply in Indeterminate mode only.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int AnimationLatency {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ApplyStyle Method

[image]
Intersoft WebEssentials Documentation
ApplyStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebEssentials Documentation
ApplyStyleSheetSkin Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


CanUseWebResources Method

[image]
Intersoft WebEssentials Documentation
CanUseWebResources Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.CanUseWebResources()
C#
public System.bool CanUseWebResources()
Delphi
public function CanUseWebResources(): System.Boolean;
JScript
public function CanUseWebResources() : System.boolean;
Managed Extensions for C++
public: System.bool CanUseWebResources();
C++/CLI
public:
System.bool CanUseWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Caption Property

[image]
Intersoft WebEssentials Documentation
Caption Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Caption Property

Glossary Item Box

Gets or sets the Progress Bar caption text.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar caption text.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Caption As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

instance.Caption = value

value = instance.Caption
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar caption text.")]
[System.ComponentModel.CategoryAttribute("General")]
public System.string Caption {get; set;}
Delphi
public read-write property Caption: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar caption text.")
System.ComponentModel.CategoryAttribute("General")
public function get,set Caption : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar caption text.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.string* get_Caption();
public: __property void set_Caption(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar caption text.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.String^ Caption {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


CaptionOrientation Property

[image]
Intersoft WebEssentials Documentation
CaptionOrientation Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : CaptionOrientation Property

Glossary Item Box

Gets or sets a value indicating whether the caption orientation of the control is Horizontal or Vertical.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar caption orientation mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CaptionOrientation As WebProgressBarOrientation
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As WebProgressBarOrientation

instance.CaptionOrientation = value

value = instance.CaptionOrientation
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar caption orientation mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public WebProgressBarOrientation CaptionOrientation {get; set;}
Delphi
public read-write property CaptionOrientation: WebProgressBarOrientation;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar caption orientation mode.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CaptionOrientation : WebProgressBarOrientation
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar caption orientation mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebProgressBarOrientation get_CaptionOrientation();
public: __property void set_CaptionOrientation(
   WebProgressBarOrientation value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar caption orientation mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebProgressBarOrientation CaptionOrientation {
   WebProgressBarOrientation get();
   void set (    WebProgressBarOrientation value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


CaptionStyle Property

[image]
Intersoft WebEssentials Documentation
CaptionStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : CaptionStyle Property

Glossary Item Box

Gets or sets the the style of the Progress Bar caption frame.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the caption text of the progress bar.")>
<System.ComponentModel.CategoryAttribute("Style")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property CaptionStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As ISNet.WebUI.WebStyle

instance.CaptionStyle = value

value = instance.CaptionStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the caption text of the progress bar.")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.WebStyle CaptionStyle {get; set;}
Delphi
public read-write property CaptionStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the caption text of the progress bar.")
System.ComponentModel.CategoryAttribute("Style")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set CaptionStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the caption text of the progress bar.")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.WebStyle* get_CaptionStyle();
public: __property void set_CaptionStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the caption text of the progress bar.")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.WebStyle^ CaptionStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ClientIDMode Property

[image]
Intersoft WebEssentials Documentation
ClientIDMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ClientSideEvents Property

[image]
Intersoft WebEssentials Documentation
ClientSideEvents Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ClientSideEvents Property

Glossary Item Box

Gets or sets client side events for WebProgressBar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DescriptionAttribute("Gets or sets client side events for WebProgressBar.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ClientSideEvents As WebProgressBarClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As WebProgressBarClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Gets or sets client side events for WebProgressBar.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebProgressBarClientSideEvents ClientSideEvents {get; set;}
Delphi
public read-write property ClientSideEvents: WebProgressBarClientSideEvents;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DescriptionAttribute("Gets or sets client side events for WebProgressBar.")
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ClientSideEvents : WebProgressBarClientSideEvents
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Gets or sets client side events for WebProgressBar.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebProgressBarClientSideEvents* get_ClientSideEvents();
public: __property void set_ClientSideEvents(
   WebProgressBarClientSideEvents* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Gets or sets client side events for WebProgressBar.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebProgressBarClientSideEvents^ ClientSideEvents {
   WebProgressBarClientSideEvents^ get();
   void set (    WebProgressBarClientSideEvents^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ControlDataTransferFormat Property

[image]
Intersoft WebEssentials Documentation
ControlDataTransferFormat Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


CopyBaseAttributes Method

[image]
Intersoft WebEssentials Documentation
CopyBaseAttributes Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members
Overload List


DataBind Method

[image]
Intersoft WebEssentials Documentation
DataBind Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


DataBind() Method

[image]
Intersoft WebEssentials Documentation
DataBind() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


DataBinding Event

[image]
Intersoft WebEssentials Documentation
DataBinding Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


DefaultStyleMode Property

[image]
Intersoft WebEssentials Documentation
DefaultStyleMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : DefaultStyleMode Property

Glossary Item Box

Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property DefaultStyleMode As WebProgressBarStyleMode
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As WebProgressBarStyleMode

instance.DefaultStyleMode = value

value = instance.DefaultStyleMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.CategoryAttribute("General")]
public WebProgressBarStyleMode DefaultStyleMode {get; set;}
Delphi
public read-write property DefaultStyleMode: WebProgressBarStyleMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")
System.ComponentModel.CategoryAttribute("General")
public function get,set DefaultStyleMode : WebProgressBarStyleMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property WebProgressBarStyleMode get_DefaultStyleMode();
public: __property void set_DefaultStyleMode(
   WebProgressBarStyleMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property WebProgressBarStyleMode DefaultStyleMode {
   WebProgressBarStyleMode get();
   void set (    WebProgressBarStyleMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Dispose Method

[image]
Intersoft WebEssentials Documentation
Dispose Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Disposed Event

[image]
Intersoft WebEssentials Documentation
Disposed Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


EnableManagedTheming Property

[image]
Intersoft WebEssentials Documentation
EnableManagedTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable Property EnableManagedTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableManagedTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.bool EnableManagedTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


EnableTheming Property

[image]
Intersoft WebEssentials Documentation
EnableTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


EnableViewState Property

[image]
Intersoft WebEssentials Documentation
EnableViewState Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


EnableWebResources Property

[image]
Intersoft WebEssentials Documentation
EnableWebResources Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Web Resources")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Web Resources")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


FindControl Method

[image]
Intersoft WebEssentials Documentation
FindControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


FindControl(String) Method

[image]
Intersoft WebEssentials Documentation
FindControl(String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Finished Event

[image]
Intersoft WebEssentials Documentation
Finished Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Finished Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Interaction")>
<System.ComponentModel.DescriptionAttribute("Fires on progress finished in WebProgressBar")>
Public Event Finished As WebProgressBarOnFinishedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim handler As WebProgressBarOnFinishedEventHandler

AddHandler instance.Finished, handler
C#
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires on progress finished in WebProgressBar")]
public event WebProgressBarOnFinishedEventHandler Finished
Delphi
public event Finished: WebProgressBarOnFinishedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires on progress finished in WebProgressBar")]
public: __event WebProgressBarOnFinishedEventHandler* Finished
C++/CLI
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires on progress finished in WebProgressBar")]
public:
event WebProgressBarOnFinishedEventHandler^ Finished

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


FlyPostBackSettings Property

[image]
Intersoft WebEssentials Documentation
FlyPostBackSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : FlyPostBackSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}
Delphi
public read-only property FlyPostBackSettings: ISNet.WebUI.FlyPostBackSettings;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get FlyPostBackSettings : ISNet.WebUI.FlyPostBackSettings
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.FlyPostBackSettings* get_FlyPostBackSettings();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.FlyPostBackSettings^ FlyPostBackSettings {
   ISNet.WebUI.FlyPostBackSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Focus Method

[image]
Intersoft WebEssentials Documentation
Focus Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ForceDisableXmlCompression Method

[image]
Intersoft WebEssentials Documentation
ForceDisableXmlCompression Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


FrameStyle Property

[image]
Intersoft WebEssentials Documentation
FrameStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : FrameStyle Property

Glossary Item Box

Gets or sets the the style of the Progress Bar frame.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the frame of the progress bar.")>
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the frame of the progress bar.")]
public ISNet.WebUI.WebStyle FrameStyle {get; set;}
Delphi
public read-write property FrameStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the frame of the progress bar.")
public function get,set FrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the frame of the progress bar.")]
public: __property ISNet.WebUI.WebStyle* get_FrameStyle();
public: __property void set_FrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the frame of the progress bar.")]
public:
property ISNet.WebUI.WebStyle^ FrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetClientAction Method

[image]
Intersoft WebEssentials Documentation
GetClientAction Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebEssentials Documentation
GetCurrentControlLifeCycle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetCurrentTheme Method

[image]
Intersoft WebEssentials Documentation
GetCurrentTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetFrameworkDataFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkDataFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

value = instance.GetFrameworkDataFolder()
C#
public System.string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): System.String;
JScript
public function GetFrameworkDataFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkDataFolder();
C++/CLI
public:
System.String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetFrameworkFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

value = instance.GetFrameworkFolder()
C#
public System.string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): System.String;
JScript
public function GetFrameworkFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkFolder();
C++/CLI
public:
System.String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetFrameworkVersion Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkVersion Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Version

value = instance.GetFrameworkVersion()
C#
public System.Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): System.Version;
JScript
public function GetFrameworkVersion() : System.Version;
Managed Extensions for C++
public: System.Version* GetFrameworkVersion();
C++/CLI
public:
System.Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetIntersoftFolder Method

[image]
Intersoft WebEssentials Documentation
GetIntersoftFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

value = instance.GetIntersoftFolder()
C#
public System.string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): System.String;
JScript
public function GetIntersoftFolder() : System.String;
Managed Extensions for C++
public: System.string* GetIntersoftFolder();
C++/CLI
public:
System.String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetLayoutFolder Method

[image]
Intersoft WebEssentials Documentation
GetLayoutFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

value = instance.GetLayoutFolder()
C#
public System.string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): System.String;
JScript
public function GetLayoutFolder() : System.String;
Managed Extensions for C++
public: System.string* GetLayoutFolder();
C++/CLI
public:
System.String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetPostedXMLData Method

[image]
Intersoft WebEssentials Documentation
GetPostedXMLData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

value = instance.GetPostedXMLData()
C#
public System.string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): System.String;
JScript
public function GetPostedXMLData() : System.String;
Managed Extensions for C++
public: System.string* GetPostedXMLData();
C++/CLI
public:
System.String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetProductInfoKey Method

[image]
Intersoft WebEssentials Documentation
GetProductInfoKey Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

value = instance.GetProductInfoKey()
C#
public System.string GetProductInfoKey()
Delphi
public function GetProductInfoKey(): System.String;
JScript
public function GetProductInfoKey() : System.String;
Managed Extensions for C++
public: System.string* GetProductInfoKey();
C++/CLI
public:
System.String^ GetProductInfoKey();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetProductSimpleName Method

[image]
Intersoft WebEssentials Documentation
GetProductSimpleName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

value = instance.GetProductSimpleName()
C#
public System.string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): System.String;
JScript
public function GetProductSimpleName() : System.String;
Managed Extensions for C++
public: System.string* GetProductSimpleName();
C++/CLI
public:
System.String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetPropertyValue Method

[image]
Intersoft WebEssentials Documentation
GetPropertyValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As System.String, _
   ByVal propValue As System.String, _
   ByVal webConfigKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim defValue As System.String
Dim propValue As System.String
Dim webConfigKey As System.String
Dim value As System.String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public System.string GetPropertyValue(
   System.string defValue,
   System.string propValue,
   System.string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: System.String;
    propValue: System.String;
    webConfigKey: System.String
): System.String;
JScript
public function GetPropertyValue(
   defValue : System.String,
   propValue : System.String,
   webConfigKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetPropertyValue(
   System.string* defValue,
   System.string* propValue,
   System.string* webConfigKey
)
C++/CLI
public:
System.String^ GetPropertyValue(
   System.String^ defValue,
   System.String^ propValue,
   System.String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetResourceStream Method

[image]
Intersoft WebEssentials Documentation
GetResourceStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As System.String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim resourceUrl As System.String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   System.string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: System.String
): System.IO.Stream;
JScript
public function GetResourceStream(
   resourceUrl : System.String
) : System.IO.Stream;
Managed Extensions for C++
public: System.IO.Stream* GetResourceStream(
   System.string* resourceUrl
)
C++/CLI
public:
System.IO.Stream^ GetResourceStream(
   System.String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetRouteUrl Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


GetRouteUrl(Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebEssentials Documentation
GetUniqueIDRelativeTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


HasControls Method

[image]
Intersoft WebEssentials Documentation
HasControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Height Property

[image]
Intersoft WebEssentials Documentation
Height Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overrides Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public override System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; override;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public override function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Web.UI.WebControls.Unit get_Height() override;
public: __property void set_Height(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ID Property

[image]
Intersoft WebEssentials Documentation
ID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ImagesDirectory Property

[image]
Intersoft WebEssentials Documentation
ImagesDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the images directory.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ImagesDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ImagesDirectory {get; set;}
Delphi
public read-write property ImagesDirectory: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set ImagesDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ImagesDirectory();
public: __property void set_ImagesDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ImagesDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Init Event

[image]
Intersoft WebEssentials Documentation
Init Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Interval Property

[image]
Intersoft WebEssentials Documentation
Interval Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Interval Property

Glossary Item Box

Gets or sets the Progress Bar interval value for ProgressInterval event handler.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the Progress Bar interval value for ProgressInterval event handler.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Interval As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Integer

instance.Interval = value

value = instance.Interval
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Progress Bar interval value for ProgressInterval event handler.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int Interval {get; set;}
Delphi
public read-write property Interval: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Gets or sets the Progress Bar interval value for ProgressInterval event handler.")
System.ComponentModel.DefaultValueAttribute()
public function get,set Interval : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Progress Bar interval value for ProgressInterval event handler.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_Interval();
public: __property void set_Interval(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Progress Bar interval value for ProgressInterval event handler.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int Interval {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


IsAtlasCallback Method

[image]
Intersoft WebEssentials Documentation
IsAtlasCallback Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.IsAtlasCallback()
C#
public System.bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): System.Boolean;
JScript
public function IsAtlasCallback() : System.boolean;
Managed Extensions for C++
public: System.bool IsAtlasCallback();
C++/CLI
public:
System.bool IsAtlasCallback();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


IsBetaRelease Method

[image]
Intersoft WebEssentials Documentation
IsBetaRelease Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.IsBetaRelease()
C#
public System.bool IsBetaRelease()
Delphi
public function IsBetaRelease(): System.Boolean;
JScript
public function IsBetaRelease() : System.boolean;
Managed Extensions for C++
public: System.bool IsBetaRelease();
C++/CLI
public:
System.bool IsBetaRelease();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


IsChromeBrowser Method

[image]
Intersoft WebEssentials Documentation
IsChromeBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.IsChromeBrowser()
C#
public System.bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): System.Boolean;
JScript
public function IsChromeBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsChromeBrowser();
C++/CLI
public:
System.bool IsChromeBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


IsFlyPostBackControl Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual System.bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): System.Boolean; virtual;
JScript
public function IsFlyPostBackControl() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackControl();
C++/CLI
public:
virtual System.bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


IsFlyPostBackRequest Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackRequest Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual System.bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): System.Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackRequest();
C++/CLI
public:
virtual System.bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebEssentials Documentation
IsGeckoBasedBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.IsGeckoBasedBrowser()
C#
public System.bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): System.Boolean;
JScript
public function IsGeckoBasedBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoBasedBrowser();
C++/CLI
public:
System.bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


IsGeckoVersion18 Method

[image]
Intersoft WebEssentials Documentation
IsGeckoVersion18 Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.IsGeckoVersion18()
C#
public System.bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): System.Boolean;
JScript
public function IsGeckoVersion18() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoVersion18();
C++/CLI
public:
System.bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


IsInDesignMode Method

[image]
Intersoft WebEssentials Documentation
IsInDesignMode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.IsInDesignMode()
C#
public System.bool IsInDesignMode()
Delphi
public function IsInDesignMode(): System.Boolean;
JScript
public function IsInDesignMode() : System.boolean;
Managed Extensions for C++
public: System.bool IsInDesignMode();
C++/CLI
public:
System.bool IsInDesignMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorer8Browser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.IsInternetExplorer8Browser()
C#
public System.bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): System.Boolean;
JScript
public function IsInternetExplorer8Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer8Browser();
C++/CLI
public:
System.bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorerBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.IsInternetExplorerBrowser()
C#
public System.bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): System.Boolean;
JScript
public function IsInternetExplorerBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorerBrowser();
C++/CLI
public:
System.bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


IsOperaBrowser Method

[image]
Intersoft WebEssentials Documentation
IsOperaBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.IsOperaBrowser()
C#
public System.bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): System.Boolean;
JScript
public function IsOperaBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsOperaBrowser();
C++/CLI
public:
System.bool IsOperaBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


IsSafariBrowser Method

[image]
Intersoft WebEssentials Documentation
IsSafariBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.IsSafariBrowser()
C#
public System.bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): System.Boolean;
JScript
public function IsSafariBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsSafariBrowser();
C++/CLI
public:
System.bool IsSafariBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


IsW3CStandardBrowser Method

[image]
Intersoft WebEssentials Documentation
IsW3CStandardBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.IsW3CStandardBrowser()
C#
public System.bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): System.Boolean;
JScript
public function IsW3CStandardBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsW3CStandardBrowser();
C++/CLI
public:
System.bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Load Event

[image]
Intersoft WebEssentials Documentation
Load Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


LoadLayout Method

[image]
Intersoft WebEssentials Documentation
LoadLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


LoadLayoutFromFile Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim filePath As System.String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   System.string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: System.String
); virtual;
JScript
public function LoadLayoutFromFile(
   filePath : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromFile(
   System.string* filePath
)
C++/CLI
public:
virtual void LoadLayoutFromFile(
   System.String^ filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromPredefinedName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim predefinedName As System.String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   System.string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: System.String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   System.string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   System.String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


LoadLayoutFromStream Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: System.IO.Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   System.IO.Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


LoadPostData Method

[image]
Intersoft WebEssentials Documentation
LoadPostData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function LoadPostData( _
   ByVal postDataKey As System.String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim postDataKey As System.String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As System.Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public virtual System.bool LoadPostData(
   System.string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)
Delphi
public function LoadPostData(
    postDataKey: System.String;
    postCollection: System.Collections.Specialized.NameValueCollection
): System.Boolean; virtual;
JScript
public function LoadPostData(
   postDataKey : System.String,
   postCollection : System.Collections.Specialized.NameValueCollection
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool LoadPostData(
   System.string* postDataKey,
   System.Collections.Specialized.NameValueCollection* postCollection
)
C++/CLI
public:
virtual System.bool LoadPostData(
   System.String^ postDataKey,
   System.Collections.Specialized.NameValueCollection^ postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


MaxSliderDimension Property

[image]
Intersoft WebEssentials Documentation
MaxSliderDimension Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : MaxSliderDimension Property

Glossary Item Box

Gets or sets the width of the slider when the progress bar is in Indeterminate mode.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the maximium dimension of the slider width during Indeterminate mode")>
Public Property MaxSliderDimension As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Web.UI.WebControls.Unit

instance.MaxSliderDimension = value

value = instance.MaxSliderDimension
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximium dimension of the slider width during Indeterminate mode")]
public System.Web.UI.WebControls.Unit MaxSliderDimension {get; set;}
Delphi
public read-write property MaxSliderDimension: System.Web.UI.WebControls.Unit;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Gets or sets the maximium dimension of the slider width during Indeterminate mode")
public function get,set MaxSliderDimension : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximium dimension of the slider width during Indeterminate mode")]
public: __property System.Web.UI.WebControls.Unit get_MaxSliderDimension();
public: __property void set_MaxSliderDimension(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximium dimension of the slider width during Indeterminate mode")]
public:
property System.Web.UI.WebControls.Unit MaxSliderDimension {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


MaxValue Property

[image]
Intersoft WebEssentials Documentation
MaxValue Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : MaxValue Property

Glossary Item Box

Gets or sets the Progress Bar maximum value.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar maximum value.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property MaxValue As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Integer

instance.MaxValue = value

value = instance.MaxValue
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar maximum value.")]
[System.ComponentModel.CategoryAttribute("General")]
public System.int MaxValue {get; set;}
Delphi
public read-write property MaxValue: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar maximum value.")
System.ComponentModel.CategoryAttribute("General")
public function get,set MaxValue : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar maximum value.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.int get_MaxValue();
public: __property void set_MaxValue(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar maximum value.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.int MaxValue {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


MergeStyle Method

[image]
Intersoft WebEssentials Documentation
MergeStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Mode Property

[image]
Intersoft WebEssentials Documentation
Mode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Mode Property

Glossary Item Box

Gets or sets a value indicating whether the progress bar mode is Determinate or Indeterminate.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar mode")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Mode As WebProgressBarMode
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As WebProgressBarMode

instance.Mode = value

value = instance.Mode
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar mode")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public WebProgressBarMode Mode {get; set;}
Delphi
public read-write property Mode: WebProgressBarMode;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar mode")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set Mode : WebProgressBarMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar mode")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebProgressBarMode get_Mode();
public: __property void set_Mode(
   WebProgressBarMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar mode")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebProgressBarMode Mode {
   WebProgressBarMode get();
   void set (    WebProgressBarMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


OnInfoChanged Method

[image]
Intersoft WebEssentials Documentation
OnInfoChanged Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


OnPreInitialize Method

[image]
Intersoft WebEssentials Documentation
OnPreInitialize Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Orientation Property

[image]
Intersoft WebEssentials Documentation
Orientation Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Orientation Property

Glossary Item Box

Gets or sets a value indicating whether the orientation of the control is Horizontal or Vertical.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar orientation mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Orientation As WebProgressBarOrientation
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As WebProgressBarOrientation

instance.Orientation = value

value = instance.Orientation
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar orientation mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public WebProgressBarOrientation Orientation {get; set;}
Delphi
public read-write property Orientation: WebProgressBarOrientation;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar orientation mode.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set Orientation : WebProgressBarOrientation
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar orientation mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebProgressBarOrientation get_Orientation();
public: __property void set_Orientation(
   WebProgressBarOrientation value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar orientation mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebProgressBarOrientation Orientation {
   WebProgressBarOrientation get();
   void set (    WebProgressBarOrientation value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Page Property

[image]
Intersoft WebEssentials Documentation
Page Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}
Delphi
public read-write property Page: System.Web.UI.Page; virtual;
JScript
public function get,set Page : System.Web.UI.Page
Managed Extensions for C++
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
C++/CLI
public:
virtual property System.Web.UI.Page^ Page {
   System.Web.UI.Page^ get();
   void set (    System.Web.UI.Page^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


PreInitialize Event

[image]
Intersoft WebEssentials Documentation
PreInitialize Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim handler As System.EventHandler

AddHandler instance.PreInitialize, handler
C#
public event System.EventHandler PreInitialize
Delphi
public event PreInitialize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* PreInitialize
C++/CLI
public:
event System.EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


PreRender Event

[image]
Intersoft WebEssentials Documentation
PreRender Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ProgressBarStyle Property

[image]
Intersoft WebEssentials Documentation
ProgressBarStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ProgressBarStyle Property

Glossary Item Box

Gets or sets the the style of the ProgressBar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the progress bar.")>
Public Property ProgressBarStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As ISNet.WebUI.WebStyle

instance.ProgressBarStyle = value

value = instance.ProgressBarStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the progress bar.")]
public ISNet.WebUI.WebStyle ProgressBarStyle {get; set;}
Delphi
public read-write property ProgressBarStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the progress bar.")
public function get,set ProgressBarStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the progress bar.")]
public: __property ISNet.WebUI.WebStyle* get_ProgressBarStyle();
public: __property void set_ProgressBarStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the progress bar.")]
public:
property ISNet.WebUI.WebStyle^ ProgressBarStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ProgressContainerBarStyle Property

[image]
Intersoft WebEssentials Documentation
ProgressContainerBarStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ProgressContainerBarStyle Property

Glossary Item Box

Gets or sets the the style of the ProgressBar background container bar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the background container bar of the progress bar.")>
Public Property ProgressContainerBarStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As ISNet.WebUI.WebStyle

instance.ProgressContainerBarStyle = value

value = instance.ProgressContainerBarStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the background container bar of the progress bar.")]
public ISNet.WebUI.WebStyle ProgressContainerBarStyle {get; set;}
Delphi
public read-write property ProgressContainerBarStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the background container bar of the progress bar.")
public function get,set ProgressContainerBarStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the background container bar of the progress bar.")]
public: __property ISNet.WebUI.WebStyle* get_ProgressContainerBarStyle();
public: __property void set_ProgressContainerBarStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the style applied to the background container bar of the progress bar.")]
public:
property ISNet.WebUI.WebStyle^ ProgressContainerBarStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ProgressInterval Event

[image]
Intersoft WebEssentials Documentation
ProgressInterval Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ProgressInterval Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires on a custom interval set in WebProgressBar")>
<System.ComponentModel.CategoryAttribute("Interaction")>
Public Event ProgressInterval As WebProgressBarOnProgressIntervalEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim handler As WebProgressBarOnProgressIntervalEventHandler

AddHandler instance.ProgressInterval, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires on a custom interval set in WebProgressBar")]
[System.ComponentModel.CategoryAttribute("Interaction")]
public event WebProgressBarOnProgressIntervalEventHandler ProgressInterval
Delphi
public event ProgressInterval: WebProgressBarOnProgressIntervalEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires on a custom interval set in WebProgressBar")]
[System.ComponentModel.CategoryAttribute("Interaction")]
public: __event WebProgressBarOnProgressIntervalEventHandler* ProgressInterval
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires on a custom interval set in WebProgressBar")]
[System.ComponentModel.CategoryAttribute("Interaction")]
public:
event WebProgressBarOnProgressIntervalEventHandler^ ProgressInterval

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RaisePostBackEvent Method

[image]
Intersoft WebEssentials Documentation
RaisePostBackEvent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim eventArgument As System.String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   System.string eventArgument
)
Delphi
public procedure RaisePostBackEvent(
    eventArgument: System.String
);
JScript
public function RaisePostBackEvent(
   eventArgument : System.String
);
Managed Extensions for C++
public: void RaisePostBackEvent(
   System.string* eventArgument
)
C++/CLI
public:
void RaisePostBackEvent(
   System.String^ eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebEssentials Documentation
RaisePostDataChangedEvent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); virtual;
JScript
public function RaisePostDataChangedEvent();
Managed Extensions for C++
public: virtual void RaisePostDataChangedEvent();
C++/CLI
public:
virtual void RaisePostDataChangedEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ReadWebConfigValue Method

[image]
Intersoft WebEssentials Documentation
ReadWebConfigValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim key As System.String
Dim value As System.String

value = instance.ReadWebConfigValue(key)
C#
public System.string ReadWebConfigValue(
   System.string key
)
Delphi
public function ReadWebConfigValue(
    key: System.String
): System.String;
JScript
public function ReadWebConfigValue(
   key : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ReadWebConfigValue(
   System.string* key
)
C++/CLI
public:
System.String^ ReadWebConfigValue(
   System.String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RecreateChildControls Method

[image]
Intersoft WebEssentials Documentation
RecreateChildControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar

instance.RecreateChildControls()
C#
public void RecreateChildControls()
Delphi
public procedure RecreateChildControls();
JScript
public function RecreateChildControls();
Managed Extensions for C++
public: void RecreateChildControls();
C++/CLI
public:
void RecreateChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RegisterBoxSizing Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RegisterBoxSizing() Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim forceAll As System.Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   System.bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: System.Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : System.boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   System.bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   System.bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebEssentials Documentation
RegisterGlobalStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RegisterLink Method

[image]
Intersoft WebEssentials Documentation
RegisterLink Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As System.String, _
   ByVal url As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim name As System.String
Dim url As System.String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   System.string name,
   System.string url
)
Delphi
public procedure RegisterLink(
    name: System.String;
    url: System.String
);
JScript
public function RegisterLink(
   name : System.String,
   url : System.String
);
Managed Extensions for C++
public: void RegisterLink(
   System.string* name,
   System.string* url
)
C++/CLI
public:
void RegisterLink(
   System.String^ name,
   System.String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebEssentials Documentation
RegisterOptimizedCssClasses Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim runtimeStyleOnly As System.Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: System.Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : System.boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RegisterPreloadImage Method

[image]
Intersoft WebEssentials Documentation
RegisterPreloadImage Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim image As System.String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   System.string image
)
Delphi
public procedure RegisterPreloadImage(
    image: System.String
);
JScript
public function RegisterPreloadImage(
   image : System.String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   System.string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   System.String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RegisterSharePointHandler Method

[image]
Intersoft WebEssentials Documentation
RegisterSharePointHandler Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RenderBeginTag Method

[image]
Intersoft WebEssentials Documentation
RenderBeginTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RenderControl Method

[image]
Intersoft WebEssentials Documentation
RenderControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebEssentials Documentation
RenderControl(HtmlTextWriter) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RenderEndTag Method

[image]
Intersoft WebEssentials Documentation
RenderEndTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RenderingMode Property

[image]
Intersoft WebEssentials Documentation
RenderingMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ResolveClientUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveClientUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ResolveImagePath Method

[image]
Intersoft WebEssentials Documentation
ResolveImagePath Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As System.String, _
   ByVal image As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim folder As System.String
Dim image As System.String
Dim value As System.String

value = instance.ResolveImagePath(folder, image)
C#
public System.string ResolveImagePath(
   System.string folder,
   System.string image
)
Delphi
public function ResolveImagePath(
    folder: System.String;
    image: System.String
): System.String;
JScript
public function ResolveImagePath(
   folder : System.String,
   image : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveImagePath(
   System.string* folder,
   System.string* image
)
C++/CLI
public:
System.String^ ResolveImagePath(
   System.String^ folder,
   System.String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ResolveRelativeURL Method

[image]
Intersoft WebEssentials Documentation
ResolveRelativeURL Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim url As System.String
Dim value As System.String

value = instance.ResolveRelativeURL(url)
C#
public virtual System.string ResolveRelativeURL(
   System.string url
)
Delphi
public function ResolveRelativeURL(
    url: System.String
): System.String; virtual;
JScript
public function ResolveRelativeURL(
   url : System.String
) : System.String;
Managed Extensions for C++
public: virtual System.string* ResolveRelativeURL(
   System.string* url
)
C++/CLI
public:
virtual System.String^ ResolveRelativeURL(
   System.String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ResolveResourceUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveResourceUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As System.String, _
   ByVal currentFolder As System.String, _
   ByVal resourceName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As System.String
Dim currentFolder As System.String
Dim resourceName As System.String
Dim value As System.String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public System.string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string defaultFolder,
   System.string currentFolder,
   System.string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: System.String;
    currentFolder: System.String;
    resourceName: System.String
): System.String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : System.String,
   currentFolder : System.String,
   resourceName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string* defaultFolder,
   System.string* currentFolder,
   System.string* resourceName
)
C++/CLI
public:
System.String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.String^ defaultFolder,
   System.String^ currentFolder,
   System.String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ResolveUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


RuntimeLicenseKey Property

[image]
Intersoft WebEssentials Documentation
RuntimeLicenseKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
Public Overridable Property RuntimeLicenseKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public virtual System.string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: System.String; virtual;
JScript
ISNet.PersistLayoutAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
public function get,set RuntimeLicenseKey : System.String
Managed Extensions for C++
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public: __property virtual System.string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   System.string* value
);
C++/CLI
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public:
virtual property System.String^ RuntimeLicenseKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


SaveLayout Method

[image]
Intersoft WebEssentials Documentation
SaveLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


SaveLayoutToFile Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim filePath As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   System.string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   System.string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   System.String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


SaveLayoutToStream Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
ScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overrides Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public override System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String; override;
JScript
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public override function get,set ScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.String^ ScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


SetRenderMethodDelegate Method

[image]
Intersoft WebEssentials Documentation
SetRenderMethodDelegate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


SetSessionTheme Method

[image]
Intersoft WebEssentials Documentation
SetSessionTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


SharedScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
SharedScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : SharedScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all shared scripts for Intersoft controls are stored.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property SharedScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all shared scripts for Intersoft controls are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: System.String; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all shared scripts for Intersoft controls are stored.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set SharedScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all shared scripts for Intersoft controls are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.string* get_SharedScriptDirectory();
public: __property virtual void set_SharedScriptDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all shared scripts for Intersoft controls are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.String^ SharedScriptDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ShouldReturnJson Method

[image]
Intersoft WebEssentials Documentation
ShouldReturnJson Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

value = instance.ShouldReturnJson()
C#
public virtual System.bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): System.Boolean; virtual;
JScript
public function ShouldReturnJson() : System.boolean;
Managed Extensions for C++
public: virtual System.bool ShouldReturnJson();
C++/CLI
public:
virtual System.bool ShouldReturnJson();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


SkinID Property

[image]
Intersoft WebEssentials Documentation
SkinID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Start Event

[image]
Intersoft WebEssentials Documentation
Start Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Start Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Interaction")>
<System.ComponentModel.DescriptionAttribute("Fires on a progress start in WebProgressBar")>
Public Event Start As WebProgressBarOnStartEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim handler As WebProgressBarOnStartEventHandler

AddHandler instance.Start, handler
C#
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires on a progress start in WebProgressBar")]
public event WebProgressBarOnStartEventHandler Start
Delphi
public event Start: WebProgressBarOnStartEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires on a progress start in WebProgressBar")]
public: __event WebProgressBarOnStartEventHandler* Start
C++/CLI
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires on a progress start in WebProgressBar")]
public:
event WebProgressBarOnStartEventHandler^ Start

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Step Property

[image]
Intersoft WebEssentials Documentation
Step Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Step Property

Glossary Item Box

Gets or sets the Progress Bar step increment. Apply in Indeterminate mode only.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar step increment. Apply in Indeterminate mode only.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Step As System.Double
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Double

instance.Step = value

value = instance.Step
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar step increment. Apply in Indeterminate mode only.")]
[System.ComponentModel.CategoryAttribute("General")]
public System.double Step {get; set;}
Delphi
public read-write property Step: System.Double;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar step increment. Apply in Indeterminate mode only.")
System.ComponentModel.CategoryAttribute("General")
public function get,set Step : System.double
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar step increment. Apply in Indeterminate mode only.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.double get_Step();
public: __property void set_Step(
   System.double value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar step increment. Apply in Indeterminate mode only.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.double Step {
   System.double get();
   void set (    System.double value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


TabIndex Property

[image]
Intersoft WebEssentials Documentation
TabIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set TabIndex : System.short
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ToolTip Property

[image]
Intersoft WebEssentials Documentation
ToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Unload Event

[image]
Intersoft WebEssentials Documentation
Unload Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


UseDefaultStyle Property

[image]
Intersoft WebEssentials Documentation
UseDefaultStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : UseDefaultStyle Property

Glossary Item Box

Determines whether or not WebProgressBar is using default style.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether or not WebProgressBar is using default style.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property UseDefaultStyle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

instance.UseDefaultStyle = value

value = instance.UseDefaultStyle
C#
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebProgressBar is using default style.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool UseDefaultStyle {get; set;}
Delphi
public read-write property UseDefaultStyle: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether or not WebProgressBar is using default style.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set UseDefaultStyle : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebProgressBar is using default style.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_UseDefaultStyle();
public: __property void set_UseDefaultStyle(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebProgressBar is using default style.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool UseDefaultStyle {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


UseRoundCorner Property

[image]
Intersoft WebEssentials Documentation
UseRoundCorner Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : UseRoundCorner Property

Glossary Item Box

Determines whether or not WebProgressBar is using rounder corner style.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether or not WebProgressBar is using rounded corner style.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property UseRoundCorner As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

instance.UseRoundCorner = value

value = instance.UseRoundCorner
C#
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebProgressBar is using rounded corner style.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool UseRoundCorner {get; set;}
Delphi
public read-write property UseRoundCorner: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether or not WebProgressBar is using rounded corner style.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set UseRoundCorner : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebProgressBar is using rounded corner style.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_UseRoundCorner();
public: __property void set_UseRoundCorner(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebProgressBar is using rounded corner style.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool UseRoundCorner {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ValidateRequestMode Property

[image]
Intersoft WebEssentials Documentation
ValidateRequestMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Value Property

[image]
Intersoft WebEssentials Documentation
Value Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Value Property

Glossary Item Box

Gets or sets the Progress Bar current value.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar current value.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Value As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Integer

instance.Value = value

value = instance.Value
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar current value.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.int Value {get; set;}
Delphi
public read-write property Value: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar current value.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Value : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar current value.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.int get_Value();
public: __property void set_Value(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the progress bar current value.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.int Value {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ValueChanged Event

[image]
Intersoft WebEssentials Documentation
ValueChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ValueChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires when WebProgressBar value is changed")>
<System.ComponentModel.CategoryAttribute("Interaction")>
Public Event ValueChanged As WebProgressBarOnValueChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim handler As WebProgressBarOnValueChangedEventHandler

AddHandler instance.ValueChanged, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires when WebProgressBar value is changed")]
[System.ComponentModel.CategoryAttribute("Interaction")]
public event WebProgressBarOnValueChangedEventHandler ValueChanged
Delphi
public event ValueChanged: WebProgressBarOnValueChangedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires when WebProgressBar value is changed")]
[System.ComponentModel.CategoryAttribute("Interaction")]
public: __event WebProgressBarOnValueChangedEventHandler* ValueChanged
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires when WebProgressBar value is changed")]
[System.ComponentModel.CategoryAttribute("Interaction")]
public:
event WebProgressBarOnValueChangedEventHandler^ ValueChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ViewStateItems Property

[image]
Intersoft WebEssentials Documentation
ViewStateItems Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ViewStateItems Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ViewStateMode Property

[image]
Intersoft WebEssentials Documentation
ViewStateMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ViewStateServerConnection Property

[image]
Intersoft WebEssentials Documentation
ViewStateServerConnection Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ViewStateServerConnection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ViewStateServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: System.String; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
System.ComponentModel.CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ViewStateServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ViewStateServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


ViewStateStorage Property

[image]
Intersoft WebEssentials Documentation
ViewStateStorage Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : ViewStateStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
System.ComponentModel.CategoryAttribute("View State Settings")
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


Width Property

[image]
Intersoft WebEssentials Documentation
Width Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Overrides Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public override System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; override;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public override function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.Web.UI.WebControls.Unit get_Width() override;
public: __property void set_Width(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


XmlCompressionEnabled Property

[image]
Intersoft WebEssentials Documentation
XmlCompressionEnabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebProgressBar Class : XmlCompressionEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property XmlCompressionEnabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebProgressBar
Dim value As System.Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: System.Boolean; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set XmlCompressionEnabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool XmlCompressionEnabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebProgressBar Class
WebProgressBar Members


WebRating Class

[image]
Intersoft WebEssentials Documentation
WebRating Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRating Class

Glossary Item Box

Intersoft WebRating.

Object Model

WebRating Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.ToolboxDataAttribute("<{0}:WebRating runat=server></{0}:WebRating>")>
<ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebRating.js", Type=XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebRatingDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.SerializableAttribute()>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebRating
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebRating
C#
[System.Web.UI.ToolboxDataAttribute("<{0}:WebRating runat=server></{0}:WebRating>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebRating.js", Type=XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebRatingDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebRating : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Delphi
public class WebRating = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings)
JScript
System.Web.UI.ToolboxDataAttribute("<{0}:WebRating runat=server></{0}:WebRating>")
ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebRating.js", Type=XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebRatingDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.SerializableAttribute()
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebRating extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Managed Extensions for C++
[System.Web.UI.ToolboxDataAttribute("<{0}:WebRating runat=server></{0}:WebRating>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebRating.js", Type=XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebRatingDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebRating : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
C++/CLI
[System.Web.UI.ToolboxDataAttribute("<{0}:WebRating runat=server></{0}:WebRating>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebRating.js", Type=XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebRatingDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebRating : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebEssentials.WebRating

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Members
ISNet.WebUI.WebEssentials Namespace


WebRating Class Events

[image]
Intersoft WebEssentials Documentation
WebRating Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRating Class

Glossary Item Box

For a list of all members of this type, see WebRating members.

Public Events

 | Name | Description
Public Event | Click | Fires when WebRating is clicked.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebRating Class
ISNet.WebUI.WebEssentials Namespace


WebRating Class Members

[image]
Intersoft WebEssentials Documentation
WebRating Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRating Class

Glossary Item Box

The following tables list the members exposed by WebRating.

Public Constructors

 | Name | Description
Public Constructor | WebRating Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebRating.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings |
Public Property | FrameStyle | Contains interactive style for Frame.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | ImagesSettings | Provides the settings that control the images in WebRating.
Public Property | IsReversed | Determines whether or not the moving of WebRating should be reversed.
Public Property | ItemCount | Specifies the item count of WebRating.
Public Property | MaximumValue | Specifies the maximum value of WebRating.
Public Property | MinimumValue | Specifies the minimal value of WebRating.
Public Property | Orientation | Specifies WebRating orientation.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PostbackMode | Specifies WebRating postback mode.
Public Property | Precision | Specifies WebRating precision.
Public Property | ReadOnly | Determines whether or not WebRating is in readonly mode.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | Overridden.
Public Property | UseCustomImages | Gets or sets the value that determines whether or not WebRating use images that specified by user.
Public Property | UseDefaultStyle | Determines whether or not WebRating is using default style.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | Value | Specifies the value of WebRating.
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetImageName |
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | Click | Fires when WebRating is clicked.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebRating Class
ISNet.WebUI.WebEssentials Namespace


WebRating Class Methods

[image]
Intersoft WebEssentials Documentation
WebRating Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRating Class

Glossary Item Box

For a list of all members of this type, see WebRating members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetImageName |
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebRating Class
ISNet.WebUI.WebEssentials Namespace


WebRating Class Properties

[image]
Intersoft WebEssentials Documentation
WebRating Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRating Class

Glossary Item Box

For a list of all members of this type, see WebRating members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebRating.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings |
Public Property | FrameStyle | Contains interactive style for Frame.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | ImagesSettings | Provides the settings that control the images in WebRating.
Public Property | IsReversed | Determines whether or not the moving of WebRating should be reversed.
Public Property | ItemCount | Specifies the item count of WebRating.
Public Property | MaximumValue | Specifies the maximum value of WebRating.
Public Property | MinimumValue | Specifies the minimal value of WebRating.
Public Property | Orientation | Specifies WebRating orientation.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PostbackMode | Specifies WebRating postback mode.
Public Property | Precision | Specifies WebRating precision.
Public Property | ReadOnly | Determines whether or not WebRating is in readonly mode.
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ToolTip | Overridden.
Public Property | UseCustomImages | Gets or sets the value that determines whether or not WebRating use images that specified by user.
Public Property | UseDefaultStyle | Determines whether or not WebRating is using default style.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | Value | Specifies the value of WebRating.
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebRating Class
ISNet.WebUI.WebEssentials Namespace


WebRatingClientSideEvents Class

[image]
Intersoft WebEssentials Documentation
WebRatingClientSideEvents Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingClientSideEvents Class

Glossary Item Box

A collection of WebRating's client side events.

Object Model

WebRatingClientSideEvents Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebRatingClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebRatingClientSideEvents
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebRatingClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebRatingClientSideEvents = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebRatingClientSideEvents extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebRatingClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebRatingClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebRatingClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Members
ISNet.WebUI.WebEssentials Namespace


WebRatingClientSideEvents Class Members

[image]
Intersoft WebEssentials Documentation
WebRatingClientSideEvents Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebRatingClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebRatingClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnClick | Gets or sets the event handler when click is triggered on WebRating.
Public Property | OnInitialize | Gets or sets the event handler that will be invoked when WebRating is initialized.
Public Property | OnResponse | Gets or sets the event handler on response.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebRatingClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebRatingClientSideEvents Class Methods

[image]
Intersoft WebEssentials Documentation
WebRatingClientSideEvents Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebRatingClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebRatingClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebRatingClientSideEvents Class Properties

[image]
Intersoft WebEssentials Documentation
WebRatingClientSideEvents Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebRatingClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnClick | Gets or sets the event handler when click is triggered on WebRating.
Public Property | OnInitialize | Gets or sets the event handler that will be invoked when WebRating is initialized.
Public Property | OnResponse | Gets or sets the event handler on response.
Top

See Also

Reference

WebRatingClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebRatingClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebRatingClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class : WebRatingClientSideEvents Constructor

Glossary Item Box

Overload List

Overload | Description
WebRatingClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members


WebRatingClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebRatingClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class : WebRatingClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebRatingClientSideEvents()
C#
public WebRatingClientSideEvents()
Delphi
public WebRatingClientSideEvents();
JScript
public function WebRatingClientSideEvents();
Managed Extensions for C++
public: WebRatingClientSideEvents();
C++/CLI
public:
WebRatingClientSideEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebRatingClientSideEvents
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRatingClientSideEvents
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRatingClientSideEvents
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRatingClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebRatingClientSideEvents
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRatingClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRatingClientSideEvents
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members


OnClick Property

[image]
Intersoft WebEssentials Documentation
OnClick Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class : OnClick Property

Glossary Item Box

Gets or sets the event handler when click is triggered on WebRating.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, newValue")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when click is triggered on WebRating.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnClick As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRatingClientSideEvents
Dim value As System.String

instance.OnClick = value

value = instance.OnClick
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, newValue")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when click is triggered on WebRating.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnClick {get; set;}
Delphi
public read-write property OnClick: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, newValue")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when click is triggered on WebRating.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnClick : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, newValue")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when click is triggered on WebRating.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnClick();
public: __property void set_OnClick(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, newValue")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when click is triggered on WebRating.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnClick {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebEssentials Documentation
OnInitialize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class : OnInitialize Property

Glossary Item Box

Gets or sets the event handler that will be invoked when WebRating is initialized.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebRating is initialized.")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRatingClientSideEvents
Dim value As System.String

instance.OnInitialize = value

value = instance.OnInitialize
C#
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebRating is initialized.")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnInitialize {get; set;}
Delphi
public read-write property OnInitialize: System.String;
JScript
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebRating is initialized.")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnInitialize : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebRating is initialized.")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnInitialize();
public: __property void set_OnInitialize(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebRating is initialized.")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members


OnResponse Property

[image]
Intersoft WebEssentials Documentation
OnResponse Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class : OnResponse Property

Glossary Item Box

Gets or sets the event handler on response.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, action")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnResponse As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRatingClientSideEvents
Dim value As System.String

instance.OnResponse = value

value = instance.OnResponse
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, action")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnResponse {get; set;}
Delphi
public read-write property OnResponse: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, action")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnResponse : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, action")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnResponse();
public: __property void set_OnResponse(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, action")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnResponse {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebRatingClientSideEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRatingClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRatingClientSideEvents
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingClientSideEvents Class
WebRatingClientSideEvents Members


WebRatingDefaultStyleMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebRatingDefaultStyleMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingDefaultStyleMode Enumeration

Glossary Item Box

Specifies DefaultStyle mode in WebRating.

Syntax

Visual Basic (Declaration)
Public Enum WebRatingDefaultStyleMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebRatingDefaultStyleMode
C#
public enum WebRatingDefaultStyleMode : System.Enum
Delphi
public enum WebRatingDefaultStyleMode = class(System.Enum)
JScript
public enum WebRatingDefaultStyleMode extends System.Enum
Managed Extensions for C++
__value public enum WebRatingDefaultStyleMode : public System.Enum
C++/CLI
public enum class WebRatingDefaultStyleMode : public System.Enum

Members

Member | Description
Black |
CrystalRed |
Default |
ElegantBlue |
Win7 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebRatingDefaultStyleMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebRatingEventDataArgs Class

[image]
Intersoft WebEssentials Documentation
WebRatingEventDataArgs Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingEventDataArgs Class

Glossary Item Box

Provides data for OnClick event.

Object Model

WebRatingEventDataArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebRatingEventDataArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebRatingEventDataArgs
C#
public class WebRatingEventDataArgs : System.EventArgs
Delphi
public class WebRatingEventDataArgs = class(System.EventArgs)
JScript
public class WebRatingEventDataArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebRatingEventDataArgs : public System.EventArgs
C++/CLI
public ref class WebRatingEventDataArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebEssentials.WebRatingEventDataArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingEventDataArgs Members
ISNet.WebUI.WebEssentials Namespace


WebRatingEventDataArgs Class Members

[image]
Intersoft WebEssentials Documentation
WebRatingEventDataArgs Class Members
See Also Properties Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingEventDataArgs Class

Glossary Item Box

The following tables list the members exposed by WebRatingEventDataArgs.

Public Constructors

 | Name | Description
Public Constructor | WebRatingEventDataArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Value |
Top

See Also

Reference

WebRatingEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebRatingEventDataArgs Class Properties

[image]
Intersoft WebEssentials Documentation
WebRatingEventDataArgs Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingEventDataArgs Class

Glossary Item Box

For a list of all members of this type, see WebRatingEventDataArgs members.

Public Properties

 | Name | Description
Public Property | Value |
Top

See Also

Reference

WebRatingEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebRatingEventDataArgs Constructor

[image]
Intersoft WebEssentials Documentation
WebRatingEventDataArgs Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingEventDataArgs Class : WebRatingEventDataArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebRatingEventDataArgs()
C#
public WebRatingEventDataArgs()
Delphi
public WebRatingEventDataArgs();
JScript
public function WebRatingEventDataArgs();
Managed Extensions for C++
public: WebRatingEventDataArgs();
C++/CLI
public:
WebRatingEventDataArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingEventDataArgs Class
WebRatingEventDataArgs Members


Value Property

[image]
Intersoft WebEssentials Documentation
Value Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingEventDataArgs Class : Value Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Value As System.Double
Visual Basic (Usage) Copy Code
Dim instance As WebRatingEventDataArgs
Dim value As System.Double

instance.Value = value

value = instance.Value
C#
public System.double Value {get; set;}
Delphi
public read-write property Value: System.Double;
JScript
public function get,set Value : System.double
Managed Extensions for C++
public: __property System.double get_Value();
public: __property void set_Value(
   System.double value
);
C++/CLI
public:
property System.double Value {
   System.double get();
   void set (    System.double value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingEventDataArgs Class
WebRatingEventDataArgs Members


WebRatingImagesSettings Class

[image]
Intersoft WebEssentials Documentation
WebRatingImagesSettings Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingImagesSettings Class

Glossary Item Box

A collection of WebRating's images settings.

Object Model

WebRatingImagesSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebRatingImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebRatingImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebRatingImagesSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebRatingImagesSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebRatingImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebRatingImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebRatingImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Members
ISNet.WebUI.WebEssentials Namespace


WebRatingImagesSettings Class Members

[image]
Intersoft WebEssentials Documentation
WebRatingImagesSettings Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebRatingImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebRatingImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Border |
Public Property | Empty |
Public Property | Full |
Public Property | Normal |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebRatingImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebRatingImagesSettings Class Methods

[image]
Intersoft WebEssentials Documentation
WebRatingImagesSettings Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebRatingImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebRatingImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebRatingImagesSettings Class Properties

[image]
Intersoft WebEssentials Documentation
WebRatingImagesSettings Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebRatingImagesSettings members.

Public Properties

 | Name | Description
Public Property | Border |
Public Property | Empty |
Public Property | Full |
Public Property | Normal |
Top

See Also

Reference

WebRatingImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebRatingImagesSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebRatingImagesSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : WebRatingImagesSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebRatingImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


WebRatingImagesSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebRatingImagesSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : WebRatingImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebRatingImagesSettings()
C#
public WebRatingImagesSettings()
Delphi
public WebRatingImagesSettings();
JScript
public function WebRatingImagesSettings();
Managed Extensions for C++
public: WebRatingImagesSettings();
C++/CLI
public:
WebRatingImagesSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


Border Property

[image]
Intersoft WebEssentials Documentation
Border Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : Border Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the border image of WebSlider rating.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Border As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings
Dim value As System.String

instance.Border = value

value = instance.Border
C#
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the border image of WebSlider rating.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Border {get; set;}
Delphi
public read-write property Border: System.String;
JScript
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DefaultValueAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DescriptionAttribute("Sets the border image of WebSlider rating.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Border : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the border image of WebSlider rating.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Border();
public: __property void set_Border(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the border image of WebSlider rating.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Border {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


Empty Property

[image]
Intersoft WebEssentials Documentation
Empty Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : Empty Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the empty image of WebSlider rating.")>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Empty As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings
Dim value As System.String

instance.Empty = value

value = instance.Empty
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the empty image of WebSlider rating.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Empty {get; set;}
Delphi
public read-write property Empty: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Sets the empty image of WebSlider rating.")
ISNet.MarkAsStyleAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DefaultValueAttribute()
public function get,set Empty : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the empty image of WebSlider rating.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Empty();
public: __property void set_Empty(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the empty image of WebSlider rating.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Empty {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


Full Property

[image]
Intersoft WebEssentials Documentation
Full Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : Full Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the full image of WebSlider rating.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Full As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings
Dim value As System.String

instance.Full = value

value = instance.Full
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the full image of WebSlider rating.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Full {get; set;}
Delphi
public read-write property Full: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Sets the full image of WebSlider rating.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Full : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the full image of WebSlider rating.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Full();
public: __property void set_Full(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the full image of WebSlider rating.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Full {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


Normal Property

[image]
Intersoft WebEssentials Documentation
Normal Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : Normal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the normal image of WebSlider rating.")>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
Public Property Normal As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings
Dim value As System.String

instance.Normal = value

value = instance.Normal
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the normal image of WebSlider rating.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
public System.string Normal {get; set;}
Delphi
public read-write property Normal: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DescriptionAttribute("Sets the normal image of WebSlider rating.")
System.ComponentModel.CategoryAttribute("ImagesSettings")
public function get,set Normal : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the normal image of WebSlider rating.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
public: __property System.string* get_Normal();
public: __property void set_Normal(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the normal image of WebSlider rating.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
public:
property System.String^ Normal {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRatingImagesSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingImagesSettings Class
WebRatingImagesSettings Members


WebRatingOnClickEventHandler Delegate

[image]
Intersoft WebEssentials Documentation
WebRatingOnClickEventHandler Delegate
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingOnClickEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the OnClick event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebRatingOnClickEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebRatingEventDataArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebRatingOnClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebRatingOnClickEventHandler(
   System.object sender,
   WebRatingEventDataArgs e
)
Delphi
public delegate WebRatingOnClickEventHandler(
    sender: System.TObject;
    e: WebRatingEventDataArgs
);
JScript
public delegate WebRatingOnClickEventHandler(
   sender : System.Object,
   e : WebRatingEventDataArgs
)
Managed Extensions for C++
public: __gc __delegate void WebRatingOnClickEventHandler(
   System.Object* sender,
   WebRatingEventDataArgs* e
)
C++/CLI
public delegate void WebRatingOnClickEventHandler(
   System.Object^ sender,
   WebRatingEventDataArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingOnClickEventHandler Members
ISNet.WebUI.WebEssentials Namespace


WebRatingOrientation Enumeration

[image]
Intersoft WebEssentials Documentation
WebRatingOrientation Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingOrientation Enumeration

Glossary Item Box

Specifies WebRating orientation.

Syntax

Visual Basic (Declaration)
Public Enum WebRatingOrientation
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebRatingOrientation
C#
public enum WebRatingOrientation : System.Enum
Delphi
public enum WebRatingOrientation = class(System.Enum)
JScript
public enum WebRatingOrientation extends System.Enum
Managed Extensions for C++
__value public enum WebRatingOrientation : public System.Enum
C++/CLI
public enum class WebRatingOrientation : public System.Enum

Members

Member | Description
Horizontal |
Vertical |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebRatingOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebRatingPostBack Enumeration

[image]
Intersoft WebEssentials Documentation
WebRatingPostBack Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingPostBack Enumeration

Glossary Item Box

Specifies WebRating postback mode.

Syntax

Visual Basic (Declaration)
Public Enum WebRatingPostBack
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebRatingPostBack
C#
public enum WebRatingPostBack : System.Enum
Delphi
public enum WebRatingPostBack = class(System.Enum)
JScript
public enum WebRatingPostBack extends System.Enum
Managed Extensions for C++
__value public enum WebRatingPostBack : public System.Enum
C++/CLI
public enum class WebRatingPostBack : public System.Enum

Members

Member | Description
FlyPostback |
FullPostback |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebRatingPostBack

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebRatingPrecision Enumeration

[image]
Intersoft WebEssentials Documentation
WebRatingPrecision Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingPrecision Enumeration

Glossary Item Box

Specifies WebRating precision.

Syntax

Visual Basic (Declaration)
Public Enum WebRatingPrecision
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebRatingPrecision
C#
public enum WebRatingPrecision : System.Enum
Delphi
public enum WebRatingPrecision = class(System.Enum)
JScript
public enum WebRatingPrecision extends System.Enum
Managed Extensions for C++
__value public enum WebRatingPrecision : public System.Enum
C++/CLI
public enum class WebRatingPrecision : public System.Enum

Members

Member | Description
ExactPosition |
Half |
Whole |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebRatingPrecision

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebRatingPresets Class

[image]
Intersoft WebEssentials Documentation
WebRatingPresets Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingPresets Class

Glossary Item Box

Object Model

WebRatingPresets Class

Syntax

Visual Basic (Declaration)
Public Class WebRatingPresets
Visual Basic (Usage) Copy Code
Dim instance As WebRatingPresets
C#
public class WebRatingPresets
Delphi
public class WebRatingPresets
JScript
public class WebRatingPresets
Managed Extensions for C++
public __gc class WebRatingPresets
C++/CLI
public ref class WebRatingPresets

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebEssentials.WebRatingPresets

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingPresets Members
ISNet.WebUI.WebEssentials Namespace


WebRatingPresets Class Members

[image]
Intersoft WebEssentials Documentation
WebRatingPresets Class Members
See Also Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingPresets Class

Glossary Item Box

The following tables list the members exposed by WebRatingPresets.

Public Constructors

 | Name | Description
Public Constructor | WebRatingPresets Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

WebRatingPresets Class
ISNet.WebUI.WebEssentials Namespace


WebRatingPresets Class Methods

[image]
Intersoft WebEssentials Documentation
WebRatingPresets Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebRatingPresets Class

Glossary Item Box

For a list of all members of this type, see WebRatingPresets members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

WebRatingPresets Class
ISNet.WebUI.WebEssentials Namespace


WebRatingPresets Constructor

[image]
Intersoft WebEssentials Documentation
WebRatingPresets Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingPresets Class : WebRatingPresets Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebRatingPresets()
C#
public WebRatingPresets()
Delphi
public WebRatingPresets();
JScript
public function WebRatingPresets();
Managed Extensions for C++
public: WebRatingPresets();
C++/CLI
public:
WebRatingPresets();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingPresets Class
WebRatingPresets Members


GetDefaultStyle Method

[image]
Intersoft WebEssentials Documentation
GetDefaultStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingPresets Class : GetDefaultStyle Method

Glossary Item Box

Overload List

Overload | Description
GetDefaultStyle |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingPresets Class
WebRatingPresets Members


GetDefaultStyle(WebRatingDefaultStyleMode,String) Method

[image]
Intersoft WebEssentials Documentation
GetDefaultStyle(WebRatingDefaultStyleMode,String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRatingPresets Class : GetDefaultStyle(WebRatingDefaultStyleMode,String) Method

mode
styleName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetDefaultStyle( _
   ByVal mode As WebRatingDefaultStyleMode, _
   ByVal styleName As System.String _
) As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim mode As WebRatingDefaultStyleMode
Dim styleName As System.String
Dim value As ISNet.WebUI.WebStyle

value = WebRatingPresets.GetDefaultStyle(mode, styleName)
C#
public static ISNet.WebUI.WebStyle GetDefaultStyle(
   WebRatingDefaultStyleMode mode,
   System.string styleName
)
Delphi
public function GetDefaultStyle(
    mode: WebRatingDefaultStyleMode;
    styleName: System.String
): ISNet.WebUI.WebStyle; static;
JScript
public static function GetDefaultStyle(
   mode : WebRatingDefaultStyleMode,
   styleName : System.String
) : ISNet.WebUI.WebStyle;
Managed Extensions for C++
public: static ISNet.WebUI.WebStyle* GetDefaultStyle(
   WebRatingDefaultStyleMode mode,
   System.string* styleName
)
C++/CLI
public:
static ISNet.WebUI.WebStyle^ GetDefaultStyle(
   WebRatingDefaultStyleMode mode,
   System.String^ styleName
)

Parameters

mode
styleName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRatingPresets Class
WebRatingPresets Members


WebRating Constructor

[image]
Intersoft WebEssentials Documentation
WebRating Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : WebRating Constructor

Glossary Item Box

Overload List

Overload | Description
WebRating Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


WebRating Constructor

[image]
Intersoft WebEssentials Documentation
WebRating Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : WebRating Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebRating()
C#
public WebRating()
Delphi
public WebRating();
JScript
public function WebRating();
Managed Extensions for C++
public: WebRating();
C++/CLI
public:
WebRating();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


AccessKey Property

[image]
Intersoft WebEssentials Documentation
AccessKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set AccessKey : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


AllowDefaultStyleMerging Property

[image]
Intersoft WebEssentials Documentation
AllowDefaultStyleMerging Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : AllowDefaultStyleMerging Property

Glossary Item Box

Gets or sets the value that determines whether or not the default style can be merged with custom styles.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property AllowDefaultStyleMerging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

instance.AllowDefaultStyleMerging = value

value = instance.AllowDefaultStyleMerging
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[System.ComponentModel.CategoryAttribute("General")]
public System.bool AllowDefaultStyleMerging {get; set;}
Delphi
public read-write property AllowDefaultStyleMerging: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")
System.ComponentModel.CategoryAttribute("General")
public function get,set AllowDefaultStyleMerging : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.bool get_AllowDefaultStyleMerging();
public: __property void set_AllowDefaultStyleMerging(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.bool AllowDefaultStyleMerging {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ApplyStyle Method

[image]
Intersoft WebEssentials Documentation
ApplyStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebEssentials Documentation
ApplyStyleSheetSkin Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


CanUseWebResources Method

[image]
Intersoft WebEssentials Documentation
CanUseWebResources Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.CanUseWebResources()
C#
public System.bool CanUseWebResources()
Delphi
public function CanUseWebResources(): System.Boolean;
JScript
public function CanUseWebResources() : System.boolean;
Managed Extensions for C++
public: System.bool CanUseWebResources();
C++/CLI
public:
System.bool CanUseWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


CheckConstrains Method

[image]
Intersoft WebEssentials Documentation
CheckConstrains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebRating

instance.CheckConstrains()
C#
public override void CheckConstrains()
Delphi
public procedure CheckConstrains(); override;
JScript
public override function CheckConstrains();
Managed Extensions for C++
public: void CheckConstrains(); override
C++/CLI
public:
void CheckConstrains(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Click Event

[image]
Intersoft WebEssentials Documentation
Click Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Click Event

Glossary Item Box

Fires when WebRating is clicked.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Interaction")>
<System.ComponentModel.DescriptionAttribute("Fires when WebRating is clicked")>
Public Event Click As WebRatingOnClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim handler As WebRatingOnClickEventHandler

AddHandler instance.Click, handler
C#
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebRating is clicked")]
public event WebRatingOnClickEventHandler Click
Delphi
public event Click: WebRatingOnClickEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebRating is clicked")]
public: __event WebRatingOnClickEventHandler* Click
C++/CLI
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebRating is clicked")]
public:
event WebRatingOnClickEventHandler^ Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ClientIDMode Property

[image]
Intersoft WebEssentials Documentation
ClientIDMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ClientSideEvents Property

[image]
Intersoft WebEssentials Documentation
ClientSideEvents Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ClientSideEvents Property

Glossary Item Box

Contains client side events supported by WebRating.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebRating.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ClientSideEvents As WebRatingClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As WebRatingClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebRating.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebRatingClientSideEvents ClientSideEvents {get; set;}
Delphi
public read-write property ClientSideEvents: WebRatingClientSideEvents;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebRating.")
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ClientSideEvents : WebRatingClientSideEvents
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebRating.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebRatingClientSideEvents* get_ClientSideEvents();
public: __property void set_ClientSideEvents(
   WebRatingClientSideEvents* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebRating.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebRatingClientSideEvents^ ClientSideEvents {
   WebRatingClientSideEvents^ get();
   void set (    WebRatingClientSideEvents^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ControlDataTransferFormat Property

[image]
Intersoft WebEssentials Documentation
ControlDataTransferFormat Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


CopyBaseAttributes Method

[image]
Intersoft WebEssentials Documentation
CopyBaseAttributes Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members
Overload List


DataBind Method

[image]
Intersoft WebEssentials Documentation
DataBind Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


DataBind() Method

[image]
Intersoft WebEssentials Documentation
DataBind() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebRating

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


DataBinding Event

[image]
Intersoft WebEssentials Documentation
DataBinding Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


DefaultStyleMode Property

[image]
Intersoft WebEssentials Documentation
DefaultStyleMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : DefaultStyleMode Property

Glossary Item Box

Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property DefaultStyleMode As WebRatingDefaultStyleMode
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As WebRatingDefaultStyleMode

instance.DefaultStyleMode = value

value = instance.DefaultStyleMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.CategoryAttribute("General")]
public WebRatingDefaultStyleMode DefaultStyleMode {get; set;}
Delphi
public read-write property DefaultStyleMode: WebRatingDefaultStyleMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")
System.ComponentModel.CategoryAttribute("General")
public function get,set DefaultStyleMode : WebRatingDefaultStyleMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property WebRatingDefaultStyleMode get_DefaultStyleMode();
public: __property void set_DefaultStyleMode(
   WebRatingDefaultStyleMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property WebRatingDefaultStyleMode DefaultStyleMode {
   WebRatingDefaultStyleMode get();
   void set (    WebRatingDefaultStyleMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Dispose Method

[image]
Intersoft WebEssentials Documentation
Dispose Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebRating

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Disposed Event

[image]
Intersoft WebEssentials Documentation
Disposed Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


EnableManagedTheming Property

[image]
Intersoft WebEssentials Documentation
EnableManagedTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable Property EnableManagedTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableManagedTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.bool EnableManagedTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


EnableTheming Property

[image]
Intersoft WebEssentials Documentation
EnableTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


EnableViewState Property

[image]
Intersoft WebEssentials Documentation
EnableViewState Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


EnableWebResources Property

[image]
Intersoft WebEssentials Documentation
EnableWebResources Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Web Resources")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Web Resources")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


FindControl Method

[image]
Intersoft WebEssentials Documentation
FindControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


FindControl(String) Method

[image]
Intersoft WebEssentials Documentation
FindControl(String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


FlyPostBackSettings Property

[image]
Intersoft WebEssentials Documentation
FlyPostBackSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : FlyPostBackSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}
Delphi
public read-only property FlyPostBackSettings: ISNet.WebUI.FlyPostBackSettings;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get FlyPostBackSettings : ISNet.WebUI.FlyPostBackSettings
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.FlyPostBackSettings* get_FlyPostBackSettings();
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.FlyPostBackSettings^ FlyPostBackSettings {
   ISNet.WebUI.FlyPostBackSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Focus Method

[image]
Intersoft WebEssentials Documentation
Focus Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebRating

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ForceDisableXmlCompression Method

[image]
Intersoft WebEssentials Documentation
ForceDisableXmlCompression Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebRating

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


FrameStyle Property

[image]
Intersoft WebEssentials Documentation
FrameStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : FrameStyle Property

Glossary Item Box

Contains interactive style for Frame.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle FrameStyle {get; set;}
Delphi
public read-write property FrameStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Style")
public function get,set FrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_FrameStyle();
public: __property void set_FrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ FrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetClientAction Method

[image]
Intersoft WebEssentials Documentation
GetClientAction Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebEssentials Documentation
GetCurrentControlLifeCycle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetCurrentTheme Method

[image]
Intersoft WebEssentials Documentation
GetCurrentTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetFrameworkDataFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkDataFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

value = instance.GetFrameworkDataFolder()
C#
public System.string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): System.String;
JScript
public function GetFrameworkDataFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkDataFolder();
C++/CLI
public:
System.String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetFrameworkFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

value = instance.GetFrameworkFolder()
C#
public System.string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): System.String;
JScript
public function GetFrameworkFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkFolder();
C++/CLI
public:
System.String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetFrameworkVersion Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkVersion Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Version

value = instance.GetFrameworkVersion()
C#
public System.Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): System.Version;
JScript
public function GetFrameworkVersion() : System.Version;
Managed Extensions for C++
public: System.Version* GetFrameworkVersion();
C++/CLI
public:
System.Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetImageName Method

[image]
Intersoft WebEssentials Documentation
GetImageName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetImageName Method

imageType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetImageName( _
   ByVal imageType As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim imageType As System.String
Dim value As System.String

value = instance.GetImageName(imageType)
C#
public System.string GetImageName(
   System.string imageType
)
Delphi
public function GetImageName(
    imageType: System.String
): System.String;
JScript
public function GetImageName(
   imageType : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetImageName(
   System.string* imageType
)
C++/CLI
public:
System.String^ GetImageName(
   System.String^ imageType
)

Parameters

imageType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetIntersoftFolder Method

[image]
Intersoft WebEssentials Documentation
GetIntersoftFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

value = instance.GetIntersoftFolder()
C#
public System.string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): System.String;
JScript
public function GetIntersoftFolder() : System.String;
Managed Extensions for C++
public: System.string* GetIntersoftFolder();
C++/CLI
public:
System.String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetLayoutFolder Method

[image]
Intersoft WebEssentials Documentation
GetLayoutFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

value = instance.GetLayoutFolder()
C#
public System.string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): System.String;
JScript
public function GetLayoutFolder() : System.String;
Managed Extensions for C++
public: System.string* GetLayoutFolder();
C++/CLI
public:
System.String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetPostedXMLData Method

[image]
Intersoft WebEssentials Documentation
GetPostedXMLData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

value = instance.GetPostedXMLData()
C#
public System.string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): System.String;
JScript
public function GetPostedXMLData() : System.String;
Managed Extensions for C++
public: System.string* GetPostedXMLData();
C++/CLI
public:
System.String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetProductInfoKey Method

[image]
Intersoft WebEssentials Documentation
GetProductInfoKey Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

value = instance.GetProductInfoKey()
C#
public System.string GetProductInfoKey()
Delphi
public function GetProductInfoKey(): System.String;
JScript
public function GetProductInfoKey() : System.String;
Managed Extensions for C++
public: System.string* GetProductInfoKey();
C++/CLI
public:
System.String^ GetProductInfoKey();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetProductSimpleName Method

[image]
Intersoft WebEssentials Documentation
GetProductSimpleName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

value = instance.GetProductSimpleName()
C#
public System.string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): System.String;
JScript
public function GetProductSimpleName() : System.String;
Managed Extensions for C++
public: System.string* GetProductSimpleName();
C++/CLI
public:
System.String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetPropertyValue Method

[image]
Intersoft WebEssentials Documentation
GetPropertyValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As System.String, _
   ByVal propValue As System.String, _
   ByVal webConfigKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim defValue As System.String
Dim propValue As System.String
Dim webConfigKey As System.String
Dim value As System.String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public System.string GetPropertyValue(
   System.string defValue,
   System.string propValue,
   System.string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: System.String;
    propValue: System.String;
    webConfigKey: System.String
): System.String;
JScript
public function GetPropertyValue(
   defValue : System.String,
   propValue : System.String,
   webConfigKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetPropertyValue(
   System.string* defValue,
   System.string* propValue,
   System.string* webConfigKey
)
C++/CLI
public:
System.String^ GetPropertyValue(
   System.String^ defValue,
   System.String^ propValue,
   System.String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetResourceStream Method

[image]
Intersoft WebEssentials Documentation
GetResourceStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As System.String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim resourceUrl As System.String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   System.string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: System.String
): System.IO.Stream;
JScript
public function GetResourceStream(
   resourceUrl : System.String
) : System.IO.Stream;
Managed Extensions for C++
public: System.IO.Stream* GetResourceStream(
   System.string* resourceUrl
)
C++/CLI
public:
System.IO.Stream^ GetResourceStream(
   System.String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetRouteUrl Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


GetRouteUrl(Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebEssentials Documentation
GetUniqueIDRelativeTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


HasControls Method

[image]
Intersoft WebEssentials Documentation
HasControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ID Property

[image]
Intersoft WebEssentials Documentation
ID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ImagesDirectory Property

[image]
Intersoft WebEssentials Documentation
ImagesDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the images directory.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
Public Property ImagesDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public System.string ImagesDirectory {get; set;}
Delphi
public read-write property ImagesDirectory: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set ImagesDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.string* get_ImagesDirectory();
public: __property void set_ImagesDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.String^ ImagesDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ImagesSettings Property

[image]
Intersoft WebEssentials Documentation
ImagesSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ImagesSettings Property

Glossary Item Box

Provides the settings that control the images in WebRating.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebRating.")>
Public ReadOnly Property ImagesSettings As WebRatingImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As WebRatingImagesSettings

value = instance.ImagesSettings
C#
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebRating.")]
public WebRatingImagesSettings ImagesSettings {get;}
Delphi
public read-only property ImagesSettings: WebRatingImagesSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebRating.")
public function get ImagesSettings : WebRatingImagesSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebRating.")]
public: __property WebRatingImagesSettings* get_ImagesSettings();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebRating.")]
public:
property WebRatingImagesSettings^ ImagesSettings {
   WebRatingImagesSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Init Event

[image]
Intersoft WebEssentials Documentation
Init Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsAtlasCallback Method

[image]
Intersoft WebEssentials Documentation
IsAtlasCallback Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.IsAtlasCallback()
C#
public System.bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): System.Boolean;
JScript
public function IsAtlasCallback() : System.boolean;
Managed Extensions for C++
public: System.bool IsAtlasCallback();
C++/CLI
public:
System.bool IsAtlasCallback();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsBetaRelease Method

[image]
Intersoft WebEssentials Documentation
IsBetaRelease Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.IsBetaRelease()
C#
public System.bool IsBetaRelease()
Delphi
public function IsBetaRelease(): System.Boolean;
JScript
public function IsBetaRelease() : System.boolean;
Managed Extensions for C++
public: System.bool IsBetaRelease();
C++/CLI
public:
System.bool IsBetaRelease();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsChromeBrowser Method

[image]
Intersoft WebEssentials Documentation
IsChromeBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.IsChromeBrowser()
C#
public System.bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): System.Boolean;
JScript
public function IsChromeBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsChromeBrowser();
C++/CLI
public:
System.bool IsChromeBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsFlyPostBackControl Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual System.bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): System.Boolean; virtual;
JScript
public function IsFlyPostBackControl() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackControl();
C++/CLI
public:
virtual System.bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsFlyPostBackRequest Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackRequest Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual System.bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): System.Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackRequest();
C++/CLI
public:
virtual System.bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebEssentials Documentation
IsGeckoBasedBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.IsGeckoBasedBrowser()
C#
public System.bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): System.Boolean;
JScript
public function IsGeckoBasedBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoBasedBrowser();
C++/CLI
public:
System.bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsGeckoVersion18 Method

[image]
Intersoft WebEssentials Documentation
IsGeckoVersion18 Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.IsGeckoVersion18()
C#
public System.bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): System.Boolean;
JScript
public function IsGeckoVersion18() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoVersion18();
C++/CLI
public:
System.bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsInDesignMode Method

[image]
Intersoft WebEssentials Documentation
IsInDesignMode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.IsInDesignMode()
C#
public System.bool IsInDesignMode()
Delphi
public function IsInDesignMode(): System.Boolean;
JScript
public function IsInDesignMode() : System.boolean;
Managed Extensions for C++
public: System.bool IsInDesignMode();
C++/CLI
public:
System.bool IsInDesignMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorer8Browser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.IsInternetExplorer8Browser()
C#
public System.bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): System.Boolean;
JScript
public function IsInternetExplorer8Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer8Browser();
C++/CLI
public:
System.bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorerBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.IsInternetExplorerBrowser()
C#
public System.bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): System.Boolean;
JScript
public function IsInternetExplorerBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorerBrowser();
C++/CLI
public:
System.bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsOperaBrowser Method

[image]
Intersoft WebEssentials Documentation
IsOperaBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.IsOperaBrowser()
C#
public System.bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): System.Boolean;
JScript
public function IsOperaBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsOperaBrowser();
C++/CLI
public:
System.bool IsOperaBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsReversed Property

[image]
Intersoft WebEssentials Documentation
IsReversed Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsReversed Property

Glossary Item Box

Determines whether or not the moving of WebRating should be reversed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Determines whether or not the moving of WebRating should be reversed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property IsReversed As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

instance.IsReversed = value

value = instance.IsReversed
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Determines whether or not the moving of WebRating should be reversed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool IsReversed {get; set;}
Delphi
public read-write property IsReversed: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Determines whether or not the moving of WebRating should be reversed.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set IsReversed : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Determines whether or not the moving of WebRating should be reversed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_IsReversed();
public: __property void set_IsReversed(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Determines whether or not the moving of WebRating should be reversed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool IsReversed {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsSafariBrowser Method

[image]
Intersoft WebEssentials Documentation
IsSafariBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.IsSafariBrowser()
C#
public System.bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): System.Boolean;
JScript
public function IsSafariBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsSafariBrowser();
C++/CLI
public:
System.bool IsSafariBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


IsW3CStandardBrowser Method

[image]
Intersoft WebEssentials Documentation
IsW3CStandardBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.IsW3CStandardBrowser()
C#
public System.bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): System.Boolean;
JScript
public function IsW3CStandardBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsW3CStandardBrowser();
C++/CLI
public:
System.bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ItemCount Property

[image]
Intersoft WebEssentials Documentation
ItemCount Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ItemCount Property

Glossary Item Box

Specifies the item count of WebRating.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the item count of WebRating.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property ItemCount As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Integer

instance.ItemCount = value

value = instance.ItemCount
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the item count of WebRating.")]
[System.ComponentModel.CategoryAttribute("General")]
public System.int ItemCount {get; set;}
Delphi
public read-write property ItemCount: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the item count of WebRating.")
System.ComponentModel.CategoryAttribute("General")
public function get,set ItemCount : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the item count of WebRating.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.int get_ItemCount();
public: __property void set_ItemCount(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the item count of WebRating.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.int ItemCount {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 5.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Load Event

[image]
Intersoft WebEssentials Documentation
Load Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


LoadLayout Method

[image]
Intersoft WebEssentials Documentation
LoadLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


LoadLayoutFromFile Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim filePath As System.String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   System.string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: System.String
); virtual;
JScript
public function LoadLayoutFromFile(
   filePath : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromFile(
   System.string* filePath
)
C++/CLI
public:
virtual void LoadLayoutFromFile(
   System.String^ filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromPredefinedName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim predefinedName As System.String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   System.string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: System.String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   System.string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   System.String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


LoadLayoutFromStream Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: System.IO.Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   System.IO.Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


LoadPostData Method

[image]
Intersoft WebEssentials Documentation
LoadPostData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function LoadPostData( _
   ByVal postDataKey As System.String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim postDataKey As System.String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As System.Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public virtual System.bool LoadPostData(
   System.string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)
Delphi
public function LoadPostData(
    postDataKey: System.String;
    postCollection: System.Collections.Specialized.NameValueCollection
): System.Boolean; virtual;
JScript
public function LoadPostData(
   postDataKey : System.String,
   postCollection : System.Collections.Specialized.NameValueCollection
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool LoadPostData(
   System.string* postDataKey,
   System.Collections.Specialized.NameValueCollection* postCollection
)
C++/CLI
public:
virtual System.bool LoadPostData(
   System.String^ postDataKey,
   System.Collections.Specialized.NameValueCollection^ postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


MaximumValue Property

[image]
Intersoft WebEssentials Documentation
MaximumValue Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : MaximumValue Property

Glossary Item Box

Specifies the maximum value of WebRating.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the maximum value of WebRating.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property MaximumValue As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Integer

instance.MaximumValue = value

value = instance.MaximumValue
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the maximum value of WebRating.")]
[System.ComponentModel.CategoryAttribute("General")]
public System.int MaximumValue {get; set;}
Delphi
public read-write property MaximumValue: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the maximum value of WebRating.")
System.ComponentModel.CategoryAttribute("General")
public function get,set MaximumValue : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the maximum value of WebRating.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.int get_MaximumValue();
public: __property void set_MaximumValue(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the maximum value of WebRating.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.int MaximumValue {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


MergeStyle Method

[image]
Intersoft WebEssentials Documentation
MergeStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


MinimumValue Property

[image]
Intersoft WebEssentials Documentation
MinimumValue Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : MinimumValue Property

Glossary Item Box

Specifies the minimal value of WebRating.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the minimal value of WebRating.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property MinimumValue As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Integer

instance.MinimumValue = value

value = instance.MinimumValue
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the minimal value of WebRating.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int MinimumValue {get; set;}
Delphi
public read-write property MinimumValue: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the minimal value of WebRating.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set MinimumValue : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the minimal value of WebRating.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_MinimumValue();
public: __property void set_MinimumValue(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the minimal value of WebRating.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int MinimumValue {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


OnInfoChanged Method

[image]
Intersoft WebEssentials Documentation
OnInfoChanged Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


OnPreInitialize Method

[image]
Intersoft WebEssentials Documentation
OnPreInitialize Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebRating

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Orientation Property

[image]
Intersoft WebEssentials Documentation
Orientation Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Orientation Property

Glossary Item Box

Specifies WebRating orientation.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies WebSlider orientation.")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Orientation As WebRatingOrientation
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As WebRatingOrientation

instance.Orientation = value

value = instance.Orientation
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebSlider orientation.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebRatingOrientation Orientation {get; set;}
Delphi
public read-write property Orientation: WebRatingOrientation;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies WebSlider orientation.")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Orientation : WebRatingOrientation
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebSlider orientation.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebRatingOrientation get_Orientation();
public: __property void set_Orientation(
   WebRatingOrientation value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebSlider orientation.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebRatingOrientation Orientation {
   WebRatingOrientation get();
   void set (    WebRatingOrientation value);
}

Property Value

The default value is Horizontal.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Page Property

[image]
Intersoft WebEssentials Documentation
Page Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}
Delphi
public read-write property Page: System.Web.UI.Page; virtual;
JScript
public function get,set Page : System.Web.UI.Page
Managed Extensions for C++
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
C++/CLI
public:
virtual property System.Web.UI.Page^ Page {
   System.Web.UI.Page^ get();
   void set (    System.Web.UI.Page^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


PostbackMode Property

[image]
Intersoft WebEssentials Documentation
PostbackMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : PostbackMode Property

Glossary Item Box

Specifies WebRating postback mode.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies WebRating postback mode.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property PostbackMode As WebRatingPostBack
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As WebRatingPostBack

instance.PostbackMode = value

value = instance.PostbackMode
C#
[System.ComponentModel.DescriptionAttribute("Specifies WebRating postback mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public WebRatingPostBack PostbackMode {get; set;}
Delphi
public read-write property PostbackMode: WebRatingPostBack;
JScript
System.ComponentModel.DescriptionAttribute("Specifies WebRating postback mode.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set PostbackMode : WebRatingPostBack
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies WebRating postback mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebRatingPostBack get_PostbackMode();
public: __property void set_PostbackMode(
   WebRatingPostBack value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies WebRating postback mode.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebRatingPostBack PostbackMode {
   WebRatingPostBack get();
   void set (    WebRatingPostBack value);
}

Property Value

The default value is FlyPostback.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Precision Property

[image]
Intersoft WebEssentials Documentation
Precision Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Precision Property

Glossary Item Box

Specifies WebRating precision.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies WebRating precision.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Precision As WebRatingPrecision
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As WebRatingPrecision

instance.Precision = value

value = instance.Precision
C#
[System.ComponentModel.DescriptionAttribute("Specifies WebRating precision.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public WebRatingPrecision Precision {get; set;}
Delphi
public read-write property Precision: WebRatingPrecision;
JScript
System.ComponentModel.DescriptionAttribute("Specifies WebRating precision.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set Precision : WebRatingPrecision
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies WebRating precision.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebRatingPrecision get_Precision();
public: __property void set_Precision(
   WebRatingPrecision value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies WebRating precision.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebRatingPrecision Precision {
   WebRatingPrecision get();
   void set (    WebRatingPrecision value);
}

Property Value

The default value is Half.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


PreInitialize Event

[image]
Intersoft WebEssentials Documentation
PreInitialize Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim handler As System.EventHandler

AddHandler instance.PreInitialize, handler
C#
public event System.EventHandler PreInitialize
Delphi
public event PreInitialize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* PreInitialize
C++/CLI
public:
event System.EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


PreRender Event

[image]
Intersoft WebEssentials Documentation
PreRender Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RaisePostBackEvent Method

[image]
Intersoft WebEssentials Documentation
RaisePostBackEvent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim eventArgument As System.String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   System.string eventArgument
)
Delphi
public procedure RaisePostBackEvent(
    eventArgument: System.String
);
JScript
public function RaisePostBackEvent(
   eventArgument : System.String
);
Managed Extensions for C++
public: void RaisePostBackEvent(
   System.string* eventArgument
)
C++/CLI
public:
void RaisePostBackEvent(
   System.String^ eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebEssentials Documentation
RaisePostDataChangedEvent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebRating

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); virtual;
JScript
public function RaisePostDataChangedEvent();
Managed Extensions for C++
public: virtual void RaisePostDataChangedEvent();
C++/CLI
public:
virtual void RaisePostDataChangedEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ReadOnly Property

[image]
Intersoft WebEssentials Documentation
ReadOnly Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ReadOnly Property

Glossary Item Box

Determines whether or not WebRating is in readonly mode.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determines whether or not WebRating is in readonly mode.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property ReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebRating is in readonly mode.")]
[System.ComponentModel.CategoryAttribute("General")]
public System.bool ReadOnly {get; set;}
Delphi
public read-write property ReadOnly: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not WebRating is in readonly mode.")
System.ComponentModel.CategoryAttribute("General")
public function get,set ReadOnly : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebRating is in readonly mode.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.bool get_ReadOnly();
public: __property void set_ReadOnly(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebRating is in readonly mode.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.bool ReadOnly {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ReadWebConfigValue Method

[image]
Intersoft WebEssentials Documentation
ReadWebConfigValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim key As System.String
Dim value As System.String

value = instance.ReadWebConfigValue(key)
C#
public System.string ReadWebConfigValue(
   System.string key
)
Delphi
public function ReadWebConfigValue(
    key: System.String
): System.String;
JScript
public function ReadWebConfigValue(
   key : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ReadWebConfigValue(
   System.string* key
)
C++/CLI
public:
System.String^ ReadWebConfigValue(
   System.String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RecreateChildControls Method

[image]
Intersoft WebEssentials Documentation
RecreateChildControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebRating

instance.RecreateChildControls()
C#
public void RecreateChildControls()
Delphi
public procedure RecreateChildControls();
JScript
public function RecreateChildControls();
Managed Extensions for C++
public: void RecreateChildControls();
C++/CLI
public:
void RecreateChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RegisterBoxSizing Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RegisterBoxSizing() Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebRating

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim forceAll As System.Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   System.bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: System.Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : System.boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   System.bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   System.bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebEssentials Documentation
RegisterGlobalStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RegisterLink Method

[image]
Intersoft WebEssentials Documentation
RegisterLink Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As System.String, _
   ByVal url As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim name As System.String
Dim url As System.String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   System.string name,
   System.string url
)
Delphi
public procedure RegisterLink(
    name: System.String;
    url: System.String
);
JScript
public function RegisterLink(
   name : System.String,
   url : System.String
);
Managed Extensions for C++
public: void RegisterLink(
   System.string* name,
   System.string* url
)
C++/CLI
public:
void RegisterLink(
   System.String^ name,
   System.String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebEssentials Documentation
RegisterOptimizedCssClasses Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim runtimeStyleOnly As System.Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: System.Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : System.boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RegisterPreloadImage Method

[image]
Intersoft WebEssentials Documentation
RegisterPreloadImage Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim image As System.String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   System.string image
)
Delphi
public procedure RegisterPreloadImage(
    image: System.String
);
JScript
public function RegisterPreloadImage(
   image : System.String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   System.string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   System.String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RegisterScript Method

[image]
Intersoft WebEssentials Documentation
RegisterScript Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebRating

instance.RegisterScript()
C#
public override void RegisterScript()
Delphi
public procedure RegisterScript(); override;
JScript
public override function RegisterScript();
Managed Extensions for C++
public: void RegisterScript(); override
C++/CLI
public:
void RegisterScript(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RegisterSharePointHandler Method

[image]
Intersoft WebEssentials Documentation
RegisterSharePointHandler Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebRating

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RenderBeginTag Method

[image]
Intersoft WebEssentials Documentation
RenderBeginTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RenderControl Method

[image]
Intersoft WebEssentials Documentation
RenderControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebEssentials Documentation
RenderControl(HtmlTextWriter) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RenderEndTag Method

[image]
Intersoft WebEssentials Documentation
RenderEndTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RenderingMode Property

[image]
Intersoft WebEssentials Documentation
RenderingMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebRating

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ResolveClientUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveClientUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ResolveImagePath Method

[image]
Intersoft WebEssentials Documentation
ResolveImagePath Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As System.String, _
   ByVal image As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim folder As System.String
Dim image As System.String
Dim value As System.String

value = instance.ResolveImagePath(folder, image)
C#
public System.string ResolveImagePath(
   System.string folder,
   System.string image
)
Delphi
public function ResolveImagePath(
    folder: System.String;
    image: System.String
): System.String;
JScript
public function ResolveImagePath(
   folder : System.String,
   image : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveImagePath(
   System.string* folder,
   System.string* image
)
C++/CLI
public:
System.String^ ResolveImagePath(
   System.String^ folder,
   System.String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ResolveRelativeURL Method

[image]
Intersoft WebEssentials Documentation
ResolveRelativeURL Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim url As System.String
Dim value As System.String

value = instance.ResolveRelativeURL(url)
C#
public virtual System.string ResolveRelativeURL(
   System.string url
)
Delphi
public function ResolveRelativeURL(
    url: System.String
): System.String; virtual;
JScript
public function ResolveRelativeURL(
   url : System.String
) : System.String;
Managed Extensions for C++
public: virtual System.string* ResolveRelativeURL(
   System.string* url
)
C++/CLI
public:
virtual System.String^ ResolveRelativeURL(
   System.String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ResolveResourceUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveResourceUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As System.String, _
   ByVal currentFolder As System.String, _
   ByVal resourceName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As System.String
Dim currentFolder As System.String
Dim resourceName As System.String
Dim value As System.String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public System.string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string defaultFolder,
   System.string currentFolder,
   System.string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: System.String;
    currentFolder: System.String;
    resourceName: System.String
): System.String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : System.String,
   currentFolder : System.String,
   resourceName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string* defaultFolder,
   System.string* currentFolder,
   System.string* resourceName
)
C++/CLI
public:
System.String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.String^ defaultFolder,
   System.String^ currentFolder,
   System.String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ResolveUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


RuntimeLicenseKey Property

[image]
Intersoft WebEssentials Documentation
RuntimeLicenseKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
Public Overridable Property RuntimeLicenseKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public virtual System.string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: System.String; virtual;
JScript
ISNet.PersistLayoutAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
public function get,set RuntimeLicenseKey : System.String
Managed Extensions for C++
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public: __property virtual System.string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   System.string* value
);
C++/CLI
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public:
virtual property System.String^ RuntimeLicenseKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


SaveLayout Method

[image]
Intersoft WebEssentials Documentation
SaveLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


SaveLayoutToFile Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim filePath As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   System.string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   System.string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   System.String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


SaveLayoutToStream Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
ScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overrides Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
public override System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String; override;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.DefaultValueAttribute()
public override function get,set ScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


SetRenderMethodDelegate Method

[image]
Intersoft WebEssentials Documentation
SetRenderMethodDelegate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


SetSessionTheme Method

[image]
Intersoft WebEssentials Documentation
SetSessionTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


SharedScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
SharedScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required framework scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overrides Property SharedScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.BinarySerializableAttribute()]
public override System.string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: System.String; override;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
ISNet.Serialization.BinarySerializableAttribute()
public override function get,set SharedScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_SharedScriptDirectory() override;
public: __property void set_SharedScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ SharedScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ShouldReturnJson Method

[image]
Intersoft WebEssentials Documentation
ShouldReturnJson Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

value = instance.ShouldReturnJson()
C#
public virtual System.bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): System.Boolean; virtual;
JScript
public function ShouldReturnJson() : System.boolean;
Managed Extensions for C++
public: virtual System.bool ShouldReturnJson();
C++/CLI
public:
virtual System.bool ShouldReturnJson();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


SkinID Property

[image]
Intersoft WebEssentials Documentation
SkinID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


TabIndex Property

[image]
Intersoft WebEssentials Documentation
TabIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set TabIndex : System.short
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ToolTip Property

[image]
Intersoft WebEssentials Documentation
ToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets WebRating tooltip value.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overrides Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets WebRating tooltip value.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public override System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; override;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets WebRating tooltip value.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
public override function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets WebRating tooltip value.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ToolTip() override;
public: __property void set_ToolTip(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets WebRating tooltip value.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ToolTip {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Unload Event

[image]
Intersoft WebEssentials Documentation
Unload Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


UseCustomImages Property

[image]
Intersoft WebEssentials Documentation
UseCustomImages Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : UseCustomImages Property

Glossary Item Box

Gets or sets the value that determines whether or not WebRating use images that specified by user.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebRating use images that specified by user.")>
Public Property UseCustomImages As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

instance.UseCustomImages = value

value = instance.UseCustomImages
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebRating use images that specified by user.")]
public System.bool UseCustomImages {get; set;}
Delphi
public read-write property UseCustomImages: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebRating use images that specified by user.")
public function get,set UseCustomImages : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebRating use images that specified by user.")]
public: __property System.bool get_UseCustomImages();
public: __property void set_UseCustomImages(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebRating use images that specified by user.")]
public:
property System.bool UseCustomImages {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


UseDefaultStyle Property

[image]
Intersoft WebEssentials Documentation
UseDefaultStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : UseDefaultStyle Property

Glossary Item Box

Determines whether or not WebRating is using default style.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not WebRating is using default style.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property UseDefaultStyle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

instance.UseDefaultStyle = value

value = instance.UseDefaultStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebRating is using default style.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool UseDefaultStyle {get; set;}
Delphi
public read-write property UseDefaultStyle: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not WebRating is using default style.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set UseDefaultStyle : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebRating is using default style.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_UseDefaultStyle();
public: __property void set_UseDefaultStyle(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebRating is using default style.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool UseDefaultStyle {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ValidateRequestMode Property

[image]
Intersoft WebEssentials Documentation
ValidateRequestMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Value Property

[image]
Intersoft WebEssentials Documentation
Value Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Value Property

Glossary Item Box

Specifies the value of WebRating.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the value of WebRating.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Value As System.Double
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Double

instance.Value = value

value = instance.Value
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the value of WebRating.")]
[System.ComponentModel.CategoryAttribute("General")]
public System.double Value {get; set;}
Delphi
public read-write property Value: System.Double;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the value of WebRating.")
System.ComponentModel.CategoryAttribute("General")
public function get,set Value : System.double
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the value of WebRating.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.double get_Value();
public: __property void set_Value(
   System.double value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the value of WebRating.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.double Value {
   System.double get();
   void set (    System.double value);
}

Property Value

The default value is 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ViewStateItems Property

[image]
Intersoft WebEssentials Documentation
ViewStateItems Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ViewStateItems Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ViewStateMode Property

[image]
Intersoft WebEssentials Documentation
ViewStateMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ViewStateServerConnection Property

[image]
Intersoft WebEssentials Documentation
ViewStateServerConnection Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ViewStateServerConnection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ViewStateServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: System.String; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
System.ComponentModel.CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ViewStateServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ViewStateServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


ViewStateStorage Property

[image]
Intersoft WebEssentials Documentation
ViewStateStorage Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : ViewStateStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
System.ComponentModel.CategoryAttribute("View State Settings")
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


XmlCompressionEnabled Property

[image]
Intersoft WebEssentials Documentation
XmlCompressionEnabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebRating Class : XmlCompressionEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property XmlCompressionEnabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebRating
Dim value As System.Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: System.Boolean; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set XmlCompressionEnabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool XmlCompressionEnabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebRating Class
WebRating Members


WebSlider Class

[image]
Intersoft WebEssentials Documentation
WebSlider Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlider Class

Glossary Item Box

Intersoft WebSlider.

Object Model

WebSlider Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebSliderDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.Web.UI.ToolboxDataAttribute("<{0}:WebSlider runat=server Width="250px" Height="80px"></{0}:WebSlider>")>
<ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSlider.js", Type=XmlSerializationType.ClientAndLayout)>
<System.SerializableAttribute()>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebSlider
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
C#
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebSliderDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebSlider runat=server Width="250px" Height="80px"></{0}:WebSlider>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSlider.js", Type=XmlSerializationType.ClientAndLayout)]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebSlider : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Delphi
public class WebSlider = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings)
JScript
System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebSliderDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.Web.UI.ToolboxDataAttribute("<{0}:WebSlider runat=server Width="250px" Height="80px"></{0}:WebSlider>")
ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSlider.js", Type=XmlSerializationType.ClientAndLayout)
System.SerializableAttribute()
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebSlider extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Managed Extensions for C++
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebSliderDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebSlider runat=server Width="250px" Height="80px"></{0}:WebSlider>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSlider.js", Type=XmlSerializationType.ClientAndLayout)]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebSlider : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
C++/CLI
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebSliderDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebSlider runat=server Width="250px" Height="80px"></{0}:WebSlider>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSlider.js", Type=XmlSerializationType.ClientAndLayout)]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebSlider : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebEssentials.WebSlider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Members
ISNet.WebUI.WebEssentials Namespace


WebSlider Class Events

[image]
Intersoft WebEssentials Documentation
WebSlider Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlider Class

Glossary Item Box

For a list of all members of this type, see WebSlider members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebSlider Class
ISNet.WebUI.WebEssentials Namespace


WebSlider Class Members

[image]
Intersoft WebEssentials Documentation
WebSlider Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlider Class

Glossary Item Box

The following tables list the members exposed by WebSlider.

Public Constructors

 | Name | Description
Public Constructor | WebSlider Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebSlider.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | Direction | Specifies WebSlider direction.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableRange | Determines whether or not range value should be enabled in WebSlider.
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EndValue | Specifies the end range value of WebSlider.
Public Property | FrameStyle | Contains interactive style for Frame.
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | ImagesSettings | Provides the settings that control the images in WebSlider.
Public Property | Items | The item collection used by WebSlider.
Public Property | LabelStyle | Contains interactive style for WebSlider label.
Public Property | LargeStepValue | Specifies the large step value of WebSlider.
Public Property | MaximumValue | Specifies the end value of WebSlider.
Public Property | MinimumValue | Specifies the start value of WebSlider.
Public Property | Orientation | Specifies WebSlider orientation.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | ShowSliderRail | Determines whether or not WebSlider rail is shown.
Public Property | ShowValueInTooltip | Determines whether or not WebSlider value appear in Tooltip.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SliderLabelAlignment | Specifies slider step value alignment.
Public Property | SliderType | Determines type of WebSlider.
Public Property | StartValue | Specifies the start range value of WebSlider.
Public Property | StepValue | Specifies the step value of WebSlider.
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ThumbsInteractionMode | Determines thumbs interaction mode of WebSlider.
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseCustomImages | Gets or sets the value that determines whether or not WebSlider use images that specified by user.
Public Property | UseDefaultStyle | Determines whether or not WebSlider is using default style.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | Value | Specifies the value of WebSlider.
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | Overridden.
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetImageName |
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebSlider Class
ISNet.WebUI.WebEssentials Namespace


WebSlider Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlider Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlider Class

Glossary Item Box

For a list of all members of this type, see WebSlider members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetImageName |
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebSlider Class
ISNet.WebUI.WebEssentials Namespace


WebSlider Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlider Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlider Class

Glossary Item Box

For a list of all members of this type, see WebSlider members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebSlider.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | Direction | Specifies WebSlider direction.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableRange | Determines whether or not range value should be enabled in WebSlider.
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EndValue | Specifies the end range value of WebSlider.
Public Property | FrameStyle | Contains interactive style for Frame.
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | ImagesSettings | Provides the settings that control the images in WebSlider.
Public Property | Items | The item collection used by WebSlider.
Public Property | LabelStyle | Contains interactive style for WebSlider label.
Public Property | LargeStepValue | Specifies the large step value of WebSlider.
Public Property | MaximumValue | Specifies the end value of WebSlider.
Public Property | MinimumValue | Specifies the start value of WebSlider.
Public Property | Orientation | Specifies WebSlider orientation.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | ShowSliderRail | Determines whether or not WebSlider rail is shown.
Public Property | ShowValueInTooltip | Determines whether or not WebSlider value appear in Tooltip.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SliderLabelAlignment | Specifies slider step value alignment.
Public Property | SliderType | Determines type of WebSlider.
Public Property | StartValue | Specifies the start range value of WebSlider.
Public Property | StepValue | Specifies the step value of WebSlider.
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ThumbsInteractionMode | Determines thumbs interaction mode of WebSlider.
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseCustomImages | Gets or sets the value that determines whether or not WebSlider use images that specified by user.
Public Property | UseDefaultStyle | Determines whether or not WebSlider is using default style.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | Value | Specifies the value of WebSlider.
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | Overridden.
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebSlider Class
ISNet.WebUI.WebEssentials Namespace


WebSliderClientSideEvents Class

[image]
Intersoft WebEssentials Documentation
WebSliderClientSideEvents Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderClientSideEvents Class

Glossary Item Box

A collection of WebSlider's client side events.

Object Model

WebSliderClientSideEvents Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSliderClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSliderClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSliderClientSideEvents = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSliderClientSideEvents extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSliderClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSliderClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebSliderClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Members
ISNet.WebUI.WebEssentials Namespace


WebSliderClientSideEvents Class Members

[image]
Intersoft WebEssentials Documentation
WebSliderClientSideEvents Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebSliderClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebSliderClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnAfterSliding | Gets or sets the event handler that will be invoked after WebSlider sliding action.
Public Property | OnBeforeSliding | Gets or sets the event handler that will be invoked before WebSlider's drag handle sliding action.
Public Property | OnBeforeValueChanged | Gets or sets the event handler that will be invoked before WebSlider value is changed.
Public Property | OnInitialize | Gets or sets the event handler that will be invoked when WebSlider is initialized.
Public Property | OnSliding | Gets or sets the event handler that will be invoked when WebSlider's drag handle is in sliding action.
Public Property | OnValueChanged | Gets or sets the event handler that will be invoked when WebSlider value is changed.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSliderClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebSliderClientSideEvents Class Methods

[image]
Intersoft WebEssentials Documentation
WebSliderClientSideEvents Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebSliderClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSliderClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebSliderClientSideEvents Class Properties

[image]
Intersoft WebEssentials Documentation
WebSliderClientSideEvents Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebSliderClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnAfterSliding | Gets or sets the event handler that will be invoked after WebSlider sliding action.
Public Property | OnBeforeSliding | Gets or sets the event handler that will be invoked before WebSlider's drag handle sliding action.
Public Property | OnBeforeValueChanged | Gets or sets the event handler that will be invoked before WebSlider value is changed.
Public Property | OnInitialize | Gets or sets the event handler that will be invoked when WebSlider is initialized.
Public Property | OnSliding | Gets or sets the event handler that will be invoked when WebSlider's drag handle is in sliding action.
Public Property | OnValueChanged | Gets or sets the event handler that will be invoked when WebSlider value is changed.
Top

See Also

Reference

WebSliderClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebSliderClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebSliderClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : WebSliderClientSideEvents Constructor

Glossary Item Box

Overload List

Overload | Description
WebSliderClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


WebSliderClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebSliderClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : WebSliderClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSliderClientSideEvents()
C#
public WebSliderClientSideEvents()
Delphi
public WebSliderClientSideEvents();
JScript
public function WebSliderClientSideEvents();
Managed Extensions for C++
public: WebSliderClientSideEvents();
C++/CLI
public:
WebSliderClientSideEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


OnAfterSliding Property

[image]
Intersoft WebEssentials Documentation
OnAfterSliding Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : OnAfterSliding Property

Glossary Item Box

Gets or sets the event handler that will be invoked after WebSlider sliding action.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after WebSlider's drag handle sliding action.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnAfterSliding As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim value As System.String

instance.OnAfterSliding = value

value = instance.OnAfterSliding
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after WebSlider's drag handle sliding action.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnAfterSliding {get; set;}
Delphi
public read-write property OnAfterSliding: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after WebSlider's drag handle sliding action.")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnAfterSliding : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after WebSlider's drag handle sliding action.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnAfterSliding();
public: __property void set_OnAfterSliding(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after WebSlider's drag handle sliding action.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnAfterSliding {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


OnBeforeSliding Property

[image]
Intersoft WebEssentials Documentation
OnBeforeSliding Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : OnBeforeSliding Property

Glossary Item Box

Gets or sets the event handler that will be invoked before WebSlider's drag handle sliding action.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebSlider's drag handle sliding action.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnBeforeSliding As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim value As System.String

instance.OnBeforeSliding = value

value = instance.OnBeforeSliding
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebSlider's drag handle sliding action.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string OnBeforeSliding {get; set;}
Delphi
public read-write property OnBeforeSliding: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebSlider's drag handle sliding action.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnBeforeSliding : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebSlider's drag handle sliding action.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_OnBeforeSliding();
public: __property void set_OnBeforeSliding(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebSlider's drag handle sliding action.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ OnBeforeSliding {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


OnBeforeValueChanged Property

[image]
Intersoft WebEssentials Documentation
OnBeforeValueChanged Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : OnBeforeValueChanged Property

Glossary Item Box

Gets or sets the event handler that will be invoked before WebSlider value is changed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebSlider value is changed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnBeforeValueChanged As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim value As System.String

instance.OnBeforeValueChanged = value

value = instance.OnBeforeValueChanged
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebSlider value is changed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string OnBeforeValueChanged {get; set;}
Delphi
public read-write property OnBeforeValueChanged: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebSlider value is changed.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnBeforeValueChanged : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebSlider value is changed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_OnBeforeValueChanged();
public: __property void set_OnBeforeValueChanged(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebSlider value is changed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ OnBeforeValueChanged {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebEssentials Documentation
OnInitialize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : OnInitialize Property

Glossary Item Box

Gets or sets the event handler that will be invoked when WebSlider is initialized.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSlider is initialized.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim value As System.String

instance.OnInitialize = value

value = instance.OnInitialize
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSlider is initialized.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string OnInitialize {get; set;}
Delphi
public read-write property OnInitialize: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSlider is initialized.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnInitialize : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSlider is initialized.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_OnInitialize();
public: __property void set_OnInitialize(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSlider is initialized.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ OnInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


OnSliding Property

[image]
Intersoft WebEssentials Documentation
OnSliding Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : OnSliding Property

Glossary Item Box

Gets or sets the event handler that will be invoked when WebSlider's drag handle is in sliding action.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebSlider's drag handle is in sliding action.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnSliding As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim value As System.String

instance.OnSliding = value

value = instance.OnSliding
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebSlider's drag handle is in sliding action.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string OnSliding {get; set;}
Delphi
public read-write property OnSliding: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebSlider's drag handle is in sliding action.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnSliding : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebSlider's drag handle is in sliding action.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_OnSliding();
public: __property void set_OnSliding(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebSlider's drag handle is in sliding action.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ OnSliding {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


OnValueChanged Property

[image]
Intersoft WebEssentials Documentation
OnValueChanged Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : OnValueChanged Property

Glossary Item Box

Gets or sets the event handler that will be invoked when WebSlider value is changed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, oldValue, newValue")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked WebSlider value is changed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnValueChanged As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim value As System.String

instance.OnValueChanged = value

value = instance.OnValueChanged
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, oldValue, newValue")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked WebSlider value is changed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string OnValueChanged {get; set;}
Delphi
public read-write property OnValueChanged: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, oldValue, newValue")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked WebSlider value is changed.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnValueChanged : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, oldValue, newValue")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked WebSlider value is changed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_OnValueChanged();
public: __property void set_OnValueChanged(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, oldValue, newValue")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked WebSlider value is changed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ OnValueChanged {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderClientSideEvents
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderClientSideEvents Class
WebSliderClientSideEvents Members


WebSliderDefaultStyleMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebSliderDefaultStyleMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderDefaultStyleMode Enumeration

Glossary Item Box

Specifies DefaultStyle mode in WebSlider.

Syntax

Visual Basic (Declaration)
Public Enum WebSliderDefaultStyleMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSliderDefaultStyleMode
C#
public enum WebSliderDefaultStyleMode : System.Enum
Delphi
public enum WebSliderDefaultStyleMode = class(System.Enum)
JScript
public enum WebSliderDefaultStyleMode extends System.Enum
Managed Extensions for C++
__value public enum WebSliderDefaultStyleMode : public System.Enum
C++/CLI
public enum class WebSliderDefaultStyleMode : public System.Enum

Members

Member | Description
DefaultBlack |
DefaultBlue |
MinimalistBlue |
MinimalistSilver |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebSliderDefaultStyleMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebSliderDirection Enumeration

[image]
Intersoft WebEssentials Documentation
WebSliderDirection Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderDirection Enumeration

Glossary Item Box

Specifies WebSlider Direction.

Syntax

Visual Basic (Declaration)
Public Enum WebSliderDirection
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSliderDirection
C#
public enum WebSliderDirection : System.Enum
Delphi
public enum WebSliderDirection = class(System.Enum)
JScript
public enum WebSliderDirection extends System.Enum
Managed Extensions for C++
__value public enum WebSliderDirection : public System.Enum
C++/CLI
public enum class WebSliderDirection : public System.Enum

Members

Member | Description
BottomToTop |
LeftToRight |
RightToLeft |
TopToBottom |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebSliderDirection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebSliderImagesSettings Class

[image]
Intersoft WebEssentials Documentation
WebSliderImagesSettings Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderImagesSettings Class

Glossary Item Box

A collection of WebSlider's images settings.

Object Model

WebSliderImagesSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSliderImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSliderImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSliderImagesSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSliderImagesSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSliderImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSliderImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebSliderImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Members
ISNet.WebUI.WebEssentials Namespace


WebSliderImagesSettings Class Members

[image]
Intersoft WebEssentials Documentation
WebSliderImagesSettings Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebSliderImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebSliderImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | DownPointer |
Public Property | DownPointerHover |
Public Property | DownPointerPress |
Public Property | DownSlider |
Public Property | DownSliderHover |
Public Property | DownSliderPress |
Public Property | HorizontalMiddle |
Public Property | HorizontalMiddleFill |
Public Property | ItemInfoLine |
Public Property | LargeInfoLine |
Public Property | LeftPointer |
Public Property | LeftPointerHover |
Public Property | LeftPointerPress |
Public Property | LeftSlider |
Public Property | LeftSliderHover |
Public Property | LeftSliderPress |
Public Property | RightPointer |
Public Property | RightPointerHover |
Public Property | RightPointerPress |
Public Property | RightSlider |
Public Property | RightSliderHover |
Public Property | RightSliderPress |
Public Property | SmallInfoLine |
Public Property | UpPointer |
Public Property | UpPointerHover |
Public Property | UpPointerPress |
Public Property | UpSlider |
Public Property | UpSliderHover |
Public Property | UpSliderPress |
Public Property | VerticalItemInfoLine |
Public Property | VerticalLargeInfoLine |
Public Property | VerticalMiddle |
Public Property | VerticalMiddleFill |
Public Property | VerticalSmallInfoLine |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSliderImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebSliderImagesSettings Class Methods

[image]
Intersoft WebEssentials Documentation
WebSliderImagesSettings Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebSliderImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSliderImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebSliderImagesSettings Class Properties

[image]
Intersoft WebEssentials Documentation
WebSliderImagesSettings Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebSliderImagesSettings members.

Public Properties

 | Name | Description
Public Property | DownPointer |
Public Property | DownPointerHover |
Public Property | DownPointerPress |
Public Property | DownSlider |
Public Property | DownSliderHover |
Public Property | DownSliderPress |
Public Property | HorizontalMiddle |
Public Property | HorizontalMiddleFill |
Public Property | ItemInfoLine |
Public Property | LargeInfoLine |
Public Property | LeftPointer |
Public Property | LeftPointerHover |
Public Property | LeftPointerPress |
Public Property | LeftSlider |
Public Property | LeftSliderHover |
Public Property | LeftSliderPress |
Public Property | RightPointer |
Public Property | RightPointerHover |
Public Property | RightPointerPress |
Public Property | RightSlider |
Public Property | RightSliderHover |
Public Property | RightSliderPress |
Public Property | SmallInfoLine |
Public Property | UpPointer |
Public Property | UpPointerHover |
Public Property | UpPointerPress |
Public Property | UpSlider |
Public Property | UpSliderHover |
Public Property | UpSliderPress |
Public Property | VerticalItemInfoLine |
Public Property | VerticalLargeInfoLine |
Public Property | VerticalMiddle |
Public Property | VerticalMiddleFill |
Public Property | VerticalSmallInfoLine |
Top

See Also

Reference

WebSliderImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebSliderImagesSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebSliderImagesSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : WebSliderImagesSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebSliderImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


WebSliderImagesSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebSliderImagesSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : WebSliderImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSliderImagesSettings()
C#
public WebSliderImagesSettings()
Delphi
public WebSliderImagesSettings();
JScript
public function WebSliderImagesSettings();
Managed Extensions for C++
public: WebSliderImagesSettings();
C++/CLI
public:
WebSliderImagesSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


DownPointer Property

[image]
Intersoft WebEssentials Documentation
DownPointer Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : DownPointer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the down pointer image of WebSlider.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DownPointer As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.DownPointer = value

value = instance.DownPointer
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the down pointer image of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DownPointer {get; set;}
Delphi
public read-write property DownPointer: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Sets the down pointer image of WebSlider.")
System.ComponentModel.DefaultValueAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DownPointer : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the down pointer image of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DownPointer();
public: __property void set_DownPointer(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the down pointer image of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DownPointer {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


DownPointerHover Property

[image]
Intersoft WebEssentials Documentation
DownPointerHover Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : DownPointerHover Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the down pointer hover image of WebSlider.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.MarkAsStyleAttribute(True)>
Public Property DownPointerHover As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.DownPointerHover = value

value = instance.DownPointerHover
C#
[System.ComponentModel.DescriptionAttribute("Sets the down pointer hover image of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public System.string DownPointerHover {get; set;}
Delphi
public read-write property DownPointerHover: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Sets the down pointer hover image of WebSlider.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.MarkAsStyleAttribute()
public function get,set DownPointerHover : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the down pointer hover image of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public: __property System.string* get_DownPointerHover();
public: __property void set_DownPointerHover(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the down pointer hover image of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public:
property System.String^ DownPointerHover {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


DownPointerPress Property

[image]
Intersoft WebEssentials Documentation
DownPointerPress Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : DownPointerPress Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the down pointer press image of WebSlider.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DownPointerPress As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.DownPointerPress = value

value = instance.DownPointerPress
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the down pointer press image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string DownPointerPress {get; set;}
Delphi
public read-write property DownPointerPress: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Sets the down pointer press image of WebSlider.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DefaultValueAttribute()
public function get,set DownPointerPress : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the down pointer press image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_DownPointerPress();
public: __property void set_DownPointerPress(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the down pointer press image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ DownPointerPress {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


DownSlider Property

[image]
Intersoft WebEssentials Documentation
DownSlider Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : DownSlider Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the down slider image of WebSlider.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.MarkAsStyleAttribute(True)>
Public Property DownSlider As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.DownSlider = value

value = instance.DownSlider
C#
[System.ComponentModel.DescriptionAttribute("Sets the down slider image of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public System.string DownSlider {get; set;}
Delphi
public read-write property DownSlider: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Sets the down slider image of WebSlider.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.MarkAsStyleAttribute()
public function get,set DownSlider : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the down slider image of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public: __property System.string* get_DownSlider();
public: __property void set_DownSlider(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the down slider image of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public:
property System.String^ DownSlider {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


DownSliderHover Property

[image]
Intersoft WebEssentials Documentation
DownSliderHover Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : DownSliderHover Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the down slider image of WebSlider when mouse over.")>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
Public Property DownSliderHover As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.DownSliderHover = value

value = instance.DownSliderHover
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the down slider image of WebSlider when mouse over.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
public System.string DownSliderHover {get; set;}
Delphi
public read-write property DownSliderHover: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Sets the down slider image of WebSlider when mouse over.")
System.ComponentModel.CategoryAttribute("ImagesSettings")
public function get,set DownSliderHover : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the down slider image of WebSlider when mouse over.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
public: __property System.string* get_DownSliderHover();
public: __property void set_DownSliderHover(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the down slider image of WebSlider when mouse over.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
public:
property System.String^ DownSliderHover {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


DownSliderPress Property

[image]
Intersoft WebEssentials Documentation
DownSliderPress Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : DownSliderPress Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the slider image of WebSlider when pressed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property DownSliderPress As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.DownSliderPress = value

value = instance.DownSliderPress
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the slider image of WebSlider when pressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string DownSliderPress {get; set;}
Delphi
public read-write property DownSliderPress: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DescriptionAttribute("Sets the slider image of WebSlider when pressed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set DownSliderPress : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the slider image of WebSlider when pressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_DownSliderPress();
public: __property void set_DownSliderPress(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the slider image of WebSlider when pressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ DownSliderPress {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


HorizontalMiddle Property

[image]
Intersoft WebEssentials Documentation
HorizontalMiddle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : HorizontalMiddle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the middle image of horizontal WebSlider.")>
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HorizontalMiddle As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.HorizontalMiddle = value

value = instance.HorizontalMiddle
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the middle image of horizontal WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string HorizontalMiddle {get; set;}
Delphi
public read-write property HorizontalMiddle: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Sets the middle image of horizontal WebSlider.")
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DefaultValueAttribute()
public function get,set HorizontalMiddle : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the middle image of horizontal WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_HorizontalMiddle();
public: __property void set_HorizontalMiddle(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the middle image of horizontal WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ HorizontalMiddle {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


HorizontalMiddleFill Property

[image]
Intersoft WebEssentials Documentation
HorizontalMiddleFill Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : HorizontalMiddleFill Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the middle fill image of horizontal WebSlider.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property HorizontalMiddleFill As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.HorizontalMiddleFill = value

value = instance.HorizontalMiddleFill
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the middle fill image of horizontal WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string HorizontalMiddleFill {get; set;}
Delphi
public read-write property HorizontalMiddleFill: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Sets the middle fill image of horizontal WebSlider.")
System.ComponentModel.DefaultValueAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set HorizontalMiddleFill : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the middle fill image of horizontal WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_HorizontalMiddleFill();
public: __property void set_HorizontalMiddleFill(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the middle fill image of horizontal WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ HorizontalMiddleFill {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


ItemInfoLine Property

[image]
Intersoft WebEssentials Documentation
ItemInfoLine Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : ItemInfoLine Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the item info line image of WebSlider.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
Public Property ItemInfoLine As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.ItemInfoLine = value

value = instance.ItemInfoLine
C#
[System.ComponentModel.DescriptionAttribute("Sets the item info line image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public System.string ItemInfoLine {get; set;}
Delphi
public read-write property ItemInfoLine: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Sets the item info line image of WebSlider.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.MarkAsStyleAttribute()
public function get,set ItemInfoLine : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the item info line image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public: __property System.string* get_ItemInfoLine();
public: __property void set_ItemInfoLine(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the item info line image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public:
property System.String^ ItemInfoLine {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


LargeInfoLine Property

[image]
Intersoft WebEssentials Documentation
LargeInfoLine Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : LargeInfoLine Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the large info line image of WebSlider.")>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
Public Property LargeInfoLine As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.LargeInfoLine = value

value = instance.LargeInfoLine
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the large info line image of WebSlider.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
public System.string LargeInfoLine {get; set;}
Delphi
public read-write property LargeInfoLine: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Sets the large info line image of WebSlider.")
System.ComponentModel.CategoryAttribute("ImagesSettings")
public function get,set LargeInfoLine : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the large info line image of WebSlider.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
public: __property System.string* get_LargeInfoLine();
public: __property void set_LargeInfoLine(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the large info line image of WebSlider.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
public:
property System.String^ LargeInfoLine {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


LeftPointer Property

[image]
Intersoft WebEssentials Documentation
LeftPointer Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : LeftPointer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the left pointer image of WebSlider.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property LeftPointer As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.LeftPointer = value

value = instance.LeftPointer
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the left pointer image of WebSlider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string LeftPointer {get; set;}
Delphi
public read-write property LeftPointer: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Sets the left pointer image of WebSlider.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DefaultValueAttribute()
public function get,set LeftPointer : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the left pointer image of WebSlider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_LeftPointer();
public: __property void set_LeftPointer(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the left pointer image of WebSlider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ LeftPointer {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


LeftPointerHover Property

[image]
Intersoft WebEssentials Documentation
LeftPointerHover Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : LeftPointerHover Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DescriptionAttribute("Sets the left pointer hover image of WebSlider.")>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property LeftPointerHover As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.LeftPointerHover = value

value = instance.LeftPointerHover
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the left pointer hover image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string LeftPointerHover {get; set;}
Delphi
public read-write property LeftPointerHover: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DescriptionAttribute("Sets the left pointer hover image of WebSlider.")
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set LeftPointerHover : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the left pointer hover image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_LeftPointerHover();
public: __property void set_LeftPointerHover(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the left pointer hover image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ LeftPointerHover {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


LeftPointerPress Property

[image]
Intersoft WebEssentials Documentation
LeftPointerPress Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : LeftPointerPress Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the left pointer press image of WebSlider.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property LeftPointerPress As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.LeftPointerPress = value

value = instance.LeftPointerPress
C#
[System.ComponentModel.DescriptionAttribute("Sets the left pointer press image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string LeftPointerPress {get; set;}
Delphi
public read-write property LeftPointerPress: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Sets the left pointer press image of WebSlider.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set LeftPointerPress : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the left pointer press image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_LeftPointerPress();
public: __property void set_LeftPointerPress(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the left pointer press image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ LeftPointerPress {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


LeftSlider Property

[image]
Intersoft WebEssentials Documentation
LeftSlider Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : LeftSlider Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
Public Property LeftSlider As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.LeftSlider = value

value = instance.LeftSlider
C#
[System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public System.string LeftSlider {get; set;}
Delphi
public read-write property LeftSlider: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.MarkAsStyleAttribute()
public function get,set LeftSlider : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public: __property System.string* get_LeftSlider();
public: __property void set_LeftSlider(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public:
property System.String^ LeftSlider {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


LeftSliderHover Property

[image]
Intersoft WebEssentials Documentation
LeftSliderHover Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : LeftSliderHover Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider when mouse over.")>
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property LeftSliderHover As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.LeftSliderHover = value

value = instance.LeftSliderHover
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider when mouse over.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string LeftSliderHover {get; set;}
Delphi
public read-write property LeftSliderHover: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider when mouse over.")
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DefaultValueAttribute()
public function get,set LeftSliderHover : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider when mouse over.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_LeftSliderHover();
public: __property void set_LeftSliderHover(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider when mouse over.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ LeftSliderHover {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


LeftSliderPress Property

[image]
Intersoft WebEssentials Documentation
LeftSliderPress Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : LeftSliderPress Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider when pressed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property LeftSliderPress As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.LeftSliderPress = value

value = instance.LeftSliderPress
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider when pressed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string LeftSliderPress {get; set;}
Delphi
public read-write property LeftSliderPress: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider when pressed.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DefaultValueAttribute()
public function get,set LeftSliderPress : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider when pressed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_LeftSliderPress();
public: __property void set_LeftSliderPress(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the left slider image of WebSlider when pressed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ LeftSliderPress {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


RightPointer Property

[image]
Intersoft WebEssentials Documentation
RightPointer Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : RightPointer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the right pointer image of WebSlider.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
Public Property RightPointer As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.RightPointer = value

value = instance.RightPointer
C#
[System.ComponentModel.DescriptionAttribute("Sets the right pointer image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public System.string RightPointer {get; set;}
Delphi
public read-write property RightPointer: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Sets the right pointer image of WebSlider.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.MarkAsStyleAttribute()
public function get,set RightPointer : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the right pointer image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public: __property System.string* get_RightPointer();
public: __property void set_RightPointer(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the right pointer image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
public:
property System.String^ RightPointer {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


RightPointerHover Property

[image]
Intersoft WebEssentials Documentation
RightPointerHover Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : RightPointerHover Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DescriptionAttribute("Sets the right pointer hover image of WebSlider.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.MarkAsStyleAttribute(True)>
Public Property RightPointerHover As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.RightPointerHover = value

value = instance.RightPointerHover
C#
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the right pointer hover image of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public System.string RightPointerHover {get; set;}
Delphi
public read-write property RightPointerHover: System.String;
JScript
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DescriptionAttribute("Sets the right pointer hover image of WebSlider.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.MarkAsStyleAttribute()
public function get,set RightPointerHover : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the right pointer hover image of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public: __property System.string* get_RightPointerHover();
public: __property void set_RightPointerHover(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the right pointer hover image of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public:
property System.String^ RightPointerHover {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


RightPointerPress Property

[image]
Intersoft WebEssentials Documentation
RightPointerPress Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : RightPointerPress Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DescriptionAttribute("Sets the right pointer press image of WebSlider.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property RightPointerPress As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.RightPointerPress = value

value = instance.RightPointerPress
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the right pointer press image of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string RightPointerPress {get; set;}
Delphi
public read-write property RightPointerPress: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DescriptionAttribute("Sets the right pointer press image of WebSlider.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set RightPointerPress : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the right pointer press image of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_RightPointerPress();
public: __property void set_RightPointerPress(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the right pointer press image of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ RightPointerPress {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


RightSlider Property

[image]
Intersoft WebEssentials Documentation
RightSlider Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : RightSlider Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider.")>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property RightSlider As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.RightSlider = value

value = instance.RightSlider
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string RightSlider {get; set;}
Delphi
public read-write property RightSlider: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider.")
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set RightSlider : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_RightSlider();
public: __property void set_RightSlider(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ RightSlider {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


RightSliderHover Property

[image]
Intersoft WebEssentials Documentation
RightSliderHover Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : RightSliderHover Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider when mouse over.")>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property RightSliderHover As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.RightSliderHover = value

value = instance.RightSliderHover
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider when mouse over.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string RightSliderHover {get; set;}
Delphi
public read-write property RightSliderHover: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider when mouse over.")
System.ComponentModel.CategoryAttribute("ImagesSettings")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set RightSliderHover : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider when mouse over.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_RightSliderHover();
public: __property void set_RightSliderHover(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider when mouse over.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ RightSliderHover {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


RightSliderPress Property

[image]
Intersoft WebEssentials Documentation
RightSliderPress Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : RightSliderPress Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider when pressed.")>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property RightSliderPress As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.RightSliderPress = value

value = instance.RightSliderPress
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider when pressed.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string RightSliderPress {get; set;}
Delphi
public read-write property RightSliderPress: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider when pressed.")
ISNet.MarkAsStyleAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set RightSliderPress : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider when pressed.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_RightSliderPress();
public: __property void set_RightSliderPress(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the right slider image of WebSlider when pressed.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ RightSliderPress {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


SmallInfoLine Property

[image]
Intersoft WebEssentials Documentation
SmallInfoLine Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : SmallInfoLine Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DescriptionAttribute("Sets the small info line image of WebSlider.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SmallInfoLine As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.SmallInfoLine = value

value = instance.SmallInfoLine
C#
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the small info line image of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string SmallInfoLine {get; set;}
Delphi
public read-write property SmallInfoLine: System.String;
JScript
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DescriptionAttribute("Sets the small info line image of WebSlider.")
System.ComponentModel.DefaultValueAttribute()
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SmallInfoLine : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the small info line image of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_SmallInfoLine();
public: __property void set_SmallInfoLine(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the small info line image of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ SmallInfoLine {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


UpPointer Property

[image]
Intersoft WebEssentials Documentation
UpPointer Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : UpPointer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the up pointer image of WebSlider.")>
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property UpPointer As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.UpPointer = value

value = instance.UpPointer
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the up pointer image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string UpPointer {get; set;}
Delphi
public read-write property UpPointer: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Sets the up pointer image of WebSlider.")
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DefaultValueAttribute()
public function get,set UpPointer : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the up pointer image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_UpPointer();
public: __property void set_UpPointer(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the up pointer image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ UpPointer {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


UpPointerHover Property

[image]
Intersoft WebEssentials Documentation
UpPointerHover Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : UpPointerHover Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the up pointer hover image of WebSlider.")>
Public Property UpPointerHover As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.UpPointerHover = value

value = instance.UpPointerHover
C#
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the up pointer hover image of WebSlider.")]
public System.string UpPointerHover {get; set;}
Delphi
public read-write property UpPointerHover: System.String;
JScript
ISNet.MarkAsStyleAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Sets the up pointer hover image of WebSlider.")
public function get,set UpPointerHover : System.String
Managed Extensions for C++
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the up pointer hover image of WebSlider.")]
public: __property System.string* get_UpPointerHover();
public: __property void set_UpPointerHover(
   System.string* value
);
C++/CLI
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the up pointer hover image of WebSlider.")]
public:
property System.String^ UpPointerHover {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


UpPointerPress Property

[image]
Intersoft WebEssentials Documentation
UpPointerPress Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : UpPointerPress Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the up pointer press image of WebSlider.")>
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property UpPointerPress As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.UpPointerPress = value

value = instance.UpPointerPress
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the up pointer press image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string UpPointerPress {get; set;}
Delphi
public read-write property UpPointerPress: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Sets the up pointer press image of WebSlider.")
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DefaultValueAttribute()
public function get,set UpPointerPress : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the up pointer press image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_UpPointerPress();
public: __property void set_UpPointerPress(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the up pointer press image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ UpPointerPress {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


UpSlider Property

[image]
Intersoft WebEssentials Documentation
UpSlider Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : UpSlider Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider.")>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
Public Property UpSlider As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.UpSlider = value

value = instance.UpSlider
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
public System.string UpSlider {get; set;}
Delphi
public read-write property UpSlider: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider.")
System.ComponentModel.CategoryAttribute("ImagesSettings")
public function get,set UpSlider : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
public: __property System.string* get_UpSlider();
public: __property void set_UpSlider(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider.")]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
public:
property System.String^ UpSlider {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


UpSliderHover Property

[image]
Intersoft WebEssentials Documentation
UpSliderHover Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : UpSliderHover Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider when mouse over.")>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property UpSliderHover As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.UpSliderHover = value

value = instance.UpSliderHover
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider when mouse over.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string UpSliderHover {get; set;}
Delphi
public read-write property UpSliderHover: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider when mouse over.")
ISNet.MarkAsStyleAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set UpSliderHover : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider when mouse over.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_UpSliderHover();
public: __property void set_UpSliderHover(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider when mouse over.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ UpSliderHover {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


UpSliderPress Property

[image]
Intersoft WebEssentials Documentation
UpSliderPress Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : UpSliderPress Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider when pressed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.MarkAsStyleAttribute(True)>
Public Property UpSliderPress As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.UpSliderPress = value

value = instance.UpSliderPress
C#
[System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider when pressed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public System.string UpSliderPress {get; set;}
Delphi
public read-write property UpSliderPress: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider when pressed.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.MarkAsStyleAttribute()
public function get,set UpSliderPress : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider when pressed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public: __property System.string* get_UpSliderPress();
public: __property void set_UpSliderPress(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the up slider image of WebSlider when pressed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public:
property System.String^ UpSliderPress {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


VerticalItemInfoLine Property

[image]
Intersoft WebEssentials Documentation
VerticalItemInfoLine Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : VerticalItemInfoLine Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Sets the vertical item info line image of WebSlider.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property VerticalItemInfoLine As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.VerticalItemInfoLine = value

value = instance.VerticalItemInfoLine
C#
[System.ComponentModel.DescriptionAttribute("Sets the vertical item info line image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string VerticalItemInfoLine {get; set;}
Delphi
public read-write property VerticalItemInfoLine: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Sets the vertical item info line image of WebSlider.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set VerticalItemInfoLine : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Sets the vertical item info line image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_VerticalItemInfoLine();
public: __property void set_VerticalItemInfoLine(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Sets the vertical item info line image of WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ VerticalItemInfoLine {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


VerticalLargeInfoLine Property

[image]
Intersoft WebEssentials Documentation
VerticalLargeInfoLine Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : VerticalLargeInfoLine Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Sets the vertical large info line image of WebSlider.")>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property VerticalLargeInfoLine As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.VerticalLargeInfoLine = value

value = instance.VerticalLargeInfoLine
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the vertical large info line image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string VerticalLargeInfoLine {get; set;}
Delphi
public read-write property VerticalLargeInfoLine: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Sets the vertical large info line image of WebSlider.")
ISNet.MarkAsStyleAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DefaultValueAttribute()
public function get,set VerticalLargeInfoLine : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the vertical large info line image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_VerticalLargeInfoLine();
public: __property void set_VerticalLargeInfoLine(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Sets the vertical large info line image of WebSlider.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ VerticalLargeInfoLine {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


VerticalMiddle Property

[image]
Intersoft WebEssentials Documentation
VerticalMiddle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : VerticalMiddle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DescriptionAttribute("Sets the middle image of vertical WebSlider.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property VerticalMiddle As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.VerticalMiddle = value

value = instance.VerticalMiddle
C#
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the middle image of vertical WebSlider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string VerticalMiddle {get; set;}
Delphi
public read-write property VerticalMiddle: System.String;
JScript
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DescriptionAttribute("Sets the middle image of vertical WebSlider.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set VerticalMiddle : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the middle image of vertical WebSlider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_VerticalMiddle();
public: __property void set_VerticalMiddle(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the middle image of vertical WebSlider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ VerticalMiddle {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


VerticalMiddleFill Property

[image]
Intersoft WebEssentials Documentation
VerticalMiddleFill Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : VerticalMiddleFill Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Sets the middle fill image of vertical WebSlider.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property VerticalMiddleFill As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.VerticalMiddleFill = value

value = instance.VerticalMiddleFill
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the middle fill image of vertical WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string VerticalMiddleFill {get; set;}
Delphi
public read-write property VerticalMiddleFill: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Sets the middle fill image of vertical WebSlider.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.MarkAsStyleAttribute()
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DefaultValueAttribute()
public function get,set VerticalMiddleFill : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the middle fill image of vertical WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_VerticalMiddleFill();
public: __property void set_VerticalMiddleFill(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Sets the middle fill image of vertical WebSlider.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ VerticalMiddleFill {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


VerticalSmallInfoLine Property

[image]
Intersoft WebEssentials Documentation
VerticalSmallInfoLine Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderImagesSettings Class : VerticalSmallInfoLine Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("ImagesSettings")>
<System.ComponentModel.DescriptionAttribute("Sets the vertical small info line image of WebSlider.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property VerticalSmallInfoLine As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderImagesSettings
Dim value As System.String

instance.VerticalSmallInfoLine = value

value = instance.VerticalSmallInfoLine
C#
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the vertical small info line image of WebSlider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string VerticalSmallInfoLine {get; set;}
Delphi
public read-write property VerticalSmallInfoLine: System.String;
JScript
System.ComponentModel.CategoryAttribute("ImagesSettings")
System.ComponentModel.DescriptionAttribute("Sets the vertical small info line image of WebSlider.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set VerticalSmallInfoLine : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the vertical small info line image of WebSlider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_VerticalSmallInfoLine();
public: __property void set_VerticalSmallInfoLine(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("ImagesSettings")]
[System.ComponentModel.DescriptionAttribute("Sets the vertical small info line image of WebSlider.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ VerticalSmallInfoLine {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderImagesSettings Class
WebSliderImagesSettings Members


WebSliderItem Class

[image]
Intersoft WebEssentials Documentation
WebSliderItem Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderItem Class

Glossary Item Box

A collection of custom item in WebSlider.

Object Model

WebSliderItem Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSliderItem
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItem
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSliderItem : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebSliderItem = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSliderItem extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSliderItem : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSliderItem : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebEssentials.WebSliderItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Members
ISNet.WebUI.WebEssentials Namespace


WebSliderItem Class Members

[image]
Intersoft WebEssentials Documentation
WebSliderItem Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderItem Class

Glossary Item Box

The following tables list the members exposed by WebSliderItem.

Public Constructors

 | Name | Description
Public Constructor | WebSliderItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | Name | Overridden.
Public Property | Text | Specifies the text of WebSlider's item.
Public Property | Value | Specifies the value of WebSlider's item.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSliderItem Class
ISNet.WebUI.WebEssentials Namespace


WebSliderItem Class Methods

[image]
Intersoft WebEssentials Documentation
WebSliderItem Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderItem Class

Glossary Item Box

For a list of all members of this type, see WebSliderItem members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSliderItem Class
ISNet.WebUI.WebEssentials Namespace


WebSliderItem Class Properties

[image]
Intersoft WebEssentials Documentation
WebSliderItem Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderItem Class

Glossary Item Box

For a list of all members of this type, see WebSliderItem members.

Public Properties

 | Name | Description
Public Property | Name | Overridden.
Public Property | Text | Specifies the text of WebSlider's item.
Public Property | Value | Specifies the value of WebSlider's item.
Top

See Also

Reference

WebSliderItem Class
ISNet.WebUI.WebEssentials Namespace


WebSliderItemCollection Class

[image]
Intersoft WebEssentials Documentation
WebSliderItemCollection Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderItemCollection Class

Glossary Item Box

A collection of custom item used by WebSlider.

Object Model

WebSliderItemCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSliderItemCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebSliderItem)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSliderItemCollection : ISNet.WebUI.ISGenericCollectionBase<WebSliderItem>
Delphi
public class WebSliderItemCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSliderItemCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSliderItemCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSliderItem>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSliderItemCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSliderItem>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebEssentials.WebSliderItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Members
ISNet.WebUI.WebEssentials Namespace


WebSliderItemCollection Class Members

[image]
Intersoft WebEssentials Documentation
WebSliderItemCollection Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderItemCollection Class

Glossary Item Box

The following tables list the members exposed by WebSliderItemCollection.

Public Constructors

 | Name | Description
Public Constructor | WebSliderItemCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSliderItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSliderItem>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSliderItem>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSliderItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebSliderItemCollection Class Methods

[image]
Intersoft WebEssentials Documentation
WebSliderItemCollection Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebSliderItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSliderItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSliderItem>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSliderItem>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSliderItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebSliderItemCollection Class Properties

[image]
Intersoft WebEssentials Documentation
WebSliderItemCollection Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebSliderItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSliderItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebSliderItemCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebSliderItemCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : WebSliderItemCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebSliderItemCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


WebSliderItemCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebSliderItemCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : WebSliderItemCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSliderItemCollection()
C#
public WebSliderItemCollection()
Delphi
public WebSliderItemCollection();
JScript
public function WebSliderItemCollection();
Managed Extensions for C++
public: WebSliderItemCollection();
C++/CLI
public:
WebSliderItemCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


Add Method

[image]
Intersoft WebEssentials Documentation
Add Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


Clear Method

[image]
Intersoft WebEssentials Documentation
Clear Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


Contains Method

[image]
Intersoft WebEssentials Documentation
Contains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


CopyTo Method

[image]
Intersoft WebEssentials Documentation
CopyTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


Count Property

[image]
Intersoft WebEssentials Documentation
Count Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


CreateNewItem Method

[image]
Intersoft WebEssentials Documentation
CreateNewItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebSliderItem
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim value As WebSliderItem

value = instance.CreateNewItem()
C#
public WebSliderItem CreateNewItem()
Delphi
public function CreateNewItem(): WebSliderItem;
JScript
public function CreateNewItem() : WebSliderItem;
Managed Extensions for C++
public: WebSliderItem* CreateNewItem();
C++/CLI
public:
WebSliderItem^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


GetEnumerator Method

[image]
Intersoft WebEssentials Documentation
GetEnumerator Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


GetNamedItem Method

[image]
Intersoft WebEssentials Documentation
GetNamedItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebSliderItem
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim name As System.String
Dim value As WebSliderItem

value = instance.GetNamedItem(name)
C#
public WebSliderItem GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebSliderItem;
JScript
public function GetNamedItem(
   name : System.String
) : WebSliderItem;
Managed Extensions for C++
public: WebSliderItem* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebSliderItem^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


IndexOf Method

[image]
Intersoft WebEssentials Documentation
IndexOf Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


Insert Method

[image]
Intersoft WebEssentials Documentation
Insert Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


Item Property

[image]
Intersoft WebEssentials Documentation
Item Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


Parent Property

[image]
Intersoft WebEssentials Documentation
Parent Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


Remove Method

[image]
Intersoft WebEssentials Documentation
Remove Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


RemoveAt Method

[image]
Intersoft WebEssentials Documentation
RemoveAt Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


SerializerConstructor Method

[image]
Intersoft WebEssentials Documentation
SerializerConstructor Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


SetParent Method

[image]
Intersoft WebEssentials Documentation
SetParent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItemCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItemCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItemCollection Class
WebSliderItemCollection Members


WebSliderItem Constructor

[image]
Intersoft WebEssentials Documentation
WebSliderItem Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class : WebSliderItem Constructor

Glossary Item Box

Overload List

Overload | Description
WebSliderItem Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members


WebSliderItem Constructor

[image]
Intersoft WebEssentials Documentation
WebSliderItem Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class : WebSliderItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSliderItem()
C#
public WebSliderItem()
Delphi
public WebSliderItem();
JScript
public function WebSliderItem();
Managed Extensions for C++
public: WebSliderItem();
C++/CLI
public:
WebSliderItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItem
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItem
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItem
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItem
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItem
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItem
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItem
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members


Name Property

[image]
Intersoft WebEssentials Documentation
Name Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.BrowsableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the name of WebSlider's item.")>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItem
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the name of WebSlider's item.")]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.BrowsableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the name of WebSlider's item.")
public override function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the name of WebSlider's item.")]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the name of WebSlider's item.")]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItem

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItem
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members


Text Property

[image]
Intersoft WebEssentials Documentation
Text Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class : Text Property

Glossary Item Box

Specifies the text of WebSlider's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of WebSlider's item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItem
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of WebSlider's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of WebSlider's item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of WebSlider's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of WebSlider's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItem
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members


Value Property

[image]
Intersoft WebEssentials Documentation
Value Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderItem Class : Value Property

Glossary Item Box

Specifies the value of WebSlider's item.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the value of WebSlider's item.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Value As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSliderItem
Dim value As System.Integer

instance.Value = value

value = instance.Value
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the value of WebSlider's item.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int Value {get; set;}
Delphi
public read-write property Value: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the value of WebSlider's item.")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set Value : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the value of WebSlider's item.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_Value();
public: __property void set_Value(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the value of WebSlider's item.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int Value {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderItem Class
WebSliderItem Members


WebSliderLabelAlignment Enumeration

[image]
Intersoft WebEssentials Documentation
WebSliderLabelAlignment Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderLabelAlignment Enumeration

Glossary Item Box

Specifies label alignment in WebSlider.

Syntax

Visual Basic (Declaration)
Public Enum WebSliderLabelAlignment
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSliderLabelAlignment
C#
public enum WebSliderLabelAlignment : System.Enum
Delphi
public enum WebSliderLabelAlignment = class(System.Enum)
JScript
public enum WebSliderLabelAlignment extends System.Enum
Managed Extensions for C++
__value public enum WebSliderLabelAlignment : public System.Enum
C++/CLI
public enum class WebSliderLabelAlignment : public System.Enum

Members

Member | Description
Left |
LeftAndRight |
Right |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebSliderLabelAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebSliderOrientation Enumeration

[image]
Intersoft WebEssentials Documentation
WebSliderOrientation Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderOrientation Enumeration

Glossary Item Box

Specifies WebSlider Orientation.

Syntax

Visual Basic (Declaration)
Public Enum WebSliderOrientation
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSliderOrientation
C#
public enum WebSliderOrientation : System.Enum
Delphi
public enum WebSliderOrientation = class(System.Enum)
JScript
public enum WebSliderOrientation extends System.Enum
Managed Extensions for C++
__value public enum WebSliderOrientation : public System.Enum
C++/CLI
public enum class WebSliderOrientation : public System.Enum

Members

Member | Description
Horizontal |
Vertical |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebSliderOrientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebSliderPresets Class

[image]
Intersoft WebEssentials Documentation
WebSliderPresets Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderPresets Class

Glossary Item Box

Object Model

WebSliderPresets Class

Syntax

Visual Basic (Declaration)
Public Class WebSliderPresets
Visual Basic (Usage) Copy Code
Dim instance As WebSliderPresets
C#
public class WebSliderPresets
Delphi
public class WebSliderPresets
JScript
public class WebSliderPresets
Managed Extensions for C++
public __gc class WebSliderPresets
C++/CLI
public ref class WebSliderPresets

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebEssentials.WebSliderPresets

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderPresets Members
ISNet.WebUI.WebEssentials Namespace


WebSliderPresets Class Members

[image]
Intersoft WebEssentials Documentation
WebSliderPresets Class Members
See Also Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderPresets Class

Glossary Item Box

The following tables list the members exposed by WebSliderPresets.

Public Constructors

 | Name | Description
Public Constructor | WebSliderPresets Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

WebSliderPresets Class
ISNet.WebUI.WebEssentials Namespace


WebSliderPresets Class Methods

[image]
Intersoft WebEssentials Documentation
WebSliderPresets Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderPresets Class

Glossary Item Box

For a list of all members of this type, see WebSliderPresets members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

WebSliderPresets Class
ISNet.WebUI.WebEssentials Namespace


WebSliderPresets Constructor

[image]
Intersoft WebEssentials Documentation
WebSliderPresets Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderPresets Class : WebSliderPresets Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSliderPresets()
C#
public WebSliderPresets()
Delphi
public WebSliderPresets();
JScript
public function WebSliderPresets();
Managed Extensions for C++
public: WebSliderPresets();
C++/CLI
public:
WebSliderPresets();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderPresets Class
WebSliderPresets Members


GetDefaultStyle Method

[image]
Intersoft WebEssentials Documentation
GetDefaultStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderPresets Class : GetDefaultStyle Method

Glossary Item Box

Overload List

Overload | Description
GetDefaultStyle |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderPresets Class
WebSliderPresets Members


GetDefaultStyle(WebSliderDefaultStyleMode,String) Method

[image]
Intersoft WebEssentials Documentation
GetDefaultStyle(WebSliderDefaultStyleMode,String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSliderPresets Class : GetDefaultStyle(WebSliderDefaultStyleMode,String) Method

mode
styleName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetDefaultStyle( _
   ByVal mode As WebSliderDefaultStyleMode, _
   ByVal styleName As System.String _
) As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim mode As WebSliderDefaultStyleMode
Dim styleName As System.String
Dim value As ISNet.WebUI.WebStyle

value = WebSliderPresets.GetDefaultStyle(mode, styleName)
C#
public static ISNet.WebUI.WebStyle GetDefaultStyle(
   WebSliderDefaultStyleMode mode,
   System.string styleName
)
Delphi
public function GetDefaultStyle(
    mode: WebSliderDefaultStyleMode;
    styleName: System.String
): ISNet.WebUI.WebStyle; static;
JScript
public static function GetDefaultStyle(
   mode : WebSliderDefaultStyleMode,
   styleName : System.String
) : ISNet.WebUI.WebStyle;
Managed Extensions for C++
public: static ISNet.WebUI.WebStyle* GetDefaultStyle(
   WebSliderDefaultStyleMode mode,
   System.string* styleName
)
C++/CLI
public:
static ISNet.WebUI.WebStyle^ GetDefaultStyle(
   WebSliderDefaultStyleMode mode,
   System.String^ styleName
)

Parameters

mode
styleName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSliderPresets Class
WebSliderPresets Members


WebSliderThumbsInteractionMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebSliderThumbsInteractionMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderThumbsInteractionMode Enumeration

Glossary Item Box

Specifies interaction mode of range WebSlider.

Syntax

Visual Basic (Declaration)
Public Enum WebSliderThumbsInteractionMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSliderThumbsInteractionMode
C#
public enum WebSliderThumbsInteractionMode : System.Enum
Delphi
public enum WebSliderThumbsInteractionMode = class(System.Enum)
JScript
public enum WebSliderThumbsInteractionMode extends System.Enum
Managed Extensions for C++
__value public enum WebSliderThumbsInteractionMode : public System.Enum
C++/CLI
public enum class WebSliderThumbsInteractionMode : public System.Enum

Members

Member | Description
Locked |
Push |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebSliderThumbsInteractionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebSliderType Enumeration

[image]
Intersoft WebEssentials Documentation
WebSliderType Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSliderType Enumeration

Glossary Item Box

Specifies type of WebSlider.

Syntax

Visual Basic (Declaration)
Public Enum WebSliderType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSliderType
C#
public enum WebSliderType : System.Enum
Delphi
public enum WebSliderType = class(System.Enum)
JScript
public enum WebSliderType extends System.Enum
Managed Extensions for C++
__value public enum WebSliderType : public System.Enum
C++/CLI
public enum class WebSliderType : public System.Enum

Members

Member | Description
Item |
None |
Tick |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebSliderType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebSlider Constructor

[image]
Intersoft WebEssentials Documentation
WebSlider Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : WebSlider Constructor

Glossary Item Box

Overload List

Overload | Description
WebSlider Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


WebSlider Constructor

[image]
Intersoft WebEssentials Documentation
WebSlider Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : WebSlider Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlider()
C#
public WebSlider()
Delphi
public WebSlider();
JScript
public function WebSlider();
Managed Extensions for C++
public: WebSlider();
C++/CLI
public:
WebSlider();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


AccessKey Property

[image]
Intersoft WebEssentials Documentation
AccessKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set AccessKey : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


AllowDefaultStyleMerging Property

[image]
Intersoft WebEssentials Documentation
AllowDefaultStyleMerging Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : AllowDefaultStyleMerging Property

Glossary Item Box

Gets or sets the value that determines whether or not the default style can be merged with custom styles.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AllowDefaultStyleMerging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

instance.AllowDefaultStyleMerging = value

value = instance.AllowDefaultStyleMerging
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool AllowDefaultStyleMerging {get; set;}
Delphi
public read-write property AllowDefaultStyleMerging: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set AllowDefaultStyleMerging : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_AllowDefaultStyleMerging();
public: __property void set_AllowDefaultStyleMerging(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool AllowDefaultStyleMerging {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ApplyStyle Method

[image]
Intersoft WebEssentials Documentation
ApplyStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebEssentials Documentation
ApplyStyleSheetSkin Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


CanUseWebResources Method

[image]
Intersoft WebEssentials Documentation
CanUseWebResources Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.CanUseWebResources()
C#
public System.bool CanUseWebResources()
Delphi
public function CanUseWebResources(): System.Boolean;
JScript
public function CanUseWebResources() : System.boolean;
Managed Extensions for C++
public: System.bool CanUseWebResources();
C++/CLI
public:
System.bool CanUseWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


CheckConstrains Method

[image]
Intersoft WebEssentials Documentation
CheckConstrains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebSlider

instance.CheckConstrains()
C#
public override void CheckConstrains()
Delphi
public procedure CheckConstrains(); override;
JScript
public override function CheckConstrains();
Managed Extensions for C++
public: void CheckConstrains(); override
C++/CLI
public:
void CheckConstrains(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ClientIDMode Property

[image]
Intersoft WebEssentials Documentation
ClientIDMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ClientSideEvents Property

[image]
Intersoft WebEssentials Documentation
ClientSideEvents Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ClientSideEvents Property

Glossary Item Box

Contains client side events supported by WebSlider.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSlider.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ClientSideEvents As WebSliderClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As WebSliderClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSlider.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebSliderClientSideEvents ClientSideEvents {get; set;}
Delphi
public read-write property ClientSideEvents: WebSliderClientSideEvents;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSlider.")
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ClientSideEvents : WebSliderClientSideEvents
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSlider.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebSliderClientSideEvents* get_ClientSideEvents();
public: __property void set_ClientSideEvents(
   WebSliderClientSideEvents* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSlider.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebSliderClientSideEvents^ ClientSideEvents {
   WebSliderClientSideEvents^ get();
   void set (    WebSliderClientSideEvents^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ControlDataTransferFormat Property

[image]
Intersoft WebEssentials Documentation
ControlDataTransferFormat Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


CopyBaseAttributes Method

[image]
Intersoft WebEssentials Documentation
CopyBaseAttributes Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members
Overload List


DataBind Method

[image]
Intersoft WebEssentials Documentation
DataBind Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


DataBind() Method

[image]
Intersoft WebEssentials Documentation
DataBind() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebSlider

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


DataBinding Event

[image]
Intersoft WebEssentials Documentation
DataBinding Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


DefaultStyleMode Property

[image]
Intersoft WebEssentials Documentation
DefaultStyleMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : DefaultStyleMode Property

Glossary Item Box

Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DefaultStyleMode As WebSliderDefaultStyleMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As WebSliderDefaultStyleMode

instance.DefaultStyleMode = value

value = instance.DefaultStyleMode
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebSliderDefaultStyleMode DefaultStyleMode {get; set;}
Delphi
public read-write property DefaultStyleMode: WebSliderDefaultStyleMode;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DefaultStyleMode : WebSliderDefaultStyleMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebSliderDefaultStyleMode get_DefaultStyleMode();
public: __property void set_DefaultStyleMode(
   WebSliderDefaultStyleMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebSliderDefaultStyleMode DefaultStyleMode {
   WebSliderDefaultStyleMode get();
   void set (    WebSliderDefaultStyleMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Direction Property

[image]
Intersoft WebEssentials Documentation
Direction Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Direction Property

Glossary Item Box

Specifies WebSlider direction.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies WebSlider direction.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Direction As WebSliderDirection
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As WebSliderDirection

instance.Direction = value

value = instance.Direction
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies WebSlider direction.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebSliderDirection Direction {get; set;}
Delphi
public read-write property Direction: WebSliderDirection;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies WebSlider direction.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Direction : WebSliderDirection
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies WebSlider direction.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebSliderDirection get_Direction();
public: __property void set_Direction(
   WebSliderDirection value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies WebSlider direction.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebSliderDirection Direction {
   WebSliderDirection get();
   void set (    WebSliderDirection value);
}

Property Value

The default value is LeftToRight.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Dispose Method

[image]
Intersoft WebEssentials Documentation
Dispose Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebSlider

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Disposed Event

[image]
Intersoft WebEssentials Documentation
Disposed Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


EnableManagedTheming Property

[image]
Intersoft WebEssentials Documentation
EnableManagedTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable Property EnableManagedTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableManagedTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.bool EnableManagedTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


EnableRange Property

[image]
Intersoft WebEssentials Documentation
EnableRange Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : EnableRange Property

Glossary Item Box

Determines whether or not range value should be enabled in WebSlider.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether or not range value should be enabled in WebSlider.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EnableRange As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

instance.EnableRange = value

value = instance.EnableRange
C#
[System.ComponentModel.DescriptionAttribute("Determines whether or not range value should be enabled in WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool EnableRange {get; set;}
Delphi
public read-write property EnableRange: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether or not range value should be enabled in WebSlider.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableRange : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether or not range value should be enabled in WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_EnableRange();
public: __property void set_EnableRange(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether or not range value should be enabled in WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool EnableRange {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


EnableTheming Property

[image]
Intersoft WebEssentials Documentation
EnableTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


EnableViewState Property

[image]
Intersoft WebEssentials Documentation
EnableViewState Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


EnableWebResources Property

[image]
Intersoft WebEssentials Documentation
EnableWebResources Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Web Resources")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Web Resources")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


EndValue Property

[image]
Intersoft WebEssentials Documentation
EndValue Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : EndValue Property

Glossary Item Box

Specifies the end range value of WebSlider.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the end range value of WebSlider.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EndValue As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Integer

instance.EndValue = value

value = instance.EndValue
C#
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the end range value of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int EndValue {get; set;}
Delphi
public read-write property EndValue: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the end range value of WebSlider.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EndValue : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the end range value of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_EndValue();
public: __property void set_EndValue(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the end range value of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int EndValue {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 100.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


FindControl Method

[image]
Intersoft WebEssentials Documentation
FindControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


FindControl(String) Method

[image]
Intersoft WebEssentials Documentation
FindControl(String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Focus Method

[image]
Intersoft WebEssentials Documentation
Focus Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebSlider

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ForceDisableXmlCompression Method

[image]
Intersoft WebEssentials Documentation
ForceDisableXmlCompression Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebSlider

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


FrameStyle Property

[image]
Intersoft WebEssentials Documentation
FrameStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : FrameStyle Property

Glossary Item Box

Contains interactive style for Frame.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle FrameStyle {get; set;}
Delphi
public read-write property FrameStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")
System.ComponentModel.CategoryAttribute("Style")
public function get,set FrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_FrameStyle();
public: __property void set_FrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ FrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetClientAction Method

[image]
Intersoft WebEssentials Documentation
GetClientAction Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebEssentials Documentation
GetCurrentControlLifeCycle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetCurrentTheme Method

[image]
Intersoft WebEssentials Documentation
GetCurrentTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetFrameworkDataFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkDataFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

value = instance.GetFrameworkDataFolder()
C#
public System.string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): System.String;
JScript
public function GetFrameworkDataFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkDataFolder();
C++/CLI
public:
System.String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetFrameworkFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

value = instance.GetFrameworkFolder()
C#
public System.string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): System.String;
JScript
public function GetFrameworkFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkFolder();
C++/CLI
public:
System.String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetFrameworkVersion Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkVersion Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Version

value = instance.GetFrameworkVersion()
C#
public System.Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): System.Version;
JScript
public function GetFrameworkVersion() : System.Version;
Managed Extensions for C++
public: System.Version* GetFrameworkVersion();
C++/CLI
public:
System.Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetImageName Method

[image]
Intersoft WebEssentials Documentation
GetImageName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetImageName Method

imageType

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetImageName( _
   ByVal imageType As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim imageType As System.String
Dim value As System.String

value = instance.GetImageName(imageType)
C#
public System.string GetImageName(
   System.string imageType
)
Delphi
public function GetImageName(
    imageType: System.String
): System.String;
JScript
public function GetImageName(
   imageType : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetImageName(
   System.string* imageType
)
C++/CLI
public:
System.String^ GetImageName(
   System.String^ imageType
)

Parameters

imageType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetIntersoftFolder Method

[image]
Intersoft WebEssentials Documentation
GetIntersoftFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

value = instance.GetIntersoftFolder()
C#
public System.string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): System.String;
JScript
public function GetIntersoftFolder() : System.String;
Managed Extensions for C++
public: System.string* GetIntersoftFolder();
C++/CLI
public:
System.String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetLayoutFolder Method

[image]
Intersoft WebEssentials Documentation
GetLayoutFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

value = instance.GetLayoutFolder()
C#
public System.string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): System.String;
JScript
public function GetLayoutFolder() : System.String;
Managed Extensions for C++
public: System.string* GetLayoutFolder();
C++/CLI
public:
System.String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetPostedXMLData Method

[image]
Intersoft WebEssentials Documentation
GetPostedXMLData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

value = instance.GetPostedXMLData()
C#
public System.string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): System.String;
JScript
public function GetPostedXMLData() : System.String;
Managed Extensions for C++
public: System.string* GetPostedXMLData();
C++/CLI
public:
System.String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetProductInfoKey Method

[image]
Intersoft WebEssentials Documentation
GetProductInfoKey Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

value = instance.GetProductInfoKey()
C#
public System.string GetProductInfoKey()
Delphi
public function GetProductInfoKey(): System.String;
JScript
public function GetProductInfoKey() : System.String;
Managed Extensions for C++
public: System.string* GetProductInfoKey();
C++/CLI
public:
System.String^ GetProductInfoKey();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetProductSimpleName Method

[image]
Intersoft WebEssentials Documentation
GetProductSimpleName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

value = instance.GetProductSimpleName()
C#
public System.string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): System.String;
JScript
public function GetProductSimpleName() : System.String;
Managed Extensions for C++
public: System.string* GetProductSimpleName();
C++/CLI
public:
System.String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetPropertyValue Method

[image]
Intersoft WebEssentials Documentation
GetPropertyValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As System.String, _
   ByVal propValue As System.String, _
   ByVal webConfigKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim defValue As System.String
Dim propValue As System.String
Dim webConfigKey As System.String
Dim value As System.String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public System.string GetPropertyValue(
   System.string defValue,
   System.string propValue,
   System.string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: System.String;
    propValue: System.String;
    webConfigKey: System.String
): System.String;
JScript
public function GetPropertyValue(
   defValue : System.String,
   propValue : System.String,
   webConfigKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetPropertyValue(
   System.string* defValue,
   System.string* propValue,
   System.string* webConfigKey
)
C++/CLI
public:
System.String^ GetPropertyValue(
   System.String^ defValue,
   System.String^ propValue,
   System.String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetResourceStream Method

[image]
Intersoft WebEssentials Documentation
GetResourceStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As System.String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim resourceUrl As System.String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   System.string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: System.String
): System.IO.Stream;
JScript
public function GetResourceStream(
   resourceUrl : System.String
) : System.IO.Stream;
Managed Extensions for C++
public: System.IO.Stream* GetResourceStream(
   System.string* resourceUrl
)
C++/CLI
public:
System.IO.Stream^ GetResourceStream(
   System.String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetRouteUrl Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


GetRouteUrl(Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebEssentials Documentation
GetUniqueIDRelativeTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


HasControls Method

[image]
Intersoft WebEssentials Documentation
HasControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Height Property

[image]
Intersoft WebEssentials Documentation
Height Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Overrides Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
public override System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; override;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
public override function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.Web.UI.WebControls.Unit get_Height() override;
public: __property void set_Height(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ID Property

[image]
Intersoft WebEssentials Documentation
ID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ImagesDirectory Property

[image]
Intersoft WebEssentials Documentation
ImagesDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the images directory.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ImagesDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ImagesDirectory {get; set;}
Delphi
public read-write property ImagesDirectory: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ImagesDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ImagesDirectory();
public: __property void set_ImagesDirectory(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ImagesDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ImagesSettings Property

[image]
Intersoft WebEssentials Documentation
ImagesSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ImagesSettings Property

Glossary Item Box

Provides the settings that control the images in WebSlider.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSlider.")>
Public ReadOnly Property ImagesSettings As WebSliderImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As WebSliderImagesSettings

value = instance.ImagesSettings
C#
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSlider.")]
public WebSliderImagesSettings ImagesSettings {get;}
Delphi
public read-only property ImagesSettings: WebSliderImagesSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSlider.")
public function get ImagesSettings : WebSliderImagesSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSlider.")]
public: __property WebSliderImagesSettings* get_ImagesSettings();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSlider.")]
public:
property WebSliderImagesSettings^ ImagesSettings {
   WebSliderImagesSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Init Event

[image]
Intersoft WebEssentials Documentation
Init Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


IsAtlasCallback Method

[image]
Intersoft WebEssentials Documentation
IsAtlasCallback Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.IsAtlasCallback()
C#
public System.bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): System.Boolean;
JScript
public function IsAtlasCallback() : System.boolean;
Managed Extensions for C++
public: System.bool IsAtlasCallback();
C++/CLI
public:
System.bool IsAtlasCallback();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


IsBetaRelease Method

[image]
Intersoft WebEssentials Documentation
IsBetaRelease Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.IsBetaRelease()
C#
public System.bool IsBetaRelease()
Delphi
public function IsBetaRelease(): System.Boolean;
JScript
public function IsBetaRelease() : System.boolean;
Managed Extensions for C++
public: System.bool IsBetaRelease();
C++/CLI
public:
System.bool IsBetaRelease();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


IsChromeBrowser Method

[image]
Intersoft WebEssentials Documentation
IsChromeBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.IsChromeBrowser()
C#
public System.bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): System.Boolean;
JScript
public function IsChromeBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsChromeBrowser();
C++/CLI
public:
System.bool IsChromeBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


IsFlyPostBackControl Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual System.bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): System.Boolean; virtual;
JScript
public function IsFlyPostBackControl() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackControl();
C++/CLI
public:
virtual System.bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


IsFlyPostBackRequest Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackRequest Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual System.bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): System.Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackRequest();
C++/CLI
public:
virtual System.bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebEssentials Documentation
IsGeckoBasedBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.IsGeckoBasedBrowser()
C#
public System.bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): System.Boolean;
JScript
public function IsGeckoBasedBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoBasedBrowser();
C++/CLI
public:
System.bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


IsGeckoVersion18 Method

[image]
Intersoft WebEssentials Documentation
IsGeckoVersion18 Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.IsGeckoVersion18()
C#
public System.bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): System.Boolean;
JScript
public function IsGeckoVersion18() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoVersion18();
C++/CLI
public:
System.bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


IsInDesignMode Method

[image]
Intersoft WebEssentials Documentation
IsInDesignMode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.IsInDesignMode()
C#
public System.bool IsInDesignMode()
Delphi
public function IsInDesignMode(): System.Boolean;
JScript
public function IsInDesignMode() : System.boolean;
Managed Extensions for C++
public: System.bool IsInDesignMode();
C++/CLI
public:
System.bool IsInDesignMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorer8Browser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.IsInternetExplorer8Browser()
C#
public System.bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): System.Boolean;
JScript
public function IsInternetExplorer8Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer8Browser();
C++/CLI
public:
System.bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorerBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.IsInternetExplorerBrowser()
C#
public System.bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): System.Boolean;
JScript
public function IsInternetExplorerBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorerBrowser();
C++/CLI
public:
System.bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


IsOperaBrowser Method

[image]
Intersoft WebEssentials Documentation
IsOperaBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.IsOperaBrowser()
C#
public System.bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): System.Boolean;
JScript
public function IsOperaBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsOperaBrowser();
C++/CLI
public:
System.bool IsOperaBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


IsSafariBrowser Method

[image]
Intersoft WebEssentials Documentation
IsSafariBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.IsSafariBrowser()
C#
public System.bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): System.Boolean;
JScript
public function IsSafariBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsSafariBrowser();
C++/CLI
public:
System.bool IsSafariBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


IsW3CStandardBrowser Method

[image]
Intersoft WebEssentials Documentation
IsW3CStandardBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.IsW3CStandardBrowser()
C#
public System.bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): System.Boolean;
JScript
public function IsW3CStandardBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsW3CStandardBrowser();
C++/CLI
public:
System.bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Items Property

[image]
Intersoft WebEssentials Documentation
Items Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Items Property

Glossary Item Box

The item collection used by WebSlider.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setItems")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The item collection used by WebSlider.")>
Public ReadOnly Property Items As WebSliderItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As WebSliderItemCollection

value = instance.Items
C#
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The item collection used by WebSlider.")]
public WebSliderItemCollection Items {get;}
Delphi
public read-only property Items: WebSliderItemCollection;
JScript
ISNet.Serialization.BinarySerializableAttribute("setItems")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("The item collection used by WebSlider.")
public function get Items : WebSliderItemCollection
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The item collection used by WebSlider.")]
public: __property WebSliderItemCollection* get_Items();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The item collection used by WebSlider.")]
public:
property WebSliderItemCollection^ Items {
   WebSliderItemCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


LabelStyle Property

[image]
Intersoft WebEssentials Documentation
LabelStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : LabelStyle Property

Glossary Item Box

Contains interactive style for WebSlider label.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for WebSlider label.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property LabelStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As ISNet.WebUI.WebStyle

instance.LabelStyle = value

value = instance.LabelStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebSlider label.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle LabelStyle {get; set;}
Delphi
public read-write property LabelStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for WebSlider label.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.DefaultValueAttribute()
public function get,set LabelStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebSlider label.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_LabelStyle();
public: __property void set_LabelStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for WebSlider label.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ LabelStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


LargeStepValue Property

[image]
Intersoft WebEssentials Documentation
LargeStepValue Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : LargeStepValue Property

Glossary Item Box

Specifies the large step value of WebSlider.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the large step value of WebSlider.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property LargeStepValue As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Integer

instance.LargeStepValue = value

value = instance.LargeStepValue
C#
[System.ComponentModel.DescriptionAttribute("Specifies the large step value of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.int LargeStepValue {get; set;}
Delphi
public read-write property LargeStepValue: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the large step value of WebSlider.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set LargeStepValue : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the large step value of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_LargeStepValue();
public: __property void set_LargeStepValue(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the large step value of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int LargeStepValue {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Load Event

[image]
Intersoft WebEssentials Documentation
Load Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


LoadLayout Method

[image]
Intersoft WebEssentials Documentation
LoadLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


LoadLayoutFromFile Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim filePath As System.String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   System.string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: System.String
); virtual;
JScript
public function LoadLayoutFromFile(
   filePath : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromFile(
   System.string* filePath
)
C++/CLI
public:
virtual void LoadLayoutFromFile(
   System.String^ filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromPredefinedName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim predefinedName As System.String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   System.string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: System.String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   System.string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   System.String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


LoadLayoutFromStream Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: System.IO.Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   System.IO.Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


LoadPostData Method

[image]
Intersoft WebEssentials Documentation
LoadPostData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function LoadPostData( _
   ByVal postDataKey As System.String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim postDataKey As System.String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As System.Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public virtual System.bool LoadPostData(
   System.string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)
Delphi
public function LoadPostData(
    postDataKey: System.String;
    postCollection: System.Collections.Specialized.NameValueCollection
): System.Boolean; virtual;
JScript
public function LoadPostData(
   postDataKey : System.String,
   postCollection : System.Collections.Specialized.NameValueCollection
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool LoadPostData(
   System.string* postDataKey,
   System.Collections.Specialized.NameValueCollection* postCollection
)
C++/CLI
public:
virtual System.bool LoadPostData(
   System.String^ postDataKey,
   System.Collections.Specialized.NameValueCollection^ postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


MaximumValue Property

[image]
Intersoft WebEssentials Documentation
MaximumValue Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : MaximumValue Property

Glossary Item Box

Specifies the end value of WebSlider.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the end value of WebSlider.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MaximumValue As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Integer

instance.MaximumValue = value

value = instance.MaximumValue
C#
[System.ComponentModel.DescriptionAttribute("Specifies the end value of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int MaximumValue {get; set;}
Delphi
public read-write property MaximumValue: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the end value of WebSlider.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set MaximumValue : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the end value of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_MaximumValue();
public: __property void set_MaximumValue(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the end value of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int MaximumValue {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 100.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


MergeStyle Method

[image]
Intersoft WebEssentials Documentation
MergeStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


MinimumValue Property

[image]
Intersoft WebEssentials Documentation
MinimumValue Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : MinimumValue Property

Glossary Item Box

Specifies the start value of WebSlider.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the start value of WebSlider.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MinimumValue As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Integer

instance.MinimumValue = value

value = instance.MinimumValue
C#
[System.ComponentModel.DescriptionAttribute("Specifies the start value of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int MinimumValue {get; set;}
Delphi
public read-write property MinimumValue: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the start value of WebSlider.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set MinimumValue : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the start value of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_MinimumValue();
public: __property void set_MinimumValue(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the start value of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int MinimumValue {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


OnInfoChanged Method

[image]
Intersoft WebEssentials Documentation
OnInfoChanged Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


OnPreInitialize Method

[image]
Intersoft WebEssentials Documentation
OnPreInitialize Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebSlider

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Orientation Property

[image]
Intersoft WebEssentials Documentation
Orientation Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Orientation Property

Glossary Item Box

Specifies WebSlider orientation.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies WebSlider orientation.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Orientation As WebSliderOrientation
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As WebSliderOrientation

instance.Orientation = value

value = instance.Orientation
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies WebSlider orientation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebSliderOrientation Orientation {get; set;}
Delphi
public read-write property Orientation: WebSliderOrientation;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies WebSlider orientation.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Orientation : WebSliderOrientation
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies WebSlider orientation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebSliderOrientation get_Orientation();
public: __property void set_Orientation(
   WebSliderOrientation value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies WebSlider orientation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebSliderOrientation Orientation {
   WebSliderOrientation get();
   void set (    WebSliderOrientation value);
}

Property Value

The default value is Horizontal.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Page Property

[image]
Intersoft WebEssentials Documentation
Page Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}
Delphi
public read-write property Page: System.Web.UI.Page; virtual;
JScript
public function get,set Page : System.Web.UI.Page
Managed Extensions for C++
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
C++/CLI
public:
virtual property System.Web.UI.Page^ Page {
   System.Web.UI.Page^ get();
   void set (    System.Web.UI.Page^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


PreInitialize Event

[image]
Intersoft WebEssentials Documentation
PreInitialize Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim handler As System.EventHandler

AddHandler instance.PreInitialize, handler
C#
public event System.EventHandler PreInitialize
Delphi
public event PreInitialize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* PreInitialize
C++/CLI
public:
event System.EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


PreRender Event

[image]
Intersoft WebEssentials Documentation
PreRender Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebEssentials Documentation
RaisePostDataChangedEvent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebSlider

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); virtual;
JScript
public function RaisePostDataChangedEvent();
Managed Extensions for C++
public: virtual void RaisePostDataChangedEvent();
C++/CLI
public:
virtual void RaisePostDataChangedEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ReadWebConfigValue Method

[image]
Intersoft WebEssentials Documentation
ReadWebConfigValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim key As System.String
Dim value As System.String

value = instance.ReadWebConfigValue(key)
C#
public System.string ReadWebConfigValue(
   System.string key
)
Delphi
public function ReadWebConfigValue(
    key: System.String
): System.String;
JScript
public function ReadWebConfigValue(
   key : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ReadWebConfigValue(
   System.string* key
)
C++/CLI
public:
System.String^ ReadWebConfigValue(
   System.String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RecreateChildControls Method

[image]
Intersoft WebEssentials Documentation
RecreateChildControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebSlider

instance.RecreateChildControls()
C#
public void RecreateChildControls()
Delphi
public procedure RecreateChildControls();
JScript
public function RecreateChildControls();
Managed Extensions for C++
public: void RecreateChildControls();
C++/CLI
public:
void RecreateChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RegisterBoxSizing Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RegisterBoxSizing() Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebSlider

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim forceAll As System.Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   System.bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: System.Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : System.boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   System.bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   System.bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebEssentials Documentation
RegisterGlobalStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RegisterLink Method

[image]
Intersoft WebEssentials Documentation
RegisterLink Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As System.String, _
   ByVal url As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim name As System.String
Dim url As System.String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   System.string name,
   System.string url
)
Delphi
public procedure RegisterLink(
    name: System.String;
    url: System.String
);
JScript
public function RegisterLink(
   name : System.String,
   url : System.String
);
Managed Extensions for C++
public: void RegisterLink(
   System.string* name,
   System.string* url
)
C++/CLI
public:
void RegisterLink(
   System.String^ name,
   System.String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebEssentials Documentation
RegisterOptimizedCssClasses Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim runtimeStyleOnly As System.Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: System.Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : System.boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RegisterPreloadImage Method

[image]
Intersoft WebEssentials Documentation
RegisterPreloadImage Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim image As System.String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   System.string image
)
Delphi
public procedure RegisterPreloadImage(
    image: System.String
);
JScript
public function RegisterPreloadImage(
   image : System.String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   System.string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   System.String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RegisterScript Method

[image]
Intersoft WebEssentials Documentation
RegisterScript Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebSlider

instance.RegisterScript()
C#
public override void RegisterScript()
Delphi
public procedure RegisterScript(); override;
JScript
public override function RegisterScript();
Managed Extensions for C++
public: void RegisterScript(); override
C++/CLI
public:
void RegisterScript(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RegisterSharePointHandler Method

[image]
Intersoft WebEssentials Documentation
RegisterSharePointHandler Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebSlider

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RenderBeginTag Method

[image]
Intersoft WebEssentials Documentation
RenderBeginTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RenderControl Method

[image]
Intersoft WebEssentials Documentation
RenderControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebEssentials Documentation
RenderControl(HtmlTextWriter) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RenderEndTag Method

[image]
Intersoft WebEssentials Documentation
RenderEndTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RenderingMode Property

[image]
Intersoft WebEssentials Documentation
RenderingMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSlider

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ResolveClientUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveClientUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ResolveImagePath Method

[image]
Intersoft WebEssentials Documentation
ResolveImagePath Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As System.String, _
   ByVal image As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim folder As System.String
Dim image As System.String
Dim value As System.String

value = instance.ResolveImagePath(folder, image)
C#
public System.string ResolveImagePath(
   System.string folder,
   System.string image
)
Delphi
public function ResolveImagePath(
    folder: System.String;
    image: System.String
): System.String;
JScript
public function ResolveImagePath(
   folder : System.String,
   image : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveImagePath(
   System.string* folder,
   System.string* image
)
C++/CLI
public:
System.String^ ResolveImagePath(
   System.String^ folder,
   System.String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ResolveRelativeURL Method

[image]
Intersoft WebEssentials Documentation
ResolveRelativeURL Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim url As System.String
Dim value As System.String

value = instance.ResolveRelativeURL(url)
C#
public virtual System.string ResolveRelativeURL(
   System.string url
)
Delphi
public function ResolveRelativeURL(
    url: System.String
): System.String; virtual;
JScript
public function ResolveRelativeURL(
   url : System.String
) : System.String;
Managed Extensions for C++
public: virtual System.string* ResolveRelativeURL(
   System.string* url
)
C++/CLI
public:
virtual System.String^ ResolveRelativeURL(
   System.String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ResolveResourceUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveResourceUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As System.String, _
   ByVal currentFolder As System.String, _
   ByVal resourceName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As System.String
Dim currentFolder As System.String
Dim resourceName As System.String
Dim value As System.String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public System.string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string defaultFolder,
   System.string currentFolder,
   System.string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: System.String;
    currentFolder: System.String;
    resourceName: System.String
): System.String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : System.String,
   currentFolder : System.String,
   resourceName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string* defaultFolder,
   System.string* currentFolder,
   System.string* resourceName
)
C++/CLI
public:
System.String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.String^ defaultFolder,
   System.String^ currentFolder,
   System.String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ResolveUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


RuntimeLicenseKey Property

[image]
Intersoft WebEssentials Documentation
RuntimeLicenseKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
Public Overridable Property RuntimeLicenseKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public virtual System.string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: System.String; virtual;
JScript
ISNet.PersistLayoutAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
public function get,set RuntimeLicenseKey : System.String
Managed Extensions for C++
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public: __property virtual System.string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   System.string* value
);
C++/CLI
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public:
virtual property System.String^ RuntimeLicenseKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


SaveLayout Method

[image]
Intersoft WebEssentials Documentation
SaveLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


SaveLayoutToFile Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim filePath As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   System.string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   System.string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   System.String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


SaveLayoutToStream Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
ScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
Public Overrides Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public override System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String; override;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Client Script Directory")
public override function get,set ScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public: __property System.string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public:
property System.String^ ScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


SetRenderMethodDelegate Method

[image]
Intersoft WebEssentials Documentation
SetRenderMethodDelegate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


SetSessionTheme Method

[image]
Intersoft WebEssentials Documentation
SetSessionTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


SharedScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
SharedScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required framework scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
Public Overrides Property SharedScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public override System.string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: System.String; override;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
public override function get,set SharedScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public: __property System.string* get_SharedScriptDirectory() override;
public: __property void set_SharedScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public:
property System.String^ SharedScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ShouldReturnJson Method

[image]
Intersoft WebEssentials Documentation
ShouldReturnJson Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

value = instance.ShouldReturnJson()
C#
public virtual System.bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): System.Boolean; virtual;
JScript
public function ShouldReturnJson() : System.boolean;
Managed Extensions for C++
public: virtual System.bool ShouldReturnJson();
C++/CLI
public:
virtual System.bool ShouldReturnJson();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ShowSliderRail Property

[image]
Intersoft WebEssentials Documentation
ShowSliderRail Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ShowSliderRail Property

Glossary Item Box

Determines whether or not WebSlider rail is shown.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider rail is shown.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ShowSliderRail As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

instance.ShowSliderRail = value

value = instance.ShowSliderRail
C#
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider rail is shown.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool ShowSliderRail {get; set;}
Delphi
public read-write property ShowSliderRail: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider rail is shown.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set ShowSliderRail : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider rail is shown.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_ShowSliderRail();
public: __property void set_ShowSliderRail(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider rail is shown.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool ShowSliderRail {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ShowValueInTooltip Property

[image]
Intersoft WebEssentials Documentation
ShowValueInTooltip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ShowValueInTooltip Property

Glossary Item Box

Determines whether or not WebSlider value appear in Tooltip.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider value appear in Tooltip.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ShowValueInTooltip As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

instance.ShowValueInTooltip = value

value = instance.ShowValueInTooltip
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider value appear in Tooltip.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool ShowValueInTooltip {get; set;}
Delphi
public read-write property ShowValueInTooltip: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider value appear in Tooltip.")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set ShowValueInTooltip : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider value appear in Tooltip.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_ShowValueInTooltip();
public: __property void set_ShowValueInTooltip(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider value appear in Tooltip.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool ShowValueInTooltip {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


SkinID Property

[image]
Intersoft WebEssentials Documentation
SkinID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


SliderLabelAlignment Property

[image]
Intersoft WebEssentials Documentation
SliderLabelAlignment Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : SliderLabelAlignment Property

Glossary Item Box

Specifies slider step value alignment.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies slider step value alignment.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property SliderLabelAlignment As WebSliderLabelAlignment
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As WebSliderLabelAlignment

instance.SliderLabelAlignment = value

value = instance.SliderLabelAlignment
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies slider step value alignment.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebSliderLabelAlignment SliderLabelAlignment {get; set;}
Delphi
public read-write property SliderLabelAlignment: WebSliderLabelAlignment;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies slider step value alignment.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set SliderLabelAlignment : WebSliderLabelAlignment
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies slider step value alignment.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebSliderLabelAlignment get_SliderLabelAlignment();
public: __property void set_SliderLabelAlignment(
   WebSliderLabelAlignment value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies slider step value alignment.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebSliderLabelAlignment SliderLabelAlignment {
   WebSliderLabelAlignment get();
   void set (    WebSliderLabelAlignment value);
}

Property Value

The default value is LeftAndRight.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


SliderType Property

[image]
Intersoft WebEssentials Documentation
SliderType Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : SliderType Property

Glossary Item Box

Determines type of WebSlider.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determines type of WebSlider.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property SliderType As WebSliderType
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As WebSliderType

instance.SliderType = value

value = instance.SliderType
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines type of WebSlider.")]
[System.ComponentModel.CategoryAttribute("General")]
public WebSliderType SliderType {get; set;}
Delphi
public read-write property SliderType: WebSliderType;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determines type of WebSlider.")
System.ComponentModel.CategoryAttribute("General")
public function get,set SliderType : WebSliderType
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines type of WebSlider.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property WebSliderType get_SliderType();
public: __property void set_SliderType(
   WebSliderType value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines type of WebSlider.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property WebSliderType SliderType {
   WebSliderType get();
   void set (    WebSliderType value);
}

Property Value

The default value is None.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


StartValue Property

[image]
Intersoft WebEssentials Documentation
StartValue Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : StartValue Property

Glossary Item Box

Specifies the start range value of WebSlider.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the start range value of WebSlider.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property StartValue As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Integer

instance.StartValue = value

value = instance.StartValue
C#
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the start range value of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int StartValue {get; set;}
Delphi
public read-write property StartValue: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the start range value of WebSlider.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set StartValue : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the start range value of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_StartValue();
public: __property void set_StartValue(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the start range value of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int StartValue {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 0.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


StepValue Property

[image]
Intersoft WebEssentials Documentation
StepValue Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : StepValue Property

Glossary Item Box

Specifies the step value of WebSlider.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the step value of WebSlider.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property StepValue As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Integer

instance.StepValue = value

value = instance.StepValue
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the step value of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int StepValue {get; set;}
Delphi
public read-write property StepValue: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the step value of WebSlider.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set StepValue : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the step value of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_StepValue();
public: __property void set_StepValue(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the step value of WebSlider.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int StepValue {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


TabIndex Property

[image]
Intersoft WebEssentials Documentation
TabIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set TabIndex : System.short
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ThumbsInteractionMode Property

[image]
Intersoft WebEssentials Documentation
ThumbsInteractionMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ThumbsInteractionMode Property

Glossary Item Box

Determines thumbs interaction mode of WebSlider.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determines thumbs interaction mode of WebSlider.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property ThumbsInteractionMode As WebSliderThumbsInteractionMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As WebSliderThumbsInteractionMode

instance.ThumbsInteractionMode = value

value = instance.ThumbsInteractionMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines thumbs interaction mode of WebSlider.")]
[System.ComponentModel.CategoryAttribute("General")]
public WebSliderThumbsInteractionMode ThumbsInteractionMode {get; set;}
Delphi
public read-write property ThumbsInteractionMode: WebSliderThumbsInteractionMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determines thumbs interaction mode of WebSlider.")
System.ComponentModel.CategoryAttribute("General")
public function get,set ThumbsInteractionMode : WebSliderThumbsInteractionMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines thumbs interaction mode of WebSlider.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property WebSliderThumbsInteractionMode get_ThumbsInteractionMode();
public: __property void set_ThumbsInteractionMode(
   WebSliderThumbsInteractionMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines thumbs interaction mode of WebSlider.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property WebSliderThumbsInteractionMode ThumbsInteractionMode {
   WebSliderThumbsInteractionMode get();
   void set (    WebSliderThumbsInteractionMode value);
}

Property Value

The default value is Locked.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ToolTip Property

[image]
Intersoft WebEssentials Documentation
ToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Unload Event

[image]
Intersoft WebEssentials Documentation
Unload Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


UseCustomImages Property

[image]
Intersoft WebEssentials Documentation
UseCustomImages Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : UseCustomImages Property

Glossary Item Box

Gets or sets the value that determines whether or not WebSlider use images that specified by user.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebSlider use images that specify by user.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property UseCustomImages As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

instance.UseCustomImages = value

value = instance.UseCustomImages
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebSlider use images that specify by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool UseCustomImages {get; set;}
Delphi
public read-write property UseCustomImages: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebSlider use images that specify by user.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set UseCustomImages : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebSlider use images that specify by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_UseCustomImages();
public: __property void set_UseCustomImages(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebSlider use images that specify by user.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool UseCustomImages {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


UseDefaultStyle Property

[image]
Intersoft WebEssentials Documentation
UseDefaultStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : UseDefaultStyle Property

Glossary Item Box

Determines whether or not WebSlider is using default style.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider is using default style.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property UseDefaultStyle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

instance.UseDefaultStyle = value

value = instance.UseDefaultStyle
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider is using default style.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool UseDefaultStyle {get; set;}
Delphi
public read-write property UseDefaultStyle: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider is using default style.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set UseDefaultStyle : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider is using default style.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_UseDefaultStyle();
public: __property void set_UseDefaultStyle(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebSlider is using default style.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool UseDefaultStyle {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ValidateRequestMode Property

[image]
Intersoft WebEssentials Documentation
ValidateRequestMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Value Property

[image]
Intersoft WebEssentials Documentation
Value Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Value Property

Glossary Item Box

Specifies the value of WebSlider.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the value of WebSlider.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Value As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Integer

instance.Value = value

value = instance.Value
C#
[System.ComponentModel.DescriptionAttribute("Specifies the value of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int Value {get; set;}
Delphi
public read-write property Value: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the value of WebSlider.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set Value : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the value of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_Value();
public: __property void set_Value(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the value of WebSlider.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int Value {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is the same with MinimumValue property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ViewStateItems Property

[image]
Intersoft WebEssentials Documentation
ViewStateItems Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ViewStateItems Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ViewStateMode Property

[image]
Intersoft WebEssentials Documentation
ViewStateMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ViewStateServerConnection Property

[image]
Intersoft WebEssentials Documentation
ViewStateServerConnection Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ViewStateServerConnection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ViewStateServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: System.String; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
System.ComponentModel.CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ViewStateServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ViewStateServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


ViewStateStorage Property

[image]
Intersoft WebEssentials Documentation
ViewStateStorage Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : ViewStateStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
System.ComponentModel.CategoryAttribute("View State Settings")
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


Width Property

[image]
Intersoft WebEssentials Documentation
Width Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overrides Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public override System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; override;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public override function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.Web.UI.WebControls.Unit get_Width() override;
public: __property void set_Width(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


XmlCompressionEnabled Property

[image]
Intersoft WebEssentials Documentation
XmlCompressionEnabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlider Class : XmlCompressionEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property XmlCompressionEnabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlider
Dim value As System.Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: System.Boolean; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set XmlCompressionEnabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool XmlCompressionEnabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlider Class
WebSlider Members


WebSlidingMenu Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenu Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenu Class

Glossary Item Box

Intersoft WebSlidingMenu is an interactive menu that offer different approach in menu system.

Object Model

WebSlidingMenu Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSlidingMenu.js;", Type=XmlSerializationType.ClientAndLayout)>
<System.Web.UI.ToolboxDataAttribute("<{0}:WebSlidingMenu runat=server Width="200px" Height="200px"></{0}:WebSlidingMenu>")>
<System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebSlidingMenuDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.SerializableAttribute()>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebSlidingMenu
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
C#
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSlidingMenu.js;", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebSlidingMenu runat=server Width="200px" Height="200px"></{0}:WebSlidingMenu>")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebSlidingMenuDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebSlidingMenu : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync
Delphi
public class WebSlidingMenu = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync)
JScript
ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSlidingMenu.js;", Type=XmlSerializationType.ClientAndLayout)
System.Web.UI.ToolboxDataAttribute("<{0}:WebSlidingMenu runat=server Width="200px" Height="200px"></{0}:WebSlidingMenu>")
System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebSlidingMenuDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
ISNet.Serialization.BinarySerializableAttribute()
System.SerializableAttribute()
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebSlidingMenu extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSlidingMenu.js;", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebSlidingMenu runat=server Width="200px" Height="200px"></{0}:WebSlidingMenu>")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebSlidingMenuDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebSlidingMenu : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSlidingMenu.js;", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebSlidingMenu runat=server Width="200px" Height="200px"></{0}:WebSlidingMenu>")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebEssentials.WebSlidingMenuDesigner, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebSlidingMenu : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ITemplateSync

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebEssentials.WebSlidingMenu

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenu Class Events

[image]
Intersoft WebEssentials Documentation
WebSlidingMenu Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenu Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenu members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | InitializeItem | Fires when WebSlidingMenu Item is initialize when LoadOnDemand feature is activate.
Public Event | ItemBound | Fires when WebSlidingMenu Item is bound in binding to datasource scenario.
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebSlidingMenu Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenu Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenu Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenu Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenu.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenu Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | AlternateItemStyle | Contains interactive style for alternate item style.
Public Property | BackColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderWidth | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Caption | Gets or sets the caption for WebSlidingMenu.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebAccordion.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CssClass | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DataBindings |
Public Property | DataSourceID |
Public Property | DefaultStyleMode |
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableLoaderIndicator | Determines whether or not loader indicator appear when WebSlidingMenu performing load on demand.
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings |
Public Property | Font | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ForeColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FrameStyle | Contains interactive style for the frame of WebSlidingMenu.
Public Property | HeaderStyle | Contains interactive style for the header of WebSlidingMenu.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory for ImagesSettings.
Public Property | ImagesSettings | Provides the settings that control the images in WebSlidingMenu.
Public Property | InitialPath | Gets or sets the initial path for WebSlidingMenu.
Public Property | ItemContentStyle | Contains interactive style for the item content of WebSlidingMenuItem.
Public Property | Items | The item collection of WebSlidingMenuItem
Public Property | ItemStyle | Contains interactive style for item style.
Public Property | LayoutSettings | Provides the settings that control the behaviors of the layout in WebSlidingMenu.
Public Property | Levels | The level collection of WebSlidingMenuLevel
Public Property | LoadOnDemand | Gets or sets the value that determines whether the WebSlidingMenu is load on demand or not.
Public Property | MaxDataBindDepth |
Public Property | NextIndicatorStyle | Contains interactive style for the next indicator arrow of WebSlidingMenuItem.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TextSettings | Provides the settings that control the text in WebSlidingMenu.
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseDefaultStyle | Specifies whether WebSlidingMenu should apply embedded default style for its appearance.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Gets or sets the value that determines whether the WebSlidingMenu is visible or not.
Public Property | Width | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetDataSourceInternal |
Public Method | SetInitialLevelByPath | Set Initial level by path.
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | InitializeItem | Fires when WebSlidingMenu Item is initialize when LoadOnDemand feature is activate.
Public Event | ItemBound | Fires when WebSlidingMenu Item is bound in binding to datasource scenario.
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebSlidingMenu Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenu Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlidingMenu Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenu Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenu members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetDataSourceInternal |
Public Method | SetInitialLevelByPath | Set Initial level by path.
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SynchronizeTemplatesFrom |
Top

See Also

Reference

WebSlidingMenu Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenu Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenu Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenu Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenu members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | AlternateItemStyle | Contains interactive style for alternate item style.
Public Property | BackColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderWidth | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Caption | Gets or sets the caption for WebSlidingMenu.
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebAccordion.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CssClass | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DataBindings |
Public Property | DataSourceID |
Public Property | DefaultStyleMode |
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableLoaderIndicator | Determines whether or not loader indicator appear when WebSlidingMenu performing load on demand.
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings |
Public Property | Font | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ForeColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FrameStyle | Contains interactive style for the frame of WebSlidingMenu.
Public Property | HeaderStyle | Contains interactive style for the header of WebSlidingMenu.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory for ImagesSettings.
Public Property | ImagesSettings | Provides the settings that control the images in WebSlidingMenu.
Public Property | InitialPath | Gets or sets the initial path for WebSlidingMenu.
Public Property | ItemContentStyle | Contains interactive style for the item content of WebSlidingMenuItem.
Public Property | Items | The item collection of WebSlidingMenuItem
Public Property | ItemStyle | Contains interactive style for item style.
Public Property | LayoutSettings | Provides the settings that control the behaviors of the layout in WebSlidingMenu.
Public Property | Levels | The level collection of WebSlidingMenuLevel
Public Property | LoadOnDemand | Gets or sets the value that determines whether the WebSlidingMenu is load on demand or not.
Public Property | MaxDataBindDepth |
Public Property | NextIndicatorStyle | Contains interactive style for the next indicator arrow of WebSlidingMenuItem.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TextSettings | Provides the settings that control the text in WebSlidingMenu.
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UseDefaultStyle | Specifies whether WebSlidingMenu should apply embedded default style for its appearance.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Gets or sets the value that determines whether the WebSlidingMenu is visible or not.
Public Property | Width | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebSlidingMenu Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuBindingEditor Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuBindingEditor Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuBindingEditor Class

Glossary Item Box

Object Model

WebSlidingMenuBindingEditor Class

Syntax

Visual Basic (Declaration)
Public Class WebSlidingMenuBindingEditor
   Inherits System.Drawing.Design.UITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditor
C#
public class WebSlidingMenuBindingEditor : System.Drawing.Design.UITypeEditor
Delphi
public class WebSlidingMenuBindingEditor = class(System.Drawing.Design.UITypeEditor)
JScript
public class WebSlidingMenuBindingEditor extends System.Drawing.Design.UITypeEditor
Managed Extensions for C++
public __gc class WebSlidingMenuBindingEditor : public System.Drawing.Design.UITypeEditor
C++/CLI
public ref class WebSlidingMenuBindingEditor : public System.Drawing.Design.UITypeEditor

Inheritance Hierarchy

System.Object
System.Drawing.Design.UITypeEditor
ISNet.WebUI.WebEssentials.WebSlidingMenuBindingEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuBindingEditor Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuBindingEditor Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuBindingEditor Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuBindingEditor.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuBindingEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

WebSlidingMenuBindingEditor Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuBindingEditor Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuBindingEditor Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuBindingEditor Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuBindingEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden.
Public Method | GetEditStyle | Overloaded. Overridden.
Public Method | GetPaintValueSupported | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Public Method | PaintValue | Overloaded. (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

WebSlidingMenuBindingEditor Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuBindingEditor Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuBindingEditor Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuBindingEditor Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuBindingEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | (Inherited from System.Drawing.Design.UITypeEditor)
Top

See Also

Reference

WebSlidingMenuBindingEditor Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuBindingEditorForm Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuBindingEditorForm Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuBindingEditorForm Class

Glossary Item Box

Object Model

WebSlidingMenuBindingEditorForm Class

Syntax

Visual Basic (Declaration)
Public Class WebSlidingMenuBindingEditorForm
   Inherits System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
C#
public class WebSlidingMenuBindingEditorForm : System.Windows.Forms.Form
Delphi
public class WebSlidingMenuBindingEditorForm = class(System.Windows.Forms.Form)
JScript
public class WebSlidingMenuBindingEditorForm extends System.Windows.Forms.Form
Managed Extensions for C++
public __gc class WebSlidingMenuBindingEditorForm : public System.Windows.Forms.Form
C++/CLI
public ref class WebSlidingMenuBindingEditorForm : public System.Windows.Forms.Form

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ISNet.WebUI.WebEssentials.WebSlidingMenuBindingEditorForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuBindingEditorForm Class Events

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuBindingEditorForm Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuBindingEditorForm Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuBindingEditorForm members.

Public Events

 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

WebSlidingMenuBindingEditorForm Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuBindingEditorForm Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuBindingEditorForm Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuBindingEditorForm Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuBindingEditorForm.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuBindingEditorForm Constructor |
Top

Public Properties

 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top

Public Methods

 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top

Public Events

 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

WebSlidingMenuBindingEditorForm Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuBindingEditorForm Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuBindingEditorForm Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuBindingEditorForm Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuBindingEditorForm members.

Public Methods

 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top

See Also

Reference

WebSlidingMenuBindingEditorForm Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuBindingEditorForm Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuBindingEditorForm Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuBindingEditorForm Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuBindingEditorForm members.

Public Properties

 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top

See Also

Reference

WebSlidingMenuBindingEditorForm Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuBindingEditorForm Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuBindingEditorForm Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : WebSlidingMenuBindingEditorForm Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuBindingEditorForm()
C#
public WebSlidingMenuBindingEditorForm()
Delphi
public WebSlidingMenuBindingEditorForm();
JScript
public function WebSlidingMenuBindingEditorForm();
Managed Extensions for C++
public: WebSlidingMenuBindingEditorForm();
C++/CLI
public:
WebSlidingMenuBindingEditorForm();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


AcceptButton Property

[image]
Intersoft WebEssentials Documentation
AcceptButton Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : AcceptButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")>
Public Property AcceptButton As System.Windows.Forms.IButtonControl
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.IButtonControl

instance.AcceptButton = value

value = instance.AcceptButton
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")]
public System.Windows.Forms.IButtonControl AcceptButton {get; set;}
Delphi
public read-write property AcceptButton: System.Windows.Forms.IButtonControl;
JScript
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")
public function get,set AcceptButton : System.Windows.Forms.IButtonControl
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")]
public: __property System.Windows.Forms.IButtonControl* get_AcceptButton();
public: __property void set_AcceptButton(
   System.Windows.Forms.IButtonControl* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")]
public:
property System.Windows.Forms.IButtonControl^ AcceptButton {
   System.Windows.Forms.IButtonControl^ get();
   void set (    System.Windows.Forms.IButtonControl^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


AccessibleDescription Property

[image]
Intersoft WebEssentials Documentation
AccessibleDescription Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : AccessibleDescription Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Accessibility")>
<SRDescriptionAttribute("The description that will be reported to accessibility clients.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AccessibleDescription As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.String

instance.AccessibleDescription = value

value = instance.AccessibleDescription
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The description that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string AccessibleDescription {get; set;}
Delphi
public read-write property AccessibleDescription: System.String;
JScript
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Accessibility")
SRDescriptionAttribute("The description that will be reported to accessibility clients.")
System.ComponentModel.DefaultValueAttribute()
public function get,set AccessibleDescription : System.String
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The description that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_AccessibleDescription();
public: __property void set_AccessibleDescription(
   System.string* value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The description that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ AccessibleDescription {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


AccessibleName Property

[image]
Intersoft WebEssentials Documentation
AccessibleName Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : AccessibleName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Accessibility")>
<SRDescriptionAttribute("The name that will be reported to accessibility clients.")>
Public Property AccessibleName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.String

instance.AccessibleName = value

value = instance.AccessibleName
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The name that will be reported to accessibility clients.")]
public System.string AccessibleName {get; set;}
Delphi
public read-write property AccessibleName: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Accessibility")
SRDescriptionAttribute("The name that will be reported to accessibility clients.")
public function get,set AccessibleName : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The name that will be reported to accessibility clients.")]
public: __property System.string* get_AccessibleName();
public: __property void set_AccessibleName(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The name that will be reported to accessibility clients.")]
public:
property System.String^ AccessibleName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


AccessibleRole Property

[image]
Intersoft WebEssentials Documentation
AccessibleRole Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : AccessibleRole Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The role that will be reported to accessibility clients.")>
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Accessibility")>
Public Property AccessibleRole As System.Windows.Forms.AccessibleRole
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.AccessibleRole

instance.AccessibleRole = value

value = instance.AccessibleRole
C#
[SRDescriptionAttribute("The role that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Accessibility")]
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}
Delphi
public read-write property AccessibleRole: System.Windows.Forms.AccessibleRole;
JScript
SRDescriptionAttribute("The role that will be reported to accessibility clients.")
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Accessibility")
public function get,set AccessibleRole : System.Windows.Forms.AccessibleRole
Managed Extensions for C++
[SRDescriptionAttribute("The role that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Accessibility")]
public: __property System.Windows.Forms.AccessibleRole get_AccessibleRole();
public: __property void set_AccessibleRole(
   System.Windows.Forms.AccessibleRole value
);
C++/CLI
[SRDescriptionAttribute("The role that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Accessibility")]
public:
property System.Windows.Forms.AccessibleRole AccessibleRole {
   System.Windows.Forms.AccessibleRole get();
   void set (    System.Windows.Forms.AccessibleRole value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Activate Method

[image]
Intersoft WebEssentials Documentation
Activate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Activate Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Activate()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.Activate()
C#
public void Activate()
Delphi
public procedure Activate();
JScript
public function Activate();
Managed Extensions for C++
public: void Activate();
C++/CLI
public:
void Activate();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Activated Event

[image]
Intersoft WebEssentials Documentation
Activated Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Activated Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Occurs whenever the form is activated.")>
Public Event Activated As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.Activated, handler
C#
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is activated.")]
public event System.EventHandler Activated
Delphi
public event Activated: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is activated.")]
public: __event System.EventHandler* Activated
C++/CLI
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is activated.")]
public:
event System.EventHandler^ Activated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


AddOwnedForm Method

[image]
Intersoft WebEssentials Documentation
AddOwnedForm Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : AddOwnedForm Method

ownedForm

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub AddOwnedForm( _
   ByVal ownedForm As System.Windows.Forms.Form _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim ownedForm As System.Windows.Forms.Form

instance.AddOwnedForm(ownedForm)
C#
public void AddOwnedForm(
   System.Windows.Forms.Form ownedForm
)
Delphi
public procedure AddOwnedForm(
    ownedForm: System.Windows.Forms.Form
);
JScript
public function AddOwnedForm(
   ownedForm : System.Windows.Forms.Form
);
Managed Extensions for C++
public: void AddOwnedForm(
   System.Windows.Forms.Form* ownedForm
)
C++/CLI
public:
void AddOwnedForm(
   System.Windows.Forms.Form^ ownedForm
)

Parameters

ownedForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


AllowDrop Property

[image]
Intersoft WebEssentials Documentation
AllowDrop Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : AllowDrop Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")>
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Overridable Property AllowDrop As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
[SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public virtual System.bool AllowDrop {get; set;}
Delphi
public read-write property AllowDrop: System.Boolean; virtual;
JScript
SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Behavior")
public function get,set AllowDrop : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property virtual System.bool get_AllowDrop();
public: __property virtual void set_AllowDrop(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
virtual property System.bool AllowDrop {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Anchor Property

[image]
Intersoft WebEssentials Documentation
Anchor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Anchor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
Public Overridable Property Anchor As System.Windows.Forms.AnchorStyles
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.AnchorStyles

instance.Anchor = value

value = instance.Anchor
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}
Delphi
public read-write property Anchor: System.Windows.Forms.AnchorStyles; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")
SRCategoryAttribute("Layout")
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
public function get,set Anchor : System.Windows.Forms.AnchorStyles
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
public: __property virtual System.Windows.Forms.AnchorStyles get_Anchor();
public: __property virtual void set_Anchor(
   System.Windows.Forms.AnchorStyles value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
public:
virtual property System.Windows.Forms.AnchorStyles Anchor {
   System.Windows.Forms.AnchorStyles get();
   void set (    System.Windows.Forms.AnchorStyles value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


AutoScroll Property

[image]
Intersoft WebEssentials Documentation
AutoScroll Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : AutoScroll Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
Public Overridable Property AutoScroll As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.AutoScroll = value

value = instance.AutoScroll
C#
[System.ComponentModel.LocalizableAttribute(true)]
public virtual System.bool AutoScroll {get; set;}
Delphi
public read-write property AutoScroll: System.Boolean; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
public function get,set AutoScroll : System.boolean
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
public: __property virtual System.bool get_AutoScroll();
public: __property virtual void set_AutoScroll(
   System.bool value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
public:
virtual property System.bool AutoScroll {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


AutoScrollMargin Property

[image]
Intersoft WebEssentials Documentation
AutoScrollMargin Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : AutoScrollMargin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("The margin around controls during auto scroll.")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Property AutoScrollMargin As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Size

instance.AutoScrollMargin = value

value = instance.AutoScrollMargin
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The margin around controls during auto scroll.")]
[System.ComponentModel.LocalizableAttribute(true)]
public System.Drawing.Size AutoScrollMargin {get; set;}
Delphi
public read-write property AutoScrollMargin: System.Drawing.Size;
JScript
SRCategoryAttribute("Layout")
SRDescriptionAttribute("The margin around controls during auto scroll.")
System.ComponentModel.LocalizableAttribute()
public function get,set AutoScrollMargin : System.Drawing.Size
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The margin around controls during auto scroll.")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property System.Drawing.Size get_AutoScrollMargin();
public: __property void set_AutoScrollMargin(
   System.Drawing.Size value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The margin around controls during auto scroll.")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
property System.Drawing.Size AutoScrollMargin {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


AutoScrollMinSize Property

[image]
Intersoft WebEssentials Documentation
AutoScrollMinSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : AutoScrollMinSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The minimum logical size for the auto scroll region.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
Public Property AutoScrollMinSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Size

instance.AutoScrollMinSize = value

value = instance.AutoScrollMinSize
C#
[SRDescriptionAttribute("The minimum logical size for the auto scroll region.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public System.Drawing.Size AutoScrollMinSize {get; set;}
Delphi
public read-write property AutoScrollMinSize: System.Drawing.Size;
JScript
SRDescriptionAttribute("The minimum logical size for the auto scroll region.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Layout")
public function get,set AutoScrollMinSize : System.Drawing.Size
Managed Extensions for C++
[SRDescriptionAttribute("The minimum logical size for the auto scroll region.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public: __property System.Drawing.Size get_AutoScrollMinSize();
public: __property void set_AutoScrollMinSize(
   System.Drawing.Size value
);
C++/CLI
[SRDescriptionAttribute("The minimum logical size for the auto scroll region.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public:
property System.Drawing.Size AutoScrollMinSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


AutoSize Property

[image]
Intersoft WebEssentials Documentation
AutoSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : AutoSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.EditorBrowsableAttribute()>
Public Overridable Property AutoSize As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.AutoSize = value

value = instance.AutoSize
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.EditorBrowsableAttribute()]
public virtual System.bool AutoSize {get; set;}
Delphi
public read-write property AutoSize: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.EditorBrowsableAttribute()
public function get,set AutoSize : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.EditorBrowsableAttribute()]
public: __property virtual System.bool get_AutoSize();
public: __property virtual void set_AutoSize(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.EditorBrowsableAttribute()]
public:
virtual property System.bool AutoSize {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


AutoSizeChanged Event

[image]
Intersoft WebEssentials Documentation
AutoSizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : AutoSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<SRDescriptionAttribute("Occurs when the AutoSize property has changed.")>
<System.ComponentModel.EditorBrowsableAttribute()>
<SRCategoryAttribute("Property Changed")>
Public Event AutoSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.AutoSizeChanged, handler
C#
[System.ComponentModel.BrowsableAttribute(true)]
[SRDescriptionAttribute("Occurs when the AutoSize property has changed.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler AutoSizeChanged
Delphi
public event AutoSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[SRDescriptionAttribute("Occurs when the AutoSize property has changed.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* AutoSizeChanged
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[SRDescriptionAttribute("Occurs when the AutoSize property has changed.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ AutoSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


AutoSizeMode Property

[image]
Intersoft WebEssentials Documentation
AutoSizeMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : AutoSizeMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AutoSizeMode As System.Windows.Forms.AutoSizeMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.AutoSizeMode

instance.AutoSizeMode = value

value = instance.AutoSizeMode
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.Windows.Forms.AutoSizeMode AutoSizeMode {get; set;}
Delphi
public read-write property AutoSizeMode: System.Windows.Forms.AutoSizeMode;
JScript
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Layout")
SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AutoSizeMode : System.Windows.Forms.AutoSizeMode
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Windows.Forms.AutoSizeMode get_AutoSizeMode();
public: __property void set_AutoSizeMode(
   System.Windows.Forms.AutoSizeMode value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Windows.Forms.AutoSizeMode AutoSizeMode {
   System.Windows.Forms.AutoSizeMode get();
   void set (    System.Windows.Forms.AutoSizeMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


AutoValidate Property

[image]
Intersoft WebEssentials Documentation
AutoValidate Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : AutoValidate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property AutoValidate As System.Windows.Forms.AutoValidate
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.AutoValidate

instance.AutoValidate = value

value = instance.AutoValidate
C#
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.Windows.Forms.AutoValidate AutoValidate {get; set;}
Delphi
public read-write property AutoValidate: System.Windows.Forms.AutoValidate; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute()
System.ComponentModel.BrowsableAttribute()
public function get,set AutoValidate : System.Windows.Forms.AutoValidate
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.Windows.Forms.AutoValidate get_AutoValidate();
public: __property virtual void set_AutoValidate(
   System.Windows.Forms.AutoValidate value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.Windows.Forms.AutoValidate AutoValidate {
   System.Windows.Forms.AutoValidate get();
   void set (    System.Windows.Forms.AutoValidate value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


AutoValidateChanged Event

[image]
Intersoft WebEssentials Documentation
AutoValidateChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : AutoValidateChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
Public Event AutoValidateChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.AutoValidateChanged, handler
C#
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public event System.EventHandler AutoValidateChanged
Delphi
public event AutoValidateChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public: __event System.EventHandler* AutoValidateChanged
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public:
event System.EventHandler^ AutoValidateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


BackColor Property

[image]
Intersoft WebEssentials Documentation
BackColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : BackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public virtual System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; virtual;
JScript
public function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
C++/CLI
public:
virtual property System.Drawing.Color BackColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


BackColorChanged Event

[image]
Intersoft WebEssentials Documentation
BackColorChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : BackColorChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")>
Public Event BackColorChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.BackColorChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")]
public event System.EventHandler BackColorChanged
Delphi
public event BackColorChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")]
public: __event System.EventHandler* BackColorChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")]
public:
event System.EventHandler^ BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


BackgroundImage Property

[image]
Intersoft WebEssentials Documentation
BackgroundImage Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : BackgroundImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("The background image used for the control.")>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property BackgroundImage As System.Drawing.Image
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image used for the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Drawing.Image BackgroundImage {get; set;}
Delphi
public read-write property BackgroundImage: System.Drawing.Image; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("The background image used for the control.")
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
public function get,set BackgroundImage : System.Drawing.Image
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image used for the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Drawing.Image* get_BackgroundImage();
public: __property virtual void set_BackgroundImage(
   System.Drawing.Image* value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image used for the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Drawing.Image^ BackgroundImage {
   System.Drawing.Image^ get();
   void set (    System.Drawing.Image^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


BackgroundImageChanged Event

[image]
Intersoft WebEssentials Documentation
BackgroundImageChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : BackgroundImageChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")>
Public Event BackgroundImageChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")]
public event System.EventHandler BackgroundImageChanged
Delphi
public event BackgroundImageChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")]
public: __event System.EventHandler* BackgroundImageChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")]
public:
event System.EventHandler^ BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


BackgroundImageLayout Property

[image]
Intersoft WebEssentials Documentation
BackgroundImageLayout Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : BackgroundImageLayout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("The background image layout used for the component.")>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property BackgroundImageLayout As System.Windows.Forms.ImageLayout
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.ImageLayout

instance.BackgroundImageLayout = value

value = instance.BackgroundImageLayout
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image layout used for the component.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}
Delphi
public read-write property BackgroundImageLayout: System.Windows.Forms.ImageLayout; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("The background image layout used for the component.")
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
public function get,set BackgroundImageLayout : System.Windows.Forms.ImageLayout
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image layout used for the component.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Windows.Forms.ImageLayout get_BackgroundImageLayout();
public: __property virtual void set_BackgroundImageLayout(
   System.Windows.Forms.ImageLayout value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image layout used for the component.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Windows.Forms.ImageLayout BackgroundImageLayout {
   System.Windows.Forms.ImageLayout get();
   void set (    System.Windows.Forms.ImageLayout value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


BackgroundImageLayoutChanged Event

[image]
Intersoft WebEssentials Documentation
BackgroundImageLayoutChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event BackgroundImageLayoutChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageLayoutChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler BackgroundImageLayoutChanged
Delphi
public event BackgroundImageLayoutChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* BackgroundImageLayoutChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


BeginInvoke Method

[image]
Intersoft WebEssentials Documentation
BeginInvoke Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : BeginInvoke Method

Glossary Item Box

Overload List

Overload | Description
BeginInvoke(Delegate) | (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


BeginInvoke(Delegate) Method

[image]
Intersoft WebEssentials Documentation
BeginInvoke(Delegate) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate _
) As System.IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim method As System.Delegate
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)
Delphi
public function BeginInvoke(
    method: System.Delegate
): System.IAsyncResult;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function BeginInvoke(
   method : System.Delegate
) : System.IAsyncResult;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.IAsyncResult* BeginInvoke(
   System.Delegate* method
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.IAsyncResult^ BeginInvoke(
   System.Delegate^ method
)

Parameters

method

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
Intersoft WebEssentials Documentation
BeginInvoke(Delegate,Object[]) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method, args)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)
Delphi
public function BeginInvoke(
    method: System.Delegate;
   params  args: System.TObjectarray of
): System.IAsyncResult;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function BeginInvoke(
   method : System.Delegate,
   args : System.Object[]
) : System.IAsyncResult;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: System.IAsyncResult* BeginInvoke(
   System.Delegate* method,
   params System.Object*[]* args
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
System.IAsyncResult^ BeginInvoke(
   System.Delegate^ method,
   ... System.array<Object^>^ args
)

Parameters

method
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


BindingContextChanged Event

[image]
Intersoft WebEssentials Documentation
BindingContextChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : BindingContextChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")>
Public Event BindingContextChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.BindingContextChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")]
public event System.EventHandler BindingContextChanged
Delphi
public event BindingContextChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")]
public: __event System.EventHandler* BindingContextChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")]
public:
event System.EventHandler^ BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


BringToFront Method

[image]
Intersoft WebEssentials Documentation
BringToFront Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : BringToFront Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.BringToFront()
C#
public void BringToFront()
Delphi
public procedure BringToFront();
JScript
public function BringToFront();
Managed Extensions for C++
public: void BringToFront();
C++/CLI
public:
void BringToFront();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


CancelButton Property

[image]
Intersoft WebEssentials Documentation
CancelButton Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : CancelButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")>
Public Property CancelButton As System.Windows.Forms.IButtonControl
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.IButtonControl

instance.CancelButton = value

value = instance.CancelButton
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")]
public System.Windows.Forms.IButtonControl CancelButton {get; set;}
Delphi
public read-write property CancelButton: System.Windows.Forms.IButtonControl;
JScript
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")
public function get,set CancelButton : System.Windows.Forms.IButtonControl
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")]
public: __property System.Windows.Forms.IButtonControl* get_CancelButton();
public: __property void set_CancelButton(
   System.Windows.Forms.IButtonControl* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")]
public:
property System.Windows.Forms.IButtonControl^ CancelButton {
   System.Windows.Forms.IButtonControl^ get();
   void set (    System.Windows.Forms.IButtonControl^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


CausesValidation Property

[image]
Intersoft WebEssentials Documentation
CausesValidation Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : CausesValidation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Indicates whether this component raises validation events. ")>
Public Property CausesValidation As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.CausesValidation = value

value = instance.CausesValidation
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Indicates whether this component raises validation events. ")]
public System.bool CausesValidation {get; set;}
Delphi
public read-write property CausesValidation: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Focus")
SRDescriptionAttribute("Indicates whether this component raises validation events. ")
public function get,set CausesValidation : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Indicates whether this component raises validation events. ")]
public: __property System.bool get_CausesValidation();
public: __property void set_CausesValidation(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Indicates whether this component raises validation events. ")]
public:
property System.bool CausesValidation {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


CausesValidationChanged Event

[image]
Intersoft WebEssentials Documentation
CausesValidationChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : CausesValidationChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event CausesValidationChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.CausesValidationChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler CausesValidationChanged
Delphi
public event CausesValidationChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* CausesValidationChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ChangeUICues Event

[image]
Intersoft WebEssentials Documentation
ChangeUICues Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ChangeUICues Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")>
Public Event ChangeUICues As System.Windows.Forms.UICuesEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.UICuesEventHandler

AddHandler instance.ChangeUICues, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")]
public event System.Windows.Forms.UICuesEventHandler ChangeUICues
Delphi
public event ChangeUICues: System.Windows.Forms.UICuesEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")]
public: __event System.Windows.Forms.UICuesEventHandler* ChangeUICues
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")]
public:
event System.Windows.Forms.UICuesEventHandler^ ChangeUICues

Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Click Event

[image]
Intersoft WebEssentials Documentation
Click Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Click Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the component is clicked.")>
Public Event Click As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.Click, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the component is clicked.")]
public event System.EventHandler Click
Delphi
public event Click: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the component is clicked.")]
public: __event System.EventHandler* Click
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the component is clicked.")]
public:
event System.EventHandler^ Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ClientSize Property

[image]
Intersoft WebEssentials Documentation
ClientSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ClientSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
Public Property ClientSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Size

instance.ClientSize = value

value = instance.ClientSize
C#
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public System.Drawing.Size ClientSize {get; set;}
Delphi
public read-write property ClientSize: System.Drawing.Size;
JScript
System.ComponentModel.LocalizableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
public function get,set ClientSize : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public: __property System.Drawing.Size get_ClientSize();
public: __property void set_ClientSize(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public:
property System.Drawing.Size ClientSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ClientSizeChanged Event

[image]
Intersoft WebEssentials Documentation
ClientSizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ClientSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")>
Public Event ClientSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.ClientSizeChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")]
public event System.EventHandler ClientSizeChanged
Delphi
public event ClientSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")]
public: __event System.EventHandler* ClientSizeChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")]
public:
event System.EventHandler^ ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Close Method

[image]
Intersoft WebEssentials Documentation
Close Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Close Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.Close()
C#
public void Close()
Delphi
public procedure Close();
JScript
public function Close();
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Contains Method

[image]
Intersoft WebEssentials Documentation
Contains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Contains Method

ctl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ctl As System.Windows.Forms.Control _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim ctl As System.Windows.Forms.Control
Dim value As System.Boolean

value = instance.Contains(ctl)
C#
public System.bool Contains(
   System.Windows.Forms.Control ctl
)
Delphi
public function Contains(
    ctl: System.Windows.Forms.Control
): System.Boolean;
JScript
public function Contains(
   ctl : System.Windows.Forms.Control
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   System.Windows.Forms.Control* ctl
)
C++/CLI
public:
System.bool Contains(
   System.Windows.Forms.Control^ ctl
)

Parameters

ctl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ContextMenuStrip Property

[image]
Intersoft WebEssentials Documentation
ContextMenuStrip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ContextMenuStrip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")>
Public Overridable Property ContextMenuStrip As System.Windows.Forms.ContextMenuStrip
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.ContextMenuStrip

instance.ContextMenuStrip = value

value = instance.ContextMenuStrip
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}
Delphi
public read-write property ContextMenuStrip: System.Windows.Forms.ContextMenuStrip; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Behavior")
SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")
public function get,set ContextMenuStrip : System.Windows.Forms.ContextMenuStrip
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public: __property virtual System.Windows.Forms.ContextMenuStrip* get_ContextMenuStrip();
public: __property virtual void set_ContextMenuStrip(
   System.Windows.Forms.ContextMenuStrip* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public:
virtual property System.Windows.Forms.ContextMenuStrip^ ContextMenuStrip {
   System.Windows.Forms.ContextMenuStrip^ get();
   void set (    System.Windows.Forms.ContextMenuStrip^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ContextMenuStripChanged Event

[image]
Intersoft WebEssentials Documentation
ContextMenuStripChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ContextMenuStripChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event ContextMenuStripChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.ContextMenuStripChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler ContextMenuStripChanged
Delphi
public event ContextMenuStripChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* ContextMenuStripChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ControlAdded Event

[image]
Intersoft WebEssentials Documentation
ControlAdded Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ControlAdded Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a control is added to this control.")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event ControlAdded As System.Windows.Forms.ControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlAdded, handler
C#
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a control is added to this control.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event System.Windows.Forms.ControlEventHandler ControlAdded
Delphi
public event ControlAdded: System.Windows.Forms.ControlEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a control is added to this control.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event System.Windows.Forms.ControlEventHandler* ControlAdded
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a control is added to this control.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event System.Windows.Forms.ControlEventHandler^ ControlAdded

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ControlBox Property

[image]
Intersoft WebEssentials Documentation
ControlBox Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ControlBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")>
Public Property ControlBox As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.ControlBox = value

value = instance.ControlBox
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")]
public System.bool ControlBox {get; set;}
Delphi
public read-write property ControlBox: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")
public function get,set ControlBox : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")]
public: __property System.bool get_ControlBox();
public: __property void set_ControlBox(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")]
public:
property System.bool ControlBox {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ControlRemoved Event

[image]
Intersoft WebEssentials Documentation
ControlRemoved Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ControlRemoved Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a control is removed from this control.")>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.BrowsableAttribute(True)>
Public Event ControlRemoved As System.Windows.Forms.ControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlRemoved, handler
C#
[SRDescriptionAttribute("Occurs when a control is removed from this control.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(true)]
public event System.Windows.Forms.ControlEventHandler ControlRemoved
Delphi
public event ControlRemoved: System.Windows.Forms.ControlEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a control is removed from this control.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(true)]
public: __event System.Windows.Forms.ControlEventHandler* ControlRemoved
C++/CLI
[SRDescriptionAttribute("Occurs when a control is removed from this control.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(true)]
public:
event System.Windows.Forms.ControlEventHandler^ ControlRemoved

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


CreateControl Method

[image]
Intersoft WebEssentials Documentation
CreateControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : CreateControl Method

Glossary Item Box

Overload List

Overload | Description
CreateControl | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


CreateControl() Method

[image]
Intersoft WebEssentials Documentation
CreateControl() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : CreateControl() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.CreateControl()
C#
public void CreateControl()
Delphi
public procedure CreateControl();
JScript
public function CreateControl();
Managed Extensions for C++
public: void CreateControl();
C++/CLI
public:
void CreateControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


CreateGraphics Method

[image]
Intersoft WebEssentials Documentation
CreateGraphics Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : CreateGraphics Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As System.Drawing.Graphics
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Graphics

value = instance.CreateGraphics()
C#
public System.Drawing.Graphics CreateGraphics()
Delphi
public function CreateGraphics(): System.Drawing.Graphics;
JScript
public function CreateGraphics() : System.Drawing.Graphics;
Managed Extensions for C++
public: System.Drawing.Graphics* CreateGraphics();
C++/CLI
public:
System.Drawing.Graphics^ CreateGraphics();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


CreateObjRef Method

[image]
Intersoft WebEssentials Documentation
CreateObjRef Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : CreateObjRef Method

requestedType

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
[System.Security.SecurityCriticalAttribute()]
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: System.Type
): System.Runtime.Remoting.ObjRef; virtual;
JScript
System.Security.SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : System.Type
) : System.Runtime.Remoting.ObjRef;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
virtual System.Runtime.Remoting.ObjRef^ CreateObjRef(
   System.Type^ requestedType
)

Parameters

requestedType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Cursor Property

[image]
Intersoft WebEssentials Documentation
Cursor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Cursor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.AmbientValueAttribute()>
Public Overridable Property Cursor As System.Windows.Forms.Cursor
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.Cursor

instance.Cursor = value

value = instance.Cursor
C#
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.AmbientValueAttribute()]
public virtual System.Windows.Forms.Cursor Cursor {get; set;}
Delphi
public read-write property Cursor: System.Windows.Forms.Cursor; virtual;
JScript
SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")
SRCategoryAttribute("Appearance")
System.ComponentModel.AmbientValueAttribute()
public function get,set Cursor : System.Windows.Forms.Cursor
Managed Extensions for C++
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.AmbientValueAttribute()]
public: __property virtual System.Windows.Forms.Cursor* get_Cursor();
public: __property virtual void set_Cursor(
   System.Windows.Forms.Cursor* value
);
C++/CLI
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.AmbientValueAttribute()]
public:
virtual property System.Windows.Forms.Cursor^ Cursor {
   System.Windows.Forms.Cursor^ get();
   void set (    System.Windows.Forms.Cursor^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


CursorChanged Event

[image]
Intersoft WebEssentials Documentation
CursorChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : CursorChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event CursorChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.CursorChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler CursorChanged
Delphi
public event CursorChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* CursorChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


DataBindings Property

[image]
Intersoft WebEssentials Documentation
DataBindings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : DataBindings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)>
<SRDescriptionAttribute("The data bindings for the control.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<SRCategoryAttribute("Data")>
Public ReadOnly Property DataBindings As System.Windows.Forms.ControlBindingsCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.ControlBindingsCollection

value = instance.DataBindings
C#
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)]
[SRDescriptionAttribute("The data bindings for the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[SRCategoryAttribute("Data")]
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}
Delphi
public read-only property DataBindings: System.Windows.Forms.ControlBindingsCollection;
JScript
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)
SRDescriptionAttribute("The data bindings for the control.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.ParenthesizePropertyNameAttribute()
SRCategoryAttribute("Data")
public function get DataBindings : System.Windows.Forms.ControlBindingsCollection
Managed Extensions for C++
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)]
[SRDescriptionAttribute("The data bindings for the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[SRCategoryAttribute("Data")]
public: __property System.Windows.Forms.ControlBindingsCollection* get_DataBindings();
C++/CLI
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)]
[SRDescriptionAttribute("The data bindings for the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[SRCategoryAttribute("Data")]
public:
property System.Windows.Forms.ControlBindingsCollection^ DataBindings {
   System.Windows.Forms.ControlBindingsCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Deactivate Event

[image]
Intersoft WebEssentials Documentation
Deactivate Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Deactivate Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Occurs whenever the form is deactivated.")>
Public Event Deactivate As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.Deactivate, handler
C#
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is deactivated.")]
public event System.EventHandler Deactivate
Delphi
public event Deactivate: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is deactivated.")]
public: __event System.EventHandler* Deactivate
C++/CLI
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is deactivated.")]
public:
event System.EventHandler^ Deactivate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


DisplayRectangle Property

[image]
Intersoft WebEssentials Documentation
DisplayRectangle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : DisplayRectangle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DisplayRectangle As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Rectangle

value = instance.DisplayRectangle
C#
public virtual System.Drawing.Rectangle DisplayRectangle {get;}
Delphi
public read-only property DisplayRectangle: System.Drawing.Rectangle; virtual;
JScript
public function get DisplayRectangle : System.Drawing.Rectangle
Managed Extensions for C++
public: __property virtual System.Drawing.Rectangle get_DisplayRectangle();
C++/CLI
public:
virtual property System.Drawing.Rectangle DisplayRectangle {
   System.Drawing.Rectangle get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Dispose Method

[image]
Intersoft WebEssentials Documentation
Dispose Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Dispose Method

Glossary Item Box

Clean up any resources being used.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Dispose() Method

[image]
Intersoft WebEssentials Documentation
Dispose() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.Dispose()
C#
public void Dispose()
Delphi
public procedure Dispose();
JScript
public function Dispose();
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Dock Property

[image]
Intersoft WebEssentials Documentation
Dock Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Dock Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property Dock As System.Windows.Forms.DockStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.DockStyle

instance.Dock = value

value = instance.Dock
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Windows.Forms.DockStyle Dock {get; set;}
Delphi
public read-write property Dock: System.Windows.Forms.DockStyle; virtual;
JScript
SRCategoryAttribute("Layout")
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")
System.ComponentModel.DefaultValueAttribute()
public function get,set Dock : System.Windows.Forms.DockStyle
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Windows.Forms.DockStyle get_Dock();
public: __property virtual void set_Dock(
   System.Windows.Forms.DockStyle value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Windows.Forms.DockStyle Dock {
   System.Windows.Forms.DockStyle get();
   void set (    System.Windows.Forms.DockStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


DockChanged Event

[image]
Intersoft WebEssentials Documentation
DockChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : DockChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event DockChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.DockChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler DockChanged
Delphi
public event DockChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* DockChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


DoDragDrop Method

[image]
Intersoft WebEssentials Documentation
DoDragDrop Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : DoDragDrop Method

data
allowedEffects

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Function DoDragDrop( _
   ByVal data As System.Object, _
   ByVal allowedEffects As System.Windows.Forms.DragDropEffects _
) As System.Windows.Forms.DragDropEffects
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim data As System.Object
Dim allowedEffects As System.Windows.Forms.DragDropEffects
Dim value As System.Windows.Forms.DragDropEffects

value = instance.DoDragDrop(data, allowedEffects)
C#
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)
Delphi
public function DoDragDrop(
    data: System.TObject;
    allowedEffects: System.Windows.Forms.DragDropEffects
): System.Windows.Forms.DragDropEffects;
JScript
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=)
public function DoDragDrop(
   data : System.Object,
   allowedEffects : System.Windows.Forms.DragDropEffects
) : System.Windows.Forms.DragDropEffects;
Managed Extensions for C++
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: System.Windows.Forms.DragDropEffects DoDragDrop(
   System.Object* data,
   System.Windows.Forms.DragDropEffects allowedEffects
)
C++/CLI
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
System.Windows.Forms.DragDropEffects DoDragDrop(
   System.Object^ data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
allowedEffects

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


DoubleClick Event

[image]
Intersoft WebEssentials Documentation
DoubleClick Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : DoubleClick Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the component is double-clicked.")>
<SRCategoryAttribute("Action")>
Public Event DoubleClick As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.DoubleClick, handler
C#
[SRDescriptionAttribute("Occurs when the component is double-clicked.")]
[SRCategoryAttribute("Action")]
public event System.EventHandler DoubleClick
Delphi
public event DoubleClick: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the component is double-clicked.")]
[SRCategoryAttribute("Action")]
public: __event System.EventHandler* DoubleClick
C++/CLI
[SRDescriptionAttribute("Occurs when the component is double-clicked.")]
[SRCategoryAttribute("Action")]
public:
event System.EventHandler^ DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


DragDrop Event

[image]
Intersoft WebEssentials Documentation
DragDrop Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : DragDrop Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")>
<SRCategoryAttribute("Drag Drop")>
Public Event DragDrop As System.Windows.Forms.DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragDrop, handler
C#
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
[SRCategoryAttribute("Drag Drop")]
public event System.Windows.Forms.DragEventHandler DragDrop
Delphi
public event DragDrop: System.Windows.Forms.DragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
[SRCategoryAttribute("Drag Drop")]
public: __event System.Windows.Forms.DragEventHandler* DragDrop
C++/CLI
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
[SRCategoryAttribute("Drag Drop")]
public:
event System.Windows.Forms.DragEventHandler^ DragDrop

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


DragEnter Event

[image]
Intersoft WebEssentials Documentation
DragEnter Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : DragEnter Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")>
Public Event DragEnter As System.Windows.Forms.DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragEnter, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")]
public event System.Windows.Forms.DragEventHandler DragEnter
Delphi
public event DragEnter: System.Windows.Forms.DragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")]
public: __event System.Windows.Forms.DragEventHandler* DragEnter
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")]
public:
event System.Windows.Forms.DragEventHandler^ DragEnter

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


DragLeave Event

[image]
Intersoft WebEssentials Documentation
DragLeave Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : DragLeave Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")>
Public Event DragLeave As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.DragLeave, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")]
public event System.EventHandler DragLeave
Delphi
public event DragLeave: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")]
public: __event System.EventHandler* DragLeave
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")]
public:
event System.EventHandler^ DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


DragOver Event

[image]
Intersoft WebEssentials Documentation
DragOver Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : DragOver Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")>
Public Event DragOver As System.Windows.Forms.DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragOver, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")]
public event System.Windows.Forms.DragEventHandler DragOver
Delphi
public event DragOver: System.Windows.Forms.DragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")]
public: __event System.Windows.Forms.DragEventHandler* DragOver
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")]
public:
event System.Windows.Forms.DragEventHandler^ DragOver

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


DrawToBitmap Method

[image]
Intersoft WebEssentials Documentation
DrawToBitmap Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : DrawToBitmap Method

bitmap
targetBounds

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows Or  _
    UIPermissionWindow.SafeTopLevelWindows Or  _
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Sub DrawToBitmap( _
   ByVal bitmap As System.Drawing.Bitmap, _
   ByVal targetBounds As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim bitmap As System.Drawing.Bitmap
Dim targetBounds As System.Drawing.Rectangle

instance.DrawToBitmap(bitmap, targetBounds)
C#
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public void DrawToBitmap(
   System.Drawing.Bitmap bitmap,
   System.Drawing.Rectangle targetBounds
)
Delphi
public procedure DrawToBitmap(
    bitmap: System.Drawing.Bitmap;
    targetBounds: System.Drawing.Rectangle
);
JScript
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=)
public function DrawToBitmap(
   bitmap : System.Drawing.Bitmap,
   targetBounds : System.Drawing.Rectangle
);
Managed Extensions for C++
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void DrawToBitmap(
   System.Drawing.Bitmap* bitmap,
   System.Drawing.Rectangle targetBounds
)
C++/CLI
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void DrawToBitmap(
   System.Drawing.Bitmap^ bitmap,
   System.Drawing.Rectangle targetBounds
)

Parameters

bitmap
targetBounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the control is enabled.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Behavior")>
<System.Runtime.InteropServices.DispIdAttribute(-514)>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[System.Runtime.InteropServices.DispIdAttribute(-514)]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
SRDescriptionAttribute("Indicates whether the control is enabled.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Behavior")
System.Runtime.InteropServices.DispIdAttribute(-514)
public function get,set Enabled : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[System.Runtime.InteropServices.DispIdAttribute(-514)]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[System.Runtime.InteropServices.DispIdAttribute(-514)]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


EnabledChanged Event

[image]
Intersoft WebEssentials Documentation
EnabledChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : EnabledChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the control's enabled state changes.")>
Public Event EnabledChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.EnabledChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's enabled state changes.")]
public event System.EventHandler EnabledChanged
Delphi
public event EnabledChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's enabled state changes.")]
public: __event System.EventHandler* EnabledChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's enabled state changes.")]
public:
event System.EventHandler^ EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


EndInvoke Method

[image]
Intersoft WebEssentials Documentation
EndInvoke Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : EndInvoke Method

asyncResult

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Function EndInvoke( _
   ByVal asyncResult As System.IAsyncResult _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim asyncResult As System.IAsyncResult
Dim value As System.Object

value = instance.EndInvoke(asyncResult)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)
Delphi
public function EndInvoke(
    asyncResult: System.IAsyncResult
): System.TObject;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function EndInvoke(
   asyncResult : System.IAsyncResult
) : System.Object;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: System.Object* EndInvoke(
   System.IAsyncResult* asyncResult
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
System.Object^ EndInvoke(
   System.IAsyncResult^ asyncResult
)

Parameters

asyncResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Enter Event

[image]
Intersoft WebEssentials Documentation
Enter Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Enter Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")>
<SRCategoryAttribute("Focus")>
Public Event Enter As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.Enter, handler
C#
[SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")]
[SRCategoryAttribute("Focus")]
public event System.EventHandler Enter
Delphi
public event Enter: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")]
[SRCategoryAttribute("Focus")]
public: __event System.EventHandler* Enter
C++/CLI
[SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")]
[SRCategoryAttribute("Focus")]
public:
event System.EventHandler^ Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


FindForm Method

[image]
Intersoft WebEssentials Documentation
FindForm Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : FindForm Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows Or  _
    UIPermissionWindow.SafeTopLevelWindows Or  _
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Function FindForm() As System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.Form

value = instance.FindForm()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public System.Windows.Forms.Form FindForm()
Delphi
public function FindForm(): System.Windows.Forms.Form;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=)
public function FindForm() : System.Windows.Forms.Form;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: System.Windows.Forms.Form* FindForm();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
System.Windows.Forms.Form^ FindForm();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Focus Method

[image]
Intersoft WebEssentials Documentation
Focus Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Function Focus() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

value = instance.Focus()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.bool Focus()
Delphi
public function Focus(): System.Boolean;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function Focus() : System.boolean;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: System.bool Focus();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
System.bool Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Font Property

[image]
Intersoft WebEssentials Documentation
Font Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.LocalizableAttribute(True)>
<System.Runtime.InteropServices.DispIdAttribute(-512)>
<SRDescriptionAttribute("The font used to display text in the control.")>
Public Overridable Property Font As System.Drawing.Font
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
[System.ComponentModel.AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.LocalizableAttribute(true)]
[System.Runtime.InteropServices.DispIdAttribute(-512)]
[SRDescriptionAttribute("The font used to display text in the control.")]
public virtual System.Drawing.Font Font {get; set;}
Delphi
public read-write property Font: System.Drawing.Font; virtual;
JScript
System.ComponentModel.AmbientValueAttribute()
SRCategoryAttribute("Appearance")
System.ComponentModel.LocalizableAttribute()
System.Runtime.InteropServices.DispIdAttribute(-512)
SRDescriptionAttribute("The font used to display text in the control.")
public function get,set Font : System.Drawing.Font
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.LocalizableAttribute(true)]
[System.Runtime.InteropServices.DispIdAttribute(-512)]
[SRDescriptionAttribute("The font used to display text in the control.")]
public: __property virtual System.Drawing.Font* get_Font();
public: __property virtual void set_Font(
   System.Drawing.Font* value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.LocalizableAttribute(true)]
[System.Runtime.InteropServices.DispIdAttribute(-512)]
[SRDescriptionAttribute("The font used to display text in the control.")]
public:
virtual property System.Drawing.Font^ Font {
   System.Drawing.Font^ get();
   void set (    System.Drawing.Font^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


FontChanged Event

[image]
Intersoft WebEssentials Documentation
FontChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : FontChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event FontChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.FontChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler FontChanged
Delphi
public event FontChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* FontChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ForeColor Property

[image]
Intersoft WebEssentials Documentation
ForeColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ForeColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The foreground color of this component, which is used to display text.")>
<System.Runtime.InteropServices.DispIdAttribute(-513)>
<SRCategoryAttribute("Appearance")>
Public Overridable Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
[System.Runtime.InteropServices.DispIdAttribute(-513)]
[SRCategoryAttribute("Appearance")]
public virtual System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; virtual;
JScript
SRDescriptionAttribute("The foreground color of this component, which is used to display text.")
System.Runtime.InteropServices.DispIdAttribute(-513)
SRCategoryAttribute("Appearance")
public function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
[System.Runtime.InteropServices.DispIdAttribute(-513)]
[SRCategoryAttribute("Appearance")]
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
C++/CLI
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
[System.Runtime.InteropServices.DispIdAttribute(-513)]
[SRCategoryAttribute("Appearance")]
public:
virtual property System.Drawing.Color ForeColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ForeColorChanged Event

[image]
Intersoft WebEssentials Documentation
ForeColorChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ForeColorChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")>
Public Event ForeColorChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.ForeColorChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")]
public event System.EventHandler ForeColorChanged
Delphi
public event ForeColorChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")]
public: __event System.EventHandler* ForeColorChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")]
public:
event System.EventHandler^ ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


FormBorderStyle Property

[image]
Intersoft WebEssentials Documentation
FormBorderStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : FormBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")>
<System.Runtime.InteropServices.DispIdAttribute(-504)>
<SRCategoryAttribute("Appearance")>
Public Property FormBorderStyle As System.Windows.Forms.FormBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.FormBorderStyle

instance.FormBorderStyle = value

value = instance.FormBorderStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[System.Runtime.InteropServices.DispIdAttribute(-504)]
[SRCategoryAttribute("Appearance")]
public System.Windows.Forms.FormBorderStyle FormBorderStyle {get; set;}
Delphi
public read-write property FormBorderStyle: System.Windows.Forms.FormBorderStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")
System.Runtime.InteropServices.DispIdAttribute(-504)
SRCategoryAttribute("Appearance")
public function get,set FormBorderStyle : System.Windows.Forms.FormBorderStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[System.Runtime.InteropServices.DispIdAttribute(-504)]
[SRCategoryAttribute("Appearance")]
public: __property System.Windows.Forms.FormBorderStyle get_FormBorderStyle();
public: __property void set_FormBorderStyle(
   System.Windows.Forms.FormBorderStyle value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[System.Runtime.InteropServices.DispIdAttribute(-504)]
[SRCategoryAttribute("Appearance")]
public:
property System.Windows.Forms.FormBorderStyle FormBorderStyle {
   System.Windows.Forms.FormBorderStyle get();
   void set (    System.Windows.Forms.FormBorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


FormClosed Event

[image]
Intersoft WebEssentials Documentation
FormClosed Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : FormClosed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")>
Public Event FormClosed As System.Windows.Forms.FormClosedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.FormClosedEventHandler

AddHandler instance.FormClosed, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")]
public event System.Windows.Forms.FormClosedEventHandler FormClosed
Delphi
public event FormClosed: System.Windows.Forms.FormClosedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")]
public: __event System.Windows.Forms.FormClosedEventHandler* FormClosed
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")]
public:
event System.Windows.Forms.FormClosedEventHandler^ FormClosed

Event Data

The event handler receives an argument of type System.Windows.Forms.FormClosedEventArgs containing data related to this event. The following FormClosedEventArgs properties provide information specific to this event.

Property | Description
CloseReason | Gets a value that indicates why the form was closed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


FormClosing Event

[image]
Intersoft WebEssentials Documentation
FormClosing Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : FormClosing Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")>
<SRCategoryAttribute("Behavior")>
Public Event FormClosing As System.Windows.Forms.FormClosingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.FormClosingEventHandler

AddHandler instance.FormClosing, handler
C#
[SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")]
[SRCategoryAttribute("Behavior")]
public event System.Windows.Forms.FormClosingEventHandler FormClosing
Delphi
public event FormClosing: System.Windows.Forms.FormClosingEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")]
[SRCategoryAttribute("Behavior")]
public: __event System.Windows.Forms.FormClosingEventHandler* FormClosing
C++/CLI
[SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")]
[SRCategoryAttribute("Behavior")]
public:
event System.Windows.Forms.FormClosingEventHandler^ FormClosing

Event Data

The event handler receives an argument of type System.Windows.Forms.FormClosingEventArgs containing data related to this event. The following FormClosingEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
CloseReason | Gets a value that indicates why the form is being closed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


GetChildAtPoint Method

[image]
Intersoft WebEssentials Documentation
GetChildAtPoint Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : GetChildAtPoint Method

Glossary Item Box

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


GetChildAtPoint(Point) Method

[image]
Intersoft WebEssentials Documentation
GetChildAtPoint(Point) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetChildAtPoint( _
   ByVal pt As System.Drawing.Point _
) As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim pt As System.Drawing.Point
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt
)
Delphi
public function GetChildAtPoint(
    pt: System.Drawing.Point
): System.Windows.Forms.Control;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetChildAtPoint(
   pt : System.Drawing.Point
) : System.Windows.Forms.Control;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Windows.Forms.Control* GetChildAtPoint(
   System.Drawing.Point pt
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Windows.Forms.Control^ GetChildAtPoint(
   System.Drawing.Point pt
)

Parameters

pt

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
Intersoft WebEssentials Documentation
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
skipValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As System.Drawing.Point, _
   ByVal skipValue As System.Windows.Forms.GetChildAtPointSkip _
) As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim pt As System.Drawing.Point
Dim skipValue As System.Windows.Forms.GetChildAtPointSkip
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt, skipValue)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)
Delphi
public function GetChildAtPoint(
    pt: System.Drawing.Point;
    skipValue: System.Windows.Forms.GetChildAtPointSkip
): System.Windows.Forms.Control;
JScript
public function GetChildAtPoint(
   pt : System.Drawing.Point,
   skipValue : System.Windows.Forms.GetChildAtPointSkip
) : System.Windows.Forms.Control;
Managed Extensions for C++
public: System.Windows.Forms.Control* GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)
C++/CLI
public:
System.Windows.Forms.Control^ GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
skipValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


GetContainerControl Method

[image]
Intersoft WebEssentials Documentation
GetContainerControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : GetContainerControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As System.Windows.Forms.IContainerControl
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.IContainerControl

value = instance.GetContainerControl()
C#
public System.Windows.Forms.IContainerControl GetContainerControl()
Delphi
public function GetContainerControl(): System.Windows.Forms.IContainerControl;
JScript
public function GetContainerControl() : System.Windows.Forms.IContainerControl;
Managed Extensions for C++
public: System.Windows.Forms.IContainerControl* GetContainerControl();
C++/CLI
public:
System.Windows.Forms.IContainerControl^ GetContainerControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


GetLifetimeService Method

[image]
Intersoft WebEssentials Documentation
GetLifetimeService Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : GetLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Function GetLifetimeService() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Object

value = instance.GetLifetimeService()
C#
[System.Security.SecurityCriticalAttribute()]
public System.object GetLifetimeService()
Delphi
public function GetLifetimeService(): System.TObject;
JScript
System.Security.SecurityCriticalAttribute()
public function GetLifetimeService() : System.Object;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: System.Object* GetLifetimeService();
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
System.Object^ GetLifetimeService();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


GetNextControl Method

[image]
Intersoft WebEssentials Documentation
GetNextControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : GetNextControl Method

ctl
forward

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean _
) As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim value As System.Windows.Forms.Control

value = instance.GetNextControl(ctl, forward)
C#
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)
Delphi
public function GetNextControl(
    ctl: System.Windows.Forms.Control;
    forward: System.Boolean
): System.Windows.Forms.Control;
JScript
public function GetNextControl(
   ctl : System.Windows.Forms.Control,
   forward : System.boolean
) : System.Windows.Forms.Control;
Managed Extensions for C++
public: System.Windows.Forms.Control* GetNextControl(
   System.Windows.Forms.Control* ctl,
   System.bool forward
)
C++/CLI
public:
System.Windows.Forms.Control^ GetNextControl(
   System.Windows.Forms.Control^ ctl,
   System.bool forward
)

Parameters

ctl
forward

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


GetPreferredSize Method

[image]
Intersoft WebEssentials Documentation
GetPreferredSize Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : GetPreferredSize Method

proposedSize

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As System.Drawing.Size _
) As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim proposedSize As System.Drawing.Size
Dim value As System.Drawing.Size

value = instance.GetPreferredSize(proposedSize)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)
Delphi
public function GetPreferredSize(
    proposedSize: System.Drawing.Size
): System.Drawing.Size; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function GetPreferredSize(
   proposedSize : System.Drawing.Size
) : System.Drawing.Size;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)

Parameters

proposedSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


GiveFeedback Event

[image]
Intersoft WebEssentials Documentation
GiveFeedback Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : GiveFeedback Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")>
Public Event GiveFeedback As System.Windows.Forms.GiveFeedbackEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.GiveFeedbackEventHandler

AddHandler instance.GiveFeedback, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")]
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback
Delphi
public event GiveFeedback: System.Windows.Forms.GiveFeedbackEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")]
public: __event System.Windows.Forms.GiveFeedbackEventHandler* GiveFeedback
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")]
public:
event System.Windows.Forms.GiveFeedbackEventHandler^ GiveFeedback

Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


HelpButton Property

[image]
Intersoft WebEssentials Documentation
HelpButton Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : HelpButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HelpButton As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.HelpButton = value

value = instance.HelpButton
C#
[SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool HelpButton {get; set;}
Delphi
public read-write property HelpButton: System.Boolean;
JScript
SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
public function get,set HelpButton : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_HelpButton();
public: __property void set_HelpButton(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool HelpButton {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


HelpButtonClicked Event

[image]
Intersoft WebEssentials Documentation
HelpButtonClicked Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : HelpButtonClicked Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the help button is clicked.")>
<System.ComponentModel.EditorBrowsableAttribute()>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.BrowsableAttribute(True)>
Public Event HelpButtonClicked As System.ComponentModel.CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.HelpButtonClicked, handler
C#
[SRDescriptionAttribute("Event raised when the help button is clicked.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(true)]
public event System.ComponentModel.CancelEventHandler HelpButtonClicked
Delphi
public event HelpButtonClicked: System.ComponentModel.CancelEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the help button is clicked.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(true)]
public: __event System.ComponentModel.CancelEventHandler* HelpButtonClicked
C++/CLI
[SRDescriptionAttribute("Event raised when the help button is clicked.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(true)]
public:
event System.ComponentModel.CancelEventHandler^ HelpButtonClicked

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


HelpRequested Event

[image]
Intersoft WebEssentials Documentation
HelpRequested Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : HelpRequested Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the user invokes Help for the control.")>
<SRCategoryAttribute("Behavior")>
Public Event HelpRequested As System.Windows.Forms.HelpEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.HelpEventHandler

AddHandler instance.HelpRequested, handler
C#
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
[SRCategoryAttribute("Behavior")]
public event System.Windows.Forms.HelpEventHandler HelpRequested
Delphi
public event HelpRequested: System.Windows.Forms.HelpEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
[SRCategoryAttribute("Behavior")]
public: __event System.Windows.Forms.HelpEventHandler* HelpRequested
C++/CLI
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
[SRCategoryAttribute("Behavior")]
public:
event System.Windows.Forms.HelpEventHandler^ HelpRequested

Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Hide Method

[image]
Intersoft WebEssentials Documentation
Hide Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Hide Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Sub Hide()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.Hide()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Hide()
Delphi
public procedure Hide();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Hide();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Hide();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Hide();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Icon Property

[image]
Intersoft WebEssentials Documentation
Icon Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Icon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Property Icon As System.Drawing.Icon
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Icon

instance.Icon = value

value = instance.Icon
C#
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.LocalizableAttribute(true)]
public System.Drawing.Icon Icon {get; set;}
Delphi
public read-write property Icon: System.Drawing.Icon;
JScript
System.ComponentModel.AmbientValueAttribute()
SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")
SRCategoryAttribute("Window Style")
System.ComponentModel.LocalizableAttribute()
public function get,set Icon : System.Drawing.Icon
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property System.Drawing.Icon* get_Icon();
public: __property void set_Icon(
   System.Drawing.Icon* value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
property System.Drawing.Icon^ Icon {
   System.Drawing.Icon^ get();
   void set (    System.Drawing.Icon^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ImeMode Property

[image]
Intersoft WebEssentials Documentation
ImeMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ImeMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Property ImeMode As System.Windows.Forms.ImeMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.ImeMode

instance.ImeMode = value

value = instance.ImeMode
C#
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.LocalizableAttribute(true)]
public System.Windows.Forms.ImeMode ImeMode {get; set;}
Delphi
public read-write property ImeMode: System.Windows.Forms.ImeMode;
JScript
System.ComponentModel.AmbientValueAttribute()
SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")
SRCategoryAttribute("Behavior")
System.ComponentModel.LocalizableAttribute()
public function get,set ImeMode : System.Windows.Forms.ImeMode
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property System.Windows.Forms.ImeMode get_ImeMode();
public: __property void set_ImeMode(
   System.Windows.Forms.ImeMode value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
property System.Windows.Forms.ImeMode ImeMode {
   System.Windows.Forms.ImeMode get();
   void set (    System.Windows.Forms.ImeMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ImeModeChanged Event

[image]
Intersoft WebEssentials Documentation
ImeModeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ImeModeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WinCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")>
Public Event ImeModeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.ImeModeChanged, handler
C#
[WinCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")]
public event System.EventHandler ImeModeChanged
Delphi
public event ImeModeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WinCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")]
public: __event System.EventHandler* ImeModeChanged
C++/CLI
[WinCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")]
public:
event System.EventHandler^ ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


InitializeLifetimeService Method

[image]
Intersoft WebEssentials Documentation
InitializeLifetimeService Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : InitializeLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Object

value = instance.InitializeLifetimeService()
C#
[System.Security.SecurityCriticalAttribute()]
public virtual System.object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): System.TObject; virtual;
JScript
System.Security.SecurityCriticalAttribute()
public function InitializeLifetimeService() : System.Object;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: virtual System.Object* InitializeLifetimeService();
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
virtual System.Object^ InitializeLifetimeService();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


InputLanguageChanged Event

[image]
Intersoft WebEssentials Documentation
InputLanguageChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : InputLanguageChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")>
<SRCategoryAttribute("Behavior")>
Public Event InputLanguageChanged As System.Windows.Forms.InputLanguageChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.InputLanguageChangedEventHandler

AddHandler instance.InputLanguageChanged, handler
C#
[SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")]
[SRCategoryAttribute("Behavior")]
public event System.Windows.Forms.InputLanguageChangedEventHandler InputLanguageChanged
Delphi
public event InputLanguageChanged: System.Windows.Forms.InputLanguageChangedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")]
[SRCategoryAttribute("Behavior")]
public: __event System.Windows.Forms.InputLanguageChangedEventHandler* InputLanguageChanged
C++/CLI
[SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")]
[SRCategoryAttribute("Behavior")]
public:
event System.Windows.Forms.InputLanguageChangedEventHandler^ InputLanguageChanged

Event Data

The event handler receives an argument of type System.Windows.Forms.InputLanguageChangedEventArgs containing data related to this event. The following InputLanguageChangedEventArgs properties provide information specific to this event.

Property | Description
CharSet | Gets the character set associated with the new input language.
Culture | Gets the locale of the input language.
InputLanguage | Gets a value indicating the input language.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


InputLanguageChanging Event

[image]
Intersoft WebEssentials Documentation
InputLanguageChanging Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : InputLanguageChanging Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")>
Public Event InputLanguageChanging As System.Windows.Forms.InputLanguageChangingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.InputLanguageChangingEventHandler

AddHandler instance.InputLanguageChanging, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")]
public event System.Windows.Forms.InputLanguageChangingEventHandler InputLanguageChanging
Delphi
public event InputLanguageChanging: System.Windows.Forms.InputLanguageChangingEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")]
public: __event System.Windows.Forms.InputLanguageChangingEventHandler* InputLanguageChanging
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")]
public:
event System.Windows.Forms.InputLanguageChangingEventHandler^ InputLanguageChanging

Event Data

The event handler receives an argument of type System.Windows.Forms.InputLanguageChangingEventArgs containing data related to this event. The following InputLanguageChangingEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
Culture | Gets the locale of the requested input language.
InputLanguage | Gets a value indicating the input language.
SysCharSet | Gets a value indicating whether the system default font supports the character set required for the requested input language.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Invalidate Method

[image]
Intersoft WebEssentials Documentation
Invalidate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Invalidate Method

Glossary Item Box

Overload List

Overload | Description
Invalidate(Region) | (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate() | (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Invalidate() Method

[image]
Intersoft WebEssentials Documentation
Invalidate() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Invalidate()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.Invalidate()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Invalidate()
Delphi
public procedure Invalidate();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invalidate();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Invalidate();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Invalidate();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


Invalidate(Boolean) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim invalidateChildren As System.Boolean

instance.Invalidate(invalidateChildren)
C#
public void Invalidate(
   System.bool invalidateChildren
)
Delphi
public procedure Invalidate(
    invalidateChildren: System.Boolean
);
JScript
public function Invalidate(
   invalidateChildren : System.boolean
);
Managed Extensions for C++
public: void Invalidate(
   System.bool invalidateChildren
)
C++/CLI
public:
void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


Invalidate(Rectangle) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Rectangle) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > Invalidate Method : Invalidate(Rectangle) Method

rc

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Invalidate( _
   ByVal rc As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim rc As System.Drawing.Rectangle

instance.Invalidate(rc)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Invalidate(
   System.Drawing.Rectangle rc
)
Delphi
public procedure Invalidate(
    rc: System.Drawing.Rectangle
);
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invalidate(
   rc : System.Drawing.Rectangle
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Invalidate(
   System.Drawing.Rectangle rc
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Invalidate(
   System.Drawing.Rectangle rc
)

Parameters

rc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Rectangle,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
invalidateChildren

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As System.Drawing.Rectangle, _
   ByVal invalidateChildren As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim rc As System.Drawing.Rectangle
Dim invalidateChildren As System.Boolean

instance.Invalidate(rc, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)
Delphi
public procedure Invalidate(
    rc: System.Drawing.Rectangle;
    invalidateChildren: System.Boolean
);
JScript
public function Invalidate(
   rc : System.Drawing.Rectangle,
   invalidateChildren : System.boolean
);
Managed Extensions for C++
public: void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)
C++/CLI
public:
void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
invalidateChildren

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


Invalidate(Region) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Region) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > Invalidate Method : Invalidate(Region) Method

region

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Invalidate( _
   ByVal region As System.Drawing.Region _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim region As System.Drawing.Region

instance.Invalidate(region)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Invalidate(
   System.Drawing.Region region
)
Delphi
public procedure Invalidate(
    region: System.Drawing.Region
);
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invalidate(
   region : System.Drawing.Region
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Invalidate(
   System.Drawing.Region* region
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Invalidate(
   System.Drawing.Region^ region
)

Parameters

region

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


Invalidate(Region,Boolean) Method

[image]
Intersoft WebEssentials Documentation
Invalidate(Region,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
invalidateChildren

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As System.Drawing.Region, _
   ByVal invalidateChildren As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim region As System.Drawing.Region
Dim invalidateChildren As System.Boolean

instance.Invalidate(region, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Region region,
   System.bool invalidateChildren
)
Delphi
public procedure Invalidate(
    region: System.Drawing.Region;
    invalidateChildren: System.Boolean
);
JScript
public function Invalidate(
   region : System.Drawing.Region,
   invalidateChildren : System.boolean
);
Managed Extensions for C++
public: void Invalidate(
   System.Drawing.Region* region,
   System.bool invalidateChildren
)
C++/CLI
public:
void Invalidate(
   System.Drawing.Region^ region,
   System.bool invalidateChildren
)

Parameters

region
invalidateChildren

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


Invoke Method

[image]
Intersoft WebEssentials Documentation
Invoke Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Invoke Method

Glossary Item Box

Overload List

Overload | Description
Invoke(Delegate) | (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Invoke(Delegate) Method

[image]
Intersoft WebEssentials Documentation
Invoke(Delegate) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > Invoke Method : Invoke(Delegate) Method

method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function Invoke( _
   ByVal method As System.Delegate _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim method As System.Delegate
Dim value As System.Object

value = instance.Invoke(method)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object Invoke(
   System.Delegate method
)
Delphi
public function Invoke(
    method: System.Delegate
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invoke(
   method : System.Delegate
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* Invoke(
   System.Delegate* method
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ Invoke(
   System.Delegate^ method
)

Parameters

method

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
Intersoft WebEssentials Documentation
Invoke(Delegate,Object[]) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.Object

value = instance.Invoke(method, args)
C#
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)
Delphi
public function Invoke(
    method: System.Delegate;
   params  args: System.TObjectarray of
): System.TObject;
JScript
public function Invoke(
   method : System.Delegate,
   args : System.Object[]
) : System.Object;
Managed Extensions for C++
public: System.Object* Invoke(
   System.Delegate* method,
   params System.Object*[]* args
)
C++/CLI
public:
System.Object^ Invoke(
   System.Delegate^ method,
   ... System.array<Object^>^ args
)

Parameters

method
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


IsMdiContainer Property

[image]
Intersoft WebEssentials Documentation
IsMdiContainer Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : IsMdiContainer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Determines whether the form is an MDI container.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property IsMdiContainer As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.IsMdiContainer = value

value = instance.IsMdiContainer
C#
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool IsMdiContainer {get; set;}
Delphi
public read-write property IsMdiContainer: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Determines whether the form is an MDI container.")
System.ComponentModel.DefaultValueAttribute()
public function get,set IsMdiContainer : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_IsMdiContainer();
public: __property void set_IsMdiContainer(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool IsMdiContainer {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


KeyDown Event

[image]
Intersoft WebEssentials Documentation
KeyDown Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : KeyDown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a key is first pressed.")>
<SRCategoryAttribute("Key")>
Public Event KeyDown As System.Windows.Forms.KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyDown, handler
C#
[SRDescriptionAttribute("Occurs when a key is first pressed.")]
[SRCategoryAttribute("Key")]
public event System.Windows.Forms.KeyEventHandler KeyDown
Delphi
public event KeyDown: System.Windows.Forms.KeyEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a key is first pressed.")]
[SRCategoryAttribute("Key")]
public: __event System.Windows.Forms.KeyEventHandler* KeyDown
C++/CLI
[SRDescriptionAttribute("Occurs when a key is first pressed.")]
[SRCategoryAttribute("Key")]
public:
event System.Windows.Forms.KeyEventHandler^ KeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


KeyPress Event

[image]
Intersoft WebEssentials Documentation
KeyPress Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : KeyPress Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Key")>
<SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")>
Public Event KeyPress As System.Windows.Forms.KeyPressEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.KeyPressEventHandler

AddHandler instance.KeyPress, handler
C#
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")]
public event System.Windows.Forms.KeyPressEventHandler KeyPress
Delphi
public event KeyPress: System.Windows.Forms.KeyPressEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")]
public: __event System.Windows.Forms.KeyPressEventHandler* KeyPress
C++/CLI
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")]
public:
event System.Windows.Forms.KeyPressEventHandler^ KeyPress

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


KeyPreview Property

[image]
Intersoft WebEssentials Documentation
KeyPreview Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : KeyPreview Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property KeyPreview As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.KeyPreview = value

value = instance.KeyPreview
C#
[SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool KeyPreview {get; set;}
Delphi
public read-write property KeyPreview: System.Boolean;
JScript
SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")
System.ComponentModel.DefaultValueAttribute()
public function get,set KeyPreview : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_KeyPreview();
public: __property void set_KeyPreview(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool KeyPreview {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


KeyUp Event

[image]
Intersoft WebEssentials Documentation
KeyUp Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : KeyUp Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a key is released.")>
<SRCategoryAttribute("Key")>
Public Event KeyUp As System.Windows.Forms.KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyUp, handler
C#
[SRDescriptionAttribute("Occurs when a key is released.")]
[SRCategoryAttribute("Key")]
public event System.Windows.Forms.KeyEventHandler KeyUp
Delphi
public event KeyUp: System.Windows.Forms.KeyEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a key is released.")]
[SRCategoryAttribute("Key")]
public: __event System.Windows.Forms.KeyEventHandler* KeyUp
C++/CLI
[SRDescriptionAttribute("Occurs when a key is released.")]
[SRCategoryAttribute("Key")]
public:
event System.Windows.Forms.KeyEventHandler^ KeyUp

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Layout Event

[image]
Intersoft WebEssentials Documentation
Layout Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Layout Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")>
Public Event Layout As System.Windows.Forms.LayoutEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.LayoutEventHandler

AddHandler instance.Layout, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")]
public event System.Windows.Forms.LayoutEventHandler Layout
Delphi
public event Layout: System.Windows.Forms.LayoutEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")]
public: __event System.Windows.Forms.LayoutEventHandler* Layout
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")]
public:
event System.Windows.Forms.LayoutEventHandler^ Layout

Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


LayoutMdi Method

[image]
Intersoft WebEssentials Documentation
LayoutMdi Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : LayoutMdi Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub LayoutMdi( _
   ByVal value As System.Windows.Forms.MdiLayout _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.MdiLayout

instance.LayoutMdi(value)
C#
public void LayoutMdi(
   System.Windows.Forms.MdiLayout value
)
Delphi
public procedure LayoutMdi(
    value: System.Windows.Forms.MdiLayout
);
JScript
public function LayoutMdi(
   value : System.Windows.Forms.MdiLayout
);
Managed Extensions for C++
public: void LayoutMdi(
   System.Windows.Forms.MdiLayout value
)
C++/CLI
public:
void LayoutMdi(
   System.Windows.Forms.MdiLayout value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Leave Event

[image]
Intersoft WebEssentials Documentation
Leave Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Leave Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")>
Public Event Leave As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.Leave, handler
C#
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")]
public event System.EventHandler Leave
Delphi
public event Leave: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")]
public: __event System.EventHandler* Leave
C++/CLI
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")]
public:
event System.EventHandler^ Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Load Event

[image]
Intersoft WebEssentials Documentation
Load Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the user loads the form.")>
<SRCategoryAttribute("Behavior")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[SRDescriptionAttribute("Occurs whenever the user loads the form.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the user loads the form.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* Load
C++/CLI
[SRDescriptionAttribute("Occurs whenever the user loads the form.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Location Property

[image]
Intersoft WebEssentials Documentation
Location Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Location Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.SettingsBindableAttribute(True)>
Public Property Location As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
C#
[System.ComponentModel.SettingsBindableAttribute(true)]
public System.Drawing.Point Location {get; set;}
Delphi
public read-write property Location: System.Drawing.Point;
JScript
System.ComponentModel.SettingsBindableAttribute()
public function get,set Location : System.Drawing.Point
Managed Extensions for C++
[System.ComponentModel.SettingsBindableAttribute(true)]
public: __property System.Drawing.Point get_Location();
public: __property void set_Location(
   System.Drawing.Point value
);
C++/CLI
[System.ComponentModel.SettingsBindableAttribute(true)]
public:
property System.Drawing.Point Location {
   System.Drawing.Point get();
   void set (    System.Drawing.Point value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


LocationChanged Event

[image]
Intersoft WebEssentials Documentation
LocationChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : LocationChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")>
Public Event LocationChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.LocationChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")]
public event System.EventHandler LocationChanged
Delphi
public event LocationChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")]
public: __event System.EventHandler* LocationChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")]
public:
event System.EventHandler^ LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MainMenuStrip Property

[image]
Intersoft WebEssentials Documentation
MainMenuStrip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MainMenuStrip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")>
Public Property MainMenuStrip As System.Windows.Forms.MenuStrip
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.MenuStrip

instance.MainMenuStrip = value

value = instance.MainMenuStrip
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")]
public System.Windows.Forms.MenuStrip MainMenuStrip {get; set;}
Delphi
public read-write property MainMenuStrip: System.Windows.Forms.MenuStrip;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")
public function get,set MainMenuStrip : System.Windows.Forms.MenuStrip
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")]
public: __property System.Windows.Forms.MenuStrip* get_MainMenuStrip();
public: __property void set_MainMenuStrip(
   System.Windows.Forms.MenuStrip* value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")]
public:
property System.Windows.Forms.MenuStrip^ MainMenuStrip {
   System.Windows.Forms.MenuStrip^ get();
   void set (    System.Windows.Forms.MenuStrip^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MaximizeBox Property

[image]
Intersoft WebEssentials Documentation
MaximizeBox Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MaximizeBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MaximizeBox As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.MaximizeBox = value

value = instance.MaximizeBox
C#
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool MaximizeBox {get; set;}
Delphi
public read-write property MaximizeBox: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")
System.ComponentModel.DefaultValueAttribute()
public function get,set MaximizeBox : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_MaximizeBox();
public: __property void set_MaximizeBox(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool MaximizeBox {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MaximizedBoundsChanged Event

[image]
Intersoft WebEssentials Documentation
MaximizedBoundsChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MaximizedBoundsChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")>
<SRCategoryAttribute("Property Changed")>
Public Event MaximizedBoundsChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.MaximizedBoundsChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler MaximizedBoundsChanged
Delphi
public event MaximizedBoundsChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* MaximizedBoundsChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ MaximizedBoundsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MaximumSize Property

[image]
Intersoft WebEssentials Documentation
MaximumSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MaximumSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("The maximum size the form can be resized to.")>
Public Overridable Property MaximumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The maximum size the form can be resized to.")]
public virtual System.Drawing.Size MaximumSize {get; set;}
Delphi
public read-write property MaximumSize: System.Drawing.Size; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
SRCategoryAttribute("Layout")
SRDescriptionAttribute("The maximum size the form can be resized to.")
public function get,set MaximumSize : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The maximum size the form can be resized to.")]
public: __property virtual System.Drawing.Size get_MaximumSize();
public: __property virtual void set_MaximumSize(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The maximum size the form can be resized to.")]
public:
virtual property System.Drawing.Size MaximumSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MaximumSizeChanged Event

[image]
Intersoft WebEssentials Documentation
MaximumSizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MaximumSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")>
Public Event MaximumSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.MaximumSizeChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")]
public event System.EventHandler MaximumSizeChanged
Delphi
public event MaximumSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")]
public: __event System.EventHandler* MaximumSizeChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")]
public:
event System.EventHandler^ MaximumSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MdiChildActivate Event

[image]
Intersoft WebEssentials Documentation
MdiChildActivate Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MdiChildActivate Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when an MDI Child window is activated.")>
Public Event MdiChildActivate As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.MdiChildActivate, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when an MDI Child window is activated.")]
public event System.EventHandler MdiChildActivate
Delphi
public event MdiChildActivate: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when an MDI Child window is activated.")]
public: __event System.EventHandler* MdiChildActivate
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when an MDI Child window is activated.")]
public:
event System.EventHandler^ MdiChildActivate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MinimizeBox Property

[image]
Intersoft WebEssentials Documentation
MinimizeBox Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MinimizeBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")>
Public Property MinimizeBox As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.MinimizeBox = value

value = instance.MinimizeBox
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public System.bool MinimizeBox {get; set;}
Delphi
public read-write property MinimizeBox: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")
public function get,set MinimizeBox : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public: __property System.bool get_MinimizeBox();
public: __property void set_MinimizeBox(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public:
property System.bool MinimizeBox {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MinimumSize Property

[image]
Intersoft WebEssentials Documentation
MinimumSize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MinimumSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The minimum size the form can be resized to.")>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Overridable Property MinimumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
[SRDescriptionAttribute("The minimum size the form can be resized to.")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
public virtual System.Drawing.Size MinimumSize {get; set;}
Delphi
public read-write property MinimumSize: System.Drawing.Size; virtual;
JScript
SRDescriptionAttribute("The minimum size the form can be resized to.")
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
SRCategoryAttribute("Layout")
System.ComponentModel.LocalizableAttribute()
public function get,set MinimumSize : System.Drawing.Size
Managed Extensions for C++
[SRDescriptionAttribute("The minimum size the form can be resized to.")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property virtual System.Drawing.Size get_MinimumSize();
public: __property virtual void set_MinimumSize(
   System.Drawing.Size value
);
C++/CLI
[SRDescriptionAttribute("The minimum size the form can be resized to.")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
virtual property System.Drawing.Size MinimumSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MinimumSizeChanged Event

[image]
Intersoft WebEssentials Documentation
MinimumSizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MinimumSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")>
<SRCategoryAttribute("Property Changed")>
Public Event MinimumSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.MinimumSizeChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler MinimumSizeChanged
Delphi
public event MinimumSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* MinimumSizeChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ MinimumSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MouseCaptureChanged Event

[image]
Intersoft WebEssentials Documentation
MouseCaptureChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MouseCaptureChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs after the mouse capture is changed.")>
<SRCategoryAttribute("Action")>
Public Event MouseCaptureChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.MouseCaptureChanged, handler
C#
[SRDescriptionAttribute("Occurs after the mouse capture is changed.")]
[SRCategoryAttribute("Action")]
public event System.EventHandler MouseCaptureChanged
Delphi
public event MouseCaptureChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs after the mouse capture is changed.")]
[SRCategoryAttribute("Action")]
public: __event System.EventHandler* MouseCaptureChanged
C++/CLI
[SRDescriptionAttribute("Occurs after the mouse capture is changed.")]
[SRCategoryAttribute("Action")]
public:
event System.EventHandler^ MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MouseClick Event

[image]
Intersoft WebEssentials Documentation
MouseClick Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MouseClick Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")>
<SRCategoryAttribute("Action")>
Public Event MouseClick As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseClick, handler
C#
[SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")]
[SRCategoryAttribute("Action")]
public event System.Windows.Forms.MouseEventHandler MouseClick
Delphi
public event MouseClick: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")]
[SRCategoryAttribute("Action")]
public: __event System.Windows.Forms.MouseEventHandler* MouseClick
C++/CLI
[SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")]
[SRCategoryAttribute("Action")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MouseDoubleClick Event

[image]
Intersoft WebEssentials Documentation
MouseDoubleClick Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MouseDoubleClick Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")>
Public Event MouseDoubleClick As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDoubleClick, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")]
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick
Delphi
public event MouseDoubleClick: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")]
public: __event System.Windows.Forms.MouseEventHandler* MouseDoubleClick
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseDoubleClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MouseDown Event

[image]
Intersoft WebEssentials Documentation
MouseDown Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MouseDown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseDown As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDown, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")]
[SRCategoryAttribute("Mouse")]
public event System.Windows.Forms.MouseEventHandler MouseDown
Delphi
public event MouseDown: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")]
[SRCategoryAttribute("Mouse")]
public: __event System.Windows.Forms.MouseEventHandler* MouseDown
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")]
[SRCategoryAttribute("Mouse")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseDown

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MouseEnter Event

[image]
Intersoft WebEssentials Documentation
MouseEnter Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MouseEnter Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseEnter As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.MouseEnter, handler
C#
[SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")]
[SRCategoryAttribute("Mouse")]
public event System.EventHandler MouseEnter
Delphi
public event MouseEnter: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")]
[SRCategoryAttribute("Mouse")]
public: __event System.EventHandler* MouseEnter
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")]
[SRCategoryAttribute("Mouse")]
public:
event System.EventHandler^ MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MouseHover Event

[image]
Intersoft WebEssentials Documentation
MouseHover Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MouseHover Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")>
Public Event MouseHover As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.MouseHover, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")]
public event System.EventHandler MouseHover
Delphi
public event MouseHover: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")]
public: __event System.EventHandler* MouseHover
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")]
public:
event System.EventHandler^ MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MouseLeave Event

[image]
Intersoft WebEssentials Documentation
MouseLeave Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MouseLeave Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")>
Public Event MouseLeave As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.MouseLeave, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")]
public event System.EventHandler MouseLeave
Delphi
public event MouseLeave: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")]
public: __event System.EventHandler* MouseLeave
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")]
public:
event System.EventHandler^ MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MouseMove Event

[image]
Intersoft WebEssentials Documentation
MouseMove Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MouseMove Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseMove As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseMove, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")]
[SRCategoryAttribute("Mouse")]
public event System.Windows.Forms.MouseEventHandler MouseMove
Delphi
public event MouseMove: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")]
[SRCategoryAttribute("Mouse")]
public: __event System.Windows.Forms.MouseEventHandler* MouseMove
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")]
[SRCategoryAttribute("Mouse")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseMove

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


MouseUp Event

[image]
Intersoft WebEssentials Documentation
MouseUp Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : MouseUp Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseUp As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseUp, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")]
[SRCategoryAttribute("Mouse")]
public event System.Windows.Forms.MouseEventHandler MouseUp
Delphi
public event MouseUp: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")]
[SRCategoryAttribute("Mouse")]
public: __event System.Windows.Forms.MouseEventHandler* MouseUp
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")]
[SRCategoryAttribute("Mouse")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseUp

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Move Event

[image]
Intersoft WebEssentials Documentation
Move Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Move Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when a control is moved.")>
Public Event Move As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.Move, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when a control is moved.")]
public event System.EventHandler Move
Delphi
public event Move: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when a control is moved.")]
public: __event System.EventHandler* Move
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when a control is moved.")]
public:
event System.EventHandler^ Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Opacity Property

[image]
Intersoft WebEssentials Documentation
Opacity Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Opacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("The opacity percentage of the control. ")>
<System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property Opacity As System.Double
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Double

instance.Opacity = value

value = instance.Opacity
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The opacity percentage of the control. ")]
[System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public System.double Opacity {get; set;}
Delphi
public read-write property Opacity: System.Double;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("The opacity percentage of the control. ")
System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set Opacity : System.double
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The opacity percentage of the control. ")]
[System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property System.double get_Opacity();
public: __property void set_Opacity(
   System.double value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The opacity percentage of the control. ")]
[System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property System.double Opacity {
   System.double get();
   void set (    System.double value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Padding Property

[image]
Intersoft WebEssentials Documentation
Padding Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Padding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Specifies the interior spacing of a control.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
Public Property Padding As System.Windows.Forms.Padding
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.Padding

instance.Padding = value

value = instance.Padding
C#
[SRDescriptionAttribute("Specifies the interior spacing of a control.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public System.Windows.Forms.Padding Padding {get; set;}
Delphi
public read-write property Padding: System.Windows.Forms.Padding;
JScript
SRDescriptionAttribute("Specifies the interior spacing of a control.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Layout")
public function get,set Padding : System.Windows.Forms.Padding
Managed Extensions for C++
[SRDescriptionAttribute("Specifies the interior spacing of a control.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public: __property System.Windows.Forms.Padding get_Padding();
public: __property void set_Padding(
   System.Windows.Forms.Padding value
);
C++/CLI
[SRDescriptionAttribute("Specifies the interior spacing of a control.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public:
property System.Windows.Forms.Padding Padding {
   System.Windows.Forms.Padding get();
   void set (    System.Windows.Forms.Padding value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


PaddingChanged Event

[image]
Intersoft WebEssentials Documentation
PaddingChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : PaddingChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when the Padding property has changed.")>
Public Event PaddingChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.PaddingChanged, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the Padding property has changed.")]
public event System.EventHandler PaddingChanged
Delphi
public event PaddingChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the Padding property has changed.")]
public: __event System.EventHandler* PaddingChanged
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the Padding property has changed.")]
public:
event System.EventHandler^ PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Paint Event

[image]
Intersoft WebEssentials Documentation
Paint Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Paint Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a control needs repainting.")>
<SRCategoryAttribute("Appearance")>
Public Event Paint As System.Windows.Forms.PaintEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.PaintEventHandler

AddHandler instance.Paint, handler
C#
[SRDescriptionAttribute("Occurs when a control needs repainting.")]
[SRCategoryAttribute("Appearance")]
public event System.Windows.Forms.PaintEventHandler Paint
Delphi
public event Paint: System.Windows.Forms.PaintEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a control needs repainting.")]
[SRCategoryAttribute("Appearance")]
public: __event System.Windows.Forms.PaintEventHandler* Paint
C++/CLI
[SRDescriptionAttribute("Occurs when a control needs repainting.")]
[SRCategoryAttribute("Appearance")]
public:
event System.Windows.Forms.PaintEventHandler^ Paint

Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ParentChanged Event

[image]
Intersoft WebEssentials Documentation
ParentChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ParentChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")>
Public Event ParentChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.ParentChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public event System.EventHandler ParentChanged
Delphi
public event ParentChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public: __event System.EventHandler* ParentChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public:
event System.EventHandler^ ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


PerformAutoScale Method

[image]
Intersoft WebEssentials Documentation
PerformAutoScale Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : PerformAutoScale Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Sub PerformAutoScale()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.PerformAutoScale()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void PerformAutoScale()
Delphi
public procedure PerformAutoScale();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function PerformAutoScale();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void PerformAutoScale();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void PerformAutoScale();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


PerformLayout Method

[image]
Intersoft WebEssentials Documentation
PerformLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : PerformLayout Method

Glossary Item Box

Overload List

Overload | Description
PerformLayout() | (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


PerformLayout() Method

[image]
Intersoft WebEssentials Documentation
PerformLayout() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Sub PerformLayout()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.PerformLayout()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void PerformLayout()
Delphi
public procedure PerformLayout();
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function PerformLayout();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void PerformLayout();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void PerformLayout();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


PerformLayout(Control,String) Method

[image]
Intersoft WebEssentials Documentation
PerformLayout(Control,String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
affectedProperty

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As System.Windows.Forms.Control, _
   ByVal affectedProperty As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim affectedControl As System.Windows.Forms.Control
Dim affectedProperty As System.String

instance.PerformLayout(affectedControl, affectedProperty)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)
Delphi
public procedure PerformLayout(
    affectedControl: System.Windows.Forms.Control;
    affectedProperty: System.String
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function PerformLayout(
   affectedControl : System.Windows.Forms.Control,
   affectedProperty : System.String
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void PerformLayout(
   System.Windows.Forms.Control* affectedControl,
   System.string* affectedProperty
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void PerformLayout(
   System.Windows.Forms.Control^ affectedControl,
   System.String^ affectedProperty
)

Parameters

affectedControl
affectedProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


PointToClient Method

[image]
Intersoft WebEssentials Documentation
PointToClient Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : PointToClient Method

p

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Function PointToClient( _
   ByVal p As System.Drawing.Point _
) As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToClient(p)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Drawing.Point PointToClient(
   System.Drawing.Point p
)
Delphi
public function PointToClient(
    p: System.Drawing.Point
): System.Drawing.Point;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function PointToClient(
   p : System.Drawing.Point
) : System.Drawing.Point;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Drawing.Point PointToClient(
   System.Drawing.Point p
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Drawing.Point PointToClient(
   System.Drawing.Point p
)

Parameters

p

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


PointToScreen Method

[image]
Intersoft WebEssentials Documentation
PointToScreen Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : PointToScreen Method

p

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As System.Drawing.Point _
) As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToScreen(p)
C#
public System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)
Delphi
public function PointToScreen(
    p: System.Drawing.Point
): System.Drawing.Point;
JScript
public function PointToScreen(
   p : System.Drawing.Point
) : System.Drawing.Point;
Managed Extensions for C++
public: System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)
C++/CLI
public:
System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)

Parameters

p

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


PreProcessControlMessage Method

[image]
Intersoft WebEssentials Documentation
PreProcessControlMessage Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : PreProcessControlMessage Method

msg

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
Public Function PreProcessControlMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Windows.Forms.PreProcessControlState
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim msg As System.Windows.Forms.Message
Dim value As System.Windows.Forms.PreProcessControlState

value = instance.PreProcessControlMessage(msg)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)
Delphi
public function PreProcessControlMessage(
   var  msg: System.Windows.Forms.Message
): System.Windows.Forms.PreProcessControlState;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
public function PreProcessControlMessage(
   msg : System.Windows.Forms.Message
) : System.Windows.Forms.PreProcessControlState;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public: System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public:
System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   System.Windows.Forms.Message% msg
)

Parameters

msg

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


PreProcessMessage Method

[image]
Intersoft WebEssentials Documentation
PreProcessMessage Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : PreProcessMessage Method

msg

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Overridable Function PreProcessMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim msg As System.Windows.Forms.Message
Dim value As System.Boolean

value = instance.PreProcessMessage(msg)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)
Delphi
public function PreProcessMessage(
   var  msg: System.Windows.Forms.Message
): System.Boolean; virtual;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public function PreProcessMessage(
   msg : System.Windows.Forms.Message
) : System.boolean;
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public: virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public:
virtual System.bool PreProcessMessage(
   System.Windows.Forms.Message% msg
)

Parameters

msg

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


PreviewKeyDown Event

[image]
Intersoft WebEssentials Documentation
PreviewKeyDown Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : PreviewKeyDown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Key")>
<SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")>
Public Event PreviewKeyDown As System.Windows.Forms.PreviewKeyDownEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.PreviewKeyDownEventHandler

AddHandler instance.PreviewKeyDown, handler
C#
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")]
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown
Delphi
public event PreviewKeyDown: System.Windows.Forms.PreviewKeyDownEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")]
public: __event System.Windows.Forms.PreviewKeyDownEventHandler* PreviewKeyDown
C++/CLI
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")]
public:
event System.Windows.Forms.PreviewKeyDownEventHandler^ PreviewKeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


QueryAccessibilityHelp Event

[image]
Intersoft WebEssentials Documentation
QueryAccessibilityHelp Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : QueryAccessibilityHelp Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")>
Public Event QueryAccessibilityHelp As System.Windows.Forms.QueryAccessibilityHelpEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.QueryAccessibilityHelpEventHandler

AddHandler instance.QueryAccessibilityHelp, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")]
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp
Delphi
public event QueryAccessibilityHelp: System.Windows.Forms.QueryAccessibilityHelpEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")]
public: __event System.Windows.Forms.QueryAccessibilityHelpEventHandler* QueryAccessibilityHelp
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")]
public:
event System.Windows.Forms.QueryAccessibilityHelpEventHandler^ QueryAccessibilityHelp

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


QueryContinueDrag Event

[image]
Intersoft WebEssentials Documentation
QueryContinueDrag Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : QueryContinueDrag Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")>
<SRCategoryAttribute("Drag Drop")>
Public Event QueryContinueDrag As System.Windows.Forms.QueryContinueDragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.QueryContinueDragEventHandler

AddHandler instance.QueryContinueDrag, handler
C#
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")]
[SRCategoryAttribute("Drag Drop")]
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag
Delphi
public event QueryContinueDrag: System.Windows.Forms.QueryContinueDragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")]
[SRCategoryAttribute("Drag Drop")]
public: __event System.Windows.Forms.QueryContinueDragEventHandler* QueryContinueDrag
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")]
[SRCategoryAttribute("Drag Drop")]
public:
event System.Windows.Forms.QueryContinueDragEventHandler^ QueryContinueDrag

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


RectangleToClient Method

[image]
Intersoft WebEssentials Documentation
RectangleToClient Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : RectangleToClient Method

r

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As System.Drawing.Rectangle _
) As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToClient(r)
C#
public System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)
Delphi
public function RectangleToClient(
    r: System.Drawing.Rectangle
): System.Drawing.Rectangle;
JScript
public function RectangleToClient(
   r : System.Drawing.Rectangle
) : System.Drawing.Rectangle;
Managed Extensions for C++
public: System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)
C++/CLI
public:
System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)

Parameters

r

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


RectangleToScreen Method

[image]
Intersoft WebEssentials Documentation
RectangleToScreen Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : RectangleToScreen Method

r

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As System.Drawing.Rectangle _
) As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToScreen(r)
C#
public System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)
Delphi
public function RectangleToScreen(
    r: System.Drawing.Rectangle
): System.Drawing.Rectangle;
JScript
public function RectangleToScreen(
   r : System.Drawing.Rectangle
) : System.Drawing.Rectangle;
Managed Extensions for C++
public: System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)
C++/CLI
public:
System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)

Parameters

r

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Refresh Method

[image]
Intersoft WebEssentials Documentation
Refresh Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Refresh Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.Refresh()
C#
public virtual void Refresh()
Delphi
public procedure Refresh(); virtual;
JScript
public function Refresh();
Managed Extensions for C++
public: virtual void Refresh();
C++/CLI
public:
virtual void Refresh();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


RegionChanged Event

[image]
Intersoft WebEssentials Documentation
RegionChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : RegionChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event RegionChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.RegionChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler RegionChanged
Delphi
public event RegionChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* RegionChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


RemoveOwnedForm Method

[image]
Intersoft WebEssentials Documentation
RemoveOwnedForm Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : RemoveOwnedForm Method

ownedForm

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RemoveOwnedForm( _
   ByVal ownedForm As System.Windows.Forms.Form _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim ownedForm As System.Windows.Forms.Form

instance.RemoveOwnedForm(ownedForm)
C#
public void RemoveOwnedForm(
   System.Windows.Forms.Form ownedForm
)
Delphi
public procedure RemoveOwnedForm(
    ownedForm: System.Windows.Forms.Form
);
JScript
public function RemoveOwnedForm(
   ownedForm : System.Windows.Forms.Form
);
Managed Extensions for C++
public: void RemoveOwnedForm(
   System.Windows.Forms.Form* ownedForm
)
C++/CLI
public:
void RemoveOwnedForm(
   System.Windows.Forms.Form^ ownedForm
)

Parameters

ownedForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ResetText Method

[image]
Intersoft WebEssentials Documentation
ResetText Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ResetText Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetText()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.ResetText()
C#
public virtual void ResetText()
Delphi
public procedure ResetText(); virtual;
JScript
public function ResetText();
Managed Extensions for C++
public: virtual void ResetText();
C++/CLI
public:
virtual void ResetText();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Resize Event

[image]
Intersoft WebEssentials Documentation
Resize Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Resize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Occurs when a control is resized.")>
Public Event Resize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.Resize, handler
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when a control is resized.")]
public event System.EventHandler Resize
Delphi
public event Resize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when a control is resized.")]
public: __event System.EventHandler* Resize
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when a control is resized.")]
public:
event System.EventHandler^ Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ResizeBegin Event

[image]
Intersoft WebEssentials Documentation
ResizeBegin Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ResizeBegin Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")>
<SRCategoryAttribute("Action")>
Public Event ResizeBegin As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.ResizeBegin, handler
C#
[SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")]
[SRCategoryAttribute("Action")]
public event System.EventHandler ResizeBegin
Delphi
public event ResizeBegin: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")]
[SRCategoryAttribute("Action")]
public: __event System.EventHandler* ResizeBegin
C++/CLI
[SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")]
[SRCategoryAttribute("Action")]
public:
event System.EventHandler^ ResizeBegin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ResizeEnd Event

[image]
Intersoft WebEssentials Documentation
ResizeEnd Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ResizeEnd Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")>
Public Event ResizeEnd As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.ResizeEnd, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")]
public event System.EventHandler ResizeEnd
Delphi
public event ResizeEnd: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")]
public: __event System.EventHandler* ResizeEnd
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")]
public:
event System.EventHandler^ ResizeEnd

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ResumeLayout Method

[image]
Intersoft WebEssentials Documentation
ResumeLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ResumeLayout Method

Glossary Item Box

Overload List

Overload | Description
ResumeLayout() | (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ResumeLayout() Method

[image]
Intersoft WebEssentials Documentation
ResumeLayout() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub ResumeLayout()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.ResumeLayout()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void ResumeLayout()
Delphi
public procedure ResumeLayout();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ResumeLayout();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void ResumeLayout();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void ResumeLayout();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


ResumeLayout(Boolean) Method

[image]
Intersoft WebEssentials Documentation
ResumeLayout(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim performLayout As System.Boolean

instance.ResumeLayout(performLayout)
C#
public void ResumeLayout(
   System.bool performLayout
)
Delphi
public procedure ResumeLayout(
    performLayout: System.Boolean
);
JScript
public function ResumeLayout(
   performLayout : System.boolean
);
Managed Extensions for C++
public: void ResumeLayout(
   System.bool performLayout
)
C++/CLI
public:
void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


RightToLeft Property

[image]
Intersoft WebEssentials Documentation
RightToLeft Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : RightToLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")>
Public Overridable Property RightToLeft As System.Windows.Forms.RightToLeft
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
C#
[System.ComponentModel.AmbientValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}
Delphi
public read-write property RightToLeft: System.Windows.Forms.RightToLeft; virtual;
JScript
System.ComponentModel.AmbientValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Appearance")
SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")
public function get,set RightToLeft : System.Windows.Forms.RightToLeft
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
public: __property virtual System.Windows.Forms.RightToLeft get_RightToLeft();
public: __property virtual void set_RightToLeft(
   System.Windows.Forms.RightToLeft value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
public:
virtual property System.Windows.Forms.RightToLeft RightToLeft {
   System.Windows.Forms.RightToLeft get();
   void set (    System.Windows.Forms.RightToLeft value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


RightToLeftChanged Event

[image]
Intersoft WebEssentials Documentation
RightToLeftChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : RightToLeftChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event RightToLeftChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.RightToLeftChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler RightToLeftChanged
Delphi
public event RightToLeftChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* RightToLeftChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


RightToLeftLayout Property

[image]
Intersoft WebEssentials Documentation
RightToLeftLayout Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : RightToLeftLayout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")>
Public Overridable Property RightToLeftLayout As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.RightToLeftLayout = value

value = instance.RightToLeftLayout
C#
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")]
public virtual System.bool RightToLeftLayout {get; set;}
Delphi
public read-write property RightToLeftLayout: System.Boolean; virtual;
JScript
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")
public function get,set RightToLeftLayout : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")]
public: __property virtual System.bool get_RightToLeftLayout();
public: __property virtual void set_RightToLeftLayout(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")]
public:
virtual property System.bool RightToLeftLayout {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


RightToLeftLayoutChanged Event

[image]
Intersoft WebEssentials Documentation
RightToLeftLayoutChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : RightToLeftLayoutChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event RightToLeftLayoutChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.RightToLeftLayoutChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler RightToLeftLayoutChanged
Delphi
public event RightToLeftLayoutChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* RightToLeftLayoutChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ RightToLeftLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Scale Method

[image]
Intersoft WebEssentials Documentation
Scale Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Scale Method

Glossary Item Box

Overload List

Overload | Description
Scale | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Scale(SizeF) Method

[image]
Intersoft WebEssentials Documentation
Scale(SizeF) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > Scale Method : Scale(SizeF) Method

factor

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Sub Scale( _
   ByVal factor As System.Drawing.SizeF _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim factor As System.Drawing.SizeF

instance.Scale(factor)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void Scale(
   System.Drawing.SizeF factor
)
Delphi
public procedure Scale(
    factor: System.Drawing.SizeF
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function Scale(
   factor : System.Drawing.SizeF
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void Scale(
   System.Drawing.SizeF factor
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void Scale(
   System.Drawing.SizeF factor
)

Parameters

factor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


Scroll Event

[image]
Intersoft WebEssentials Documentation
Scroll Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Scroll Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the user moves the scroll box.")>
Public Event Scroll As System.Windows.Forms.ScrollEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.Windows.Forms.ScrollEventHandler

AddHandler instance.Scroll, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user moves the scroll box.")]
public event System.Windows.Forms.ScrollEventHandler Scroll
Delphi
public event Scroll: System.Windows.Forms.ScrollEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user moves the scroll box.")]
public: __event System.Windows.Forms.ScrollEventHandler* Scroll
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user moves the scroll box.")]
public:
event System.Windows.Forms.ScrollEventHandler^ Scroll

Event Data

The event handler receives an argument of type System.Windows.Forms.ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ScrollControlIntoView Method

[image]
Intersoft WebEssentials Documentation
ScrollControlIntoView Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ScrollControlIntoView Method

activeControl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ScrollControlIntoView( _
   ByVal activeControl As System.Windows.Forms.Control _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim activeControl As System.Windows.Forms.Control

instance.ScrollControlIntoView(activeControl)
C#
public void ScrollControlIntoView(
   System.Windows.Forms.Control activeControl
)
Delphi
public procedure ScrollControlIntoView(
    activeControl: System.Windows.Forms.Control
);
JScript
public function ScrollControlIntoView(
   activeControl : System.Windows.Forms.Control
);
Managed Extensions for C++
public: void ScrollControlIntoView(
   System.Windows.Forms.Control* activeControl
)
C++/CLI
public:
void ScrollControlIntoView(
   System.Windows.Forms.Control^ activeControl
)

Parameters

activeControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Select Method

[image]
Intersoft WebEssentials Documentation
Select Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Select Method

Glossary Item Box

Overload List

Overload | Description
Select | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Select() Method

[image]
Intersoft WebEssentials Documentation
Select() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Select() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Sub Select()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.Select()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Select()
Delphi
public procedure Select();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Select();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Select();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Select();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


SelectNextControl Method

[image]
Intersoft WebEssentials Documentation
SelectNextControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : SelectNextControl Method

ctl
forward
tabStopOnly
nested
wrap

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean, _
   ByVal tabStopOnly As System.Boolean, _
   ByVal nested As System.Boolean, _
   ByVal wrap As System.Boolean _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim tabStopOnly As System.Boolean
Dim nested As System.Boolean
Dim wrap As System.Boolean
Dim value As System.Boolean

value = instance.SelectNextControl(ctl, forward, tabStopOnly, nested, wrap)
C#
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)
Delphi
public function SelectNextControl(
    ctl: System.Windows.Forms.Control;
    forward: System.Boolean;
    tabStopOnly: System.Boolean;
    nested: System.Boolean;
    wrap: System.Boolean
): System.Boolean;
JScript
public function SelectNextControl(
   ctl : System.Windows.Forms.Control,
   forward : System.boolean,
   tabStopOnly : System.boolean,
   nested : System.boolean,
   wrap : System.boolean
) : System.boolean;
Managed Extensions for C++
public: System.bool SelectNextControl(
   System.Windows.Forms.Control* ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)
C++/CLI
public:
System.bool SelectNextControl(
   System.Windows.Forms.Control^ ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
forward
tabStopOnly
nested
wrap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


SendToBack Method

[image]
Intersoft WebEssentials Documentation
SendToBack Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : SendToBack Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.SendToBack()
C#
public void SendToBack()
Delphi
public procedure SendToBack();
JScript
public function SendToBack();
Managed Extensions for C++
public: void SendToBack();
C++/CLI
public:
void SendToBack();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


SetAutoScrollMargin Method

[image]
Intersoft WebEssentials Documentation
SetAutoScrollMargin Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : SetAutoScrollMargin Method

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetAutoScrollMargin( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim x As System.Integer
Dim y As System.Integer

instance.SetAutoScrollMargin(x, y)
C#
public void SetAutoScrollMargin(
   System.int x,
   System.int y
)
Delphi
public procedure SetAutoScrollMargin(
    x: System.Integer;
    y: System.Integer
);
JScript
public function SetAutoScrollMargin(
   x : System.int,
   y : System.int
);
Managed Extensions for C++
public: void SetAutoScrollMargin(
   System.int x,
   System.int y
)
C++/CLI
public:
void SetAutoScrollMargin(
   System.int x,
   System.int y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


SetBounds Method

[image]
Intersoft WebEssentials Documentation
SetBounds Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : SetBounds Method

Glossary Item Box

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


SetBounds(Int32,Int32,Int32,Int32) Method

[image]
Intersoft WebEssentials Documentation
SetBounds(Int32,Int32,Int32,Int32) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
y
width
height

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetBounds(x, y, width, height)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
Delphi
public procedure SetBounds(
    x: System.Integer;
    y: System.Integer;
    width: System.Integer;
    height: System.Integer
);
JScript
public function SetBounds(
   x : System.int,
   y : System.int,
   width : System.int,
   height : System.int
);
Managed Extensions for C++
public: void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
C++/CLI
public:
void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

[image]
Intersoft WebEssentials Documentation
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
y
width
height
specified

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer, _
   ByVal specified As System.Windows.Forms.BoundsSpecified _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer
Dim specified As System.Windows.Forms.BoundsSpecified

instance.SetBounds(x, y, width, height, specified)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)
Delphi
public procedure SetBounds(
    x: System.Integer;
    y: System.Integer;
    width: System.Integer;
    height: System.Integer;
    specified: System.Windows.Forms.BoundsSpecified
);
JScript
public function SetBounds(
   x : System.int,
   y : System.int,
   width : System.int,
   height : System.int,
   specified : System.Windows.Forms.BoundsSpecified
);
Managed Extensions for C++
public: void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)
C++/CLI
public:
void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
y
width
height
specified

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


SetDesktopBounds Method

[image]
Intersoft WebEssentials Documentation
SetDesktopBounds Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : SetDesktopBounds Method

x
y
width
height

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDesktopBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetDesktopBounds(x, y, width, height)
C#
public void SetDesktopBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
Delphi
public procedure SetDesktopBounds(
    x: System.Integer;
    y: System.Integer;
    width: System.Integer;
    height: System.Integer
);
JScript
public function SetDesktopBounds(
   x : System.int,
   y : System.int,
   width : System.int,
   height : System.int
);
Managed Extensions for C++
public: void SetDesktopBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
C++/CLI
public:
void SetDesktopBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


SetDesktopLocation Method

[image]
Intersoft WebEssentials Documentation
SetDesktopLocation Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : SetDesktopLocation Method

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDesktopLocation( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim x As System.Integer
Dim y As System.Integer

instance.SetDesktopLocation(x, y)
C#
public void SetDesktopLocation(
   System.int x,
   System.int y
)
Delphi
public procedure SetDesktopLocation(
    x: System.Integer;
    y: System.Integer
);
JScript
public function SetDesktopLocation(
   x : System.int,
   y : System.int
);
Managed Extensions for C++
public: void SetDesktopLocation(
   System.int x,
   System.int y
)
C++/CLI
public:
void SetDesktopLocation(
   System.int x,
   System.int y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Show Method

[image]
Intersoft WebEssentials Documentation
Show Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Show Method

Glossary Item Box

Overload List

Overload | Description
Show(IWin32Window) | (Inherited from System.Windows.Forms.Form)
Show() | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Show() Method

[image]
Intersoft WebEssentials Documentation
Show() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > Show Method : Show() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Show()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.Show()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Show()
Delphi
public procedure Show();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Show();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Show();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Show();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


Show(IWin32Window) Method

[image]
Intersoft WebEssentials Documentation
Show(IWin32Window) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > Show Method : Show(IWin32Window) Method

owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Show( _
   ByVal owner As System.Windows.Forms.IWin32Window _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim owner As System.Windows.Forms.IWin32Window

instance.Show(owner)
C#
public void Show(
   System.Windows.Forms.IWin32Window owner
)
Delphi
public procedure Show(
    owner: System.Windows.Forms.IWin32Window
);
JScript
public function Show(
   owner : System.Windows.Forms.IWin32Window
);
Managed Extensions for C++
public: void Show(
   System.Windows.Forms.IWin32Window* owner
)
C++/CLI
public:
void Show(
   System.Windows.Forms.IWin32Window^ owner
)

Parameters

owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


ShowDialog Method

[image]
Intersoft WebEssentials Documentation
ShowDialog Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ShowDialog Method

Glossary Item Box

Overload List

Overload | Description
ShowDialog() | (Inherited from System.Windows.Forms.Form)
ShowDialog(IWin32Window) | (Inherited from System.Windows.Forms.Form)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ShowDialog() Method

[image]
Intersoft WebEssentials Documentation
ShowDialog() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > ShowDialog Method : ShowDialog() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function ShowDialog() As System.Windows.Forms.DialogResult
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.DialogResult

value = instance.ShowDialog()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Windows.Forms.DialogResult ShowDialog()
Delphi
public function ShowDialog(): System.Windows.Forms.DialogResult;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ShowDialog() : System.Windows.Forms.DialogResult;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Windows.Forms.DialogResult ShowDialog();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Windows.Forms.DialogResult ShowDialog();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


ShowDialog(IWin32Window) Method

[image]
Intersoft WebEssentials Documentation
ShowDialog(IWin32Window) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > ShowDialog Method : ShowDialog(IWin32Window) Method

owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowDialog( _
   ByVal owner As System.Windows.Forms.IWin32Window _
) As System.Windows.Forms.DialogResult
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim owner As System.Windows.Forms.IWin32Window
Dim value As System.Windows.Forms.DialogResult

value = instance.ShowDialog(owner)
C#
public System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.IWin32Window owner
)
Delphi
public function ShowDialog(
    owner: System.Windows.Forms.IWin32Window
): System.Windows.Forms.DialogResult;
JScript
public function ShowDialog(
   owner : System.Windows.Forms.IWin32Window
) : System.Windows.Forms.DialogResult;
Managed Extensions for C++
public: System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.IWin32Window* owner
)
C++/CLI
public:
System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.IWin32Window^ owner
)

Parameters

owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


ShowIcon Property

[image]
Intersoft WebEssentials Documentation
ShowIcon Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ShowIcon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")>
Public Property ShowIcon As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.ShowIcon = value

value = instance.ShowIcon
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")]
public System.bool ShowIcon {get; set;}
Delphi
public read-write property ShowIcon: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")
public function get,set ShowIcon : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")]
public: __property System.bool get_ShowIcon();
public: __property void set_ShowIcon(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")]
public:
property System.bool ShowIcon {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ShowInTaskbar Property

[image]
Intersoft WebEssentials Documentation
ShowInTaskbar Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ShowInTaskbar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")>
Public Property ShowInTaskbar As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.ShowInTaskbar = value

value = instance.ShowInTaskbar
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public System.bool ShowInTaskbar {get; set;}
Delphi
public read-write property ShowInTaskbar: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")
public function get,set ShowInTaskbar : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public: __property System.bool get_ShowInTaskbar();
public: __property void set_ShowInTaskbar(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public:
property System.bool ShowInTaskbar {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Shown Event

[image]
Intersoft WebEssentials Documentation
Shown Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Shown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the form is first shown.")>
<SRCategoryAttribute("Behavior")>
Public Event Shown As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.Shown, handler
C#
[SRDescriptionAttribute("Occurs whenever the form is first shown.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler Shown
Delphi
public event Shown: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the form is first shown.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* Shown
C++/CLI
[SRDescriptionAttribute("Occurs whenever the form is first shown.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ Shown

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Site Property

[image]
Intersoft WebEssentials Documentation
Site Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Property Site As System.ComponentModel.ISite
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual System.ComponentModel.ISite Site {get; set;}
Delphi
public read-write property Site: System.ComponentModel.ISite; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function get,set Site : System.ComponentModel.ISite
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual property System.ComponentModel.ISite^ Site {
   System.ComponentModel.ISite^ get();
   void set (    System.ComponentModel.ISite^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Size Property

[image]
Intersoft WebEssentials Documentation
Size Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Size Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Size As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Size

instance.Size = value

value = instance.Size
C#
[System.ComponentModel.LocalizableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Drawing.Size Size {get; set;}
Delphi
public read-write property Size: System.Drawing.Size;
JScript
System.ComponentModel.LocalizableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set Size : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Drawing.Size get_Size();
public: __property void set_Size(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Drawing.Size Size {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


SizeChanged Event

[image]
Intersoft WebEssentials Documentation
SizeChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : SizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event SizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.SizeChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler SizeChanged
Delphi
public event SizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* SizeChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


SizeGripStyle Property

[image]
Intersoft WebEssentials Documentation
SizeGripStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : SizeGripStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")>
Public Property SizeGripStyle As System.Windows.Forms.SizeGripStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.SizeGripStyle

instance.SizeGripStyle = value

value = instance.SizeGripStyle
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")]
public System.Windows.Forms.SizeGripStyle SizeGripStyle {get; set;}
Delphi
public read-write property SizeGripStyle: System.Windows.Forms.SizeGripStyle;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")
public function get,set SizeGripStyle : System.Windows.Forms.SizeGripStyle
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")]
public: __property System.Windows.Forms.SizeGripStyle get_SizeGripStyle();
public: __property void set_SizeGripStyle(
   System.Windows.Forms.SizeGripStyle value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")]
public:
property System.Windows.Forms.SizeGripStyle SizeGripStyle {
   System.Windows.Forms.SizeGripStyle get();
   void set (    System.Windows.Forms.SizeGripStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


StartPosition Property

[image]
Intersoft WebEssentials Documentation
StartPosition Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : StartPosition Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Determines the position of a form when it first appears.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property StartPosition As System.Windows.Forms.FormStartPosition
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.FormStartPosition

instance.StartPosition = value

value = instance.StartPosition
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Windows.Forms.FormStartPosition StartPosition {get; set;}
Delphi
public read-write property StartPosition: System.Windows.Forms.FormStartPosition;
JScript
SRCategoryAttribute("Layout")
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Determines the position of a form when it first appears.")
System.ComponentModel.DefaultValueAttribute()
public function get,set StartPosition : System.Windows.Forms.FormStartPosition
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Windows.Forms.FormStartPosition get_StartPosition();
public: __property void set_StartPosition(
   System.Windows.Forms.FormStartPosition value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Windows.Forms.FormStartPosition StartPosition {
   System.Windows.Forms.FormStartPosition get();
   void set (    System.Windows.Forms.FormStartPosition value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


StyleChanged Event

[image]
Intersoft WebEssentials Documentation
StyleChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : StyleChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the window style of a Control is changed.")>
<SRCategoryAttribute("Behavior")>
Public Event StyleChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.StyleChanged, handler
C#
[SRDescriptionAttribute("Event raised when the window style of a Control is changed.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler StyleChanged
Delphi
public event StyleChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the window style of a Control is changed.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* StyleChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the window style of a Control is changed.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


SuspendLayout Method

[image]
Intersoft WebEssentials Documentation
SuspendLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : SuspendLayout Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.SuspendLayout()
C#
public void SuspendLayout()
Delphi
public procedure SuspendLayout();
JScript
public function SuspendLayout();
Managed Extensions for C++
public: void SuspendLayout();
C++/CLI
public:
void SuspendLayout();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


SystemColorsChanged Event

[image]
Intersoft WebEssentials Documentation
SystemColorsChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : SystemColorsChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the system colors change.")>
<SRCategoryAttribute("Behavior")>
Public Event SystemColorsChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.SystemColorsChanged, handler
C#
[SRDescriptionAttribute("Event raised when the system colors change.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler SystemColorsChanged
Delphi
public event SystemColorsChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the system colors change.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* SystemColorsChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the system colors change.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Tag Property

[image]
Intersoft WebEssentials Documentation
Tag Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Tag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.LocalizableAttribute(False)>
<SRDescriptionAttribute("User-defined data associated with the object.")>
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
Public Property Tag As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public System.object Tag {get; set;}
Delphi
public read-write property Tag: System.TObject;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("User-defined data associated with the object.")
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Data")
public function get,set Tag : System.Object
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public: __property System.Object* get_Tag();
public: __property void set_Tag(
   System.Object* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public:
property System.Object^ Tag {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Text Property

[image]
Intersoft WebEssentials Documentation
Text Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.SettingsBindableAttribute(True)>
Public Overridable Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.SettingsBindableAttribute(true)]
public virtual System.string Text {get; set;}
Delphi
public read-write property Text: System.String; virtual;
JScript
System.ComponentModel.SettingsBindableAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.SettingsBindableAttribute(true)]
public: __property virtual System.string* get_Text();
public: __property virtual void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.SettingsBindableAttribute(true)]
public:
virtual property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


TextChanged Event

[image]
Intersoft WebEssentials Documentation
TextChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : TextChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")>
Public Event TextChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.TextChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")]
public event System.EventHandler TextChanged
Delphi
public event TextChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")]
public: __event System.EventHandler* TextChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")]
public:
event System.EventHandler^ TextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


TopMost Property

[image]
Intersoft WebEssentials Documentation
TopMost Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : TopMost Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TopMost As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.TopMost = value

value = instance.TopMost
C#
[SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool TopMost {get; set;}
Delphi
public read-write property TopMost: System.Boolean;
JScript
SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
public function get,set TopMost : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_TopMost();
public: __property void set_TopMost(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool TopMost {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


TransparencyKey Property

[image]
Intersoft WebEssentials Documentation
TransparencyKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : TransparencyKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("A color which will appear transparent when painted on the form.")>
<SRCategoryAttribute("Window Style")>
Public Property TransparencyKey As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Drawing.Color

instance.TransparencyKey = value

value = instance.TransparencyKey
C#
[SRDescriptionAttribute("A color which will appear transparent when painted on the form.")]
[SRCategoryAttribute("Window Style")]
public System.Drawing.Color TransparencyKey {get; set;}
Delphi
public read-write property TransparencyKey: System.Drawing.Color;
JScript
SRDescriptionAttribute("A color which will appear transparent when painted on the form.")
SRCategoryAttribute("Window Style")
public function get,set TransparencyKey : System.Drawing.Color
Managed Extensions for C++
[SRDescriptionAttribute("A color which will appear transparent when painted on the form.")]
[SRCategoryAttribute("Window Style")]
public: __property System.Drawing.Color get_TransparencyKey();
public: __property void set_TransparencyKey(
   System.Drawing.Color value
);
C++/CLI
[SRDescriptionAttribute("A color which will appear transparent when painted on the form.")]
[SRCategoryAttribute("Window Style")]
public:
property System.Drawing.Color TransparencyKey {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Update Method

[image]
Intersoft WebEssentials Documentation
Update Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Update Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Update()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm

instance.Update()
C#
public void Update()
Delphi
public procedure Update();
JScript
public function Update();
Managed Extensions for C++
public: void Update();
C++/CLI
public:
void Update();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


UseWaitCursor Property

[image]
Intersoft WebEssentials Documentation
UseWaitCursor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : UseWaitCursor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorBrowsableAttribute()>
<SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")>
Public Property UseWaitCursor As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.UseWaitCursor = value

value = instance.UseWaitCursor
C#
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")]
public System.bool UseWaitCursor {get; set;}
Delphi
public read-write property UseWaitCursor: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorBrowsableAttribute()
SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")
public function get,set UseWaitCursor : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")]
public: __property System.bool get_UseWaitCursor();
public: __property void set_UseWaitCursor(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")]
public:
property System.bool UseWaitCursor {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Validate Method

[image]
Intersoft WebEssentials Documentation
Validate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Validate Method

Glossary Item Box

Overload List

Overload | Description
Validate() | (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | (Inherited from System.Windows.Forms.ContainerControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Validate() Method

[image]
Intersoft WebEssentials Documentation
Validate() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > Validate Method : Validate() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function Validate() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

value = instance.Validate()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool Validate()
Delphi
public function Validate(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Validate() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool Validate();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool Validate();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


Validate(Boolean) Method

[image]
Intersoft WebEssentials Documentation
Validate(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > Validate Method : Validate(Boolean) Method

checkAutoValidate

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate( _
   ByVal checkAutoValidate As System.Boolean _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim checkAutoValidate As System.Boolean
Dim value As System.Boolean

value = instance.Validate(checkAutoValidate)
C#
public System.bool Validate(
   System.bool checkAutoValidate
)
Delphi
public function Validate(
    checkAutoValidate: System.Boolean
): System.Boolean;
JScript
public function Validate(
   checkAutoValidate : System.boolean
) : System.boolean;
Managed Extensions for C++
public: System.bool Validate(
   System.bool checkAutoValidate
)
C++/CLI
public:
System.bool Validate(
   System.bool checkAutoValidate
)

Parameters

checkAutoValidate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


ValidateChildren Method

[image]
Intersoft WebEssentials Documentation
ValidateChildren Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : ValidateChildren Method

Glossary Item Box

Overload List

Overload | Description
ValidateChildren() | (Inherited from System.Windows.Forms.Form)
ValidateChildren(ValidationConstraints) | (Inherited from System.Windows.Forms.Form)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


ValidateChildren() Method

[image]
Intersoft WebEssentials Documentation
ValidateChildren() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > ValidateChildren Method : ValidateChildren() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.EditorBrowsableAttribute()>
Public Overloads Overridable Function ValidateChildren() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

value = instance.ValidateChildren()
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public virtual System.bool ValidateChildren()
Delphi
public function ValidateChildren(): System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute()
public function ValidateChildren() : System.boolean;
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public: virtual System.bool ValidateChildren();
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public:
virtual System.bool ValidateChildren();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


ValidateChildren(ValidationConstraints) Method

[image]
Intersoft WebEssentials Documentation
ValidateChildren(ValidationConstraints) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method

validationConstraints

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.EditorBrowsableAttribute()>
Public Overloads Overridable Function ValidateChildren( _
   ByVal validationConstraints As System.Windows.Forms.ValidationConstraints _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim validationConstraints As System.Windows.Forms.ValidationConstraints
Dim value As System.Boolean

value = instance.ValidateChildren(validationConstraints)
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)
Delphi
public function ValidateChildren(
    validationConstraints: System.Windows.Forms.ValidationConstraints
): System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute()
public function ValidateChildren(
   validationConstraints : System.Windows.Forms.ValidationConstraints
) : System.boolean;
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public: virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public:
virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)

Parameters

validationConstraints

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members
Overload List


Validated Event

[image]
Intersoft WebEssentials Documentation
Validated Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Validated Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs after a control has been successfully validated.")>
<SRCategoryAttribute("Focus")>
Public Event Validated As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.Validated, handler
C#
[SRDescriptionAttribute("Occurs after a control has been successfully validated.")]
[SRCategoryAttribute("Focus")]
public event System.EventHandler Validated
Delphi
public event Validated: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs after a control has been successfully validated.")]
[SRCategoryAttribute("Focus")]
public: __event System.EventHandler* Validated
C++/CLI
[SRDescriptionAttribute("Occurs after a control has been successfully validated.")]
[SRCategoryAttribute("Focus")]
public:
event System.EventHandler^ Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Validating Event

[image]
Intersoft WebEssentials Documentation
Validating Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Validating Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the control is validating.")>
<SRCategoryAttribute("Focus")>
Public Event Validating As System.ComponentModel.CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.Validating, handler
C#
[SRDescriptionAttribute("Occurs when the control is validating.")]
[SRCategoryAttribute("Focus")]
public event System.ComponentModel.CancelEventHandler Validating
Delphi
public event Validating: System.ComponentModel.CancelEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the control is validating.")]
[SRCategoryAttribute("Focus")]
public: __event System.ComponentModel.CancelEventHandler* Validating
C++/CLI
[SRDescriptionAttribute("Occurs when the control is validating.")]
[SRCategoryAttribute("Focus")]
public:
event System.ComponentModel.CancelEventHandler^ Validating

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether the control is visible or hidden.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Behavior")>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
SRDescriptionAttribute("Determines whether the control is visible or hidden.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


VisibleChanged Event

[image]
Intersoft WebEssentials Documentation
VisibleChanged Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : VisibleChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the control's visibility changes.")>
Public Event VisibleChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim handler As System.EventHandler

AddHandler instance.VisibleChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
public event System.EventHandler VisibleChanged
Delphi
public event VisibleChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
public: __event System.EventHandler* VisibleChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
public:
event System.EventHandler^ VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


WindowState Property

[image]
Intersoft WebEssentials Documentation
WindowState Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditorForm Class : WindowState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Determines the initial visual state of the form.")>
Public Property WindowState As System.Windows.Forms.FormWindowState
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditorForm
Dim value As System.Windows.Forms.FormWindowState

instance.WindowState = value

value = instance.WindowState
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
public System.Windows.Forms.FormWindowState WindowState {get; set;}
Delphi
public read-write property WindowState: System.Windows.Forms.FormWindowState;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Layout")
SRDescriptionAttribute("Determines the initial visual state of the form.")
public function get,set WindowState : System.Windows.Forms.FormWindowState
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
public: __property System.Windows.Forms.FormWindowState get_WindowState();
public: __property void set_WindowState(
   System.Windows.Forms.FormWindowState value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
public:
property System.Windows.Forms.FormWindowState WindowState {
   System.Windows.Forms.FormWindowState get();
   void set (    System.Windows.Forms.FormWindowState value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditorForm Class
WebSlidingMenuBindingEditorForm Members


WebSlidingMenuBindingEditor Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuBindingEditor Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditor Class : WebSlidingMenuBindingEditor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuBindingEditor()
C#
public WebSlidingMenuBindingEditor()
Delphi
public WebSlidingMenuBindingEditor();
JScript
public function WebSlidingMenuBindingEditor();
Managed Extensions for C++
public: WebSlidingMenuBindingEditor();
C++/CLI
public:
WebSlidingMenuBindingEditor();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Class
WebSlidingMenuBindingEditor Members


EditValue Method

[image]
Intersoft WebEssentials Documentation
EditValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditor Class : EditValue Method

Glossary Item Box

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object) |
EditValue(IServiceProvider,Object) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Class
WebSlidingMenuBindingEditor Members


EditValue(IServiceProvider,Object) Method

[image]
Intersoft WebEssentials Documentation
EditValue(IServiceProvider,Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditor Class > EditValue Method : EditValue(IServiceProvider,Object) Method

provider
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function EditValue( _
   ByVal provider As System.IServiceProvider, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditor
Dim provider As System.IServiceProvider
Dim value As System.Object
Dim value As System.Object

value = instance.EditValue(provider, value)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object EditValue(
   System.IServiceProvider provider,
   System.object value
)
Delphi
public function EditValue(
    provider: System.IServiceProvider;
    value: System.TObject
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditValue(
   provider : System.IServiceProvider,
   value : System.Object
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* EditValue(
   System.IServiceProvider* provider,
   System.Object* value
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ EditValue(
   System.IServiceProvider^ provider,
   System.Object^ value
)

Parameters

provider
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Class
WebSlidingMenuBindingEditor Members
Overload List


EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

[image]
Intersoft WebEssentials Documentation
EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object) Method

context
provider
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function EditValue( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal provider As System.IServiceProvider, _
   ByVal value As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim provider As System.IServiceProvider
Dim value As System.Object
Dim value As System.Object

value = instance.EditValue(context, provider, value)
C#
public override System.object EditValue(
   System.ComponentModel.ITypeDescriptorContext context,
   System.IServiceProvider provider,
   System.object value
)
Delphi
public function EditValue(
    context: System.ComponentModel.ITypeDescriptorContext;
    provider: System.IServiceProvider;
    value: System.TObject
): System.TObject; override;
JScript
public override function EditValue(
   context : System.ComponentModel.ITypeDescriptorContext,
   provider : System.IServiceProvider,
   value : System.Object
) : System.Object;
Managed Extensions for C++
public: System.Object* EditValue(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.IServiceProvider* provider,
   System.Object* value
) override
C++/CLI
public:
System.Object^ EditValue(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.IServiceProvider^ provider,
   System.Object^ value
) override

Parameters

context
provider
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Class
WebSlidingMenuBindingEditor Members
Overload List


GetEditStyle Method

[image]
Intersoft WebEssentials Documentation
GetEditStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditor Class : GetEditStyle Method

Glossary Item Box

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) |
GetEditStyle() | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Class
WebSlidingMenuBindingEditor Members


GetEditStyle() Method

[image]
Intersoft WebEssentials Documentation
GetEditStyle() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditor Class > GetEditStyle Method : GetEditStyle() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetEditStyle() As System.Drawing.Design.UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditor
Dim value As System.Drawing.Design.UITypeEditorEditStyle

value = instance.GetEditStyle()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Drawing.Design.UITypeEditorEditStyle GetEditStyle()
Delphi
public function GetEditStyle(): System.Drawing.Design.UITypeEditorEditStyle;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetEditStyle() : System.Drawing.Design.UITypeEditorEditStyle;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Drawing.Design.UITypeEditorEditStyle GetEditStyle();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Drawing.Design.UITypeEditorEditStyle GetEditStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Class
WebSlidingMenuBindingEditor Members
Overload List


GetEditStyle(ITypeDescriptorContext) Method

[image]
Intersoft WebEssentials Documentation
GetEditStyle(ITypeDescriptorContext) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetEditStyle( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Drawing.Design.UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Drawing.Design.UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetEditStyle(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Drawing.Design.UITypeEditorEditStyle; override;
JScript
public override function GetEditStyle(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.Drawing.Design.UITypeEditorEditStyle;
Managed Extensions for C++
public: System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext* context
) override
C++/CLI
public:
System.Drawing.Design.UITypeEditorEditStyle GetEditStyle(
   System.ComponentModel.ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Class
WebSlidingMenuBindingEditor Members
Overload List


GetPaintValueSupported Method

[image]
Intersoft WebEssentials Documentation
GetPaintValueSupported Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditor Class : GetPaintValueSupported Method

Glossary Item Box

Overload List

Overload | Description
GetPaintValueSupported() | (Inherited from System.Drawing.Design.UITypeEditor)
GetPaintValueSupported(ITypeDescriptorContext) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Class
WebSlidingMenuBindingEditor Members


GetPaintValueSupported() Method

[image]
Intersoft WebEssentials Documentation
GetPaintValueSupported() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditor Class > GetPaintValueSupported Method : GetPaintValueSupported() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetPaintValueSupported() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditor
Dim value As System.Boolean

value = instance.GetPaintValueSupported()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool GetPaintValueSupported()
Delphi
public function GetPaintValueSupported(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetPaintValueSupported() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool GetPaintValueSupported();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool GetPaintValueSupported();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Class
WebSlidingMenuBindingEditor Members
Overload List


GetPaintValueSupported(ITypeDescriptorContext) Method

[image]
Intersoft WebEssentials Documentation
GetPaintValueSupported(ITypeDescriptorContext) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditor Class > GetPaintValueSupported Method : GetPaintValueSupported(ITypeDescriptorContext) Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetPaintValueSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim value As System.Boolean

value = instance.GetPaintValueSupported(context)
C#
public virtual System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext context
)
Delphi
public function GetPaintValueSupported(
    context: System.ComponentModel.ITypeDescriptorContext
): System.Boolean; virtual;
JScript
public function GetPaintValueSupported(
   context : System.ComponentModel.ITypeDescriptorContext
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext* context
)
C++/CLI
public:
virtual System.bool GetPaintValueSupported(
   System.ComponentModel.ITypeDescriptorContext^ context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Class
WebSlidingMenuBindingEditor Members
Overload List


IsDropDownResizable Property

[image]
Intersoft WebEssentials Documentation
IsDropDownResizable Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditor Class : IsDropDownResizable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsDropDownResizable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditor
Dim value As System.Boolean

value = instance.IsDropDownResizable
C#
public virtual System.bool IsDropDownResizable {get;}
Delphi
public read-only property IsDropDownResizable: System.Boolean; virtual;
JScript
public function get IsDropDownResizable : System.boolean
Managed Extensions for C++
public: __property virtual System.bool get_IsDropDownResizable();
C++/CLI
public:
virtual property System.bool IsDropDownResizable {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Class
WebSlidingMenuBindingEditor Members


PaintValue Method

[image]
Intersoft WebEssentials Documentation
PaintValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditor Class : PaintValue Method

Glossary Item Box

Overload List

Overload | Description
PaintValue(Object,Graphics,Rectangle) | (Inherited from System.Drawing.Design.UITypeEditor)
PaintValue(PaintValueEventArgs) | (Inherited from System.Drawing.Design.UITypeEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Class
WebSlidingMenuBindingEditor Members


PaintValue(Object,Graphics,Rectangle) Method

[image]
Intersoft WebEssentials Documentation
PaintValue(Object,Graphics,Rectangle) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditor Class > PaintValue Method : PaintValue(Object,Graphics,Rectangle) Method

value
canvas
rectangle

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub PaintValue( _
   ByVal value As System.Object, _
   ByVal canvas As System.Drawing.Graphics, _
   ByVal rectangle As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditor
Dim value As System.Object
Dim canvas As System.Drawing.Graphics
Dim rectangle As System.Drawing.Rectangle

instance.PaintValue(value, canvas, rectangle)
C#
public void PaintValue(
   System.object value,
   System.Drawing.Graphics canvas,
   System.Drawing.Rectangle rectangle
)
Delphi
public procedure PaintValue(
    value: System.TObject;
    canvas: System.Drawing.Graphics;
    rectangle: System.Drawing.Rectangle
);
JScript
public function PaintValue(
   value : System.Object,
   canvas : System.Drawing.Graphics,
   rectangle : System.Drawing.Rectangle
);
Managed Extensions for C++
public: void PaintValue(
   System.Object* value,
   System.Drawing.Graphics* canvas,
   System.Drawing.Rectangle rectangle
)
C++/CLI
public:
void PaintValue(
   System.Object^ value,
   System.Drawing.Graphics^ canvas,
   System.Drawing.Rectangle rectangle
)

Parameters

value
canvas
rectangle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Class
WebSlidingMenuBindingEditor Members
Overload List


PaintValue(PaintValueEventArgs) Method

[image]
Intersoft WebEssentials Documentation
PaintValue(PaintValueEventArgs) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuBindingEditor Class > PaintValue Method : PaintValue(PaintValueEventArgs) Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub PaintValue( _
   ByVal e As System.Drawing.Design.PaintValueEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuBindingEditor
Dim e As System.Drawing.Design.PaintValueEventArgs

instance.PaintValue(e)
C#
public virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs e
)
Delphi
public procedure PaintValue(
    e: System.Drawing.Design.PaintValueEventArgs
); virtual;
JScript
public function PaintValue(
   e : System.Drawing.Design.PaintValueEventArgs
);
Managed Extensions for C++
public: virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs* e
)
C++/CLI
public:
virtual void PaintValue(
   System.Drawing.Design.PaintValueEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuBindingEditor Class
WebSlidingMenuBindingEditor Members
Overload List


WebSlidingMenuClientSideEvents Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuClientSideEvents Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuClientSideEvents Class

Glossary Item Box

A collection of WebSlidingMenu's client side events.

Object Model

WebSlidingMenuClientSideEvents Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSlidingMenuClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSlidingMenuClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSlidingMenuClientSideEvents = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSlidingMenuClientSideEvents extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSlidingMenuClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSlidingMenuClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebSlidingMenuClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuClientSideEvents Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuClientSideEvents Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuClientSideEvents Constructor |
Top

Public Properties

 | Name | Description
Public Property | OnInitialize | Gets or sets the event handler when the control is being initialized.
Public Property | OnInitializeItem | Gets or sets the event handler on initialize item.
Public Property | OnItemClick |
Public Property | OnPreviousButtonClick |
Public Property | OnResponse | Gets or sets the event handler on response.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSlidingMenuClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuClientSideEvents Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuClientSideEvents Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSlidingMenuClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuClientSideEvents Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuClientSideEvents Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnInitialize | Gets or sets the event handler when the control is being initialized.
Public Property | OnInitializeItem | Gets or sets the event handler on initialize item.
Public Property | OnItemClick |
Public Property | OnPreviousButtonClick |
Public Property | OnResponse | Gets or sets the event handler on response.
Top

See Also

Reference

WebSlidingMenuClientSideEvents Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : WebSlidingMenuClientSideEvents Constructor

Glossary Item Box

Overload List

Overload | Description
WebSlidingMenuClientSideEvents Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


WebSlidingMenuClientSideEvents Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuClientSideEvents Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : WebSlidingMenuClientSideEvents Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuClientSideEvents()
C#
public WebSlidingMenuClientSideEvents()
Delphi
public WebSlidingMenuClientSideEvents();
JScript
public function WebSlidingMenuClientSideEvents();
Managed Extensions for C++
public: WebSlidingMenuClientSideEvents();
C++/CLI
public:
WebSlidingMenuClientSideEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebEssentials Documentation
OnInitialize Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : OnInitialize Property

Glossary Item Box

Gets or sets the event handler when the control is being initialized.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the control is being initialized.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
Dim value As System.String

instance.OnInitialize = value

value = instance.OnInitialize
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the control is being initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnInitialize {get; set;}
Delphi
public read-write property OnInitialize: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the control is being initialized.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnInitialize : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the control is being initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnInitialize();
public: __property void set_OnInitialize(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when the control is being initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


OnInitializeItem Property

[image]
Intersoft WebEssentials Documentation
OnInitializeItem Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : OnInitializeItem Property

Glossary Item Box

Gets or sets the event handler on initialize item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, itemObject, itemText")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on initialize item.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnInitializeItem As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
Dim value As System.String

instance.OnInitializeItem = value

value = instance.OnInitializeItem
C#
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, itemObject, itemText")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on initialize item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnInitializeItem {get; set;}
Delphi
public read-write property OnInitializeItem: System.String;
JScript
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, itemObject, itemText")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on initialize item.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnInitializeItem : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, itemObject, itemText")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on initialize item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnInitializeItem();
public: __property void set_OnInitializeItem(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, itemObject, itemText")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on initialize item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnInitializeItem {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


OnItemClick Property

[image]
Intersoft WebEssentials Documentation
OnItemClick Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : OnItemClick Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, itemObject, itemText")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an item is clicked.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnItemClick As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
Dim value As System.String

instance.OnItemClick = value

value = instance.OnItemClick
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, itemObject, itemText")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an item is clicked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnItemClick {get; set;}
Delphi
public read-write property OnItemClick: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, itemObject, itemText")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an item is clicked.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnItemClick : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, itemObject, itemText")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an item is clicked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnItemClick();
public: __property void set_OnItemClick(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, itemObject, itemText")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when an item is clicked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnItemClick {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


OnPreviousButtonClick Property

[image]
Intersoft WebEssentials Documentation
OnPreviousButtonClick Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : OnPreviousButtonClick Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when previous button is clicked.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnPreviousButtonClick As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
Dim value As System.String

instance.OnPreviousButtonClick = value

value = instance.OnPreviousButtonClick
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when previous button is clicked.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnPreviousButtonClick {get; set;}
Delphi
public read-write property OnPreviousButtonClick: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when previous button is clicked.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnPreviousButtonClick : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when previous button is clicked.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnPreviousButtonClick();
public: __property void set_OnPreviousButtonClick(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when previous button is clicked.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnPreviousButtonClick {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


OnResponse Property

[image]
Intersoft WebEssentials Documentation
OnResponse Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : OnResponse Property

Glossary Item Box

Gets or sets the event handler on response.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, action")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnResponse As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
Dim value As System.String

instance.OnResponse = value

value = instance.OnResponse
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnResponse {get; set;}
Delphi
public read-write property OnResponse: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, action")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnResponse : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnResponse();
public: __property void set_OnResponse(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler on response.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnResponse {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuClientSideEvents
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuClientSideEvents Class
WebSlidingMenuClientSideEvents Members


WebSlidingMenuContentMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuContentMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuContentMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebSlidingMenuContentMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuContentMode
C#
public enum WebSlidingMenuContentMode : System.Enum
Delphi
public enum WebSlidingMenuContentMode = class(System.Enum)
JScript
public enum WebSlidingMenuContentMode extends System.Enum
Managed Extensions for C++
__value public enum WebSlidingMenuContentMode : public System.Enum
C++/CLI
public enum class WebSlidingMenuContentMode : public System.Enum

Members

Member | Description
Default |
IFrame |
Inline |
Text |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebSlidingMenuContentMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuDefaultStyleMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuDefaultStyleMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuDefaultStyleMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebSlidingMenuDefaultStyleMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuDefaultStyleMode
C#
public enum WebSlidingMenuDefaultStyleMode : System.Enum
Delphi
public enum WebSlidingMenuDefaultStyleMode = class(System.Enum)
JScript
public enum WebSlidingMenuDefaultStyleMode extends System.Enum
Managed Extensions for C++
__value public enum WebSlidingMenuDefaultStyleMode : public System.Enum
C++/CLI
public enum class WebSlidingMenuDefaultStyleMode : public System.Enum

Members

Member | Description
Black |
OfficeBlack |
Silver |
Standard |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebSlidingMenuDefaultStyleMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuEventDataArgs Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuEventDataArgs Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuEventDataArgs Class

Glossary Item Box

Provides data for OnInitializeItem event.

Object Model

WebSlidingMenuEventDataArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebSlidingMenuEventDataArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuEventDataArgs
C#
public class WebSlidingMenuEventDataArgs : System.EventArgs
Delphi
public class WebSlidingMenuEventDataArgs = class(System.EventArgs)
JScript
public class WebSlidingMenuEventDataArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebSlidingMenuEventDataArgs : public System.EventArgs
C++/CLI
public ref class WebSlidingMenuEventDataArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebEssentials.WebSlidingMenuEventDataArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuEventDataArgs Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuEventDataArgs Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuEventDataArgs Class Members
See Also Properties Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuEventDataArgs Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuEventDataArgs.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuEventDataArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Action |
Public Property | Depth |
Public Property | NewItemsObject |
Public Property | SelectedItemName |
Public Property | SelectedParentItemName |
Top

See Also

Reference

WebSlidingMenuEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuEventDataArgs Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuEventDataArgs Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuEventDataArgs Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuEventDataArgs members.

Public Properties

 | Name | Description
Public Property | Action |
Public Property | Depth |
Public Property | NewItemsObject |
Public Property | SelectedItemName |
Public Property | SelectedParentItemName |
Top

See Also

Reference

WebSlidingMenuEventDataArgs Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuEventDataArgs Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuEventDataArgs Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuEventDataArgs Class : WebSlidingMenuEventDataArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuEventDataArgs()
C#
public WebSlidingMenuEventDataArgs()
Delphi
public WebSlidingMenuEventDataArgs();
JScript
public function WebSlidingMenuEventDataArgs();
Managed Extensions for C++
public: WebSlidingMenuEventDataArgs();
C++/CLI
public:
WebSlidingMenuEventDataArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuEventDataArgs Class
WebSlidingMenuEventDataArgs Members


Action Property

[image]
Intersoft WebEssentials Documentation
Action Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuEventDataArgs Class : Action Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Action As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuEventDataArgs
Dim value As System.String

instance.Action = value

value = instance.Action
C#
public System.string Action {get; set;}
Delphi
public read-write property Action: System.String;
JScript
public function get,set Action : System.String
Managed Extensions for C++
public: __property System.string* get_Action();
public: __property void set_Action(
   System.string* value
);
C++/CLI
public:
property System.String^ Action {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuEventDataArgs Class
WebSlidingMenuEventDataArgs Members


Depth Property

[image]
Intersoft WebEssentials Documentation
Depth Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuEventDataArgs Class : Depth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Depth As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuEventDataArgs
Dim value As System.String

instance.Depth = value

value = instance.Depth
C#
public System.string Depth {get; set;}
Delphi
public read-write property Depth: System.String;
JScript
public function get,set Depth : System.String
Managed Extensions for C++
public: __property System.string* get_Depth();
public: __property void set_Depth(
   System.string* value
);
C++/CLI
public:
property System.String^ Depth {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuEventDataArgs Class
WebSlidingMenuEventDataArgs Members


NewItemsObject Property

[image]
Intersoft WebEssentials Documentation
NewItemsObject Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuEventDataArgs Class : NewItemsObject Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property NewItemsObject As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuEventDataArgs
Dim value As System.Object

instance.NewItemsObject = value

value = instance.NewItemsObject
C#
public System.object NewItemsObject {get; set;}
Delphi
public read-write property NewItemsObject: System.TObject;
JScript
public function get,set NewItemsObject : System.Object
Managed Extensions for C++
public: __property System.Object* get_NewItemsObject();
public: __property void set_NewItemsObject(
   System.Object* value
);
C++/CLI
public:
property System.Object^ NewItemsObject {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuEventDataArgs Class
WebSlidingMenuEventDataArgs Members


SelectedItemName Property

[image]
Intersoft WebEssentials Documentation
SelectedItemName Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuEventDataArgs Class : SelectedItemName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property SelectedItemName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuEventDataArgs
Dim value As System.String

instance.SelectedItemName = value

value = instance.SelectedItemName
C#
public System.string SelectedItemName {get; set;}
Delphi
public read-write property SelectedItemName: System.String;
JScript
public function get,set SelectedItemName : System.String
Managed Extensions for C++
public: __property System.string* get_SelectedItemName();
public: __property void set_SelectedItemName(
   System.string* value
);
C++/CLI
public:
property System.String^ SelectedItemName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuEventDataArgs Class
WebSlidingMenuEventDataArgs Members


SelectedParentItemName Property

[image]
Intersoft WebEssentials Documentation
SelectedParentItemName Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuEventDataArgs Class : SelectedParentItemName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property SelectedParentItemName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuEventDataArgs
Dim value As System.String

instance.SelectedParentItemName = value

value = instance.SelectedParentItemName
C#
public System.string SelectedParentItemName {get; set;}
Delphi
public read-write property SelectedParentItemName: System.String;
JScript
public function get,set SelectedParentItemName : System.String
Managed Extensions for C++
public: __property System.string* get_SelectedParentItemName();
public: __property void set_SelectedParentItemName(
   System.string* value
);
C++/CLI
public:
property System.String^ SelectedParentItemName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuEventDataArgs Class
WebSlidingMenuEventDataArgs Members


WebSlidingMenuEventHandler Delegate

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuEventHandler Delegate
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the OnInitializeItem event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebSlidingMenuEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebSlidingMenuEventDataArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebSlidingMenuEventHandler(
   System.object sender,
   WebSlidingMenuEventDataArgs e
)
Delphi
public delegate WebSlidingMenuEventHandler(
    sender: System.TObject;
    e: WebSlidingMenuEventDataArgs
);
JScript
public delegate WebSlidingMenuEventHandler(
   sender : System.Object,
   e : WebSlidingMenuEventDataArgs
)
Managed Extensions for C++
public: __gc __delegate void WebSlidingMenuEventHandler(
   System.Object* sender,
   WebSlidingMenuEventDataArgs* e
)
C++/CLI
public delegate void WebSlidingMenuEventHandler(
   System.Object^ sender,
   WebSlidingMenuEventDataArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuEventHandler Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuEventItemBoundArgs Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuEventItemBoundArgs Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuEventItemBoundArgs Class

Glossary Item Box

Provides data for OnItemBound event.

Object Model

WebSlidingMenuEventItemBoundArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebSlidingMenuEventItemBoundArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuEventItemBoundArgs
C#
public class WebSlidingMenuEventItemBoundArgs : System.EventArgs
Delphi
public class WebSlidingMenuEventItemBoundArgs = class(System.EventArgs)
JScript
public class WebSlidingMenuEventItemBoundArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebSlidingMenuEventItemBoundArgs : public System.EventArgs
C++/CLI
public ref class WebSlidingMenuEventItemBoundArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebEssentials.WebSlidingMenuEventItemBoundArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuEventItemBoundArgs Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuEventItemBoundArgs Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuEventItemBoundArgs Class Members
See Also Properties Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuEventItemBoundArgs Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuEventItemBoundArgs.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuEventItemBoundArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Item |
Top

See Also

Reference

WebSlidingMenuEventItemBoundArgs Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuEventItemBoundArgs Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuEventItemBoundArgs Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuEventItemBoundArgs Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuEventItemBoundArgs members.

Public Properties

 | Name | Description
Public Property | Item |
Top

See Also

Reference

WebSlidingMenuEventItemBoundArgs Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuEventItemBoundArgs Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuEventItemBoundArgs Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuEventItemBoundArgs Class : WebSlidingMenuEventItemBoundArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuEventItemBoundArgs()
C#
public WebSlidingMenuEventItemBoundArgs()
Delphi
public WebSlidingMenuEventItemBoundArgs();
JScript
public function WebSlidingMenuEventItemBoundArgs();
Managed Extensions for C++
public: WebSlidingMenuEventItemBoundArgs();
C++/CLI
public:
WebSlidingMenuEventItemBoundArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuEventItemBoundArgs Class
WebSlidingMenuEventItemBoundArgs Members


Item Property

[image]
Intersoft WebEssentials Documentation
Item Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuEventItemBoundArgs Class : Item Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Item As WebSlidingMenuItem
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuEventItemBoundArgs
Dim value As WebSlidingMenuItem

instance.Item = value

value = instance.Item
C#
public WebSlidingMenuItem Item {get; set;}
Delphi
public read-write property Item: WebSlidingMenuItem;
JScript
public function get,set Item : WebSlidingMenuItem
Managed Extensions for C++
public: __property WebSlidingMenuItem* get_Item();
public: __property void set_Item(
   WebSlidingMenuItem* value
);
C++/CLI
public:
property WebSlidingMenuItem^ Item {
   WebSlidingMenuItem^ get();
   void set (    WebSlidingMenuItem^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuEventItemBoundArgs Class
WebSlidingMenuEventItemBoundArgs Members


WebSlidingMenuEventItemBoundHandler Delegate

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuEventItemBoundHandler Delegate
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuEventItemBoundHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the OnItemBound event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebSlidingMenuEventItemBoundHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebSlidingMenuEventItemBoundArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuEventItemBoundHandler(AddressOf HandlerMethod)
C#
public delegate void WebSlidingMenuEventItemBoundHandler(
   System.object sender,
   WebSlidingMenuEventItemBoundArgs e
)
Delphi
public delegate WebSlidingMenuEventItemBoundHandler(
    sender: System.TObject;
    e: WebSlidingMenuEventItemBoundArgs
);
JScript
public delegate WebSlidingMenuEventItemBoundHandler(
   sender : System.Object,
   e : WebSlidingMenuEventItemBoundArgs
)
Managed Extensions for C++
public: __gc __delegate void WebSlidingMenuEventItemBoundHandler(
   System.Object* sender,
   WebSlidingMenuEventItemBoundArgs* e
)
C++/CLI
public delegate void WebSlidingMenuEventItemBoundHandler(
   System.Object^ sender,
   WebSlidingMenuEventItemBoundArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuEventItemBoundHandler Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuHeaderContentMode Enumeration

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuHeaderContentMode Enumeration
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuHeaderContentMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebSlidingMenuHeaderContentMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuHeaderContentMode
C#
public enum WebSlidingMenuHeaderContentMode : System.Enum
Delphi
public enum WebSlidingMenuHeaderContentMode = class(System.Enum)
JScript
public enum WebSlidingMenuHeaderContentMode extends System.Enum
Managed Extensions for C++
__value public enum WebSlidingMenuHeaderContentMode : public System.Enum
C++/CLI
public enum class WebSlidingMenuHeaderContentMode : public System.Enum

Members

Member | Description
Inline |
Text |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebEssentials.WebSlidingMenuHeaderContentMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuImagesSettings Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuImagesSettings Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuImagesSettings Class

Glossary Item Box

A collection of WebSlidingMenu's images settings.

Object Model

WebSlidingMenuImagesSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSlidingMenuImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuImagesSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSlidingMenuImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSlidingMenuImagesSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSlidingMenuImagesSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSlidingMenuImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSlidingMenuImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebSlidingMenuImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuImagesSettings Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuImagesSettings Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuImagesSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | InProgressIndicator | Gets or sets the default image used for progress indicator.
Public Property | NextIndicator | Gets or sets the default image used for bottom scroller.
Public Property | PreviousButton | Gets or sets the default image used for previous button.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSlidingMenuImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuImagesSettings Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuImagesSettings Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSlidingMenuImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuImagesSettings Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuImagesSettings Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuImagesSettings members.

Public Properties

 | Name | Description
Public Property | InProgressIndicator | Gets or sets the default image used for progress indicator.
Public Property | NextIndicator | Gets or sets the default image used for bottom scroller.
Public Property | PreviousButton | Gets or sets the default image used for previous button.
Top

See Also

Reference

WebSlidingMenuImagesSettings Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuImagesSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuImagesSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class : WebSlidingMenuImagesSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebSlidingMenuImagesSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members


WebSlidingMenuImagesSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuImagesSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class : WebSlidingMenuImagesSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuImagesSettings()
C#
public WebSlidingMenuImagesSettings()
Delphi
public WebSlidingMenuImagesSettings();
JScript
public function WebSlidingMenuImagesSettings();
Managed Extensions for C++
public: WebSlidingMenuImagesSettings();
C++/CLI
public:
WebSlidingMenuImagesSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuImagesSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuImagesSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuImagesSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuImagesSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members


InProgressIndicator Property

[image]
Intersoft WebEssentials Documentation
InProgressIndicator Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class : InProgressIndicator Property

Glossary Item Box

Gets or sets the default image used for progress indicator.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for progress indicator.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property InProgressIndicator As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuImagesSettings
Dim value As System.String

instance.InProgressIndicator = value

value = instance.InProgressIndicator
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for progress indicator.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string InProgressIndicator {get; set;}
Delphi
public read-write property InProgressIndicator: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for progress indicator.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set InProgressIndicator : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for progress indicator.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_InProgressIndicator();
public: __property void set_InProgressIndicator(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for progress indicator.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ InProgressIndicator {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuImagesSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members


NextIndicator Property

[image]
Intersoft WebEssentials Documentation
NextIndicator Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class : NextIndicator Property

Glossary Item Box

Gets or sets the default image used for bottom scroller.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for bottom scroller.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property NextIndicator As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuImagesSettings
Dim value As System.String

instance.NextIndicator = value

value = instance.NextIndicator
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for bottom scroller.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string NextIndicator {get; set;}
Delphi
public read-write property NextIndicator: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for bottom scroller.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set NextIndicator : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for bottom scroller.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_NextIndicator();
public: __property void set_NextIndicator(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for bottom scroller.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ NextIndicator {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members


PreviousButton Property

[image]
Intersoft WebEssentials Documentation
PreviousButton Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class : PreviousButton Property

Glossary Item Box

Gets or sets the default image used for previous button.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous button.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property PreviousButton As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuImagesSettings
Dim value As System.String

instance.PreviousButton = value

value = instance.PreviousButton
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous button.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string PreviousButton {get; set;}
Delphi
public read-write property PreviousButton: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous button.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set PreviousButton : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous button.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_PreviousButton();
public: __property void set_PreviousButton(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for previous button.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ PreviousButton {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuImagesSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuImagesSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuImagesSettings Class
WebSlidingMenuImagesSettings Members


WebSlidingMenuItem Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItem Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItem Class

Glossary Item Box

WebListBoxItem object of WebListBox.

Object Model

WebSlidingMenuItem Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSlidingMenuItem
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSlidingMenuItem : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebSlidingMenuItem = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSlidingMenuItem extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSlidingMenuItem : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSlidingMenuItem : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebEssentials.WebSlidingMenuItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItem Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItem Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItem Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuItem.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | AutoHeight | Gets or sets the value that determines whether or not an item is auto height.
Public Property | ContentMode | Specifies the container mode of WebSlidingMenu's item.
Public Property | ContentURL | Specifies the content url of of WebSlidingMenu's item.
Public Property | CustomRules | Gets or sets the custom styles applied to item.
Public Property | Enabled | Gets or sets the value that determines whether or not an item is enabled.
Public Property | ItemHeight | Gets or sets the item's height.
Public Property | Items | The item collection of WebSlidingMenuItem
Public Property | Name | Overridden. Specifies the name of the item.
Public Property | Parent | Gets the WebSlidingMenu object that own this Menu.
Public Property | ParentMenu |
Public Property | Tag | Gets or sets tag of an item.
Public Property | TargetURL | Gets or sets the target url when item is selected.
Public Property | TargetWindow | Gets or sets the target window when item is selected.
Public Property | Text | Gets or sets the item's text.
Public Property | ToolTip | Gets or sets the tooltip of item.
Public Property | Value | Gets or sets the item's value.
Public Property | Visible | Gets or sets the value that determines whether or not an item is visible.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | FindControl |
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetLevelByItem |
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSlidingMenuItem Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItem Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItem Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItem Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuItem members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | FindControl |
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetLevelByItem |
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSlidingMenuItem Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItem Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItem Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItem Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuItem members.

Public Properties

 | Name | Description
Public Property | AutoHeight | Gets or sets the value that determines whether or not an item is auto height.
Public Property | ContentMode | Specifies the container mode of WebSlidingMenu's item.
Public Property | ContentURL | Specifies the content url of of WebSlidingMenu's item.
Public Property | CustomRules | Gets or sets the custom styles applied to item.
Public Property | Enabled | Gets or sets the value that determines whether or not an item is enabled.
Public Property | ItemHeight | Gets or sets the item's height.
Public Property | Items | The item collection of WebSlidingMenuItem
Public Property | Name | Overridden. Specifies the name of the item.
Public Property | Parent | Gets the WebSlidingMenu object that own this Menu.
Public Property | ParentMenu |
Public Property | Tag | Gets or sets tag of an item.
Public Property | TargetURL | Gets or sets the target url when item is selected.
Public Property | TargetWindow | Gets or sets the target window when item is selected.
Public Property | Text | Gets or sets the item's text.
Public Property | ToolTip | Gets or sets the tooltip of item.
Public Property | Value | Gets or sets the item's value.
Public Property | Visible | Gets or sets the value that determines whether or not an item is visible.
Top

See Also

Reference

WebSlidingMenuItem Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItemBinding Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemBinding Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItemBinding Class

Glossary Item Box

Represents a bound item which belongs to WebSlidingMenu object.

Object Model

WebSlidingMenuItemBinding Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Represents a bound item which belongs to WebSlidingMenu object.")>
Public Class WebSlidingMenuItemBinding
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
C#
[System.ComponentModel.DescriptionAttribute("Represents a bound item which belongs to WebSlidingMenu object.")]
public class WebSlidingMenuItemBinding : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebSlidingMenuItemBinding = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.ComponentModel.DescriptionAttribute("Represents a bound item which belongs to WebSlidingMenu object.")
public class WebSlidingMenuItemBinding extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Represents a bound item which belongs to WebSlidingMenu object.")]
public __gc class WebSlidingMenuItemBinding : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.ComponentModel.DescriptionAttribute("Represents a bound item which belongs to WebSlidingMenu object.")]
public ref class WebSlidingMenuItemBinding : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebEssentials.WebSlidingMenuItemBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItemBinding Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemBinding Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItemBinding Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuItemBinding.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuItemBinding Constructor |
Top

Public Properties

 | Name | Description
Public Property | ContentModeField |
Public Property | ContentURL |
Public Property | ContentURLField |
Public Property | CustomRules |
Public Property | CustomRulesField |
Public Property | DataMember |
Public Property | Depth |
Public Property | Enabled |
Public Property | EnabledField |
Public Property | ItemHeight |
Public Property | ItemHeightField |
Public Property | MaxBindingDepth |
Public Property | MaxBindingDepthField |
Public Property | Name |
Public Property | NameField |
Public Property | TargetURL |
Public Property | TargetURLField |
Public Property | Text |
Public Property | TextField |
Public Property | ToolTip |
Public Property | ToolTipField |
Public Property | Value |
Public Property | ValueField |
Public Property | Visible |
Public Property | VisibleField |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.NamedObjectBase)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebSlidingMenuItemBinding Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItemBinding Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemBinding Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItemBinding Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuItemBinding members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.NamedObjectBase)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

See Also

Reference

WebSlidingMenuItemBinding Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItemBinding Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemBinding Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItemBinding Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuItemBinding members.

Public Properties

 | Name | Description
Public Property | ContentModeField |
Public Property | ContentURL |
Public Property | ContentURLField |
Public Property | CustomRules |
Public Property | CustomRulesField |
Public Property | DataMember |
Public Property | Depth |
Public Property | Enabled |
Public Property | EnabledField |
Public Property | ItemHeight |
Public Property | ItemHeightField |
Public Property | MaxBindingDepth |
Public Property | MaxBindingDepthField |
Public Property | Name |
Public Property | NameField |
Public Property | TargetURL |
Public Property | TargetURLField |
Public Property | Text |
Public Property | TextField |
Public Property | ToolTip |
Public Property | ToolTipField |
Public Property | Value |
Public Property | ValueField |
Public Property | Visible |
Public Property | VisibleField |
Top

See Also

Reference

WebSlidingMenuItemBinding Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItemBindingCollection Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemBindingCollection Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItemBindingCollection Class

Glossary Item Box

Summary description for WebSlidingMenuItemBindingCollection.

Object Model

WebSlidingMenuItemBindingCollection Class

Syntax

Visual Basic (Declaration)
<System.Reflection.DefaultMemberAttribute("Item")>
<System.ComponentModel.DescriptionAttribute("A collection of WebSlidingMenuItemBindingCollection.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSlidingMenuItemBindingCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
C#
[System.Reflection.DefaultMemberAttribute("Item")]
[System.ComponentModel.DescriptionAttribute("A collection of WebSlidingMenuItemBindingCollection.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSlidingMenuItemBindingCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class WebSlidingMenuItemBindingCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.Reflection.DefaultMemberAttribute("Item")
System.ComponentModel.DescriptionAttribute("A collection of WebSlidingMenuItemBindingCollection.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSlidingMenuItemBindingCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.Reflection.DefaultMemberAttribute("Item")]
[System.ComponentModel.DescriptionAttribute("A collection of WebSlidingMenuItemBindingCollection.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSlidingMenuItemBindingCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.Reflection.DefaultMemberAttribute("Item")]
[System.ComponentModel.DescriptionAttribute("A collection of WebSlidingMenuItemBindingCollection.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSlidingMenuItemBindingCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebEssentials.WebSlidingMenuItemBindingCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItemBindingCollection Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemBindingCollection Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItemBindingCollection Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuItemBindingCollection.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuItemBindingCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add WebSlidingMenuItem object into the WebSlidingMenuItemBinding collection.
Public Method | Clear | Removes all WebSlidingMenuItemBinding objects from the collection.
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator | Returns an enumerator object for the collection.
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem | Property indexer for the collection. Uses the Name string to return an WebSlidingMenuItemBinding object.
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert | Inserts a WebSlidingMenuItemBinding object into the WebSlidingMenuItemBinding collection at a specified index.
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove | Removes the specified WebSlidingMenuItemBinding object from the collection.
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebSlidingMenuItemBindingCollection Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItemBindingCollection Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemBindingCollection Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItemBindingCollection Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuItemBindingCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add WebSlidingMenuItem object into the WebSlidingMenuItemBinding collection.
Public Method | Clear | Removes all WebSlidingMenuItemBinding objects from the collection.
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyFrom |
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator | Returns an enumerator object for the collection.
Public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem | Property indexer for the collection. Uses the Name string to return an WebSlidingMenuItemBinding object.
Public Method | GetObjectData |
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert | Inserts a WebSlidingMenuItemBinding object into the WebSlidingMenuItemBinding collection at a specified index.
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove | Removes the specified WebSlidingMenuItemBinding object from the collection.
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebSlidingMenuItemBindingCollection Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItemBindingCollection Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemBindingCollection Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItemBindingCollection Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuItemBindingCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden.
Public Property | Item |
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

WebSlidingMenuItemBindingCollection Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItemBindingCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemBindingCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : WebSlidingMenuItemBindingCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebSlidingMenuItemBindingCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


WebSlidingMenuItemBindingCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemBindingCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : WebSlidingMenuItemBindingCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebSlidingMenuItemBindingCollection class. ")>
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuItemBindingCollection()
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebSlidingMenuItemBindingCollection class. ")]
public WebSlidingMenuItemBindingCollection()
Delphi
public WebSlidingMenuItemBindingCollection();
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebSlidingMenuItemBindingCollection class. ")
public function WebSlidingMenuItemBindingCollection();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebSlidingMenuItemBindingCollection class. ")]
public: WebSlidingMenuItemBindingCollection();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebSlidingMenuItemBindingCollection class. ")]
public:
WebSlidingMenuItemBindingCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


Add Method

[image]
Intersoft WebEssentials Documentation
Add Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : Add Method

Glossary Item Box

Add WebSlidingMenuItem object into the WebSlidingMenuItemBinding collection.

Overload List

Overload | Description
Add(WebSlidingMenuItemBinding) | Add WebSlidingMenuItem object into the WebSlidingMenuItemBinding collection.
Add(String) | Creates a new item object in the collection and initializes its Name value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


Add(String) Method

[image]
Intersoft WebEssentials Documentation
Add(String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class > Add Method : Add(String) Method

name
The unique Name value.

Glossary Item Box

Creates a new item object in the collection and initializes its Name value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Adds a new item to a WebSlidingMenuItemBindingCollection instance with String parameter as its name. ")>
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
[System.ComponentModel.DescriptionAttribute("Adds a new item to a WebSlidingMenuItemBindingCollection instance with String parameter as its name. ")]
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Adds a new item to a WebSlidingMenuItemBindingCollection instance with String parameter as its name. ")
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Adds a new item to a WebSlidingMenuItemBindingCollection instance with String parameter as its name. ")]
public: System.int Add(
   System.string* name
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Adds a new item to a WebSlidingMenuItemBindingCollection instance with String parameter as its name. ")]
public:
System.int Add(
   System.String^ name
)

Parameters

name
The unique Name value.

Return Value

The index of the newly-added item object within the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members
Overload List


Add(WebSlidingMenuItemBinding) Method

[image]
Intersoft WebEssentials Documentation
Add(WebSlidingMenuItemBinding) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class > Add Method : Add(WebSlidingMenuItemBinding) Method

item

Glossary Item Box

Add WebSlidingMenuItem object into the WebSlidingMenuItemBinding collection.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Adds a new node to a WebSlidingMenuItemBindingCollection instance with WebSlidingMenuItemBinding parameter as its name.")>
Public Overloads Overridable Function Add( _
   ByVal item As WebSlidingMenuItemBinding _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim item As WebSlidingMenuItemBinding
Dim value As System.Integer

value = instance.Add(item)
C#
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebSlidingMenuItemBindingCollection instance with WebSlidingMenuItemBinding parameter as its name.")]
public virtual System.int Add(
   WebSlidingMenuItemBinding item
)
Delphi
public function Add(
    item: WebSlidingMenuItemBinding
): System.Integer; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Adds a new node to a WebSlidingMenuItemBindingCollection instance with WebSlidingMenuItemBinding parameter as its name.")
public function Add(
   item : WebSlidingMenuItemBinding
) : System.int;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebSlidingMenuItemBindingCollection instance with WebSlidingMenuItemBinding parameter as its name.")]
public: virtual System.int Add(
   WebSlidingMenuItemBinding* item
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebSlidingMenuItemBindingCollection instance with WebSlidingMenuItemBinding parameter as its name.")]
public:
virtual System.int Add(
   WebSlidingMenuItemBinding^ item
)

Parameters

item

Return Value

The index of the newly added item.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members
Overload List


Capacity Property

[image]
Intersoft WebEssentials Documentation
Capacity Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


Clear Method

[image]
Intersoft WebEssentials Documentation
Clear Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : Clear Method

Glossary Item Box

Removes all WebSlidingMenuItemBinding objects from the collection.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Removes item objects from the node binding collection. ")>
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection

instance.Clear()
C#
[System.ComponentModel.DescriptionAttribute("Removes item objects from the node binding collection. ")]
public new void Clear()
Delphi
public procedure Clear();
JScript
System.ComponentModel.DescriptionAttribute("Removes item objects from the node binding collection. ")
public hide function Clear();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Removes item objects from the node binding collection. ")]
public: new void Clear();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Removes item objects from the node binding collection. ")]
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


Contains Method

[image]
Intersoft WebEssentials Documentation
Contains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : CopyFrom Method

passIn

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
Public Function CopyFrom( _
   ByVal passIn As WebSlidingMenuItemBindingCollection _
) As WebSlidingMenuItemBindingCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim passIn As WebSlidingMenuItemBindingCollection
Dim value As WebSlidingMenuItemBindingCollection

value = instance.CopyFrom(passIn)
C#
[System.ComponentModel.DescriptionAttribute()]
public WebSlidingMenuItemBindingCollection CopyFrom(
   WebSlidingMenuItemBindingCollection passIn
)
Delphi
public function CopyFrom(
    passIn: WebSlidingMenuItemBindingCollection
): WebSlidingMenuItemBindingCollection;
JScript
System.ComponentModel.DescriptionAttribute()
public function CopyFrom(
   passIn : WebSlidingMenuItemBindingCollection
) : WebSlidingMenuItemBindingCollection;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
public: WebSlidingMenuItemBindingCollection* CopyFrom(
   WebSlidingMenuItemBindingCollection* passIn
)
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
public:
WebSlidingMenuItemBindingCollection^ CopyFrom(
   WebSlidingMenuItemBindingCollection^ passIn
)

Parameters

passIn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


CopyTo Method

[image]
Intersoft WebEssentials Documentation
CopyTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


Count Property

[image]
Intersoft WebEssentials Documentation
Count Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


Exists Method

[image]
Intersoft WebEssentials Documentation
Exists Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


GetEnumerator Method

[image]
Intersoft WebEssentials Documentation
GetEnumerator Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : GetEnumerator Method

Glossary Item Box

Returns an enumerator object for the collection.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Returns an enumerator object for the collection. ")>
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
[System.ComponentModel.DescriptionAttribute("Returns an enumerator object for the collection. ")]
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
System.ComponentModel.DescriptionAttribute("Returns an enumerator object for the collection. ")
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Returns an enumerator object for the collection. ")]
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Returns an enumerator object for the collection. ")]
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


GetItem Method

[image]
Intersoft WebEssentials Documentation
GetItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


GetItem(Int32) Method

[image]
Intersoft WebEssentials Documentation
GetItem(Int32) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


GetNamedItem Method

[image]
Intersoft WebEssentials Documentation
GetNamedItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : GetNamedItem Method

name

Glossary Item Box

Property indexer for the collection. Uses the Name string to return an WebSlidingMenuItemBinding object.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebSlidingMenuItem node object.")>
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebSlidingMenuItemBinding
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim name As System.String
Dim value As WebSlidingMenuItemBinding

value = instance.GetNamedItem(name)
C#
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebSlidingMenuItem node object.")]
public WebSlidingMenuItemBinding GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebSlidingMenuItemBinding;
JScript
System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebSlidingMenuItem node object.")
public function GetNamedItem(
   name : System.String
) : WebSlidingMenuItemBinding;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebSlidingMenuItem node object.")]
public: WebSlidingMenuItemBinding* GetNamedItem(
   System.string* name
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebSlidingMenuItem node object.")]
public:
WebSlidingMenuItemBinding^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


IndexOf Method

[image]
Intersoft WebEssentials Documentation
IndexOf Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


IndexOf(INamedObject) Method

[image]
Intersoft WebEssentials Documentation
IndexOf(INamedObject) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members
Overload List


IndexOf(String) Method

[image]
Intersoft WebEssentials Documentation
IndexOf(String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members
Overload List


Insert Method

[image]
Intersoft WebEssentials Documentation
Insert Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : Insert Method

index
The position in the collection for the new WebSlidingMenuItemBinding.
item

Glossary Item Box

Inserts a WebSlidingMenuItemBinding object into the WebSlidingMenuItemBinding collection at a specified index.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Inserts a new WebSlidingMenu item into a WebSlidingMenu collection at a specified index.")>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As WebSlidingMenuItemBinding _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim index As System.Integer
Dim item As WebSlidingMenuItemBinding

instance.Insert(index, item)
C#
[System.ComponentModel.DescriptionAttribute("Inserts a new WebSlidingMenu item into a WebSlidingMenu collection at a specified index.")]
public void Insert(
   System.int index,
   WebSlidingMenuItemBinding item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: WebSlidingMenuItemBinding
);
JScript
System.ComponentModel.DescriptionAttribute("Inserts a new WebSlidingMenu item into a WebSlidingMenu collection at a specified index.")
public function Insert(
   index : System.int,
   item : WebSlidingMenuItemBinding
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Inserts a new WebSlidingMenu item into a WebSlidingMenu collection at a specified index.")]
public: void Insert(
   System.int index,
   WebSlidingMenuItemBinding* item
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Inserts a new WebSlidingMenu item into a WebSlidingMenu collection at a specified index.")]
public:
void Insert(
   System.int index,
   WebSlidingMenuItemBinding^ item
)

Parameters

index
The position in the collection for the new WebSlidingMenuItemBinding.
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


IntInsert Method

[image]
Intersoft WebEssentials Documentation
IntInsert Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


IsReadOnly Property

[image]
Intersoft WebEssentials Documentation
IsReadOnly Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : IsReadOnly Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only.")>
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
[System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only.")]
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only.")
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only.")]
public: __property System.bool get_IsReadOnly() override;
C++/CLI
[System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only.")]
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


Item Property

[image]
Intersoft WebEssentials Documentation
Item Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")>
Public Default Property Item( _
   ByVal index As System.Integer _
) As WebSlidingMenuItemBinding
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim index As System.Integer
Dim value As WebSlidingMenuItemBinding

instance.Item(index) = value

value = instance.Item(index)
C#
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")]
public WebSlidingMenuItemBinding this[
   System.int index
]; {get; set;}
Delphi
public  this: : WebSlidingMenuItemBinding;[
    index: System.Integer
]; read-write
JScript
System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")
public  this[
   index : System.int
] get,set : WebSlidingMenuItemBinding
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")]
public: __property WebSlidingMenuItemBinding* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   WebSlidingMenuItemBinding* value
;
C++/CLI
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")]
public:
property WebSlidingMenuItemBinding^ default [int] {
   WebSlidingMenuItemBinding^ get(System.int index);
   void set (System.int index, WebSlidingMenuItemBinding^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


Parent Property

[image]
Intersoft WebEssentials Documentation
Parent Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


Remove Method

[image]
Intersoft WebEssentials Documentation
Remove Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : Remove Method

item

Glossary Item Box

Removes the specified WebSlidingMenuItemBinding object from the collection.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Removes the specified WebSlidingMenu item object from the collection.")>
Public Sub Remove( _
   ByVal item As WebSlidingMenuItemBinding _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim item As WebSlidingMenuItemBinding

instance.Remove(item)
C#
[System.ComponentModel.DescriptionAttribute("Removes the specified WebSlidingMenu item object from the collection.")]
public void Remove(
   WebSlidingMenuItemBinding item
)
Delphi
public procedure Remove(
    item: WebSlidingMenuItemBinding
);
JScript
System.ComponentModel.DescriptionAttribute("Removes the specified WebSlidingMenu item object from the collection.")
public function Remove(
   item : WebSlidingMenuItemBinding
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Removes the specified WebSlidingMenu item object from the collection.")]
public: void Remove(
   WebSlidingMenuItemBinding* item
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Removes the specified WebSlidingMenu item object from the collection.")]
public:
void Remove(
   WebSlidingMenuItemBinding^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


setParent Method

[image]
Intersoft WebEssentials Documentation
setParent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBindingCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBindingCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBindingCollection Class
WebSlidingMenuItemBindingCollection Members


WebSlidingMenuItemBinding Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemBinding Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : WebSlidingMenuItemBinding Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebSlidingMenuItemBinding class. ")>
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuItemBinding()
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebSlidingMenuItemBinding class. ")]
public WebSlidingMenuItemBinding()
Delphi
public WebSlidingMenuItemBinding();
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebSlidingMenuItemBinding class. ")
public function WebSlidingMenuItemBinding();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebSlidingMenuItemBinding class. ")]
public: WebSlidingMenuItemBinding();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebSlidingMenuItemBinding class. ")]
public:
WebSlidingMenuItemBinding();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


ContentModeField Property

[image]
Intersoft WebEssentials Documentation
ContentModeField Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : ContentModeField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("BindingFields")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies data field for ContentMode.")>
Public Property ContentModeField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.ContentModeField = value

value = instance.ContentModeField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ContentMode.")]
public System.string ContentModeField {get; set;}
Delphi
public read-write property ContentModeField: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("BindingFields")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies data field for ContentMode.")
public function get,set ContentModeField : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ContentMode.")]
public: __property System.string* get_ContentModeField();
public: __property void set_ContentModeField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ContentMode.")]
public:
property System.String^ ContentModeField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


ContentURL Property

[image]
Intersoft WebEssentials Documentation
ContentURL Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : ContentURL Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("DefaultProperties")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the ContentURL of WebSlidingMenu item.")>
Public Property ContentURL As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.ContentURL = value

value = instance.ContentURL
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ContentURL of WebSlidingMenu item.")]
public System.string ContentURL {get; set;}
Delphi
public read-write property ContentURL: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("DefaultProperties")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the ContentURL of WebSlidingMenu item.")
public function get,set ContentURL : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ContentURL of WebSlidingMenu item.")]
public: __property System.string* get_ContentURL();
public: __property void set_ContentURL(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the ContentURL of WebSlidingMenu item.")]
public:
property System.String^ ContentURL {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


ContentURLField Property

[image]
Intersoft WebEssentials Documentation
ContentURLField Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : ContentURLField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("BindingFields")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for ContentURL.")>
Public Property ContentURLField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.ContentURLField = value

value = instance.ContentURLField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ContentURL.")]
public System.string ContentURLField {get; set;}
Delphi
public read-write property ContentURLField: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("BindingFields")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.ComponentModel.DescriptionAttribute("Specifies data field for ContentURL.")
public function get,set ContentURLField : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ContentURL.")]
public: __property System.string* get_ContentURLField();
public: __property void set_ContentURLField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ContentURL.")]
public:
property System.String^ ContentURLField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members
Overload List


CustomRules Property

[image]
Intersoft WebEssentials Documentation
CustomRules Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : CustomRules Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("DefaultProperties")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the CustomRules of WebSlidingMenu item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CustomRules As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.CustomRules = value

value = instance.CustomRules
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the CustomRules of WebSlidingMenu item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string CustomRules {get; set;}
Delphi
public read-write property CustomRules: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("DefaultProperties")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the CustomRules of WebSlidingMenu item.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CustomRules : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the CustomRules of WebSlidingMenu item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_CustomRules();
public: __property void set_CustomRules(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the CustomRules of WebSlidingMenu item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ CustomRules {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


CustomRulesField Property

[image]
Intersoft WebEssentials Documentation
CustomRulesField Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : CustomRulesField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("BindingFields")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for CustomRules.")>
Public Property CustomRulesField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.CustomRulesField = value

value = instance.CustomRulesField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for CustomRules.")]
public System.string CustomRulesField {get; set;}
Delphi
public read-write property CustomRulesField: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("BindingFields")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.ComponentModel.DescriptionAttribute("Specifies data field for CustomRules.")
public function get,set CustomRulesField : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for CustomRules.")]
public: __property System.string* get_CustomRulesField();
public: __property void set_CustomRulesField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for CustomRules.")]
public:
property System.String^ CustomRulesField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


DataMember Property

[image]
Intersoft WebEssentials Documentation
DataMember Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : DataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the data member.")>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.DataMember = value

value = instance.DataMember
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data member.")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DataMember {get; set;}
Delphi
public read-write property DataMember: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the data member.")
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DataMember : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data member.")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DataMember();
public: __property void set_DataMember(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data member.")]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


Depth Property

[image]
Intersoft WebEssentials Documentation
Depth Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : Depth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the depth.")>
<System.ComponentModel.CategoryAttribute("Data")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Depth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.Integer

instance.Depth = value

value = instance.Depth
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the depth.")]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int Depth {get; set;}
Delphi
public read-write property Depth: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the depth.")
System.ComponentModel.CategoryAttribute("Data")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Depth : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the depth.")]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_Depth();
public: __property void set_Depth(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the depth.")]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int Depth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("DefaultProperties")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the item is enabled.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the item is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("DefaultProperties")
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the item is enabled.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the item is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the item is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


EnabledField Property

[image]
Intersoft WebEssentials Documentation
EnabledField Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : EnabledField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies data field for Enabled.")>
<System.ComponentModel.CategoryAttribute("BindingFields")>
Public Property EnabledField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.EnabledField = value

value = instance.EnabledField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Enabled.")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
public System.string EnabledField {get; set;}
Delphi
public read-write property EnabledField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies data field for Enabled.")
System.ComponentModel.CategoryAttribute("BindingFields")
public function get,set EnabledField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Enabled.")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
public: __property System.string* get_EnabledField();
public: __property void set_EnabledField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Enabled.")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
public:
property System.String^ EnabledField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


ItemHeight Property

[image]
Intersoft WebEssentials Documentation
ItemHeight Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : ItemHeight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("DefaultProperties")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets ItemHeight of WebSlidingMenu.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ItemHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.Integer

instance.ItemHeight = value

value = instance.ItemHeight
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets ItemHeight of WebSlidingMenu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int ItemHeight {get; set;}
Delphi
public read-write property ItemHeight: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("DefaultProperties")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets ItemHeight of WebSlidingMenu.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ItemHeight : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets ItemHeight of WebSlidingMenu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_ItemHeight();
public: __property void set_ItemHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets ItemHeight of WebSlidingMenu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int ItemHeight {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


ItemHeightField Property

[image]
Intersoft WebEssentials Documentation
ItemHeightField Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : ItemHeightField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies data field for ItemHeightField.")>
<System.ComponentModel.CategoryAttribute("BindingFields")>
Public Property ItemHeightField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.ItemHeightField = value

value = instance.ItemHeightField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ItemHeightField.")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
public System.string ItemHeightField {get; set;}
Delphi
public read-write property ItemHeightField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies data field for ItemHeightField.")
System.ComponentModel.CategoryAttribute("BindingFields")
public function get,set ItemHeightField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ItemHeightField.")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
public: __property System.string* get_ItemHeightField();
public: __property void set_ItemHeightField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ItemHeightField.")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
public:
property System.String^ ItemHeightField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


MaxBindingDepth Property

[image]
Intersoft WebEssentials Documentation
MaxBindingDepth Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : MaxBindingDepth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("DefaultProperties")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the MaxBindingDepth of WebSlidingMenu item.")>
Public Property MaxBindingDepth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.Integer

instance.MaxBindingDepth = value

value = instance.MaxBindingDepth
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the MaxBindingDepth of WebSlidingMenu item.")]
public System.int MaxBindingDepth {get; set;}
Delphi
public read-write property MaxBindingDepth: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("DefaultProperties")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the MaxBindingDepth of WebSlidingMenu item.")
public function get,set MaxBindingDepth : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the MaxBindingDepth of WebSlidingMenu item.")]
public: __property System.int get_MaxBindingDepth();
public: __property void set_MaxBindingDepth(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the MaxBindingDepth of WebSlidingMenu item.")]
public:
property System.int MaxBindingDepth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


MaxBindingDepthField Property

[image]
Intersoft WebEssentials Documentation
MaxBindingDepthField Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : MaxBindingDepthField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies data field for MaxBindingDepth.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("BindingFields")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property MaxBindingDepthField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.MaxBindingDepthField = value

value = instance.MaxBindingDepthField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for MaxBindingDepth.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string MaxBindingDepthField {get; set;}
Delphi
public read-write property MaxBindingDepthField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies data field for MaxBindingDepth.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("BindingFields")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set MaxBindingDepthField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for MaxBindingDepth.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_MaxBindingDepthField();
public: __property void set_MaxBindingDepthField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for MaxBindingDepth.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ MaxBindingDepthField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


Name Property

[image]
Intersoft WebEssentials Documentation
Name Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("DefaultProperties")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the name of WebSlidingMenu.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Shadows Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the name of WebSlidingMenu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public new System.string Name {get; set;}
Delphi
public read-write property Name: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("DefaultProperties")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the name of WebSlidingMenu.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public hide function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the name of WebSlidingMenu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property new System.string* get_Name();
public: __property new void set_Name(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the name of WebSlidingMenu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
new property System.String^ Name {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


NameField Property

[image]
Intersoft WebEssentials Documentation
NameField Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : NameField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies data field for Name.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.ComponentModel.CategoryAttribute("BindingFields")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property NameField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.NameField = value

value = instance.NameField
C#
[System.ComponentModel.DescriptionAttribute("Specifies data field for Name.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string NameField {get; set;}
Delphi
public read-write property NameField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies data field for Name.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.ComponentModel.CategoryAttribute("BindingFields")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set NameField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies data field for Name.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_NameField();
public: __property void set_NameField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies data field for Name.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ NameField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


TargetURL Property

[image]
Intersoft WebEssentials Documentation
TargetURL Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : TargetURL Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the targetURL of WebSlidingMenu item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("DefaultProperties")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TargetURL As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.TargetURL = value

value = instance.TargetURL
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the targetURL of WebSlidingMenu item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string TargetURL {get; set;}
Delphi
public read-write property TargetURL: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the targetURL of WebSlidingMenu item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("DefaultProperties")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TargetURL : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the targetURL of WebSlidingMenu item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_TargetURL();
public: __property void set_TargetURL(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the targetURL of WebSlidingMenu item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ TargetURL {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


TargetURLField Property

[image]
Intersoft WebEssentials Documentation
TargetURLField Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : TargetURLField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies data field for targetURL.")>
<System.ComponentModel.CategoryAttribute("BindingFields")>
Public Property TargetURLField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.TargetURLField = value

value = instance.TargetURLField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for targetURL.")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
public System.string TargetURLField {get; set;}
Delphi
public read-write property TargetURLField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies data field for targetURL.")
System.ComponentModel.CategoryAttribute("BindingFields")
public function get,set TargetURLField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for targetURL.")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
public: __property System.string* get_TargetURLField();
public: __property void set_TargetURLField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for targetURL.")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
public:
property System.String^ TargetURLField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


Text Property

[image]
Intersoft WebEssentials Documentation
Text Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("DefaultProperties")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the Text of WebSlidingMenu item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Text of WebSlidingMenu item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("DefaultProperties")
System.ComponentModel.DescriptionAttribute("Gets or sets the Text of WebSlidingMenu item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Text of WebSlidingMenu item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Text of WebSlidingMenu item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


TextField Property

[image]
Intersoft WebEssentials Documentation
TextField Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : TextField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("BindingFields")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for Text.")>
Public Property TextField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.TextField = value

value = instance.TextField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Text.")]
public System.string TextField {get; set;}
Delphi
public read-write property TextField: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("BindingFields")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.ComponentModel.DescriptionAttribute("Specifies data field for Text.")
public function get,set TextField : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Text.")]
public: __property System.string* get_TextField();
public: __property void set_TextField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Text.")]
public:
property System.String^ TextField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


ToolTip Property

[image]
Intersoft WebEssentials Documentation
ToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("DefaultProperties")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the Tooltip of WebSlidingMenu item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Tooltip of WebSlidingMenu item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("DefaultProperties")
System.ComponentModel.DescriptionAttribute("Gets or sets the Tooltip of WebSlidingMenu item.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Tooltip of WebSlidingMenu item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ToolTip();
public: __property void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the Tooltip of WebSlidingMenu item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


ToolTipField Property

[image]
Intersoft WebEssentials Documentation
ToolTipField Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : ToolTipField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies data field for Tooltip.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("BindingFields")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ToolTipField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.ToolTipField = value

value = instance.ToolTipField
C#
[System.ComponentModel.DescriptionAttribute("Specifies data field for Tooltip.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ToolTipField {get; set;}
Delphi
public read-write property ToolTipField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies data field for Tooltip.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("BindingFields")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ToolTipField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies data field for Tooltip.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ToolTipField();
public: __property void set_ToolTipField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies data field for Tooltip.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ToolTipField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


Value Property

[image]
Intersoft WebEssentials Documentation
Value Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : Value Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("DefaultProperties")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value of WebSlidingMenu item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Value As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.Value = value

value = instance.Value
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value of WebSlidingMenu item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Value {get; set;}
Delphi
public read-write property Value: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("DefaultProperties")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value of WebSlidingMenu item.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Value : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value of WebSlidingMenu item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Value();
public: __property void set_Value(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value of WebSlidingMenu item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Value {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


ValueField Property

[image]
Intersoft WebEssentials Documentation
ValueField Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : ValueField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies data field for Value.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.ComponentModel.CategoryAttribute("BindingFields")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ValueField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.ValueField = value

value = instance.ValueField
C#
[System.ComponentModel.DescriptionAttribute("Specifies data field for Value.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ValueField {get; set;}
Delphi
public read-write property ValueField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies data field for Value.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.ComponentModel.CategoryAttribute("BindingFields")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ValueField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies data field for Value.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ValueField();
public: __property void set_ValueField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies data field for Value.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ValueField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an WebSlidingMenu item is visible.")>
<System.ComponentModel.CategoryAttribute("DefaultProperties")>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an WebSlidingMenu item is visible.")]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an WebSlidingMenu item is visible.")
System.ComponentModel.CategoryAttribute("DefaultProperties")
public function get,set Visible : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an WebSlidingMenu item is visible.")]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an WebSlidingMenu item is visible.")]
[System.ComponentModel.CategoryAttribute("DefaultProperties")]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


VisibleField Property

[image]
Intersoft WebEssentials Documentation
VisibleField Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemBinding Class : VisibleField Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies data field for Visible.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("BindingFields")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property VisibleField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemBinding
Dim value As System.String

instance.VisibleField = value

value = instance.VisibleField
C#
[System.ComponentModel.DescriptionAttribute("Specifies data field for Visible.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string VisibleField {get; set;}
Delphi
public read-write property VisibleField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies data field for Visible.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("BindingFields")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set VisibleField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies data field for Visible.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_VisibleField();
public: __property void set_VisibleField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies data field for Visible.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("BindingFields")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ VisibleField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemBinding Class
WebSlidingMenuItemBinding Members


WebSlidingMenuItemCollection Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemCollection Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItemCollection Class

Glossary Item Box

The collection of WebSlidingMenuItem in WebSlidingMenu

Object Model

WebSlidingMenuItemCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.SerializableAttribute()>
Public Class WebSlidingMenuItemCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebSlidingMenuItem)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.SerializableAttribute()]
public class WebSlidingMenuItemCollection : ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuItem>
Delphi
public class WebSlidingMenuItemCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.SerializableAttribute()
public class WebSlidingMenuItemCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.SerializableAttribute()]
public __gc class WebSlidingMenuItemCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuItem>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.SerializableAttribute()]
public ref class WebSlidingMenuItemCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuItem>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebEssentials.WebSlidingMenuItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItemCollection Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemCollection Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItemCollection Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuItemCollection.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuItemCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuItem>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuItem>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSlidingMenuItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItemCollection Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemCollection Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuItem>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuItem>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSlidingMenuItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItemCollection Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemCollection Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSlidingMenuItemCollection Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuItemCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : WebSlidingMenuItemCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebSlidingMenuItemCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


WebSlidingMenuItemCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItemCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : WebSlidingMenuItemCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuItemCollection()
C#
public WebSlidingMenuItemCollection()
Delphi
public WebSlidingMenuItemCollection();
JScript
public function WebSlidingMenuItemCollection();
Managed Extensions for C++
public: WebSlidingMenuItemCollection();
C++/CLI
public:
WebSlidingMenuItemCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


Add Method

[image]
Intersoft WebEssentials Documentation
Add Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


Clear Method

[image]
Intersoft WebEssentials Documentation
Clear Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


Contains Method

[image]
Intersoft WebEssentials Documentation
Contains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


CopyTo Method

[image]
Intersoft WebEssentials Documentation
CopyTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


Count Property

[image]
Intersoft WebEssentials Documentation
Count Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


CreateNewItem Method

[image]
Intersoft WebEssentials Documentation
CreateNewItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebSlidingMenuItem
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim value As WebSlidingMenuItem

value = instance.CreateNewItem()
C#
public WebSlidingMenuItem CreateNewItem()
Delphi
public function CreateNewItem(): WebSlidingMenuItem;
JScript
public function CreateNewItem() : WebSlidingMenuItem;
Managed Extensions for C++
public: WebSlidingMenuItem* CreateNewItem();
C++/CLI
public:
WebSlidingMenuItem^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


GetEnumerator Method

[image]
Intersoft WebEssentials Documentation
GetEnumerator Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


GetNamedItem Method

[image]
Intersoft WebEssentials Documentation
GetNamedItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebSlidingMenuItem
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim name As System.String
Dim value As WebSlidingMenuItem

value = instance.GetNamedItem(name)
C#
public WebSlidingMenuItem GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebSlidingMenuItem;
JScript
public function GetNamedItem(
   name : System.String
) : WebSlidingMenuItem;
Managed Extensions for C++
public: WebSlidingMenuItem* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebSlidingMenuItem^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


IndexOf Method

[image]
Intersoft WebEssentials Documentation
IndexOf Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


Insert Method

[image]
Intersoft WebEssentials Documentation
Insert Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


Item Property

[image]
Intersoft WebEssentials Documentation
Item Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


Parent Property

[image]
Intersoft WebEssentials Documentation
Parent Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


Remove Method

[image]
Intersoft WebEssentials Documentation
Remove Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


RemoveAt Method

[image]
Intersoft WebEssentials Documentation
RemoveAt Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


SerializerConstructor Method

[image]
Intersoft WebEssentials Documentation
SerializerConstructor Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


SetParent Method

[image]
Intersoft WebEssentials Documentation
SetParent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItemCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItemCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItemCollection Class
WebSlidingMenuItemCollection Members


WebSlidingMenuItem Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItem Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : WebSlidingMenuItem Constructor

Glossary Item Box

Overload List

Overload | Description
WebSlidingMenuItem Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


WebSlidingMenuItem Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuItem Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : WebSlidingMenuItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuItem()
C#
public WebSlidingMenuItem()
Delphi
public WebSlidingMenuItem();
JScript
public function WebSlidingMenuItem();
Managed Extensions for C++
public: WebSlidingMenuItem();
C++/CLI
public:
WebSlidingMenuItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


AutoHeight Property

[image]
Intersoft WebEssentials Documentation
AutoHeight Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : AutoHeight Property

Glossary Item Box

Gets or sets the value that determines whether or not an item is auto height.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is auto height.")>
<System.ComponentModel.CategoryAttribute("Item Details")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AutoHeight As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.Boolean

instance.AutoHeight = value

value = instance.AutoHeight
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is auto height.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool AutoHeight {get; set;}
Delphi
public read-write property AutoHeight: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is auto height.")
System.ComponentModel.CategoryAttribute("Item Details")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AutoHeight : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is auto height.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_AutoHeight();
public: __property void set_AutoHeight(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is auto height.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool AutoHeight {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


ContentMode Property

[image]
Intersoft WebEssentials Documentation
ContentMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : ContentMode Property

Glossary Item Box

Specifies the container mode of WebSlidingMenu's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ContentMode As WebSlidingMenuContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As WebSlidingMenuContentMode

instance.ContentMode = value

value = instance.ContentMode
C#
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebSlidingMenuContentMode ContentMode {get; set;}
Delphi
public read-write property ContentMode: WebSlidingMenuContentMode;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ContentMode : WebSlidingMenuContentMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebSlidingMenuContentMode get_ContentMode();
public: __property void set_ContentMode(
   WebSlidingMenuContentMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebSlidingMenuContentMode ContentMode {
   WebSlidingMenuContentMode get();
   void set (    WebSlidingMenuContentMode value);
}

Property Value

The default value is Default.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


ContentURL Property

[image]
Intersoft WebEssentials Documentation
ContentURL Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : ContentURL Property

Glossary Item Box

Specifies the content url of of WebSlidingMenu's item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the content url of of WebSlidingMenu's item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ContentURL As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.String

instance.ContentURL = value

value = instance.ContentURL
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the content url of of WebSlidingMenu's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ContentURL {get; set;}
Delphi
public read-write property ContentURL: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the content url of of WebSlidingMenu's item.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ContentURL : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the content url of of WebSlidingMenu's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ContentURL();
public: __property void set_ContentURL(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the content url of of WebSlidingMenu's item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.UrlEditor, System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ContentURL {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members
Overload List


CustomRules Property

[image]
Intersoft WebEssentials Documentation
CustomRules Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : CustomRules Property

Glossary Item Box

Gets or sets the custom styles applied to item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the custom styles applied to item.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CustomRules As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.String

instance.CustomRules = value

value = instance.CustomRules
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the custom styles applied to item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string CustomRules {get; set;}
Delphi
public read-write property CustomRules: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the custom styles applied to item.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CustomRules : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the custom styles applied to item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_CustomRules();
public: __property void set_CustomRules(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the custom styles applied to item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ CustomRules {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : Enabled Property

Glossary Item Box

Gets or sets the value that determines whether or not an item is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is enabled.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Item Details")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is enabled.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


FindControl Method

[image]
Intersoft WebEssentials Documentation
FindControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : FindControl Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


GetLevelByItem Method

[image]
Intersoft WebEssentials Documentation
GetLevelByItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : GetLevelByItem Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLevelByItem( _
   ByVal item As WebSlidingMenuItem _
) As WebSlidingMenuLevel
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim item As WebSlidingMenuItem
Dim value As WebSlidingMenuLevel

value = instance.GetLevelByItem(item)
C#
public WebSlidingMenuLevel GetLevelByItem(
   WebSlidingMenuItem item
)
Delphi
public function GetLevelByItem(
    item: WebSlidingMenuItem
): WebSlidingMenuLevel;
JScript
public function GetLevelByItem(
   item : WebSlidingMenuItem
) : WebSlidingMenuLevel;
Managed Extensions for C++
public: WebSlidingMenuLevel* GetLevelByItem(
   WebSlidingMenuItem* item
)
C++/CLI
public:
WebSlidingMenuLevel^ GetLevelByItem(
   WebSlidingMenuItem^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


ItemHeight Property

[image]
Intersoft WebEssentials Documentation
ItemHeight Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : ItemHeight Property

Glossary Item Box

Gets or sets the item's height.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the item's height.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ItemHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.Integer

instance.ItemHeight = value

value = instance.ItemHeight
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the item's height.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int ItemHeight {get; set;}
Delphi
public read-write property ItemHeight: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the item's height.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ItemHeight : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the item's height.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_ItemHeight();
public: __property void set_ItemHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the item's height.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int ItemHeight {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


Items Property

[image]
Intersoft WebEssentials Documentation
Items Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : Items Property

Glossary Item Box

The item collection of WebSlidingMenuItem

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The item collection of WebSlidingMenuItem.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setItems")>
Public ReadOnly Property Items As WebSlidingMenuItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As WebSlidingMenuItemCollection

value = instance.Items
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The item collection of WebSlidingMenuItem.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
public WebSlidingMenuItemCollection Items {get;}
Delphi
public read-only property Items: WebSlidingMenuItemCollection;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The item collection of WebSlidingMenuItem.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setItems")
public function get Items : WebSlidingMenuItemCollection
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The item collection of WebSlidingMenuItem.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
public: __property WebSlidingMenuItemCollection* get_Items();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The item collection of WebSlidingMenuItem.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
public:
property WebSlidingMenuItemCollection^ Items {
   WebSlidingMenuItemCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


Name Property

[image]
Intersoft WebEssentials Documentation
Name Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : Name Property

Glossary Item Box

Specifies the name of the item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")>
<System.ComponentModel.CategoryAttribute("Item Details")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")
System.ComponentModel.CategoryAttribute("Item Details")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BrowsableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public override function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the item.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


Parent Property

[image]
Intersoft WebEssentials Documentation
Parent Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : Parent Property

Glossary Item Box

Gets the WebSlidingMenu object that own this Menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenu object that own this Menu.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(True)>
Public Property Parent As WebSlidingMenu
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As WebSlidingMenu

instance.Parent = value

value = instance.Parent
C#
[System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenu object that own this Menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(true)]
public WebSlidingMenu Parent {get; set;}
Delphi
public read-write property Parent: WebSlidingMenu;
JScript
System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenu object that own this Menu.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Parent : WebSlidingMenu
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenu object that own this Menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(true)]
public: __property WebSlidingMenu* get_Parent();
public: __property void set_Parent(
   WebSlidingMenu* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenu object that own this Menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(true)]
public:
property WebSlidingMenu^ Parent {
   WebSlidingMenu^ get();
   void set (    WebSlidingMenu^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


ParentMenu Property

[image]
Intersoft WebEssentials Documentation
ParentMenu Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : ParentMenu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenuItem object parent of this menu.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BrowsableAttribute(True)>
Public ReadOnly Property ParentMenu As WebSlidingMenuItem
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As WebSlidingMenuItem

value = instance.ParentMenu
C#
[System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenuItem object parent of this menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
public WebSlidingMenuItem ParentMenu {get;}
Delphi
public read-only property ParentMenu: WebSlidingMenuItem;
JScript
System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenuItem object parent of this menu.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BrowsableAttribute()
public function get ParentMenu : WebSlidingMenuItem
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenuItem object parent of this menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
public: __property WebSlidingMenuItem* get_ParentMenu();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenuItem object parent of this menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
public:
property WebSlidingMenuItem^ ParentMenu {
   WebSlidingMenuItem^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


Tag Property

[image]
Intersoft WebEssentials Documentation
Tag Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : Tag Property

Glossary Item Box

Gets or sets tag of an item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.DescriptionAttribute("Gets or sets tag of an item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Tag As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.String

instance.Tag = value

value = instance.Tag
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets tag of an item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Tag {get; set;}
Delphi
public read-write property Tag: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.DescriptionAttribute("Gets or sets tag of an item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Tag : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets tag of an item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Tag();
public: __property void set_Tag(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets tag of an item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Tag {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


TargetURL Property

[image]
Intersoft WebEssentials Documentation
TargetURL Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : TargetURL Property

Glossary Item Box

Gets or sets the target url when item is selected.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the target url when item is selected.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property TargetURL As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.String

instance.TargetURL = value

value = instance.TargetURL
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the target url when item is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string TargetURL {get; set;}
Delphi
public read-write property TargetURL: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the target url when item is selected.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set TargetURL : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the target url when item is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_TargetURL();
public: __property void set_TargetURL(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the target url when item is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ TargetURL {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


TargetWindow Property

[image]
Intersoft WebEssentials Documentation
TargetWindow Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : TargetWindow Property

Glossary Item Box

Gets or sets the target window when item is selected.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Item Details")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the target window when item is selected.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TargetWindow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.String

instance.TargetWindow = value

value = instance.TargetWindow
C#
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the target window when item is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TargetWindow {get; set;}
Delphi
public read-write property TargetWindow: System.String;
JScript
System.ComponentModel.CategoryAttribute("Item Details")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the target window when item is selected.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TargetWindow : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the target window when item is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TargetWindow();
public: __property void set_TargetWindow(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the target window when item is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TargetWindow {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


Text Property

[image]
Intersoft WebEssentials Documentation
Text Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : Text Property

Glossary Item Box

Gets or sets the item's text.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the item's text.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the item's text.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.DescriptionAttribute("Gets or sets the item's text.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the item's text.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the item's text.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


ToolTip Property

[image]
Intersoft WebEssentials Documentation
ToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : ToolTip Property

Glossary Item Box

Gets or sets the tooltip of item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")>
<System.ComponentModel.CategoryAttribute("Item Details")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")
System.ComponentModel.CategoryAttribute("Item Details")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ToolTip();
public: __property void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip of item.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


Value Property

[image]
Intersoft WebEssentials Documentation
Value Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : Value Property

Glossary Item Box

Gets or sets the item's value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Item Details")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the item's value.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Value As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.String

instance.Value = value

value = instance.Value
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the item's value.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Value {get; set;}
Delphi
public read-write property Value: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
System.ComponentModel.DescriptionAttribute("Gets or sets the item's value.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Value : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the item's value.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Value();
public: __property void set_Value(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Item Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the item's value.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Value {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuItem Class : Visible Property

Glossary Item Box

Gets or sets the value that determines whether or not an item is visible.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is visible.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Item Details")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuItem
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is visible.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is visible.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Item Details")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is visible.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not an item is visible.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Item Details")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuItem Class
WebSlidingMenuItem Members


WebSlidingMenuLayoutSettings Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLayoutSettings Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuLayoutSettings Class

Glossary Item Box

A collection of WebSlidingMenu layout settings.

Object Model

WebSlidingMenuLayoutSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSlidingMenuLayoutSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSlidingMenuLayoutSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSlidingMenuLayoutSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSlidingMenuLayoutSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSlidingMenuLayoutSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSlidingMenuLayoutSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebSlidingMenuLayoutSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuLayoutSettings Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLayoutSettings Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuLayoutSettings Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuLayoutSettings.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuLayoutSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | HeaderHeight | Gets or sets the value that determines the height of header.
Public Property | ItemHeight | Gets or sets the value that determines the height of an item.
Public Property | ShowLoader | Gets or sets the value that determines whether loader is displayed.
Public Property | ShowNextIndicator | Gets or sets the value that determines whether show next indicator is displayed.
Public Property | ShowPreviousIndicator | Gets or sets the value that determines whether PreviousIndicator is displayed.
Public Property | TargetWindow | Gets or sets the value that determines the global target window when items are clicked.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSlidingMenuLayoutSettings Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuLayoutSettings Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLayoutSettings Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuLayoutSettings Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuLayoutSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSlidingMenuLayoutSettings Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuLayoutSettings Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLayoutSettings Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuLayoutSettings Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuLayoutSettings members.

Public Properties

 | Name | Description
Public Property | HeaderHeight | Gets or sets the value that determines the height of header.
Public Property | ItemHeight | Gets or sets the value that determines the height of an item.
Public Property | ShowLoader | Gets or sets the value that determines whether loader is displayed.
Public Property | ShowNextIndicator | Gets or sets the value that determines whether show next indicator is displayed.
Public Property | ShowPreviousIndicator | Gets or sets the value that determines whether PreviousIndicator is displayed.
Public Property | TargetWindow | Gets or sets the value that determines the global target window when items are clicked.
Top

See Also

Reference

WebSlidingMenuLayoutSettings Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuLayoutSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLayoutSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : WebSlidingMenuLayoutSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebSlidingMenuLayoutSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


WebSlidingMenuLayoutSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLayoutSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : WebSlidingMenuLayoutSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuLayoutSettings()
C#
public WebSlidingMenuLayoutSettings()
Delphi
public WebSlidingMenuLayoutSettings();
JScript
public function WebSlidingMenuLayoutSettings();
Managed Extensions for C++
public: WebSlidingMenuLayoutSettings();
C++/CLI
public:
WebSlidingMenuLayoutSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


HeaderHeight Property

[image]
Intersoft WebEssentials Documentation
HeaderHeight Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : HeaderHeight Property

Glossary Item Box

Gets or sets the value that determines the height of header.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of header.")>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property HeaderHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim value As System.Integer

instance.HeaderHeight = value

value = instance.HeaderHeight
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of header.")]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int HeaderHeight {get; set;}
Delphi
public read-write property HeaderHeight: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of header.")
System.ComponentModel.CategoryAttribute("Layout Settings")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set HeaderHeight : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of header.")]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_HeaderHeight();
public: __property void set_HeaderHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of header.")]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int HeaderHeight {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 20.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


ItemHeight Property

[image]
Intersoft WebEssentials Documentation
ItemHeight Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : ItemHeight Property

Glossary Item Box

Gets or sets the value that determines the height of an item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of an item.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ItemHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim value As System.Integer

instance.ItemHeight = value

value = instance.ItemHeight
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of an item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int ItemHeight {get; set;}
Delphi
public read-write property ItemHeight: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Layout Settings")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of an item.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ItemHeight : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of an item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_ItemHeight();
public: __property void set_ItemHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the height of an item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int ItemHeight {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 20.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


ShowLoader Property

[image]
Intersoft WebEssentials Documentation
ShowLoader Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : ShowLoader Property

Glossary Item Box

Gets or sets the value that determines whether loader is displayed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether loader is displayed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ShowLoader As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim value As System.Boolean

instance.ShowLoader = value

value = instance.ShowLoader
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether loader is displayed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool ShowLoader {get; set;}
Delphi
public read-write property ShowLoader: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Layout Settings")
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether loader is displayed.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ShowLoader : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether loader is displayed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_ShowLoader();
public: __property void set_ShowLoader(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether loader is displayed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool ShowLoader {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


ShowNextIndicator Property

[image]
Intersoft WebEssentials Documentation
ShowNextIndicator Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : ShowNextIndicator Property

Glossary Item Box

Gets or sets the value that determines whether show next indicator is displayed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether show next indicator is displayed.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ShowNextIndicator As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim value As System.Boolean

instance.ShowNextIndicator = value

value = instance.ShowNextIndicator
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether show next indicator is displayed.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool ShowNextIndicator {get; set;}
Delphi
public read-write property ShowNextIndicator: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Layout Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether show next indicator is displayed.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ShowNextIndicator : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether show next indicator is displayed.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_ShowNextIndicator();
public: __property void set_ShowNextIndicator(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether show next indicator is displayed.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool ShowNextIndicator {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


ShowPreviousIndicator Property

[image]
Intersoft WebEssentials Documentation
ShowPreviousIndicator Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : ShowPreviousIndicator Property

Glossary Item Box

Gets or sets the value that determines whether PreviousIndicator is displayed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether PreviousIndicator is displayed.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ShowPreviousIndicator As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim value As System.Boolean

instance.ShowPreviousIndicator = value

value = instance.ShowPreviousIndicator
C#
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether PreviousIndicator is displayed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool ShowPreviousIndicator {get; set;}
Delphi
public read-write property ShowPreviousIndicator: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Layout Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether PreviousIndicator is displayed.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ShowPreviousIndicator : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether PreviousIndicator is displayed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_ShowPreviousIndicator();
public: __property void set_ShowPreviousIndicator(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether PreviousIndicator is displayed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool ShowPreviousIndicator {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


TargetWindow Property

[image]
Intersoft WebEssentials Documentation
TargetWindow Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : TargetWindow Property

Glossary Item Box

Gets or sets the value that determines the global target window when items are clicked.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the global target window when items are clicked.")>
<System.ComponentModel.CategoryAttribute("Layout Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TargetWindow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim value As System.String

instance.TargetWindow = value

value = instance.TargetWindow
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the global target window when items are clicked.")]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string TargetWindow {get; set;}
Delphi
public read-write property TargetWindow: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the global target window when items are clicked.")
System.ComponentModel.CategoryAttribute("Layout Settings")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TargetWindow : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the global target window when items are clicked.")]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_TargetWindow();
public: __property void set_TargetWindow(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the global target window when items are clicked.")]
[System.ComponentModel.CategoryAttribute("Layout Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ TargetWindow {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is "".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLayoutSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLayoutSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLayoutSettings Class
WebSlidingMenuLayoutSettings Members


WebSlidingMenuLevel Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLevel Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuLevel Class

Glossary Item Box

WebListBoxLevel object of WebListBox.

Object Model

WebSlidingMenuLevel Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSlidingMenuLevel
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSlidingMenuLevel : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebSlidingMenuLevel = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSlidingMenuLevel extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSlidingMenuLevel : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSlidingMenuLevel : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebEssentials.WebSlidingMenuLevel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuLevel Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLevel Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuLevel Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuLevel.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuLevel Constructor |
Top

Public Properties

 | Name | Description
Public Property | AutoHeight |
Public Property | EnableDynamicStyle | Gets or sets the value that determines whether or not a level use dynamic style or not.
Public Property | HeaderContentMode | Specifies the container mode of WebSlidingMenu's header.
Public Property | HeaderHeight | Gets or sets the header's height.
Public Property | HeaderText | Gets or sets the header's text.
Public Property | HeaderToolTip | Gets or sets the header's tooltip.
Public Property | ItemContentMode | Specifies the container mode of WebSlidingMenu's items.
Public Property | Level | Gets or sets the header's level.
Public Property | Name | Overridden. Specifies the name of the header.
Public Property | Parent | Gets the WebSlidingMenu object that own this Menu.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSlidingMenuLevel Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuLevel Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLevel Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuLevel Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuLevel members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSlidingMenuLevel Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuLevel Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLevel Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuLevel Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuLevel members.

Public Properties

 | Name | Description
Public Property | AutoHeight |
Public Property | EnableDynamicStyle | Gets or sets the value that determines whether or not a level use dynamic style or not.
Public Property | HeaderContentMode | Specifies the container mode of WebSlidingMenu's header.
Public Property | HeaderHeight | Gets or sets the header's height.
Public Property | HeaderText | Gets or sets the header's text.
Public Property | HeaderToolTip | Gets or sets the header's tooltip.
Public Property | ItemContentMode | Specifies the container mode of WebSlidingMenu's items.
Public Property | Level | Gets or sets the header's level.
Public Property | Name | Overridden. Specifies the name of the header.
Public Property | Parent | Gets the WebSlidingMenu object that own this Menu.
Top

See Also

Reference

WebSlidingMenuLevel Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuLevelCollection Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLevelCollection Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuLevelCollection Class

Glossary Item Box

The collection of WebSlidingMenuLevel in WebSlidingMenu

Object Model

WebSlidingMenuLevelCollection Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSlidingMenuLevelCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebSlidingMenuLevel)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSlidingMenuLevelCollection : ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuLevel>
Delphi
public class WebSlidingMenuLevelCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSlidingMenuLevelCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSlidingMenuLevelCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuLevel>
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSlidingMenuLevelCollection : public ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuLevel>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebEssentials.WebSlidingMenuLevelCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuLevelCollection Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLevelCollection Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuLevelCollection Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuLevelCollection.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuLevelCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuLevel>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuLevel>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuLevel>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSlidingMenuLevelCollection Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuLevelCollection Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLevelCollection Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuLevelCollection Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuLevelCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuLevel>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuLevel>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebSlidingMenuLevel>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSlidingMenuLevelCollection Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuLevelCollection Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLevelCollection Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuLevelCollection Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuLevelCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

See Also

Reference

WebSlidingMenuLevelCollection Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuLevelCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLevelCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : WebSlidingMenuLevelCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebSlidingMenuLevelCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


WebSlidingMenuLevelCollection Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLevelCollection Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : WebSlidingMenuLevelCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuLevelCollection()
C#
public WebSlidingMenuLevelCollection()
Delphi
public WebSlidingMenuLevelCollection();
JScript
public function WebSlidingMenuLevelCollection();
Managed Extensions for C++
public: WebSlidingMenuLevelCollection();
C++/CLI
public:
WebSlidingMenuLevelCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


Add Method

[image]
Intersoft WebEssentials Documentation
Add Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


Clear Method

[image]
Intersoft WebEssentials Documentation
Clear Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


Contains Method

[image]
Intersoft WebEssentials Documentation
Contains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


CopyTo Method

[image]
Intersoft WebEssentials Documentation
CopyTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


Count Property

[image]
Intersoft WebEssentials Documentation
Count Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


CreateNewItem Method

[image]
Intersoft WebEssentials Documentation
CreateNewItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebSlidingMenuLevel
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim value As WebSlidingMenuLevel

value = instance.CreateNewItem()
C#
public WebSlidingMenuLevel CreateNewItem()
Delphi
public function CreateNewItem(): WebSlidingMenuLevel;
JScript
public function CreateNewItem() : WebSlidingMenuLevel;
Managed Extensions for C++
public: WebSlidingMenuLevel* CreateNewItem();
C++/CLI
public:
WebSlidingMenuLevel^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


GetEnumerator Method

[image]
Intersoft WebEssentials Documentation
GetEnumerator Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


GetNamedItem Method

[image]
Intersoft WebEssentials Documentation
GetNamedItem Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebSlidingMenuLevel
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim name As System.String
Dim value As WebSlidingMenuLevel

value = instance.GetNamedItem(name)
C#
public WebSlidingMenuLevel GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebSlidingMenuLevel;
JScript
public function GetNamedItem(
   name : System.String
) : WebSlidingMenuLevel;
Managed Extensions for C++
public: WebSlidingMenuLevel* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebSlidingMenuLevel^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


IndexOf Method

[image]
Intersoft WebEssentials Documentation
IndexOf Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


Insert Method

[image]
Intersoft WebEssentials Documentation
Insert Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


Item Property

[image]
Intersoft WebEssentials Documentation
Item Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


Parent Property

[image]
Intersoft WebEssentials Documentation
Parent Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


Remove Method

[image]
Intersoft WebEssentials Documentation
Remove Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


RemoveAt Method

[image]
Intersoft WebEssentials Documentation
RemoveAt Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


SerializerConstructor Method

[image]
Intersoft WebEssentials Documentation
SerializerConstructor Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


SetParent Method

[image]
Intersoft WebEssentials Documentation
SetParent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevelCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevelCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevelCollection Class
WebSlidingMenuLevelCollection Members


WebSlidingMenuLevel Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLevel Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : WebSlidingMenuLevel Constructor

Glossary Item Box

Overload List

Overload | Description
WebSlidingMenuLevel Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


WebSlidingMenuLevel Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuLevel Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : WebSlidingMenuLevel Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuLevel()
C#
public WebSlidingMenuLevel()
Delphi
public WebSlidingMenuLevel();
JScript
public function WebSlidingMenuLevel();
Managed Extensions for C++
public: WebSlidingMenuLevel();
C++/CLI
public:
WebSlidingMenuLevel();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


AutoHeight Property

[image]
Intersoft WebEssentials Documentation
AutoHeight Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : AutoHeight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not all item in the level use auto height.")>
<System.ComponentModel.CategoryAttribute("Item Details")>
Public Property AutoHeight As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim value As System.Boolean

instance.AutoHeight = value

value = instance.AutoHeight
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not all item in the level use auto height.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
public System.bool AutoHeight {get; set;}
Delphi
public read-write property AutoHeight: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not all item in the level use auto height.")
System.ComponentModel.CategoryAttribute("Item Details")
public function get,set AutoHeight : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not all item in the level use auto height.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
public: __property System.bool get_AutoHeight();
public: __property void set_AutoHeight(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not all item in the level use auto height.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
public:
property System.bool AutoHeight {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


EnableDynamicStyle Property

[image]
Intersoft WebEssentials Documentation
EnableDynamicStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : EnableDynamicStyle Property

Glossary Item Box

Gets or sets the value that determines whether or not a level use dynamic style or not.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not a level use dynamic style or not.")>
<System.ComponentModel.CategoryAttribute("Item Details")>
Public Property EnableDynamicStyle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim value As System.Boolean

instance.EnableDynamicStyle = value

value = instance.EnableDynamicStyle
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not a level use dynamic style or not.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
public System.bool EnableDynamicStyle {get; set;}
Delphi
public read-write property EnableDynamicStyle: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not a level use dynamic style or not.")
System.ComponentModel.CategoryAttribute("Item Details")
public function get,set EnableDynamicStyle : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not a level use dynamic style or not.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
public: __property System.bool get_EnableDynamicStyle();
public: __property void set_EnableDynamicStyle(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not a level use dynamic style or not.")]
[System.ComponentModel.CategoryAttribute("Item Details")]
public:
property System.bool EnableDynamicStyle {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


HeaderContentMode Property

[image]
Intersoft WebEssentials Documentation
HeaderContentMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : HeaderContentMode Property

Glossary Item Box

Specifies the container mode of WebSlidingMenu's header.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's header.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HeaderContentMode As WebSlidingMenuHeaderContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim value As WebSlidingMenuHeaderContentMode

instance.HeaderContentMode = value

value = instance.HeaderContentMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's header.")]
[System.ComponentModel.DefaultValueAttribute()]
public WebSlidingMenuHeaderContentMode HeaderContentMode {get; set;}
Delphi
public read-write property HeaderContentMode: WebSlidingMenuHeaderContentMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's header.")
System.ComponentModel.DefaultValueAttribute()
public function get,set HeaderContentMode : WebSlidingMenuHeaderContentMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's header.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebSlidingMenuHeaderContentMode get_HeaderContentMode();
public: __property void set_HeaderContentMode(
   WebSlidingMenuHeaderContentMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's header.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebSlidingMenuHeaderContentMode HeaderContentMode {
   WebSlidingMenuHeaderContentMode get();
   void set (    WebSlidingMenuHeaderContentMode value);
}

Property Value

The default value is Text.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


HeaderHeight Property

[image]
Intersoft WebEssentials Documentation
HeaderHeight Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : HeaderHeight Property

Glossary Item Box

Gets or sets the header's height.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the header's height.")>
<System.ComponentModel.CategoryAttribute("Header Details")>
Public Property HeaderHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim value As System.Integer

instance.HeaderHeight = value

value = instance.HeaderHeight
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the header's height.")]
[System.ComponentModel.CategoryAttribute("Header Details")]
public System.int HeaderHeight {get; set;}
Delphi
public read-write property HeaderHeight: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the header's height.")
System.ComponentModel.CategoryAttribute("Header Details")
public function get,set HeaderHeight : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the header's height.")]
[System.ComponentModel.CategoryAttribute("Header Details")]
public: __property System.int get_HeaderHeight();
public: __property void set_HeaderHeight(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the header's height.")]
[System.ComponentModel.CategoryAttribute("Header Details")]
public:
property System.int HeaderHeight {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


HeaderText Property

[image]
Intersoft WebEssentials Documentation
HeaderText Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : HeaderText Property

Glossary Item Box

Gets or sets the header's text.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Header Details")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the header's text.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HeaderText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim value As System.String

instance.HeaderText = value

value = instance.HeaderText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Header Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the header's text.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string HeaderText {get; set;}
Delphi
public read-write property HeaderText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Header Details")
System.ComponentModel.DescriptionAttribute("Gets or sets the header's text.")
System.ComponentModel.DefaultValueAttribute()
public function get,set HeaderText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Header Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the header's text.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_HeaderText();
public: __property void set_HeaderText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Header Details")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the header's text.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ HeaderText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


HeaderToolTip Property

[image]
Intersoft WebEssentials Documentation
HeaderToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : HeaderToolTip Property

Glossary Item Box

Gets or sets the header's tooltip.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the header's tooltip.")>
<System.ComponentModel.CategoryAttribute("Header Details")>
Public Property HeaderToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim value As System.String

instance.HeaderToolTip = value

value = instance.HeaderToolTip
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the header's tooltip.")]
[System.ComponentModel.CategoryAttribute("Header Details")]
public System.string HeaderToolTip {get; set;}
Delphi
public read-write property HeaderToolTip: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the header's tooltip.")
System.ComponentModel.CategoryAttribute("Header Details")
public function get,set HeaderToolTip : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the header's tooltip.")]
[System.ComponentModel.CategoryAttribute("Header Details")]
public: __property System.string* get_HeaderToolTip();
public: __property void set_HeaderToolTip(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the header's tooltip.")]
[System.ComponentModel.CategoryAttribute("Header Details")]
public:
property System.String^ HeaderToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


ItemContentMode Property

[image]
Intersoft WebEssentials Documentation
ItemContentMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : ItemContentMode Property

Glossary Item Box

Specifies the container mode of WebSlidingMenu's items.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's items.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property ItemContentMode As WebSlidingMenuContentMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim value As WebSlidingMenuContentMode

instance.ItemContentMode = value

value = instance.ItemContentMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's items.")]
[System.ComponentModel.CategoryAttribute("General")]
public WebSlidingMenuContentMode ItemContentMode {get; set;}
Delphi
public read-write property ItemContentMode: WebSlidingMenuContentMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's items.")
System.ComponentModel.CategoryAttribute("General")
public function get,set ItemContentMode : WebSlidingMenuContentMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's items.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property WebSlidingMenuContentMode get_ItemContentMode();
public: __property void set_ItemContentMode(
   WebSlidingMenuContentMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the container mode of WebSlidingMenu's items.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property WebSlidingMenuContentMode ItemContentMode {
   WebSlidingMenuContentMode get();
   void set (    WebSlidingMenuContentMode value);
}

Property Value

The default value is UseItems.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


Level Property

[image]
Intersoft WebEssentials Documentation
Level Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : Level Property

Glossary Item Box

Gets or sets the header's level.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the header's level.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Header Details")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Level As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim value As System.Integer

instance.Level = value

value = instance.Level
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the header's level.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Header Details")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int Level {get; set;}
Delphi
public read-write property Level: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the header's level.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Header Details")
System.ComponentModel.DefaultValueAttribute()
public function get,set Level : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the header's level.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Header Details")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_Level();
public: __property void set_Level(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the header's level.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Header Details")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int Level {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


Name Property

[image]
Intersoft WebEssentials Documentation
Name Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : Name Property

Glossary Item Box

Specifies the name of the header.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the name of the Header.")>
<System.ComponentModel.CategoryAttribute("Header Details")>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the Header.")]
[System.ComponentModel.CategoryAttribute("Header Details")]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the name of the Header.")
System.ComponentModel.CategoryAttribute("Header Details")
public override function get,set Name : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the Header.")]
[System.ComponentModel.CategoryAttribute("Header Details")]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the Header.")]
[System.ComponentModel.CategoryAttribute("Header Details")]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


Parent Property

[image]
Intersoft WebEssentials Documentation
Parent Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : Parent Property

Glossary Item Box

Gets the WebSlidingMenu object that own this Menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenu object that own this Level.")>
<System.ComponentModel.CategoryAttribute("Header Details")>
Public Property Parent As WebSlidingMenu
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim value As WebSlidingMenu

instance.Parent = value

value = instance.Parent
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenu object that own this Level.")]
[System.ComponentModel.CategoryAttribute("Header Details")]
public WebSlidingMenu Parent {get; set;}
Delphi
public read-write property Parent: WebSlidingMenu;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenu object that own this Level.")
System.ComponentModel.CategoryAttribute("Header Details")
public function get,set Parent : WebSlidingMenu
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenu object that own this Level.")]
[System.ComponentModel.CategoryAttribute("Header Details")]
public: __property WebSlidingMenu* get_Parent();
public: __property void set_Parent(
   WebSlidingMenu* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets the WebSlidingMenu object that own this Level.")]
[System.ComponentModel.CategoryAttribute("Header Details")]
public:
property WebSlidingMenu^ Parent {
   WebSlidingMenu^ get();
   void set (    WebSlidingMenu^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuLevel Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuLevel
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuLevel Class
WebSlidingMenuLevel Members


WebSlidingMenuPresets Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuPresets Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuPresets Class

Glossary Item Box

Object Model

WebSlidingMenuPresets Class

Syntax

Visual Basic (Declaration)
Public Class WebSlidingMenuPresets
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuPresets
C#
public class WebSlidingMenuPresets
Delphi
public class WebSlidingMenuPresets
JScript
public class WebSlidingMenuPresets
Managed Extensions for C++
public __gc class WebSlidingMenuPresets
C++/CLI
public ref class WebSlidingMenuPresets

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebEssentials.WebSlidingMenuPresets

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuPresets Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuPresets Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuPresets Class Members
See Also Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuPresets Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuPresets.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuPresets Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

WebSlidingMenuPresets Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuPresets Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuPresets Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuPresets Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuPresets members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

WebSlidingMenuPresets Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuPresets Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuPresets Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuPresets Class : WebSlidingMenuPresets Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuPresets()
C#
public WebSlidingMenuPresets()
Delphi
public WebSlidingMenuPresets();
JScript
public function WebSlidingMenuPresets();
Managed Extensions for C++
public: WebSlidingMenuPresets();
C++/CLI
public:
WebSlidingMenuPresets();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuPresets Class
WebSlidingMenuPresets Members


GetDefaultStyle Method

[image]
Intersoft WebEssentials Documentation
GetDefaultStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuPresets Class : GetDefaultStyle Method

mode
styleName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetDefaultStyle( _
   ByVal mode As WebSlidingMenuDefaultStyleMode, _
   ByVal styleName As System.String _
) As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim mode As WebSlidingMenuDefaultStyleMode
Dim styleName As System.String
Dim value As ISNet.WebUI.WebStyle

value = WebSlidingMenuPresets.GetDefaultStyle(mode, styleName)
C#
public static ISNet.WebUI.WebStyle GetDefaultStyle(
   WebSlidingMenuDefaultStyleMode mode,
   System.string styleName
)
Delphi
public function GetDefaultStyle(
    mode: WebSlidingMenuDefaultStyleMode;
    styleName: System.String
): ISNet.WebUI.WebStyle; static;
JScript
public static function GetDefaultStyle(
   mode : WebSlidingMenuDefaultStyleMode,
   styleName : System.String
) : ISNet.WebUI.WebStyle;
Managed Extensions for C++
public: static ISNet.WebUI.WebStyle* GetDefaultStyle(
   WebSlidingMenuDefaultStyleMode mode,
   System.string* styleName
)
C++/CLI
public:
static ISNet.WebUI.WebStyle^ GetDefaultStyle(
   WebSlidingMenuDefaultStyleMode mode,
   System.String^ styleName
)

Parameters

mode
styleName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuPresets Class
WebSlidingMenuPresets Members


WebSlidingMenuTextSettings Class

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuTextSettings Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuTextSettings Class

Glossary Item Box

Object Model

WebSlidingMenuTextSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSlidingMenuTextSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuTextSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSlidingMenuTextSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSlidingMenuTextSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSlidingMenuTextSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSlidingMenuTextSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSlidingMenuTextSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebEssentials.WebSlidingMenuTextSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Members
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuTextSettings Class Members

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuTextSettings Class Members
See Also Properties Methods Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuTextSettings Class

Glossary Item Box

The following tables list the members exposed by WebSlidingMenuTextSettings.

Public Constructors

 | Name | Description
Public Constructor | WebSlidingMenuTextSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | PreviousButtonToolTip | Specifies the text of Previous button tool tip.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSlidingMenuTextSettings Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuTextSettings Class Methods

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuTextSettings Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuTextSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSlidingMenuTextSettings Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuTextSettings Class Properties

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuTextSettings Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebSlidingMenuTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebSlidingMenuTextSettings members.

Public Properties

 | Name | Description
Public Property | PreviousButtonToolTip | Specifies the text of Previous button tool tip.
Top

See Also

Reference

WebSlidingMenuTextSettings Class
ISNet.WebUI.WebEssentials Namespace


WebSlidingMenuTextSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuTextSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuTextSettings Class : WebSlidingMenuTextSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebSlidingMenuTextSettings Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Class
WebSlidingMenuTextSettings Members


WebSlidingMenuTextSettings Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenuTextSettings Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuTextSettings Class : WebSlidingMenuTextSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenuTextSettings()
C#
public WebSlidingMenuTextSettings()
Delphi
public WebSlidingMenuTextSettings();
JScript
public function WebSlidingMenuTextSettings();
Managed Extensions for C++
public: WebSlidingMenuTextSettings();
C++/CLI
public:
WebSlidingMenuTextSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Class
WebSlidingMenuTextSettings Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuTextSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuTextSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Class
WebSlidingMenuTextSettings Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuTextSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Class
WebSlidingMenuTextSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuTextSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuTextSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Class
WebSlidingMenuTextSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuTextSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuTextSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Class
WebSlidingMenuTextSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuTextSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuTextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Class
WebSlidingMenuTextSettings Members


GetHashCode Method

[image]
Intersoft WebEssentials Documentation
GetHashCode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuTextSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuTextSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Class
WebSlidingMenuTextSettings Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuTextSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuTextSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Class
WebSlidingMenuTextSettings Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuTextSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuTextSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Class
WebSlidingMenuTextSettings Members


PreviousButtonToolTip Property

[image]
Intersoft WebEssentials Documentation
PreviousButtonToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuTextSettings Class : PreviousButtonToolTip Property

Glossary Item Box

Specifies the text of Previous button tool tip.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Previous button tool tip.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PreviousButtonToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuTextSettings
Dim value As System.String

instance.PreviousButtonToolTip = value

value = instance.PreviousButtonToolTip
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Previous button tool tip.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string PreviousButtonToolTip {get; set;}
Delphi
public read-write property PreviousButtonToolTip: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text Settings")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Previous button tool tip.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PreviousButtonToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Previous button tool tip.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_PreviousButtonToolTip();
public: __property void set_PreviousButtonToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Previous button tool tip.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ PreviousButtonToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Back to {0}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Class
WebSlidingMenuTextSettings Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuTextSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuTextSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Class
WebSlidingMenuTextSettings Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuTextSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuTextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Class
WebSlidingMenuTextSettings Members


ToString Method

[image]
Intersoft WebEssentials Documentation
ToString Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenuTextSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenuTextSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenuTextSettings Class
WebSlidingMenuTextSettings Members


WebSlidingMenu Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenu Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : WebSlidingMenu Constructor

Glossary Item Box

Overload List

Overload | Description
WebSlidingMenu Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


WebSlidingMenu Constructor

[image]
Intersoft WebEssentials Documentation
WebSlidingMenu Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : WebSlidingMenu Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSlidingMenu()
C#
public WebSlidingMenu()
Delphi
public WebSlidingMenu();
JScript
public function WebSlidingMenu();
Managed Extensions for C++
public: WebSlidingMenu();
C++/CLI
public:
WebSlidingMenu();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


AccessKey Property

[image]
Intersoft WebEssentials Documentation
AccessKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set AccessKey : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


AllowDefaultStyleMerging Property

[image]
Intersoft WebEssentials Documentation
AllowDefaultStyleMerging Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : AllowDefaultStyleMerging Property

Glossary Item Box

Gets or sets the value that determines whether or not the default style can be merged with custom styles.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AllowDefaultStyleMerging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

instance.AllowDefaultStyleMerging = value

value = instance.AllowDefaultStyleMerging
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool AllowDefaultStyleMerging {get; set;}
Delphi
public read-write property AllowDefaultStyleMerging: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AllowDefaultStyleMerging : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_AllowDefaultStyleMerging();
public: __property void set_AllowDefaultStyleMerging(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool AllowDefaultStyleMerging {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


AlternateItemStyle Property

[image]
Intersoft WebEssentials Documentation
AlternateItemStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : AlternateItemStyle Property

Glossary Item Box

Contains interactive style for alternate item style.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for alternate item style.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AlternateItemStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.DynamicStyle

instance.AlternateItemStyle = value

value = instance.AlternateItemStyle
C#
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for alternate item style.")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.DynamicStyle AlternateItemStyle {get; set;}
Delphi
public read-write property AlternateItemStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for alternate item style.")
System.ComponentModel.DefaultValueAttribute()
public function get,set AlternateItemStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for alternate item style.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.DynamicStyle* get_AlternateItemStyle();
public: __property void set_AlternateItemStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for alternate item style.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.DynamicStyle^ AlternateItemStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ApplyStyle Method

[image]
Intersoft WebEssentials Documentation
ApplyStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebEssentials Documentation
ApplyStyleSheetSkin Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


BackColor Property

[image]
Intersoft WebEssentials Documentation
BackColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : BackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Drawing.Color BackColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


BorderColor Property

[image]
Intersoft WebEssentials Documentation
BorderColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : BorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
Public Overridable Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public virtual System.Drawing.Color BorderColor {get; set;}
Delphi
public read-write property BorderColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
public function get,set BorderColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public:
virtual property System.Drawing.Color BorderColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


BorderStyle Property

[image]
Intersoft WebEssentials Documentation
BorderStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
Delphi
public read-write property BorderStyle: System.Web.UI.WebControls.BorderStyle; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Frame Appearance")
public function get,set BorderStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public:
virtual property System.Web.UI.WebControls.BorderStyle BorderStyle {
   System.Web.UI.WebControls.BorderStyle get();
   void set (    System.Web.UI.WebControls.BorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


BorderWidth Property

[image]
Intersoft WebEssentials Documentation
BorderWidth Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : BorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
Delphi
public read-write property BorderWidth: System.Web.UI.WebControls.Unit; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BorderWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit BorderWidth {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


CanUseWebResources Method

[image]
Intersoft WebEssentials Documentation
CanUseWebResources Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.CanUseWebResources()
C#
public System.bool CanUseWebResources()
Delphi
public function CanUseWebResources(): System.Boolean;
JScript
public function CanUseWebResources() : System.boolean;
Managed Extensions for C++
public: System.bool CanUseWebResources();
C++/CLI
public:
System.bool CanUseWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Caption Property

[image]
Intersoft WebEssentials Documentation
Caption Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Caption Property

Glossary Item Box

Gets or sets the caption for WebSlidingMenu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the caption for WebSlidingMenu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Caption As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

instance.Caption = value

value = instance.Caption
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the caption for WebSlidingMenu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Caption {get; set;}
Delphi
public read-write property Caption: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the caption for WebSlidingMenu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Caption : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the caption for WebSlidingMenu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Caption();
public: __property void set_Caption(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the caption for WebSlidingMenu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Caption {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


CheckConstrains Method

[image]
Intersoft WebEssentials Documentation
CheckConstrains Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu

instance.CheckConstrains()
C#
public override void CheckConstrains()
Delphi
public procedure CheckConstrains(); override;
JScript
public override function CheckConstrains();
Managed Extensions for C++
public: void CheckConstrains(); override
C++/CLI
public:
void CheckConstrains(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ClientIDMode Property

[image]
Intersoft WebEssentials Documentation
ClientIDMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ClientSideEvents Property

[image]
Intersoft WebEssentials Documentation
ClientSideEvents Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ClientSideEvents Property

Glossary Item Box

Contains client side events supported by WebAccordion.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSlidingMenu.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ClientSideEvents As WebSlidingMenuClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As WebSlidingMenuClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSlidingMenu.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebSlidingMenuClientSideEvents ClientSideEvents {get; set;}
Delphi
public read-write property ClientSideEvents: WebSlidingMenuClientSideEvents;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSlidingMenu.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ClientSideEvents : WebSlidingMenuClientSideEvents
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSlidingMenu.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebSlidingMenuClientSideEvents* get_ClientSideEvents();
public: __property void set_ClientSideEvents(
   WebSlidingMenuClientSideEvents* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSlidingMenu.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebSlidingMenuClientSideEvents^ ClientSideEvents {
   WebSlidingMenuClientSideEvents^ get();
   void set (    WebSlidingMenuClientSideEvents^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Clone Method

[image]
Intersoft WebEssentials Documentation
Clone Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ControlDataTransferFormat Property

[image]
Intersoft WebEssentials Documentation
ControlDataTransferFormat Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


CopyBaseAttributes Method

[image]
Intersoft WebEssentials Documentation
CopyBaseAttributes Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


CopyFrom Method

[image]
Intersoft WebEssentials Documentation
CopyFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


CopyFrom(Object) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebEssentials Documentation
CopyFrom(Object,Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members
Overload List


CssClass Property

[image]
Intersoft WebEssentials Documentation
CssClass Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : CssClass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
Public Overridable Property CssClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public virtual System.string CssClass {get; set;}
Delphi
public read-write property CssClass: System.String; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Frame Appearance")
public function get,set CssClass : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public:
virtual property System.String^ CssClass {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


DataBind Method

[image]
Intersoft WebEssentials Documentation
DataBind Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


DataBind() Method

[image]
Intersoft WebEssentials Documentation
DataBind() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


DataBinding Event

[image]
Intersoft WebEssentials Documentation
DataBinding Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


DataBindings Property

[image]
Intersoft WebEssentials Documentation
DataBindings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : DataBindings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebEssentials.WebSlidingMenuBindingEditor, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.ComponentModel.MergablePropertyAttribute(False)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property DataBindings As WebSlidingMenuItemBindingCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As WebSlidingMenuItemBindingCollection

value = instance.DataBindings
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebEssentials.WebSlidingMenuBindingEditor, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.MergablePropertyAttribute(false)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public WebSlidingMenuItemBindingCollection DataBindings {get;}
Delphi
public read-only property DataBindings: WebSlidingMenuItemBindingCollection;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebEssentials.WebSlidingMenuBindingEditor, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.ComponentModel.MergablePropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DefaultValueAttribute()
public function get DataBindings : WebSlidingMenuItemBindingCollection
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebEssentials.WebSlidingMenuBindingEditor, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.MergablePropertyAttribute(false)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebSlidingMenuItemBindingCollection* get_DataBindings();
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebEssentials.WebSlidingMenuBindingEditor, ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.MergablePropertyAttribute(false)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebSlidingMenuItemBindingCollection^ DataBindings {
   WebSlidingMenuItemBindingCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


DataSourceID Property

[image]
Intersoft WebEssentials Documentation
DataSourceID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : DataSourceID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets WebSlidingMenu DataSourceID")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.HierarchicalDataSourceControl)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DataSourceID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

instance.DataSourceID = value

value = instance.DataSourceID
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets WebSlidingMenu DataSourceID")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.HierarchicalDataSourceControl)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string DataSourceID {get; set;}
Delphi
public read-write property DataSourceID: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Data")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets WebSlidingMenu DataSourceID")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.HierarchicalDataSourceControl)
System.ComponentModel.DefaultValueAttribute()
public function get,set DataSourceID : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets WebSlidingMenu DataSourceID")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.HierarchicalDataSourceControl)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_DataSourceID();
public: __property void set_DataSourceID(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets WebSlidingMenu DataSourceID")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.HierarchicalDataSourceControl)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ DataSourceID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


DefaultStyleMode Property

[image]
Intersoft WebEssentials Documentation
DefaultStyleMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : DefaultStyleMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DefaultStyleMode As WebSlidingMenuDefaultStyleMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As WebSlidingMenuDefaultStyleMode

instance.DefaultStyleMode = value

value = instance.DefaultStyleMode
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebSlidingMenuDefaultStyleMode DefaultStyleMode {get; set;}
Delphi
public read-write property DefaultStyleMode: WebSlidingMenuDefaultStyleMode;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DefaultStyleMode : WebSlidingMenuDefaultStyleMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebSlidingMenuDefaultStyleMode get_DefaultStyleMode();
public: __property void set_DefaultStyleMode(
   WebSlidingMenuDefaultStyleMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebSlidingMenuDefaultStyleMode DefaultStyleMode {
   WebSlidingMenuDefaultStyleMode get();
   void set (    WebSlidingMenuDefaultStyleMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


DeSerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
DeSerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Dispose Method

[image]
Intersoft WebEssentials Documentation
Dispose Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Disposed Event

[image]
Intersoft WebEssentials Documentation
Disposed Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Enabled Property

[image]
Intersoft WebEssentials Documentation
Enabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


EnableLoaderIndicator Property

[image]
Intersoft WebEssentials Documentation
EnableLoaderIndicator Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : EnableLoaderIndicator Property

Glossary Item Box

Determines whether or not loader indicator appear when WebSlidingMenu performing load on demand.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not loader indicator appear when WebSlidingMenu performing load on demand.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property EnableLoaderIndicator As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

instance.EnableLoaderIndicator = value

value = instance.EnableLoaderIndicator
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not loader indicator appear when WebSlidingMenu performing load on demand.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool EnableLoaderIndicator {get; set;}
Delphi
public read-write property EnableLoaderIndicator: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not loader indicator appear when WebSlidingMenu performing load on demand.")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set EnableLoaderIndicator : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not loader indicator appear when WebSlidingMenu performing load on demand.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_EnableLoaderIndicator();
public: __property void set_EnableLoaderIndicator(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not loader indicator appear when WebSlidingMenu performing load on demand.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool EnableLoaderIndicator {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


EnableManagedTheming Property

[image]
Intersoft WebEssentials Documentation
EnableManagedTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable Property EnableManagedTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableManagedTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.bool EnableManagedTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


EnableTheming Property

[image]
Intersoft WebEssentials Documentation
EnableTheming Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


EnableViewState Property

[image]
Intersoft WebEssentials Documentation
EnableViewState Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


EnableWebResources Property

[image]
Intersoft WebEssentials Documentation
EnableWebResources Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Web Resources")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Web Resources")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


FindControl Method

[image]
Intersoft WebEssentials Documentation
FindControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


FindControl(String) Method

[image]
Intersoft WebEssentials Documentation
FindControl(String) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


FlyPostBackSettings Property

[image]
Intersoft WebEssentials Documentation
FlyPostBackSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : FlyPostBackSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")>
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}
Delphi
public read-only property FlyPostBackSettings: ISNet.WebUI.FlyPostBackSettings;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")
public function get FlyPostBackSettings : ISNet.WebUI.FlyPostBackSettings
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
public: __property ISNet.WebUI.FlyPostBackSettings* get_FlyPostBackSettings();
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
public:
property ISNet.WebUI.FlyPostBackSettings^ FlyPostBackSettings {
   ISNet.WebUI.FlyPostBackSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Focus Method

[image]
Intersoft WebEssentials Documentation
Focus Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Font Property

[image]
Intersoft WebEssentials Documentation
Font Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
Delphi
public read-only property Font: System.Web.UI.WebControls.FontInfo; virtual;
JScript
System.ComponentModel.CategoryAttribute("Frame Appearance")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
public function get Font : System.Web.UI.WebControls.FontInfo
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public: __property virtual System.Web.UI.WebControls.FontInfo* get_Font();
C++/CLI
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public:
virtual property System.Web.UI.WebControls.FontInfo^ Font {
   System.Web.UI.WebControls.FontInfo^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ForceDisableXmlCompression Method

[image]
Intersoft WebEssentials Documentation
ForceDisableXmlCompression Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ForeColor Property

[image]
Intersoft WebEssentials Documentation
ForeColor Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ForeColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Drawing.Color ForeColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


FrameStyle Property

[image]
Intersoft WebEssentials Documentation
FrameStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : FrameStyle Property

Glossary Item Box

Contains interactive style for the frame of WebSlidingMenu.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for the frame of WebSlidingMenu.")>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the frame of WebSlidingMenu.")]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle FrameStyle {get; set;}
Delphi
public read-write property FrameStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for the frame of WebSlidingMenu.")
System.ComponentModel.CategoryAttribute("Style")
public function get,set FrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the frame of WebSlidingMenu.")]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_FrameStyle();
public: __property void set_FrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the frame of WebSlidingMenu.")]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ FrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetClientAction Method

[image]
Intersoft WebEssentials Documentation
GetClientAction Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebEssentials Documentation
GetCurrentControlLifeCycle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetCurrentTheme Method

[image]
Intersoft WebEssentials Documentation
GetCurrentTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetFrameworkDataFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkDataFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

value = instance.GetFrameworkDataFolder()
C#
public System.string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): System.String;
JScript
public function GetFrameworkDataFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkDataFolder();
C++/CLI
public:
System.String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetFrameworkFolder Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

value = instance.GetFrameworkFolder()
C#
public System.string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): System.String;
JScript
public function GetFrameworkFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkFolder();
C++/CLI
public:
System.String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetFrameworkVersion Method

[image]
Intersoft WebEssentials Documentation
GetFrameworkVersion Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Version

value = instance.GetFrameworkVersion()
C#
public System.Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): System.Version;
JScript
public function GetFrameworkVersion() : System.Version;
Managed Extensions for C++
public: System.Version* GetFrameworkVersion();
C++/CLI
public:
System.Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetIntersoftFolder Method

[image]
Intersoft WebEssentials Documentation
GetIntersoftFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

value = instance.GetIntersoftFolder()
C#
public System.string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): System.String;
JScript
public function GetIntersoftFolder() : System.String;
Managed Extensions for C++
public: System.string* GetIntersoftFolder();
C++/CLI
public:
System.String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetLayoutFolder Method

[image]
Intersoft WebEssentials Documentation
GetLayoutFolder Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

value = instance.GetLayoutFolder()
C#
public System.string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): System.String;
JScript
public function GetLayoutFolder() : System.String;
Managed Extensions for C++
public: System.string* GetLayoutFolder();
C++/CLI
public:
System.String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetObjectData Method

[image]
Intersoft WebEssentials Documentation
GetObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetPostedXMLData Method

[image]
Intersoft WebEssentials Documentation
GetPostedXMLData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

value = instance.GetPostedXMLData()
C#
public System.string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): System.String;
JScript
public function GetPostedXMLData() : System.String;
Managed Extensions for C++
public: System.string* GetPostedXMLData();
C++/CLI
public:
System.String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetProductInfoKey Method

[image]
Intersoft WebEssentials Documentation
GetProductInfoKey Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

value = instance.GetProductInfoKey()
C#
public System.string GetProductInfoKey()
Delphi
public function GetProductInfoKey(): System.String;
JScript
public function GetProductInfoKey() : System.String;
Managed Extensions for C++
public: System.string* GetProductInfoKey();
C++/CLI
public:
System.String^ GetProductInfoKey();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetProductSimpleName Method

[image]
Intersoft WebEssentials Documentation
GetProductSimpleName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

value = instance.GetProductSimpleName()
C#
public System.string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): System.String;
JScript
public function GetProductSimpleName() : System.String;
Managed Extensions for C++
public: System.string* GetProductSimpleName();
C++/CLI
public:
System.String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetPropertyValue Method

[image]
Intersoft WebEssentials Documentation
GetPropertyValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As System.String, _
   ByVal propValue As System.String, _
   ByVal webConfigKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim defValue As System.String
Dim propValue As System.String
Dim webConfigKey As System.String
Dim value As System.String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public System.string GetPropertyValue(
   System.string defValue,
   System.string propValue,
   System.string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: System.String;
    propValue: System.String;
    webConfigKey: System.String
): System.String;
JScript
public function GetPropertyValue(
   defValue : System.String,
   propValue : System.String,
   webConfigKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetPropertyValue(
   System.string* defValue,
   System.string* propValue,
   System.string* webConfigKey
)
C++/CLI
public:
System.String^ GetPropertyValue(
   System.String^ defValue,
   System.String^ propValue,
   System.String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetResourceStream Method

[image]
Intersoft WebEssentials Documentation
GetResourceStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As System.String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim resourceUrl As System.String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   System.string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: System.String
): System.IO.Stream;
JScript
public function GetResourceStream(
   resourceUrl : System.String
) : System.IO.Stream;
Managed Extensions for C++
public: System.IO.Stream* GetResourceStream(
   System.string* resourceUrl
)
C++/CLI
public:
System.IO.Stream^ GetResourceStream(
   System.String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetRouteUrl Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


GetRouteUrl(Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebEssentials Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members
Overload List


GetUniqueIDRelativeTo Method

[image]
Intersoft WebEssentials Documentation
GetUniqueIDRelativeTo Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


HasControls Method

[image]
Intersoft WebEssentials Documentation
HasControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


HeaderStyle Property

[image]
Intersoft WebEssentials Documentation
HeaderStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : HeaderStyle Property

Glossary Item Box

Contains interactive style for the header of WebSlidingMenu.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for the header of WebSlidingMenu.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HeaderStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.WebStyle

instance.HeaderStyle = value

value = instance.HeaderStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the header of WebSlidingMenu.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle HeaderStyle {get; set;}
Delphi
public read-write property HeaderStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Contains interactive style for the header of WebSlidingMenu.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style")
System.ComponentModel.DefaultValueAttribute()
public function get,set HeaderStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the header of WebSlidingMenu.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_HeaderStyle();
public: __property void set_HeaderStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the header of WebSlidingMenu.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ HeaderStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Height Property

[image]
Intersoft WebEssentials Documentation
Height Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ID Property

[image]
Intersoft WebEssentials Documentation
ID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ImagesDirectory Property

[image]
Intersoft WebEssentials Documentation
ImagesDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the images directory for ImagesSettings.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSettings.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ImagesDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSettings.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ImagesDirectory {get; set;}
Delphi
public read-write property ImagesDirectory: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSettings.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set ImagesDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSettings.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ImagesDirectory();
public: __property void set_ImagesDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory for ImagesSettings.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ImagesDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ImagesSettings Property

[image]
Intersoft WebEssentials Documentation
ImagesSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ImagesSettings Property

Glossary Item Box

Provides the settings that control the images in WebSlidingMenu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSlidingMenu.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property ImagesSettings As WebSlidingMenuImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As WebSlidingMenuImagesSettings

value = instance.ImagesSettings
C#
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSlidingMenu.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebSlidingMenuImagesSettings ImagesSettings {get;}
Delphi
public read-only property ImagesSettings: WebSlidingMenuImagesSettings;
JScript
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSlidingMenu.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get ImagesSettings : WebSlidingMenuImagesSettings
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSlidingMenu.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebSlidingMenuImagesSettings* get_ImagesSettings();
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSlidingMenu.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebSlidingMenuImagesSettings^ ImagesSettings {
   WebSlidingMenuImagesSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Init Event

[image]
Intersoft WebEssentials Documentation
Init Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


InitializeItem Event

[image]
Intersoft WebEssentials Documentation
InitializeItem Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : InitializeItem Event

Glossary Item Box

Fires when WebSlidingMenu Item is initialize when LoadOnDemand feature is activate.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Interaction")>
<System.ComponentModel.DescriptionAttribute("Fires when WebSlidingMenu Item is initialize when LoadOnDemand feature is activate")>
Public Event InitializeItem As WebSlidingMenuEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim handler As WebSlidingMenuEventHandler

AddHandler instance.InitializeItem, handler
C#
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebSlidingMenu Item is initialize when LoadOnDemand feature is activate")]
public event WebSlidingMenuEventHandler InitializeItem
Delphi
public event InitializeItem: WebSlidingMenuEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebSlidingMenu Item is initialize when LoadOnDemand feature is activate")]
public: __event WebSlidingMenuEventHandler* InitializeItem
C++/CLI
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebSlidingMenu Item is initialize when LoadOnDemand feature is activate")]
public:
event WebSlidingMenuEventHandler^ InitializeItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


InitialPath Property

[image]
Intersoft WebEssentials Documentation
InitialPath Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : InitialPath Property

Glossary Item Box

Gets or sets the initial path for WebSlidingMenu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the initial path for WebSlidingMenu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InitialPath As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

instance.InitialPath = value

value = instance.InitialPath
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the initial path for WebSlidingMenu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InitialPath {get; set;}
Delphi
public read-write property InitialPath: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the initial path for WebSlidingMenu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set InitialPath : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the initial path for WebSlidingMenu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InitialPath();
public: __property void set_InitialPath(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the initial path for WebSlidingMenu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InitialPath {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


IsAtlasCallback Method

[image]
Intersoft WebEssentials Documentation
IsAtlasCallback Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.IsAtlasCallback()
C#
public System.bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): System.Boolean;
JScript
public function IsAtlasCallback() : System.boolean;
Managed Extensions for C++
public: System.bool IsAtlasCallback();
C++/CLI
public:
System.bool IsAtlasCallback();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


IsBetaRelease Method

[image]
Intersoft WebEssentials Documentation
IsBetaRelease Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.IsBetaRelease()
C#
public System.bool IsBetaRelease()
Delphi
public function IsBetaRelease(): System.Boolean;
JScript
public function IsBetaRelease() : System.boolean;
Managed Extensions for C++
public: System.bool IsBetaRelease();
C++/CLI
public:
System.bool IsBetaRelease();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


IsChromeBrowser Method

[image]
Intersoft WebEssentials Documentation
IsChromeBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.IsChromeBrowser()
C#
public System.bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): System.Boolean;
JScript
public function IsChromeBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsChromeBrowser();
C++/CLI
public:
System.bool IsChromeBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


IsEmpty Method

[image]
Intersoft WebEssentials Documentation
IsEmpty Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


IsFlyPostBackControl Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual System.bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): System.Boolean; virtual;
JScript
public function IsFlyPostBackControl() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackControl();
C++/CLI
public:
virtual System.bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


IsFlyPostBackRequest Method

[image]
Intersoft WebEssentials Documentation
IsFlyPostBackRequest Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual System.bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): System.Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackRequest();
C++/CLI
public:
virtual System.bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebEssentials Documentation
IsGeckoBasedBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.IsGeckoBasedBrowser()
C#
public System.bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): System.Boolean;
JScript
public function IsGeckoBasedBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoBasedBrowser();
C++/CLI
public:
System.bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


IsGeckoVersion18 Method

[image]
Intersoft WebEssentials Documentation
IsGeckoVersion18 Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.IsGeckoVersion18()
C#
public System.bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): System.Boolean;
JScript
public function IsGeckoVersion18() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoVersion18();
C++/CLI
public:
System.bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


IsInDesignMode Method

[image]
Intersoft WebEssentials Documentation
IsInDesignMode Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.IsInDesignMode()
C#
public System.bool IsInDesignMode()
Delphi
public function IsInDesignMode(): System.Boolean;
JScript
public function IsInDesignMode() : System.boolean;
Managed Extensions for C++
public: System.bool IsInDesignMode();
C++/CLI
public:
System.bool IsInDesignMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorer8Browser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.IsInternetExplorer8Browser()
C#
public System.bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): System.Boolean;
JScript
public function IsInternetExplorer8Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer8Browser();
C++/CLI
public:
System.bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebEssentials Documentation
IsInternetExplorerBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.IsInternetExplorerBrowser()
C#
public System.bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): System.Boolean;
JScript
public function IsInternetExplorerBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorerBrowser();
C++/CLI
public:
System.bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


IsOperaBrowser Method

[image]
Intersoft WebEssentials Documentation
IsOperaBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.IsOperaBrowser()
C#
public System.bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): System.Boolean;
JScript
public function IsOperaBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsOperaBrowser();
C++/CLI
public:
System.bool IsOperaBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


IsSafariBrowser Method

[image]
Intersoft WebEssentials Documentation
IsSafariBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.IsSafariBrowser()
C#
public System.bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): System.Boolean;
JScript
public function IsSafariBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsSafariBrowser();
C++/CLI
public:
System.bool IsSafariBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


IsW3CStandardBrowser Method

[image]
Intersoft WebEssentials Documentation
IsW3CStandardBrowser Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.IsW3CStandardBrowser()
C#
public System.bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): System.Boolean;
JScript
public function IsW3CStandardBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsW3CStandardBrowser();
C++/CLI
public:
System.bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ItemBound Event

[image]
Intersoft WebEssentials Documentation
ItemBound Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ItemBound Event

Glossary Item Box

Fires when WebSlidingMenu Item is bound in binding to datasource scenario.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Interaction")>
<System.ComponentModel.DescriptionAttribute("Fires when WebSlidingMenu Item is bound in binding to datasource scenario.")>
Public Event ItemBound As WebSlidingMenuEventItemBoundHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim handler As WebSlidingMenuEventItemBoundHandler

AddHandler instance.ItemBound, handler
C#
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebSlidingMenu Item is bound in binding to datasource scenario.")]
public event WebSlidingMenuEventItemBoundHandler ItemBound
Delphi
public event ItemBound: WebSlidingMenuEventItemBoundHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebSlidingMenu Item is bound in binding to datasource scenario.")]
public: __event WebSlidingMenuEventItemBoundHandler* ItemBound
C++/CLI
[System.ComponentModel.CategoryAttribute("Interaction")]
[System.ComponentModel.DescriptionAttribute("Fires when WebSlidingMenu Item is bound in binding to datasource scenario.")]
public:
event WebSlidingMenuEventItemBoundHandler^ ItemBound

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ItemContentStyle Property

[image]
Intersoft WebEssentials Documentation
ItemContentStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ItemContentStyle Property

Glossary Item Box

Contains interactive style for the item content of WebSlidingMenuItem.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for the item content of WebSlidingMenuItem.")>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property ItemContentStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.WebStyle

instance.ItemContentStyle = value

value = instance.ItemContentStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the item content of WebSlidingMenuItem.")]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle ItemContentStyle {get; set;}
Delphi
public read-write property ItemContentStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for the item content of WebSlidingMenuItem.")
System.ComponentModel.CategoryAttribute("Style")
public function get,set ItemContentStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the item content of WebSlidingMenuItem.")]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_ItemContentStyle();
public: __property void set_ItemContentStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the item content of WebSlidingMenuItem.")]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ ItemContentStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Items Property

[image]
Intersoft WebEssentials Documentation
Items Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Items Property

Glossary Item Box

The item collection of WebSlidingMenuItem

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("The item collection of WebSlidingMenuItem.")>
<ISNet.Serialization.BinarySerializableAttribute("setItems")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property Items As WebSlidingMenuItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As WebSlidingMenuItemCollection

value = instance.Items
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The item collection of WebSlidingMenuItem.")]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebSlidingMenuItemCollection Items {get;}
Delphi
public read-only property Items: WebSlidingMenuItemCollection;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("The item collection of WebSlidingMenuItem.")
ISNet.Serialization.BinarySerializableAttribute("setItems")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get Items : WebSlidingMenuItemCollection
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The item collection of WebSlidingMenuItem.")]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebSlidingMenuItemCollection* get_Items();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The item collection of WebSlidingMenuItem.")]
[ISNet.Serialization.BinarySerializableAttribute("setItems")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebSlidingMenuItemCollection^ Items {
   WebSlidingMenuItemCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ItemStyle Property

[image]
Intersoft WebEssentials Documentation
ItemStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ItemStyle Property

Glossary Item Box

Contains interactive style for item style.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Style")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for item style.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ItemStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.DynamicStyle

instance.ItemStyle = value

value = instance.ItemStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.DynamicStyle ItemStyle {get; set;}
Delphi
public read-write property ItemStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Style")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for item style.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
public function get,set ItemStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.DynamicStyle* get_ItemStyle();
public: __property void set_ItemStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for item style.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.DynamicStyle^ ItemStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


LayoutSettings Property

[image]
Intersoft WebEssentials Documentation
LayoutSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : LayoutSettings Property

Glossary Item Box

Provides the settings that control the behaviors of the layout in WebSlidingMenu.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebSlidingMenu.")>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property LayoutSettings As WebSlidingMenuLayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As WebSlidingMenuLayoutSettings

value = instance.LayoutSettings
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebSlidingMenu.")]
[System.ComponentModel.CategoryAttribute("General")]
public WebSlidingMenuLayoutSettings LayoutSettings {get;}
Delphi
public read-only property LayoutSettings: WebSlidingMenuLayoutSettings;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebSlidingMenu.")
System.ComponentModel.CategoryAttribute("General")
public function get LayoutSettings : WebSlidingMenuLayoutSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebSlidingMenu.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property WebSlidingMenuLayoutSettings* get_LayoutSettings();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLayoutSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the behaviors of the layout in WebSlidingMenu.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property WebSlidingMenuLayoutSettings^ LayoutSettings {
   WebSlidingMenuLayoutSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Levels Property

[image]
Intersoft WebEssentials Documentation
Levels Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Levels Property

Glossary Item Box

The level collection of WebSlidingMenuLevel

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setLevels")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("The level collection of WebSlidingMenuLevel.")>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property Levels As WebSlidingMenuLevelCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As WebSlidingMenuLevelCollection

value = instance.Levels
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLevels")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The level collection of WebSlidingMenuLevel.")]
[System.ComponentModel.CategoryAttribute("General")]
public WebSlidingMenuLevelCollection Levels {get;}
Delphi
public read-only property Levels: WebSlidingMenuLevelCollection;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setLevels")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("The level collection of WebSlidingMenuLevel.")
System.ComponentModel.CategoryAttribute("General")
public function get Levels : WebSlidingMenuLevelCollection
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLevels")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The level collection of WebSlidingMenuLevel.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property WebSlidingMenuLevelCollection* get_Levels();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setLevels")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebEssentials, Version=1.0.1000.2, Culture=neutral, PublicKeyToken=ba1fcebb69a7393e")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("The level collection of WebSlidingMenuLevel.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property WebSlidingMenuLevelCollection^ Levels {
   WebSlidingMenuLevelCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Load Event

[image]
Intersoft WebEssentials Documentation
Load Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


LoadLayout Method

[image]
Intersoft WebEssentials Documentation
LoadLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


LoadLayoutFromFile Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim filePath As System.String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   System.string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: System.String
); virtual;
JScript
public function LoadLayoutFromFile(
   filePath : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromFile(
   System.string* filePath
)
C++/CLI
public:
virtual void LoadLayoutFromFile(
   System.String^ filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromPredefinedName Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim predefinedName As System.String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   System.string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: System.String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   System.string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   System.String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


LoadLayoutFromStream Method

[image]
Intersoft WebEssentials Documentation
LoadLayoutFromStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: System.IO.Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   System.IO.Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


LoadOnDemand Property

[image]
Intersoft WebEssentials Documentation
LoadOnDemand Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : LoadOnDemand Property

Glossary Item Box

Gets or sets the value that determines whether the WebSlidingMenu is load on demand or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether the WebSlidingMenu is load on demand or not.")>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property LoadOnDemand As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

instance.LoadOnDemand = value

value = instance.LoadOnDemand
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether the WebSlidingMenu is load on demand or not.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool LoadOnDemand {get; set;}
Delphi
public read-write property LoadOnDemand: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether the WebSlidingMenu is load on demand or not.")
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set LoadOnDemand : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether the WebSlidingMenu is load on demand or not.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_LoadOnDemand();
public: __property void set_LoadOnDemand(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether the WebSlidingMenu is load on demand or not.")]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool LoadOnDemand {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


LoadPostData Method

[image]
Intersoft WebEssentials Documentation
LoadPostData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function LoadPostData( _
   ByVal postDataKey As System.String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim postDataKey As System.String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As System.Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public virtual System.bool LoadPostData(
   System.string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)
Delphi
public function LoadPostData(
    postDataKey: System.String;
    postCollection: System.Collections.Specialized.NameValueCollection
): System.Boolean; virtual;
JScript
public function LoadPostData(
   postDataKey : System.String,
   postCollection : System.Collections.Specialized.NameValueCollection
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool LoadPostData(
   System.string* postDataKey,
   System.Collections.Specialized.NameValueCollection* postCollection
)
C++/CLI
public:
virtual System.bool LoadPostData(
   System.String^ postDataKey,
   System.Collections.Specialized.NameValueCollection^ postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


MaxDataBindDepth Property

[image]
Intersoft WebEssentials Documentation
MaxDataBindDepth Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : MaxDataBindDepth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the depth to which the WebSlidingMenu will databind.")>
Public Property MaxDataBindDepth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Integer

instance.MaxDataBindDepth = value

value = instance.MaxDataBindDepth
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the depth to which the WebSlidingMenu will databind.")]
public System.int MaxDataBindDepth {get; set;}
Delphi
public read-write property MaxDataBindDepth: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DescriptionAttribute("Gets or sets the depth to which the WebSlidingMenu will databind.")
public function get,set MaxDataBindDepth : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the depth to which the WebSlidingMenu will databind.")]
public: __property System.int get_MaxDataBindDepth();
public: __property void set_MaxDataBindDepth(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the depth to which the WebSlidingMenu will databind.")]
public:
property System.int MaxDataBindDepth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


MergeStyle Method

[image]
Intersoft WebEssentials Documentation
MergeStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


NextIndicatorStyle Property

[image]
Intersoft WebEssentials Documentation
NextIndicatorStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : NextIndicatorStyle Property

Glossary Item Box

Contains interactive style for the next indicator arrow of WebSlidingMenuItem.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for the next indicator arrow of WebSlidingMenuItem.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Style")>
Public Property NextIndicatorStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.WebStyle

instance.NextIndicatorStyle = value

value = instance.NextIndicatorStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the next indicator arrow of WebSlidingMenuItem.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style")]
public ISNet.WebUI.WebStyle NextIndicatorStyle {get; set;}
Delphi
public read-write property NextIndicatorStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for the next indicator arrow of WebSlidingMenuItem.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Style")
public function get,set NextIndicatorStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the next indicator arrow of WebSlidingMenuItem.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style")]
public: __property ISNet.WebUI.WebStyle* get_NextIndicatorStyle();
public: __property void set_NextIndicatorStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the next indicator arrow of WebSlidingMenuItem.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Style")]
public:
property ISNet.WebUI.WebStyle^ NextIndicatorStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


OnInfoChanged Method

[image]
Intersoft WebEssentials Documentation
OnInfoChanged Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


OnPreInitialize Method

[image]
Intersoft WebEssentials Documentation
OnPreInitialize Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Page Property

[image]
Intersoft WebEssentials Documentation
Page Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}
Delphi
public read-write property Page: System.Web.UI.Page; virtual;
JScript
public function get,set Page : System.Web.UI.Page
Managed Extensions for C++
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
C++/CLI
public:
virtual property System.Web.UI.Page^ Page {
   System.Web.UI.Page^ get();
   void set (    System.Web.UI.Page^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


PreInitialize Event

[image]
Intersoft WebEssentials Documentation
PreInitialize Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim handler As System.EventHandler

AddHandler instance.PreInitialize, handler
C#
public event System.EventHandler PreInitialize
Delphi
public event PreInitialize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* PreInitialize
C++/CLI
public:
event System.EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


PreRender Event

[image]
Intersoft WebEssentials Documentation
PreRender Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebEssentials Documentation
RaisePostDataChangedEvent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); virtual;
JScript
public function RaisePostDataChangedEvent();
Managed Extensions for C++
public: virtual void RaisePostDataChangedEvent();
C++/CLI
public:
virtual void RaisePostDataChangedEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ReadWebConfigValue Method

[image]
Intersoft WebEssentials Documentation
ReadWebConfigValue Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim key As System.String
Dim value As System.String

value = instance.ReadWebConfigValue(key)
C#
public System.string ReadWebConfigValue(
   System.string key
)
Delphi
public function ReadWebConfigValue(
    key: System.String
): System.String;
JScript
public function ReadWebConfigValue(
   key : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ReadWebConfigValue(
   System.string* key
)
C++/CLI
public:
System.String^ ReadWebConfigValue(
   System.String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RecreateChildControls Method

[image]
Intersoft WebEssentials Documentation
RecreateChildControls Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu

instance.RecreateChildControls()
C#
public void RecreateChildControls()
Delphi
public procedure RecreateChildControls();
JScript
public function RecreateChildControls();
Managed Extensions for C++
public: void RecreateChildControls();
C++/CLI
public:
void RecreateChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RegisterBoxSizing Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RegisterBoxSizing() Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing() Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebEssentials Documentation
RegisterBoxSizing(Boolean) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim forceAll As System.Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   System.bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: System.Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : System.boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   System.bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   System.bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebEssentials Documentation
RegisterGlobalStyle Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RegisterLink Method

[image]
Intersoft WebEssentials Documentation
RegisterLink Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As System.String, _
   ByVal url As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim name As System.String
Dim url As System.String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   System.string name,
   System.string url
)
Delphi
public procedure RegisterLink(
    name: System.String;
    url: System.String
);
JScript
public function RegisterLink(
   name : System.String,
   url : System.String
);
Managed Extensions for C++
public: void RegisterLink(
   System.string* name,
   System.string* url
)
C++/CLI
public:
void RegisterLink(
   System.String^ name,
   System.String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebEssentials Documentation
RegisterOptimizedCssClasses Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim runtimeStyleOnly As System.Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: System.Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : System.boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RegisterPreloadImage Method

[image]
Intersoft WebEssentials Documentation
RegisterPreloadImage Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim image As System.String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   System.string image
)
Delphi
public procedure RegisterPreloadImage(
    image: System.String
);
JScript
public function RegisterPreloadImage(
   image : System.String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   System.string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   System.String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RegisterScript Method

[image]
Intersoft WebEssentials Documentation
RegisterScript Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu

instance.RegisterScript()
C#
public override void RegisterScript()
Delphi
public procedure RegisterScript(); override;
JScript
public override function RegisterScript();
Managed Extensions for C++
public: void RegisterScript(); override
C++/CLI
public:
void RegisterScript(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RegisterSharePointHandler Method

[image]
Intersoft WebEssentials Documentation
RegisterSharePointHandler Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RenderBeginTag Method

[image]
Intersoft WebEssentials Documentation
RenderBeginTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RenderControl Method

[image]
Intersoft WebEssentials Documentation
RenderControl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebEssentials Documentation
RenderControl(HtmlTextWriter) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RenderEndTag Method

[image]
Intersoft WebEssentials Documentation
RenderEndTag Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RenderingMode Property

[image]
Intersoft WebEssentials Documentation
RenderingMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Reset Method

[image]
Intersoft WebEssentials Documentation
Reset Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ResolveClientUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveClientUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ResolveImagePath Method

[image]
Intersoft WebEssentials Documentation
ResolveImagePath Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As System.String, _
   ByVal image As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim folder As System.String
Dim image As System.String
Dim value As System.String

value = instance.ResolveImagePath(folder, image)
C#
public System.string ResolveImagePath(
   System.string folder,
   System.string image
)
Delphi
public function ResolveImagePath(
    folder: System.String;
    image: System.String
): System.String;
JScript
public function ResolveImagePath(
   folder : System.String,
   image : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveImagePath(
   System.string* folder,
   System.string* image
)
C++/CLI
public:
System.String^ ResolveImagePath(
   System.String^ folder,
   System.String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ResolveRelativeURL Method

[image]
Intersoft WebEssentials Documentation
ResolveRelativeURL Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim url As System.String
Dim value As System.String

value = instance.ResolveRelativeURL(url)
C#
public virtual System.string ResolveRelativeURL(
   System.string url
)
Delphi
public function ResolveRelativeURL(
    url: System.String
): System.String; virtual;
JScript
public function ResolveRelativeURL(
   url : System.String
) : System.String;
Managed Extensions for C++
public: virtual System.string* ResolveRelativeURL(
   System.string* url
)
C++/CLI
public:
virtual System.String^ ResolveRelativeURL(
   System.String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ResolveResourceUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveResourceUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As System.String, _
   ByVal currentFolder As System.String, _
   ByVal resourceName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As System.String
Dim currentFolder As System.String
Dim resourceName As System.String
Dim value As System.String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public System.string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string defaultFolder,
   System.string currentFolder,
   System.string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: System.String;
    currentFolder: System.String;
    resourceName: System.String
): System.String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : System.String,
   currentFolder : System.String,
   resourceName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string* defaultFolder,
   System.string* currentFolder,
   System.string* resourceName
)
C++/CLI
public:
System.String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.String^ defaultFolder,
   System.String^ currentFolder,
   System.String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ResolveUrl Method

[image]
Intersoft WebEssentials Documentation
ResolveUrl Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


RuntimeLicenseKey Property

[image]
Intersoft WebEssentials Documentation
RuntimeLicenseKey Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
Public Overridable Property RuntimeLicenseKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public virtual System.string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: System.String; virtual;
JScript
ISNet.PersistLayoutAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
public function get,set RuntimeLicenseKey : System.String
Managed Extensions for C++
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public: __property virtual System.string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   System.string* value
);
C++/CLI
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public:
virtual property System.String^ RuntimeLicenseKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


SaveLayout Method

[image]
Intersoft WebEssentials Documentation
SaveLayout Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


SaveLayoutToFile Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToFile Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim filePath As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   System.string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   System.string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   System.String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


SaveLayoutToStream Method

[image]
Intersoft WebEssentials Documentation
SaveLayoutToStream Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
ScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overrides Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
public override System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String; override;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.DefaultValueAttribute()
public override function get,set ScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


SerializeObjectData Method

[image]
Intersoft WebEssentials Documentation
SerializeObjectData Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


SetDataSourceInternal Method

[image]
Intersoft WebEssentials Documentation
SetDataSourceInternal Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : SetDataSourceInternal Method

dataSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DoNotObfuscateAttribute()>
Public Sub SetDataSourceInternal( _
   ByVal dataSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim dataSource As System.Object

instance.SetDataSourceInternal(dataSource)
C#
[DoNotObfuscateAttribute()]
public void SetDataSourceInternal(
   System.object dataSource
)
Delphi
public procedure SetDataSourceInternal(
    dataSource: System.TObject
);
JScript
DoNotObfuscateAttribute()
public function SetDataSourceInternal(
   dataSource : System.Object
);
Managed Extensions for C++
[DoNotObfuscateAttribute()]
public: void SetDataSourceInternal(
   System.Object* dataSource
)
C++/CLI
[DoNotObfuscateAttribute()]
public:
void SetDataSourceInternal(
   System.Object^ dataSource
)

Parameters

dataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


SetInitialLevelByPath Method

[image]
Intersoft WebEssentials Documentation
SetInitialLevelByPath Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : SetInitialLevelByPath Method

path

Glossary Item Box

Set Initial level by path.

Syntax

Visual Basic (Declaration)
Public Sub SetInitialLevelByPath( _
   ByVal path As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim path As System.String

instance.SetInitialLevelByPath(path)
C#
public void SetInitialLevelByPath(
   System.string path
)
Delphi
public procedure SetInitialLevelByPath(
    path: System.String
);
JScript
public function SetInitialLevelByPath(
   path : System.String
);
Managed Extensions for C++
public: void SetInitialLevelByPath(
   System.string* path
)
C++/CLI
public:
void SetInitialLevelByPath(
   System.String^ path
)

Parameters

path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


SetRenderMethodDelegate Method

[image]
Intersoft WebEssentials Documentation
SetRenderMethodDelegate Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


SetSessionTheme Method

[image]
Intersoft WebEssentials Documentation
SetSessionTheme Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


SharedScriptDirectory Property

[image]
Intersoft WebEssentials Documentation
SharedScriptDirectory Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required framework scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Overrides Property SharedScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public override System.string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: System.String; override;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public override function get,set SharedScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_SharedScriptDirectory() override;
public: __property void set_SharedScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ SharedScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ShouldReturnJson Method

[image]
Intersoft WebEssentials Documentation
ShouldReturnJson Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

value = instance.ShouldReturnJson()
C#
public virtual System.bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): System.Boolean; virtual;
JScript
public function ShouldReturnJson() : System.boolean;
Managed Extensions for C++
public: virtual System.bool ShouldReturnJson();
C++/CLI
public:
virtual System.bool ShouldReturnJson();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


SkinID Property

[image]
Intersoft WebEssentials Documentation
SkinID Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


SynchronizeTemplatesFrom Method

[image]
Intersoft WebEssentials Documentation
SynchronizeTemplatesFrom Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : SynchronizeTemplatesFrom Method

sourceObj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SynchronizeTemplatesFrom( _
   ByVal sourceObj As ISNet.WebUI.ISNetControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim sourceObj As ISNet.WebUI.ISNetControl

instance.SynchronizeTemplatesFrom(sourceObj)
C#
public virtual void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl sourceObj
)
Delphi
public procedure SynchronizeTemplatesFrom(
    sourceObj: ISNet.WebUI.ISNetControl
); virtual;
JScript
public function SynchronizeTemplatesFrom(
   sourceObj : ISNet.WebUI.ISNetControl
);
Managed Extensions for C++
public: virtual void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl* sourceObj
)
C++/CLI
public:
virtual void SynchronizeTemplatesFrom(
   ISNet.WebUI.ISNetControl^ sourceObj
)

Parameters

sourceObj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


TabIndex Property

[image]
Intersoft WebEssentials Documentation
TabIndex Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set TabIndex : System.short
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


TextSettings Property

[image]
Intersoft WebEssentials Documentation
TextSettings Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : TextSettings Property

Glossary Item Box

Provides the settings that control the text in WebSlidingMenu.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setTextSettings")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the text in WebSlidingMenu.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property TextSettings As WebSlidingMenuTextSettings
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As WebSlidingMenuTextSettings

value = instance.TextSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTextSettings")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the text in WebSlidingMenu.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public WebSlidingMenuTextSettings TextSettings {get;}
Delphi
public read-only property TextSettings: WebSlidingMenuTextSettings;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setTextSettings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Provides the settings that control the text in WebSlidingMenu.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get TextSettings : WebSlidingMenuTextSettings
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTextSettings")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the text in WebSlidingMenu.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebSlidingMenuTextSettings* get_TextSettings();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTextSettings")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the text in WebSlidingMenu.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebSlidingMenuTextSettings^ TextSettings {
   WebSlidingMenuTextSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ToolTip Property

[image]
Intersoft WebEssentials Documentation
ToolTip Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Unload Event

[image]
Intersoft WebEssentials Documentation
Unload Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


UseDefaultStyle Property

[image]
Intersoft WebEssentials Documentation
UseDefaultStyle Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : UseDefaultStyle Property

Glossary Item Box

Specifies whether WebSlidingMenu should apply embedded default style for its appearance.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies whether WebSlidingMenu should apply embedded default style for its appearance.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property UseDefaultStyle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

instance.UseDefaultStyle = value

value = instance.UseDefaultStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebSlidingMenu should apply embedded default style for its appearance.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool UseDefaultStyle {get; set;}
Delphi
public read-write property UseDefaultStyle: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies whether WebSlidingMenu should apply embedded default style for its appearance.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set UseDefaultStyle : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebSlidingMenu should apply embedded default style for its appearance.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_UseDefaultStyle();
public: __property void set_UseDefaultStyle(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies whether WebSlidingMenu should apply embedded default style for its appearance.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool UseDefaultStyle {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ValidateRequestMode Property

[image]
Intersoft WebEssentials Documentation
ValidateRequestMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ViewStateItems Property

[image]
Intersoft WebEssentials Documentation
ViewStateItems Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ViewStateItems Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ViewStateMode Property

[image]
Intersoft WebEssentials Documentation
ViewStateMode Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ViewStateServerConnection Property

[image]
Intersoft WebEssentials Documentation
ViewStateServerConnection Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ViewStateServerConnection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ViewStateServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: System.String; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
System.ComponentModel.CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ViewStateServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ViewStateServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


ViewStateStorage Property

[image]
Intersoft WebEssentials Documentation
ViewStateStorage Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : ViewStateStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
System.ComponentModel.CategoryAttribute("View State Settings")
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Visible Property

[image]
Intersoft WebEssentials Documentation
Visible Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Visible Property

Glossary Item Box

Gets or sets the value that determines whether the WebSlidingMenu is visible or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether the WebSlidingMenu is visible or not.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Shadows Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether the WebSlidingMenu is visible or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public new System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether the WebSlidingMenu is visible or not.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public hide function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether the WebSlidingMenu is visible or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property new System.bool get_Visible();
public: __property new void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether the WebSlidingMenu is visible or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
new property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


Width Property

[image]
Intersoft WebEssentials Documentation
Width Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.CategoryAttribute("Layout")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


XmlCompressionEnabled Property

[image]
Intersoft WebEssentials Documentation
XmlCompressionEnabled Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebSlidingMenu Class : XmlCompressionEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property XmlCompressionEnabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSlidingMenu
Dim value As System.Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: System.Boolean; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set XmlCompressionEnabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool XmlCompressionEnabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSlidingMenu Class
WebSlidingMenu Members


WebUIComponentEssentials Class

[image]
Intersoft WebEssentials Documentation
WebUIComponentEssentials Class
Members See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebUIComponentEssentials Class

Glossary Item Box

Summary description for WebEssentialsComponentEditor.

Object Model

WebUIComponentEssentials Class

Syntax

Visual Basic (Declaration)
Public Class WebUIComponentEssentials
   Inherits System.Windows.Forms.Design.WindowsFormsComponentEditor
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEssentials
C#
public class WebUIComponentEssentials : System.Windows.Forms.Design.WindowsFormsComponentEditor
Delphi
public class WebUIComponentEssentials = class(System.Windows.Forms.Design.WindowsFormsComponentEditor)
JScript
public class WebUIComponentEssentials extends System.Windows.Forms.Design.WindowsFormsComponentEditor
Managed Extensions for C++
public __gc class WebUIComponentEssentials : public System.Windows.Forms.Design.WindowsFormsComponentEditor
C++/CLI
public ref class WebUIComponentEssentials : public System.Windows.Forms.Design.WindowsFormsComponentEditor

Inheritance Hierarchy

System.Object
System.ComponentModel.ComponentEditor
System.Windows.Forms.Design.WindowsFormsComponentEditor
ISNet.WebUI.WebEssentials.WebUIComponentEssentials

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEssentials Members
ISNet.WebUI.WebEssentials Namespace


WebUIComponentEssentials Class Events

[image]
Intersoft WebEssentials Documentation
WebUIComponentEssentials Class Events
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebUIComponentEssentials Class

Glossary Item Box

For a list of all members of this type, see WebUIComponentEssentials members.

Public Events

 | Name | Description
Public Event | ApplyChanges |
Top

See Also

Reference

WebUIComponentEssentials Class
ISNet.WebUI.WebEssentials Namespace


WebUIComponentEssentials Class Members

[image]
Intersoft WebEssentials Documentation
WebUIComponentEssentials Class Members
See Also Properties Methods Events Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebUIComponentEssentials Class

Glossary Item Box

The following tables list the members exposed by WebUIComponentEssentials.

Public Constructors

 | Name | Description
Public Constructor | WebUIComponentEssentials Constructor |
Top

Public Properties

 | Name | Description
Public Property | DesignerForm |
Top

Public Methods

 | Name | Description
Public Method | EditComponent | Overloaded. Overridden.
Top

Public Events

 | Name | Description
Public Event | ApplyChanges |
Top

See Also

Reference

WebUIComponentEssentials Class
ISNet.WebUI.WebEssentials Namespace


WebUIComponentEssentials Class Methods

[image]
Intersoft WebEssentials Documentation
WebUIComponentEssentials Class Methods
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebUIComponentEssentials Class

Glossary Item Box

For a list of all members of this type, see WebUIComponentEssentials members.

Public Methods

 | Name | Description
Public Method | EditComponent | Overloaded. Overridden.
Top

See Also

Reference

WebUIComponentEssentials Class
ISNet.WebUI.WebEssentials Namespace


WebUIComponentEssentials Class Properties

[image]
Intersoft WebEssentials Documentation
WebUIComponentEssentials Class Properties
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace : WebUIComponentEssentials Class

Glossary Item Box

For a list of all members of this type, see WebUIComponentEssentials members.

Public Properties

 | Name | Description
Public Property | DesignerForm |
Top

See Also

Reference

WebUIComponentEssentials Class
ISNet.WebUI.WebEssentials Namespace


WebUIComponentEssentials Constructor

[image]
Intersoft WebEssentials Documentation
WebUIComponentEssentials Constructor
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebUIComponentEssentials Class : WebUIComponentEssentials Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebUIComponentEssentials()
C#
public WebUIComponentEssentials()
Delphi
public WebUIComponentEssentials();
JScript
public function WebUIComponentEssentials();
Managed Extensions for C++
public: WebUIComponentEssentials();
C++/CLI
public:
WebUIComponentEssentials();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEssentials Class
WebUIComponentEssentials Members


ApplyChanges Event

[image]
Intersoft WebEssentials Documentation
ApplyChanges Event
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebUIComponentEssentials Class : ApplyChanges Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event ApplyChanges As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEssentials
Dim handler As System.EventHandler

AddHandler instance.ApplyChanges, handler
C#
public event System.EventHandler ApplyChanges
Delphi
public event ApplyChanges: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* ApplyChanges
C++/CLI
public:
event System.EventHandler^ ApplyChanges

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEssentials Class
WebUIComponentEssentials Members


DesignerForm Property

[image]
Intersoft WebEssentials Documentation
DesignerForm Property
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebUIComponentEssentials Class : DesignerForm Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DesignerForm As System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEssentials
Dim value As System.Windows.Forms.Form

instance.DesignerForm = value

value = instance.DesignerForm
C#
public System.Windows.Forms.Form DesignerForm {get; set;}
Delphi
public read-write property DesignerForm: System.Windows.Forms.Form;
JScript
public function get,set DesignerForm : System.Windows.Forms.Form
Managed Extensions for C++
public: __property System.Windows.Forms.Form* get_DesignerForm();
public: __property void set_DesignerForm(
   System.Windows.Forms.Form* value
);
C++/CLI
public:
property System.Windows.Forms.Form^ DesignerForm {
   System.Windows.Forms.Form^ get();
   void set (    System.Windows.Forms.Form^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEssentials Class
WebUIComponentEssentials Members


EditComponent Method

[image]
Intersoft WebEssentials Documentation
EditComponent Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebUIComponentEssentials Class : EditComponent Method

Glossary Item Box

Overload List

Overload | Description
EditComponent(ITypeDescriptorContext,Object,IWin32Window) |
EditComponent(ITypeDescriptorContext,Object) | (Inherited from System.Windows.Forms.Design.WindowsFormsComponentEditor)
EditComponent(Object,IWin32Window) | (Inherited from System.Windows.Forms.Design.WindowsFormsComponentEditor)
EditComponent(Object) | (Inherited from System.ComponentModel.ComponentEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEssentials Class
WebUIComponentEssentials Members


EditComponent(ITypeDescriptorContext,Object) Method

[image]
Intersoft WebEssentials Documentation
EditComponent(ITypeDescriptorContext,Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebUIComponentEssentials Class > EditComponent Method : EditComponent(ITypeDescriptorContext,Object) Method

context
component

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Overridable Function EditComponent( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal component As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEssentials
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim component As System.Object
Dim value As System.Boolean

value = instance.EditComponent(context, component)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext context,
   System.object component
)
Delphi
public function EditComponent(
    context: System.ComponentModel.ITypeDescriptorContext;
    component: System.TObject
): System.Boolean; virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditComponent(
   context : System.ComponentModel.ITypeDescriptorContext,
   component : System.Object
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Object* component
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Object^ component
)

Parameters

context
component

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEssentials Class
WebUIComponentEssentials Members
Overload List


EditComponent(ITypeDescriptorContext,Object,IWin32Window) Method

[image]
Intersoft WebEssentials Documentation
EditComponent(ITypeDescriptorContext,Object,IWin32Window) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebUIComponentEssentials Class > EditComponent Method : EditComponent(ITypeDescriptorContext,Object,IWin32Window) Method

context
component
owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function EditComponent( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal component As System.Object, _
   ByVal owner As System.Windows.Forms.IWin32Window _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEssentials
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim component As System.Object
Dim owner As System.Windows.Forms.IWin32Window
Dim value As System.Boolean

value = instance.EditComponent(context, component, owner)
C#
public override System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext context,
   System.object component,
   System.Windows.Forms.IWin32Window owner
)
Delphi
public function EditComponent(
    context: System.ComponentModel.ITypeDescriptorContext;
    component: System.TObject;
    owner: System.Windows.Forms.IWin32Window
): System.Boolean; override;
JScript
public override function EditComponent(
   context : System.ComponentModel.ITypeDescriptorContext,
   component : System.Object,
   owner : System.Windows.Forms.IWin32Window
) : System.boolean;
Managed Extensions for C++
public: System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Object* component,
   System.Windows.Forms.IWin32Window* owner
) override
C++/CLI
public:
System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Object^ component,
   System.Windows.Forms.IWin32Window^ owner
) override

Parameters

context
component
owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEssentials Class
WebUIComponentEssentials Members
Overload List


EditComponent(Object) Method

[image]
Intersoft WebEssentials Documentation
EditComponent(Object) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebUIComponentEssentials Class > EditComponent Method : EditComponent(Object) Method

component

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function EditComponent( _
   ByVal component As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEssentials
Dim component As System.Object
Dim value As System.Boolean

value = instance.EditComponent(component)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool EditComponent(
   System.object component
)
Delphi
public function EditComponent(
    component: System.TObject
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditComponent(
   component : System.Object
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool EditComponent(
   System.Object* component
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool EditComponent(
   System.Object^ component
)

Parameters

component

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEssentials Class
WebUIComponentEssentials Members
Overload List


EditComponent(Object,IWin32Window) Method

[image]
Intersoft WebEssentials Documentation
EditComponent(Object,IWin32Window) Method
See Also Send comments on this topic.
ISNet.WebUI.WebEssentials Namespace > WebUIComponentEssentials Class > EditComponent Method : EditComponent(Object,IWin32Window) Method

component
owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function EditComponent( _
   ByVal component As System.Object, _
   ByVal owner As System.Windows.Forms.IWin32Window _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEssentials
Dim component As System.Object
Dim owner As System.Windows.Forms.IWin32Window
Dim value As System.Boolean

value = instance.EditComponent(component, owner)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool EditComponent(
   System.object component,
   System.Windows.Forms.IWin32Window owner
)
Delphi
public function EditComponent(
    component: System.TObject;
    owner: System.Windows.Forms.IWin32Window
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditComponent(
   component : System.Object,
   owner : System.Windows.Forms.IWin32Window
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool EditComponent(
   System.Object* component,
   System.Windows.Forms.IWin32Window* owner
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool EditComponent(
   System.Object^ component,
   System.Windows.Forms.IWin32Window^ owner
)

Parameters

component
owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEssentials Class
WebUIComponentEssentials Members
Overload List


ISNet.WebUI.WebEssentials Namespace

ISNet.WebUI.WebEssentials Namespace
See Also Inheritance Hierarchy Send comments on this topic.

Glossary Item Box

Classes

 | Class | Description
Class | WebAccordion | Intersoft WebAccordion.
Class | WebAccordionClientSideEvents | A collection of WebAccordion's client side events.
Class | WebAccordionImagesSettings | A collection of WebAccordion's images settings.
Class | WebAccordionItem | A collection of WebAccordion's Items.
Class | WebAccordionItemCollection | The data collection of Item used by WebAccordion.
Class | WebAccordionItemSettings | A collection of settings which controls the default WebAccordion's Item settings.
Class | WebAccordionNewItemForm |
Class | WebAccordionPresets |
Class | WebCalendar | Intersoft WebCalendar.
Class | WebCalendarClientSideEvents | A collection of WebCalendar's client side events.
Class | WebCalendarHoliday | A collection of Holiday in WebCalendar.
Class | WebCalendarHolidayCollection | A collection of holiday used by WebCalendar.
Class | WebCalendarImagesSettings | A collection of WebCalendar's images settings.
Class | WebCalendarPresets |
Class | WebCalendarSelectedDateEventDataArgs | Provides data for OnSelectedDateChanged event.
Class | WebCalendarSelectedDates | A collection of SelectedDates in WebCalendar.
Class | WebCalendarSelectedDatesCollection | A collection of SelectedDates used by WebCalendar.
Class | WebCalendarTextSettings | A collection of settings which controls the text shown in WebCalendar.
Class | WebCalendarWorkWeekSettings | A collection of WebCalendar's work week settings.
Class | WebContainerViewItem |
Class | WebContainerViewItemBound |
Class | WebExpander | Intersoft WebExpander.
Class | WebExpanderChangedEventDataArgs | Represents the WebExpander collapsed and expanded event argument.
Class | WebExpanderClickEventDataArgs | Represents the WebExpander click event argument.
Class | WebExpanderClientSideEvents | Represents the client side (Javascript) WebExpander html element events.
Class | WebExpanderItem |
Class | WebExpanderItemCollection |
Class | WebExpanderItemSettings |
Class | WebExpanderNewItemForm |
Class | WebExpanderPresets |
Class | WebListBox |
Class | WebListBox.PostBackAction | Specifies PostBackAction of WebListBox.
Class | WebListBoxClientSideEvents | A collection of WebListBox's client side events.
Class | WebListBoxDataSourceInfo | Sets the data source info of WebListBox.
Class | WebListBoxImagesSettings | A collection of WebListBox's images settings.
Class | WebListBoxItem | WebListBoxItem object of WebListBox.
Class | WebListBoxItemCollection | The collection of WebListBoxItem in WebListBox
Class | WebListBoxItemDataBoundEventArgs | Provides data for event when each item is being bound.
Class | WebListBoxLayoutSettings | A collection of WebListBox's layout settings.
Class | WebListBoxPresets |
Class | WebListBoxSelectedItemChangedEventArgs | Provides data for event when selected item is changed.
Class | WebProgressBar | Intersoft WebProgressBar.
Class | WebProgressBarClientSideEvents | Represents the client side (Javascript) WebProgressBar html element events.
Class | WebProgressBarFinishedEventDataArgs | Represents the WebProgressBar finish event argument.
Class | WebProgressBarProgressIntervalEventDataArgs | Represents the WebProgressBar progress interval event argument.
Class | WebProgressBarStartEventDataArgs | Represents the WebProgressBar start event argument.
Class | WebProgressBarValueChangedEventDataArgs | Represents the WebProgressBar value changed event argument.
Class | WebRating | Intersoft WebRating.
Class | WebRatingClientSideEvents | A collection of WebRating's client side events.
Class | WebRatingEventDataArgs | Provides data for OnClick event.
Class | WebRatingImagesSettings | A collection of WebRating's images settings.
Class | WebRatingPresets |
Class | WebSlider | Intersoft WebSlider.
Class | WebSliderClientSideEvents | A collection of WebSlider's client side events.
Class | WebSliderImagesSettings | A collection of WebSlider's images settings.
Class | WebSliderItem | A collection of custom item in WebSlider.
Class | WebSliderItemCollection | A collection of custom item used by WebSlider.
Class | WebSliderPresets |
Class | WebSlidingMenu | Intersoft WebSlidingMenu is an interactive menu that offer different approach in menu system.
Class | WebSlidingMenuBindingEditor |
Class | WebSlidingMenuBindingEditorForm |
Class | WebSlidingMenuClientSideEvents | A collection of WebSlidingMenu's client side events.
Class | WebSlidingMenuEventDataArgs | Provides data for OnInitializeItem event.
Class | WebSlidingMenuEventItemBoundArgs | Provides data for OnItemBound event.
Class | WebSlidingMenuImagesSettings | A collection of WebSlidingMenu's images settings.
Class | WebSlidingMenuItem | WebListBoxItem object of WebListBox.
Class | WebSlidingMenuItemBinding | Represents a bound item which belongs to WebSlidingMenu object.
Class | WebSlidingMenuItemBindingCollection | Summary description for WebSlidingMenuItemBindingCollection.
Class | WebSlidingMenuItemCollection | The collection of WebSlidingMenuItem in WebSlidingMenu
Class | WebSlidingMenuLayoutSettings | A collection of WebSlidingMenu layout settings.
Class | WebSlidingMenuLevel | WebListBoxLevel object of WebListBox.
Class | WebSlidingMenuLevelCollection | The collection of WebSlidingMenuLevel in WebSlidingMenu
Class | WebSlidingMenuPresets |
Class | WebSlidingMenuTextSettings |
Class | WebUIComponentEssentials | Summary description for WebEssentialsComponentEditor.

Delegates

 | Delegate | Description
Delegate | WebCalendarOnSelectedDateChangedEventHandler | Delegates that handles the OnSelectedDateChanged event.
Delegate | WebExpanderOnClickEventHandler |
Delegate | WebExpanderOnCollapsedEventHandler |
Delegate | WebExpanderOnExpandedEventHandler |
Delegate | WebListBoxItemDataBoundEventHandler | Delegates that handles the event when each item is being bound.
Delegate | WebListBoxSelectedItemChangedEventHandler | Delegates that handles the event when selected item is changed.
Delegate | WebProgressBarOnFinishedEventHandler |
Delegate | WebProgressBarOnProgressIntervalEventHandler |
Delegate | WebProgressBarOnStartEventHandler |
Delegate | WebProgressBarOnValueChangedEventHandler |
Delegate | WebRatingOnClickEventHandler | Delegates that handles the OnClick event.
Delegate | WebSlidingMenuEventHandler | Delegates that handles the OnInitializeItem event.
Delegate | WebSlidingMenuEventItemBoundHandler | Delegates that handles the OnItemBound event.

Enumerations

 | Enumeration | Description
Enumeration | PostBackMode |
Enumeration | WebAccordionContentMode | Specifies WebAccordion content mode.
Enumeration | WebAccordionDefaultStyleMode | Specifies DefaultStyle mode in WebAccordion.
Enumeration | WebAccordionExpandDirection | Specifies expand direction of WebAccordion.
Enumeration | WebAccordionHeaderContentMode | Specifies WebAccordion header content mode.
Enumeration | WebAccordionHeaderImageAlignment | Specifies WebAccordion header image alignment.
Enumeration | WebAccordionInteractionMode | Specifies WebAccordion Interaction mode.
Enumeration | WebCalendarDefaultStyleMode | Specifies DefaultStyle mode in WebCalendar.
Enumeration | WebCalendarFirstWeekOfYear | Specifies FirstWeekOfYear in WebCalendar.
Enumeration | WebCalendarHighlightMode | Specifies HighlightMode in WebCalendar.
Enumeration | WebCalendarViewType | Specifies ViewMode in WebCalendar.
Enumeration | WebCalendarWeekViewMode | Specifies WeekViewMode in WebCalendar.
Enumeration | WebExpanderContentType |
Enumeration | WebExpanderFlow |
Enumeration | WebExpanderHeaderContentMode |
Enumeration | WebExpanderIndicatorPosition |
Enumeration | WebExpanderItemState |
Enumeration | WebExpanderItemType |
Enumeration | WebExpanderMode |
Enumeration | WebExpanderStyleMode |
Enumeration | WebListBoxDefaultStyleMode | Specifies default style mode in WebListBox.
Enumeration | WebListBoxDisplayMode | Specifies display mode in WebListBox.
Enumeration | WebListBoxImagePosition | Specifies image position in WebListBox.
Enumeration | WebListBoxItemAlignment | Specifies item alignment in WebListBox.
Enumeration | WebListBoxPostBackMode | Specifies postback mode in WebListBox.
Enumeration | WebListBoxScrollMode | Specifies scroll mode in WebListBox.
Enumeration | WebListBoxSelectionMode | Specifies selection mode in WebListBox.
Enumeration | WebProgressBarMode |
Enumeration | WebProgressBarOrientation |
Enumeration | WebProgressBarStyleMode |
Enumeration | WebRatingDefaultStyleMode | Specifies DefaultStyle mode in WebRating.
Enumeration | WebRatingOrientation | Specifies WebRating orientation.
Enumeration | WebRatingPostBack | Specifies WebRating postback mode.
Enumeration | WebRatingPrecision | Specifies WebRating precision.
Enumeration | WebSliderDefaultStyleMode | Specifies DefaultStyle mode in WebSlider.
Enumeration | WebSliderDirection | Specifies WebSlider Direction.
Enumeration | WebSliderLabelAlignment | Specifies label alignment in WebSlider.
Enumeration | WebSliderOrientation | Specifies WebSlider Orientation.
Enumeration | WebSliderThumbsInteractionMode | Specifies interaction mode of range WebSlider.
Enumeration | WebSliderType | Specifies type of WebSlider.
Enumeration | WebSlidingMenuContentMode |
Enumeration | WebSlidingMenuDefaultStyleMode |
Enumeration | WebSlidingMenuHeaderContentMode |

See Also

Reference

ISNet.WebUI.WebEssentials Assembly


ISNet.WebUI.WebEssentials Namespace Inheritance Hierarchy

ISNet.WebUI.WebEssentials Namespace Inheritance Hierarchy
See Also Send comments on this topic.

Glossary Item Box

Inheritance Hierarchy

System.Object
ISNet.WebUI.DataSourceInfo
ISNet.WebUI.WebEssentials.WebListBoxDataSourceInfo
ISNet.WebUI.WebEssentials.WebAccordionPresets
ISNet.WebUI.WebEssentials.WebCalendarPresets
ISNet.WebUI.WebEssentials.WebExpanderPresets
ISNet.WebUI.WebEssentials.WebListBox.PostBackAction
ISNet.WebUI.WebEssentials.WebListBoxPresets
ISNet.WebUI.WebEssentials.WebRatingPresets
ISNet.WebUI.WebEssentials.WebSliderPresets
ISNet.WebUI.WebEssentials.WebSlidingMenuPresets
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebEssentials.WebSlidingMenuItemBinding
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebEssentials.WebAccordionItem
ISNet.WebUI.WebEssentials.WebCalendarHoliday
ISNet.WebUI.WebEssentials.WebCalendarSelectedDates
ISNet.WebUI.WebEssentials.WebExpanderItem
ISNet.WebUI.WebEssentials.WebListBoxItem
ISNet.WebUI.WebEssentials.WebSliderItem
ISNet.WebUI.WebEssentials.WebSlidingMenuItem
ISNet.WebUI.WebEssentials.WebSlidingMenuLevel
ISNet.WebUI.WebEssentials.WebAccordionClientSideEvents
ISNet.WebUI.WebEssentials.WebAccordionImagesSettings
ISNet.WebUI.WebEssentials.WebAccordionItemSettings
ISNet.WebUI.WebEssentials.WebCalendarClientSideEvents
ISNet.WebUI.WebEssentials.WebCalendarImagesSettings
ISNet.WebUI.WebEssentials.WebCalendarTextSettings
ISNet.WebUI.WebEssentials.WebCalendarWorkWeekSettings
ISNet.WebUI.WebEssentials.WebExpanderClientSideEvents
ISNet.WebUI.WebEssentials.WebExpanderItemSettings
ISNet.WebUI.WebEssentials.WebListBoxClientSideEvents
ISNet.WebUI.WebEssentials.WebListBoxImagesSettings
ISNet.WebUI.WebEssentials.WebListBoxLayoutSettings
ISNet.WebUI.WebEssentials.WebProgressBarClientSideEvents
ISNet.WebUI.WebEssentials.WebRatingClientSideEvents
ISNet.WebUI.WebEssentials.WebRatingImagesSettings
ISNet.WebUI.WebEssentials.WebSliderClientSideEvents
ISNet.WebUI.WebEssentials.WebSliderImagesSettings
ISNet.WebUI.WebEssentials.WebSlidingMenuClientSideEvents
ISNet.WebUI.WebEssentials.WebSlidingMenuImagesSettings
ISNet.WebUI.WebEssentials.WebSlidingMenuLayoutSettings
ISNet.WebUI.WebEssentials.WebSlidingMenuTextSettings
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebEssentials.WebSlidingMenuItemBindingCollection
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebEssentials.WebAccordionItemCollection
ISNet.WebUI.WebEssentials.WebCalendarHolidayCollection
ISNet.WebUI.WebEssentials.WebCalendarSelectedDatesCollection
ISNet.WebUI.WebEssentials.WebExpanderItemCollection
ISNet.WebUI.WebEssentials.WebListBoxItemCollection
ISNet.WebUI.WebEssentials.WebSliderItemCollection
ISNet.WebUI.WebEssentials.WebSlidingMenuItemCollection
ISNet.WebUI.WebEssentials.WebSlidingMenuLevelCollection
System.ComponentModel.ComponentEditor
System.Windows.Forms.Design.WindowsFormsComponentEditor
ISNet.WebUI.WebEssentials.WebUIComponentEssentials
System.Drawing.Design.UITypeEditor
ISNet.WebUI.WebEssentials.WebSlidingMenuBindingEditor
System.EventArgs
ISNet.WebUI.WebEssentials.WebCalendarSelectedDateEventDataArgs
ISNet.WebUI.WebEssentials.WebExpanderChangedEventDataArgs
ISNet.WebUI.WebEssentials.WebExpanderClickEventDataArgs
ISNet.WebUI.WebEssentials.WebListBoxItemDataBoundEventArgs
ISNet.WebUI.WebEssentials.WebListBoxSelectedItemChangedEventArgs
ISNet.WebUI.WebEssentials.WebProgressBarFinishedEventDataArgs
ISNet.WebUI.WebEssentials.WebProgressBarProgressIntervalEventDataArgs
ISNet.WebUI.WebEssentials.WebProgressBarStartEventDataArgs
ISNet.WebUI.WebEssentials.WebProgressBarValueChangedEventDataArgs
ISNet.WebUI.WebEssentials.WebRatingEventDataArgs
ISNet.WebUI.WebEssentials.WebSlidingMenuEventDataArgs
ISNet.WebUI.WebEssentials.WebSlidingMenuEventItemBoundArgs
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ISNet.WebUI.WebEssentials.WebAccordionNewItemForm
ISNet.WebUI.WebEssentials.WebExpanderNewItemForm
ISNet.WebUI.WebEssentials.WebSlidingMenuBindingEditorForm
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebEssentials.WebAccordion
ISNet.WebUI.WebEssentials.WebCalendar
ISNet.WebUI.WebEssentials.WebExpander
ISNet.WebUI.WebEssentials.WebListBox
ISNet.WebUI.WebEssentials.WebProgressBar
ISNet.WebUI.WebEssentials.WebRating
ISNet.WebUI.WebEssentials.WebSlider
ISNet.WebUI.WebEssentials.WebSlidingMenu
System.Web.UI.WebControls.Panel
ISNet.WebUI.WebEssentials.WebContainerViewItem
ISNet.WebUI.WebEssentials.WebContainerViewItemBound

See Also

Reference

ISNet.WebUI.WebEssentials Assembly


License Agreement

License Agreement
Send comments on this topic.
Intersoft WebEssentials > Licensing > License Agreement

Glossary Item Box

Software License Agreement for Intersoft Solutions Corp.

VERY IMPORTANT -- By installing the WebEssentials Version 1.0 software (herein the 'SOFTWARE') developed by Intersoft Solutions Corp (hereinafter the 'VENDOR'), you are accepting the following License Agreement.

I. LICENSE AGREEMENT. This is a legal agreement between you (either an individual or a single entity) and VENDOR. By installing the SOFTWARE you are agreeing to be bound by the terms of this agreement. If you do not agree to the terms of this agreement, please kindly click the [CANCEL] icon to exit now. The installation process will be immediately terminated.

II. OWNERSHIP; GRANT OF LICENSE. This is a license agreement and NOT an agreement for sale. The VENDOR hereby grants to you, and you accept, a non-exclusive, non-transferable license to use, copy and modify the SOFTWARE only as authorized below.

III. PERMITTED USES. This LICENSE grants you the following rights:

A. The SOFTWARE is licensed per individual developer. You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same developer. If you have purchased a "multi-pack" license, you may use a copy of the SOFTWARE identified in the multi-pack on the number of computers associated with the multi-pack (e.g. a five user multi-pack allows you to use the SOFTWARE on up to five computers concurrently or by five different developers, the ten user multi-pack on up to ten computers concurrently or by ten different developers). The SOFTWARE is in "use" on a computer when it is loaded into temporary memory (i.e. RAM) or installed into permanent memory (e.g. hard disk, CD-ROM, or other storage devise) of that computer. However, installation on a network server for the sole purpose of internal distribution to one or more other computer(s) shall not constitute "use" for which a separate license is required, provided you have a separate license for each computer to which the SOFTWARE is distributed.

B. Solely with respect to electronic documents included with the SOFTWARE, you may make a copy (either in hardcopy or electronic form) for each developer for which the Software has been licensed as described in Section III.A, above; provided, that such copies shall be used only by such developer for internal purposes and are not to be republished or distributed to any other third party.

C. Runtime and redistributable files. You may deploy your web applications using the SOFTWARE to any number of production server or clients with no additional charges. The SOFTWARE runtime files shouldn't be modified in any ways prior to deploying and all copyright notices should be retain.

IV. PROHIBITED USES. You may not, without the prior written permission of the VENDOR:

A. Disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.

B. Use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.

C. Transfer, rent, lease, or sublicense the SOFTWARE.

D. Separate the software programs comprising the SOFTWARE for use by more than one user at a time.

V. COPYRIGHT. All title and copyrights in and to the SOFTWARE (including but not limited to any images, photographs, animation, video, audio, music, text and "applets" incorporated into the SOFTWARE) and the accompanying printed materials are owned by the VENDOR or its suppliers. The SOFTWARE is protected by Indonesian copyright laws and international treaty provisions. All rights are reserved worldwide. You must treat the SOFTWARE like any other copyrighted material, except that you may, in addition to the copies permitted in this LICENSE, make one copy of the SOFTWARE solely for backup or archival purposes. No part of the accompanying printed materials may be reproduced, transmitted, transcribed, stored in any retrieval system, or translated into any language by any means without the express prior written permission of the VENDOR.

VI. TERMINATION

A. This LICENSE and your right to use the SOFTWARE will terminate immediately without notice from the VENDOR if you fail to comply with the terms and conditions of this LICENSE. Upon termination, you agree to destroy the SOFTWARE, including all accompanying documents and copies. This is in addition to and not in lieu of any criminal, civil or other remedies available to the VENDOR.

B. The VENDOR has the right to perform temporary or permanent TERMINATION to this LICENSE upon the detection of license violation described in Section III A. The SOFTWARE has implemented Installation Tracker which is used to increment the number of installations during the installation of SOFTWARE. Related to Section III A, the LICENSE will be temporarily or permanently terminated upon the detection of unauthorized transfer or distribution of the LICENSE to either private or public web site, or to ANY medium.

C. ANY VIOLATION TO THE COPYRIGHT, OR TO THIS LICENSE AGREEMENT, MAY RESULT IN SEVERE CIVIL AND CRIMINAL PENALTIES, AND WILL BE PROSECUTED TO THE MAXIMUM EXTENT POSSIBLE UNDER THE LAW.

VII. LIMITED WARRANTY.

A. The VENDOR warrants that the SOFTWARE will perform substantially in accordance with the accompanying printed materials or officially "online" documented materials for a period of thirty (30) days from the date of receipt. The VENDOR does not warranty that the SOFTWARE will be error-free.

B. Your exclusive remedy under the performance warranty set forth in Section X.A, shall be, at VENDOR's option, either (a) return of the purchase price paid, or (b) repair or replacement of the defective SOFTWARE. SOFTWARE purchased other than directly from the VENDOR shall be returned to the place it was purchased. This limited warranty is void if failure of the SOFTWARE has resulted from accident, abuse, or misapplication. Any replacement SOFTWARE will be warranted for the remainder of the original thirty (30) day period.


Licensing

Licensing
Send comments on this topic.
Intersoft WebEssentials > Licensing

Glossary Item Box

This topic provides links to information about the licensing mechanism in WebCombo which includes design-time licensing for development seat and application licensing for deployment. The link to the software license agreement is also provided in the sections below.

In This Section

License Agreement

Contains information about Software License Agreement for Intersoft Solutions Corp.

Copyright Information

Provides information about Copyright for Intersoft Solutions products.


How-to: Modify WebExpander Expand Direction

How-to: Modify WebExpander Expand Direction
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebExpander > WebExpander How-to Topics > How-to: Modify WebExpander Expand Direction

Glossary Item Box

WebExpander provides 4 expansion flow which are up, down, left, and right.

This topic will show you how to modify WebExpander expand direction.

To modify expand direction

  1. Right-click on WebExpander control and choose Properties.
  2. Set Flow to either Down, Up, Right or Left.
  3. Run the project.

See Also

Tasks
How-to Topics

Other Resources
Flexible View Customization


How-to: Modify WebExpander Mode

How-to: Modify WebExpander Mode
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebExpander > WebExpander How-to Topics > How-to: Modify WebExpander Mode

Glossary Item Box

WebExpander provides two expand modes which are Fixed and Flow.

This topic will show you how to modify WebExpander mode.

To modify WebExpander mode

  1. Right-click on WebExpander control and choose Properties.
  2. Set Mode to either Flow or Fixed.
  3. Run the project.

See Also

Tasks
How-to Topics


How-to: Modify WebProgressBar indeterminate animation

How-to: Modify WebProgressBar indeterminate animation
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebProgressBar > WebProgressBar How-to Topics > How-to: Modify WebProgressBar indeterminate animation

Glossary Item Box

In indeterminate mode, WebProgressBar provides properties to control the animation which are Step and AnimationLatency.

This topic will show you how to modify WebProgressBar indeterminate animation.

To modify WebProgressBar indeterminate animation

  1. Right-click on WebProgressBar control and choose Properties.
  2. Set Step property to determine how far the ProgressBar will move after each tick. The default value is 0.01.
  3. Set AnimationLatency to determine how fast is the next tick. The default value is 500 ms.
  4. Run the project.

See Also

Tasks
{How-to Topics}

Other Resources
{Appearance and Styles}


How-to: Modify WebProgressBar mode

How-to: Modify WebProgressBar mode
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebProgressBar > WebProgressBar How-to Topics > How-to: Modify WebProgressBar mode

Glossary Item Box

WebProgressBar provides two progress mode, which are determinate and indeterminate.

This topic will show you how to modify WebProgressBar mode.

To modify WebProgressBar mode

  1. Right-click on WebProgressBar control and choose Properties.
  2. Set Mode to either Determinate or Indeterminate.
  3. Run the project.

See Also

Tasks
{How-to Topics}

Other Resources
{Flexible Behavior Customization}


How-to: Modify WebProgressBar orientation

How-to: Modify WebProgressBar orientation
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebProgressBar > WebProgressBar How-to Topics > How-to: Modify WebProgressBar orientation

Glossary Item Box

WebProgressBar supports vertical and horizontal orientations.

This topic will show you how to modify WebProgressBar orientation.

To modify WebProgressBar orientation

  1. Right-click on WebProgressBar control and choose Properties.
  2. Set Orientation to either Horizontal or Vertical.
  3. Run the project.

See Also

Tasks
{How-to Topics}

Other Resources
{Flexible View Customization}


How-to: Modify WebProgressBar rounded corner

How-to: Modify WebProgressBar rounded corner
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebProgressBar > WebProgressBar How-to Topics > How-to: Modify WebProgressBar rounded corner

Glossary Item Box

WebProgressBar is able to make the bar rounded corner.

This topic will show you how to modify WebProgressBar rounded corner.

To modify WebProgressBar rounded corner

  1. Right-click on WebProgressBar control and choose Properties.
  2. Set UseRoundCorner to True.
  3. You need to use the border-radius CSS 3 property in order to make the progress bar more/less rounded. Put the following code in the ProgressContainerBarStyle and ProgressBarStyle custom rules.

    <ProgressContainerBarStyle CustomRules="-moz-border-radius: 3px; -webkit-border-radius: 3px; -khtml-border-radius: 3px; border-radius: 3px;">
    </ProgressContainerBarStyle>

    <ProgressBarStyle CustomRules="-moz-border-radius: 3px; -webkit-border-radius: 3px; -khtml-border-radius: 3px; border-radius: 3px;">
    </ProgressBarStyle>

  4. Run the project.

See Also

Tasks
{How-to Topics}

Other Resources
{Appearance and Styles}


New Topic

New Topic
Send comments on this topic.

Glossary Item Box


NonContextualTabGroup

NonContextualTabGroup
Send comments on this topic.
Intersoft WebEssentials > Client-side References > NonContextualTabGroup

Glossary Item Box

NonContextualTabGroup Properties

RibbonTabs Description
The non-contextual WebRibbonTab collection.

ValueType
Array

Default Value


How-to: Perform FlyPostback in WebCalendar

How-to: Perform FlyPostback in WebCalendar
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebCalendar > WebCalendar How-to Topics > How-to: Perform FlyPostback in WebCalendar

Glossary Item Box

WebCalendar offers two postback modes, which are FullPostback and FlyPostback.

This topic will show you how to perform FlyPostback in WebCalendar.

To perform FlyPostback

  1. Right-click on WebCalendar control and choose Properties.
  2. Set PostBackMode to FlyPostBack.
  3. When you run the page in FlyPostBack mode, it will trigger a server-side event called SelectedDateChanged.

See Also

Tasks
How-to: Perform FlyPostback in WebCalendar
How-to Topics

Other Resources
Integrated to FullPostback and FlyPostback (or AJAX)


How-to: Perform FlyPostback in WebRating

How-to: Perform FlyPostback in WebRating
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebRating > WebRating How-to Topics > How-to: Perform FlyPostback in WebRating

Glossary Item Box

WebRating offers two postback modes, which are FullPostback and FlyPostback.

This topic will show you how to perform FullPostback in WebRating.

To perform FlyPostback

  1. Right-click on WebRating control and choose Properties.
  2. Set PostBackMode to FlyPostBack.
  3. When you run the page in FlyPostBack mode, it will trigger a server-side event called Click.

See Also

Tasks
How-to: Perform FullPostback in WebRating
How-to Topics

Other Resources
Integrated with FullPostback and FlyPostback (or AJAX)


How-to: Perform FullPostback in WebCalendar

How-to: Perform FullPostback in WebCalendar
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebCalendar > WebCalendar How-to Topics > How-to: Perform FullPostback in WebCalendar

Glossary Item Box

WebCalendar offers two postback modes, which are FullPostback and FlyPostback.

This topic will show you how to perform FullPostback in WebCalendar.

To perform FullPostback

  1. Right-click on WebCalendar control and choose Properties.
  2. Set PostBackMode to FullPostBack.
  3. When you run the page in FullPostBack mode, it will trigger a server-side event called SelectedDateChanged.

See Also

Tasks
How-to: Perform FlyPostback in WebCalendar
How-to Topics

Other Resources
Integrated to FullPostback and FlyPostback (or AJAX)


How-to: Perform FullPostback in WebRating

How-to: Perform FullPostback in WebRating
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebRating > WebRating How-to Topics > How-to: Perform FullPostback in WebRating

Glossary Item Box

WebRating offers two postback modes, which are FullPostback and FlyPostback.

This topic will show you how to perform FullPostback in WebRating.

To perform FullPostback

  1. Right-click on WebRating control and choose Properties.
  2. Set PostBackMode to FullPostBack.
  3. When you run the page in FullPostBack mode, it will trigger a server-side event called Click.

See Also

Tasks
How-to: Perform FlyPostback in WebRating
How-to Topics

Other Resources
Integrated with FullPostback and FlyPostback (or AJAX)


Walkthrough: Performing WebSlidingMenu data binding

Walkthrough: Performing WebSlidingMenu data binding
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Data Binding > Walkthrough: Performing WebSlidingMenu data binding

Glossary Item Box

This walkthrough shows you how to create and bind WebSlidingMenu to XmlDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use XmlDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to XML database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebSlidingMenu to XmlDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Right-click on WebSlidingMenu control and choose Properties.
  11. In DataSourceID property, choose <New data source...>.

  12. In Data Source Configuration Wizard, choose XML File and click OK.

  13. Set the Data File and XPath expression then click OK.

  14. Add Root, Parent and Leaf in Selected data bindings. Set NameField and TextField to Name in each property.

  15. Run the project and the WebGrid will look like following.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Concepts
{Data Binding Editor}


RadioButtonGroup

RadioButtonGroup
Send comments on this topic.
Intersoft WebEssentials > Client-side References > RadioButtonGroup

Glossary Item Box

RadioButtonGroup Properties

Name | Description Gets name of radio button group. This name is reflected from GroupName property of group-item with GroupItemType.ToggleButton and ToggleButtonMode.RadioButton. ValueType String Default Value
Items | Description The WebRibbonGroupItem collection with same group name. ValueType Array Default Value


Selection Mode

Selection Mode
See Also Send comments on this topic.

Glossary Item Box

This topic discusses more advanced WebListBox's Selection Mode features in depth, which contains the following topics.

  • Set Selected Item(s) On Load
  • Get Selected value

Set Selected Item(s) On Load

See Also

Other Resources
{User Interface}
{Scroll Mode}


Server-side References

Server-side References
Send comments on this topic.
Intersoft WebEssentials > Server-side References

Glossary Item Box

This section is designated to help user working with server-side references in WebEssentials.


How-to: Set Selected Items on Load

How-to: Set Selected Items on Load
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > WebListBox How-to Topics > How-to: Set Selected Items on Load

Glossary Item Box

WebListBox provides features that enable user to set selected items in single or multiple mode.

This topic will show you how to set selected items on load.

To set selected items on load

  1. Right-click on WebListBox control and choose Properties.
  2. Set SelectedIndex to any item index you want to select.
  3. To select multiple items on load, simply set SelectionMode to Multiple. Note that SelectedIndex property should be set to -1 so that the below configuration is used
  4. Go to Items and click the collection button.
  5. You can set Selected to True in each item you want to select.

See Also

Tasks
{How-to Topics}

Other Resources
{Set Selected Item(s) On Load}


How-to: Set WebAccordion's item through item specific settings

How-to: Set WebAccordion's item through item specific settings
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebAccordion > WebAccordion How-to Topics > How-to: Set WebAccordion's item through item specific settings

Glossary Item Box

You can use individual settings if you want to customize a specific pane further.

This topic will show you how to set WebAccordion's item through item specific settings.

To set WebAccordion's item through item specific settings

  1. Right-click on WebAccordion control and choose Properties.
  2. Go to Items and click the collection button.
  3. Add a WebAccordion's item. You can set ContentMode, ContentURL, HeaderContentMode, HeaderImageAlignment, HeaderImageSize, HeaderImageURL and HeaderText.
  4. Whenever you add an item, you can set each property in more specific.

See Also

Tasks
How-to: Set WebAccordion's items through general settings
How-to Topics

Other Resources
Global and individual item settings


How-to: Set WebAccordion's items through general settings

How-to: Set WebAccordion's items through general settings
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebAccordion > WebAccordion How-to Topics > How-to: Set WebAccordion's items through general settings

Glossary Item Box

The global settings are particularly useful when you have numerous panes with same configurations, so you can quickly setup a WebAccordion's pane without having to specify it in each pane.

This topic will show you how to set WebAccordion's items through general settings.

To set WebAccordion's items through general settings

  1. Right-click on WebAccordion control and choose Properties.
  2. Expand ItemSettings. You can set ContentMode, HeaderContentMode, HeaderImageAlignment and HeaderImageSize.
  3. Whenever you add WebAccordion item, it will automatically use the settings configured in ItemSettings.

See Also

Tasks
How-to: Set WebAccordion's item through item specific settings
How-to Topics

Other Resources
Global and individual item settings


How-to: Set/Change Item label alignment in WebSlider

How-to: Set/Change Item label alignment in WebSlider
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlider > WebSlider How-to Topics > How-to: Set/Change Item label alignment in WebSlider

Glossary Item Box

WebSlider provides feature to control the item's alignment.

This topic will show you how to set/change item label alignment in WebSlider.

To set/change item label alignment

  1. Right-click on WebSlider control and choose Properties.
  2. Set SliderType to either Tick or Item.
  3. Set SliderLabelAlignment to either Left, Right or LeftAndRight.
  4. Run the project.
If you set SliderType to Item, you should specify WebRating Item collection. Please refer to How-to: Specify custom WebSlider item.

See Also

Tasks
How-to Topics

Other Resources
Item Alignment


How-to: Set/Change WebAccordion's ExpandDirection

How-to: Set/Change WebAccordion's ExpandDirection
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebAccordion > WebAccordion How-to Topics > How-to: Set/Change WebAccordion's ExpandDirection

Glossary Item Box

WebAccordion provides 4 expand direction, which are top, bottom, left and right.

This topic will show you how to set/change WebAccordion's ExpandDirection.

To set/change WebAccordion's ExpandDirection

  1. Create WebAccordion with Inline content / Create WebAccordion with IFrame content.
  2. In Properties window, set ExpandDirection to either Top, Bottom, Left or Right.
  3. Run the project.

See Also

Tasks
How-to: Set/Change WebAccordion's ExpandIndex
How-to: Set/Change WebAccordion's InteractionMode
How-to Topics

Other Resources
Flexible layout and behavioral customization


How-to: Set/Change WebAccordion's ExpandIndex

How-to: Set/Change WebAccordion's ExpandIndex
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebAccordion > WebAccordion How-to Topics > How-to: Set/Change WebAccordion's ExpandIndex

Glossary Item Box

WebAccordion provides ExpandIndex property to determine which specific pane should be expanded initially.

This topic will show you how to set/change WebAccordion's ExpandIndex.

To set/change WebAccordion's ExpandIndex

  1. Create WebAccordion with Inline content / Create WebAccordion with IFrame content.
  2. In Properties window, set ExpandIndex to any pane's index you want to expand initially.
  3. Run the project.
When ExpandIndex is set to -1 then none of WebAccordion item will be expanded when first load.

See Also

Tasks
How-to: Set/Change WebAccordion's ExpandDirection
How-to: Set/Change WebAccordion's InteractionMode
How-to Topics

Other Resources
Flexible layout and behavioral customization


How-to: Set/Change WebAccordion's InteractionMode

How-to: Set/Change WebAccordion's InteractionMode
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebAccordion > WebAccordion How-to Topics > How-to: Set/Change WebAccordion's InteractionMode

Glossary Item Box

WebAccordion provides three type of interaction mode, which are MouseOver, Click and Both.
  • MouseOver
    WebAccordion will start expanding or collapsing when a cursor hovers and stops on an item (or pane) for a specific duration. Complementing this behavior, DisplayLatency property is provided - enabling you to control the mouse over state duration. The default value is 500 ms.
  • Click
    WebAccordion will start expanding or collapsing when the item's header is clicked.
  • Both
    Combining both MouveOver and Click modes, WebAccordion will respond to a mouse click or mouse over.
This topic will show you how to set/change WebAccordion InteractionMode.

To set/change WebAccordion InteractionMode

  1. Create WebAccordion with Inline content / Create WebAccordion with IFrame content.
  2. In Properties window, set InteractionMode to either MouseOver, Click or Both.
  3. Run the project.

See Also

Tasks
How-to: Set/Change WebAccordion's ExpandDirection
How-to: Set/Change WebAccordion's ExpandIndex
How-to Topics

Other Resources
Flexible layout and behavioral customization


How-to: Set/Change WebCalendar FirstDayOfWeek

How-to: Set/Change WebCalendar FirstDayOfWeek
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebCalendar > WebCalendar How-to Topics > How-to: Set/Change WebCalendar FirstDayOfWeek

Glossary Item Box

The default value for this property is Sunday.

This topic will show you how to set/change WebCalendar FirstDayOfWeek.

To set/change WebCalendar FirstDayOfWeek

  1. Right-click on WebCalendar control and choose Properties.
  2. Set FirstDayOfWeek to any day you want, such as Monday, Tuesday and etc.
  3. Run the project.

See Also

Tasks
How-to Topics

Other Resources
FirstDayOfWeek


How-to: Set/Change WebCalendar FirstWeekOfYear

How-to: Set/Change WebCalendar FirstWeekOfYear
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebCalendar > WebCalendar How-to Topics > How-to: Set/Change WebCalendar FirstWeekOfYear

Glossary Item Box

Three options are available in FirstWeekOfYear properties, such as:

  • First4DayWeek
    The first week is the week which has at least 4 days. This is WebCalendar's default value.

  • StartOn1January
    The first week always starts from January 1st.

  • FirstFullWeek
    The first week is the full week, which has exact 7 days.

This topic will show you how to set/change WebCalendar FirstWeekOfYear.

To set/change WebCalendar FirstWeekOfYear

  1. Right-click on WebCalendar control and choose Properties.
  2. Set FirstWeekOfYear to either First4DayWeek, StartOn1January or FirstFullWeek.
  3. Run the project.

See Also

Tasks
How-to Topics

Other Resources
FirstWeekOfYear


How-to: Set/Change WebCalendar HighlightMode

How-to: Set/Change WebCalendar HighlightMode
See Also Send comments on this topic.

Glossary Item Box

You can customize highlight mode in WebCalendar.

This topic will show you how to set/change WebCalendar HighlightMode.

To set/change WebCalendar HighlightMode

  1. Right-click on WebCalendar control and choose Properties.
  2. Set HighlightMode to either Day, Month, Week and Custom.
  3. Run the project.
HighlightMode is only applicable when ViewMode is set to Month.

See Also

Tasks
{How-to: Set/Change WebCalendar WeekViewMode}
{How-to Topics}

Other Resources
{Behavioral configuration}


How-to: Set/Change WebCalendar ViewMode

How-to: Set/Change WebCalendar ViewMode
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebCalendar > WebCalendar How-to Topics > How-to: Set/Change WebCalendar ViewMode

Glossary Item Box

Three view modes are provided, Month, Quarter, and Year.

This topic will show you how to set/change WebCalendar ViewMode.

To set/change WebCalendar ViewMode

  1. Right-click on WebCalendar control and choose Properties.
  2. Set ViewMode to either Month, Quarter or Year.
  3. Run the project.

See Also

Tasks
How-to Topics

Other Resources
View customization


How-to: Set/Change WebCalendar WeekViewMode

How-to: Set/Change WebCalendar WeekViewMode
See Also Send comments on this topic.

Glossary Item Box

WebCalendar allows user to customize WeekViewMode property.

This topic will show you how to set/change WebCalendar WeekViewMode.

To set/change WebCalendar WeekViewMode

  1. Right-click on WebCalendar control and choose Properties.
  2. Set WeekViewMode to either FullWeek or WorkWeek.
  3. Run the project.
WeekViewMode is only applicable when HighlightMode is set to Week.

See Also

Tasks
{How-to: Set/Change WebCalendar HighlightMode}
{How-to Topics}

Other Resources
{Behavioral configuration}


How-to: Set/Change WebRating Direction

How-to: Set/Change WebRating Direction
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebRating > WebRating How-to Topics > How-to: Set/Change WebRating Direction

Glossary Item Box

By default, the rating direction will automatically follow its orientation, from left-to-right or top-to-bottom.

This topic will show you how to set/change WebRating direction.

To set/change WebRating direction

  1. Right-click WebRating control and choose Properties.
  2. Set IsReversed to True.
  3. Run the project. The rating direction will be reversed from its default behavior.

See Also

Tasks
How-to: Set/Change WebRating Orientation
How-to Topics

Other Resources
Flexible Orientation and Direction


How-to: Set/Change WebRating Item number

How-to: Set/Change WebRating Item number
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebRating > WebRating How-to Topics > How-to: Set/Change WebRating Item number

Glossary Item Box

WebRating offers the flexibility to add or reduce the number of star (item).

This topic will show you how to set/change WebRating item number.

To set/change WebRating item number

  1. Right-click on WebRating control and choose Properties.
  2. Set ItemCount to 3 or any item number you want to use.
  3. Run the project.

See Also

Tasks
How-to Topics

Other Resources
Flexible Number of Item


How-to: Set/Change WebRating Orientation

How-to: Set/Change WebRating Orientation
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebRating > WebRating How-to Topics > How-to: Set/Change WebRating Orientation

Glossary Item Box

WebRating offers two orientations which are horizontal and vertical.

This topic will show you how to set/change WebRating orientation.

To set/change WebRating orientation

  1. Right-click on WebRating control and choose Properties.
  2. Set Orientation to either Horizontal or Vertical.
  3. Run the project.

See Also

Tasks
How-to: Set/Change WebRating Direction
How-to Topics

Other Resources
Flexible Orientation and Direction


How-to: Set/Change WebRating precision behavior

How-to: Set/Change WebRating precision behavior
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebRating > WebRating How-to Topics > How-to: Set/Change WebRating precision behavior

Glossary Item Box

WebRating offers three rating precision options, which are Whole, Half and Exact Position.

This topic will show you how to set/change WebRating precision behavior.

To set/change WebRating prevision behavior

  1. Right-click on WebRating control and choose Properties.
  2. Set Precision to either Whole, Half or Exact Position.
  3. Run the project.

See Also

Tasks
How-to Topics

Other Resources
Customizable Rating Precision


How-to: Set/Change WebSlider Direction

How-to: Set/Change WebSlider Direction
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlider > WebSlider How-to Topics > How-to: Set/Change WebSlider Direction

Glossary Item Box

WebSlider also offers 4 direction options that work conjunctionally with the orientation setting.

This topic will show you how to set/change WebSlider direction.

To set/change WebSlider direction

  1. Right-click on WebSlider control and choose Properties.
  2. Set Direction to either LeftToRight, RightToLeft, TopToBottom and BottomToTop.
  3. Run the project. LeftToRight and RightToLeft are applicable when you set Orientation to Horizontal. TopToBottom and BottomToTop are applicable when you set Orientation to Vertical.

See Also

Tasks
How-to: Set/Change WebSlider Orientation
How-to Topics

Other Resources
Flexible Layout and Behavior Customization


How-to: Set/Change WebSlider Orientation

How-to: Set/Change WebSlider Orientation
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlider > WebSlider How-to Topics > How-to: Set/Change WebSlider Orientation

Glossary Item Box

WebSlider offers two orientations which are horizontal and vertical.

This topic will show you how to set/change WebSlider orientation.

To set/change WebSlider orientation

  1. Right-click on WebSlider control and choose Properties.
  2. Set Orientation to either Horizontal or Vertical.
  3. Run the project.

See Also

Tasks
How-to: Set/Change WebSlider Direction
How-to Topics

Other Resources
Flexible Layout and Behavior Customization


How-to: Show/Hide item next indicator

How-to: Show/Hide item next indicator
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Understanding WebSlidingMenu User Interface > How-to: Show/Hide item next indicator

Glossary Item Box

WebSlidingMenu provides feature to show/hide item next indicator.

This topic will show you how to display item next indicator.

To show/hide item next indicator

  1. Right-click on WebSlidingMenu control and choose Properties.
  2. Go to LayoutSettings and set ShowNextIndicator to True. Set the property to False to hide the indicator.
  3. Run the project.

See Also

Tasks
How-to: Customize Item Height
How-to: Customize Header Height
How-to: Show/Hide item previous indicator
Walkthrough Topics
{How-to Topics}


How-to: Show/Hide item previous indicator

How-to: Show/Hide item previous indicator
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Understanding WebSlidingMenu User Interface > How-to: Show/Hide item previous indicator

Glossary Item Box

WebSlidingMenu provides feature to show/hide item previous indicator.

This topic will show you how to display item previous indicator.

To show/hide item previous indicator

  1. Right-click on WebSlidingMenu control and choose Properties.
  2. Go to LayoutSettings and set ShowPreviousIndicator to True. Set the property to False to hide the indicator.
  3. Run the project.

See Also

Tasks
How-to: Show/Hide item next indicator
How-to: Customize Header Height
How-to: Customize Item Height
{Walkthrough Topics}
{How-to Topics}


How-to: Specify Custom Item Styles

How-to: Specify Custom Item Styles
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > Understanding WebListBox User Interface > Understanding WebListBox User Interface How-to Topics > How-to: Specify Custom Item Styles

Glossary Item Box

WebSlidingMenu provides feature to specify custom item styles.

This topic will show you how to use custom item styles.

To use custom item styles

  1. Right-click on WebSlidingMenu control and choose Properties.
  2. Go to ItemStyle. There are 3 sections provided in ItemStyle, i.e. Active, Normal and Over. You can freely customize the properties in each section and see the result.
  3. Run the project.

See Also

Tasks
How-to: Customize Item Height
How-to: Customize Header Height
How-to: Show/Hide item next indicator
How-to: Show/hide item previous indicator
Walkthrough Topics
How-to Topics

Concepts
Item Style


How-to: Specify Custom Item Styles for Specific Items

How-to: Specify Custom Item Styles for Specific Items
See Also Send comments on this topic.

Glossary Item Box

WebListBox provides feature to enable user to use their own custom styles.

This topic will show you how to specify custom item styles for specific items.

To specify custom item styles for specific items

  1. Customize Display Mode.
  2. You can assign CSS class to the following properties: ItemNormalClass, ItemHoverClass, ItemActiveClass, ItemTextClass, and ItemImageClass.
  3. Run the project.
To configure custom item styles globally, you need to configure ItemStyle, ItemTextStyle, and ItemImageStyle properties.

See Also

Tasks
{How-to Topics}


How-to: Specify custom WebSlider item

How-to: Specify custom WebSlider item
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlider > WebSlider How-to Topics > How-to: Specify custom WebSlider item

Glossary Item Box

WebSlider provides features to allow use to create a custom WebSlider item.

This topic will show you how to specify custom WebSlider item.

To specify custom WebSlider item

  1. Right-click WebSlider control and choose Properties.
  2. Go to Items and click the collection button.
  3. Add three members and set each member like following:
    • Text to Easy, Value to 1.
    • Text to Normal, Value to 2.
    • Text to Hard, Value to 3.

  4. Set MinimumValue to 1 and MaximumValue to 3.
  5. Set SliderType to Item and Value to 2 in order to make Normal level as the default selection.
  6. Run the project.

See Also

Tasks
How-to Topics

Other Resources
Custom WebSlider Item


How-to: Specify Holiday(s) in WebCalendar

How-to: Specify Holiday(s) in WebCalendar
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebCalendar > WebCalendar How-to Topics > How-to: Specify Holiday(s) in WebCalendar

Glossary Item Box

WebCalendar provides holiday feature, which essentially enables you to define holiday easily. By default, a holiday is rendered in red.

This topic will show you how to specify holiday in WebCalendar.

To specify holiday in WebCalendar

  1. Right-click on WebCalendar control and choose Properties.
  2. Go to Holidays and click the collection button.
  3. Add a member. Specify the Date, Description and Name.

  4. Run the project. IsGeneral property indicates whether the holiday occurs annually or occasionally.
Holiday style is rendered based on HolidayStyle property.

See Also

Tasks
How-to Topics

Other Resources
Supports holiday


How-to: Specify localization in WebCalendar

How-to: Specify localization in WebCalendar
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebCalendar > WebCalendar How-to Topics > How-to: Specify localization in WebCalendar

Glossary Item Box

WebCalendar enables you to select culture format.

This topic will show you how to specify localization in WebCalendar.

To specify localization

  1. Right-click on WebCalendar control and choose Properties.
  2. Set Culture to any format you want to use.
  3. Expand TextSettings. You will find there properties that you can set, such as CalendarHeaderText, CalendarNextArrowText and CalendarPrevArrowText.
  4. Run the project.

See Also

Tasks
How-to Topics

Other Resources
Localization and various text settings


Support and Community

Support and Community
Send comments on this topic.
Intersoft WebEssentials > Support and Community

Glossary Item Box

Intersoft Solutions provides full product support for the ClientUI targeting Silverlight 3, Silverlight 4 and WPF 4 platform. This topic outlines a number of ways to get product support, get involved with the community, as well as obtaining product updates.

Blogs

Intersoft ClientUI development team members and community leaders author a variety of blogs that target Silverlight and WPF development in general using the recommended guidelines and best practice. The blogs often discuss interesting topics such as using MVVM pattern with rich user interface controls, database access and connectivity challenges, as well as samples, videos and latest development news.

Visit Intersoft ClientUI Blog.

Forums

The Intersoft Community Forums is the best place where you can post your questions and technical problems, as well as discussing on the latest application development trend around ClientUI, Silverlight and WPF.

Blending the modern minimalist styling and lightweight user interface, Intersoft Community is designed to be your most resource-wealth technical community center. You can create a new thread to ask question or simply to start a discussion, reply other user's questions or rate your most favorite threads – everything you need for a productive forum activity.

Visit Intersoft Community Forums.

Support Center

Intersoft Support Center provides a wealth of product resources and literatures that help you quickly find the solutions to your problems. With the intuitive navigation, you can quickly navigate to a product page, read the tutorial, watch getting started videos, browse knowledge base and latest development blogs and more.

Visit Intersoft Support Center.

Feedback Center

Issues can sometimes be difficult to resolve, or irresolvable. Such situations arise because of bugs in the technology, difficulties applying the technology to particular scenarios, or lack of support for particular scenarios. This information is important to Intersoft, and can be provided via the Product Feedback Center in Intersoft Developer Network.

Intersoft Developer Network is a web-based portal for its customers to send feedback, work with support inquiries, manage development accounts and download licensed products. You can use the user credentials in the purchase receipt email that sent from Intersoft Accounts when you purchased the product.

Items posted on the Product Feedback Center are routed to the Intersoft team's internal database. Consequently, it is the most reliable way to get your feedback to the product feature owner. In addition, you can validate and track suggestions and bugs as well as vote on them, which helps the ClientUI team to prioritize issues and feature requests.

Contact Technical Support

Depending on the support level agreement (SLA) as part of the benefits that you received from your purchase, you can contact our technical support through various ways such as email or phone call. More comprehensive support levels such as instant messaging and real-time web-based chat support are also provided. Please visit Intersoft Support Level site to learn your support benefits and find out the most convenient way for you to contact us.

Checking for Product Updates

ClientUI is now a fully managed Intersoft WebUI Studio® product in which it can be updated in the same way and manner using the same tool as in the other WebUI Studio® family product. Product hotfixes are released on monthly basis to provide the most time-efficient enhancements and values to existing customers. To check, download and install for updates, simply launch Update Manager from Intersoft WebUI Studio program group.

The following illustration shows the Update Manager application interface.

Bug Reports

When submitting a bug report, make sure you have following information to avoid multiple communication roundtrip:

  • Product Edition (if applicable)
  • Full Product Version. Eg: 1.0.1500
  • Browsers (with Full Version, including Service Packs or HotFixes if any)
  • Operating System (with Full Version, including Service Packs or HotFixes if any)
  • Development Environment Products
  • Development Environment Versions
  • Affected Machines: Development, Production Server or Both
  • Monitors: Single or Dual

You also might need to provide issue-specific information such as:

  • Current result/behavior
  • Expected result/behavior
  • Steps to reproduce
  • Working/Compilable Samples


Support Options

Support Options
Send comments on this topic.
Intersoft WebEssentials > Support and Community > Support Options

Glossary Item Box

Intersoft Presenter is developed and fully supported by Intersoft Solutions Corp. The company provides several methods for registered customers to obtain technical supports.

Online Support

All of Intersoft Presenter users have free access to our online support at www.intersoftpt.com which includes latest product updates, bug fixes, FAQ, hundreds of Knowledge Base Articles.

Standard Email Support

You can also send email to technical@intersoftpt.com for product troubleshooting or bugs. Please provides information on the product version, operating system name and version as well as your development environment and its version. Your email will be answered shortly by our technical support team.

The turnaround time for standard email support is 72 hours (at the latest).

Before sending out your email, we highly recommend you to initially search for the information on locally installed Reference and Online Support.

Developer Network Support

The company provides a rich web-based forums for registered customers to discuss about the product. You may find information and answer to your questions in the forums, or simply posting your message in the forums and our technical support team will answer it in short time.

To access the Developer Network, please go to Intersoft website and click on Developer Network.

Login details are required to access Developer Network. Please refer to your original order receipt sent from Intersoft Accounts. If you do not get the automated order receipt, please contact accounts@intersoftpt.com

Priority Support Options

The NEW Priority Support option allows registered customers to obtain technical support via direct e-mail or telephone support from our Senior Support Engineer.

This option is designated for advanced customers who require faster response time. The inquiries types are mostly intermediate to advanced involving application-specific scenarios, minor feature requests, quick patches and more.

For more information about the Priority Support pricing and online purchase, please visit Intersoft Solutions web site at http://www.intersoftpt.com

Phone Support

Phone Support is currently available only for registered customers who have purchased Priority Support. You can reach Technical Support through following numbers:

  • +62 21 25556680
  • +62 21 25556681
Please have your UserID ready when calling.


System Requirements

System Requirements
See Also Send comments on this topic.
Intersoft WebEssentials > Getting Started > Installation > System Requirements

Glossary Item Box

Development Machine Requirements

  • Microsoft Windows Vista
  • Microsoft Windows 2000/2003/2008 Server family
  • Microsoft Windows XP Professional or Home Edition
  • Microsoft .NET Framework v2.0 or higher
  • Microsoft Visual Studio 2005 Professional/Team Studio/Express Edition
  • Microsoft Visual Studio 2008
  • Intersoft WebUI.NET Framework v3.0 or higher

Server Machine Requirements

  • Windows Server 2003 Enterprise
  • Windows Server 2003 Web Edition
  • Windows Server 2008
  • Internet Information Services 6.0 or later
  • Microsoft .NET Framework Version 2.0 or later
  • Intersoft WebUI.NET Framework v3.0 or higher

Client Machine Requirements

  • Microsoft Internet Explorer 5.5 or higher
  • Mozilla V1.7 +for Windows/Mac/Linux/Solaris
  • Firefox V1.0+ for Windows/Mac/Linux/Solaris
  • Netscape V7.0+ for Windows/Mac/Linux/Solaris
  • Opera 9.5+ for Windows/Mac/Linux/Solaris/FreeBSD/BeOS/QNX
  • Apple Safari 3+ for Windows/Mac

See Also

Other Resources
Installation Guide
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox


Understanding WebListBox User Interface

Understanding WebListBox User Interface
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > Understanding WebListBox User Interface

Glossary Item Box

WebListBox is a unique control, part of WebEssentials family, which can be used as an input control or a navigation control. It contains a list of items displayed vertically and users can select single or multiple items.

Built to support XHTML and HTML doctype, WebListBox provides limitless customizations on the user interface aspect through its comprehensive properties. Furthermore, the UI personalization can be made globally (specified in LayoutSettings property) or item specific depending on your need.

Display Mode

It is possible to display text and images, text, or images only in WebListBox's item. Use the LayoutSettings >> DisplayMode property to customize this behavior, or [Item] >> DisplayMode property for individual configuration. By default, the display mode is set to Text.

To learn more about Display mode, see How-to: Customize Display Mode.

Image Position

When TextAndImage display mode is used, the default image positioning is before the text. This behavior can be tweaked further using ImagePosition property inside LayoutSettings, or[Item] >> Imageposition for individual setting. Four image positioning options are available: AboveText, BelowText, AfterText, and BeforeText.

To learn more about Image position, see How-to: Customize Image Position.

Item Alignment

You can set items to be left-aligned, right-aligned, or center-aligned using ItemAlignment property. Item alignment can be specified globally or individually. Use the LayoutSettings >> ItemAlignment property for global configuration, or [Item] >> ItemAlignment for individual configuration.

Item Height

Item's height can be specified globally or individually. Use the LayoutSettings >> ItemHeight property to apply this globally or [Item] >> ItemHeight property to set individual item height. By default the height is 80 pixels.

To learn more about item height, see How-to: Customize item height.

Item Style

WebListBox enables you to refine the item styles to match your need. ItemStyle, ItemTextStyle and ItemImageStyle properties are provided for global configuration.

Individual item styling properties are also available enabling you to fine-tune the look-and-feel, ItemNormalClass, ItemHoverClass, ItemActiveClass, ItemTextClass, and ItemImageClass. All you need to do is to simply assign CSS classes to those properties.

A helpful triangle indicator can be enabled to show the currently active item. Use the LayoutSettings >> DisplayActiveItemIndicator property to enable this feature.

To learn more about custom item styles, see How-to: Specify custom item styles for specific items.

See Also

Other Resources
{Scroll Mode}
{Selection Mode}


Understanding WebListBox User Interface How-to Topics

Understanding WebListBox User Interface How-to Topics
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > Understanding WebListBox User Interface > Understanding WebListBox User Interface How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common WebListBox tasks.

In This Section

How-to: Customize Display Mode

How-to: Customize Image Position

How-to: Customize Item Height

How-to: Specify Custom Item Styles for Specific Items


Understanding WebSlidingMenuItem

Understanding WebSlidingMenuItem
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Understanding WebSlidingMenuItem

Glossary Item Box

This section contains features in WebSlidingMenuItem.

  • Various Item's Content Mode
  • AutoHeight

Various Item's Content Mode

WebSlidingMenu supports three types of content modes to better serve your requirement. Use the [Level] >> ItemContentMode property to apply this globally per level or [Item] >> ContentMode property to set individual content mode.

  • Text
    Use the Text property to specify your own content.

To learn more about Text content, see How-to: Use WebSlidingMenuItem with Text content.

  • Inline
    This advanced mode gives you the flexibility to present richer information using HTML object or any server-side controls. WebEssentials' solid integration to Visual Studio IDE enables you to directly input the content in the design time mode.

To learn more about Inline content, see How-to: Use WebSlidingMenuItem with Inline content.

  • IFrame
    IFrame content mode is an alternative to the two above. It enables you to host an external page through the ContentURL property.

To learn more about IFrame content, see How-to: Use WebSlidingMenutItem with IFrame content.

To learn more about Content mode, see How-to: Customize WebSlidingMenuItem content mode from server-side.

AutoHeight

AutoHeight is an interesting feature as it automatically calculates each item's height based on its content's height. When AutoHeight property is set to true, WebSlidingMenu will ignore any value in ItemHeight property. Use the [Level] >> AutoHeight property to apply this globally per level or [Item] >> AutoHeight property to set individual content mode.

See Also

Other Resources
Understanding WebSlidingMenu User Interface
Other Resources


Understanding WebSlidingMenuLevel

Understanding WebSlidingMenuLevel
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Understanding WebSlidingMenuLevel

Glossary Item Box

WebSlidingMenu enables users to customize the item and header per section. In this properties, users can specify HeaderContentMode, ItemContentMode (globally per section), AutoHeight (globally for item in the section) and other feature that help user to customize the WebSlidingMenu.

  • Various Header's Content Mode
  • Adjustable Header Level
  • Enable Dynamic Style

Various Header's Content Mode

WebSlidingMenu supports two types of content mode for the header.

  • Text
    This default property only accepts text as the header's content.

To learn more about Text content, see How-to: Use WebSlidingMenuHeader with Text content.

  • Inline
    Inline mode offers better customization as it enables you to insert other controls or HTML objects during design time.

To learn more about Inline content, see How-to: Use WebSlidingMenuHeader with Inline content.

To learn more about content mode, see How-to: Customize WebSlidingMenuHeader content mode from server side.

Adjustable Header Level

Header level represents the hierarchy level of each header item, which can be determined by Level property.

To learn more about Header level, see How-to: Use WebSlidingMenuHeader with Level properties.

Enable Dynamic Style

Using the EnableDynamicStyle properties, user can customize whether or not to use the item's dynamic style at the level. The dynamic style will be enabled or disabled for all items and alternate items in the level and can be configured differently in each level.

See Also

Other Resources
{User Interface}
{Navigation}


How-to: Use LoadOnDemand to retrieve parent and child in WebSlidingMenu

How-to: Use LoadOnDemand to retrieve parent and child in WebSlidingMenu
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > How-to: Use LoadOnDemand to retrieve parent and child in WebSlidingMenu

Glossary Item Box

WebSlidingMenu adds a powerful LoadOnDemand to load the child's content on every request.

This topic will show you how to use LoadOnDemand to retrieve parent and child in WebSlidingMenu.

To use LoadOnDemand

  1. Right-click on WebSlidingMenu control and choose Properties.
  2. Set LoadOnDemand to True.
  3. Place the following code in InitializeItem server-side event:
    C# Copy Code
    protected void WebSlidingMenu1_InitializeItem(object sender, ISNet.WebUI.WebEssentials.WebSlidingMenuEventDataArgs e)
{
   if (e.Action == "InitializeChild")
   {
      WebSlidingMenuItemCollection itemCol = new WebSlidingMenuItemCollection();
      string studentID = e.SelectedItemName;
      switch (studentID)
      {
         case "1":
            WebSlidingMenuItem item = new WebSlidingMenuItem();
            item.Text = studentID + "Child";
            item.Name = studentID + "Child";

            item.ContentMode = WebSlidingMenuContentMode.Inline;
            item.AutoHeight = true;
            item.ContentTemplate = new MyTemplate(Page, studentID);

            itemCol.Add(item);
            break;

         case "2":
            WebSlidingMenuItem item2 = new WebSlidingMenuItem();
            item2.Text = studentID + "Child";
            item2.Name = studentID + "Child";

            item2.ContentMode = WebSlidingMenuContentMode.Inline;
            item2.AutoHeight = true;
            item2.ContentTemplate = new MyTemplate(Page, studentID);

            itemCol.Add(item2);
            break;
      }
      e.NewItemsObject = itemCol;
   }
}

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Concepts
{Powerful Load-on-Demand}


Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
See Also Send comments on this topic.
Intersoft WebEssentials > Getting Started > Installation > Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Glossary Item Box

This topic provides a step-by-step instruction on how to manually add Intersoft products to Visual Studio Toolbox using Toolbox Utility tool.

To add Intersoft products to Visual Studio Toolbox

  1. Run Intersoft ToolBox Utility for Visual Studio from Start Menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> Intersoft ToolBox Utility for Visual Studio or you can access ToolBoxUtility.exe from [Installation Folder]\Intersoft Solutions\Intersoft WebUI Studio 2010 R1\ToolBoxUtility
  2. Select on the Visual Studio platform you want Intersoft products to be installed. By default, it will automatically select all Visual Studio versions installed on your PC.

  3. Click Register to run the tool and wait until the process is finished.

  4. Finally, open your project and you will notice that Intersoft products has been installed successfully into Visual Studio Toolbox.

See Also

Other Resources
Installation Guide
System Requirements


How-to: Use WebAccordion with IFrame content

How-to: Use WebAccordion with IFrame content
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebAccordion > WebAccordion How-to Topics > How-to: Use WebAccordion with IFrame content

Glossary Item Box

IFrame mode is more flexible as developer can easily customize the ContentURL property and point it to a specific page.

This topic will show you how to use WebAccordion with IFrame content.

To use WebAccordion with IFrame content

  1. Add a page called PageWithIFrame.aspx.
  2. Right-click on WebAccordion control and choose Properties.
  3. Go to Items and click the collection button.
  4. Add a WebAccordion item. Set the following properties:
    Property | Value
    ContentMode | IFrame
    ContentURL | Specify the url where PageWithFrame.aspx is created.
    HeaderText | WebAccordionContent

  5. If HeaderContentMode is set to Image/TextAndImage, you need to specify the image url in HeaderImageURL property.
  6. You can simply edit the pane directly during design time.
  7. Run the project

See Also

Tasks
How-to: Use WebAccordion with Inline content
How-to Topics

Other Resources
Inline and iFrame content


How-to: Use WebAccordion with Inline content

How-to: Use WebAccordion with Inline content
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebAccordion > WebAccordion How-to Topics > How-to: Use WebAccordion with Inline content

Glossary Item Box

Using Inline content enables the pane to be edited directly during design time.

This topic will show you how to use WebAccordion with Inline content.

To use WebAccordion with Inline content

  1. Right-click on WebAccordion control and choose Properties.
  2. Go to Items and click the collection button.
  3. Add a WebAccordion item. Set the following properties:
    Property | Value
    ContentMode | Inline (By default, it is set to Inline)
    HeaderContentMode | Text/Image/TextAndImage/Inline
    HeaderText | WebAccordionContent

  4. If HeaderContentMode is set to Image/TextAndImage, you need to specify the image url in HeaderImageURL property.
  5. You can simply edit the pane directly during design time.
  6. Run the project.

See Also

Tasks
How-to: Use WebAccordion with IFrame content
How-to Topics

Other Resources
Inline and iFrame content


How-to: Use WebExpander with IFrame content

How-to: Use WebExpander with IFrame content
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebExpander > WebExpander How-to Topics > How-to: Use WebExpander with IFrame content

Glossary Item Box

You can use IFrame to create content in WebExpander.

This topic will show you how to use WebExpander with IFrame content.

To use WebExpander with IFrame content

  1. Right-click on WebExpander control and choose Properties.
  2. Go to ItemCollection and click the collection button.
  3. Add an item. Set ContentType to IFrame.
  4. Set ContentURL to any content you want to display.
  5. Run the project.

See Also

Other Resources
Rich content support

Tasks
How-to: Use WebExpander with Inline content
How-to Topics


How-to: Use WebExpander with Inline content

How-to: Use WebExpander with Inline content
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebExpander > WebExpander How-to Topics > How-to: Use WebExpander with Inline content

Glossary Item Box

You can use custom template to create inline content and header section in WebExpander.

This topic will show you how to use WebExpander with inline content.

To use WebExpander with inline content

  1. Right-click on WebExpander control and choose Properties.
  2. Go to ItemCollection and click the collection button.
  3. Add an item. Set HeaderContentMode to Inline and ContentType to Inline.
  4. Right-click on WebExpander control and choose Edit Template >> WebExpander1_item0. WebExpander1_item0 is the default name when creating the 1st item.
  5. Inside content template, you can fill with any content you want. Right-click on the content template and choose End Template Editing to apply the settings.
  6. Run the project.
ItemSettings property is applicable if user wish to apply this setting to all items in WebExpander.

See Also

Tasks
How-to: Use WebExpander with IFrame content
How-to Topics

Other Resources
Rich content support


How-to: Use WebSlidingMenuHeader with Inline content

How-to: Use WebSlidingMenuHeader with Inline content
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Understanding WebSlidingMenuLevel > How-to: Use WebSlidingMenuHeader with Inline content

Glossary Item Box

WebSlidingMenu provides feature to customize menu header with inline content.

This topic will show you how to use WebSlidingMenuHeader with inline content.

To use WebSlidingMenuHeader with Text content

  1. Right-click on WebSlidingMenu control and choose Properties.
  2. Go to Levels and click the collection button.
  3. Set HeaderContentMode to Inline.
  4. Run the project.

See Also

Tasks
{How-to: Use WebSlidingMenuHeader with Text content}
{How-to: Customize WebSlidingMenuHeader content mode from server side}
{Walkthrough Topics}
{How-to Topics}

Concepts
{Various Header's Content Mode}


How-to: Use WebSlidingMenuHeader with Level properties

How-to: Use WebSlidingMenuHeader with Level properties
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Understanding WebSlidingMenuLevel > How-to: Use WebSlidingMenuHeader with Level properties

Glossary Item Box

WebSlidingMenu provides feature to customize menu header with level properties.

This topic will show you how to perform the above scenario.

To use WebSlidingMenuHeader with Level properties

  1. Right-click on WebSlidingMenu control and choose Properties.
  2. Go to Levels and click the collection button.
  3. Set Level to any level index you want to customize.
  4. Run the project.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Concepts
{Adjustable Header Level}


How-to: Use WebSlidingMenuHeader with Text content

How-to: Use WebSlidingMenuHeader with Text content
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Understanding WebSlidingMenuLevel > How-to: Use WebSlidingMenuHeader with Text content

Glossary Item Box

WebSlidingMenu provides feature to customize menu header with text content.

This topic will show you how to use WebSlidingMenuHeader with Text content.

To use WebSlidingMenuHeader with Text content

  1. Right-click on WebSlidingMenu control and choose Properties.
  2. Go to Levels and click the collection button.
  3. Set HeaderContentMode to Text.
  4. Run the project.

See Also

Tasks
{How-to: Use WebSlidingMenuHeader with Inline content}
{How-to: Customize WebSlidingMenuHeader content mode from server side}
{Walkthrough Topics}
{How-to Topics}

Concepts
{Various Header's Content Mode}


How-to: Use WebSlidingMenuItem with IFrame content

How-to: Use WebSlidingMenuItem with IFrame content
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Understanding WebSlidingMenuItem > How-to: Use WebSlidingMenuItem with IFrame content

Glossary Item Box

WebSlidingMenu provides feature to use menu item with IFrame content.

This topic will show you how to use WebSlidingMenuItem with IFrame content.

To use WebSlidingMenuItem with IFrame content

  1. Right-click on WebSlidingMenu control and choose Properties.
  2. Go to Levels and click collection button.
  3. Set ItemContentMode to IFrame.
  4. To set individually, go to Items and click the collection button.
  5. Set ContentMode to IFrame.
  6. Run the project.

See Also

Tasks
{How-to: Use WebSlidingMenuItem with Text content}
{How-to: Use WebSlidingMenuItem with Inline content}
Walkthrough Topics
{How-to Topics}

Concepts
{Various Item's Content Mode}


How-to: Use WebSlidingMenuItem with Inline content

How-to: Use WebSlidingMenuItem with Inline content
See Also Send comments on this topic.

Glossary Item Box

WebSlidingMenu provides feature to use menu item with inline content.

This topic will show you how to use WebSlidingMenuItem with Inline content.

To use WebSlidingMenuItem with Inline content

  1. Right-click on WebSlidingMenu control and choose Properties.
  2. Go to Levels and click collection button.
  3. Set ItemContentMode to Inline.
  4. To set individually, go to Items and click the collection button.
  5. Set ContentMode to Inline.
  6. Run the project.

See Also

Tasks
{How-to: Use WebSlidingMenuItem with Text content}
{How-to: Use WebSlidingMenuItem with IFrame content}
{How-to: Customize WebSlidingMenuItem content mode from server side}
{Walkthrough Topics}
{How-to Topics}

Concepts
{Various Item's Content Mode}


How-to: Use WebSlidingMenuItem with Text content

How-to: Use WebSlidingMenuItem with Text content
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Understanding WebSlidingMenuItem > How-to: Use WebSlidingMenuItem with Text content

Glossary Item Box

WebSlidingMenu provides feature to use menu item with text content.

This topic will show you how to use WebSlidingMenuItem with Text content.

To use WebSlidingMenuItem with Text content

  1. Right-click on WebSlidingMenu control and choose Properties.
  2. Go to Levels and click collection button.
  3. Set ItemContentMode to Text.
  4. To set individually, go to Items and click the collection button.
  5. Set ContentMode to Text.
  6. Run the project.

See Also

Tasks
{How-to: Use WebSlidingMenuItem with Inline content}
{How-to: Use WebSlidingMenuItem with IFrame content}
{How-to: Customize WebSlidingMenuItem content mode from server side}
{Walkthrough Topics}
{How-to Topics}


Using Deployment Manager
See Also Send comments on this topic.
Intersoft WebEssentials > Getting Started > Deployment > Deployment Guide > Using Deployment Manager

Glossary Item Box

Intersoft comes up with a new hassle-free Deployment Manager that is designated to help developers to easily manage configurations during deployment phase.

Now, you can quickly configure the common settings required in deployment such as entering runtime license keys, view state configurations and others through user-friendly Windows GUI application.

Using Deployment Manager

Here are the step-by-step instructions to use Deployment Manager:

  1. Open Deployment Manager from Start menu >> All Programs >> Intersoft WebUI Studio 2010 RC >> WebUI Studio for ASP.NET >> Deployment Manager.
  2. Click Browse and select the project's directory of your web application to be configured. Click Next afterwards.

  3. Tick WebEssentials.NET 1.0.1000 and put the Runtime License key according to the component. Click Next to proceed to the next step.

  4. In this step, there are many settings you can configure such as View State Storage, Optimization, Client Resources and Advanced sections.

    View State Storage Section

    View State Storage section lets you configure how ViewState is stored, specify how ViewState items are going to be saved in ViewState and determine the priority and duration of items stored in Cache object.

    Optimization Section

    Optimization section lets you choose whether to enable CSS Optimization and XML compression.

    Client Resources Section

    This section contains information on how to enable WebResources and set its mode.

    If you have applied SmartWebResources™ in your project, this option will be automatically selected with its default mode set to Auto.

    Advanced Section

    Advances section allows you to add necessary keys such as SharedScriptDirectory, ImagesDirectory or custom keys.

    In this section, you will learn how to assign the keys and values needed when you deploy the project.
    - In Advances section, click the ">" sign to move the available keys to the applied keys.
    - In Applied Keys table, Set the values like following:

    Key | Value
    ScriptDirectory | ~/CommonLibrary/Script
    SharedScriptDirectory | ~/CommonLibrary/WebEssentials/V1_0_1000/
    ImagesDirectory | ~/CommonLibrary/Images/

    This section is very critical to be applied when you copy the CommonLibrary folder to the project's directory in development machine. However, if you have enabled SmartWebResources™, you no longer need to configure the directory settings.

  5. Click Next or Apply to save the configuration. Finally, the web.config has been updated successfully. Click Close to apply the settings.

See Also

Other Resources
{Deploying project that uses SmartWebResources™}
{Deploying project that does not use SmartWebResources™}


W

W
Send comments on this topic.

Glossary Item Box


Walkthrough Topics

Walkthrough Topics
See Also Send comments on this topic.
Intersoft WebEssentials > Walkthrough Topics

Glossary Item Box

The following list of walkthrough topics demonstrates how to use all features in WebEssentials and how to manipulate WebEssentials into some complex structures.

WebSlidingMenu - DataBinding - Data Binding Editor

The topic in this category provides information on how to bind data to WebSlidingMenu.

  • Walkthrough: Performing WebSlidingMenu data binding

See Also

Other Resources
{How-to Topics}


WebAccordion How-to Topics

WebAccordion How-to Topics
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebAccordion > WebAccordion How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common WebAccordion tasks.

In This Section

How-to: Use WebAccordion with Inline content

How-to: Use WebAccordion with IFrame content

How-to: Set/Change WebAccordion's ExpandDirection

How-to: Set/Change WebAccordion's ExpandIndex

How-to: Set/Change WebAccordion InteractionMode

How-to: Set WebACcordion's Item through general settings

How-to: Set WebAccordion's item through specific settings


WebAccordion

WebAccordion
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebAccordion

Glossary Item Box

WebAccordion is a collapsible content panel featuring a modern minimalist style and silky-smooth expand/collapse animation. Take advantage of its tight integration with the Visual Studio IDE to easily add new items and set their content directly, or use IFrame mode to host external pages in WebAccordion items.

Display multiple panes in one time

WebAccordion enables developer to quickly add multiple expandable panes and display them one at a time. Adding pane or a collection of panes can be done through Items property collection in WebAccordion.

Easily add item

Made to be easy to work with, WebAccordion emphasizes in the rich and interactive design time experience for accelerated development. To add a new pane, simply click on the header in Visual Studio's design time mode and follow the step-by-step wizard to configure your item.

Inline and iFrame content

Two types of item content mode are available to match your scenario.

  • Inline
    This default mode enables the pane to be edited directly during design time.

To learn more about using Inline content, see How-to: Use WebAccordion with Inline content.

  • IFrame
    IFrame mode is more flexible as developer can easily customize the ContentURL property and point it to a specific page.

To learn more about IFrame content, see How-to: Use WebAccordion with IFrame content.

Customizable Header

Four types of header content mode are available to match your scenario.

  • Text
    This mode is used to display Text in header content.

  • Image
    This mode is used to display Image in header content.

  • TextAndImage
    This mode is used to display Text and Image in header content.

  • Inline
    When HeaderContentMode is set to "Inline", user can fill and edit the accordion's header directly during design time. This allows greater customization to be made for delivering a more personalized accordion.

Flexible layout and behavioral customization

Built on top of a solid architecture, WebAccordion provides a rich array of layout and behavioral customizations to meet your business scenario. Two most fundamental manipulations are the expand direction and interaction mode.

Expand Direction

Controlled by ExpandDirection property, WebAccordion offers 4 expand direction: top, bottom, left, and right.

Top Bottom

Left

Right

In addition to controlling the expand direction, ExpandIndex property enables you to determine which specific pane should be expanded initially during page load.

When ExpandIndex is set to -1 then none of WebAccordion item will be expanded when first load.

To learn more about ExpandDirection, see How-to: Set/Change WebAccordion's ExpandDirection.

To learn more about ExpandIndex, see How-to: Set/Change WebAccordion's ExpandIndex.

Interaction Mode

InteractionMode property determines how user interacts with WebAccordion. Three types of interaction mode are available:
  • MouseOver
    WebAccordion will start expanding or collapsing when a cursor hovers and stops on an item (or pane) for a specific duration. Complementing this behavior, DisplayLatency property is provided - enabling you to control the mouse over state duration. The default value is 500 ms.
  • Click
    WebAccordion will start expanding or collapsing when the item's header is clicked.
  • Both
    Combining both MouveOver and Click modes, WebAccordion will respond to a mouse click or mouse over.

To learn more about InteractionMode, see How-to: Set/Change WebAccordion's InteractionMode.

Global and individual item settings

The global settings are particularly useful when you have numerous panes with same configurations, so you can quickly setup a WebAccordion's pane without having to specify it in each pane. Use the individual settings if you wish to customize a specific pane further without interrupting the others.

Global item settings can be found in ItemSettings property. The individual item settings is inside each of the item's property.

To learn more about general settings, see How-to: Set WebAccordion's items through general settings.

To learn more about item specific settings, see How-to: Set WebAccordion's item through item specific settings.

Swift animation

WebAccordion provides an elegant out-of-the-box animation when an item (or pane) is expanded or collapsed.

XHTML Compliance

WebAccordion is designed to fully comply with W3C's XHTML standard - providing identical rendering when running in different modern XHTML-ready browsers.

Appearances and styles

Default Styles

Two predefined default styles are provided for quick styling.

Advanced Layout Customization

Comprehensive Client-side Events

  • OnBeforeExpandCollapse(controlId, currentItemIndex, nextItemIndex)
    This client-side event is triggered just before an item is expanded or collapsed.

  • OnAfterExpandCollapse(controlId, previousItemIndex, currentItemIndex)
    This client-side event is triggered after an item is expanded or collapsed.

  • OnInitialize(controlId)
    This client-side event is invoked when WebAccordion is being initialized.

  • OnClick(controlId, itemIndex)
    This client-side event is invoked when an item is clicked.

Rich Client-side APIs

Methods | Description
GetElement() | Obtain WebAccordion's element.
GetItemElementByIndex(index) | Obtain WebAccordion's item by its index.
GetHeaderElementByIndex (index) | Obtain WebAccordion item's header element by index.
GetHeaderFrameElementByIndex(index) | Obtain WebAccordion item's header frame element by index.
GetHeaderContentElementByIndex(index) | Obtain WebAccordion item's header content element by index.
GetContentFrameElementByIndex(index) | Obtain WebAccordion item's content element by index.
GetContentPanelElementByIndex(index) | Obtain WebAccordion item's content panel by index.
GetContentElementByIndex(index) | Obtain WebAccordion item's content element by index.
GetIFrameByIndex(index) | Obtain WebAccordion's iFrame element by index.
HideIFrameByIndex(index) | Hide iFrame based on index.
ShowIFrameByIndex(index) | Show iFrame based on index.
MoveToItemByIndex(index) | Expand a WebAccordion's item based on index.
MoveToNextItem() | Expand the next WebAccordion item.
MoveToPrevItem() | Expand the previous WebAccordion item.


WebAccordion

WebAccordion
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebAccordion

Glossary Item Box

WebAccordion Properties

ScriptDirectory | Description Gets or sets the directory where all required scripts for the control are stored. ValueType Default Value
ImagesDirectory | Description Gets or sets the images directory ValueType Default Value
ViewStateStorage | Description Gets ir sets the location to store the viewstate of this control. ValueType Default Value
AccessKey | Description Keyboard shortcut used by the control. ValueType Default Value
Enabled | Description Enabled state of the control. ValueType Default Value
TabIndex | Description The tab order of the control. ValueType Default Value
ToolTip | Description The tooltip displayed when the mouse is over the control. ValueType Default Value
ID | Description Programmatic name of the control. ValueType Default Value
Width | Description The width of the control. ValueType Default Value
Height | Description The height of the control. ValueType Default Value
Items | Description The item collection used by WebAccordion. ValueType Default Value
ExpandDirection | Description Specifies WebAccordion expand direction. ValueType Default Value
InteractionMode | Description Specifies WebAccordion interaction mode. ValueType Default Value
DisplayLatency | Description Specifies the display latency of WebAccordion with MouseOver interaction mode. ValueType Default Value
ExpandIndex | Description Specifies the expand index of WebAccordion. ValueType Default Value
HeaderHeight | Description Specifies the header height of WebAccordion's item. ValueType Default Value
HeaderWidth | Description Specifies the header width of WebAccordion's item. ValueType Default Value
ContentHeight | Description Specifies the content height of WebAccordion's item. ValueType Default Value
ContentWidth | Description Specifies the content width of WebAccordion's item. ValueType Default Value
ItemSettings | Description Provides the settings that control the default WebAccordion's item settings. ValueType Default Value
ImagesSettings | Description Provides the settings that control the images in WebAccordion. ValueType Default Value
ClientSideEvents | Description Contains client side events supported by WebAccordion. ValueType Default Value

WebAccordion Methods

GetElement Description
Gets WebAccordion's element

Parameters

Remarks

Return Value

Samples

GetItemElementByIndex Description
Gets WebAccordion's item by its index.

Parameters
index ( )

Remarks

Return Value

Samples

GetHeaderFrameElementByIndex Description
Gets WebAccordion item's header frame element by index.

Parameters
index ( )

Remarks

Return Value

Samples

GetHeaderElementByIndex Description
Gets WebAccordion item's header element by index.

Parameters
index ( )

Remarks

Return Value

Samples

GetHeaderContentElementByIndex Description
Gets WebAccordion item's header content element by index.

Parameters
index ( )

Remarks

Return Value

Samples

GetContentFrameElementByIndex Description
Gets WebAccordion item's frame element by index.

Parameters
index ( )

Remarks

Return Value

Samples

GetContentPanelElementByIndex Description
Gets WebAccordion items' content panel by index.

Parameters
index ( )

Remarks

Return Value

Samples

GetContentElementByIndex Description
Gets WebAccordion item's content element by index.

Parameters
index ( )

Remarks

Return Value

Samples

GetIFrameByIndex Description
Gets WebAccordion's iFrame element by index.

Parameters
index ( )

Remarks

Return Value

Samples

HideIFrameByIndex Description
Hides iFrame based on index.

Parameters
index ( )

Remarks

Return Value

Samples

ShowIFrameByIndex Description
Shows iFrame based on index.

Parameters
index ( )

Remarks

Return Value

Samples

MoveToItemByIndex Description
Expands a WebAccordion's item based on index.

Parameters
index ( )

Remarks

Return Value

Samples

MoveToNextItem Description
Expands the next WebAccordion item.

Parameters

Remarks

Return Value

Samples

MoveToPrevItem Description
Expands the previous WebAccordion item.

Parameters

Remarks

Return Value

Samples


WebAccordionClientSideEvents

WebAccordionClientSideEvents
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebAccordionClientSideEvents

Glossary Item Box

WebAccordionClientSideEvents Properties

OnBeforeExpandCollapse | Description Gets or sets the event handler just before an item is expanded or collapsed. Parameters controlId The id of the control. currentItemIndex The current index of item to be expanded/collapsed. nextItemIndex The next index of item to be expanded/collapsed. Default Value -
OnAfterExpandCollapse | Description Gets or sets the event handler after an item is expanded or collapsed. Parameters controlId The id of the control. previousItemIndex The previous index of item to be expanded/collapsed. currentItemIndex The current index of item to be expanded/collapsed. Default Value -
OnInitiliaze | Description Gets or sets the event handler when WebAccordion is being initialized. Parameters controlId The id of the control. Default Value -
OnClick | Description Gets or sets the event handler an item is clicked. Parameters controlId The id of the control. ItemIndex The index of an item. Default Value -


WebAccordionItem

WebAccordionItem
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebAccordionItem

Glossary Item Box

WebAccordionItem Properties

HeaderContentMode | Description Specifies the default header image alignment of WebAccordion's item. ValueType Default Value
HeaderText | Description Specifies the default header text of WebAccordion's item. ValueType Default Value
HeaderImageAlignment | Description Specifies the default header image alignment of WebAccordion's item. ValueType Default Value
HeaderImageURL | Description Specifies the default header image URL of WebAccordion's item. ValueType Default Value
HeaderImageSize | Description Specifies the default header image size of WebAccordion's item. ValueType Default Value
ContentMode | Description Specifies the default content mode of WebAccordion's item. ValueType Default Value
ContentURL | Description Specifies the default content URL of WebAccordion's item. ValueType Default Value


WebAccordionItemSettings

WebAccordionItemSettings
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebAccordionItemSettings

Glossary Item Box

WebAccordionItemSettings Properties

HeaderImageAlignment | Description Specifies the default header image alignment of WebAccordion's item. ValueType Default Value
HeaderContentMode | Description Specifies the default header image alignment of WebAccordion's item. ValueType Default Value
HeaderImageSize | Description Specifies the default header image size of WebAccordion's item. ValueType Default Value
ContentMode | Description Specifies the default content mode of WebAccordion's item. ValueType Default Value


WebCalendar How-to Topics

WebCalendar How-to Topics
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebCalendar > WebCalendar How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common WebCalendar tasks.

In This Section

How-to: Set/Change WebCalendar ViewMode

How-to: Set/Change WebCalendar HighlightMode

How-to: Set/Change WebCalendar WeekViewMode

How-to: Customize WebCalendar WorkWeekSettings

How-to: Set/Change WebCalendar FirstDayOfWeek

How-to: Set/Change WebCalendar FirstWeekOfYear

How-to: Enable/Disable week number in WebCalendar

How-to: Enable/Disable highlights today date

How-to: Specify Holiday(s) in WebCalendar

How-to: Specify localization in WebCalendar

How-to: Enable multiple selection in WebCalendar

How-to: Perform FullPostback in WebCalendar

How-to: Perform FlyPostback in WebCalendar

How-to: Enable keyboard support in WebCalendar


WebCalendar

WebCalendar
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebCalendar

Glossary Item Box

WebCalendar provides a fast, convenient way to navigate by date and select dates and date ranges.

View customization

Three view modes are provided, Month, Quarter, and Year.

Month View

In any selected or active Month view, all dates will be selected. The highlighted date can be customized through HighlightMode property.

Quarter View

Instead of dates, Quarter View will display 12-month. Click on a month, and a quarter is selected. If the ViewMode is set to Quarter, user can't navigate to Month View.

Year View

Years are displayed in WebCalendar in Year view. If ViewMode is set to Year, navigation to month or quarter view is disabled.

To learn more about ViewMode, see How-to: Set/Change WebCalendar ViewMode.

Behavioral configuration

Four date range highlight options are provided exclusively for Month View:

Month All dates of the active month will be selected. | Week The selected dates are highlighted according to the active week, which is based on WeekViewMode property.
Day Only the selected date is highlighted. | Custom Custom date range is determined by CustomHighlightedDays property.

Additional settings are available when HighlightMode is set to Week. WeekViewMode property is used to determine how many days in a week will be highlighted. There are two options, full week and work week. As the name implies, full week will select all days (from Monday to Sunday), while work week will select specific days only according to WorkWeekSettings property (default is Monday to Friday).

Full Week

Work Week

To learn more about HighlightMode, see How-to: Set/Change WebCalendar HighlightMode.

To learn more about WeekViewMode, see How-to: Set/Change WebCalendar WeekViewMode.

WorkWeekSettings

User can easily specify workday through WorkWeekSettings property, which work in conjunction with the date selection when the HighlightMode is set to Week and WeekViewMode is WorkWeek.

To learn more about WorkWeekSettings, see How-to: Customize WebCalendar WorkWeekSettings.

FirstDayOfWeek

FirstDayOfWeek property indicates the starting day in a week. The default value is Sunday.

To learn more about FirstDayOfWeek, see How-to: Set/Change WebCalendar FirstDayOfWeek.

FirstWeekOfYear

The first week of year is also customizable according to your business requirement.
Three options are available in FirstWeekOfYear properties:

  • First4DayWeek
    The first week is the week which has at least 4 days. This is WebCalendar's default value.

  • StartOn1January
    The first week always starts from January 1st.

  • FirstFullWeek
    The first week is the full week, which has exact 7 days.

To learn more about FirstWeekOfYear, see How-to: Set/Change WebCalendar FirstWeekOfYear.

ShowWeekNumber

This property controls whether WebCalendar should show the week number or not. The week number depends on the FirstWeekOfYear property.

This property is only applicable to Month ViewMode.

To learn more about ShowWeekNumber, see How-to: Enable/Disable week number in WebCalendar.

HighlightTodayDate

This feature determines whether WebCalendar should highlight today's date or not. The highlight style is based on TodayStyle.

This property is only applicable to Month ViewMode.

To learn more about HighlightTodayDate, see How-to: Enable/Disable highlights today date.

Navigation

  • Back and Forward
    Back and forward buttons allows user to move backward or forward according to the active view.

  • Changed calendar view
    In addition to Month ViewMode, users can cycle through the views simply by clicking on the calendar's header. Three calendars views are available:
      • Day
        All days in a month are shown.
      • Month
        All 12 months in a year are displayed. The Quarter ViewMode also uses the same presentation; however, selecting a month in Quarter ViewMode will highlight a quarter.
      • Year
        WebCalendar shows years in 10 year range.

In Quarter ViewMode, users can not switch to Month view. In Year ViewMode, users can not switch to Quarter or Month view.

Supports holiday

WebCalendar provides holiday feature, which essentially enables you to define holiday easily. By default, a holiday is rendered in red. You can easily customize it in HolidayStyle property. When the cursor is over the holiday, a tooltip containing the specified description will be shown.

Holidays data collection can be specified in Holidays property.

IsGeneral property indicates whether the holiday occurs annually or occasionally.

To learn more about Holiday, see How-to: Specify Holiday(s) in WebCalendar.

Localization and various text settings

Localization

WebCalendar enables you select your most preferred culture format in Culture property. If no culture is specified, WebCalendar will automatically follow the server's setting.

TextSettings

Developer also has the freedom to customize the textual context in WebCalendar, such as the navigation button's tooltip.

CalendarHeaderText property lets you set the tooltip text of the calendar's header.
CalendarPrevArrowText property lets you set the previous navigation button's tooltip text.
CalendarNextArrowText property lets you set the next navigation button's tooltip text.

To learn more about localization, see How-to: Specify localization in WebCalendar.

Multiple calendar displayed

Unlike similar calendar solutions, WebCalendar enables developer to display multiple calendars. This behavior is controlled by NumberOfCalendarDisplayed property. In multiple calendar mode, only 1 calendar will be active when switched to year view or month view.

Supports multiple columns

Complementing the multiple calendars mode, WebCalendar also provides the multiple columns option - enabling to display more calendars horizontally. The CalendarItemWidth property controls the width of each WebCalendar and works in conjunction with WebCalendar's Width property.

For example: you want to display 6 calendars in 2x3 configurations.

NumberOfCalendarDisplayed = 6.
CalendaritemWidth = 1/3 of the entire width. For example if the width of the entire WebCalendar is set to 300px, the CalendarItemWidth must be set to 100px to achieve the desired requirement. For the best result, CalendarItemWidth's value must be exactly the division of the total columns on the entire width.

Multiple selection

WebCalendar offers multiple selections for selecting multiple dates. This feature can be activated by setting EnableMultipleSelection property to true. Multiple selections can be performed using mouse only, keyboard only, or the combination of both. The behavior is exactly the same as performing multiple selections in desktop OS. Click and drag using mouse to select a range of dates, use the CTRL, SHIFT, or CTRL + SHIFT for more advanced randomized selections. Multiple selections feature is designed to work in month view mode only and EnableKeyboardSupport property should be enabled for the best experience.

To learn more about Multiple selection, see How-to: Enable multiple selection in WebCalendar.

Integrated to FullPostback and FlyPostback (or AJAX)

Postback will occur when SelectedDate or SelectedDates (if you have multiple values), is changed and OnSelectedDateChanged server-side event is specified. WebCalendar offers two postback modes, FullPostBack and FlyPostBack (AJAX).

To learn more about FullPostback, see How-to: Perform FullPostback in WebCalendar.

To learn more about FlyPostback, see How-to: Perform FlyPostback in WebCalendar.

Strong keyboard support

The strong keyboard support gives users an effortless navigation when working with dates. Simply set EnableKeyboardSupport property to true, and users can start using the directional keys to move between months and dates. [Enter] key is used to select a date and [Space] key is used to cycle through the available views (Month, Quarter, Year).

To learn more about keyboard support, see How-to: Enable keyboard support in WebCalendar.

XHTML Compliance

WebCalendar is designed to fully comply with W3C's XHTML standard - providing identical rendering when running in different modern XHTML-ready browsers.

Appearance and styles

Most of the visual and textual aspects of WebCalendar are easily customizable, giving you the flexibility to express your creativity.

Default Styles

Four predefined styles are offered in WebCalendar.

  1. Microsoft Outlook 2007 Black
  2. Microsoft Outlook 2007 Blue
  3. Olive Green
  4. Windows 7

Comprehensive Client-side Events

Here are client side event that supported by WebCalendar:

  • OnViewChanged(controlId)
    This client-side event is triggered on every view changed.

  • OnAfterRender(controlId, calendarType)
    This client-side event is invoked immediately after WebCalendar is rendered.

  • OnSelectedDateChanged(controlId, oldDates, newDates)
    This client-side event is triggered if the selected date is changed.

  • OnBeforeNavigation(controlId, navigation, calendarType)
    This client-side event is triggered before WebCalendar performs navigation.

  • OnAfterNavigation(controlId, navigation, calendarType)
    This client-side event is triggered after WebCalendar performs navigation.

  • OnCellClicked(controlId, element, newDate)
    This client-side event is triggered when WebCalendar's cell is clicked.

Rich Client-side APIs

Methods | Description
GetElement() | Obtain WebCalendar's element.
Refresh(isOnlyPrimaryCalendar) | Refresh WebCalendar. isOnlyPrimaryCalendar is a Boolean value which control whether the first calendar is refreshed or not.
SetSelectedDate(newDate) | Jump to a specific date immediately.
MoveDayBy(n) | Move the selected date by n days from the current date.
GoToNextMonth(n) | Navigate to next month.
GoToPreviousMonth(n) | Navigate to previous month.
GoToNextQuarter(n) | Navigate to next quarter.
GoToNextYear(n) | Navigate to next year.
GoToPreviousYear(n) | Navigate to previous year.
DisableNonPrimaryCalendars() | Disable non-primary calendars if you have more than 1 calendar.
EnableNonPrimaryCalendars() | Enable non-primary calendars if you have more than 1 calendar.


WebCalendar

WebCalendar
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebCalendar

Glossary Item Box

WebCalendar Properties

ScriptDirectory | Description Gets or sets the directory where all required scripts for the control are stored. ValueType Default Value
ImagesDirectory | Description Gets or sets the images directory. ValueType Default Value
ViewStateStorage | Description Gets or sets the location to store the viewstate of this control. ValueType Default Value
AccessKey | Description Keyboard shortcut used by the control. ValueType Default Value
Enabled | Description Enabled state of the control. ValueType Default Value
TabIndex | Description The tab order of the control. ValueType Default Value
ToolTip | Description The tooltip displayed when the mouse is over the control. ValueType Default Value
ID | Description Programmatic name of the control. ValueType Default Value
Height | Description The height of the control. ValueType Default Value
Width | Description The width of the control. ValueType Default Value
DefaultStyleMode | Description Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled. ValueType Default Value
AllowDefaultStyleMerging | Description Gets or sets the value that determines whether the default style can be merged with custom styles. ValueType Default Value
UseDefaultStyle | Description Determines whether WebCalendar is using default style. ValueType Default Value
Calendars | Description ValueType Default Value
InitialDisplayDate | Description Specifies the initial WebCalendar's Date and Time. ValueType Default Value
InitialDisplayDateInfo | Description ValueType Default Value
SelectedDate | Description Specifies the selected WebCalendar's Date and Time. ValueType Default Value
EnableAnimation | Description Determines whether animation is enabled in WebCalendar. ValueType Default Value
NumberOfCalendarDisplayed | Description Specifies number of month displayed in WebCalendar. ValueType Default Value
FirstWeekOfYear | Description Specifies WebCalendar first week of year. ValueType Default Value
FirstDayOfWeek | Description Specifies WebCalendar first day of week. ValueType Default Value
HighlightTodayDate | Description Determines whether today date should be highlighted in WebCalendar. ValueType Default Value
ShowWeekNumbers | Description Determines whether week number should be displayed in WebCalendar. ValueType Default Value
WeekViewMode | Description Specifies WebCalendar week view mode. ValueType Default Value
HighlightMode | Description Specifies view mode to be highlighted. ValueType Default Value
CustomHighlightedDays | Description Specifies number of days that will be applied on custom highlight. ValueType Default Value
ViewMode | Description Specifies WebCalendar view mode. ValueType Default Value
NavigationMode | Description Determines whether WebCalendar's SelectedDate always change when navigation is triggered. ValueType Default Value
PostBackMode | Description Specifies WebCalendar postback mode. ValueType Default Value
ReadOnly | Description Determines whether WebCalendar is read only. ValueType Default Value
EnableMultipleSelection | Description Determines whether multiple selection is enabled in WebCalendar. ValueType Default Value
EnableKeyboardSupport | Description Determines whether keyboard is supported in WebCalendar. ValueType Default Value
SelectedDates | Description The selected dates collection used by WebCalendar when multiple selection is enabled. ValueType Default Value
Culture | Description Specifies the culture settings for current WebCalendar instance. ValueType Default Value
Holidays | Description The data collection used by WebCalendar to determine holiday(s). ValueType Default Value
TextSettings | Description Provides the settings that control the text that shown in WebCalendar. ValueType Default Value
WorkWeekSettings | Description Provides the settings that control the behaviors of the WorkWeek in WebCalendar. ValueType Default Value
ClientSideEvents | Description Contains client side events supported by WebCallOut. ValueType Default Value
ImagesSettings | Description Provides the settings that control the images in WebCalendar. ValueType Default Value
CalendarItemWidth | Description Specifies calendar item width. ValueType Default Value
CalendarItemHeight | Description Specifies calendar item height. ValueType Default Value

WebCalendar Methods

GetElement Description
Gets WebCalendar's element.

Parameters

Remarks

Return Value

Samples

Refresh Description
Refresh WebCalendar.

Parameters
onlyPrimaryView ( )
a Boolean value which control whether the first calendar is refreshed.

Remarks

Return Value

Samples

SetSelectedDate Description
Jump to a specific date immediately.

Parameters
date ( )
skipRender ( )
enableActiveIndex ( )
isUserSelection ( )

Remarks

Return Value

Samples

MoveDayBy Description
Move the selected date by n days from the current date.

Parameters
n ( )

Remarks

Return Value

Samples

GoToNextMonth Description
Navigate to next month.

Parameters
n ( )
alwaysRender ( )

Remarks

Return Value

Samples

GoToPreviousMonth Description
Navigate to previous month.

Parameters
n ( )
alwaysRender ( )

Remarks

Return Value

Samples

GoToNextQuarter Description
Navigate to next quarter.

Parameters
n ( )

Remarks

Return Value

Samples

GoToNextYear Description
Navigate to next year.

Parameters
n ( )

Remarks

Return Value

Samples

GoToPreviousYear Description
Navigate to previous year.

Parameters
n ( )

Remarks

Return Value

Samples

DisableNonPrimaryCalendars Description
Disable non-primary calendars if you have more than 1 calendar.

Parameters

Remarks

Return Value

Samples

EnableNonPrimaryCalendars Description
Enable non-primary calendars if you have more than 1 calendar.

Parameters

Remarks

Return Value

Samples


WebCalendarClientSideEvents

WebCalendarClientSideEvents
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebCalendarClientSideEvents

Glossary Item Box

WebCalendarClientSideEvents Properties

OnViewChanged | Description Gets or sets the event handler on every view changed. Parameters controlId Default Value -
OnAfterRender | Description Gets or sets the event handler after WebCalendar is rendered. Parameters controlId, calendarType Default Value -
OnSelectedDateChanged | Description Gets or sets the event handler if the selected date is changed. Parameters controlId, oldDates, newDates Default Value -
OnBeforeNavigation | Description Gets or sets the event handler before WebCalendar performs navigation. Parameters controlId, navigation, calendarType Default Value -
OnAfterNavigation | Description Gets or sets the event handler after WebCalendar performs navigation. Parameters controlId, navigation, calendarType Default Value -
OnCellClicked | Description Gets or sets the event handler when WebCalendar's cell is clicked. Parameters controlId, element, newDate Default Value -


WebCalendarHoliday

WebCalendarHoliday
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebCalendarHoliday

Glossary Item Box

WebCalendarHoliday Properties

Date | Description Specifies the date of the Holiday. ValueType Default Value
HolidayDateInfo | Description ValueType Default Value
Description | Description Specifies the description of the Holiday. ValueType Default Value
IsGeneral | Description Indicates whether the holiday will appear on the same date and same month, evethough it is not the same year. ValueType Default Value


WebCalendarImagesSettings

WebCalendarImagesSettings
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebCalendarImagesSettings

Glossary Item Box

WebCalendarImagesSettings Properties

BlackPrev | Description Sets the Office2007Black previous image of WebCalendar. ValueType Default Value
GreenPrev | Description Sets the OliveGreen previous image of WebCalendar. ValueType Default Value
BlackNext | Description Sets the Office2007Black next image of WebCalendar. ValueType Default Value
BlueNext | Description Sets the Office2007Blue next image of WebCalendar. ValueType Default Value
GreenNext | Description Sets the OliveGreen next image of WebCalendar. ValueType Default Value


WebCalendarTextSettings

WebCalendarTextSettings
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebCalendarTextSettings

Glossary Item Box

WebCalendarTextSettings Properties

CalendarHeaderText | Description Specifies the tooltip text of WebCalendar header. ValueType Default Value
CalendarPrevArrowText | Description Specifies the tooltip text of WebCalendar previous arrow. ValueType Default Value
CalendarNextArrowText | Description Specifies the tooltip text of WebCalendar next arrow. ValueType Default Value


WebCalendarWorkWeekSettings

WebCalendarWorkWeekSettings
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebCalendarWorkWeekSettings

Glossary Item Box

WebCalendarWorkWeekSettings Properties

Monday | Description Indicates whether Monday is work week. ValueType Default Value
Tuesday | Description Indicates whether Tuesday is work week. ValueType Default Value
Wednesday | Description Indicates whether Wednesday is work week. ValueType Default Value
Thursday | Description Indicates whether Thursday is work week. ValueType Default Value
Friday | Description Indicates whether Friday is work week. ValueType Default Value
Saturday | Description Indicates whether Saturday is work week. ValueType Default Value
Sunday | Description Indicates whether Sunday is work week. ValueType Default Value


WebEssentials Overview

WebEssentials Overview
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview

Glossary Item Box

Featuring 8 innovative components, WebEssentials lets you add breathtaking visual effects and unprecedented ease of use to your Rich Internet Applications.

With WebEssentials, you can have intuitive nagition that allows user to quickly locate vital information hidden in mountains of data or to find that one critical web page among hundreds of thousands, Multipurpose container to make the most of precious screen real-estate, Ingenious input to ensure that your users have the tools they need for guaranteed high-quality data input with WebEssential's wide array of data entry components.

In This Section

The following table lists the controls collection available in WebEssentials.

WebAccordion

WebAccordion is a collapsible content panel with various selectable styles

WebCalendar

WebCalendar is a calendar control with built-in date range selection.

WebRating

WebRating is a rating control with unlimited possible configuration.

WebSlider

WebSlider is a intuitive slider control with single and dual rails feature.

WebExpander

WebExpander is a interactive expand collapse control with dual expand modes.

WebProgressBar

WebProgressBar is a control that offers accurate progress indicator with rich features.

WebListBox

WebListBox is a sophisticated list box control with codeless data binding feature.

WebSlidingMenu

WebSlidingMenu is a iPhone-style sliding menu control with advanced Load-on-Demand.

WebRibbon

WebRibbon is a business-oriented ASP.NET ribbon UI control which is comprehensive, fast and easy to use.


Intersoft WebEssentials

Intersoft WebEssentials
Send comments on this topic.

Glossary Item Box

This section contains information about WebEssentials.

In This Section

Getting Started

Walkthrough Topics

How-to Topics

WebEssentials

Server-side References

Client-side References

Product Support

Licensing


WebExpander How-to Topics

WebExpander How-to Topics
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebExpander > WebExpander How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common WebExpander tasks.

In This Section

How-to: Modify WebExpander Expand Direction

How-to: Modify WebExpander Mode

How-to: Use WebExpander with Inline content

How-to: Use WebExpander with IFrame content


WebExpander

WebExpander
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebExpander

Glossary Item Box

WebExpander eases the burden of managing lengthy content by dividing it into multiple smaller sections. Use its customizable layout and diverse expansion modes to create a unique, personalized appearance that superbly complements your Rich Internet Applications.

Flexible View Customization

WebExpander provides 4 expand directions which are up, down, left, and right.

Up | Bottom
Left | Right

To learn more about Expand Direction, see How-to: Modify WebExpander Expand Direction.

Flexible Behavior Customization

Complementing the expand direction feature, WebExpander also offers 2 expand modes: Fixed and Flow.

Fixed mode is similar to Tabbed Document Interface (TDI), in which all the content is contained in a single window and the content could be switched using the header item.

Flow mode is similar to Multiple Document Interface (MDI), in which every header item will have its own content window which will expand in the direction determine in the WebExpander flow property.

To learn more about WebExpander Mode, see How-to: Modify WebExpander Mode.

Rich Content Support

Using custom template in the content and header section, you can deliver a richer content and embed it to WebExpander.

Content sections also support iFrame for rich content.

To learn more about Inline content, see How-to: Use WebExpander with Inline content.

To learn more about IFrame content, see How-to: Use WebExpander with IFrame content.

Integrated with FullPostback and FlyPostback (or AJAX)

Postback is triggered on every item expanded or collapsed. WebExpander offers PostBackMode property to determine the postback action it uses, FullPostBack and FlyPostBack.

XHTML Compliance

WebExpander is designed to fully comply with W3C's XHTML standard - providing identical rendering when running in different modern XHTML-ready browsers.

Appearance and Styles

Default Styles

WebExpander includes a Default Style that you can customize using the available Style property. The available default styles are:

  • Default

  • Silver

  • Office Black

Layout Overview

Almost all WebExpander's visual aspects can be customized thorough the Style property.

Comprehensive Client-side Events

  • OnClick(ControlId, ItemName)
    This client-side event is triggered when WebExpander item is clicked.
  • OnExpanded(ControlId, ItemName)
    This client-side event is triggered when a WebExpander item is expanded.

  • OnCollapsed(ControlId, ItemName)
    This client-side event is triggered when a WebExpander item is collapsed.

Rich Client-side APIs

Methods | Description
GetFrameElement() | Obtain WebExpander's frame element.
GetHeaderElement(x) | Obtain WebExpander's header element by item name based on the x value.
GetContentElement(x) | Obtain WebExpander's content element by item name based on the x value.
Expand() | Expand an item.
Collapse() | Collapse an item.
ShowIndicator() | Show the indicator element of an item.
HideIndicator() | Hide the indicator element of an item.


WebExpander

WebExpander
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebExpander

Glossary Item Box

WebExpander Properties

ScriptDirectory | Description Gets or sets the directory where all required scripts for the control are stored. ValueType Default Value
ViewStateStorage | Description Gets or sets the location to store the viewstate of this control. ValueType Default Value
AccessKey | Description Keyboard shortcut used by the control. ValueType Default Value
Enabled | Description Enable state of the control. ValueType Default Value
TabIndex | Description The tab order of the control. ValueType Default Value
ToolTip | Description The tooltip displayed when the mouse is over the control. ValueType Default Value
ID | Description Programmatic name of the control. ValueType Default Value
ImagesDirectory | Description Gets or sets the images directory. ValueType Default Value
Flow | Description Gets or sets the WebExpander expansion flow. ValueType Default Value
Mode | Description Gets or sets the WebExpander mode. ValueType Default Value
FrameStyle | Description Gets or sets the style applied to the frame of the expander. ValueType Default Value
HeaderStyle | Description Gets or sets the applied default style for all the header item in the expander. ValueType Default Value
HeaderCaptionStyle | Description Gets or sets the applied style for all the header caption in the expander. ValueType Default Value
IndicatorStyle | Description Gets or sets the style applied to the indicator of the expander item. ValueType Default Value
ItemSettings | Description Provides the settings that control the default WebExpander's item settings. ValueType Default Value
ClientSideEvents | Description Gets or sets client side events for WebExpander. ValueType Default Value
Items | Description Gets or sets the collection of content item. ValueType Default Value
UseDefaultStyle | Description Determines whether or not WebExpander is using default style. ValueType Default Value
AllowDefaultStyleMerging | Description Gets or sets the value that determines whether or not the default style can be merged with custom styles. ValueType Default Value
AnimationDuration | Description Gets or sets the animation duration during item Expand or Collapse. ValueType Default Value
PostBackMode | Description Gets or sets the PostBack mode for WebExpander. ValueType Default Value

WebExpander Methods

RemoveDynamicStyle Description

Parameters

Remarks

Return Value

Samples

GetElement Description
Gets WebExpander's element.

Parameters

Remarks

Return Value

Samples

GetHeaderElement Description
Gets WebExpander's header element by item name based on the itemName value.

Parameters
itemName ( )

Remarks

Return Value

Samples

GetContentElement Description
Gets WebExpander's content element by item name based on the itemName value.

Parameters
itemName ( )

Remarks

Return Value

Samples


WebExpanderClientSideEvents

WebExpanderClientSideEvents
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebExpanderClientSideEvents

Glossary Item Box

WebExpanderClientSideEvents Properties

OnClick | Description This client-side event is triggered when WebExpander item is clicked. Parameters controlId, ItemName Default Value -
OnExpanded | Description Gets or sets the event handler when a WebExpander item is expanded. Parameters controlId, ItemName Default Value -
OnCollapse | Description Gets or sets the event handler when a WebExpander item is collapsed. Parameters controlId, ItemName Default Value -


WebExpanderItem

WebExpanderItem
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebExpanderItem

Glossary Item Box

WebExpanderItem Properties

Name | Description Specifies the default name of WebExpander's item. ValueType Default Value
Header | Description Specifies the default header text of WebExpander's item. ValueType Default Value
HeaderContentMode | Description Specifies the default header type of WebExpander's item. ValueType Default Value
ContentType | Description Specifies the default content type of WebExpander's item. ValueType Default Value
State | Description Specifies the initial state of WebExpander's item ValueType Default Value
IndicatorPosition | Description Specifies the indicator position of WebExpander's item. ValueType Default Value
ItemHeaderStyle | Description Gets or sets the applied style for the header item in the expander. ValueType Default Value
AllowCollapse | Description Gets or sets the collapse permission of a WebExpander item. ValueType Default Value

WebExpanderItem Methods

GetHeaderElement Description
Gets WebExpander's header element.

Parameters

Remarks

Return Value

Samples

GetHeaderTemplateElement Description
Gets WebExpander's header template element.

Parameters

Remarks

Return Value

Samples

GetHeaderIndicatorElement Description
Gets WebExpander's header indicator element.

Parameters

Remarks

Return Value

Samples

GetHeaderContentElement Description
Gets WebExpander's header content element.

Parameters

Remarks

Return Value

Samples

GetContentElement Description
Gets WebExpander's content element.

Parameters

Remarks

Return Value

Samples

ShowIndicator Description
Shows the indicator element of an item.

Parameters

Remarks

Return Value

Samples

HideIndicator Description
Hides the indicator element of an item.

Parameters

Remarks

Return Value

Samples

Expand Description
Expand an item.

Parameters
raiseEvent ( )
animDuration ( )

Remarks

Return Value

Samples

Collapse Description
Collapse an item.

Parameters
raiseEvent ( )
animDuration ( )

Remarks

Return Value

Samples


WebExpanderItemSettings
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebExpanderItemSettings

Glossary Item Box

WebExpanderItemSettings

IndicatorPosition | Description Specifies the default indicator position of WebExpander's item. ValueType Default Value
HeaderContentMode | Description Specifies the default header type of WebExpander's item. ValueType Default Value
ContentType | Description Specifies the default content type of WebExpander's item. ValueType Default Value


WebListBox How-to Topics

WebListBox How-to Topics
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox > WebListBox How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common WebSlider tasks.

In This Section

How-to: Configure Scroll Mode in WebListBox

How-to: Configure Selection Mode in WebListBox

How-to: Set Selected Item on Load

How-to: Get Selected Values on Button Click

How-to: Enable AutoPostBack in WebListBox

How-to: Get Selected Values when AutoPostBack is enabled

How-to: Configure Navigation in WebListBox

How-to: Bind DataSource to WebListBox

How-to: Create Unbound WebListBox


WebListBox

WebListBox
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebListBox

Glossary Item Box

Using text, images, or both, WebListBox unleashes your inner creativity, allowing you to build eye-popping vertical navigators. A rich set of predefined themes provides an endless variety of choices bound to suit every website. For more exacting applications, a comprehensive set of style and layout properties enables you to create navigation set to your own precise specifications in mere minutes.

User Interface

WebListBox is a unique control, part of WebEssentials family, which can be used as an input control or a navigation control. It contains a list of items displayed vertically and users can select single or multiple items.

Built to support XHTML and HTML doctype, WebListBox provides limitless customizations on the user interface aspect through its comprehensive properties. Furthermore, the UI personalization can be made globally (specified in LayoutSettings property) or item specific depending on your need.

Scroll Mode

Scroll mode option is provided to anticipate having many items in WebListBox which exceeds the container's height. The common practice is to use scrollbar. WebListBox offers several scroll options, Scroller, ScrollBar, or None, that you can set in LayoutSettings >> ScrollMode property.

The Scroller scroll mode displays two directional arrows, up and down, that when users hover on it, all items will be scrolled. The ScrollBar scroll mode displays a vertical scrollbar, and the None option shows nothing. Hidden items remain invisible.

To learn more about Scroll mode, see How-to: Configure Scroll mode in WebListBox.

Selection Mode

The nature of WebListBox is as an input control where users can select not only one item, but multiple items at a time. This behavior can be configured in SelectionMode property. Single mode lets users to select only one item at a time. In Multiple mode, users can select multiple items by selecting a range using mouse, or using the keyboard + mouse combo to perform the selections. It works with CTRL and SHIFT.

To learn more about Selection mode, see How-to: Configure Selection Mode in WebListBox.

Set Selected Item(s) On Load

Initial item selections feature is essential for certain scenarios. To achieve this, simply set the [Item].Selected property to True or the SelectedIndex property to the selected item's index.

In Single selection mode with SelectedIndex property set, any items' Selected property setting is ignored. In Multiple mode, you can either use the SelectedIndex property or Item's Selected property to make the selection.

Additionally, selected items can be defined using SetValue and SetValues server-side methods.

To learn more about Selected item, see How-to: Set Selected Item on Load.

Get Selected Value

The selected item's index and value can be retrieved using Value and SelectedIndex property. When Multiple selection mode is active, use the GetValues server-side method to retrieve all selected values.

To learn more about Selected values, see How-to: Get Selected Values in Button Click.

Enable Keyboard Support

In addition to use mouse, users can use keyboard keys to select an item(s). Set the EnableKeyboardSupport property to True and users will be able to swiftly move through the items using up and down directional keys. Item will be automatically selected as users navigate using keyboard.

This property does not need to be enabled in order to use Ctrl and Shift keys when Multiple selection mode is enabled.

PostBack

WebListBox has built-in AutoPostBack property for client-server communication. When enabled, postback will be triggered as the selected item is changed. You can perform FullPostBack or FlyPostBack, customizable in PostBackMode property.

When postback is enabled, OnSelectedItemChanged server-side event is raised. This enables you to apply your programmatic processing. It allows you to obtain the selected items' index via the event arguments.

C# Copy Code
protected void WebListBox1_SelectedItemChanged(object sender, WebListBoxSelectedItemChangedEventArgs e)
{
   int index = e.SelectedIndex;
   WebListBoxItem item = WebListBox1.Items[index] as WebListBoxItem;
   SetData(int.Parse(item.Value));
}

This configuration will be ignored when the selection mode is set to Multiple.

To learn more about AutoPostBack, see How-to: Enable AutoPostBack in WebListBox.

To learn more about getting selected value on AutoPostBack, see How-to: Get Selected Values when AutoPostBack is enabled.

Navigation

Despite its nature as an input control, WebListBox can also be used as a navigation control. When an item is clicked, the specified URL will be opened in a new window or target IFrame. The target window can be specified in LayoutSettings >> TargetWindow property or [item] >> TargetWindow property for individual item. The target URL can be specified in [item] >> TargetURL property.

This configuration will be ignored when the selection mode is set to Multiple.

To learn more about Navigation, see How-to: Configure Navigation in WebListBox.

Themes

WebListBox supports various colorful and modern looking visual themes that you can select easily.

Client-side Events

Events | Description
OnInitialize() | Invoked during the control initialization process.
OnItemMouseOver() | Invoked when an item is hovered.
OnItemMouseOut() | Invoked when mouse out action is performed on an item.
OnKeyUp() | Invoked during key up action.
OnResponse() | Invoked when a response is returned after a FlyPostBack action.
OnResponseError() | Invoked if there is an error during a FlyPostBack action.
OnBeforeItemSelected() | Invoked before the item(s) are selected.
OnAfterItemSelected() | Invoked after item(s) are selected.

Data Binding

Targeting enterprise Web applications, WebListBox is enhanced with data binding to data source control capability. WebListBox can be bound using traditional binding and datasource control.

Several properties related to data binding functionality are listed below.

Properties | Description
DataSourceID | The data source id of WebListBox.
DataMember | The data member of WebListBox.
NameFieldDataMember | The field data member of Name property.
ImageFieldDataMember | The field data member of Image property.
TextFieldDataMember | The field data member of Text property.
ValueFieldDataMember | The field data member of Value property.
TargetURLFieldDataMember | The field data member of TargetURL property.
ImageFieldFormatString | The format string of Image field data member.

The related properties will be bound automatically when the field data member is specified. WebListBox also supports unbound mode. You need to add the items manually.

To learn more about Bind DataSource to WebListBox, see How-to: Bind DataSource to WebListBox.

To learn more about Unbound WebListBox, see How-to: Create Unbound WebListBox.

Rich Client-side APIs

Methods | Description
GetElement | Gets frame element of WebListBox.
GetContentFrameElement | Gets the content frame element of WebListBox.
GetContentElement | Get the content element of WebListBox.
GetIndicatorElement | Gets the triangle indicator element.
GetTopScrollerElement | Gets the content frame element of the top scroller.
GetTopScroller | Gets the top scroller element.
GetBottomScrollerElement | Gets the content frame element of the bottom scroller.
GetBottomScroller | Gets the bottom scroller element.
GetItemByValue | Gets a specific item by value.
GetSelectedIndexes | Gets the collection of selected item's indexes.
DoResize | Performs resize in WebListBox.


WebListBox

WebListBox
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebListBox

Glossary Item Box

WebListBox Properties

ScriptDirectory | Description Gets or sets the directory where all required scripts for the control are stored. ValueType Default Value
ImagesDirectory | Description Gets or sets the images directory for ImagesSettings. ValueType Default Value
ViewStateStorage | Description Gets or sets the location to store the viewstate of this control. ValueType Default Value
AccessKey | Description Keyboard shortcut used by the control. ValueType Default Value
Enabled | Description Enabled state of the control. ValueType Default Value
TabIndex | Description The tab order of the control. ValueType Default Value
ToolTip | Description The tooltip displayed when the mouse is over the control. ValueType Default Value
ID | Description Programmatic name of the control. ValueType Default Value
Width | Description The width of the control. ValueType Default Value
Height | Description The height of the control. ValueType Default Value
DefaultStyleMode | Description Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled. ValueType Default Value
UseDefaultStyle | Description Specifies whether WebListBox should apply embedded default style for its appearance. ValueType Default Value
AllowDefaultStyleMerging | Description Gets or sets the value that determines whether or not the default style can be merged with custom styles. ValueType Default Value
SelectionMode | Description Gets or sets the value that determines whether to use single or multiple selection mode. ValueType Default Value
EnableKeyboardSupport | Description Gets or sets the value that determines whether keyboard support is enabled. ValueType Default Value
AutoPostBack | Description Automatically postback to the server after selection is changed. Applicable when selection mode is set to single. ValueType Default Value
PostBackMode | Description Gets or sets the value that determines the postback mode when AutoPostBack is enabled. ValueType Default Value
Items | Description Gets the collection of WebListBoxItem. ValueType Default Value
LayoutSettings | Description Provides the settings that control the behaviors of the layout in WebListBox. ValueType Default Value
ImagesSettings | Description Provides the settings that contorl the images in WebListBox. ValueType Default Value
ClientSideEvents | Description Contains client side events supported by WebListBox. ValueType Default Value
SelectedIndex | Description Gets or sets the index that determines the selected item. ValueType Default Value
Value | Description Gets the value of selected item when SelectionMode is set to ValueType Default Value

WebListBox Methods

GetElement Description
Gets frame element of WebListBox.

Parameters

Remarks

Return Value

Samples

GetContentFrameElement Description
Gets the content frame element of WebListBox.

Parameters

Remarks

Return Value

Samples

GetContentElement Description
Get the content element of WebListBox.

Parameters

Remarks

Return Value

Samples

GetIndicatorElement Description
Gets the triangle indicator element.

Parameters

Remarks

Return Value

Samples

GetTopScrollerElement Description
Gets the content frame element of the top scroller.

Parameters

Remarks

Return Value

Samples

GetTopScroller Description
Gets the top scroller element.

Parameters

Remarks

Return Value

Samples

GetBottomScrollerElement Description
Gets the content frame element of the bottom scroller.

Parameters

Remarks

Return Value

Samples

GetBottomScroller Description
Gets the bottom scroller element.

Parameters

Remarks

Return Value

Samples

GetItemByValue Description
Gets a specific item by value.

Parameters

Remarks

Return Value

Samples

GetSelectedIndexes Description
Gets the collection of selected item's indexes.

Parameters

Remarks

Return Value

Samples

DoResize Description
Performs resize in WebListBox.

Parameters

Remarks

Return Value

Samples


WebListBoxClientSideEvents

WebListBoxClientSideEvents
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebListBoxClientSideEvents

Glossary Item Box

WebListBoxClientSideEvents Properties

OnInitialize | Description Invoked during the control initialization process. Parameters - Default Value -
OnItemMouseOver | Description Invoked when an item is hovered. Parameters - Default Value -
OnItemMouseOut | Description Invoked when mouse out action is performed on an item. Parameters - Default Value -
OnKeyUp | Description Invoked during key up action Parameters - Default Value -
OnResponse | Description Invoked when a response is returned after a FlyPostBack action. Parameters - Default Value -
OnResponseError | Description Invoked if there is an error during a FlyPostBack action. Parameters - Default Value -
OnBeforeItemSelected | Description Invoked before item(s) are selected. Parameters - Default Value -
OnAfterItemSelected | Description Invoked after item(s) are selected. Parameters - Default Value -


WebListBoxImagesSettings

WebListBoxImagesSettings
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebListBoxImagesSettings

Glossary Item Box

WebListBoxImagesSettings Properties

TopScroller | Description Gets or sets the default image used for top scroller. ValueType Default Value
BottomScroller | Description Gets or sets the default image used for bottom scroller. ValueType Default Value


WebListBoxItem

WebListBoxItem
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebListBoxItem

Glossary Item Box

WebListBoxItem Properties

Name | Description Specifies the name of the item. ValueType Default Value
Image | Description Gets or sets the image url of item ValueType Default Value
Text | Description Gets or sets the text of item. ValueType Default Value
Value | Description Gets or sets the value of item. ValueType Default Value
Selected | Description Gets or sets the value that determines whether or not the item is selected. ValueType Default Value
ItemHeight | Description Gets or sets the height of item. ValueType Default Value
DisplayMode | Description Gets or sets the display mode of item. ValueType Default Value
Enabled | Description Gets or sets the value that determines whether or not an item is enabled. ValueType Default Value
ToolTip | Description Gets or sets the tooltip of item. ValueType Default Value
Visible | Description Gets or sets the value that determines whether or not an item is visible. ValueType Default Value
ImagePosition | Description Gets or sets the value that determines the position of image in an item. ValueType Default Value
ImageSize | Description Gets or sets the value that determines the image size of an item. ValueType Default Value
TargetURL | Description Gets or sets the target url when item is selected. Applicable when selection mode is set to single. ValueType Default Value
TargetWindow | Description Gets or sets the target window when item is selected. Applicable when selection mode is set to single. ValueType Default Value
ItemAlignment | Description Gets or sets the alignment of item. ValueType Default Value
ItemNormalClass | Description Gets or sets the css class applied to item in normal state. ValueType Default Value
ItemHoverClass | Description Gets or sets the css class applied to item in hover state. ValueType Default Value
ItemActiveClass | Description Gets or sets the css class applied to item in active state. ValueType Default Value
ItemImageClass | Description Gets or sets the css class applied to the image of item. ValueType Default Value
ItemTextClass | Description Gets or sets the css class applied to the text of item. ValueType Default Value

WebListBoxItem Methods

GetElement Description
Gets the frame element of a specified item.

Parameters

Remarks

Return Value

Samples

GetItemElement Description
Gets the item element of a specified item.

Parameters

Remarks

Return Value

Samples

GetItemIndicatorElement Description
Gets the indicator frame element of a specified item.

Parameters

Remarks

Return Value

Samples

GetIndex Description
Gets the index of a specified element.

Parameters

Remarks

Return Value

Samples

IsActive Description
Gets the value that indicates whether the specified item is selected.

Parameters

Remarks

Return Value

Samples


WebListBoxLayoutSettings

WebListBoxLayoutSettings
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebListBoxLayoutSettings

Glossary Item Box

WebListBoxLayoutSettings Properties

ImageSize | Description Gets or sets the value that determines the image size of an item. ValueType Default Value
ItemHeight | Description Gets or sets the value that determines the height of an item. ValueType Default Value
DisplayActiveItemIndicator | Description Gets or sets the value that determines whether active item indicator is displayed. ValueType Default Value
DisplayMode | Description Gets or sets the value that determines the display mode of items. ValueType Default Value
ImagePosition | Description Gets or sets the value that determines the position of image in an item. ValueType Default Value
ScrollMode | Description Gets or sets the value that determines the scroll mode of WebListBox. ValueType Default Value
TargetWindow | Description Gets or sets the value that determines the global target window when items are clicked. ValueType Default Value


WebProgressBar How-to Topics

WebProgressBar How-to Topics
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebProgressBar > WebProgressBar How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common WebProgressBar tasks.

In This Section

How-to: Modify WebProgressBar orientation

How-to: Modify WebProgressBar mode

How-to: Modify WebProgressBar rounded corner

How-to: Modify WebProgressBar indeterminate animation


WebProgressBar

WebProgressBar
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebProgressBar

Glossary Item Box

Whether your preference is vertical or horizontal, WebProgressBar provides an elegant progress indicator for your Web application.

Flexible View Customization

WebProgressBar supports horizontal and vertical orientations.

In horizontal mode, the progress will move from left-to-right.

In vertical mode, the progress will move from bottom-to-top.

To learn more about Orientation, see How-to: Modify WebProgressBar orientation.

Flexible Behavior Customization

WebProgressBar offers two progress modes, determinate and indeterminate. In Determinate option when the progress reaches 100%, the entire progress bar will be filled. The Indeterminate mode, the progress indicator runs continuously in an infinite cycle.

To learn more about WebProgressBar Mode, see How-to: Modify WebProgressBar mode.

Integrated with FullPostback and FlyPostback

Postback in WebProgressBar is triggered by several occasions, such as: on after certain interval passed, finished progress bar, or when the progress bar's value has changed.

Like the other WebEssential controls, WebProgressBar offers two postback options, FullPostBack and FlyPostBack; by simply set the PostBackMode property.

XHTML Compliance

WebProgressBar is designed to fully comply with W3C's XHTML standard - providing identical rendering when running in different modern XHTML-ready browsers.

Appearance and Styles

Default Styles

WebProgressBar has included a default style which could be customized further using the available style property which will be show below.

The included style for WebProgressBar is:

  • Default

  • Safari

  • Office 2007

  • Win7

Rounded Corner

WebProgressBar has also implement CSS 3 round corner property which will not require extra image to achieve the rounded corner looks. However, since the IE has not support CSS 3 even in their version 8 release, we are using the workaround introduced in http://code.google.com/p/curved-corner/.

If you would like to make the progress bar more/less rounded, please use the border-radius CSS 3 property in the ProgressContainerBarStyle and ProgressBarStyle, for example:

-moz-border-radius: 3px; -webkit-border-radius: 3px; -khtml-border-radius: 3px; border-radius: 3px;

Layout Overview

Indeterminate Animation

During Indeterminate mode, the animation could be controlled in 2 ways, using Step property and AnimationLatency property.

The Step property will determine how far the ProgressBar will move after each tick, by default it is set to 0.01 (1% of width in horizontal WebProgressBar).

The AnimationLatency will determine how fast is the next tick, by default it is set to 500 ms.

To learn more about rounded corner, see How-to: Modify WebProgressBar rounded corner.

To learn more about indeterminate animation, see How-to: Modify WebProgressBar indeterminate animation.

Comprehensive Client-side Events

  • OnValueChanged(ControlId, Value)
    The client-side event is triggered when the value is changed.

  • OnProgressInterval(ControlId, Value, Caption)
    The client-side event is triggered after a certain interval has passed.

  • OnFinished(ControlId, EndTime, Value, Caption)
    The client-side event is triggered after the progress has finished.

  • OnInitialize(ControlId)
    The client-side event is triggered during the initialization process.

Rich Client-side APIs

Methods | Description
GetFrameElement() | Obtain WebProgressBar's frame element.
GetBarElement(x) | Obtain WebProgressBar's bar element.
GetCaptionElement(x) | Obtain WebProgressBar's caption element.
DoStep() | Animate the progress according the specified setting.
GoToStep(n) | Move the progress bar to a specific point determined by the n value.
SetValue(n) | Set WebProgressBar's value and move it to the point determined by the n value.
SetCaption(n) | Set WebProgressBar's caption text with the n value.
Start() | Indicate the WebProgressBar instance as started.
Finish() | Indicate the WebProgressBar instance as finished.


WebProgressBar

WebProgressBar
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebProgressBar

Glossary Item Box

WebProgressBar Properties

ScriptDirectory | Description Gets or sets the directory where all required scripts for the control are stored. ValueType Default Value
ViewStateStorage | Description Gets or sets the location to store the viewstate of this control. ValueType Default Value
AccessKey | Description Keyboard shortcut used by the control. ValueType Default Value
Enabled | Description Enabled state of the control. ValueType Default Value
TabIndex | Description The tab order of the control. ValueType Default Value
ToolTip | Description The tooltip displayed when the mouse is over the control. ValueType Default Value
ID | Description Programmatic name of the control. ValueType Default Value
ImagesDirectory | Description Gets or sets the image directory. ValueType Default Value
Width | Description The width of the control. ValueType Default Value
Height | Description The height of the control. ValueType Default Value
Orientation | Description Gets or sets the progress bar orientation mode. ValueType Default Value
CaptionOrientation | Description Gets or sets the progress bar caption orientation mode. ValueType Default Value
Mode | Description Gets or sets the progress bar mode. ValueType Default Value
FrameStyle | Description Gets or sets the style applied to the frame of the progress bar. ValueType Default Value
ProgressContainerBarStyle | Description Gets or sets the style applied to the background container bar of the progress bar. ValueType Default Value
ProgressBarStyle | Description Gets or sets the style applied to the progress bar. ValueType Default Value
CaptionStyle | Description Gets or sets the style applied to the caption text of the progress bar. ValueType Default Value
Caption | Description Gets or sets the progress bar caption text. ValueType Default Value
Step | Description Gets or sets the progress bar step increment. Apply in Indeterminate mode only. ValueType Default Value
AnimationLatency | Description Gets or sets the progress bar animation refresh rate in ms. Apply in Indeterminate mode only. ValueType Default Value
MaxSliderDimension | Description Gets or sets the maximum dimension of the slider width during Indeterminate mode. ValueType Default Value
ClientSideEvents | Description Gets or sets the client side events for WebProgressBar. ValueType Default Value
Value | Description Gets or sets the progress bar current value. ValueType Default Value
MaxValue | Description Gets or sets the progress bar maximum value. ValueType Default Value
Interval | Description Gets or sets the Progress Bar interval value for ProgressInterval event handler. ValueType Default Value
UseDefaultStyle | Description Determines whether WebProgressBar is using default style. ValueType Default Value
AllowDefaultStyleMerging | Description Gets or sets the value that determines whether or not the default style can be merged with custom styles. ValueType Default Value
UseRoundCorner | Description Determines whether WebProgressBar is using rounder corner style. ValueType Default Value

WebProgressBar Methods

GetElement Description
Gets WebProgressBar's element.

Parameters

Remarks

Return Value

Samples

GetBarElement Description
Gets WebProgressBar's bar element.

Parameters

Remarks

Return Value

Samples

GetCaptionElement Description
Gets WebProgressBar's caption element.

Parameters

Remarks

Return Value

Samples

DoStep Description
Animates the progress according the specified setting.

Parameters

Remarks

Return Value

Samples

GoToStep Description
Moves the progress bar to a specific point determined by the n value.

Parameters
x ( )

Remarks

Return Value

Samples

SetValue Description
Sets WebProgressBar's value and move it to the point determined by the n value.

Parameters
val ( )

Remarks

Return Value

Samples

SetCaption Description
Sets WebProgressBar's caption text with the n value.

Parameters
val ( )

Remarks

Return Value

Samples

Start Description
Indicates the WebProgressBar instance as started.

Parameters

Remarks

Return Value

Samples

Finish Description
Indicates the WebProgressBar instance as finished.

Parameters

Remarks

Return Value

Samples


WebProgressBarClientSideEvents

WebProgressBarClientSideEvents
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebProgressBarClientSideEvents

Glossary Item Box

WebProgressBarClientSideEvents Properties

OnValueChanged | Description Gets or sets the event handler when the value is changed. Parameters controlId, Value Default Value -
OnProgressInterval | Description Gets or sets the event handler after a certain interval has passed. Parameters controlId, Value, Caption Default Value -
OnFinished | Description Gets or sets the event handler after the progress has finished. Parameters controlId, EndTime, Value, Caption Default Value -
OnInitialize | Description Gets or sets the event handler during the initialization process. Parameters controlId Default Value -


WebRating How-to Topics

WebRating How-to Topics
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebRating > WebRating How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common WebRating tasks.

In This Section

  • How-to: Set/Change WebRating Orientation
  • How-to: Set/Change WebRating Direction
  • How-to: Set/Change WebRating Item number
  • How-to: Set/Change WebRating precision behavior
  • How-to: Perform FullPostback in WebRating
  • How-to: Perform FlyPostback in WebRating


WebRating

WebRating
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebRating

Glossary Item Box

WebRating is a powerful and stylish addition to your blog or forum, or any Web application that requires an interactive user rating capability.

Flexible Orientation and Direction

WebRating offers two orientations, horizontal and vertical. When set, the rating direction will automatically follow its orientation, from left-to-right or top-to-bottom.

Additionally, the direction can be manipulated by setting IsReversed property to true.

To learn more about Orientation, see How-to: Set/Change WebRating Orientation.

To learn more about Direction, see How-to: Set/Change WebRating Direction.

Versatile Layout Customization

The combination of Value, MinimumValue and MaximumValue properties grants developers the ease to customize the entire layout. The Value property determines the WebRating's value. MinimumValue and MaximumValue represent the range of WebRating.

For example:

Value = 5
MinimumValue = 0
MaximumValue = 5

Value = 5
MinimumValue = 0
MaximumValue = 10

Value = 30
MinimumValue = 0
MaximumValue = 100

Flexible Tooltip Customization

WebRating's tooltips is designed for flexibility. It offers various options to match your need.

  • [currentValue]
    When users hover, the current value is displayed.

  • [selectedValue]
    When users hover, the selected value is displayed.

  • [maximumValue]
    When users hover, WebRating's maximum value is displayed.

  • [minimumValue]
    When users hover, WebRating's minimum value is displayed.

Flexible Number of Item

While generally only 5 stars are used for common rating, for example: a discussion forum, WebRating offers the flexibility to add or reduce the number of star (item). Simply provide ItemCount property with specific number.

To learn more about WebRating Item, see How-to: Set/Change WebRating Item number.

Customizable Rating Precision

WebRating offers three rating precision options that you can choose.

  • Whole

    Users will only be able to select full star, not partially, regardless of which part of an item (or star) that they click

  • Half

    This option enables half item selection. Simply click and move the mouse to the center of the start to select half.

  • Exact Position

    This option provides the most accurate rating as it follows the where the mouse cursor stops precisely. If the mouse cursor stops at 1/8 of the item, then the selection is 1/8 of the item.

To learn more about precision, see How-to: Set/Change WebRating precision behavior.

Integrated with FullPostback and Flypostback (or AJAX)

Postback is triggered when WebRating's item is clicked. The OnClick client-side event is invoked just before the postback occur giving you the ability to perform any additional programming before postback. With 2 postback options, FullPostBack and FlyPostBack, both actions will land in OnClick server-side event with the recently clicked value as the parameter.

OnClick client-side event must be specified in order to be triggered when an item is clicked.

To learn more about FullPostback, see How-to: Perform FullPostback in WebRating.

To learn more about FlyPostback, see How-to: Perform FlyPostback in WebRating.

ReadOnly mode

ReadOnly mode is a special feature which disables any rating actions. This feature is extremely useful under certain conditions, for example: you want to display a list of top rated blog posts. You need to set ReadOnly property to true.

XHTML Compliance

WebRating is designed to fully comply with W3C's XHTML standard - providing identical rendering when running in different modern XHTML-ready browsers.

Appearance and Styles

Default Styles

Three predefined styles are included.

  1. Default

  2. Black

  3. Windows 7

  4. Elegant Blue

  5. Crystal Red

Comprehensive Client-side Events

  • OnInitialize(controlId)
    This client-side event is triggered when WebRating is initialized.

  • OnClick(controlId)
    This client-side event is triggered when WebRating is clicked.

  • OnResponse(controlId)
    This client-side event is triggered when WebRating responds to a FlyPostBack action.

Rich Client-side APIs

Methods | Description
GetElement() | Obtain WebRating's element.
GetContainer() | Obtain WebRating's container element.
GetItemElementByIndex (index) | Obtain WebRating's item by index.
SetValue (value) | Set WebRating's value.


WebRating

WebRating
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebRating

Glossary Item Box

WeRating Properties

ScriptDirectory | Description Gets or sets the directory where all required scripts for the control are stored. ValueType Default Value
ImagesDirectory | Description Gets or sets the images directory. ValueType Default Value
ViewStateStorage | Description Gets or sets the location to store the viewstate of this control. ValueType Default Value
AccessKey | Description Keyboard shortcut used by the control. ValueType Default Value
Enabled | Description Enabled state of the control. ValueType Default Value
TabIndex | Description The tab order of the control. ValueType Default Value
ToolTip | Description Gets or sets WebRating tooltip value. ValueType Default Value
ID | Description Programmatic name of the control. ValueType Default Value
DefaultStyleMode | Description Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled. ValueType Default Value
AllowDefaultStyleMerging | Description Gets or sets the value that determines whether the default style can be merged with custom styles. ValueType Default Value
Orientation | Description Specifies WebSlider orientation. ValueType Default Value
IsReversed | Description Determines whether the moving of WebRating should be reversed. ValueType Default Value
Precision | Description Specifies WebRating precision. ValueType Default Value
Value | Description Specifies the value of WebRating. ValueType Default Value
MinimumValue | Description Specifies the minimal value of WebRating ValueType Default Value
MaximumValue | Description Specifies the maximum value of WebRating. ValueType Default Value
ItemCount | Description Specifies the item count of WebRating. ValueType Default Value
PostbackMode | Description Specifies WebRating postback mode. ValueType Default Value
ReadOnly | Description Determines whether WebRating is in readonly mode. ValueType Default Value
ImagesSettings | Description Provides the settings that control the images in WebRating. ValueType Default Value
ClientSideEvents | Description Contains client side events supported by WebRating. ValueType Default Value

WebRating Methods

GetElement Description
Gets WebRating's element.

Parameters

Remarks

Return Value

Samples

GetContainer Description
Gets WebRating's container element.

Parameters

Remarks

Return Value

Samples

GetItemElementByIndex Description
Gets WebRating's item by index.

Parameters
index ( )

Remarks

Return Value

Samples

SetValue Description
Sets WebRating's value.

Parameters
value ( )

Remarks

Return Value

Samples


WebRatingClientSideEvent

WebRatingClientSideEvent
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebRatingClientSideEvent

Glossary Item Box

WebRatingClientSideEvents Properties

OnInitialize | Description Gets or sets the event handler when WebRating is initialized. Parameters controlId Default Value -
OnClick | Description Gets or sets the event handler when WebRating is clicked. Parameters controlId Default Value -
OnResponse | Description Gets or sets the event handler when WebRating responds to a FlyPostBack action. Parameters controlId Default Value -


WebRatingImagesSettings

WebRatingImagesSettings
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebRatingImagesSettings

Glossary Item Box

WebRatingImagesSettings Properties

Empty | Description Sets the empty image of WebSlider rating. ValueType Default Value
Normal | Description Sets the normal image of WebSlider rating. ValueType Default Value
Border | Description Sets the border image of WebSlider rating. ValueType Default Value
Full | Description Sets the full image of WebSlider rating. ValueType Default Value


WebRibbon How-to Topics

WebRibbon How-to Topics
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebRibbon > WebRibbon How-to Topics

Glossary Item Box


WebRibbon

WebRibbon
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebRibbon

Glossary Item Box

Intersoft WebRibbon is a business-oriented ASP.NET ribbon UI control which is comprehensive, fast and easy to use. WebRibbon is part of Intersoft WebEssentials family that provides common ribbon functionality similar to the ribbon in Office 2010 applications. It consists of application menu, ribbon tab, group and group item. WebRibbon enables you to easily create rich Ribbon-friendly applications where application functions are neatly organized and related commands are grouped together. It transforms complex applications into easy-to-use interface with more intuitive user experiences.

WebRibbon is a rich yet lightweight control that provides many time-saving features and runs rapidly especially in response to browser resizing. WebRibbon is comprised of simple element structures:

  • Application Menu: contains of app. Menu item with its dropdown-list menu.
  • Ribbon Tab: contains of ribbon tab with its groups and items.

Here is sample of ASPX markup codes about how to define simple ribbon with single ribbon tab:

ASPX Copy Code
<ISWebEssentials:WebRibbon ID="WebRibbonCRM" runat="server">
  <RibbonTabs>
    <ISWebEssentials:WebRibbonTab Name="Opportunities" Text="Opportunities">
      <Groups>
        <ISWebEssentials:WebRibbonGroup Name="Records" Text="Records"
          ImageURL="./../Images/ribbon.Records.32.png">
          <Items>
            <ISWebEssentials:WebRibbonGroupItem Name="New" Text="New"
              MinSizeState="Medium" ImageURL="./../Images/ribbon.new.32.png"
              SmallImageURL="./../Images/ribbon.new.16.png" />
            <ISWebEssentials:WebRibbonGroupItem Name="Edit" Text="Edit"
              MinSizeState="Medium"  ImageURL="./../Images/ribbon.edit.32.png"
              SmallImageURL="./../Images/ribbon.edit.16.png" />
            <ISWebEssentials:WebRibbonGroupItem Name="Merge" Text="Merge"
              MinSizeState="Medium" ImageURL="./../Images/ribbon.merge.32.png"
              SmallImageURL="./../Images/ribbon.merge.16.png" />
            <ISWebEssentials:WebRibbonGroupItem Name="Import" Text="Import"
              MaxSizeState="Medium" SmallImageURL="./../Images/ribbon.import.16.png" />
            <ISWebEssentials:WebRibbonGroupItem Name="Delete" Text="Delete"
              MaxSizeState="Medium" SmallImageURL="./../Images/ribbon.delete.16.png" />
            <ISWebEssentials:WebRibbonGroupItem Name="BulkDelete" Text="Bulk Delete"
              MaxSizeState="Medium" SmallImageURL="./../Images/ribbon.bulkdelete.16.png" />
          </Items>
        </ISWebEssentials:WebRibbonGroup>
        <ISWebEssentials:WebRibbonGroup Name="Actions" Text="Actions"
          ImageURL="./../Images/ribbon.Actions.32.png">
          <Items>
            <ISWebEssentials:WebRibbonGroupItem Name="CloseWon" Text="Close As Won"
              ImageURL="./../Images/ribbon.Close_as_won.32.png" MinSizeState="Large" />
            <ISWebEssentials:WebRibbonGroupItem Name="CloseLost" Text="Close As Lost"
              ImageURL="./../Images/ribbon.Close_as_lost.32.png" MinSizeState="Large" />
            <ISWebEssentials:WebRibbonGroupItem Name="Recalculate" Text="Recalculate"
              ImageURL="./../Images/ribbon.calculate_probability.32.png"
              MinSizeState="Large" />
            <ISWebEssentials:WebRibbonGroupItem Name="Share" Text="Share"
              SmallImageURL="./../Images/ribbon.share.16.png" MaxSizeState="Medium" />
            <ISWebEssentials:WebRibbonGroupItem Name="CopyLink" Text="Copy a Link"
              SmallImageURL="./../Images/ribbon.copy_link.16.png"
              MaxSizeState="Medium" />
            <ISWebEssentials:WebRibbonGroupItem Name="EmailLink" Text="Email a Link"
              SmallImageURL="./../Images/ribbon.email_link.16.png" MaxSizeState="Medium" />
          </Items>
        </ISWebEssentials:WebRibbonGroup>
        <ISWebEssentials:WebRibbonGroup Name="Process" Text="Process"
          CollapseAllowed="false">
          <Items>
             <ISWebEssentials:WebRibbonGroupItem Name="RunWF" Text="Run Workflow"
              ImageURL="./../Images/ribbon.workflow.32.png" MinSizeState="Large" />
          </Items>
         </ISWebEssentials:WebRibbonGroup>
      </Groups>
    </ISWebEssentials:WebRibbonTab>
  </RibbonTabs>
</ISWebEssentials:WebRibbon>

As you can see, the “CRM” ribbon-tab contains three groups of items:

  1. The “Records” group contains buttons to maintain opportunities records.
  2. The “Actopms” group contains buttons to do action against opportunities.
  3. The “Process” group contains single button to process opportunities workflow.

Image of WebRibbon in Visual Studio 2010 Web Form Editor (ASPX markup and designer)

Image of WebRibbon on action in IE.9

This topic summarizes the key features available in WebRibbon. It provides information about the basic features of WebRibbon such as application menu, ribbon tab, group and group item. You will also learn how to use WebRibbon such as handle client side events and setting group-item type and mode.

This topic discusses the WebCombo features in depth, which contains the following topics.

  • Ribbon
    Ribbon is the top container of all elements that constructs a logical ribbon interface. WebRibbon provides you with two models of menu. Those are dropdown menu list and ribbon tab menu. Dropdown menu will named Application Menu which will simply display menu items in a dropdown list. Ribbon tab menu will display a ribbon bar that contains many items divided into groups.

  • Application Menu
    As the main navigation bar that contains of all navigation of the page, WebRibbon provides standard menu named Application Menu. The application menu is a dropdown menu list that contains menu items. The application menu in WebRibbon is further simplified to suit line-of-business scenarios.

  • Ribbon Tab
    The ribbon tab is main element of the WebRibbon which provides an elegant solution for complex scenarios when a page requires numerous commands and navigation options. With WebRibbon, you can divide these actions into tabs and/or groups inside a ribbon tab.

  • Contextual Tab
    The contextual tab is an idea of grouping ribbon tab in the group of a context. By grouping ribbon tab into specific context, you can hide or show this group on specific case. For example, when focusing or processing on attachment file in Microsoft Outlook application, it will show Attachment Tools contextual tab that contains of single ‘Attachments’ ribbon tab.

  • Resizing
    As container of complex content that contains many navigation and action buttons. WebRibbon provides functionality that responds to window resizing. It will automatically resize all items and perform layout calculation so that all items still can be viewed clearly by user. In the tutorial, you will learn how to configure the resizing process of WebRibbon.

WebRibbon Control

WebRibbon control is easy to use and does not require customization of many properties. All you have to do is defining ASPX markup code such as shown below:

ASPX Copy Code
<ISWebEssentials:WebRibbon ID="MyWebRibbon" runat="server"></ISWebEssentials:WebRibbon>

What you need to do is to specify whether you need dropdown menu list or application menu by settings in ApplicationMenus property and ribbon tab bar by specifying the ribbon tab in RibbonTabs property.

Application Menu

Application menu is a simple dropdown menu list provided by WebRibbon. WebRibbon allows you to define multiple application menus for ultimate flexibility. The defined application menus will be placed in the left side of top bar before the ribbon tab menu.

Image of File application menu clicked and show dropdown menu list

The following code is the ASPX markup code to specify File application menu that contains menu items Open and Save:

ASPX Copy Code
<ISWebEssentials:WebRibbon ID="WebRibbonCRM" runat="server">
  <ApplicationMenus>
    <ISWebEssentials:WebRibbonApplicationMenuItem Name="Home" Text="Home">
      <Items>
        <ISWebEssentials:WebRibbonApplicationMenuListItem Name="Info" Text="Info"
          Description="Information about CRM application." />
        <ISWebEssentials:WebRibbonApplicationMenuListItem Name="Print" Text="Print"
          Description="Print File or Document." />
        <ISWebEssentials:WebRibbonApplicationMenuListItem Name="Separator1"
          ApplicationMenuListItemType="Separator" />
        <ISWebEssentials:WebRibbonApplicationMenuListItem Name="Help" Text="Help"
          Description="Find help about how to use this application." />
      </Items>
    </ISWebEssentials:WebRibbonApplicationMenuItem>
  </ApplicationMenus>
</ISWebEssentials:WebRibbon>

Application Menu List

Application menu is a dropdown list menu that is displayed when the user clicks the application menu. The dropdown list in WebRibbon is named Application Menu List. An application menu list consists of menu items represented as WebRibbonApplicationMenuListItem class.

The above figure shows the application menu list of File menu.

There are two types of application menu list items:

  • Button (default)
  • Separator

The button has five properties that you can set:

  • Text is the title of application menu list item.
  • Description is the description of the menu.
  • ImageURL is the URL of image in the left side or you can leave it blank
  • URL is the first URL executed when user click the menu.
  • OnClientClick is the JavaScript function that will be executed when user click the menu.
When the user clicks the menu, it will execute the specified URL if defined. Otherwise, it will execute OnClientClick if defined.

Ribbon Tab

Ribbon tab makes WebRibbon a very powerful navigation component because it can hold many items in its container. It also responds to resizing or the browser window. WebRibbon will maintain the size of ribbon tab and its items to the best fit of the width of the window, so users can still view all the items defined in the ribbon tab.

Ribbon tab in WebRibbon is represented as WebRibbonTab class. It consists of items divided into groups. WebRibbonGroup represents a group, while WebRibbonGroupItem represents a group item.

There are two type of ribbon tab: non-contextual tab (standard) and contextual tab. You can as many tabs as you desire for both the standard and contextual tab. To define a contextual tab, you set the ContextualGroupName property of the ribbon to the desired name or simply leave it empty for non-contextual tab. You can also easily specify the contextual color theme by specifying the ContextualGroupStyle property of each contextual tab. You can customize contextual tab by setting contextual tab of WebRibbon’s ContextualTabs property. For more information about customizing contextual tab, please see Contextual Tab section.

The following code shows the ASPX markup to define CRM WebRibbon with five ribbon tabs such as Opportunities, View, Search, FollowUp and Report. Search tab belongs to SearchTool contextual, while FollowUp and Report tabs belong to Schedule contextual.

ASPX Copy Code
<ISWebEssentials:WebRibbon ID="WebRibbonCRM" runat="server">
  <RibbonTabs>
    <ISWebEssentials:WebRibbonTab Name="Opportunities" Text="Opportunities">
      // opportunities groups and items here.
    </ISWebEssentials:WebRibbonTab>
    <ISWebEssentials:WebRibbonTab Name="View" Text="View" />
    <ISWebEssentials:WebRibbonTab Name="Search" Text="Search"
      ContextualGroupName="SearchTool" />
    <ISWebEssentials:WebRibbonTab Name="FollowUp" Text="Follow Up"
      ContextualGroupName="Schedule" />
    <ISWebEssentials:WebRibbonTab Name="Report" Text="Report"
      ContextualGroupName="Schedule" />
  </RibbonTabs>
</ISWebEssentials:WebRibbon>

Group

Group is a partition of items in ribbon tab divided into a specific category. In WebRibbon, you must specify a group before adding items. The group is represented as a WebRibbonGroup class.

The ribbon tab responds on browser window resizing based on the value specified in the group size state. The topic of resizing will be covered in the Resizing topic, but let’s take a look at the WebRibbonSizeState enumeration below.

Example Title Copy Code
public enum WebRibbonSizeState
{
    Hide = -1,
    Collapse = 0,
    Small = 1,
    Medium = 2,
    Large = 3
}

WebRibbon group responds to window resizing by calculating the best fit size state and that of all items the items in the group. The size state of WebRibbonGroup is available ranging from Hide to Large size state, but it can also be customized through the HideAllowed and CollapseAllowed properties. These properties have default value set to true, which means the group can be hidden or collapsed.

When a group needs to be resized into Collapse size state, it will display a large button with group image and group text. If the user clicks the button, it will display a dropdown panel containing the items being hidden.

Image of Group in Large and Collapse size state

Image of Collapse Group and dropdown panel

Here is the ASPX markup to define some groups inside a ribbon tab:

ASPX Copy Code
<ISWebEssentials:WebRibbonTab Name="Opportunities" Text="Opportunities">
  <Groups>
    <ISWebEssentials:WebRibbonGroup Name="Records" Text="Records"
      ImageURL="./../Images/ribbon.Records.32.png">
      // records items here.
    </ISWebEssentials:WebRibbonGroup>
    <ISWebEssentials:WebRibbonGroup Name="Actions" Text="Actions"
      ImageURL="./../Images/ribbon.Actions.32.png" />
    <ISWebEssentials:WebRibbonGroup Name="Process" Text="Process"
      CollapseAllowed="false" />
  </Groups>
</ISWebEssentials:WebRibbonTab>

Group Item

Group item is a button component provided by WebRibbon. It is represented by WebRibbonGroupItem class. WebRibbon offer four types of buttons with specific mode or behaviors like toggle button and split button.

There are four button types:

  • Button
  • ToggleButton (CheckBox and RadioButton modes)
  • DropDownListButton
  • SplitButton (Single and Multiple modes)

Here are the four button types and button modes represented in enums:

C# Copy Code
public enum WebRibbonGroupItemType
{
        Button = 0,
        ToggleButton = 1,
        DropDownListButton = 2,
        SplitButton = 3
}
public enum WebRibbonToggleButtonMode
{
        CheckBox = 0,
        RadioButton = 1
}
public enum WebRibbonSplitButtonMode
{
        Single = 0,
        Multiple = 1
}

Each specific type will be discussed in more detail in the next section; however, there are some important properties that affect the appearance and behavior of the button beside the type and mode.

  • ImageURL: specify 32x32 image for large size state of the item.
  • SmallImageURL: specify 16x16 image for small and medium size state of the item.
  • Text: specify title of the item in large and medium size state.
  • MaxSizeState: specify the maximum size of the item in response of resizing.
  • MinSizeState: specify the minimum size of the item in response of resizing.
  • Checked: represents cheked state of the toggle button type.
  • GroupName: specify group name of the toggle button with radio button mode.
  • URL: specify the url that will be executed if button or split-button being clicked.
  • OnClientClick: specify javascript function or code that will be executed if URL is not specified before.
  • OnCheckedChanged: specify javascript function or code that will be executed when checked state of toggle button changed.

Button

Button is the standard button component in WebRibbon. The behavior of button is similar to a standard HTML button control which comprised of an image and additional URL property. Similar to the hyperlink button, the additional URL allows developers to automatically utilize the button and hyperlink function in a single component.

The rule of this behavior is if the URL property is specified then it will be executed and OnClientClick property will be ignored, otherwise it will execute the OnClientClick property. You can specify a function name to be executed or use an in-line JavaScript function in OnClientClick property.

The figure above shows the buttons in large, medium and small size state

Here is a basic sample of ASPX markup code to define butt¬on inside a group:

ASPX Copy Code
<ISWebEssentials:WebRibbonGroup Name="Records" Text="Records"
  ImageURL="./../Images/ribbon.Records.32.png">
  <Items>
    <ISWebEssentials:WebRibbonGroupItem Name="New" Text="New"
      ImageURL="./../Images/ribbon.new.32.png"
      SmallImageURL="./../Images/ribbon.new.16.png" />
    // … other items
  </Items>
</ISWebEssentials:WebRibbonGroup>
Since WebRibbonGroupItemType.Button is the default value of a group item type, GroupItemType=”Button” is not necessarily defined.

Toggle Button

Toggle button provides checkbox or radio button functionality. The only difference is in the appearance, although the behavior is identical. The default mode of toggle button is WebRibbonToggleButtonMode.CheckBox. Like a common checkbox control, you can check or uncheck and then change the control checked state which ignores other checkbox controls. In radio button mode, the control will behave like common radio button control. When you check the control it will automatically uncheck other radio button controls in the same group. You can specify a group of radio button by specifying the GroupName property of WebRibbonGroupItem.

The behavior of checkbox is as follows: when user clicks the button, it will change the checked state property. Afterward, it will invoke the OnCheckedChanged client-side event. You can specify a JavaScript function name or inline JavaScript function to be invoked automatically.

The figure above shows the large size checkbox in unchecked and checked state.

The figure above shows the group of large size radio button.

Here is the ASPX markup code to define toggle button with check box mode:

ASPX Copy Code
<ISWebEssentials:WebRibbonGroup Name="EmailStatusGroup" Text="Email Status">
  <Items>
    <ISWebEssentials:WebRibbonGroupItem Name="UnRead" Text="UnRead"
      GroupItemType="ToggleButton" ToggleButtonMode="CheckBox"
      OnCheckedChanged="ChangeUnreadStatus;"  ImageURL="./Images/unread.32.png"
      SmallImageURL="./Images/unread.16.png" />
    // … other items
  </Items>
</ISWebEssentials:WebRibbonGroup>

Here is the ASPX markup code to define group of toggle buttons with radio button mode:

ASPX Copy Code
<ISWebEssentials:WebRibbonGroup Name="Actions" Text="Actions">
  <Items>
    <ISWebEssentials:WebRibbonGroupItem Name="MarkCompleted" Text="Mark as Completed"
      GroupItemType="ToggleButton" ToggleButtonMode="RadioButton"
      GroupName="RecordStatus"
      MinSizeState="Large"  ImageURL="./../Images/ribbon.mark_as_completed.32.png" />
    <ISWebEssentials:WebRibbonGroupItem Name="MarkPending" Text="Mark as Pending"
      GroupItemType="ToggleButton" ToggleButtonMode="RadioButton"
      GroupName="RecordStatus"
      MinSizeState="Large" ImageURL="./../Images/ribbon.mark_as_pending.32.png" />
    // … other items
  </Items>
</ISWebEssentials:WebRibbonGroup>

DropDownList Button

Dropdown list button is a button that will show dropdown list which contains menu items when clicked by the user. The dropdown list panel itself contains menu items that you specify in the MenuItems property of WebRibbonGroupItem.

The above figure shows the dropdown list button when the menu is hidden and shown.

Here is the ASPX markup code to define dropdown list button:

ASPX Copy Code
<ISWebEssentials:WebRibbonGroup Name="Refine" Text="Refine"
  ImageURL="./../Images/ribbon.Refine.32.png">
  <Items>
    <ISWebEssentials:WebRibbonGroupItem Name="Actions" Text="Actions"
      GroupItemType="DropDownListButton" MinSizeState="Large"
      ImageURL="./../Images/ribbon.actions.32.png">
      <MenuItems>
        <ISWebEssentials:WebRibbonMenuItem Name="Email" Text="Email"
          OnClientClick="ScheduleActionChanged" />
        <ISWebEssentials:WebRibbonMenuItem Name="Phone" Text="Phone Call"
          OnClientClick="ScheduleActionChanged" />
        <ISWebEssentials:WebRibbonMenuItem Name="Meeting" Text="Meeting"
          OnClientClick="ScheduleActionChanged" />
        <ISWebEssentials:WebRibbonMenuItem Name="LiveChat" Text="Live Chat"
          OnClientClick="ScheduleActionChanged" />
      </MenuItems>
    </ISWebEssentials:WebRibbonGroupItem>
    // … other items
  </Items>
</ISWebEssentials:WebRibbonGroup>

Split Button

Split button is combination of a button and a dropdownlist button. With split button, you expose one common button and a dropdown button. There are two modes of split button:

  • Single: all buttons are in one topic/purpose of a group category. For example, a Text Color button normally contains a command button that represents the last selected color, and an arrow button to select another color. The objective is simply to select a color.
  • Multiple: all buttons are in different topics/purposes of a group category.
    The sample is such as when you want to group all “file save” actions into split button. So the command button in this case will be “New”, while the dropdown list panel inside contains Edit, Save and Save As menu item.

The different of those modes is only the appearance when the button is in large size state, other behaviors remain the same. The command button in split button has behaviors similar to the standard button which allows you to specify the URL or OnClientClick property, while the dropdown button will show the dropdown list menu when clicked.

The figure above shows the split button with single category being hovered (medium and large)

The figure above shows the split button with multiple categories being hovered (medium and large)

Here is the ASPX markup code to define split-button with single mode:

ASPX Copy Code
<ISWebEssentials:WebRibbonGroup Name="Refine" Text="Refine"
  ImageURL="./../Images/ribbon.Refine.32.png">
  <Items>
    <ISWebEssentials:WebRibbonGroupItem Name="Emails" Text="Yahoo Mail"
      GroupItemType="SplitButton" SplitButtonMode="Single"
      ImageURL="./Images/yahoo.mail.32.png" SmallImageURL="./Images/yahoo.mail.16.png">
      <MenuItems>
        <ISWebEssentials:WebRibbonMenuItem Name="Yahoo" Text="Yahoo Mail"
          ImageURL="./Images/yahoo.mail.16.png" OnClientClick="EmailChange" />
        <ISWebEssentials:WebRibbonMenuItem Name="Google" Text="Google Mail"
          ImageURL="./Images/gmail.16.png" OnClientClick="EmailChange" />
        <ISWebEssentials:WebRibbonMenuItem Name="Hotmail" Text="Hotmail"
          ImageURL="./Images/msn.hotmail.16.png" OnClientClick="EmailChange" />
      </MenuItems>
    </ISWebEssentials:WebRibbonGroupItem>
    // … other items
  </Items>
</ISWebEssentials:WebRibbonGroup>

Here is the ASPX markup code to define split-button with multiple mode:

ASPX Copy Code
<ISWebEssentials:WebRibbonGroup Name="Refine" Text="Refine"
  ImageURL="./../Images/ribbon.Refine.32.png">
  <Items>
    <ISWebEssentials:WebRibbonGroupItem Name="Actions" Text="Email"
      GroupItemType="SplitButton" SplitButtonMode="Multiple"
      ImageURL="./Images/ribbon.actions.32.png"
      SmallImageURL="./Images/ribbon.actions.16.png">
      <MenuItems>
        <ISWebEssentials:WebRibbonMenuItem Name="Phone" Text="Phone Call" />
        <ISWebEssentials:WebRibbonMenuItem Name="Meeting" Text="Meeting" />
        <ISWebEssentials:WebRibbonMenuItem Name="LiveChat" Text="Live Chat" />
      </MenuItems>
    </ISWebEssentials:WebRibbonGroupItem>
    // … other items
  </Items>
</ISWebEssentials:WebRibbonGroup>

Contextual Tab

It is optional to specify contextual tab element for groups of contextual ribbon tab. By specifying ContextualGroupName property of the ribbon to the desired name, it already converts a ribbon tab to a contextual tab. All ribbons tab with same ContextualGroupName are grouped into single contextual tab group.

Contextual tab in WebRibbon is represented as WebRibbonContextualTabGroup class. You need to specify this element inside ContextualTabs property of WebRibbon to customize display text, visible status and the style of the contextual tab group.

WebRibbon provides you with eight contextual color styles which are represented in WebRibbonContextualGroupStyle enum.

C# Copy Code
public enum WebRibbonContextualGroupStyle
{
        LightBlue = 0,
        DarkBlue = 1,
        Teal = 2,
        Purple = 3,
        Magenta = 4,
        Orange = 5,
        Yellow = 6,
        Green = 7
}

The above figure shows all contextual styles available in WebRibbon

From the figure above, you can see all styles of ribbon tab from the white standard tab to eight predefined styles of the contextual tab. The following code shows the ASPX markup to define all ribbon tabs such as shown in the figure above.

ASPX Copy Code
<ISWebEssentials:WebRibbon ID="WebRibbonCRM" runat="server">
  <ContextualTabs>
    <ISWebEssentials:WebRibbonContextualTabGroup Name="LightBlueTheme"
      Text="Light Blue Theme" ContextualGroupStyle="LightBlue" />
    <ISWebEssentials:WebRibbonContextualTabGroup Name="DarkBlueTheme"
      Text="Dark Blue Theme" ContextualGroupStyle="DarkBlue" />
    <ISWebEssentials:WebRibbonContextualTabGroup Name="TealTheme"
      Text="Teal Theme" ContextualGroupStyle="Teal" />
    <ISWebEssentials:WebRibbonContextualTabGroup Name="PurpleTheme"
      Text="Purple Theme" ContextualGroupStyle="Purple" />
    <ISWebEssentials:WebRibbonContextualTabGroup Name="MagentaTheme"
      Text="Magenta Theme" ContextualGroupStyle="Magenta" />
    <ISWebEssentials:WebRibbonContextualTabGroup Name="OrangeTheme"
      Text="Orange Theme" ContextualGroupStyle="Orange" />
    <ISWebEssentials:WebRibbonContextualTabGroup Name="YellowTheme"
      Text="Yellow Theme" ContextualGroupStyle="Yellow" />
    <ISWebEssentials:WebRibbonContextualTabGroup Name="GreenTheme"
      Text="Green Theme" ContextualGroupStyle="Green" />
  </ContextualTabs>
  <RibbonTabs>
    <ISWebEssentials:WebRibbonTab Name="FollowUpLightBlue" Text="Follow Up"
      ContextualGroupName="LightBlueTheme" />
    <ISWebEssentials:WebRibbonTab Name="FollowUpDarkBlue" Text="Follow Up"
      ContextualGroupName="DarkBlueTheme" />
    <ISWebEssentials:WebRibbonTab Name="FollowUpTeal" Text="Follow Up"
      ContextualGroupName="TealTheme" />
    <ISWebEssentials:WebRibbonTab Name="FollowUpPurple" Text="Follow Up"
      ContextualGroupName="PurpleTheme" />
    <ISWebEssentials:WebRibbonTab Name="FollowUpMagenta" Text="Follow Up"
      ContextualGroupName="MagentaTheme" />
    <ISWebEssentials:WebRibbonTab Name="FollowUpOrange" Text="Follow Up"
      ContextualGroupName="OrangeTheme" />
    <ISWebEssentials:WebRibbonTab Name="FollowUpYellow" Text="Follow Up"
      ContextualGroupName="YellowTheme" />
    <ISWebEssentials:WebRibbonTab Name="FollowUpGreen" Text="Follow Up"
      ContextualGroupName="GreenTheme" />
  </RibbonTabs>
</ISWebEssentials:WebRibbon>

Resizing

Another feature that makes WebRibbon a sophisticated command and navigation control is the fluid resizing functionality which responds to the browser window resizing. If the browser is resized to a smaller size, the ribbon will render itself and its child controls to the best fit according to the available width; if the browser is resized to wider, it also resizes to the optimal wider size possible for itself and its child controls. You can disable resizing process by providing an OnResizing function and set the return value to false.

There are some configurations that you can use to customize the resizing behavior of WebRibbon:

  • ResizingGroupsOrder property of WebRibbonTab is used if you want to configure the resizing order of the group inside ribbon tab. To set resizing group order, specify the group name separated by comma. The default resizing order is from the first group to the last group.

    The following example will resize group started from Actions, Records, then back to Process.

    ASPX Copy Code
    <ISWebEssentials:WebRibbonTab Name="Opportunities" Text="Opportunities"
  ResizingGroupsOrder="Actions,Records">
         <Groups>
           <ISWebEssentials:WebRibbonGroup Name="Records" Text="Records" />
           <ISWebEssentials:WebRibbonGroup Name="Actions" Text="Actions" />
           <ISWebEssentials:WebRibbonGroup Name="Process" Text="Process" />
         </Groups>
</ISWebEssentials:WebRibbonTab>
  • IsCollapseAllowed property of WebRibbonGroup will take effect when the browser window is smaller and the need to resize group to Collapse state. If the IsCollapse property is set to false, the smallest size state possible of the group is always Small state.
  • IsHideAllowed property of WebRibbonGroup will take effect when the browser window is smaller and there is need to hide a group to allow other groups to be visible to the user. If IsHideAllowed is set to true, whenever the group is in Collapse state and it is still too big to diplay, the resizing engine will hide the group and make it not visible to the user.
  • MaxSizeState property of WebRibbonGroupItem determines the maximum size state possible whenever resizing engine renders the group item to wider state in response to window resizing. This is required so that users get the best view and largest view possible of all items in the group of selected ribbon tab.
  • MinSizeState property of WebRibbonGroupItem determines the minimum size state possible whenever the resizing engine renders the group item to smaller state in response to window resizing.


WebRibbon

WebRibbon
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebRibbon

Glossary Item Box

WebRibbon Properties

ScriptDirectory | Description Gets or sets the directory where all required scripts for the control are stored. ValueType String Default Value
ImagesDirectory | Description Gets or sets the images directory for ImagesSettings. ValueType String Default Value
Enabled | Description Enables state of the control. ValueType Boolean Default Value
ID | Description Programmatic id of the server-control. ValueType String Default Value
ElementID | Description Programmatic id of the top element of WebRibbon. ValueType String Default Value
ApplicationMenus | Description The WebRibbonApplicationMenuItem collection used by WebRibbon. ValueType Array Default Value
RibbonTabs | Description The WebRibbonTab collection used by WebRibbon. ValueType Array Default Value
ClientSideEvents | Description Contains client-side events supported by WebRibbon. ValueType WebRibbonClient Default Value
CommonResources | Description Contains URL path of common resources used by WebRibbon and other child components. ValueType WebRibbonClient Default Value
NonContextualTabGroup | Description The NonContextualTabGroup used by WebRibbon. ValueType NonContextualTabGroup Default Value
ContextualTabs | Description The WebRibbonContextualTabGroup collection used by WebRibbon. ValueType Array Default Value

WebRibbon Methods

IsRibbonElement

Description
Check whether a html element (DOM) belongs to the ribbon.

Parameters
DOM element

Remarks

Return Value
Boolean

Samples

SetEnabled Description
Sets enabled property of WebRibbon and its children to enable or disable. And also set the style of all components.

Parameters
enabled (Boolean)

Remarks

Return Value

Samples

SetSelectedRibbonTab Description
Sets SelectedRibbonTab property of WebRibbon to new WebRibbonTab. Also sets the style of related components.

Parameters
ribbonTab (WebRibbonTab)

Remarks

Return Value

Samples

IsMouseOver Description
Check whether current mouse pointer is over the ribbon element.

Parameters
ribbonTab (WebRibbonTab)

Remarks

Return Value
Boolean

Samples


WebRibbonApplicationMenuItem

WebRibbonApplicationMenuItem
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebRibbonApplicationMenuItem

Glossary Item Box

WebRibbonApplicationMenuItem Properties

Name | Description Gets or sets the unique name of the component. Note: Name must be unique among others in the same container. ValueType String Default Value
Text | Description Gets or sets the title that displayed in the page. ValueType String Default Value
Items | Description The WebRibbonApplicationMenuListItem collection used by WebRibbonApplicationMenuItem to construct its dropdown-list menu. ValueType Array Default Value
Enabled | Description Enabled state of the control. ValueType Boolean Default Value

WebRibbonApplicationMenuItem Methods

SetEnabled

Description
Sets Enabled property of WebRibbonApplicationMenuItem and its children to enable or disable. Also sets the style of itself and all child-components.

Parameters
enabled (Boolean)

Remarks

Return Value
RibbonTabGroup object

Samples

SetText Description
Sets Text property of WebRibbonApplicationMenuItem and render the text to its UI.

Parameters
text (String)

Remarks

Return Value

Samples

IsMenuShow Description
Check whether the dropdown menu of this item is shown.

Parameters

Remarks

Return Value
Boolean

Samples


WebRibbonApplicationMenuListItem

WebRibbonApplicationMenuListItem
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebRibbonApplicationMenuListItem

Glossary Item Box

WebRibbonApplicationMenuListItem Properties

Name | Description Gets or sets the unique name of the component. Note: Name must be unique among others in the same container. ValueType String Default Value
ApplicationMenuListItemType | Description Gets or sets the type of application menu list item. ValueType ApplicationMenuListItemType (Button and Separator) Default Value ApplicationMenuListItemType.Button
Text | Description Gets or sets the title that displayed in the menu. ValueType String Default Value
Description | Description Gets or sets the description that displayed in the menu. ValueType String Default Value
ImageURL | Description Gets or sets the URL of the image of the menu. ValueType String Default Value The value of CommonResource.ImgBlank property of WebRibbon.
URL | Description Gets or sets the URL of the browser window when being clicked by the user. Note: If you provide OnApplicationMenuListItemClick, it must return true to be executed. ValueType String Default Value
OnClientClick | Description Gets or sets function that will be invoked after being clicked by the user. Note: If you provide OnApplicationMenuListItemClick, it must return true to be executed. This is the second option will be executed if the URL property is null or empty. ValueType The javascript function name or javascript anonymous function definition. Default Value
Enabled | Description Enabled state of the control. ValueType Boolean Default Value

WebRibbonApplicationMenuListItem Methods

SetEnabled Description
Sets enabled property of WebRibbonApplicationMenuListItem to enable or disable. And also set the style of itself.

Parameters
enabled (Boolean)

Remarks

Return Value

Samples

SetText Description
Sets Text property of WebRibbonApplicationMenuListItem and render the text of its UI.

Parameters
text (String)

Remarks

Return Value

Samples

SetImageURL Description
Sets ImageURL property of WebRibbonApplicationMenuListItem and render the image to its UI.

Parameters
url (String)

Remarks

Return Value

Samples

SetDescription Description
Sets Desription property of WebRibbonApplicationMenuListItem and renders the description of its UI.

Parameters
text (String)

Remarks

Return Value

Samples


WebRibbonClientSideEvents

WebRibbonClientSideEvents
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebRibbonClientSideEvents

Glossary Item Box

WebRibbonClientSideEvents Properties

OnInitiliazed Description
Gets or sets function that will be invoked after all client objects being initialized.

ValueType
The javascript function name or javascript anonymous function defintion.

Default Value

OnSelectedRibbonTabChanged Description
Gets or sets function that will be invoked after SelectedRibbonTab property of WebRibbon has changed.

ValueType
The javascript function name or javascript anonymous function definition.

Default Value

OnResizing Description
Gets or sets funtion that will be invoked before resizing process begin in response of browser window onresize event.

ValueType
The javascript function name or javascript function definition.

Default Value

OnResized Description
Gets or sets function that will be invoked after resizing process begin in response of browser window onresize event.

ValueType
The javascript function name or javascript anonymous function definition.

Default Value

OnApplicationMenuItemClick Description
Gets or sets function that will be invoked if app. menu item being clicked and before its dropdown-list menu being shown.

ValueType
The javascript function name or javascript anonymous function definition.

Default Value

OnApplicationMenuListItemClick

Description
Gets or sets function that will be invoked if app. menu-list item being clicked and before its URL property or OnClientClick event being invoked.

ValueType
The javascript function name or javascript anonymous function definition.

Default Value

OnRibbonTabClick Description
Gets or sets function that will be invoked if ribbon-tab being clicked and before SelectedRibbonTab property of WebRibbon change to new WebRibbonTab.

ValueType
The javascript function name or javascript anonymous function definition.

Default Value

OnGroupItemClick

Description
Gets or sets function that will be invoked if group-item being clicked and before its URL property or OnClientClick event being invoked.

Note: This apply to GroupItemType.Button and the main button of GroupItemType.SplitButton

ValueType
The javascript function name or javascript anonymous function definition.

Default Value

OnGroupItemCheckedChanged

Description
Gets or sets function that will be invoked after Checked property of WebRibbonGroupItem has changed.

Note: This apply to GroupItemType.ToggleButton.

ValueType
The javascript function name or javascript anonymous function definition.

Default Value

OnGroupItemMenuShow

Description
Gets or sets function that will be invoked if the user clicks the arrow element of WebRibbonGroupItem that triggered to show dropdown-list menu. This event will be invoked before its dropdown-list menu being shown.

Note: This apply to GroupItemType.DropDownListButton and arrow button of GroupItemType.SplitButton.

ValueType
The javascript function name or javascript anonymous function definition.

Default Value

OnMenuItemClick

Description
Gets or sets function that will be invoked if menu-item being clicked and before its URL property or OnClientClik event being invoked.

Note: This apply to WebRibbonGroupItem that has dropdown-list menu. The types are GroupItemType.DropDownListButton and GroupItemType.SplitButton.

ValueType
The javascript function name or javascript anonymous function definition.

Default Value


WebRibbonContextualTabGroup

WebRibbonContextualTabGroup
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebRibbonContextualTabGroup

Glossary Item Box

WebRibbonContextualTabGroup Properties

Name | Description Gets or sets the unique name of the component. Note: Name must be unique among others in the same container. ValueType String Default Value
Text | Description Gets or sets the title that displayed in the contextual tab. ValueType String Default Value
ContextualGroupStyle | Description Gets or sets the color or style of contextual group. ValueType ContextualGroupStyle Default Value ContexttualGroupStyle.LightBlue
RibbonTabs | Description The WebRibbonTab collection used by WebRibbonContextualTabGroup. ValueType Array Default Value
Visible | Description Visible state of the control ValueType Boolean Default Value
Selected | Description Selected state of the control. ValueType Boolean Default Value

WebRibbonContextualTabGroup Methods

Hide Description
Sets to hide WebRibbonContextualTabGroup and all its ribbon contextual-tabs.

Parameters

Remarks

Return Value

Samples

Show Description
Sets to show WebRibbonContextualTabGroup and all its ribbon contextual-tabs.

Parameters
enabled (Boolean)

Remarks

Return Value

Samples

SetContextualGroupStyle Description
Sets contextual group style or color of the WebRibbonContextualTabGroup.

Parameters
style (ContextualGroupStyle)

Remarks

Return Value

Samples

SetText Description
Sets Text property of WebRubbonContextualTabGroup and renders the text of its UI.

Parameters
text (String)

Remarks

Return Value

Samples


WebRibbonGroup

WebRibbonGroup
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebRibbonGroup

Glossary Item Box

WebRibbonGroup Properties

Name | Description Gets or sets the unique name of the component. Note: Name must be unique among otheres in the same container. ValueType String Default Value
Text | Description Gets or sets the title that displyaed in as title of a group. ValueType String Default Value
ImageURL | Description Gets or sets the URL of the image of the group in Collapse state. ValueType String Default Value The value of CommonResources.ImgBlank32 property of WebRibbon.
SizeState | Description Gets the user-defined size state of WebRibbonGroup. ValueType SizeState Default Value SizeState.Large
Items | Description The WebRibbonGroupItem collection used by WebRibbonGroup. ValueType Array Default Value
Enabled | Description Enabled state of the control. ValueType Boolean Default Value
CollapseAllowed | Description Indicate whether or not SizeState.Collapse is allowed in WebRibbonGroup. ValueType Boolean Default Value
HideAllowed | Description Indiate whether or not SizeState.Hide is allowed in WebRibbonGroup. ValueType Boolean Default Value
LogicalSizeState | Description Gets or sets the logical size state of WebRibbonGroupItem depend on CollapseAllowed and HideAllowed properties. ValueType SizeState Default Value

WebRibbon Methods

GetRadioButtonGroup

Description
Gets RadioButtonGroup array thai maintain collection of WebRibbonGroupItem items with GroupItemType.ToggleButton and ToggleButtonMode.RadioButton.

Parameters
groupName (string)

Remarks

Return Value
RadioButtonGroup object

Samples

SetEnabled Description
Sets enabled property of WebRibbonGrouo and its children (group-items) to enable or disable. Also sets the style of itself and child components.

Parameters
enabled (Boolean)

Remarks

Return Value

Samples

SetText Description
Sets Text property of WebRibbonGroup and renders the text of its UI.

Parameters
text (String)

Remarks

Return Value

Samples

SetImageURL Description
Sets ImageURL property of WebRibbonGroup and renders the image to its UI.

Parameters
url (String)

Remarks

Return Value

Samples
SetSizeState Description
Sets SizeState and LogicalSizeState properties of itself and its children (WebRibbonGroupItem). The value of LogicalSizeState depends on HideAllowed and CollapseAllowed properties.

Parameters
selected (Boolean)

Remarks

Return Value

Samples


WebRibbonGroupItem

WebRibbonGroupItem
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebRibbonGroupItem

Glossary Item Box

WebRibbonGroupItem Properties

Name | Description Gets or sets the unique name of the component. Note: Name must be unique among others in the same container. ValueType String Default Value
Text | Description Gets or sets the title of group-item. ValueType String Default Value
ImageURL | Description Gets or sets the URL of the image of the group-item in SizeSateLarge state. ValueType String Default Value The value of CommonResources.ImgBlank32 property of WebRibbon.
SmallImageURL | Description Gets or sets the URL of the image of the group-item in SizeState.Small and SizeState.Medium state. ValueType String Default Value The value of CommonResources.ImgBlank16 property of WebRibbon.
GroupItemType | Description The type of item that determines its model and behavior. ValueType GroupItemType (Button, ToggleButton, DropDownListButton and SplitButton) Default Value GroupItemType.Button
ToggleButtonMode | Description The mode of ToggleButton type. ValueType ToggleButtonMode (CheckBox and RadioButton) Default Value ToggleButtonMode.CheckBox
SplitButtonMode | Description The mode of SplitButton type. ValueType SplitButtonMode (Single and Multiple) Default Value SplitButtonMode.Single
GroupName | Description Gets or sets the group-name of group-item. Note: At the moment this property used by RadioButton item type. ValueType String Default Value
Enabled | Description Enabled state of the control. ValueType Boolean Default Value
Checked | Description Checked state of the group item with GroupItemType.ToggleButton. ValueType Boolean Default Value
SizeState | Description Gets the current size state of WebRibbonGroupItem. Note: This property will follow its LogicalSizeState of parent group. ValueType SizeState Default Value SizeState.Large
MinSizeState | Description Gets or sets the minimium size setate of WebRibbonGroupItem. Note: This property will determine how small the group item will be in SizeState in response to resizing. ValueType SizeState Default Value SizeState.Large
MaxSizeState | Description Gets or sets the maximum size state of WebRibbonGroupItem. Note: This property will determine how big the group item will be in SizeState in response to resizing. ValueType SizeState Default Value SizeState.Large
LogicalSizeState | Description Gets the logical size state of WebRibbonGroupItem depend on MinSizeState and MaxSizeState properties. ValueType SizeState Default Value
MenuItems | Description The WebRibbonMenuItem collection used by WebRibbonGroupItem. Note: This property contains of menu-list item used by DropDownListButton and SplitButton type. ValueType Array Default Value
URL | Description Gets or sets the URL of the browser window when being clicked by the user. Note: If you provide OnGroupItemClick, it must return true to be executed. ValueType String Default Value
OnClientClick | Description Gets or sets function that will be invoked after being clicked by the user. Note: If you provide OnGroupItemClick, it must return true to be executed. This is the second option and will be executed if the URL property is null or empty. ValueType The javascript function name or javascript anonymous function definition. Default Value
OnCheckedChanged | Description Gets or sets function that will be invoked after being Checked property is changed. Note: If you provide OnGroupItemCheckedChanged, it must return true to be executed. ValueType The javascript function name or javascript anonymous function definition. Default Value

WebRibbonGroupItem Methods

SetChecked

Description
Set Checked property of WebRibbonGroupItem to true or false and also sets style of itself.

Note: This apply to GroupItemType.ToggleButton type.

Parameters
Checked (Boolean)

Remarks

Return Value

Samples

SetEnabled Description
Sets enabled property of WebRibbonGroupItem to enable or disable. Also sets the style of itself.

Parameters
enabled (Boolean)

Remarks

Return Value

Samples

SetText Description
Sets Text property of WebRibbonGroupItem and render the text of its UI.

Parameters
text (String)

Remarks

Return Value

Samples

SetImageURL Description
Sets ImageURL property of WebRibbonGroupItem and render the image to its UI.

Parameters
url (String)

Remarks

Return Value

Samples
SetSmallImageURL Description
Sets SmallImageURL property of WebRibbonGroupItem and render the image to its UI.

Parameters
url (String)

Remarks

Return Value

Samples
SetSizeState Description
Sets SizeState and LogicalSizeState properties of itself. The value of LogicalSizeState is depend on MinSizeState and MaxSizeState properties.

Parameters
size (SizeState)

Remarks

Return Value

Samples
ShowMenu

Description
Order group-item button to show its menu.

Note: This apply to GroupItemType.DropDownListButton and GroupItemType.SplitButton types.

Parameters
size (SizeState)

Remarks

Return Value

Samples


WebRibbonMenuItem

WebRibbonMenuItem
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebRibbonMenuItem

Glossary Item Box

WebRibbonMenuItem Properties

Name | Description Gets or sets the unique name of the component. Note: Name must be unique among others in the same container. ValueType String Default Value
Text | Description Gets or sets the title of group-item. ValueType String Default Value
ImageURL | Description Gets or sets the URL of the image of the menu-item. ValueType String Default Value The value of CommonResources.ImgBlank16 property of WebRibbon.
Enabled | Description Enabled state of the control. ValueType Boolean Default Value
URL | Description Gets or sets the URL of the browser window when being clicked by the user. Note: If you provide OnMenuItemClick, it must return true to be executed. ValueType String Default Value
OnClientClick | Description Gets or sets function that will be invoked after being clicked by the user. Note: If you provide OnMenuItemClick, it must return true to be executed. This is the second option and will be executed if the URL property is null or empty. ValueType The javascript function name or javascript anonymous function definition. Default Value


WebRibbonResources

WebRibbonResources
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebRibbonResources

Glossary Item Box

WebRibbonResources Properties

ImgArrow16 | Description Gets or sets the URL of common arrow-16 image for group-item that need arrow image. ValueType String Default Value
ImgWArrow | Description Gets or sets the URL of common white arrow image for app. menu-item that need arrow . ValueType String Default Value
ImgBlank16 | Description Gets or sets the URL of common 16x16 blank image for SmallImageUrl property of group-item. ValueType Boolean Default Value
ImgBlank32 | Description Gets or sets the URL of common 32x32 blank image for SmallImageUrl property of group-item. ValueType Boolean Default Value
ImgBlank | Description Gets or sets the URL of common 16x16 whiteimage for SmallImageUrl property of group-item. ValueType String Default Value


WebRibbonTab

WebRibbonTab
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebRibbonTab

Glossary Item Box

WebRibbonTab Properties

Name | Description Gets or sets the unique name of the component. Note: Name must be unique among others in the same container. ValueType String Default Value
Text | Description Gets or sets the title that displayed in the menu. ValueType String Default Value
Description | Description Gets or sets the description that displayed in the menu. ValueType String Default Value
ContextualGroupName | Description Gets or sets the contextual group name. ValueType String Default Value
ResizingGroupsOrder | Description Gets or sets the order of group resizing by specifying group-name. ValueType String (group-name-1, group-name-2, group-name-n... ) Default Value
Groups | Description The WebRibbonGroup collection used by WebRibbonTab. ValueType Array Default Value
Enabled | Description Enabled state of the control. ValueType Boolean Default Value
Selected | Description Selected state of the control. ValueType Boolean Default Value

WebRibbonTab Methods

SetEnabled

Description
Sets enabled property of WebRibbonTab and its children (groups and group-items) to enable or disable. Also sets the style of itself and child components.

Parameters
enabled (Boolean)

Remarks

Return Value

Samples

SetSelected Description
Sets selected property of WebRiboonTab to true or false. Also sets the styel of itself.

Parameters
selected (Boolean)

Remarks

Return Value

Samples

SetText Description
Sets Text property of WebRibbonTab and render the text of its UI.

Parameters
text (String)

Remarks

Return Value

Samples

SetDescription Description
Sets Description property of WebRibbonTab and render the description of its UI.

Parameters
desc (String)

Remarks

Return Value

Samples


WebSlider How-to Topics

WebSlider How-to Topics
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlider > WebSlider How-to Topics

Glossary Item Box

The topics in this section describe how to achieve common WebSlider tasks.

In This Section

How-to: Set/Change WebSlider Orientation

How-to: Set/Change WebSlider Direction

How-to: Set/Change Item label alignment in WebSlider

How-to: Specify custom WebSlider item

How-to: Enable/Disable range slider

How-to: Customize WebSlider range behavior


WebSlider

WebSlider
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlider

Glossary Item Box

With its fully customizable orientation and slide direction, WebSlider makes it a breeze to add a unique slider input control, tailored precisely to your application’s needs.

Flexible Layout and Behavior Customization

Orientation

WebSlider offers two orientations, horizontal and vertical.

To learn more about Orientation, see How-to: Set/Change WebSlider Orientation.

Direction

WebSlider also offers 4 direction options that work conjunctionally with the orientation setting, for example: if the WebSlider orientation is vertical, the selectable directions are TopToBottom or BottomToTop, and vice versa if the WebSlider orientation is horizontal.

Left-to-Right | Right-to-Left
Top-to-Bottom | Bottom-to-Top

To learn more about Direction, see How-to: Set/Change WebSlider Direction.

Fundamental Settings

Additionally, several properties are required by WebSlider. MinimumValue and MaximumValue are two properties which determine the minimum and maximum value of the slider. Value property holds the current WebSlider's value. StepValue property represents the number of discrete value within the WebSlider's range.

Three Types of WebSlider UI

There are three types of WebSlider that you can choose.

  1. None.
    This is WebSlider's default type.

  2. Tick.
    This type of WebSlider is very similar to a thermometer. It has two discrete values control by StepValue and LargerStepValue properties. StepValue determines the small label, while LargerStepValue determines the larger label with text.

  3. Item.
    This type enables more advanced customization on WebSlider. Once activated, the WebSlider's items are defined by item collection property. Please refer to Custom WebSlider item section for complete information.

Item Alignment

SliderLabelAlignment property controls the item's positioning. This property is only applicable when the WebSlider type is tick or item. There are three options available:

Left | Right

To learn more about Item label alignment, see How-to: Set/Change Item label alignment in WebSlider.

Custom WebSlider Item

To create a custom item in WebSlider, you need to specify all items in Items collection property and remember to set the SliderType to item.

Properties that need to be specified:

  • MinimumValue and MaximumValue
  • The Item's value
  • WebSlider's value

A simple sample of the implementation is to create a level selector in slider style. Here is what you need to set:

  • Newbie level
    Value = 1

  • Easy
    Value = 2

  • Normal
    Value = 3

  • Hard
    Value = 4

  • Advanced
    Value = 5

The MinimumValue is 1 and the MaximumValue is 5. WebSlider's Value is set to 3, making the "Normal" level as the default selection.

To learn more about custom WebSlider item, see How-to: Specify custom WebSlider item.

Supports Range Slider

Range Slider is a unique feature for selecting a range of value, instead of a single value. Set EnableRange to true and you will see two handles in WebSlider.

The value for both handles is determined by StartValue and EndValue properties.

To learn more about range slider, see How-to: Enable/Disable range slider.

Customizable Range Slider Behavior

Two unique interaction modes are provided.

  1. Locked
    This mode basically prevents a slider to exceed the other one. For example: Handle1 is 10 and Handle2 is 80. Users won't be able to slide Handle1 exceeding Handle2 and vice versa.

  2. Push
    Push behavior is similar to Locked mode, except it pushes the other handle as users move the handle exceeding the other one. Taking the above sample, if users click and slide Handle1 to exceed Handle2, Handle2 will be pushed as Handle1 exceeds Handle2's value.

To learn more about WebSlider range behavior, see How-to: Customize WebSlider range behavior.

XHTML Compliance

WebSlider is designed to fully comply with W3C's XHTML standard - providing identical rendering when running in different modern XHTML-ready browsers.

Appearances and Styles

Default Styles

WebSlider offers 4 predefined styles:

DefaultBlue | DefaultBlack
MinimalistBlue | MinimalistSilver

Comprehensive Client-side Events

  • OnInitialize(controlId)
    This client-side event is triggered when WebSlider is initialized.

  • OnBeforeValueChanged(controlId)
    This client-side event is triggered before WebSlider performs value changed.

  • OnBeforeSliding(controlId)
    This client-side event is triggered before WebSlider performs sliding.

  • OnSliding(controlId)
    This client-side event is triggered when WebSlider performs sliding.

  • OnAfterSliding(controlId)
    This client-side event is triggered after WebSlider performs sliding.

  • OnValueChanged(controlId, oldValue, newValue)
    This client-side event is triggered when WebSlider's value is being changed.

Rich Client-side APIs

Methods | Description
GetElement() | Obtain WebSlider's element.
GetContainer() | Obtain WebSlider's container element.
GetLeftPointer() | Obtain WebSlider's Left Pointer.
GetRightPointer() | Obtain WebSlider's Right Pointer.
GetSliderLabelElement() | Obtain WebSlider's label element.
GetDragPanelContainer() | Obtain WebSlider's drag panel container.
GetDragElement() | Obtain the element of WebSlider's first handle.
GetSecondDragElement() | Obtain the element of WebSlider's second handle.
SetValue (value, isSecondThumb) | Set WebSlider's value.
GetValue(isSecondThumb) | Obtain WebSlider's value.
GetItemText(value[optional]) | Obtain custom item's text by value.


WebSlider

WebSlider
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebSlider

Glossary Item Box

WebSlider Properties

ScriptDirectory | Description Gets or sets the directory where all required scripts for the control are stored. ValueType Default Value
ImagesDirectory | Description Gets or sets the images directory. ValueType Default Value
ViewStateStorage | Description Gets or sets the location to store the viewstate of this control. ValueType Default Value
AccessKey | Description Keyboard shortcut used by the control. ValueType Default Value
Enabled | Description Enabled state of the control. ValueType Default Value
TabIndex | Description The tab order of the control. ValueType Default Value
ToolTip | Description The tooltip displayed when the mouse is over the control. ValueType Default Value
ID | Description Programmatic name of the control. ValueType Default Value
Height | Description The height of the control. ValueType Default Value
Width | Description The width of the control. ValueType Default Value
DefaultStyleMode | Description Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled. ValueType Default Value
AllowDefaultStyleMerging | Description Gets or sets the value that determines whether the default style can be merged with custom styles. ValueType Default Value
UseDefaultStyle | Description Determines whether WebSlider is using default style. ValueType Default Value
UseCustomImages | Description Gets or sets the value that determines whether WebSlider use images specified by user. ValueType Default Value
ShowValueInTooltip | Description Determines whether WebSlider value appear in tooltip. ValueType Default Value
ShowSliderRail | Description Determines whether WebSlider rail is shown. ValueType Default Value
Value | Description Specifies the value of WebSlider. ValueType Default Value
StepValue | Description Specifies the step value of WebSlider. ValueType Default Value
LargeStepValue | Description Specifies the large step value of WebSlider. ValueType Default Value
MinimumValue | Description Specifies the start value of WebSlider. ValueType Default Value
MaximumValue | Description Specifies the end value of WebSlider. ValueType Default Value
StartValue | Description Specifies the start range value of WebSlider. ValueType Default Value
EndValue | Description Specifies the end range value of WebSlider. ValueType Default Value
Orientation | Description Specifies WebSlider orientation. ValueType Default Value
Direction | Description Specifies WebSlider direction. ValueType Default Value
EnableRange | Description Determines whether range value should be enabled in WebSlider. ValueType Default Value
SliderLabelAlignment | Description Specifies slider step value alignment. ValueType Default Value
ThumbsInteractionMode | Description Determines thumbs interaction mode of WebSlider. ValueType Default Value
SliderType | Description Determines type of WebSlider. ValueType Default Value
Items | Description The item collection used by WebSlider. ValueType Default Value
ImagesSettings | Description Provides the settings that control the images in WebSlider. ValueType Default Value
ClientSideEvents | Description Contains client side events supported by WebSlider. ValueType Default Value

WebSlider Methods

GetElement Description
Gets WebSlider's element.

Parameters

Remarks

Return Value

Samples

GetContainer Description
Gets WebSlider's container element.

Parameters

Remarks

Return Value

Samples

GetLeftPointer Description
Gets WebSlider's Left Pointer.

Parameters

Remarks

Return Value

Samples

GetRightPointer Description
Gets WebSlider's Right Pointer.

Parameters

Remarks

Return Value

Samples

GetSliderLableElement Description
Gets WebSlider's label element.

Parameters

Remarks

Return Value

Samples

GetDragPanelContainer Description
Gets WebSlider's drag panel container.

Parameters

Remarks

Return Value

Samples

GetDragElement Description
Gets the element of WebSlider's first handle.

Parameters

Remarks

Return Value

Samples

GetSecondDragElement Description
Gets the element of WebSlider's second handle.

Parameters

Remarks

Return Value

Samples

SetValue Description
Sets WebSlider's value.

Parameters
value ( )
isSecondThumb ( )

Remarks

Return Value

Samples

GetValue Description
Gets WebSlider's value.

Parameters
isSecondThumb ( )

Remarks

Return Value

Samples

GetItemText Description
Gets custom item's text by value.

Parameters
value ( )

Remarks

Return Value

Samples


WebSliderClientSideEvents

WebSliderClientSideEvents
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebSliderClientSideEvents

Glossary Item Box

WebSliderClientSideEvents Properties

OnInitialize | Description Gets or sets the event handler when WebSlider is initialized. Parameters controlId Default Value -
OnBeforeValueChanged | Description Gets or sets the event handler before WebSlider performs value changed. Parameters controlId Default Value -
OnBeforeSliding | Description Gets or sets the event handler before WebSlider performs sliding. Parameters controlId Default Value -
OnSliding | Description Gets or sets the event handler when WebSlider performs sliding. Parameters controlId Default Value -
OnAfterSliding | Description Gets or sets the event handler after WebSlider performs sliding. Parameters controlId Default Value -
OnValueChanged | Description Gets or sets the event handler when WebSlider's value is being changed. Parameters controlId, oldValue, newValue Default Value -


WebSliderImagesSettings

WebSliderImagesSettings
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebSliderImagesSettings

Glossary Item Box

WebSliderImagesSettings Properties

LeftPointer | Description Sets the left pointer image of WebSlider. ValueType Default Value
LeftPointerHover | Description Sets left pointer hover image of WebSlider. ValueType Default Value
LeftPointerPress | Description Sets the left pointer press image of WebSlider. ValueType Default Value
RightPointer | Description Sets the right pointer image of WebSlider. ValueType Default Value
RightPointerHover | Description Sets the right pointer hover image of WebSlider. ValueType Default Value
RightPointerPress | Description Sets the right pointer press image of WebSlider. ValueType Default Value
HorizontalMiddle | Description Sets the middle image of horizontal WebSlider. ValueType Default Value
HorizontalMiddleFill | Description Sets the middle fill image of horizontal WebSlider. ValueType Default Value
UpSlider | Description Sets the up slider images of WebSlider. ValueType Default Value
UpSliderHover | Description Sets the up slider image of WebSlider when mouse over. ValueType Default Value
UpSliderPress | Description Sets the up slider image of WebSlider when pressed. ValueType Default Value
DownSlider | Description Sets the down slider image of WebSlider. ValueType Default Value
DownSliderHover | Description Sets the down slider image of WebSlider when mouse ValueType Default Value
DownSliderPress | Description Sets the slider image of WebSlider when pressed. ValueType Default Value
UpPointer | Description Sets the up pointer image of WebSlider. ValueType Default Value
UpPointerHover | Description Sets the up pointer hover image of WebSlider. ValueType Default Value
UpPointerPress | Description Sets the up pointer press image of WebSlider. ValueType Default Value
DownPointer | Description Sets the down pointer image of WebSlider. ValueType Default Value
DownPointerHover | Description Sets the down pointer hover image of WebSlider. ValueType Default Value
DownPointerPress | Description Sets the down pointer press image of WebSlider. ValueType Default Value
VerticalMiddle | Description Sets the middle image of vertical WebSlider. ValueType Default Value
VerticalMiddleFill | Description Sets the middle fill image of vertical WebSlider. ValueType Default Value
LeftSlider | Description Sets the left slider image of WebSlider. ValueType Default Value
LeftSliderHover | Description Sets the left slider image of WebSlider when mouse over. ValueType Default Value
LeftSliderPress | Description Sets the left slider image of WebSlider when pressed. ValueType Default Value
RightSlider | Description Sets the right slider image of WebSlider. ValueType Default Value
RightSliderHover | Description Sets the right slider image of WebSlider when mouse over. ValueType Default Value
RightSliderPress | Description Sets the right slider image of WebSlider when pressed. ValueType Default Value
ItemInfoLine | Description Sets the item info line image of WebSlider. ValueType Default Value
SmallInfoLine | Description Sets the small info line image of WebSlider. ValueType Default Value
LargeInfoLine | Description Sets the large info line image of WebSlider. ValueType Default Value
VerticalItemInfoLine | Description Sets the vertical item info line image of WebSlider. ValueType Default Value
VerticalSmallInfoLine | Description Sets the vertical small info line image of WebSlider. ValueType Default Value
VerticalLargeInfoLine | Description Sets the vertical large info line image of WebSlider. ValueType Default Value


WebSlidingMenuItem

WebSlidingMenuItem
Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem

Glossary Item Box

Easily build sophisticated hierarchical navigation systems with WebSlidingMenu. Featuring an ultra-cool sliding animation effect, this powerful component can host virtually unlimited items in the most complex structures. Its advanced Load-on-Demand technology provides high performance with minimal overhead by intelligently requesting items just before your users need them.

Navigation

Supporting its innate nature as a navigation control, WebSlidingMenu offers comprehensive navigation-related features and properties. It enables a clicked item to be opened in a specific URL in a new window or target IFrame. The target window can be specified in LayoutSettings >> TargetWindow property or [item] >> TargetWindow property for individual item. The target URL can be specified in [item] >> TargetURL property.

To learn more about nagivation, see How-to: Configure navigation in WebSlidingMenu.

XHTML Compliance

WebSlidingMenu is designed to fully comply with W3C's XHTML standard - providing identical rendering when running in various modern XHTML-ready browsers.

Default Styles

WebSlidingMenu offers 4 different styles for quick application. Use the DefaultStyleMode property to switch to the one that suit your need the most.

WebSlidingMenu with standard style.

WebSlidingMenu with black style.

WebSlidingMenu with officeblack style.

WebSlidingMenu with Silverstyle.

Advanced Layout Customization

Header Style
Use this setting to customize WebSlidingMenu's header.

Item Style
Use this setting to customize WebSlidingMenu's item style, including normal, active, and hover style.

Alternate Item Style
AlternateItemStyle provides same setting as the ItemStyle, but applied to alternating item.

Next Indicator Style
Use this setting to customize the next indicator style.

Frame Style
Use this setting to customize the frame style.

Powerful Load-on-Demand

Enterprise users demand superior user experience. WebSlidingMenu's innovative Load-on-Demand is designed to cater this specific need by loading the child's content on every request. This mechanism delivers lightweight rendering regardless of how huge and complex the data is. Set the LoadOnDemand property to true to enjoy this amazing feature. This feature will be used in unbound mode and not in bound mode. Since LoadOnDemand request new data coinciding to the selected item, you need to implement the content retrieval logic on InitializeItem server-side event.

C# Copy Code
protected void WebSlidingMenu1_InitializeItem(object sender, ISNet.WebUI.WebEssentials.WebSlidingMenuEventDataArgs e)
{
        if (e.Action == "InitializeChild")
        {
            WebSlidingMenuItemCollection itemCol = new WebSlidingMenuItemCollection();
            string studentID = e.SelectedItemName;
            switch (studentID)
            {
                case "1":
                    WebSlidingMenuItem item = new WebSlidingMenuItem();
                    item.Text = studentID + "Child";
                    item.Name = studentID + "Child";

                    item.ContentMode = WebSlidingMenuContentMode.Inline;
                    item.AutoHeight = true;
                    item.ContentTemplate = new MyTemplate(Page, studentID);

                    itemCol.Add(item);
                    break;

                case "2":
                    WebSlidingMenuItem item2 = new WebSlidingMenuItem();
                    item2.Text = studentID + "Child";
                    item2.Name = studentID + "Child";

                    item2.ContentMode = WebSlidingMenuContentMode.Inline;
                    item2.AutoHeight = true;
                    item2.ContentTemplate = new MyTemplate(Page, studentID);

                    itemCol.Add(item2);
                    break;
            }
            e.NewItemsObject = itemCol;
        }
}

To learn more about LoadOnDemand, see How-to: Use LoadOnDemand to retrieve parent and child in WebSlidingMenu.

Set Initial Level by Path

SetInitialLevelByPath is a special server-side method for defining the path level initially. You must put the correct path using the item's name and WebSlidingMenu will automatically map it according to your custom path.

C# Copy Image Copy Code
protected void Page_Load(object sender, EventArgs e)
{
   WebSlidingMenu1.SetInitialLevelByPath("Books/Biography");
}

Comprehensive Client-side Events

Methods | Description
OnInitialize() | Invokes during the control initialization process.
OnItemClick() | Invokes when an item is clicked.
OnPreviousButtonClicked() | Invokes when the previous button is clicked.
OnResponse() | Invokes when a response is returned after a FlyPostBack action.


WebSlidingMenu

WebSlidingMenu
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebSlidingMenu

Glossary Item Box

WebSlidingMenu Properties

ScriptDirectory | Description Gets or sets the directory where all required scripts for the control are stored. ValueType Default Value
ImagesDirectory | Description Gets or sets the images directory for ImageSetings. ValueType Default Value
ViewStateStorage | Description Gets or sets the location to store the viewstate of this control. ValueType Default Value
AccessKey | Description Keyboard shorcut used by the control. ValueType Default Value
Enabled | Description Enabled state of the control. ValueType Default Value
TabIndex | Description The tab order of the control. ValueType Default Value
ToolTip | Description The tooltip displayed when mouse is over the control. ValueType Default Value
ID | Description Programmatic name of the control. ValueType Default Value
Width | Description The width of the control. ValueType Default Value
Height | Description The height of the control. ValueType Default Value
Caption | Description Gets or sets the caption for WebSlidingMenu. ValueType Default Value
DefaultStyleMode | Description Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled. ValueType Default Value
AllowDefaultStyleMerging | Description Gets or sets the value that determines whether default style can be merged with custom styles. ValueType Default Value
LoadOnDemand | Description Gets or sets the value that determines whether the WebSlidingMenu is using load on demand. ValueType Default Value
DataSourceID | Description Gets or sets the WebSlidingMenu DataSourceID. ValueType Default Value
Items | Description The item collection of WebSlidingMenuItem. ValueType Default Value
Levels | Description The level collection of WebSlidingMenuLevel. ValueType Default Value
LayoutSettings | Description Provides the settings that control the behaviors of the layout in WebSlidingMenu. ValueType Default Value
TextSettings | Description Provides the settings that control the text in WebSlidingMenu. ValueType Default Value
ImagesSettings | Description Provides the settings that control the images in WebSlidingMenu. ValueType Default Value
ClientSideEvents | Description Contains client side events supported by WebSlidingMenu. ValueType Default Value
EnableLoaderIndicator | Description Determines whether loader indicator appear when WebSlidingMenu performing load on demand. ValueType Default Value

WebSlidingMenu Methods

GetElement Description
Gets the element of WebSlidingMenu.

Parameters

Remarks

Return Value

Samples

GetContentFrameElement Description
Gets the element of WebSlidingMenu's Frame.

Parameters

Remarks

Return Value

Samples

GetHeaderElement Description
Gets the element of WebSlidingMenu's header.

Parameters

Remarks

Return Value

Samples

GetCaptionHeaderElement Description
Gets the element of WebSlidingMenu's header caption.

Parameters

Remarks

Return Value

Samples

GetImageCaptionHeaderElement Description
Gets the element of WebSlidingMenu's previous button image.

Parameters

Remarks

Return Value

Samples

GetMainContainerElement Description
Gets the element of WebSlidingMenu's main container.

Parameters

Remarks

Return Value

Samples

GetMainItemContainerElement Description
Gets the element of WebSlidingMenu's main item container.

Parameters

Remarks

Return Value

Samples

GetItemContainerElement Description
Gets the element of WebSlidingMenu's item container.

Parameters

Remarks

Return Value

Samples

GetItemByElement Description
Gets the item object based on the item's element.

Parameters
el ( )

Remarks

Return Value

Samples

GetItemByName Description
Gets the item object based on the item's name.

Parameters
itemName ( )

Remarks

Return Value

Samples

GetItemByPath Description
Gets the item object based on the item's path.

Parameters
path ( )

Remarks

Return Value

Samples

MoveToPreviousPage Description
Sets the WebSlidingMenu back to previous level.

Parameters

Remarks

Return Value

Samples

Refresh Description
Sets the refresh action to the WebSlidingMenu.

Parameters

Remarks

Return Value

Samples


Understanding WebSlidingMenu User Interface

Understanding WebSlidingMenu User Interface
See Also Send comments on this topic.
Intersoft WebEssentials > WebEssentials Overview > WebSlidingMenuItem > Understanding WebSlidingMenu User Interface

Glossary Item Box

WebSlidingMenu provides various customizations on the user interface aspect through its comprehensive properties. The customization can be made globally (specified inside LayoutSettings property) or individually depending on your requirement.

  • Item Height
  • Header Height
  • Show Loader
  • Next Indicator
  • Previous Button
  • Item Style

Item Height

The most fundamental setting in WebSlidingMenu is the ability to set the item's height. Use LayoutSettings >> ItemHeight property for global application. Or, use [Item] >> ItemHeight property to set individual item height. By default, the height is 30 pixels.

To learn more about item's height, see How-to: Customize Item Height.

Header Height

Similar to the item's height, the content height can be customized as well. Use the LayoutSettings >> HeaderHeight property to apply this globally or [Level] >> HeaderHeight property to set individual header height. By default, the height is 30 pixels.

To learn more about Header's height, see How-to: Customize Header Height.

Show Loader

When Load-on-Demand feature is enabled, a loader will automatically be shown every time an item is loaded. Using the ShowLoader properties, you can show or hide the loader.

Next Indicator

The next indicator is a visual hint indicating that an item has children. The indicator can be disabled using ShowNextIndicator property, located inside the LayoutSettings group. The default value is true.

To learn more about Next indicator, see How-ro: Show/Hide item next indicator.

Previous Button

While the next indicator is used to navigate to the child items, previous button enables user to navigate to the parent item. By default, this button is visible. You can hide it via ShowPreviousIndicator property and set it to false.

To learn more about Previous indicator, see How-to: Show/Hide item previous indicator.

Item Style

WebSlidingMenu provides a wide selection of built-in themes that you can pick. Additionally, you can also use your custom CSS class for better customization.

To learn more about Item styles, see How-to: Specify Custom Item Styles.

See Also

Other Resources
{Various Item's Content Mode}
{Navigation}
{WebSlidingMenuLevel}


WebSlidingMenuClientSideEvents

WebSlidingMenuClientSideEvents
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebSlidingMenuClientSideEvents

Glossary Item Box

WebSlidingMenuClientSideEvents Properties

OnInitialize | Description Invokes during the control initialization process. ValueType Default Value
OnItemClick | Description Invokes when an item is clicked. ValueType Default Value
OnPreviousButtonClick | Description Invokes when the previous button is clicked. ValueType Default Value
OnResponse | Description Invokes when a response is returned after a FlyPostBack action. ValueType Default Value


WebSlidingMenuImagesSettings

WebSlidingMenuImagesSettings
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebSlidingMenuImagesSettings

Glossary Item Box

WebSlidingMenuImagesSettings Properties

PreviousButton | Description Gets or sets the default image used for previous button. ValueType Default Value
NextIndicator | Description Gets or sets the default image used for bottom scroller. ValueType Default Value
InProgressIndicator | Description Gets or sets the default image used for progress indicator. ValueType Default Value


WebSlidingMenuItem

WebSlidingMenuItem
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebSlidingMenuItem

Glossary Item Box

WebSlidingMenuItem Properties

Name | Description Specifies the name of the item. ValueType Default Value
Value | Description Gets or sets the item's value. ValueType Default Value
Text | Description Gets or sets the item's text. ValueType Default Value
ItemHeight | Description Gets or sets the item's height. ValueType Default Value
AutoHeight | Description Gets or sets the value that determines whether or not an item is auto height. ValueType Default Value
Enabled | Description Gets or sets the value that determines whether or not an item is enabled. ValueType Default Value
CustomRules | Description Gets or sets the custom styles applied to item. ValueType Default Value
ContentURL | Description Specifies the content url of WebSlidingMenu's item. ValueType Default Value
ToolTip | Description Gets or sets the tooltip item. ValueType Default Value
Tag | Description Gets or sets tag of an item. ValueType Default Value
Visible | Description Gets or sets the value that determines whether an item is visible. ValueType Default Value
ParentMenu | Description Gets the WebSlidingMenuItem object parent of this menu. ValueType Default Value
TargetURL | Description Gets or sets the target url when item is selected. ValueType Default Value
TargetWindow | Description Gets or sets the target window when item is selected. ValueType Default Value
ContentMode | Description Specifies the container mode of WebSlidingMenu's item. ValueType Default Value
Items | Description The item collection of WebSlidingMenuItem. ValueType Default Value

WebSlidingMenutItem Methods

GetElement Description
Gets the element of WebSlidingMenuItem.

Parameters

Remarks

Return Value

Samples

GetItemElement Description
Gets the item element of WebSlidingMenuItem.

Parameters

Remarks

Return Value

Samples

GetSlidingMenuObject Description
Gets WebSlidingMenu object.

Parameters

Remarks

Return Value

Samples

GetLevel Description
Gets WebSlidingMenuLevel where the item is located.

Parameters

Remarks

Return Value

Samples

GetPath Description
Gets WebSlidingMenuItem's path.

Parameters

Remarks

Return Value

Samples


WebSlidingMenuLayoutSettings

WebSlidingMenuLayoutSettings
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebSlidingMenuLayoutSettings

Glossary Item Box

WebSlidingMenuLayoutSettings Properties

ItemHeight | Description Gets or sets the value that determines the height of an item. ValueType Default Value
HeaderHeight | Description Gets or sets the value that determines the height of header ValueType Default Value
ShowPreviousIndicator | Description Gets or sets the value that determines whether PreviousIndicator is displayed. ValueType Default Value
ShowNextIndicator | Description Gets or sets the value that determines whether show next indicator is displayed. ValueType Default Value
ShowLoader | Description Gets or sets the value that determines whether load is displayed. ValueType Default Value
TargetWindow | Description Gets or sets the value that determines the global target window when items are clicked. ValueType Default Value


WebSlidingMenuLevel

WebSlidingMenuLevel
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebSlidingMenuLevel

Glossary Item Box

WebSlidingMenuLevel Properties

Name | Description Specifies the name of the Header. ValueType Default Value
HeaderText | Description Gets or sets the header's text. ValueType Default Value
HeaderToolTip | Description Gets or sets the header's tooltip. ValueType Default Value
HeaderHeight | Description Gets or sets the header's height. ValueType Default Value
Level | Description Gets or sets the header's level. ValueType Default Value
AutoHeight | Description Gets or sets the value that determines whether or not all item in the level use auto height. ValueType Default Value
EnableDynamicStyle | Description Gets or sets the value that determines whether or not a level use dynamic style or not. ValueType Default Value
ItemContentMode | Description Specifies the container mode of WebSlidingMenu's items. ValueType Default Value

WebSlidingMenuLevel Methods

GetElement Description
Gets the element of WebSlidingMenuLevel.

Parameters

Remarks

Return Value

Samples


WebSlidingMenuTextSettings

WebSlidingMenuTextSettings
Send comments on this topic.
Intersoft WebEssentials > Client-side References > WebSlidingMenuTextSettings

Glossary Item Box

WebSlidingMenuTextSettings Properties

PreviousButtonToolTip Description
Specifies the text of previous button tooltip.

ValueType

Default Value


What's New

What's New
Send comments on this topic.

Glossary Item Box


What's New in WebEssentials V3

What's New in WebEssentials V3
Send comments on this topic.
Intersoft WebEssentials > What's New in WebEssentials V3

Glossary Item Box

This section describes the new features and technologies added in WebEssentials 3.0. Here are the following lists of new features supported by WebEssentials 3.0:

Support HTML5 and CSS3

WebEssentials has been refined to fully support the latest web standards. This allows you to use many of the WebEssentials features in your next-generation web applications and at the same time leveraging cutting-edge technologies such as HTML5 and CSS3.

  • To learn how to enable HTML5 rendering mode in WebEssentials, see How to: Enable HTML5 Rendering Mode.

Metro-Style Visual Theme

Designed from the ground up by Intersoft artist, WebEssentials now is preloaded with the new dazzling metro style.

Thanks to WebEssentials’s DefaultStyle – architecture, applying the new theme can be done as easy as one property set. The new theme is available as new options in DefaultStyleMode property in the WebEssentials control.

The new theme is designed with flat, clean, minimalistic, and typography-focused concept. All elements in WebEssentials besides callout and floating toolbar will be adjusted to use the selected style mode.

WebAccordion with blue, green, orange, and purple metro style.

WebCalendar with blue, green, orange, and purple metro style.

WebListBox with blue, orange, red, purple, and green metro style.

WebProgressBar with red, orange, and green metro style.

WebRating with purple, red, blue, and orange metro style.

WebRibbon using metro style as the default style mode.

WebSlider with orange, green, and red metro style.

WebExpander with blue, green, orange, and purple metro style.

WebSlidingMenu with blue, orange, and purple metro style.

In order to apply the new theme, select one of the pre-defined ascending-sorted metro theme in DefaultStyleMode property.

WebListBox with Horizontal Orientation

As a part of WebEssentials family, WebListBox is a unique control which can be used as an input control or a navigation control. It contains a list of items displayed vertically and users can select single or multiple items.
WebListBox now supports horizontal orientation which allows you show items horizontally.